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Preface 
 
This guide provides a detailed description of how to use 4MCAD, the professional CAD alternative, 
that ensures 100% DWG file compatibility (opendwg), similar environment and functionality, as well 
as full support for AutoCAD® commands, menus, scripts, styles, patterns etc. 
The 4MCAD program is available in four versions: 
 

 4MCAD Viewer: CAD Viewing & Printing plus adding texts & dimensions. 

 4MCAD Classic: 2D/3D CAD Complete Design. 

 4MCAD Standard: 4MCAD Classic + Raster-Image + Rendering. 

 4MCAD Professional: 4MCAD Standard + 3D Solids + BIM files + PDF to DWG +  
VBA\VLISP support + Library Manager. 

 
This user’s guide covers of all the four 4MCAD versions. More specifically, it shows the user how 
to proceed with the installation first and then how to start working on a new drawing, using the 
drawing settings (i.e. paper size, scale factors, text height etc) and the drawing aids (entity snaps, 
orthogonal mode etc). This guide also provides general guidelines about the way of working with 
simple entities such as lines, circles and arcs, as well as with complex entities such as polygons 
and spline curves. Other important aspects, such as moving around in the drawing, working with 
coordinate systems and printing existing drawings, are also described in detail. All these are just a 
few of the many features that are included within 4MCAD, which is designed for anyone who wants 
a fast and efficient CAD program with all the power and versatility of the most advanced CAD 
applications such as AutoCAD®. 
Despite its numerous capabilities, 4MCAD has been designed in order to be easy to learn even by 
novice users. The aim of this Guide is to provide easy-to-follow step-by-step instructions on how to 
get familiar with 4MCAD at the shortest time possible.  
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Introduction 
 

Using 4MCAD is part of an integrated documentation set that 

includes this manual and a comprehensive collection of help 

resources to give you the information you need to create 

drawings in 4MCAD®. 
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About 4MCAD and other CAD software. This manual is organized into chapters that 

parallel how you work in 4MCAD, according to the tasks you might perform. The 

tasks are divided and organized into the following work-focused chapters: 

Introduction: Chapter 1 An overview of the key features of 4MCAD plus basic con- 

cepts of computer-aided design (CAD) as they apply to 4MCAD. 

Getting started: Chapter 2 Installing 4MCAD, starting and exiting 4MCAD, working 

with toolbars, and selecting commands. 

Working with drawings: Chapter 3 Opening and saving an existing drawing and start- 

ing a new drawing. Using drawing settings to establish paper size, scale factors, and 

text height. Working with colors in your drawings. Using drawing aids such as entity 

snaps and orthogonal mode to draw accurately. 

Creating entities: Chapters 4–5 Working with simple entities such as lines, circles, and 

arcs and with complex entities such as polygons, spline curves, planes, wipeouts, 

boundary hatches, and more. 

Viewing your drawing: Chapter 6 Moving around in the drawing, changing its magnifi- 

cation, creating multiple views, and saving arrangements of windows of the drawing. 

Working with coordinates: Chapter 7 Working with Cartesian coordinate systems, 

specifying two-dimensional and three-dimensional coordinates, and defining your 

own user coordinate systems. 

Working with the 4MCAD Explorer: Chapter 8 Using the 4MCAD Explorer to man- age 

your drawings: controlling layers, linetypes, text styles, coordinate systems, views, 

and blocks and copying information between drawings. 

Getting drawing information: Chapter 9 Working with the additional information in 

4MCAD drawings, calculating areas and distances, and displaying other drawing 

information. 

Modifying entities: Chapter 10 Selecting, copying, rearranging, resizing, and editing 

entities. 

Annotating and dimensioning your drawing: Chapters 11–12 Using text to annotate 

drawings; using dimensions to annotate the measurement of entities. 

Working with blocks, attributes, and external references: Chapter 13 Using blocks and 

external references to combine entities and data for reuse; creating attribute informa- 

tion to extract for use in other programs. 

Formatting and printing drawings: Chapter 14 Combining drawings into finished lay- 

outs, customizing print options, and printing copies. 

Drawing in three dimensions: Chapter 15 Creating and editing three-dimensional enti- 

ties. And visualizing them using hidden line removal, shading, and photo-realistic 

rendering. 

Working with other programs: Chapter 16 Sharing drawings and data with other users, 

documents, and programs. 
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Customizing 4MCAD: Chapter 17 Customizing the appearance and operation of the 

program to suit your needs. 

Understanding AutoCAD compatibility: Appendix Describes similarities and differences 

between 4MCAD and AutoCAD. 

This section introduces you to 4MCAD®, its features, and its comprehensive capa- 

bilities for creating drawings of various types. 

 
 

 

About 4MCAD and other CAD software 
 

4MCAD is designed for anyone who wants a fast and efficient CAD program with 

all the power and versatility of standard programs such as AutoCAD® by Autodesk®, 

Inc., or MicroStation® by Bentley Systems, Inc., at an affordable price. Using today’s 

advanced technology, 4MCAD integrates the Microsoft® Windows® interface with a 

powerful CAD engine. 

4MCAD provides unparalleled compatibility with AutoCAD, using most of the same 

file formats including those for drawings (.dwg files), commands, linetypes, hatch 

patterns, and text styles. You can also use AutoCAD menu files and run Autodesk® 

AutoLISP® programs. If you have written your own ADS (Autodesk® AutoCAD 

Development System®) programs, simply recompile them to link with the 4MCAD 

libraries. Many third-party ADS programs already support 4MCAD. If you have a 

program that is not already supported, ask your software vendor to pro- vide an 

4MCAD-compatible version of the program. 

4MCAD is more compatible with the AutoCAD program than any other CAD 

product, delivers additional tools with advanced CAD features, and has a seamless 

Microsoft® Windows integration. This powerful program provides a superb combina- 

tion of features for CAD users like architects, engineers, and designers. 

4MCAD incorporates standard features found in other CAD programs, along with 

features and capabilities you won’t find anywhere else. Its multiple-document inter- 

face (MDI) lets you open and work with several drawings at the same time. You can 

easily copy drawing entities between drawings. In addition, the powerful 4MCAD 

Explorer lets you manage information and settings and quickly copy layers, linetypes, 

and other information between drawings. 

 

Using AutoCAD legacy drawings 
4MCAD fully supports AutoCAD legacy drawings. 4MCAD reads and writes 

.dwg files in their native format without any loss of data, from AutoCAD 2007 back 

to Version 11, including AutoCAD LT®. Because 4MCAD uses Autodesk 

DWGformat as its native file format, no translation is required. 



4 C H A P T E R   1 
 

 

4MCAD provides you with the appropriate tools for your experience level— 

whether you are a beginner, intermediate, or advanced CAD user. If you are just start- 

ing out with CAD, you may want to use the beginner level, which provides toolbars 

containing the basic tools such as lines, arcs, and circles. As you become more expe- 

rienced, you can move to the intermediate level and then to the advanced level, which 

gives you access to more than 300 commands through toolbars, menus, and keyboard 

entries. You can change the experience level in the Options dialog box on the Tools 

menu. 

4MCAD supports three-dimensional wireframes and surfaces. Three-dimensional 

drawings can be displayed in wireframe, hidden-line view, and surface shading. 

Some versions of 4MCAD also support creating and editing 3D solids; all versions 

display 3D solids, along with limited editing features. 

Some versions of 4MCAD support displaying and working with raster images in 

your drawings. However, 4MCAD does not display images located inside of blocks 

and externally referenced drawings (xrefs). When a drawing containing proxy 

entities is loaded into 4MCAD, a message displays indicating that some entities will 

not display, however, the entities reappear when you open the drawing later in 

AutoCAD. 

It’s easy to customize 4MCAD. You can modify menus and toolbars, create custom 

menus, dialog boxes, command aliases, and scripts, and add custom programs 

written in any of several programming languages, including DRX (the program’s 

Autodesk® ARX-compatible language), LISP (the program’s Autodesk AutoLISP- 

compatible language), and SDS™ (Solutions Development System™, the program’s 

Autodesk ADS-compatible language). There is also Microsoft® Visual Basic for 

Applications (VBA). 

You can run existing Autodesk® AutoLISP applications in 4MCAD with little or no 

modification. 4MCAD uses the Appload command so you can easily load LISP 

programs. 4MCAD reads files that contain dialog control language (DCL) state- 

ments as well, which makes 4MCAD compatible with dialog boxes created for 

AutoCAD. 

 

Using AutoCAD commands with 4MCAD 
Because 4MCAD supports hundreds of AutoCAD commands, you use the com- 

mands you already know. For example, to draw a circle, use the Circle command. To 

copy a circle, use the Copy command. 

When you press Enter or the spacebar, you activate the command—just like in Auto- 

CAD. 4MCAD accepts the special characters used by AutoCAD, such as point fil- 

ters (for example, .xy), relative coordinates (the @ symbol), and the apostrophe (the ‘ 

prefix) for transparent commands. 4MCAD function keys are also similar to those 

used in AutoCAD. 

Because you do not need to learn a new set of commands, you are immediately pro- 

ductive with 4MCAD. 
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Comparing 4MCAD and CAD to manual drafting 
 

4MCAD greatly reduces the time and effort it takes to create and revise drawings. 

Not only can you produce accurate drawings faster, you can also reuse the informa- 

tion in your drawings. These are the primary reasons for making the transition to 

CAD from traditional, manual drafting on paper. 

As with any tool, however, to use it effectively, you need to be familiar with some of 

the special features, functions, and concepts of CAD. If you are familiar with manual 

drafting, you’ll find some conceptual similarities in CAD as well as some differences. 

 

Drawing to scale 
In traditional, manual drafting, you usually determine the scale of the drawing before 

you even start to draw, because you are working with a sheet of paper of a fixed size. 

You may have to reduce or enlarge the entity you are drawing to fit within the con- 

fines of the paper. 

When you create a drawing in 4MCAD, you draw everything full-size. You deter- 

mine the type of units in which your drawing is measured. If you are drawing a build- 

ing, 1 drawing unit might equal 1 inch. If you are drawing a map, 1 drawing unit 

might equal 1 mile. Your drawing environment and the CAD drawing file itself are 

not limited to the size of a particular sheet of paper. 

 
 

 
1 drawing unit equals 1 inch. 1 drawing unit equals 1 foot. 

As you draw, you can use commands such as Pan and Zoom to work on different por- 

tions of the drawing and to magnify the display of the drawing to view small details. 

These commands have no effect on the actual size of the entities in your drawing; 

they affect only the way the drawing is displayed on your screen. Only when you 

print or plot your drawing do you need to set the scale so that the printed drawing fits 

within a specific paper size. 

 
Using tools 

In manual drafting, you use tools such as pencils, rulers, T-squares, templates, eras- 

ers, and so on. When you create a drawing in 4MCAD, you use a mouse instead of a 
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pencil, and you use the mouse to select other tools—commands you select from a 

menu or a toolbar. 

You use some tools to create basic entities, such as lines, circles, and arcs, and other 

tools to modify existing entities (for example, to copy or move them or to change 

properties such as color and linetype). 

 

Organizing information 
In traditional drafting, you often separate elements such as walls, dimensions, struc- 

tural steel members, and electrical plans onto separate, translucent overlays. When 

you want to print the working drawings, you can create several different drawings by 

combining different overlays. 

When you create a drawing in 4MCAD, you use layers to organize elements in a 

similar manner. However, the layers feature in CAD offers numerous advantages 

over physical transparencies. The number of overlays you can combine to print a 

manually drafted drawing is limited by the printing process. There is no such limita- 

tion in CAD. With 4MCAD, you can define an unlimited number of layers, any of 

which can be visible or invisible at any time. You can name each layer and assign 

each its own color, linetype, lineweight, and print style. You can also lock individual 

layers to ensure that information on those layers isn’t altered accidentally. 

 
 

 
Use layers to organize drawing information. 
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Drawing accurately 

When you create a manual drawing, ensuring accuracy typically requires a lot of 

manual calculations and rechecking. By contrast, 4MCAD offers a number of 

drawing aids that ensure accuracy from the start. For example, you create and modify 

entities based on an underlying Cartesian coordinate system. Every location in the 

drawing has its own x,y,z-coordinates. You can also display a grid as a visual refer- 

ence to your coordinate system. 

 

 
Every location in the drawing has its own x,y,z-coordinates within the underlying Cartesian coordinate 
system. Point 5,2,0 is 5 units to the right (along the x-axis), 2 units up (along the y-axis), and 0 units (along 
the z-axis) from the origin (the 0,0,0 point). 

 

Settings such as snap and entity snap allow you to draw accurately without specifying 

coordinates. The snap setting forces the selected points to adhere to the grid incre- 

ment or to any other increment you set. Entity snaps let you snap to precise geometric 

points on existing entities—for example, the endpoint of a line or the center of a cir- 

cle. Another setting, orthogonal, constrains lines so that they are drawn parallel to the 

vertical and horizontal axes. 
 

 

Paper-based drawings lack the high degree of accuracy possible when using CAD. Lines often overlap or fail 
to meet adjacent lines. 

-X 
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Snap and entity snap force the cursor to adhere to a specified increment or attach to key geometric points on 
existing entities. You can also constrain lines to vertical and horizontal axes. 

 

Drawing efficiently 
In paper-based, manual drafting, you often have to redraw the same entity several 

times at different scales or from different vantage points. You may also need to 

redraw the border and title block on each new sheet. 

One of the most powerful features of 4MCAD is that when you create a drawing, 

you can reuse individual entities, borders, and title blocks as often as you want. You 

need draw an entity only once; the final printed drawing can show the entity at sev- 

eral different scales and viewpoints. 

You usually begin drawing in model space on the Model tab, creating the drawing (a 

floor plan, a map, or a three-dimensional part) without regard to the final layout on 

paper. When you are ready to print your drawing, you have the option to switch to 

paper space on a Layout tab, where you lay out the drawing as you want it to appear 

on a sheet of paper. For example, you can insert a drawing file that contains the stan- 

dard border and title block that you created. You can define and arrange multiple 

views of the drawing at appropriate scales and with specific portions visible or invisi- 

ble—again, without having to redraw the border and title block for each view. 
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You create the basic drawing in model space on the Model tab. 

 

 
 

When you’re ready to print or plot your drawing, you can switch to paper space on a Layout tab, where you provide a 
layout of the drawing as you want it to appear on a sheet of paper. 
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Reusing CAD drawings and entities 

When you create a paper drawing manually, you can draw repetitive symbols by trac- 

ing a plastic template. After you draw a symbol in 4MCAD, you can reuse that 

symbol without having to redraw it. You simply save the symbol as a block. You can 

then insert copies of that block anywhere in your drawing. You can also save the 

symbol as a separate drawing for use in other drawings. 

 

 
You can draw a symbol one time, save it as a block, and then insert multiple copies of that symbol anywhere 
in your drawing. 

 

In addition, you can reuse entire drawings and insert individual drawings into other 

drawings. You can also use an external reference, which acts as a pointer to another 

drawing rather than a copy of the entire drawing. Using an external reference has an 

added advantage: when you update the externally referenced drawing, each drawing 

that references it can be automatically updated. 
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Making changes 

To make changes to a paper drawing, you erase and then redraw. With 4MCAD, you 

use commands to modify entities in the drawing. You can move, rotate, stretch, or 

change the scale of entities. When you want to remove an entity, you can delete it 

with a single click of the mouse. If you make a mistake while creating or modifying 

your drawing, you can easily reverse your actions. 

 

 
You can easily change an entity using commands such as move, rotate, stretch, and scale instead of 
redrawing the entity. 

 

Working with other data and programs 
Traditional paper drawings serve only as a means of communicating information 

between the person who created the drawing and the person viewing the drawing. The 

drawings contain no more information than what is visually imparted by the creator 

and seen by the viewer. 

4MCAD offers rich possibilities for analyzing drawings and attaching additional 

data to them. For instance, although it may be impractical to count entities in a com- 

plex paper drawing, this task is simple in CAD. 4MCAD can calculate the number of 

entities in a drawing and compute area and distance. 

CAD drawings can also contain information in addition to visible entities. You can 

attach invisible database information to visible drawing entities and extract the infor- 

mation for analysis in a database or spreadsheet. (Working with information in a data- 

base requires a program from a third-party vendor, or you can create your own means 

of exporting the data in LISP or SDS. Or, you can also use VBA.) 

4MCAD provides in-place editing of Microsoft® objects, such as those created in 

Microsoft® Word and Microsoft® Excel software programs. In-place editing makes it 

easy to share data with other users and programs. For example, you can include 

4MCAD drawings in files created using Microsoft® Word, and you can insert files 

created using Microsoft® Word into your 4MCAD drawings. 
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Using advanced CAD features 
 

In addition to being compatible with AutoCAD, 4MCAD goes several steps further 

by providing you with innovative features to increase your productivity. 
 

Using the 4MCAD Explorer 
The 4MCAD Explorer has an interface similar to the Windows Explorer, allowing 

you to view and manage the elements of multiple, open drawings, such as layers, 

blocks, linetypes, views, user coordinate systems, and text styles. 
 

Editing multiple documents simultaneously 
With 4MCAD, you can open and edit multiple drawings simultaneously. You can 

also copy and paste elements between open drawings. 
 

Editing multiple entities 
4MCAD allows you to change most of the properties of all selected entities using a 

single, tabbed dialog box. 
 

Using the CUI dialog box 
4MCAD has a single dialog box for changing ribbon tabs (if your 4MCAD ver- sion 

supports them), toolbars, menus, keyboard shortcuts, and command aliases. You can 

also use the drag-and-drop method to customize these user interface items. The 

simple, point-and-click action lets you easily create new items and keyboard short- 

cuts—no programming or manual text editing required. 
 

Performing unlimited undo and redo 
4MCAD increases your power with unlimited undo and redo of editing actions. 
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Getting more information 
 

In addition to the 4MCAD documentation, much of the assistance you need as you 

use 4MCAD is specific to the commands you work with on the screen. To obtain 

immediate information as you work, use these additional sources of information: 

• Tooltips — To find out what a specific tool on a toolbar does, pause the cursor 

over it for a moment. A ToolTip appears on the screen. 

• Status bar — To find out more detailed information about a tool when you pause 

the cursor over it, look on the status bar at the bottom of the screen. 

• Online help — 4MCAD online help is available on the screen when you press F1, 

choose a command from the Help menu, or click the question mark in a dialog 

box. The online help also presents information that does not appear in this manual, 

including a programming reference that describes how to program in DRX, LISP, 

DCL, SDS, and DIESEL. The programming reference also describes program- 

ming in VSTA and VBA. 

 
 

 

Working with sample drawings 
 

With the 4MCAD program, you can create a variety of drawings, including two- 

dimensional architectural drawings, electrical schematics, and mechanical drawings. 

Viewing and working with sample files can be an easy way to quickly learn how to 

use various 4MCAD features. 
 

To access the sample files 

• Choose File > Open, and then open the Samples folder. 
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New in 4MCAD 21 
 

New in 4MCAD 21 

Performance 

• Refactored LISP API to improve the performance of the .NET interface 

• Improved memory consumption when working with raster images. 

• Improved memory consumption and speed when using 4MCAD Explorer for 

blocks. 

• The flood fill hatch algorithm was refactored for improved performance. 

• Improved performance when snapping to .pdf files, blocks with many nested enti- 

ties, and point clouds. 

• Opening external reference files is now faster. 

• Improved performance when selecting by window. 

• More critical fixes for running 4MCAD on the Fall Creators 2017 Microsoft® 

Windows® update. 

• Incremental saving of .dwg files is supported, providing much faster saving of 

large .dwg files that contain only a few changes. 

• Zoom and Pan commands are 3 times faster for clipped external references. 

 
 

Working with Files 

• Import and export both IGES and STEP format files. 

• For 4MCAD versions that support markup for .dgn files in their native format, 

you can now use the VIEWDIR command, BASE command, and ORTHOMODE 

system variable. 

• Attach digital signatures to .dwg files, and validate attached digital signatures. 

• For 4MCAD versions that support working with .dgn files in their native for- 

mat, additional features are now available: SOLID, CHPROP, HATCH, 

DIMALIGNED, FILLMODE and more. 

• For 4MCAD versions that support working with BIM files in their native for- 

mats: now you can draw stairs, railings, and steel. 
 

User Interface 

• Use the Quick CUI command to display a small version of the Customize User 

Interface dialog box so you can quickly add commands to the Tool Palettes pane. 

• On the status bar you can now toggle Cursor Type (regular or gunsight) and XOR 

Cursor (cursor color is inverted when overlapping an area of the same color). 

• Right-click a drawing tab to see options for the tab. 

• In the command bar, click keywords to select options when you run a command. 
As a result, prompt boxes have been turned off by default. To turn them on, go to 

Tools > Options > Display. 

• When you start 4MCAD, a Start Page displays automatically where you can 
quickly open files or choose from other common tasks. 

• Click Toggle Clean Screen On/Off in the status bar to quickly hide most user 
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interface items so that only model and layout tabs, the menu bar and the status bar 

are displayed on the screen. Click again to reverse the effects. 

• Add blocks to tool palettes, which is similar to creating a stencil for quickly select- 
ing and adding anything from shapes to complex blocks to your drawings. 

• To customize the user interface, use the Customize User Interface (CUI) com- 
mand. The Customize (CUSTOMIZE) command is now used for customizing tool 
palettes into groups and importing and exporting tool palettes. 

• Set the transparency of the Properties pane, Tool Palettes pane, and Explorer Pal- 
ette pane. 

• Reset the ribbon (for 4MCAD versions that have a ribbon), menus, toolbars, 
aliases, keyboard shortcuts, and double-click actions to their original settings using 
the Reset User Interface (RESETUI) command. 

• The new Save Workspace (WSSAVE) command is a shortcut for saving a work- 
space and its settings. 

• The new File Tab and File Tab Close commands are shortcuts for turning the dis- 

play of file tabs at the top of the drawing on or off. 

• The Close All Others (CLOSEALLOTHER) command closes all drawing win- 
dows except the current one. 

• Open, save, and work with .dwg files of version 2018. 

• Load and view Mechanical entities 

• For 4MCAD versions that support working with BIM files: 

• Attach .rvt/.rfa files as underlays. These file types contain building and construction 
data, and once the file is attached, you can explode it, snap to it, and use the 

RVTPANE command to open a Categories pane to control visibility. 

• In addition to the existing ability to attach IFC underlays, you can now import ifc 

files as architectural entities.Use the new AEC commands to draw walls, doors, 
windows, openings, slabs, and roofs. 

• For 4MCAD versions that support markup for .dgn files in their native format, 
several new features are available such as working with hatches, images, multiline 
text, and more. 

• Export to .pdf files using more options, such as making exported text searchable, 
defining the DPI for exported images and hatches, exporting hyperlinks, linearized 

.pdf files, and more. 

• Attach point clouds using a new file format: .rcp/.rcs files. 

• Tool palettes display on the right side of the drawing window and are another con- 
venient way to start commands. 

• In the Properties pane, use the new selection control to view selected entities in a 
tree list instead of the default drop-down list. 

• The Properties pane supports display and editing of many new properties and entity 
types. 

Creating Entities 

• For 4MCAD versions that support working with BIM files in their native for- 

mats, now you can draw curtain walls, studs, joists, track, and wood. 

• The boundary option is now available for -HATCH. 

• The new Gradient command is a shortcut for using the Hatch and Gradient dialog 

box to add gradients to entities. 

• Convert entities to three-dimensional meshes or surfaces using the Convert to 
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Mesh and Convert to Surface commands. 

• Use the FM3DCONVERT and FMEXTRUDE commands to convert more types of 
three-dimensional entities to other types of three-dimensional entities. 

• Use the new Facet Modeler to draw these 3D entity types: box (FMBOX), cone 

(FMCONE), cylinder (FMCYLINDER), pyramid (FMPYRAMID), sphere 
(FMSPHERE), and torus (FMTORUS). These entities are designed for light- 

weight 3D use where the calculation of mass is not required. 

• Draw construction lines using the new Construction Line command. 

Selecting and Modifying Entities 

• Use the Selection Filter command to display the Selection Filter pane, which dis- 

plays all entities in the drawing and allows you to filter and select entities by layer, 

color, entity type, and linetype. 

• Click the Selection Cycling tab in the Options dialog box to specify which method 

you want to use when selecting entities that overlap. 

• Use the Overkill command to delete or combine duplicate or overlapping entities 

in a drawing, reducing the drawing's file size and complexity. 

• If you choose Undo or Redo from the ribbon toolbar, you can view and also select 

a range of actions. 

• Use the Thicken command to convert surfaces and meshes into three-dimensional 

solids with a specified thickness. 

• Move, copy, rotate, and scale entities all in a single command using the new 

Move/Copy/Rotate command. 

• Edit 3D entities that are drawn with the new Facet Modeler: 3D convert 

(FM3DCONVERT), extrude (FMEXTRUDE), intersect (FMINTERSECT), 

revolve (FMREVOLVE), subtract (FMSUBTRACT), and union (FMUNION). 

• There is a new option for arraying entities when using the Copy command. 

 

 

• Polylines and break lines have additional grips and properties for smart editing. 

• New selection grips allow you to quickly move, scale, and rotate all selected enti- 

ties. These types of grips can be helpful for schematic drawings where precise scale 
or sizing is not required. 

Text 

• Work with multiline text using right-to-left fonts. 

• Create additional types of lists for multiline text 

• The in-place Multiline Text editor now supports columns. 

• Use these new express tools to work with text: Create and modify text along an arc 

using the Arc-Aligned Text command. 

• Resize text using the Scale Text command. 

• Draw a circle, rectangle, or dashed line around text using the Enclose Text with 

Shape command. 

• Set the capitalization of text using the Change Text Case command. 

• Set text justification using the Justify Text command. 

• Position text within a defined space using the Text Fit command. 

• Rotate text using the Rotate Text command. 
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Print 

• Publish drawings to DWF and DWFx. 

• Use the Auto Publish command to automatically create electronic files (.dwf/.pdf) 

from the current drawing. 

• Print directly to PDF, including support for many sheet sizes and PDF options. 

• Publish to PDF, including support for many PDF options. 

• Select from new sheet sizes included for printing to raster images. 
 

APIs 

• .NET wrappers are available for architectural objects. 

• Load IRX applications automatically in 4MCAD via the registry. 

• Updated to ODA Teigha version 4.3.2. 

• New Teigha Mechanical API available for working with Mechanical entities. 

• Updated .NET API includes many improvements. 

New and Changed System Variables 

• AECAUTOUPDATE, AUTOMATICPUB, AUTOPUBLISHPATH, 

BLOCKEDITLOCK, CROSSHAIRMODE, OVERKILLMODE, OVERKILL- 

TOLERANCE, OVERKILLTOLARCCHORD, OVERKILLTOLARCEND- 

POINT, REFPATHTYPE, SELECTIONCYCLING, SJTABTINDEX, 

TASKBAR, WOODTABINDEX, and 

XREFNOTIFY. 

• HPPREVIEW renamed to HPQUICKPREVIEW. 

• TOOLPALETTESSTATE renamed to TPSTATE. 

• WSUPDATEALL new valid range 0 to 2. 
Viewing Entities 

 Use the new List Viewport Scale command to obtain the scale of a selected view- 
port on a Layout tab. 

• Use the new Synchronize Viewport command to synchronize all selected view- 

ports to use the zoom factor of a master viewport that you select. 

• Change the display of edges of three-dimensional entities using these new com- 

mands: 

• The Edge command controls the visibility of selected edges of 3D faces. 

• The Show Edges command displays all edges of selected 3D faces, meshes, and 

polyface meshes. 

• The Hide Edges command hides all edges of selected 3D faces, meshes, and 

polyface meshes. 

• Use the new Camera command to create and modify view settings for a 

drawing. 
 

Blocks 

• Create and edit blocks using the new Block Editor, which allows you to draw and 

save a block in-place, directly in the drawing area. 

• Use the new Convert Block to XRef command to convert each occurrence of a 

selected block to an external reference. 

• Use the new List Xref/Block Properties Info command to list property information 

for an external reference or block. 
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• Use the new Copy Nested Entities command to draw a duplicate of nested entities 

within blocks, external references, and underlays. 

More Features 

• The System Variable Manager displays all system variables and their values. You 

can change system variables and include them in reactors. 

• Choose from more formatting styles for lists of multiline text. Just start typing, for 

example, type (1) to start a numbered list with parentheses. 

• Open the standard Microsoft® Windows® Notepad application using the Notepad 

command. 

Dimensions 

• Use the new Reset Dimension Text command to remove overrides made to dimen- 

sion text and return the dimension to its original value. 

• Use the new Reassociate Dimension command to reset the association between 

dimension text and corresponding location points on entities. 
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Getting started 
 

This section helps you get started using 4MCAD software by explaining how to install 

it and providing basic information about how to use it. 

 
 

This guide assumes that you have working knowledge of Windows-based programs. 

If necessary, see the documentation that came with your operating system for infor- 

mation about Windows terminology and techniques. 
 

 

 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 

 

   2 
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System requirements 
 

You need the following software and hardware to install and run 4MCAD: 

• Microsoft® Windows 10, Windows 8, including 32-bit and 64-bit 

• For 32-bit operating systems, it is automatically installed the 32-bit version of 

4MCAD. 

• For 64-bit operating systems, it is automatically installed the 64-bit version of 

4MCAD. The 64-bit version of 4MCAD runs slightly faster, but can use all 

available system memory to handle large drawing files. 4MCAD 32-bit can 

access up to 3GB of RAM on 32-bit operating systems and up to 4GB of RAM 

on 64-bit operating systems. 

• Intel® Pentium® 4 or comparable, faster processor recommended 

• 1 gigabyte (GB) of RAM minimum for 32-bit and 2 gigabytes (GB) of RAM min- 

imum for 64-bit Windows 10, Windows 8, and Windows 7, 1 gigabyte (GB) of 

RAM minimum for Windows Vista 

• 700 MB of free hard disk space recommended for typical installation 

• 1024 x 768 VGA or higher resolution, video adapter, and monitor 

• Graphics card compatible with OpenGL Version 1.4 or higher 

• Keyboard and mouse, or other pointing device 

• CD-ROM or DVD drive for installation, if installing from a CD or DVD 

 
 

Installing and Activating/Deactivating 4MCAD 
 

A setup program guides you through the 4MCAD installation process. The program 

transfers files to a folder that it creates on your hard disk. The program also creates a 

menu item on the Start menu. 

Installation starts automatically after you insert the 4MCAD compact disc into 

your CD-ROM drive. If installation does not start, you can install 4MCAD by 

using the following procedure. 
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To install 4MCAD from a compact disc 

1 Insert the 4MCAD compact disc into your CD-ROM drive. 

2 Do one of the following: 

• Wait for the autorun feature to start. 

• Choose Start > Run and in the Open field, type d:\setup, where d is the letter 

assigned to your CD-ROM drive. Click OK. 

3 Follow the instructions on your screen. 

To activate 4MCAD  
1 Launch the application from the Start Menu. It is required to launch the 

application with Administrator Rights, only the first time for the activation 

purpose. By pressing right click on the 4MCAD Shortcut select “Run as 
Administrator”. 

 

 

2 On the window entitled "Installation Parameters" that appears on your screen, fill 

in your User Name, Company and Serial Number. Press "Activate". 

 

 
 

If you have a version of 4MCAD that uses a hardlock key the activation is completed. 
 

3 (Only for non - harlock key versions) On the window entitled "Activation" 

select  one of the four available methods to activate the software  

Those methods are: 
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 On- line: The user provides his/hers personal data (see step 4) and the 
process is performed transparently through the Internet (an active Internet 

connection is required) 

 Internet web page: The user is directed to 4M Registration-Activation 

web page (http://doc.texnikoi.gr/4MCAD/Register/Registration.aspx) in 
order to complete the activation process  

 E-mail: The user provides his/hers personal data (see step 4) which are 
saved into a text file. This file must be send via e-mail at 

registrations@4m.gr. The activation is completed by 4M personnel at 
working hours (10:00 – 19:00 LT) and the user receives via e-mail the 

activation code 

 Fax: The user provides his/hers personal data (see step 4) which are saved 

into a text file. This file must be printed and faxed to 4M at +30 210 
6848237. The activation is completed by 4M personnel at working hours 

(10:00 – 19:00 LT)  and the user receives via e-mail the activation code.  

Press "Next". 

 

4  (Only for on-line, e-mail and fax methods) On the window entitled 

"Activation" that appears on your screen, fill in your personal details. Please, be 

careful in typing a valid e-mail address on the appropriate box. Press "Activate" 

 

http://doc.texnikoi.gr/4MCAD/Register/Registration.aspx
mailto:registrations@4m.gr
mailto:registrations@4m.gr
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5 On-line method : The activation process is completed without user intervention 

through the Internet. Upon successful completion of the process, the user receives 

a confirmation via e-mail (at the address that was provided during step 4)  

Internet web page method : On this final step a window appears on the screen 

where the generated request code is displayed. 

 

Simultaneously, the user is directed at 4M Registration-Activation web page 

(http://doc.texnikoi.gr/4MCAD/Register/Registration.aspx)  

In order to complete the activation process, the following steps must be 

performed 

 Fill in your Country and Serial Number.  

 Fill in your personal details. Press “Next” (Fig. 5) 

 

http://doc.texnikoi.gr/4MCAD/Register/Registration.aspx
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 Copy-paste the request code to the appropriate box on the web page. 

 

Fig. 6 
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The corresponding response code is generated and displayed on the web page. 

This code must be inserted (preferably via copy-paste) in the appropriate box of 
the window. 

E-mail/Fax method : The user is prompted to save a text file with the 
registration parameters. Select an appropriate place on you hard drive to save the 

file. 

This file must be send at registrations@4m.gr (if e-mail method has been 

selected) or printed and faxed at +30 210 6848237 (if fax method has been 
selected), where the activation is performed by 4M personnel during working 

hours (10:00-19:00 LT) and the user receives via e-mail (at the address provided 
during step 4) the response code. This code must be inserted (preferably via 

copy-paste) in the appropriate box of the window that is displayed after the 
saving of the file (Fig. 7). 

 

 

 
 

Some 4MCAD versions may not come with a compact disc. 

For example, if you downloaded the program from the Internet, follow the instruc- 

tions that came with the program. 
 

 

 
To deactivate the software in order to activate it on another device do the followings. 

1. Launch 4MCAD “as Administrator” and go to the Startup Wizard tab. In 
case this tab is not displayed automatically, go to “HELP > Startup 

Wizard” 
2. After that select the button Deactivate. 

 

mailto:registrations@4m.gr
mailto:registrations@4m.gr
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Starting 4MCAD 
 

To start 4MCAD, choose Start > All Programs > 4MCAD version > 4MCAD (may 

vary, depending on your operating system). 

Each time you start 4MCAD, the Start Page displays on your screen (unless you have 

turned off this option). Use the Start Page to quickly open drawings, create new 

drawings, and send feedback about the program. 

For versions of 4MCAD that don’t have a Start Page, the program opens a new, 

blank drawing based on a default template, icad.dwt. Using a template as the basis for 

a new drawing has several advantages: 

• You can use predetermined units of measure, grid settings, text heights, and other 

settings appropriate for the type of drawing you’re creating. 

• You can predefine special layers. 

• You can predefine the type of print style table. 

• You can include predefined title blocks and borders. 

Working in 4MCAD 
 

You can work with the 4MCAD window and its elements in a variety of ways. For 

example, you can display and rearrange tool palettes, the toolbars, display the com- 

mand bar, and enable the status bar. The toolbars and command bar can also be 

floated anywhere on the screen or docked to the edges of the main 4MCAD win- 

dow. 

 
 

Use a shortcut to turn window elements on or off all at once. 

When multiple window elements are enabled, the size of the drawing window is 

reduced, which can limit how much drawing data can be displayed. If you want more 

screen space dedicated to drawing, simply choose Toggle Clean Screen On/Off in the 

status bar. The window elements will hide until you choose the toggle again. 
 

 

 

Displaying file tabs for drawings 
Multiple drawings can be open at the same time. By default, each drawing displays its 

own tab. Select a tab to switch the active drawing. 
 

To toggle the display of file tabs for drawings 

1   Do one of the following: 

• On the ribbon, choose View > File Tabs (in Display) 

• On the menu, choose View > File Tabs. 

• Type filetab or filetabclose and then press Enter. 
 

 

Open drawings can also be arranged side by side. 

For more details about viewing drawings, see “Working with multiple drawings” on 

page 224. 
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Displaying commands on a shortcut menu 
Shortcut menus provide quick access to specific commands. A shortcut menu dis- 

plays when you right-click an entity, toolbar, status bar, the Model tab name, or a 

Layout tab name. The selections presented in the shortcut menu depend on what you 

right-clicked. 

When you right-click the drawing, you can choose from a wide range of commands, 

including recently used commands. When you right-click a toolbar, the program dis- 

plays a shortcut menu that lets you toggle the command bar, status bar, and various 

toolbars on and off. If you select one or more entities and then right-click, the pro- 

gram displays a shortcut menu from which you can choose a command to modify the 

selected entities. To display a shortcut menu from which you can choose an entity 

snap, press and hold down the Shift key, and then right-click anywhere within the 

drawing window. 
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Displaying and hiding the ribbon 

The ribbon contains several areas from which to choose commands: 

• Application button — The Application button in the upper left corner contains 

file-related commands, such as New, Open, Import, Export, and more. 

• Quick Access toolbar — Contains common commands. Click the Quick Access 

toolbar down arrow to choose which commands display and to customize various 

visual elements of the drawing window. 

• Tabs — Contains related commands grouped together, for example, on the tabs 

named Home, Edit, Draw, etc. 

• Panels — Contains sub-categories of commands within a tab, for example Draw, 

Modify, and Layers on the Home tab. 

 

 

A Click the Application button to view and select 
commands. 

B Displays groups of commands in panels. 

C Click to lock the expanded panel open. 

D Click to expand the panel to show additional 
commands below it. 

To customize the Quick Access toolbar 

E Click to expand the panel and view related 
commands below. 

F Click a tab to view different commands. 

G Click a tool on the Quick Access Toolbar. You 
can also click the arrow on the right to choose 
additional options. 

1 To add a command to the Quick Access toolbar, right-click the command in the 

ribbon, then choose Add to Quick Access Toolbar. 

2 To remove a command from the Quick Access toolbar, right-click the command to 

delete, then choose Remove from Quick Access Toolbar. 
 

To customize a tab in the ribbon 

1 Right-click anywhere in the tab of the ribbon you want to customize. 

2 Do one of the following: 

• Choose Show Tab, then choose the tabs you want to display or hide. 

• Choose Show Panel, then choose the areas that you want to display or hide for 

that tab. 



G E T T I N G   S T A R T E D 31 
 

 

 
 

The ribbon can be customized in other ways. 

You can use the Customize UI command or manually edit the .cui file for the rib- 

bon. For more details, see “Customizing the ribbon” on page 728. Also see 

“Working with user interface customization files” on page 756. 
 

 

 
To minimize the ribbon 

1 Click the down arrow on the Quick Access toolbar. 

2 Choose Minimize the Ribbon. 
 

To show both the ribbon and menus at the same time 

1 Right-click anywhere in the ribbon. 

2 Choose Menu Bar. 
 

To hide the ribbon 

1   Do one of the following: 

• Right-click anywhere in the menus or ribbon, then choose Switch to Menu Bar. 

This hides the ribbon and displays the menus instead. 

• Type ribbonclose and press Enter to hide the ribbon only. 

To display the ribbon 

1   Do one of the following: 

• Right-click a menu or any toolbar, then choose Switch to Ribbon. 

• Type ribbon and press Enter. 
 

 

When using the ribbon, switch between drawings using file tabs or using the status bar. 

Click a drawing’s file tab to display the drawing. If file tabs are not visible, type 

filetab and press Enter. You can also switch between drawings using Show Window 

Menu on the status bar. 
 

 

 
 

Workspaces also can control the ribbon. 

The 4MCAD Classic workspace shows toolbars and the Drafting and Annotation 

workspace shows the ribbon. For more details about workspaces, see “Using work- 

spaces” on page 38 in this chapter. 
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Displaying and hiding the Tool Palettes pane 

The Tool Palettes pane displays groups of organized commands and blocks for easy 

selection. 

The Tool Palettes pane can be either docked or floating. A floating pane has a Close 

box and options along the right, can be located anywhere on the screen, and can be 

resized. A docked pane has a title bar, a Close button in the upper right only when the 

cursor moves over it, cannot be resized, and is attached along one of the edges of the 

drawing window. 

 

 
 

A Click a palette to show its commands. Right-click 
for more options. 

B Double-click to dock the pane. Right-click for 
more options. 

C Click and drag to move the pane to a new 
location. Right-click for more options. 

D Click to scroll the list of commands. Right-click 
for more options. 

E Click a tool to start its command. Right-click for 
more options. 

F Click to display a menu of options: close, 
dockable, fix to left, fix to right, autohide, and 
transparency. 

G Click to auto-hide the pane. 

H Click to close the pane. 

 

To display the Tool Palettes pane 

1   Do one of the following: 

• On the ribbon, choose View > Tool Palettes (in Display). 

• On the menu, choose View > Display > Tool Palettes. 

• Right-click a ribbon tab (if your version has a ribbon), toolbar, or menu and 

choose Tool Palettes. 

• Type toolpalettes and press Enter. 

A 
H 
G 
F 

E 

D 
C 

B 
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To close the Tool Palettes pane 

1   Do one of the following: 

• On the ribbon, choose View > Tool Palettes (in Display). 

• On the menu, choose View > Display > Tool Palettes. 

• On the Tool Palettes pane when it is undocked, click ( ) in the upper right 

corner. 

• Right-click a ribbon tab (if your version has a ribbon), toolbar, or menu and 

choose Tool Palettes. 

• Type toolpalettesclose and press Enter. 

To auto hide the Tool Palettes pane 

1   Do one of the following: 

• Right-click the Tool Palettes pane title bar and choose Auto Hide. 

• On the Tool Palettes pane when it is undocked, click Auto Hide ( ). 

• On the Tool Palettes pane when it is undocked, click the menu ( ), and choose 

Auto Hide. 
 

To move the Tool Palettes pane 

• Click and drag the title bar of the Tool Palettes pane to the desired location in the 

drawing window. 
 

To dock or undock the Tool Palettes pane 

1 On the Tool Palettes pane when it is undocked, click the menu ( ), and choose 

Dockable if it is unchecked. 

2 Do one of the following: 

• Double-click the title bar of the Tool Palettes pane to dock or undock it. 

• Drag the Tool Palettes pane title bar to the far right or left of the drawing 

window to dock it, or drag it to a different area of the drawing window to undock 

it. 

• On the Tool Palettes pane when it is undocked, click the menu ( ), and choose 

Fix to Left to dock the palette on the left side of the drawing window, or choose 

Fix to Right to dock the palette on the right side. 

 
 

Tool palettes are customizable. 

You can change the transparency of the Tool Palettes pane; add, delete and rear- 

range tool palettes; and add new customized commands and blocks. For more 

details, see “Customizing tool palettes” on page 713. 
 

 



34 C H A P T E R   2 
 

 
Displaying and hiding menus 

Related commands are grouped together on menus. You can use the menus with or 

without the ribbon. 
 

To customize the display of menus 

1 Right-click anywhere in the menus or ribbon. 

2 Choose Show Menu, then choose the menus you want to display or hide. 
 

 

There are more ways to customize menus. 

You can use the Customize UI command or manually edit the .mnu file for the 

menus. For more details, see “Customizing menus” on page 718. Also see see 

“Working with user interface customization files” on page 756. 
 

 

 
To display or hide menus when using the ribbon 

For 4MCAD versions that have a ribbon. 

1 Right-click anywhere in the menus or ribbon. 

2 Choose Menu Bar. 

 

Displaying and hiding toolbars 
When you start 4MCAD the first time, multiple toolbars are displayed. 4MCAD 

provides more than a dozen toolbars, which you can customize by adding and delet- 

ing tools. You can also move and resize toolbars, and you can create new toolbars. 

You can use a shortcut menu to display or hide toolbars. 

You can also choose whether toolbars are displayed large or small and in color. You 

can choose to display or hide ToolTips, which provide descriptions of tools that dis- 

play when you pause the cursor over them. Go to View > Toolbars to make these 

selections. 

Toolbars are either docked or floating. A floating toolbar has a title bar and a Close 

box, can be located anywhere on the screen, and can be resized. A docked toolbar 

does not display a title or Close box, cannot be resized, and is attached along one of 

the edges of the drawing window. 

• To dock a toolbar, drag it to the perimeter of your drawing; to undock it, drag it 

away from the perimeter. 

• To position a toolbar in a docking area without docking it, press Ctrl while you 

drag it. 

• To move a toolbar, drag it to a new location. 

• To resize a toolbar, move your cursor to the edge until it changes to a resize arrow, 

and then drag. 
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To choose which toolbars to display 

1 Do one of the following: 

• On the ribbon, choose View > Toolbars (in Display) 

• On the menu, choose View > Toolbars. 

• Right-click anywhere on a toolbar (docked, undocked, or the toolbar 

area at the top of the window) to display the toolbar shortcut menu, 

and then choose Toolbars. You can also select the toolbars you 

want displayed directly on the shortcut menu. 

• Type tbconfig and then press Enter. 

2 In the Select Toolbars dialog box, choose the toolbars you want 

displayed, and then click OK. 

 

 
A Mark the toolbar you want to modify. 

B Select to display a toolbar; clear to hide the toolbar. 

C Select to display large tools; clear to display small tools. 

D Select to display color tools; clear to display black and white tools. 

E Select to display ToolTips when you hover over tools on the toolbar; clear to not display 
ToolTips. 

F Highlight the toolbar name that you want to rename or delete. 

G Click to open the Customize dialog box and customize toolbars. 

H Click to delete the selected toolbar (does not delete all checked toolbars). 

I Click to type a new name for the selected toolbar (does not rename all checked toolbars). 

 
Using the command bar 

The command bar is a dockable window in which you type 4MCAD commands and 

view prompts and other program messages. By default the command bar displays the 

three most recent lines of prompts, but you can extend the window to display more 

lines. Move or resize the command bar by dragging it. 

A 
 

 
B 

I 

H 

G 

F 

C 
D 
E 
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To display or hide the command bar 

• On the ribbon, choose View > Command Bar (in Display). 

• On the menu, choose View > Display > Command Bar. 

When the command bar is docked or floating, you can drag the top or bottom of the 

window to change the number of lines of text it displays. You can dock the command 

bar at the top, bottom, left, or right of the drawing. You can auto-hide and auto-dis- 

play the command bar in its current location by clicking its pin button. 

When you type in the command bar, 4MCAD suggests names of matching com- 

mands as you type. The suggested names appear in an AutoComplete window. Sim- 

ply select the desired command in the list. In addition to command names, 

suggestions can include names of external commands, system variables, aliases, and 

LISP functions. 
 

To turn on AutoComplete for typing in the command bar 

1   Do one of the following: 

• On the menu, choose View > Display > AutoComplete. 

• Right-click the command bar and then choose AutoComplete. 

• Type autocomplete, press Enter, then choose AutoComplete. 

• Choose Tools > Options, click the Display tab, then mark Enable 

AutoComplete. 

When turned on, the AutoComplete automatically displays when you type in the 

command bar, and then automatically closes when you activate a command. 

For more details about customizing settings for the AutoComplete window, see “Cus- 

tomizing how suggestions display in the command bar” on page 693. 

 

Using the status bar 
If you elect not to use the command bar, the status bar displays information about the 

selected command or tool. It also displays the current cursor coordinates, the name of 

the current layer, mode settings, and other information about current settings. 

In addition to displaying information, the status bar is a quick way to access many 

features. You can click status bar items to make changes, and right-click items to dis- 

play short-cut menus that allow you more choices. 
 

To change the items that display on the status bar 

1   Right-click an empty area of the status bar. 
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2   Select an item to add or remove it. 
 

To change the setting of an item on the status bar 

1   Do one of the following: 

• Double-click the status bar item. 

• Right-click the status bar item you want to change, and then select the desired 

setting. 
 

To display or hide the status bar 

1   Do one of the following: 

• On the ribbon, choose View > Status Bar (in Display). 

• On the menu, choose View > Display > Status Bar. 

• Type statbar and then press Enter. 

 

Using prompt boxes 
4MCAD commands often provide several options. These options appear in the sta- 

tus bar or command bar and can also optionally appear in a prompt box (called a con- 

text menu in AutoCAD) initially displayed in the upper right corner of the screen. 

You can move the prompt box by dragging it; future prompt boxes will appear where 

you last placed it. The options appear as menu selections. Choose the appropriate 

option by selecting it in the prompt box. To close a prompt box, click the Close box. 

 

 
 

Command options appear in a prompt box. 
 

The prompt box is hidden by default. To turn on the display of prompt boxes, choose 

Tools > Options, click the Display tab, and then click the Display Prompt Boxes 

check box. 
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Using workspaces 

Workspaces are a convenient way to customize the display of commands in the 

4MCAD main window. Each workspace stores visibility settings for the following: 

• Menus — Visibility settings are saved for each top-level menu (for example, the 

Draw menu) and each nested menu (for example, the Draw > Arc submenu). 

• Toolbars — Visibility settings are saved for each toolbar, its orientation at the top, 

bottom, left, right, or floating, number of button rows, x-coordinate, and y-coordi- 

nate. 

• Ribbon — For 4MCAD versions that have a ribbon, visibility settings are saved 

for whether the ribbon itself displays, along with visibility settings for each ribbon 

tab (for example, the Home tab) and each panel (for example, Home > Modify). 
 

To create a workspace 

1 Organize the menus, toolbars, and ribbon the way you want them. 

2 Do one of the following to choose Save Workspace ( ): 

• On the ribbon, choose Tools > Save Workspace (in Manage). 

• On the menu, choose Tools > Save Workspace. 

• On the status bar, click Switch Between Workspaces, then choose Save Current 

As. 

• Type wssave, press Enter. 

• Type workspace, press Enter, then choose SaveAs. 

3 Enter the name of the new workspace. 

4 Click OK. 
 

To save the current visibility settings to an existing workspace 

1 Organize the menus, toolbars, and ribbon the way you want them. 

2 Do one of the following to choose Save Workspace ( ): 

• On the ribbon, choose Tools > Save Workspace (in Manage). 

• On the menu, choose Tools > Save Workspace. 

• On the status bar, click Switch Between Workspaces, then choose Save Current 

As. 

• Type wssave, press Enter. 

• Type workspace, press Enter, then choose SaveAs. 

3 Select an existing workspace name from the list. 

4 Click OK. 
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To switch to a workspace 

1   Do one of the following: 

• On the ribbon, choose the desired workspace from the Workspaces list ( ). 

• On the status bar, click Switch Between Workspaces ( ), then choose the 

desired workspace. 

• On the Workspaces toolbar, choose the desired workspace. 

• Type workspace, press Enter, choose Set Current, then enter the name of the 

desired workspace. 

 
 

The My Workspace tool (Workspaces toolbar) loads a specific workspace. 

Click the My Workspace tool ( ) to switch to your preferred workspace. To set 

which workspace loads when you click the My Workspace tool, click ( ) on the 

status bar, choose Workspace Settings, then choose the workspace in My Work- 

space. 
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Selecting commands 
 

Select commands using any of these methods: 

• Choose a command from the ribbon. 

• Choose a command from a menu. 

• Click a tool in the Tool Palettes pane. 

• Click a tool in a toolbar. 

• Type the command in the command bar. 

Some commands remain active until you end them, so you can repeat an action with- 

out having to select a command repeatedly. You can end a command by pressing Esc. 

 

Using commands 
You can use most commands while another command is active. For example, while 

drawing a line, you may want to use the Pan command to move the drawing across 

the screen to select the endpoint of the line. You can also change the settings of draw- 

ing aids such as snap or grid while other commands are active. 

After started, many commands have options that you can select in the command bar, 

status bar, or prompt box. 

 

Starting commands using the ribbon 
To start a command from the ribbon, choose it from the list of options available. If a 

command has an arrow, click the arrow to see related commands. For example, 

choose Home, then click the arrow for Array (in Modify) to choose the 3D Array 

command. 

 

Starting commands using tool palettes 
To start a command from a tool palette, click a tool and respond to the prompts. 

If the palette contains several tools, you might need to use the scroll bars to see the 

full list of available tools for that palette. 

 

Starting commands using toolbars 
To start a command from a toolbar, click a tool and respond to the prompts. 

 
 

The available toolbars depend on the experience level that is set. 

To change the current experience level, choose Tools > Options, and then click the 

General tab. 
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Some tools, such as Line or Arc, contain flyouts, which are options either for using 

the basic tool with different methods or that contain other, related tools. Flyouts are 

indicated by a small triangle in the lower right corner of a tool. To display a flyout, 

click the tool and hold down the mouse button. To select a tool from a flyout, point to 

the tool you want and then release the mouse button. The tool you select on the flyout 

becomes the default tool on the toolbar. 

 

Starting commands using menus 
To start a command from a menu, choose it from the list of menu options available. 

The available menu options depend on the experience level that is set. To change the 

current experience level, choose Tools > Options, and then click the General tab. 

 

Starting commands using the command bar 
Type a command, and then press Enter. If the command bar is displayed, the com- 

mand you typed appears there. If the command bar is not displayed, the command 

you typed appears in the status bar. 

 
 

Quickly start commands using the command bar by copying, cutting, and pasting text. 

In the command bar or Prompt History window, right-click to select various cut, 

copy, and paste commands. 
 

 

 

Repeating a command 
You can repeat a command you used previously without having to reselect it. 

 

To repeat the command you just used 

1   Do one of the following: 

• Press the spacebar. 

• Press Enter. 

• Click the right mouse button in the drawing. 

To repeat commands you used previously 

1   Do one of the following: 

• In the command bar or Prompt History window, press Ctrl and double-click the 

previous command text. 

• In the command bar or Prompt History window, right-click, choose Recent 

Commands, and then choose the desired command. 

• Press Ctrl + K, repeat until you get back to the desired command, and then press 

Enter. Press Ctrl + L to move forward to the desired command, and then press 

Enter. 

• Use the Up and Down arrows to display previously used commands, if Use Up/ 

Down Arrows for Command History Navigation is selected in Tools > Options. 
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Run a command multiple times using the command bar. 

If you are using the command bar to type commands, you can type multiple before 

starting some commands (Circle, Arc, and Rectangle, for example) to repeat a com- 

mand indefinitely. When you are done with a command, press Esc. 
 

 

 

Nesting a command 
If you are working in the command bar, you can use another command from within a 

command, called nesting. To use a command inside an active command, type an 

apostrophe before you type the command, such as ‘circle, ‘line, or ‘pyramid. You can 

nest commands indefinitely in 4MCAD. Many menu and toolbar macros work this 

way by default; for example, select color, reference grid, zoom, and snap. When you 

have finished with the nested command, the original command resumes. 

 

Modifying a command 
If you are working in the command bar, there are special ways that you can modify a 

command as you work. You can modify the active command using any of the follow- 

ing options: 

• Entity snaps — Type an entity snap command, such as nearest or midpoint, to 

enable a one-time entity snap for a single selection. You can also use a one-time 

entity snap to override a running entity snap. 

• Extension snaps — Type int after selecting a command, such as Line or Circle, to 

enable a one-time snap to the logical location where two entities would intersect if 

they were of infinite length. Type app to enable a similar one-time snap if the 

extensions would not intersect in three-dimensional space but would intersect in 

the current view. 

• Midpoint snaps — Type m2p or mtp to enable a one-time snap to the midpoint of 

two points that you specify. 

 

Using the Prompt History window 
The Prompt History window displays a history of the commands and prompts issued 

since you started the current session of 4MCAD. By default, the program tracks up to 

256 command lines. There is no limit to the number of command lines you can 

track, but program performance may be degraded if you choose to track an exces- 

sively high number of lines. 
 

To display or close the Prompt History window 

• Press F2. 



G E T T I N G   S T A R T E D 43 
 

 
To view entries in the Prompt History window 

1   Do one of the following: 

• Use the scroll bars. 

• Press Ctrl + K to browse backward; press Ctrl + L to browse forward. 

• Use the Up and Down arrows to display previously used commands, if Use Up/ 

Down Arrows for Command History Navigation is selected in Tools > Options. 

 

To copy or paste text in the Prompt History window 

1 If copying text, do one of the following: 

• Highlight text using your mouse. 

• Press Ctrl + Shift + arrow keys to highlight text. 

2 Right-click and choose whether to copy or paste. 
 

 

You can also copy the entire command history or the last command line. 

Choose Copy History or Copy Last Line. 
 

 

 
To change the number of command lines to track 

1 Do one of the following: 

• Choose Tools > Options, and then click the Display tab. 

• Type options and then press Enter. Click the Display tab. 

2 In the Command Lines To Track field, type the number of command lines you 

want to display, and then click OK. 

 

Using mouse shortcuts 
You can use your mouse, often combined with the keyboard, to start commands and 

perform other actions. 

 
Mouse shortcuts 

 

 
Ctrl + Hold and drag left mouse button Copy and move selected entities 

Ctrl + Hold and drag right mouse button Constrained Z Orbit command 

Ctrl + Left-click mouse Cycle select entities located below the cursor 

Ctrl + Shift + Hold and drag left mouse button Real-Time Zoom command 

Ctrl + Shift + Hold and drag middle mouse button 
(wheel) 

Alt + Shift + Hold and drag middle mouse button 
or 
Shift + Hold and drag middle mouse button 

Free Orbit command 

Constrained Orbit command 

Shift + Left-click mouse Deselect entities 

Shift + Right-click mouse Entity snap shortcut menu 
 

 

Shortcut Action 
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Mouse shortcuts 

 

 
Hold and drag left mouse button Move selected entities 

Right-click mouse Display shortcut menu for the selected entity 

Rotate mouse wheel Zoom In and Zoom Out commands 

Hold mouse wheel, then move mouse Real-Time Pan command 

Ctrl + Rotate mouse wheel when command bar 
is active 

Zoom in and out of the command bar 

 
 

 

Using keyboard shortcuts 
The following keyboard shortcuts start commonly used 4MCAD commands. To 

customize function keys, choose Tools > Function Keys, or choose Tools > Custom- 

ize and click the Keyboard tab. 
 

Keyboard shortcuts  

Command Typed Entry Shortcut Description 

Coordinate COORDINATE F6, Ctrl+D, 
Ctrl+I 

Switches coordinate display between On, 
Off, and Angle/Distance. 

Copy to Clipboard COPYCLIP Ctrl+C , 
Ctrl+J, 
Ctrl+M 

Copies selected entities to the Windows 
clipboard. 

Copy with Base 
Point 

COPYBASE Ctrl+Shift+C Copies selected entities to the Windows 
clipboard along with a base point. 

Cut to Clipboard CUTCLIP Ctrl+X Cuts selected entities from the active 
drawing and copies them into the Windows 
clipboard. 

Delete DELETE Del Removes the selected entities. 

Entity Snap ESNAP F3, Ctrl+F Turns entity snaps on and off. 

Entity Snap 
Tracking 

ENTTRACK F11 Switches entity snap tracking on and off 

Exit EXIT Alt+F4, 
Ctrl+Q 

Closes all drawings and exits 4MCAD. 

Grid GRID F7, Ctrl+G Turns the reference grid on and off. 

Help HELP F1 Starts online Help. 

Hyperlink HYPERLINK Crl+K Attaches hyperlinks to drawing entities. 

Isometric Plane ISOPLANE F5, Ctrl+E Switches the isometric plane between Top, 
Right, and Left. 

New Drawing NEW Ctrl+N Creates a new, blank drawing. 

Open Drawing OPEN Ctrl+O Displays the Open Drawing dialog box so 
you can open another drawing. 

Orthogonal ORTHOGONAL F8, Ctrl+L Switches the orthogonal mode on and off. 

Shortcut Action 
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Keyboard shortcuts  

Command Typed Entry Shortcut Description 

Pan PAN down Down Arrow Pans the drawing window view down by one 
unit. 

 PAN left Left Arrow Pans the drawing window view left by one 
unit. 

 PAN PGDown Page Down, 
Shift+Down 
Arrow 

Pans the drawing window view down by one 
screen. 

 PAN PGLeft Shift+Left 
Arrow 

Pans the drawing window view left by one 
screen. 

 PAN PGRight Shift+Right 
Arrow 

Pans the drawing window view right by one 
screen. 

 PAN PGUp Page Up, 
Shift+Up 
Arrow 

Pans the drawing window view up by one 
screen. 

 PAN Right Right Arrow Pans the drawing window view right by one 
unit. 

 PAN Up Up Arrow Pans the drawing window view up by one 
unit. 

Paste from 
Clipboard 

PASTECLIP Ctrl+V Pastes the contents of the Windows 
clipboard into the active drawing. 

Paste as Block PASTEBLOCK Ctrl+Shift+V Pastes the contents of the Windows 

   clipboard into the active drawing as a block. 

Polar Tracking POLARTRACK F10, Ctrl+U Switches polar tracking on and off 

Prompt History 
Window 

PMTHIST F2 Turns the Prompt History window on and off. 

Properties PROPERTIES Ctrl + 1 Displays or hides the Properties pane. 

Print PRINT Ctrl+P Prints the active drawing. 

Quick Save QSAVE Ctrl+S Saves the active drawing. 

Redo REDO Ctrl+Y Reverses the action of the last Undo. 

Save As SAVEAS Ctrl+Shift+S Saves the active drawing with the option to 
save it with a new name or file format. 

Select All SELGRIPS Ctrl+A Selects all entities in a drawing. 

Snap SNAP F9 
Ctrl+B 

Turns snap settings on and off. 

Start Page GOTOSTART Ctrl+Home Switches from the current drawing to the 
Start page. 

Undo U Ctrl+Z Reverses the last command action. 

VBA Editor VBA Alt+F11 Opens the Visual Basic for Applications 
editor so that you can create or modify a 
VBA macro. 

Window Close WCLOSE Ctrl+F4 Closes the active drawing window. 
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Using scripts 
The 4MCAD Script Recorder captures and saves many of your actions so you can 

play them back. After you enable the Script Recorder, all commands and options that 

you type in the command bar are recorded until you type a command to stop 

recording. When you run the script, the program carries out the recorded commands 

in succession. 

 
 

Correcting mistakes 
 

4MCAD tracks the commands you use and the changes you make. If you change 

your mind or make a mistake, you can undo, or reverse, the last action or several pre- 

vious actions. You can also redo any actions that you reversed. 
 

A B 

  
 

A Click Undo to reverse the last action. 

B Click Redo to reverse the previous undos. 

You can undo and redo multiple actions by choosing Undo and Redo from the ribbon 

toolbar to view and select a range of actions. You can also type undo and then specify 

the number of actions to undo. 

 
 

 

Customizing 4MCAD 
 

You can tailor many aspects of 4MCAD to better suit your needs. For example, you 

can easily create and modify toolbars by simply dragging and dropping icons. If you 

want to restore any area of the user interface back to its default state, click Reset. 

4MCAD stores your customized settings in the Windows registry; you can also store 

them in a separate file, called a profile. 

4MCAD supports the most important AutoCAD customization files, including 

linetypes, hatch patterns, text fonts, the unit conversion file, menus, toolbars, and 

aliases. In addition, 4MCAD unifies four AutoCAD customization functions with a 

single cui command: command aliases, keyboard shortcuts, menus, and toolbars. 

You can also add custom programs written in any of several programming languages, 

including the following: 

• IRX (similar to the Autodesk® ARX language) 

• LISP (the program’s Autodesk® AutoLISP-compatible language) 
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• SDS (similar to the Autodesk® ADS language) 

• DIESEL 

• Microsoft® Visual Basic for Applications (VBA) 

• .NET 

 

 

Getting online Help 
 

4MCAD includes online Help, which contains task-oriented topics, a command 

reference, a system variables reference, and a programming language reference. 

You can display online Help ( ) in any of these ways: 

• On the ribbon, choose Help, then choose a command. 

• On the Standard toolbar, click Help. 

• Press F1. 

• Choose a command from the Help menu. 

• Click the question mark in a dialog box. 

• Type help in the command bar. 

 

 

Saving a drawing 
 

You can save your drawing at any time. 

Use one of the following methods to choose Save ( ): 

• On the Quick Access toolbar of the ribbon, click Save. 

• On the ribbon Application button, choose Save. 

• On the Standard toolbar, click Save. 

• On the menu, choose File > Save. 

• Type save and then press Enter. 

When you save a drawing the first time, the program displays the Save Drawing As 

dialog box so that you can choose a directory and type a name for the drawing. To 

save the drawing later using another name, do the following: 

• Choose File > Save As and type the new name. 
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Exiting 4MCAD 
 

When you have finished working in 4MCAD: 

• On the ribbon Application button, choose Exit. 

• On the menu, choose File > Exit. 



 

 

 
 

 
 

 

Working with drawings 
 

CAD drawings help you organize information for greater efficiency. With 4MCAD, 

you can draw entities representing different types of information on various layers 

and use those layers to control color, linetype, and visibility. 4MCAD also includes 

drawing aids that help you draw accurately. 

This section explains setting up drawings and using built-in drawing aids, including 

how to: 

• Create new drawings, open existing drawings, and save changes to drawings. 

• Use aids such as the grid, snap, and orthogonal settings to draw accurately. 

 

 
 

 

 

 
 

 

 
 

 

 
 

 

   3 
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Creating a new drawing 
 

When you start 4MCAD, the program automatically creates a new drawing based on 

a template drawing, icad.dwt. This template includes predefined settings such as 

drawing units, text size, print style table type, and drawing area. You can either use 

these settings or change them according to your needs. There is nothing unique about 

a template drawing. You can use any drawing as a template for future drawings. 

You can save many steps by basing a new drawing on an existing template (.dwt file). 

By doing this, a new drawing will contain all the settings and entities you need. When 

you open a new drawing from your custom template, you can modify existing settings 

and delete any entities that you don’t need. When you save a drawing that was created 

using a template, you do not change the template. 
 

To create a new drawing 

1   Do one of the following: 

• On the Quick Access toolbar of the ribbon, click the New tool. 

• Type qnew and then press Enter. 

To create a new drawing based on a template 

1 Do one of the following: 

• On the ribbon Application button, choose New. 

• On the menu, choose File > New. 

• Type new or newwiz and then press Enter. 

2 Click Use A Template Drawing, and then click Next. 

3 To display the Open Template dialog box, click Browse. 

4 Select the template (.dwt) file that you want, and then click Open. 

You can also choose any drawing (.dwg) file to use as a template. 

5 Click Finish. 
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Opening a drawing 
 

You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files, Design 

Web Format(.dwf) files, and drawing template (.dwt) files. 

You can also open and check drawings that you suspect are damaged. 

 

Opening an existing drawing 
You can open any of these drawing files: 

• Standard drawing files with a .dwg extension. 

In addition to your own drawing files, you can open and use one of the sample 

drawings that are included with 4MCAD. 

• Drawing Exchange Format files with a .dxf file extension. 

• Design Web Format files with a .dwf file extension. 

• Drawing templates with a .dwt file extension. 
 

To open an existing drawing 

1 Use one of the following methods to choose Open (  ): 

• On the ribbon toolbar, click the Open tool. 

• On the menu, choose File > Open. 

• On the Standard toolbar, click the Open tool. 

• Type open and then press Enter. 

2 In Files of Type, choose the type of file you want to open. 

3 Choose the folder containing the desired file. 

4 Do one of the following: 

• Choose the drawing you want to open, and then click Open. 

• Double-click the drawing you want to open. 

If the drawing requires a password, enter the password, click OK to verify the 

password, and then click Open again. 

 
 

You can also open drawings while browsing files on your computer. 

Simply double-click the file or drag it to the drawing area in 4MCAD. Using pro- 

grams that came with your operating system, such as Windows File Explorer or My 

Computer, you can find the drawing you want by viewing thumbnail images of the 

drawing files as you browse them. If needed, choose Tools > Options and on the Gen- 

eral tab, click Set Files Association to specify which filetypes are associated with 

4MCAD. 
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A If a thumbnail image exists in the selected drawing, displays an 
image of the drawing before you open it. 

B Turns the drawing preview on or off. 

C Unavailable when opening drawings; available only when saving 
drawings. 

D Opens the drawing as read-only to prevent making changes to 
the file. 

E Displays a description of the file size, creation date, and other 
information about the drawing. 

F Click to see more options for working with files. 

G Defines how drawings display in the list, including file details and 
thumbnail images. 

 
 

 

The most recently opened drawings are tracked on the File menu for easy opening. 

Choose File > file name to quickly open a drawing file that you recently used. 
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Opening a damaged drawing 

Files can become damaged for many reasons. For example, if you are working on a 

drawing during a power outage, a system crash, or a hardware failure, your drawing 

file may become damaged. 4MCAD allows you to open and check damaged files to 

attempt file recovery. 

Recovering a file attempts to open one of the following file types: 

•  Standard drawing files with a .dwg extension. 

•  Drawing Exchange Format files with a .dxf file extension. 

•  Design Web Format files with a .dwf file extension. 

•  Drawing templates with a .dwt file extension. 

You can also audit any open file to check it for errors. You specify whether you want 

4MCAD to fix any errors that are found automatically. 4MCAD fixes as many 

errors as possible and any errors that cannot be fixed are reported as “Ignored” in the 

Prompt History window. 
 

To open a damaged file 

1 Use one of the following methods: 

• On the ribbon Application button, choose Drawing Utilities > Recover. 

• On the menu, choose File > Recover. 

• Type recover and then press Enter. 

2 In Files of Type, choose the type of file you want to recover. 

3 Choose the directory containing the damaged file. 

4 Choose the damaged file you want to recover. 

5 Click Open. 
 

If you want to check all drawings for errors automatically when you open them, 

choose Tools > Options > General tab and mark the check box for Open Drawings 

using Recover. 
 

To check a drawing file for errors 

1 With the drawing open that you want to check, do one of the following: 

• On the ribbon Application button, choose Drawing Utilities > Audit. 

• On the menu, choose File > Audit. 

• Type audit and then press Enter. 

2 Choose whether you want 4MCAD to fix any found errors automatically, and 

then press Enter. 
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An ASCII file describes the audit. 

If the AUDITCTL system variable is set to On and errors are found during a file 

recovery or audit, an ASCII file is created that describes the audit. The ASCII file is 

saved in the same folder as the audited drawing and has the same name as the draw- 

ing file, but with an .adt extension. 
 

 

 

 

 

Setting up a drawing 
 

You can specify individual settings when you create a new drawing or when you 

modify settings in a drawing created from a template. 

 

Setting the current layer 
Layers are like the overlays that you use in manual drafting. You use layers to orga- 

nize different types of drawing information. Every drawing has at least one layer, the 

default layer, named “0.” Your drawing can also contain an unlimited number of 

additional layers. When you create an entity, it is created on the current layer. 
 

To set the current layer 

1 Do one of the following to choose Explore Layers (  ): 

• On the ribbon, choose Home > Layers (in Layers). 

• On the menu, choose Format > Explore Layers. 

• On the Format toolbar, click the Explore Layers tool . 

• Type explayers and then press Enter. 

• Type la and then press Enter. 

2 Double-click the layer name that you want to make current. 

3 Close the 4MCAD Explorer window. 
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Double-click the layer name that you want to make current. 

 
 

Use the status bar shortcut. 

On the status bar, right-click the current layer control, and from the list, select the 

layer you want to make current. 
 

 

 
 

Use the layer of an entity you select to set the current layer. 

Type LAYBYENT in the command bar, choose Set, and select the entity with the layer 

you want to be current. 
 

 

 

Setting the current entity color 
An entity’s color determines how it is displayed and, if you are using a color printer, 

how it prints. Entities are created in the current color. 

When you open a new drawing, entities are created in the color BYLAYER, which 

adopts the color of the current layer. Initially, layer 0 is both the only layer and the 

current layer. Its default color is white, so your entities appear as white. 

There are index colors, which contain two additional color properties that are often 

referred to as colors, true colors, and color book colors. The two additional color 

properties are BYLAYER and BYBLOCK. These color properties cause an entity to 

adopt the color either of the layer or of the block in which it is a member. 
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To set the current entity color 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Entity Creation tab. 

3 Click Select Color. 

4 In the Color dialog box, click one of the following tabs and select a color: 

• Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. 

You can also type the color number in the Index box. 

• True Color — Click a basic color, click a color in the color palette, enter the Hue, 

Saturation, and Luminance (HSL) values, or enter the Red, Green, Blue (RGB) 

values. There are more than 16 million true colors from which you can choose. 

• Color Books — Select a color book from the list, then click a color. You can 

select Show Only Color Book Colors Used in Drawing to limit the selection to 

only those color book colors that are used in the current drawing. 

5 Click OK. 

6 Click OK again. 

 
 

Use the status bar shortcut. 

On the status bar, right-click the current color, and select from the list the color you 

want to use for new entities. You can also click Select Color to choose additional col- 

ors. 
 

 

 

For more details about using color in the many aspects of your drawing, see “Work- 

ing with colors” on page 68 in this chapter. 

 

Setting the current linetype 
Linetypes help convey information. You use different linetypes to differentiate the 

purpose of one line from another. A linetype consists of a repeating pattern of dots, 

dashes, or blank spaces. Linetypes determine the appearance of entities both on the 

screen and when printed. By default, every drawing has at least three linetypes: CON- 

TINUOUS, BYLAYER, and BYBLOCK. Your drawing may also contain an unlim- 

ited number of additional linetypes. 
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When you create an entity, it is created using the current linetype. By default, the cur- 

rent linetype is BYLAYER. 4MCAD indicates that the entity linetype is deter- mined 

by the current layer’s linetype by assigning the BYLAYER property as the default 

linetype setting. When you assign BYLAYER, changing a layer’s linetype changes 

the linetype of all the entities assigned that layer (if they were created using the 

linetype BYLAYER). 

You can also select a specific linetype as the current linetype, which overrides the 

layer’s linetype setting. Entities are then created using that linetype, and changing the 

layer linetype has no effect on them. 

As a third option, you can use the linetype BYBLOCK property, in which case new 

entities are drawn using the CONTINUOUS linetype until you group them into a 

block. The entities then inherit the block’s linetype setting when you insert the block 

into a drawing. 
 

To set the current linetype 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Entity Creation tab. 

3 In the Linetype list, choose the linetype that you want to make current. 

4 Click OK. 

 
 

Use the status bar shortcut. 

On the status bar, right-click the word BYLAYER for the current linetype, click Prop- 

erties, and then choose the linetype that you want to make current. 
 

 

 

Setting the linetype scale 
You can specify the linetype scale. The smaller the scale, the more repetitions of the 

linetype pattern are generated per drawing unit. For example, a linetype pattern is 

defined as a sequence of dashed lines and open spaces, each 0.25 units long. The line- 

type scale uses the drawing scale factor to determine the length. A scale factor of 0.5 

would reduce the length of each line and space to 0.125 units; a scale factor of 2 

would increase the length of each to 0.5 units. 

Note that setting the linetype scale too large or too small may result in a line pattern 

looking like a solid line, depending on what the scale view is or at what scale the 

drawing is printed. 
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You can control a new entity’s individual linetype scale factor as well as the overall 

or global scale factor applied to all the entities in the drawing. If you use annotation 

scaling for entities such as text and dimensions, you can also set up linetype scaling to 

coordinate with various annotation scaling scenarios. 
 

To set the current individual linetype scale 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Entity Creation tab. 

3 In the Linetype Scale field, type or choose the linetype scale that you want to 

make current. 

4 Click OK. 
 

To change the global linetype scale 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Entity Creation tab. 

3 In the Global Linetype Scale field, type or choose the global linetype scale that 

you want to change. 

4 Click OK. 
 

To set up linetype scaling to be the same in model space and paper space 

1 Set the global linetype scale (mentioned previously) to the drawing scale. For 

example, enter .25 for the scale factor 1/4" - 1". 

2 Type PSLTSCALE and press Enter, then enter 0 to turn this system variable off. 

Customized linetype scaling specific to paper space will be turned off. 

3 Type MSLTSCALE and press Enter, then enter 0 to turn this system variable off. 

Customized linetype scaling specific to model space will be turned off. 
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To set up linetype scaling to be different in model space and paper space 

1 Set the global linetype scale (mentioned previously) to 1. This sets the default 

linetype scale factor to be the same as the drawing scale. 

2 Type PSLTSCALE and press Enter, then enter 1 to turn this system variable on. 

Customized linetype scaling specific to paper space will be turned off. 

3 Type MSLTSCALE and press Enter, then enter 1 to turn this system variable on. 

Customized linetype scaling specific to model space will be turned off. 

4 For drawings that also use annotation scaling, do the following: 

• On the status bar, right-click Annotations Scales List. 

• Choose the current annotation scale, for example 1/4" - 1". This makes the 

linetype scale set to the annotation scale. 

 
 

Linetypes will be the same for all viewports that have the same annotation scale. 

Setting up linetype scaling so it can be different in model space and paper space is 

the preferred method for drawings with details, profiles, or plan views that are not 

always the same scale. Paper space viewports will look and print as intended, and 

you can adjust the model space annotation scale for it to match the display in 

paper space. For more information about annotation scaling, see “Understanding 

scale factors” on page 61 in this chapter. 
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Setting the current lineweight 
Lineweights help differentiate the purpose of one line from another. Lineweights 

determine how thick or thin entities appear both on the screen and when printed. 

Every drawing has these lineweights: DEFAULT, BYLAYER, BYBLOCK, and 

many additional lineweights in millimeters (or you can use inches). 

When you create an entity, it is created using the current lineweight. By default, the 

current lineweight for a new entity is BYLAYER. This means that the entity line- 

weight is determined by the current layer. When you assign BYLAYER, changing a 

layer’s lineweight changes the lineweight of all the entities assigned that layer (if they 

were created using the lineweight BYLAYER). 

You can also select a specific lineweight (or DEFAULT) as the current lineweight, 

which overrides the layer’s lineweight setting. Entities are then created using that lin- 

eweight (or the DEFAULT lineweight), and changing the layer lineweight has no 

effect on them. 

As a third option, you can use the lineweight BYBLOCK property, in which case new 

entities are drawn using the DEFAULT lineweight until you group them into a block. 

The entities then inherit the block’s lineweight setting when you insert the block into 

a drawing. 

If you choose a lineweight that is less than .025 millimeter, it displays as one pixel 

when you create your drawing. When you print your drawing, it prints at the thinnest 

lineweight that is available for your printer. 

You cannot assign lineweights to planes, points, TrueType fonts, or raster images (if 

supported in your version of 4MCAD). 
 

To set the current lineweight 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings or choose Tools > Lineweight. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Entity Creation tab. 

3 In the Lineweight list, choose the lineweight that you want to make current. 

4 Click OK. 

 
 

Use the status bar shortcut. 

On the status bar, right-click the word BYLAYER for the current lineweight, and then 

choose the current lineweight. You can also double-click the word LWT to toggle the 

display of lineweights on and off. 
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Lineweights need to be turned on to be visible. 

To see lineweights in your drawing, you may need to turn on their visibility. For 

details, see “Displaying lineweights” on page 228. 
 

 

 

Setting the current print style 
Print styles are used to change the appearance of an entity when it prints, without 

actually changing the entity in the drawing. 

If your drawing uses named print style tables, you can specify a print style for any 

entity. Named print style tables contain print styles that you set up. If your drawing 

uses color-dependent print style tables, the print style is BYCOLOR, which cannot be 

changed. These types of print style tables determine printing requirements by the 

color assigned to an entity or layer. For details about converting a drawing that uses 

color-dependent print style tables to use named print style tables, see “Changing the 

print style table type of a drawing” on page 555. 

When you create an entity in a drawing that uses named print style tables, the entity is 

created using the current print style. By default, the current print style is BYLAYER. 

When you assign BYLAYER, changing a layer’s print style changes the print style of 

all the entities assigned that layer if they were created using the print style 

BYLAYER. 

You can also select a specific print style as the current print style, which overrides the 

layer’s print style setting. Entities are then created using that print style, and changing 

the layer print style has no effect on them. 

As a third option, you can use the print style BYBLOCK, in which case new entities 

use the Normal print style until you group them into a block. The entities then inherit 

the block’s print style setting when you insert the block into a drawing. 
 

To set the current print style in a drawing that uses named print style tables 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Entity Creation tab. 

3 In the Print Style list, choose the print style that you want to make current. If nec- 

essary, choose Other and then select a print style. 

4 Click OK. 
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Use the status bar or command bar shortcut. 

On the status bar, right-click the word BYLAYER for the current print style, click 

Other, and then choose the print style that you want to make current. Or, 

type printstyle to choose the current print style. 
 

 

 

Setting drawing units 
With 4MCAD, you typically draw at full-size (1:1 scale), and then set a scale fac- tor 

when you print or plot your drawing. Before you begin drawing, however, you need 

to determine the relationship between drawing units and real-world units. 

For example, you can decide whether one linear drawing unit represents an inch, a 

foot, a meter, or a mile. In addition, you can specify the way the program measures 

angles. For both linear and angular units, you can also set the degree of display preci- 

sion, such as the number of decimal places or smallest denominator used when dis- 

playing fractions. The precision settings affect only the display of distances, angles, 

and coordinates. 4MCAD always stores distances, angles, and coordinates using 

floating-point accuracy. 
 

To set the linear drawing units 

1 Do one of the following to choose Drawing Settings ( ): 

• On the ribbon, choose Application button > Drawing Utilities; Application 

Button > Drawing Utilities > Drawing Units; Home > Drawing Settings (in 

Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Drawing Units tab. 

3 Click the Linear Units tab. 

4 Under Unit Types, select a unit type. 

5 Under Display Precision, type the display precision according to the number of 

decimal places you want, or click the arrows to select it. 

The field above this setting shows an example of the linear unit type at the current 

precision. 

6 Click OK. 
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A Determines the type of units you are controlling. 

B Select the type of linear units. 

C Choose the display precision for linear units. 

 

To set the angular drawing units 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Drawing Units tab. 

3 Click the Angular Units tab. 

4 Under Unit Types, select a unit type. 

5 Under Display Precision, type the display precision according to the number of 

decimal places you want, or click the arrows to select it. 

The field above this setting shows an example of the angular unit type at the cur- 

rent precision. 
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6 Under Angle Direction, select the direction in which angles increase when you 

specify a positive angle value. 

7 Under Angle Base, specify the compass location for the zero angle. 

For example, by default, angle 0 is at the “three o’clock” or “east” position. 

The adjacent icon shows the current location of the angle base. 

8 Click OK. 
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A Determines the type of units you are 

controlling. 

B Select the type of angular units. 

C Choose the display precision for angular units. 

D Select the angle base, the direction of the zero 
angle. 

E Select the direction in which angles increase. 



W O R K I N G   W I T H   D R A W I N G S 65 
  

 

 
Understanding scale factors 
Instead of drawing to a particular scale, you draw everything in the program full-size. 

Although it’s a good idea to keep your scale factor in mind when setting up a draw- 

ing, you don’t need to set the scale until you print it. For example, when you draw a 

mechanical part 40 inches in length with 4MCAD, you actually draw it as 40 inches, 

rather than applying a scale factor as you draw. When you print your drawing, you 

can assign the scale at which the drawing is to print. 

Scale, however, does affect the way a few elements such as text, arrows, or linetypes 

print or plot and even display in your drawing. You can set up annotation scaling to 

control the scale of entities such as text, arrows, and linetypes, or you can make man- 

ual adjustments when you first set up your drawing so that annotations print and dis- 

play at the correct size. For example, when you draw text, you need to determine the 

text size so that when you print it later at a particular scale, the text height is correct. 

After you determine the eventual scale of your finished drawing, you can calculate 

the scale factor for the drawing as a ratio of one drawing unit to the actual scale unit 

represented by each drawing unit. For example, if you plan to print your drawing at 

1/8” = 1’-0”, your scale factor ratio is 1:96 (1/8” = 12” is the same as 1 = 96). If you 

want your printed scale to be 1 inch = 100 feet, your scale factor ratio is 1:1200. 

The following table shows some standard architectural and engineering scale ratios 

and equivalent text heights required to create text that measures 1/8-inch high when 

you print the drawing at the specified scale. 

 
Standard scale ratios and equivalent text heights 

 

Scale Scale factor Text height 

1/16” = 1’-0” 192 24” 

1/8” = 1’-0” 96 12” 

3/16” = 1’-0” 64 8” 

1/4” = 1’-0” 48 6” 

3/8” = 1’-0” 32 4” 

1/2” = 1’-0” 24 3” 

3/4” = 1’-0” 16 2” 

1” = 1’-0” 12 1.5” 

1 1/2” = 1’-0” 8 1” 

3” = 1’-0” 4 0.5” 

1” = 10’ 120 15” 

1” = 20’ 240 30” 

1” = 30’ 360 45” 

1” = 40’ 480 60” 
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Standard scale ratios and equivalent text heights 

 

Scale Scale factor Text height 

1” = 50’ 600 75” 

1” = 60’ 720 90” 

1” = 100’ 1200 150” 

 

You can use these scale factors to predetermine the size of your drawing to make sure 

that it fits on a specific size paper when you print it. You control the size of your 

drawing by the drawing limits. To calculate the drawing limits to match the size of 

your paper, multiply the dimensions of your paper size by your scale factor. 

For example, if the paper you use to print measures 36 inches x 24 inches and you 

print your drawing at 1/8” = 1’-0” (in other words, using a scale factor of 96), the size 

of your drawing measured in drawing units is 36 x 96 (or 3,456 units) wide and 24 x 

96 (or 2,304 units) high. 

Keep in mind that you can print the finished drawing at any scale, regardless of the 

scale factor you calculate. You can also print on paper of a different size and use the 

Layout tabs to create different views of your drawing and to position and scale those 

views differently. The scaling factor is not related to the size of the entities you draw; 

it simply provides a preliminary guide to help you establish the text height and draw- 

ing limits when you begin your drawing. You can change the text height and drawing 

limits at any time. 

 

Setting up annotation scaling 
Annotation scaling allows you to control individual entities so their size will consis- 

tently display when a drawing is displayed or printed at different scales. You don’t 

have to use annotation scaling, but it is a convenient way to control the scaling of the 

following entities: text, tolerances, dimensions, leaders, multileaders, attributes, 

hatches, and blocks. 

These individual entities can be annotative, and so can text styles, dimension styles, 

and multileader styles; text, dimensions, or multileaders assigned an annotative style 

will have annotation scaling turned on by default. 

4MCAD comes ready to use annotation scaling, however, you may want to cus- 

tomize some of the settings according to your needs. 

 
Customizing the scales list 
The scales list defines all of the scales that are available to assign to annotative enti- 

ties. For example, to assign an annotation scale to a text entity, you choose it from the 

scales list. The scales list displays when you do any of the following: 

• Set the current annotation scale — On the status bar, right-click Annotations 

Scales List. 

• Assign an annotation scale to an entity — Select an entity and use the Properties or 

Entity Scale command. 
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•  Print — Choose the Print command. 

After you set up your scales list, you may want to create a drawing template with the 

default scales or export your scale list so you can easily import the list into other 

drawings. 
 

To customize the scales list 

1 Do one of the following to choose Scale List (  ): 

• On the ribbon, choose Annotate > Scale List (in Annotation Scaling). 

• On the menu, choose Format > Scale List. 

• On the status bar, click Annotation Scales List. 

• Type scalelistedit and then press Enter. 

2 To add a scale to the list, do the following: 

• Click Add. 

• Enter the name of the scale, which will appear in the list. 

• Enter the paper units to drawing units ratio. 

• Click OK. 

3 Do any of the following to further customize the list: 

• Select a scale and click Modify to change a scale’s name or ratio. 

• Select a scale and click Delete to remove it from the list. 

• Select a scale and click Move Up or Move Down to reposition it in the list. 

4 Optionally click Export to save your scales list to a file that you can easily import 

into other drawings. 

5 Click OK. 
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A Displays the scales available for annotative 

entities. 

B Click to save the scales list to a file. 

C Click to open and load a scales list from a file. 

D Click to remove all unused scales from the list. 

E Click to remove the selected scale. 

 
F Click to move the selected scale down one 

position in the list. 

G Click to move the selected scale up one position 
in the list. 

H Click to modify the selected scale. 

I Click to create a new scale and add it to the list. 

 
 

Purging unused annotation scales can increase performance. 

Older drawings from other CAD programs can sometimes have thousands of unused 

annotation scales. Click Purge in the Edit Drawing Scales dialog box to remove 

unused annotation scales and increase performance. 
 

 

 
Customizing styles to be annotative 
Text styles and dimension styles determine whether text and dimension entities that 

are assigned those styles are annotative by default. Multileader styles can also be 

annotative, but 4MCAD only supports the display of multileaders, not the creation of 

multileaders or multileader styles. 

For text styles, see “Working with text styles” on page 407. 

For dimension styles, see “Controlling dimension fit” on page 456. 
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Setting up automatic annotation scaling 
Automatic annotation scaling automatically assigns the current annotation scale to 

annotation entities that have annotation scaling turned on. 
 

To set automatic annotation scaling and the current annotation scale 

1 On the status bar, click Automatic Annotation On/Off. 

2 On the status bar, click Annotations Scales List. 

3 Choose the current annotation scale. 

 

Setting the text height 
The text height setting controls the height of text, measured in drawing units. Set this 

value initially so that text used for your most common annotations, when scaled to the 

size at which you will print a drawing, measures 1/8-inch high on the printed draw- 

ing. 

For example, if you plan to print your drawing at 1/8” = 1’-0” and you want your text 

to be 1/8-inch high in the final drawing, create that text 1 foot high (in your real- 

world drawing units) so that when you print it, it appears 1/8-inch high on the paper. 

You must create text 4 feet high that you want to print 1/2-inch high. 
 

To set the text height 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Entity Creation tab. 

3 Click the Text tab. If necessary, click the right arrow to scroll the tabs horizontally 

to view the Text tab. 

4 In the Default Text Height field, select the text height or type the text height value 

that you want. If you have chosen an annotative text style, you enter the paper text 

height. 

5 Click OK. 
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A Choose Text. B Specify the text height in drawing units. 

 
 

The default text height applies only if the current text style height is 0.0. 

Otherwise, the text height for the current style takes precedence. 
 

 

 

Setting the drawing limits 
You can specify the drawing limits that form an invisible boundary around your 

drawing. You can use the drawing limits to make sure that you do not create a draw- 

ing larger than can fit on a specific sheet of paper when printed at a specific scale. 

For example, if you plan to print your drawing at 1/8” = 1’-0” (in other words, using a 

scale factor of 96) on a sheet of paper measuring 36 inches x 24 inches, you can set 

drawing limits to 3,264 units wide (that is, 34 x 96) and 2,112 units high (22 x 96), 

which allows a 1-inch margin around the edges of the printed image. 
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To set the drawing limits 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click either the Coordinate Input tab or the Display tab. 

3 Click the Limits tab. 

4 Specify the x-coordinate and y-coordinate of the upper right drawing limit and the 

lower left drawing limit. 

You can also click Select to specify the drawing limits by selecting points in the 

drawing. 

5 To constrain your drawing to these drawing limits, click the Disallow Input 

Beyond Limits check box. 

6 Click OK. 
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A Choose Limits. 

B Specify the x-coordinate and y-coordinate of the 
upper right drawing limit. 

C Specify the x-coordinate and y-coordinate of the 
lower left drawing limit. 

D When selected, the program prevents you from 
drawing outside the drawing limits. 

E Specify the drawing limits by selecting points in 
the drawing. 
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Working with colors 
 

An entity’s color determines how it is displayed and, if you are using a color printer, 

how it prints. Entities are created in the current color specified for the drawing. 

Layers can also control the color of entities. When you open a new drawing, entities 

are created in the color BYLAYER, which adopts the color of the current layer. Ini- 

tially, layer 0 is both the only layer and the current layer. Its default color is white, so 

your entities appear as white. 

For entities and layers in 4MCAD, there are three different types of colors: 

• Index colors 

• True colors 

• Color book colors 

 
 

True colors and color books are unavailable in some cases. 

For example, for dimension entities and cursor display. 
 

 

 

You can choose colors by selecting them from the Color dialog box. In the command 

bar or in some dialog boxes, you specify a color either by name or by number. 

 

Using index colors 
There are 255 standard index colors and two additional color properties that are often 

referred to as colors (BYLAYER and BYBLOCK). You can use seven of the 255 

standard index colors by name: red, yellow, green, cyan, blue, magenta, and white. 

(Numbers eight and nine are not named.) Each index color has a unique number from 

1 to 255. The two additional color properties are BYLAYER and BYBLOCK. These 

color properties cause an entity to adopt the color either of the layer or of the block in 

which it is a member. BYLAYER is color number 256, and BYBLOCK is color num- 

ber 0. In all commands for which you would use a color, you can indicate BYLAYER 

and BYBLOCK as well as by numbers 256 and 0, respectively. 
 

To select an index color 

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 

Properties, or Multiline Text. 

The Color dialog box opens. 

2 Click the Index Color tab. 

3 Do one of the following: 

• Click BYBLOCK. 

• Click BYLAYER. 

• Click the color of your choice, or type the color number in the Current box. 

4 Click OK. 
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A Click to select one of the standard colors. 

B Click to select one of the gray shades. 

D E 

D Indicates the current color. 

E Displays the color number, or enter the color 

C Click to select any one of the available index 
colors. 

 

 

Using true colors 

number. 

F Click to set the color to BYLAYER. 

G Click to set the color to BYBLOCK. 

There are more than 16 million true colors from which you can choose. True colors 

are defined using 24-bit color. 

Even with so many colors available, you can quickly choose a color from the display 

of basic colors or by clicking the color palette. Alternatively, if you know the values 

used to define the desired color, you can enter the Hue, Saturation, and Luminance 

(HSL) values, or you can enter the Red, Green, Blue (RGB) values. 
 

To select a true color 

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 

Properties, or Multiline Text. 

The Color dialog box opens. 

2 Click the True Color tab. 

A 

 
B G 

F 

C 
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3 Do one of the following: 

• Click a basic true color. 

• Click a true color in the color palette. 

• Enter HSL values for the desired true color. 

• Enter RGB values for the desired true color. 

4 Click OK. 

 

 

 

 

 
 

A Click to select one of the basic true colors. 

B Click to select one of the custom true colors, if 
any are defined. 

C Click to add the selected color to the custom 
color area. 

D Enter (or view) the amount of red, green, and 
blue of the desired true color. 

E Enter (or view) the amount of hue, saturation, 
and luminance of the desired true color. 

F Slide or click to adjust the color luminance. 

G Click to select a true color in the color palette. 
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Using color books 
4MCAD uses color books to store collections of colors. For example, you can store a 

unique color scheme for a client in a color book and then use colors only from that 

color book for the client’s drawings. 

 

Selecting a color book color 

To select a color book color 

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 

Properties, or Multiline Text. 

The Color dialog box opens. 

2 Click the Color Books tab. 

3 Select a color book from the list. 

4 If you want to narrow your color search, do one of the following: 

• In the list of colors, select a color book page, if one is available. Pages are partic- 

ularly helpful in large color books — they help group colors so you can find 

them quickly. 

• Select Show Only Color Book Colors Used in Drawing. Only those color book 

colors that are used in the current drawing will display in the list. 

5 Select the desired color. 

6 Click OK. 
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A Select a color book. 

B Click to select a color book color. 

C Select to list only those color book colors that are 
used in the current drawing. 

 

Creating color books 

D Click to create and modify color books. 

E Displays the selected color and its RGB values. 

You may have a color book given to you by a client, developed by a third-party, or 

you can create your own. Each color book has an .acb extension and is saved auto- 

matically in Extensible Markup Language (XML) format. 
 

To create a color book 

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 

Properties, or Multiline Text. 

The Color dialog box opens. 

2 Click the Color Books tab. 

3 Click Color Book Editor. 

4 In the Color Book Editor dialog box, click the New tool (   ). 

5 In Color Book Name, enter the name of the color book. This name will appear in 

the list of color books on the Color Books tab in the Color dialog box. 
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6 Do the following to define organizational pages in the color book: 

• In the contents of the color book, click an existing page or color where you want 

to add a page. 

• Define a color in the palette. 

• Enter the name of the page, and then click Add Page. 

7 Do the following to define colors in the color book: 

• In the contents of the color book, click an existing page or color where you want 

to add a color. 

• Define a color in the palette. 

• Enter the name of the color, and then click Add Color. 

8 Do any of the following to change existing pages and colors in the color book: 

• Modify pages and colors — Select a page or color in the color book, define its 

new color settings in the palette, enter any changes to its name, and then click 

Modify. 

• Delete pages and colors — Select a page or color in the color book, and then 

click Delete. 

• Rearrange pages and colors — Select a page or color in the color book, and then 

click the up arrow (  ) or down arrow (  ). 

9 In the Color Book Editor dialog box, click the Save tool (  ). 

10 Enter a filename for the color book, and then click Save. 

By default, the file is saved in the default folder where 4MCAD searches for 

color books. 
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A Click New to create a color book; click Open to 
open a color book; click Save to save the color 
book; click Save As to save the color book with a 
new filename. 

B Select a page or color to modify, delete, or 
reorder it, or to view its settings. 

C Click to create a new page in the color book 
using the current color settings. 

D Click to create a new color in the color book 
using the current color settings. 

E Click to delete the selected page or color from 
the color book. 

F Click to redefine the selected page or color to 
use the current color settings. 

G Click to move the selected page or color up or 
down one position in the color book. 

H Enter the name of the page or color as you want 
it to appear in the color book. 

I Enter (or view) the amount of red, green, and 
blue of the desired color. 

J Enter (or view) the amount of hue, saturation, 
and luminance of the desired color. 

K Slide or click to adjust the color luminance. 

L Click to select a color. 

M Enter the name of the color book. 
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Modifying color books 
You can modify your own color books and the color books that came with 4MCAD. If 

you modify a color book that came with 4MCAD, it is recommended that you save it 

with a new filename first so the original color book is not overwritten. 
 

To modify a color book 

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 

Properties, or Multiline Text. 

The Color dialog box opens. 

2 Click the Color Books tab. 

3 Select the color book you want to modify. 

4 Click Color Book Editor. 

5 In Color Book Name, enter any changes to the color book name. This name 

appears in the list of color books on the Color Books tab in the Color dialog box. 

6 Do any of the following to modify pages or colors in the color book: 

• Add pages — In the contents of the color book, click an existing page or color 

where you want to add a page. Define a color in the palette, enter the name of 

the page, and then click Add. 

• Add colors — In the contents of the color book, click an existing page or color 

where you want to add a color. Define a color in the palette, enter the name of 

the color, and then click Add. 

• Modify pages and colors — Select a page or color in the color book, define its 

new color settings in the palette, enter any changes to its name, and then click 

Modify. 

• Delete pages and colors — Select a page or color in the color book, and then 

click Delete. 

• Rearrange pages and colors — Select a page or color in the color book, and then 

click the up arrow (  ) or down arrow (  ). 

7 Do one of the following to save the color book: 

• To save the color book with the same filename, click the Save tool (  ) in the 

Color Book Editor. 

• To save the color book with a new filename or in a new location, click the 

Save As tool ( ) in the Color Book Editor. 
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Loading color books 
If you have a color book given to you by a client or developed by a third-party, sim- 

ply save it on your computer in a folder where 4MCAD can find it. By default, color 

books are stored in following folder: \Documents and Settings\YourName\My 

Documents\Color Books. 
 

To load a color book 

1 Save the color book in the folder where 4MCAD searches for color books. 

To verify the folder location, choose Tools > Options, click the Paths/Files tab, 

and find the Color Book folder in the Paths list. 

2 In a Color dialog box, click the Color Books tab. 

The previously loaded color book displays in the list of color books. 
 
 

 

Using the grid, snap alignment, and cursor restriction 
 

Grid and snap settings are effective tools to use in your drawing to ensure accuracy. 

Although many users find it convenient to match grid points to snap settings, they are 

independent of each other and should not be confused. Grid points are for visual ref- 

erence only; they do not affect your drawing and they do not print. Snap points are, 

by themselves, not visible; however, when set, they constrain the creation of new 

entities. 

In addition, the cursor can be restricted to move orthogonally only or guides can dis- 

play on the screen automatically at specified polar angle increments. 

 

Setting a reference grid 
A reference grid displays as a pattern of regularly spaced dots or lines. You can turn 

the grid on and off, and you can specify how far apart the dots or lines are spaced. 

By default, the reference grid displays as lines, and it is adaptive (it proportionately 

scales according to the zoom ratio), helping you to align entities and visualize dis- 

tances between entities. If desired, the grid can be constrained to only display within 

the limits of the drawing. 
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To turn the grid on or off and set the grid spacing 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Coordinate Input tab. 

3 Click the Snap and Grid tab. 

4 Click the Grid On check box to turn the grid on or off. 

5 Under Grid Spacing, in the X field, choose the horizontal grid spacing. 

6 Under Grid Spacing, in the Y field, choose the vertical grid spacing. 

7 Click OK. 

 
 

Use the shortcuts for toggling the grid display on and off. 

Double-click the GRID setting on the status bar, click the Reference Grid tool ( ) 
on the Settings toolbar, or press F7. 
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A Click to enable orthogonal mode. 

B Click to enable crosshairs locking to the nearest 
snap point. 

C Click to enable snap mode. 

D Specify the x and y snap spacing. 

E Specify the polar snap spacing (available if Snap 
Type is set to Polar). 

F Select whether to use standard grid snapping 
(Grid) or to use polar snapping (Polar). 

G Click to use a rectangular or isometric snap. If 
isometric, select the initial isoplane: top, left 
(default), or right. 

H Specify the x- and y-coordinates of the snap 
origin. 

I Specify the snap rotation angle. The grid will 
display rotated to match the snap setting. 

J Click to display a dotted grid for paper sheets 
and layouts (Layout tabs); otherwise a lined grid 
displays. 

K Click to display a dotted grid for model space 
(Model tab); otherwise a lined grid displays. 

L Click to display the grid beyond the limits area. 

M Click to split the grid if the zoom level is smaller 
than the grid unit (available if adaptive grid is 
turned on). 

N Click to enable an adaptive grid, which 
proportionally scales according to the zoom 
ratio. 

O Enter the number of minor grid lines to display 
for every major grid line. 

P Specify the x and y grid spacing. 

Q Click to display the reference grid. 
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Setting snap spacing 
Another way to ensure drawing accuracy is to turn on and set snap spacing. When 

snap is turned on, the program restricts the selection points to predetermined snap 

intervals. Although it is often helpful to match the snap spacing to some interval of 

the grid spacing or another related setting, the settings do not have to match. 
 

To turn snap settings on and set snap spacing 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Coordinate Input tab. 

3 Click the Snap and Grid tab. 

4 Click the Snap On check box to turn Snap on. 

5 Under Snap Spacing, in the X field, choose the horizontal snap spacing. 

6 Under Snap Spacing, in the Y field, choose the vertical snap spacing. 

7 Click OK. 

 
 

Use the shortcuts for toggling the snap settings on and off. 

Double-click the SNAP setting on the status bar or press F9. 
 

 

 

In addition to setting the snap spacing, you can change the snap and grid orientation. 

You can also rotate the alignment of the grid or set it to create isometric drawings. 
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Changing the snap and grid angle and base point 
The snap and grid are both normally based on the drawing origin, the 0,0 coordinate 

in the World Coordinate System (WCS). You can relocate the snap and grid origin, 

however, to help you draw entities in relation to a different location. You can also 

rotate the grid to a different angle to realign the crosshairs to the new grid angle. If the 

grid is on, and the grid spacing is 0,0, then the grid defaults to the snap spacing. 
 

To change the snap angle and base point 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Coordinate Input tab. 

3 Click the Snap and Grid tab. 

4 Click the Snap On check box to turn Snap on. 

5 Click the Grid On check box to turn Grid on. 

6 In Snap Basepoint, type the x-coordinate and y-coordinate of the new snap origin. 

7 In Rotation, type the snap rotation angle, which also changes the display of the 

grid. 

8 Click OK. 

 
 

  
 

Default grid and snap alignment. Rotated grid and snap alignment. 
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Using isometric snap and grid 
You can use the Isometric Snap and Grid option to create two-dimensional isometric 

drawings. With the isometric option, you are simply drawing a simulated three- 

dimensional view on a two-dimensional plane, much the same as you might draw on 

a piece of paper. Do not confuse isometric drawings with three-dimensional draw- 

ings. You create three-dimensional drawings in three-dimensional space. 

The isometric option always uses three preset planes, which are denoted as left, right, 

and top. You cannot alter the arrangement of these planes. If the snap angle is 0, the 

three isometric axes are 30 degrees, 90 degrees, and 150 degrees. 

When you use the Isometric Snap option and select an isometric plane, the snap inter- 

vals, grid, and crosshairs align with the current plane. The grid is always shown as 

isometric and uses y-coordinates to calculate the grid spacing. If you click the Draw 

Orthogonal check box, the program restricts the drawing of entities to the current iso- 

metric plane. 

 
 

Use the shortcut to toggle between isometric planes. 

Press F5. 
 

 

 
To turn the Isometric Snap and Grid option on 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Coordinate Input tab. 

3 Click the Snap and Grid tab. 

4 Click the Snap On check box to turn Snap on. 

5 Click the Grid On check box to turn Grid on. 

6 Under Snap Type, choose Isometric, then choose the option for the initial isomet- 

ric plane you want (Top, Left, or Right). 

7 Click OK. 
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Isometric planes left (A), right (B), top (C). 
 

Using orthogonal locking 
You can restrict cursor movement to the current horizontal and vertical axes so that 

you can draw at right angles, or orthogonally. For example, with the default 0-degree 

orientation (angle 0 at the “three o’clock” or “east” position), when the Draw Orthog- 

onal option is enabled, lines are restricted to 0 degrees, 90 degrees, 180 degrees, or 

270 degrees. As you draw lines, the rubber-banding line follows either the horizontal 

or vertical axis, depending on which axis is farthest from the cursor. When you 

enable the isometric snap and grid, cursor movement is restricted to orthogonal 

equivalents within the current isometric plane. 

 
 

Sometimes orthogonal locking is not used even when it is turned on. 

4MCAD ignores orthogonal locking when you type coordinates in the command bar 

or when you use entity snaps. Additionally, orthogonal locking and polar track- ing 

cannot be used at the same time — turning one option on turns the other option off. 
 

 

 
To enable orthogonal locking 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Coordinate Input tab. 

3 Click the Draw Orthogonal check box. 

4 Click OK. 

 
 

Toggle orthogonal locking on and off. 

Double-click the ORTHO setting on the status bar, click the Draw Orthogonal tool 

( ) on the Settings toolbar, or press F8. 

A 
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Using polar tracking 
When polar tracking is turned on, guides display on the screen automatically at the 

polar angle increment that you specify. For example, if you draw a line with polar 

tracking turned on at 45 degrees, the rubber-banding line displays at 45 degree angle 

increments. 

Polar tracking and orthogonal locking cannot be used at the same time — turning one 

option on turns the other option off. 
 

To enable polar tracking and specify the polar angle increment 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Coordinate Input tab. 

3 Click the Polar Tracking tab. 

4 Click the Polar Tracking check box. 

5 Do one of the following to specify the polar angle increments: 

• In Increment, select an angle. 

• Mark the Additional Angles check box and click New to define a custom angle 

increment. 

6 Click OK. 

 
 

Toggle polar tracking on and off. 

Double-click the POLAR setting on the status bar, type POLARTRACK in the com- 

mand line, press F10, or press Ctrl+U. 
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A Select Polar Tracking. 

B Select to display polar tracking guides on the 
screen. 

C Select the angle at which you want the guides to 
display. 

D Select to specify angle increments that are not 
defined in the Increment Angle list. 

E Click to add a new angle increment. 

F Click to delete the currently selected angle from 
the Additional Angles list. 
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Using entity snaps 
 

Entity snaps enable you to quickly select exact geometric points on existing entities 

without having to know the exact coordinates of those points. With entity snaps, you 

can select the endpoint of a line or arc, the center point of a circle, the intersection of 

any two entities, or any other geometrically significant position. You can also use 

entity snaps to draw entities that are tangent or perpendicular to an existing entity. 

You can use entity snaps any time the program prompts you to specify a point—for 

example, if you are drawing a line or other entity. You can work with entity snaps in 

one of two ways: 

• Enable a running entity snap that remains in effect until you turn it off by choosing 

an entity snap when no other command is active. 

• Enable a one-time entity snap for a single selection by choosing an entity snap 

when another command is active. You can also use a one-time entity snap to over- 

ride a running entity snap. 

 
 

If you type the name of entity snaps, you don’t need to type the whole name. 

Type only the first three letters of the snap name. 
 

 

 

When using entity snaps, the program recognizes only visible entities or visible por- 

tions of entities. You cannot snap to entities on layers that have been turned off or to 

the blank portions of dashed lines. 

When you specify one or more entity snaps, an entity snap target box is added to the 

crosshairs. In addition, an icon appears adjacent to the crosshairs indicating the active 

entity snap. When you select an entity, the program snaps to the snap point closest to 

the center of the target box. 

 

Setting entity snaps 
You can set entity snaps using any of the following methods: 

• On the ribbon, choose Draw and in Entity Snaps, choose the entity snap you want 

to set. 

• Choose Tools > Entity Snap, and choose the entity snap you want to set. 

• On the Entity Snaps toolbar, click one of the entity snap tools. 

• In the command bar, type an entity snap command. 

• In the status bar, double-click ESNAP. 

• Press and hold down the Shift key while right-clicking anywhere within the draw- 

ing window to display the entity snap shortcut menu, and then choose the entity 

snap you want to set. 
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You can also set entity snaps using the Drawing Settings dialog box. To do this, 

choose Tools > Entity Snap > Entity Snap Settings. The Drawing Settings dialog box 

is displayed with the Coordinate Input tab active. In the Entity Snap Modes list, click 

the check box for each of the entity snaps that you want to set. 

 
 

There are several indicators if an entity snap is active. 

If you select an entity snap, a check mark appears next to the entity snap in the menu, 

the associated tool if the Entity Snaps toolbar is active, and the corresponding box is 

checked in the Coordinate tab of the Drawing Settings dialog box. 
 

 

 
To change the size of the entity snap target box 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Coordinate Input tab. 

3 Click the Entity Selection tab. 

4 Under Entity Snap Aperture, change the value in the Aperture field. 

5 Click OK. 

 

 

 

 

 

A 

 
 
 
 
 
 
 

B 

 
 
 
 
 
 
 

A Choose Entity Selection. B Type or select the entity snap aperture size. 
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Nearest Snap tool 
Use the Nearest Snap tool to snap to the nearest point of another entity. You can snap 

to the nearest point on an arc, circle, ellipse, elliptical arc, line, point, polyline seg- 

ment, ray, spline, infinite line, or hatch pattern that is visually closest to the cursor. 
 

To set the Nearest Snap 

Do one of the following to choose Nearest Snap (  ): 

• On the ribbon, choose Draw > Nearest Snap (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Nearest Snap. 

• On the Entity Snaps toolbar, click the Set Nearest Snap tool. 

• Type nearest and then press Enter. 

Endpoint Snap tool 
Use the Endpoint Snap tool to snap to the endpoint of another entity. You can snap to 

the closest endpoint of an arc, line, polyline segment, ray, hatch pattern, plane, or 

three-dimensional face. If an entity has thickness, the Endpoint Snap also snaps to the 

endpoints of the edges of the entity. 

To set the Endpoint Snap 

Do one of the following to choose Endpoint Snap ( ): 

• On the ribbon, choose Draw > Endpoint Snap (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Endpoint Snap. 

• On the Entity Snaps toolbar, click the Set Endpoint Snap tool. 

• Type endpoint and then press Enter. 
 

 

To snap to the endpoint, select anywhere on the entity near its endpoint (A). 

 

Midpoint Snap tool 
Use the Midpoint Snap tool to snap to the midpoint of another entity. You can snap to 

the midpoint of an arc, ellipse, line, polyline segment, plane, infinite line, spline, or 

hatch pattern. In the case of infinite lines, the midpoint snaps to the first defined 

point. If an entity has thickness, the midpoint entity snap also snaps to the midpoint of 

the edges of the entity. 

 
 

Type m2p or mtp to enable a one-time snap to the midpoint of two points. 

You specify the points, such as two points selected using entity snaps. 
 

 

 

 
A 



92 C H A P T E R   3 
 

 
To set the Midpoint Snap 

Do one of the following to choose Midpoint Snap (  ): 

• On the ribbon, choose Draw > Midpoint Snap (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Midpoint Snap. 

• On the Entity Snaps toolbar, click the Set Midpoint Snap tool. 

• Type midpoint and then press Enter. 
 

 

To snap to the midpoint, select anywhere on the entity near its midpoint (A). 

 

Center Snap tool 
Use the Center Snap tool to snap to the center point of another entity. You can snap to 

the center of an arc, circle, polygon, ellipse, or elliptical arc. To snap to the center, 

you must select a visible portion of the entity. 
 

To set the Center Snap 

Do one of the following to choose Center Snap (  ): 

• On the ribbon, choose Draw > Center Snap (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Center Snap. 

• On the Entity Snaps toolbar, click the Set Center Snap tool. 

• Type center and then press Enter. 
 

 

To snap to the center, select anywhere on the visible portion of the entity (A). 

 

Perpendicular Snap tool 
Use the Perpendicular Snap tool to snap to the perpendicular point of another entity. 

You can snap to an arc, circle, ellipse, line, polyline, infinite line, ray, spline, hatch 

pattern, or edge of a plane to form a perpendicular alignment with that entity or with 

an imaginary extension of that entity. 

 

A 

 
 
 
 

A 
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To set the Perpendicular Snap 

Do one of the following to choose Perpendicular Snap (  ): 

• On the ribbon, choose Draw > Perpendicular Snap (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Perpendicular Snap. 

• On the Entity Snaps toolbar, click the Set Perpendicular Snap tool. 

• Type perpendicular and then press Enter. 

 

 

To form a perpendicular angle (A) to an entity (B), select anywhere on 
the entity. 

 

Tangent Snap tool 
Use the Tangent Snap tool to snap to the tangent point of another entity. You can snap 

to the point on an arc, ellipse, spline, or circle that, when connected to the previous 

point, forms a line tangent to that entity. 
 

To set the Tangent Snap 

Do one of the following to choose Tangent Snap (  ): 

• On the ribbon, choose Draw > Tangent Snap (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Tangent Snap. 

• On the Entity Snaps toolbar, click the Set Tangent Snap tool. 

• Type tangent and then press Enter. 

 

 
 

To snap to a tangent, select the entity near the tangent point (A). 

 
 

 

A 

 

A 
 

 
B 
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Quadrant Snap tool 
Use the Quadrant Snap tool to snap to the quadrant point of another entity. You can 

snap to the closest quadrant of an arc, circle, ellipse, or elliptical arc. 
 

To set the Quadrant Snap 

Do one of the following to choose Quadrant Snap (  ): 

• On the ribbon, choose Draw > Quadrant Snap (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Quadrant Snap. 

• On the Entity Snaps toolbar, click the Set Quadrant Snap tool. 

• Type quadrant and then press Enter. 

 

 
 

To snap to a quadrant, select the entity near the quadrant point (A). 

 

Insertion Point Snap tool 
Use the Insertion Point Snap tool to snap to the insertion point of an attribute, block, 

or text entity. 
 

To set the Insertion Point Snap 

Do one of the following (  ): 

• On the ribbon, choose Draw > Insertion Point Snap (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Insertion Point Snap. 

• On the Entity Snaps toolbar, click the Set Insertion Point Snap tool. 

• Type insertion and then press Enter. 

 

 

To snap to an insertion point, select anywhere on the entity (A). 

 
A 

 
 
 
 

 
 

A               

 

 
A 
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Node Snap tool 
Use the Node Snap tool to snap to a point entity. 

 

To set the Node Snap 

Do one of the following to choose Node Snap (  ): 

• On the ribbon, choose Draw > Node Snap (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Node Snap. 

• On the Entity Snaps toolbar, click the Set Node Snap tool. 

• Type node and then press Enter. 

 

 
 

To snap to a point entity, select the entity (A). 

 

Parallel Snap tool 
Use the Parallel Snap tool to show parallel guides when picking second and subse- 

quent points of new entities. Guides display parallel to points that you indicate on 

other lines, infinite lines, rays, or linear segments of polylines. 

 
 

Turn ORTHO off before using parallel snapping 

If on, double-click ORTHO on the status bar to turn it off. 
 

 

 
To set the Parallel Snap 

Do one of the following (  ): 

• On the ribbon, choose Draw > Parallel Snap (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Parallel Snap. 

• On the Entity Snaps toolbar, click the Set Parallel Snap tool. 

• Type parallel and then press Enter. 

 

 
 

Select the first point of an entity (A), hover over the desired parallel entity (B), 
then move the cursor back to the new entity to view the guide. 

A 
 

 

 

 

 
B 

 
 

A 
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To snap to a parallel point 

1 Choose a command, for example, line. 

2 Select the entity’s first point. 

3 Type par and then press Enter. 

4 Move the cursor over the desired parallel entity. A small “x” marks the position on 

the parallel entity. 

5 Select additional parallel entities if necessary. You can also deselect a parallel 

entity by moving the cursor over its corresponding “x.” 

6 Move the cursor back to the entity you are creating and use the parallel guide to 

select the next point of the entity. 

 

Apparent Intersection Snap tool 
The Apparent Intersection Snap tool snaps to the intersection of two entities that do 

not intersect in three-dimensional space but seem to intersect in the current view. You 

can snap to any two entities in the combination of an arc, circle, line, infinite line, 

polyline, ray, ellipse, elliptical arc, spline, hatch pattern, polygon mesh, or polyface 

mesh. You can also snap to an intersection point within a single entity, including a 

polyline or spline. 

The Extended Apparent Intersection Snap option snaps to the logical location where 

two entities (lines, arcs, or elliptical segments) would intersect if they were of infinite 

length. 4MCAD automatically uses the extension option only when you type app in 

the command bar (not the full apparent command name) after selecting a com- 

mand, such as Line or Circle. Dashed extension lines are drawn to help show the 

extended apparent intersection. 

 
 

There are two types of intersection snaps. 

You can set the Apparent Intersection Snap or Intersection Snap, but you cannot use 

both at the same time. 
 

 

 
To set the Apparent Intersection Snap 

Do one of the following to choose Apparent Intersection (  ): 

• On the ribbon, choose Draw > Apparent Intersection Snap (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Apparent Intersection Snap. 

• On the Entity Snaps toolbar, click the Apparent Intersection Snap tool. 

• Type apparent and then press Enter. 
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To snap to an intersection, select the apparent intersection (A). 

To snap to an extended apparent intersection point 

1 Choose a command, for example, line. 

2 Type app and then press Enter. 

3 Select an extended apparent intersection point. 
 

The Extended Apparent Intersection Snap turns off automatically after you select a 

point. 

 

Quick Snap command 
Normally, an entity snap searches all the entities crossing the target and selects the 

one closest to the center of the target. Use the Quick Snap command to modify the 

current entity snap so that the program stops searching for the snap point as soon as it 

finds one entity with at least one point of the current entity type. 
 

To set the Quick Snap 

• Type quick and then press Enter. 

 

Clear Entity Snaps tool 
Use the Clear Entity Snaps tool to turn off all entity snap settings, regardless of how 

they were set: by menu, tool, command, or in the Drawing Settings dialog box. 
 

To set Clear Entity Snaps 

Do one of the following to choose Clear Entity Snaps (  ): 

• On the ribbon, choose Draw > Clear Entity Snaps (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Clear Entity Snaps. 

• On the Entity Snaps toolbar, click the Clear Entity Snaps tool. 

• Type none and then press Enter. 

A 
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From Point tool 
Use the From Point tool to set a temporary base point from which to offset point 

selection. The From Point tool can be used only while another active command is 

requesting a point. 
 

To set a temporary offset point 

1 Choose a command, for example, line or move. 

2 Do one of the following to choose From Point (  ): 

• On the ribbon, choose Draw > From Point (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > From Point. 

• On the Entity Snaps toolbar, click the From Point tool. 

• Type from and then press Enter. 

3 Select where to place the temporary base point. 

4 Enter the offset distance from the base point, for example, (@8.5,0), where you 

want to locate the next point. Note that entering (8.5,0) places an absolute point 

from the UCS origin, not a relative point from the base point. 

5 Continue with the original command. 

 

Temporary Tracking Point tool 
Use the Temporary Tracking Point tool to set a temporary tracking point while using 

a command. The Temporary Tracking Point tool can be used only while another 

active command is requesting a point. 
 

To set a temporary tracking point 

1 Choose a command, for example, line or move. 

2 Do one of the following to choose Temporary Tracking Point (  ): 

• On the ribbon, choose Draw > Temporary Tracking Point (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Temporary Tracking Point. 

• On the Entity Snaps toolbar, click the Temporary Tracking Point tool. 

• Type TT and then press Enter. 

3 Select a point to mark a temporary tracking point. 

4 Continue with the original command. 
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Mid Between 2 Points tool 
Use the Mid Between 2 Points tool to set a temporary midpoint snap between two 

points. The Mid Between 2 Points tool can be used only while another active com- 

mand is requesting a point. 
 

To set a temporary midpoint snap between two points 

1 Choose a command, for example, line or move. 

2 Do one of the following to choose Mid Between 2 Points (  ): 

• On the ribbon, choose Draw > Mid Between 2 Points (in Entity Snaps). 

• On the menu, choose Tools > Entity Snap > Mid Between 2 Points. 

• On the Entity Snaps toolbar, click the Mid Between 2 Points tool. 

• Type m2p (or mtp) and then press Enter. 

3 Select the first point. 

4 Select the second point. The midpoint is calculated automatically. 

5 Continue with the original command. 

 

Using fly-over snapping 
Fly-over snapping is a visual aid to help you see and use entity snaps more efficiently. 

When fly-over snapping is turned on, 4MCAD displays a colored marker at match- 

ing entity snap points as you move the crosshairs around the drawing. 

 
Viewing fly-over snap markers 
Each entity snap has its own marker. 

 

Fly-over snap markers 
 

 
Endpoint Snap 

Nearest Snap 

Midpoint Snap 

              Center Snap 

Perpendicular Snap 
 

 

Tangent Snap 

Quadrant Snap 

Insertion Snap 

Parallel Snap 

Marker Entity snap 
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Fly-over snap markers 

 

 
              Point Snap 

              Intersection Snap 
 

 

Setting up fly-over snapping 
When fly-over snapping is enabled and multiple entity snaps are on, you can press 

Tab to cycle through the available entity snap points of the entities covered by the tar- 

get box. For example, when the Endpoint and Midpoint Snaps are on and the aperture 

box is located on a line, press Tab to cycle between the line's closest endpoint and 

midpoint. 

 
 

To set the fly-over snapping options 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings or choose Tools > Entity Snap 

> Entity Snap Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Coordinate Input tab. 

3 Click the Entity Snaps tab. 

4 Click Display Options. The Options dialog box opens to the Snapping tab. 

5 Mark Enable Fly-Over Snapping to turn on fly-over snapping. 

6 Set the fly-over options, including the color, size, and thickness of the snap 

marker. 

7 Click OK. 

Apparent Intersection Snap 

Marker Entity snap 
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8 Click OK again. 
 

For details about the various fly-over snapping options, see “Changing the options on 

the Snapping tab” on page 709. 

 

Using entity snap tracking 
When entity snap tracking is turned on, guides display at specified angles outward 

from temporary tracking points. This can help you draw and modify entities using the 

relative position of existing entities, for example, inserting a block with the same y- 

coordinate of an existing line. 

Temporary tracking points are marked with a red plus sign, and can be placed any- 

where in the drawing. To select where tracking points display, first activate a com- 

mand that requests a point, then: 

• Move the cursor and hover over an entity snap point to add a tracking point. 

• Choose the Temporary Tracking Point command, then select anywhere in the 

drawing for the tracking point to reside. 

• Move the cursor and hover over an existing tracking point to remove a tracking 

point. 

You can set up entity snap tracking to display guides at 90-degree increments or addi- 

tional increments that are defined for polar tracking. You can also set up entity snap 

tracking to display guides relative to the current UCS or relative to the last segment 

drawn. 

To use entity snap tracking, at least one entity snap must be turned on and running 

snaps cannot be turned off. Polar tracking does not have to be turned on in order to 

use entity snap tracking. 
 

To turn entity snap tracking on or off 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Coordinate Input tab. 

3 Click the Entity Snaps tab. 

4 Click the Entity Snap Tracking checkbox. 
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Toggle entity snap tracking on and off. 

Double-click the ETRACK setting on the status bar, type ENTTRACK, or press F11. 
 

 

 

 
 

Start a command, hover over one or more entity snap points to mark them with a 
tracking point (A then B), then move the cursor to view the guides (C). In this 
example, the Midpoint Snap is turned on and entity snap tracking displays at 90- 
degree increments. 

 

To specify settings for entity snap tracking 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Coordinate Input tab. 

3 Click the Polar Tracking tab. 

4 Select one of the following to specify entity tracking settings: 

• Orthogonal Only 90-degree angle increments are used for entity snap tracking, 

regardless of polar tracking settings. 

• Use all polar tracking angles All defined polar tracking angles, including those 

other than 90-degree angle increments, are used for entity snap tracking. 

5 Select one of the following to specify how the angles of guides are calculated for 

entity snap tracking: 

• Absolute Guides display at angles relative to the current UCS. 

• Relative to last segment Guides display at angles relative to the last segment 

drawn, if creating entities with multiple segments (otherwise guides display at 

absolute angles). 

6 Click OK. 

 

C 

A 
 

 

B 
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B 

 

 
A 

 
 
 
 
 
 
 

A Select to use either 90-degree increment angles 
or all angles specified in Increment Angle and 
Additional Angles for polar tracking. 

B Select whether angles for guides are calculated 
relative to the current UCS or relative to the last 
previously drawn segment when drawing entities 
with more than one segment. 
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Saving your drawing 
 

When you save a drawing, your work is saved in a drawing (.dwg) file. 

After you have saved your drawing for the first time, you can save it with a new 

name. In addition to drawing (.dwg) files, you can also save a drawing in a Drawing 

Exchange Format (.dxf) file or a drawing template (.dwt) file. 

If you created your drawing using a template, saving the drawing does not alter the 

original template. 

If you need an added level of security for your drawing files, you can save the draw- 

ing with a password so only you and those who know the password can open the 

drawing. 

 

Saving a drawing 
To save a drawing, choose any of the following methods to choose Save ( ): 

• On the ribbon Quick Access toolbar, click Save, or on the ribbon Application but- 

ton, choose Save. 

• On the menu, choose File > Save. 

• On the Standard toolbar, click Save. 

• Type save and then press Enter. 

• Type qsave and then press Enter. 

When you save a drawing the first time, the program displays the Save Drawing As 

dialog box so that you can choose a directory and type a name for the drawing. You 

can use any name when you first save the drawing. 
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A 

E 

 
B 
C 

D 
 

A Displays a description of the file size, creation 
date, and other information about the drawing. 

B Unavailable when saving drawings; available 
only when opening drawings. 

 

C Turns the drawing preview on or off. 

D Saves the drawing with a password. 

E Displays an image of the drawing before you 
save it. 

 

Saving a drawing with a new name or file 
format 
You can save a drawing with a new name and in any of the following file formats: 

• Standard drawing files with a .dwg extension. You can choose a .dwg file format 

that is compatible with various versions of AutoCAD. 

• Drawing Exchange Format files with a .dxf file extension. You can choose a .dxf 

file format that is compatible with various versions of AutoCAD. 

• Drawing templates with a .dwt file extension. Drawing templates allow you to eas- 

ily create new drawings that reuse your drawing settings and entities. 

 

To save a drawing with a new name or file format 

1 Do one of the following to choose Save As: 

• On the ribbon Quick Access toolbar, click Save As, or on the ribbon Application 

button, choose Save As. 

• On the menu, choose File > Save As. 

• Type saveas and then press Enter. 

2 In the Save Drawing As dialog box, under Save As Type, choose the file format. 

3 Specify the name of the file you want to create. 

4 Click Save. 
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Drawings can also be saved by exporting to various file formats. 

For more details, see “Exporting drawings” on page 655. 
 

 

 

Saving a drawing with a password 
Sometimes drawings may contain confidential information and you want to control 

who has access to that information. If you need an added level of security, you can 

save a drawing with a password so only you and those who know the password can 

open the drawing. 

To save a drawing with a password, you must save it as a .dwg file for AutoCAD ver- 

sion 2004 or newer. 

 
 

Record passwords or use familiar words. 

If you forget a drawing’s password, the drawing cannot be opened or recovered. You 

may want to store all passwords in a safe place. 
 

 

 
To save a drawing with a password 

1 Do one of the following to choose Save As: 

• On the ribbon Quick Access toolbar, click Save As, or on the ribbon Application 

button, choose Save As. 

• On the menu, choose File > Save As. 

• Type saveas and then press Enter. 

2 In the Save Drawing As dialog box, under Save As Type, choose a .dwg file for 

AutoCAD version 2004 or newer. 

3 Click Password Protect. 

4 Choose a folder where you want to save the drawing. 

5 In File Name, specify the name of the file you want to create. 

6 Click Save. 

7 In the Password dialog box, enter a password. 

8 If desired, record and store the password in a safe place. If you forget the draw- 

ing’s password, the drawing cannot be opened or recovered. 

9 Click OK. 



 

 
 

 
 

 

 

Creating simple entities 
 

Simple entities include lines (both finite and infinite), circles, arcs, ellipses, elliptical 

arcs, points, and rays. In addition, 4MCAD includes a freehand sketch tool that can 

be used to create simple entities. 

This section explains several methods for creating simple entities, including how to: 

• Use menu commands on the Draw menu. 

• Use the tools on the Draw toolbar. 

• Type commands in the command bar. 

In some cases, there are a number of different ways to create an entity. For the most 

part, one or two are given in this guide. Refer to the Command Reference in the 

online Help to learn how to create entities using other methods. 

When you use a tool or a drawing command, the program prompts you to enter coor- 

dinate points, such as endpoints or insertion points. You can enter the points or dis- 

tances either using a mouse or by typing coordinate values in the command bar. As 

you draw, 4MCAD also displays a context-sensitive prompt box with appropriate 

additional options for the type of entity you are drawing. 

After you create entities, you can modify them using the entity modification tools. 
 
 
 

4 
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Drawing lines 
 

A line consists of two points: a start point and an endpoint. You can connect a series 

of lines, but each line segment is considered a separate line entity. 
 

To draw a line 

1 Do one of the following to choose Line (  ): 

• On the ribbon, choose Home > Line or choose Draw > Line. 

• On the menu, choose Draw > Line. 

• On the Draw toolbar, click the Line tool. 

• Type line and then press Enter. 

2 Specify the start point. 

3 Specify the endpoint. 

4 In the prompt box, choose Done to complete the command. 

 
 

 
Start point (A) and endpoint (B). 

The prompt box provides several options as you draw. For example, when you draw 

the first line segment, you can specify its length or orientation angle. After you draw 

at least one line segment, you can click Undo to remove the previous line segment. 

You can click Done to end the line command. After you draw two or more line seg- 

ments, you can click Close to complete the line command by drawing a line segment 

that connects to the start point of the first line segment you drew. 

If the last entity you drew was an arc, you can also draw a line tangent to and starting 

from the endpoint of the arc. 
 

To draw a line as a continuation from the end of an arc 

1 Do one of the following to choose Line (  ): 

• On the ribbon, choose Home > Line or choose Draw > Line. 

• On the menu, choose Draw > Line. 

• On the Draw toolbar, click the Line tool. 

• Type line and then press Enter. 

2 In the prompt box, choose Follow. 

3 Specify the length of the line. 

B 

A 
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Endpoint of previous arc (A) and length of the line (B). 

 

 

Drawing circles 
 

The default method for drawing a circle is to specify a center point and radius. You 

can draw circles using any of the following methods: 

• Center-Radius ( ) 

• Center-Diameter ( ) 

• 2-Points ( ) 

• 3-Points ( ) 

• Radius-Tangents (  ) 

• Tan-Tan-Tan 

• Convert Arc to Circle (  ) 

To draw a circle by specifying its center and radius 

1 Do one of the following to choose Circle Center-Radius (  ): 

• On the ribbon, choose Home > Circle Center-Radius or choose Draw > Circle 

Center-Radius. 

• On the menu, choose Draw > Circle > Circle Center-Radius. 

• On the Draw toolbar, click the Circle Center-Radius tool. 

• Type circle and then press Enter. 

2 Specify the center point. 

3 Specify the radius of the circle. 

 
 

 
Center point (A) and radius (B). 

 

B 
A 

 
A 

B 
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To draw a circle by specifying its center and diameter 

1 Do one of the following to choose Circle Center-Diameter (  ): 

• On the ribbon, choose Home > Circle Center-Diameter or choose Draw > Circle 

Center-Diameter. Skip step 3. 

• On the menu, choose Draw > Circle > Circle Center-Diameter. Skip step 3. 

• On the Draw toolbar, click the Circle tool. 

• Type circle and then press Enter. 

2 Specify the center point. 

3 In the prompt box choose Diameter. 

4 Specify the second point indicating the diameter of the circle. 

 
 

 
Center point (A) and diameter (B). 

To draw a circle by specifying two endpoints of the diameter 

1 Do one of the following to choose Circle 2-Points (  ): 

• On the ribbon, choose Home > Circle 2-Points or choose Draw > Circle 2- 

Points. Go to step 3. 

• On the menu, choose Draw > Circle > Circle 2-Points. Go to step 3. 

• On the Draw toolbar, click the Circle tool. 

• Type circle and then press Enter. 

2 In the prompt box choose 2 Points. 

3 Specify the first endpoint of the diameter of the circle. 

4 Specify the second endpoint of the diameter of the circle. 

 
 

 
First endpoint (A) and second endpoint (B). 

 
A 

 

B 

 

A 

 
B 
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To draw a circle by specifying three points on the circumference 

1 Do one of the following to choose Circle 3-Points (  ): 

• On the ribbon, choose Home > Circle 3-Points or choose Draw > Circle 3- 

Points. Go to step 3. 

• On the menu, choose Draw > Circle > Circle 3-Points. Go to step 3. 

• On the Draw toolbar, click the Circle tool. 

• Type circle and then press Enter. 

2 In the prompt box choose 3 Points. 

3 Specify the first point on the circumference of the circle. 

4 Specify the second point on the circumference of the circle. 

5 Specify the third point on the circumference of the circle. 

 
 

 
First point (A), second point (B), third point (C). 

To draw a circle by specifying its radius and two tangent points 

1 Do one of the following to choose Circle Radius-Tangents (  ): 

• On the ribbon, choose Home > Circle Radius-Tangents or choose Draw > Circle 

Radius-Tangents. Go to step 3. 

• On the menu, choose Draw > Circle > Circle Radius-Tangents. Go to step 3. 

• On the Draw toolbar, click the Circle tool. 

• Type circle and then press Enter. 

2 In the prompt box, choose Tangent-Tangent-Radius. 

3 Select the first entity that you want the circle to touch 

4 Select the second entity that you want the circle to touch. 

5 Specify the radius of the circle. 

A 

C 
 

B 



 

C 
B 

A 

A 
C 

B 
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Tangent lines (A) and (B) and radius of circle (C). 

To draw a circle tangent to three entities 

1 Do one of the following to choose Tan-Tan-Tan (  ): 

• On the ribbon, choose Home > Circle Tan-Tan-Tan or choose Draw > Circle 

Tan-Tan-Tan. Go to step 3. 

• On the menu, choose Draw > Circle > Tan-Tan-Tan. Go to step 3. 

• On the Draw toolbar, click the Circle tool. 

• Type circle and then press Enter. 

2 In the prompt box, choose Tangent-Tangent-Tangent. 

3 Select the first entity that you want the circle to touch 

4 Select the second entity that you want the circle to touch. 

5 Select the third entity you want the circle to touch. 

 
 

 

First tangent entity (A), second tangent entity (B) and third 
tangent entity (C). 

 

To convert an arc to a circle 

1 Do one of the following to choose Convert Arc to Circle ( ): 

• On the ribbon, choose Home > Convert Arc to Circle or choose Draw > Convert 

Arc to Circle. 

• On the menu, choose Draw > Circle > Convert Arc to Circle. 

• On the Draw toolbar, click the Convert Arc to Circle tool. 

Go to step 3. 

• Type circle and then press Enter. 

2 In the prompt box, choose Turn Arc Into Circle. 

3 Select the arc you want to convert to a circle. 
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Select an arc (A) to convert to a circle. 

 

 

Drawing arcs 
 

An arc is a portion of a circle. The default method for drawing an arc is to specify 

three points—the start point, a second point, and the endpoint. You can draw arcs 

using any of the following methods: 

• Three points on an arc ( ). 

• Start point-center-endpoint ( ), or Start point-endpoint-center ( ), or Center- 

start point-endpoint ( ). 

• Start point-center-included angle (  ), or Start point-included angle-center 

(  ), or Center-start point-included angle (  ). 

• Start point-center-chord length ( ), or Center-start point-chord length ( ). 

• Start point-endpoint-radius ( ), or Start point-radius-endpoint (  ). 

• Start point-endpoint-included angle (  ), or Start point-included angle-endpoint 

(  ). 

• Start point-endpoint-starting direction ( ), or Start point-starting direction-end- 

point (  ). 

• Start point-radius-angle (  ). 

• As a tangent continuation of the previous arc or line (  ). 

To draw an arc by specifying three points 

1 Do one of the following to choose 3-Point Arc ( ): 

• On the ribbon, choose Home > 3-Point Arc or choose Draw > 3-Point Arc. 

• On the menu, choose Draw > Arc > 3-Point Arc. 

• On the Draw toolbar, click the 3-Point Arc tool. 

• Type arc and then press Enter. 

2 Specify the start point. 

3 Specify a second point. 

4 Specify the endpoint. 

 
A 



 

 

110 C H A P T E R   4 

 
 
 

 
Start point (A), second point (B), and endpoint (C). 

The prompt box provides additional options for drawing arcs. For example, after you 

specify the start point of an arc, you can choose Angle, Center, Direction, Endpoint, 

or Radius. You can select the options in a different order as well. For instance, you 

can draw an arc by specifying its start point, endpoint, and radius, or you can specify 

the start point, radius, and then endpoint. 
 

To draw an arc by specifying its start point, center point, and endpoint 

1 Do one of the following to choose Arc Start-Center-End ( ): 

• On the ribbon, choose Home > Arc Start-Center-End or choose Draw > Arc 

Start-Center-End. 

• On the menu, choose Draw > Arc > Arc Start-Center-End. 

• On the Draw toolbar, click the Arc Start-Center-End tool. 

• Type arc and then press Enter. 

2 Specify the start point. 

3 In the prompt box, choose Center. 

4 Specify the center point. 

5 Specify the endpoint. 

 
 

 
Start point (A), center point (B), and endpoint (C). 

 

B 
 

C 

A 

 

C 

B 
 

 
A 
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To draw an arc by specifying two points and an included angle 

1 Do one of the following to choose Arc Start-End-Angle (  ): 

• On the ribbon, choose Home > Arc Start-End-Angle or choose Draw > Arc 

Start-End-Angle. 

• On the menu, choose Draw > Arc > Arc Start-End-Angle. 

• On the Draw toolbar, click the Arc Start-End-Angle tool. 

• Type arc and then press Enter. 

2 Specify the start point. 

3 In the prompt box, choose Angle or type angle. 

4 To draw an arc in a counterclockwise direction, enter a positive value for the 

included angle. 

To draw an arc in a clockwise direction, enter a negative value for the included 

angle. 

5 Specify the endpoint. 
 

 
Start point (A), endpoint (B), and included angle (C). 

If the last entity you drew was an arc or a line, you can also draw an arc tangent to and 

starting from the endpoint of the arc or line. 
 

To draw an arc tangent to an arc or line 

1 Do one of the following to choose Tangent Arc (  ): 

• On the ribbon, choose Home > Tangent Arc or choose Draw > Tangent Arc. 

• On the menu, choose Draw > Arc > Tangent Arc. 

• On the Draw toolbar, click the Tangent Arc tool. Go to step 3. 

• Type arc and then press Enter. 

2 In the prompt box, choose Follow. 

3 Specify the endpoint. 

 
C 

B 

A 
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Endpoint (A). 

 
 

Arcs can be converted to circles 
 

 
On the Draw toolbar, click the Convert Arc To Circle flyout tool ( ). 

 
 

A 
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Drawing ellipses 
 

The default method for drawing an ellipse is to specify the endpoints of one axis of 

the ellipse, and then specify a distance representing half the length of the second axis. 

The endpoints of the first axis determine the orientation of the ellipse. The longer axis 

of the ellipse is called the major axis, and the shorter one is the minor axis. The order 

in which you define the axes does not matter. The program determines the major and 

minor axes based on their relative lengths. You can draw ellipses using any of the fol- 

lowing methods: 

• Axis-Axis ( ) 

• Axis-Rotation ( ) 

• Center-Axes ( ) 

• Center-Rotation ( ) 

To draw an ellipse by specifying the axis endpoints 

1 Do one of the following to choose Ellipse Axis-Axis (  ): 

• On the ribbon, choose Home > Ellipse Axis-Axis or choose Draw > Ellipse 

Axis-Axis. 

• On the menu, choose Draw > Ellipse > Ellipse Axis-Axis. 

• On the Draw toolbar, click the Ellipse Axis-Axis tool. 

• Type ellipse and then press Enter. 

2 Specify the first endpoint. 

3 Specify the second endpoint. 

4 Specify the half-length of the other axis. 

 
 

 
First axis endpoint (A), second axis endpoint (B), and half-length of other axis (C). 



 

D 

A 
C 

E 

B 
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Drawing elliptical arcs 
 

An elliptical arc is a portion of an ellipse. The default method for drawing an ellipti- 

cal arc is to specify the endpoints of one axis of the ellipse, and then specify a dis- 

tance representing half the length of the second axis. Then you specify the start and 

end angles for the arc, measured from the center of the ellipse in relation to its major 

axis. You can draw elliptical arcs using any of the following methods: 

• Axis-Axis ( ) 

• Axis-Rotation ( ) 

• Center-Axes ( ) 

• Center-Rotation (  ) 

To draw an elliptical arc by specifying the axis endpoints 

1 Do one of the following to choose Elliptical Arc Axis-Axis ( ): 

• On the ribbon, choose Home > Elliptical Arc Axis-Axis or choose Draw > Ellip- 

tical Arc Axis-Axis. 

• On the menu, choose Draw > Elliptical Arc > Elliptical Arc Axis-Axis. 

• On the Draw toolbar, click the Elliptical Arc Axis-Axis tool. 

• Type ellipse and then press Enter, and then type a (for Arc) and press Enter. 

2 Specify the first endpoint. 

3 Specify the second endpoint. 

4 Specify the half-length of the other axis. 

5 Specify the start angle of the arc. 

6 Specify the end angle. 

 
 

4MCAD draws elliptical arcs in the direction you specify. 

Go to Tools > Drawing Settings > Drawing Units tab. Click the Angular Units tab. 

The default setting is counterclockwise. 
 

 

 

 

 
First axis endpoint (A), second axis endpoint (B), half-length of other axis (C), start angle of arc (D), and 
end angle (E). 
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Drawing point entities 
 

A point entity is a single x,y,z-coordinate location formatted as either a single dot or 

as one of 19 other possible display styles. 

 

Drawing points 
You can draw points one at a time or several at a time. 

 

To draw a point 

1 Do one of the following to choose Point (  ): 

• On the ribbon, choose Draw > Point. 

• On the menu, choose Draw > Point. 

• On the Draw toolbar, click the Point tool. 

• Type point and then press Enter. 

2 Specify the location of the point. 
 

To draw several points 

1 Do one of the following to choose Point (  ): 

• On the ribbon, choose Draw > Point. 

• On the menu, choose Draw > Point. 

• On the Draw toolbar, click the Point tool. 

• Type point and then press Enter. 

2 In the prompt box, choose Multiple Points. 

3 Specify the location of each point. 

4 In the prompt box, choose Done to complete the command. 

 

Changing the size and appearance of point entities 
Changing the size and appearance of point entities affects all point entities already in 

the drawing, as well as all points that you subsequently draw. Positive values repre- 

sent the absolute size of the point entity measured in drawing units. Negative values 

represent a percentage relative to the drawing screen, so that points retain their visual 

size as you use the Zoom command to change the magnification of the drawing. 
 

To change the size and appearance of point entities 

1 Do one of the following: 

• Choose Format > Point Style. 

• Type ddptype and then press Enter. 

2 Under Point Display Type, select the style you want. 

3 Under Point Size, select the point size, or choose one of the options. 
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4   Click OK. 

 

When you regenerate the drawing, all point entities change to reflect the new size and 

appearance settings. 

 

 

 

 

 

 

 

 
 

A 
 
 
 

B 
 
 
 

C 

 
 
 

A To increase or decrease the point size, type or 
select a value. 

B To use one of the preset point size options, click 
the one that you want. 

C Select the button for the Point Display Type that 
you want. 
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Drawing rays 
 

A ray is a line in three-dimensional space that starts at a point and extends to infinity. 

Because rays extend to infinity, they are not calculated as part of the drawing extents. 

The default method for drawing a ray is to select the start point of the ray and then 

specify its direction. You can draw a ray in any of the following ways: 

• Horizontal draws the ray parallel to the x-axis of the current user coordinate sys- 

tem (UCS). 

• Vertical draws the ray parallel to the y-axis of the current UCS. 

• Angle draws the ray parallel to a specified angle. 

• Bisect draws the ray perpendicular to an existing entity. 

• Parallel draws the ray parallel to an existing entity. 
 

To draw a ray 

1 Do one of the following to choose Ray ( ): 

• On the ribbon, choose Home > Ray or choose Draw > Ray. 

• On the menu, choose Draw > Ray. 

• On the Draw toolbar, click the Ray tool. 

• Type ray and then press Enter. 

2 Specify the start point. 

3 Specify the direction. 

4 To complete the command, press Enter. 

 
 

 
Start point (A) and direction (B). 

B 
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Drawing infinite lines 
 

An infinite line is a line through a given point, oriented at a specified angle in three- 

dimensional space and extending to infinity in both directions. Because infinite lines 

extend to infinity, they are not calculated as part of the drawing extents. 

The default method for drawing an infinite line is to select a point along the line and 

then specify the direction of the line. You can draw an infinite line in any of the fol- 

lowing ways: 

• Horizontal draws the infinite line parallel to the x-axis of the current UCS. 

• Vertical draws the infinite line parallel to the y-axis of the current UCS. 

• Angle draws the infinite line parallel to a specified angle. 

• Bisect draws the infinite line perpendicular to an existing entity. 

• Parallel draws the infinite line parallel to an existing entity. 
 

To draw an infinite line 

1 Do one of the following to choose Infinite Line (  ): 

• On the ribbon, choose Home > Infinite Line or choose Draw > Infinite Line. 

• On the menu, choose Draw > Infinite Line. 

• On the Draw toolbar, click the Infinite Line tool. 

• Type infline and then press Enter. 

2 Specify a point along the line. 

3 Specify the direction. 

4 To complete the command, press Enter. 
. 

 

 
Point along the infinite line (A) and the direction (B). 

You can also draw infinite lines at a specific angle or at an angle relative to an exist- 

ing entity. 

A 
B 
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To draw an infinite line at a specified angle relative to another entity 

1 Do one of the following to choose Infinite Line (  ): 

• On the ribbon, choose Home > Infinite Line or choose Draw > Infinite Line. 

• On the menu, choose Draw > Infinite Line. 

• On the Draw toolbar, click the Infinite Line tool. 

• Type infline and then press Enter. 

2 In the prompt box, choose Angle. 

3 In the prompt box, choose Reference. 

4 Select the reference entity. 

5 Specify the angle of the infinite line in relation to the selected entity. 

6 Specify the location of the infinite line. 

7 To complete the command, press Enter. 

 
 

 
Reference entity (A) and angle in relation to entity (B). 

 

A B 
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Drawing construction lines 
 

A construction line is a special type of infinite line that is typically used when quick 

drafting techniques are required, for example, to make projections of front and side 

views. 

Similar to an infinite line, a construction line is a line through a given point, oriented 

at a specified angle in three-dimensional space and extending to infinity in both direc- 

tions. Because construction lines extend to infinity, they are not calculated as part of 

the drawing extents. 

Construction lines are drawn automatically on their own layer, which by default is 

named CLINE. This makes it easy to change the appearance of construction lines; 

simply change the properties of the layer such as its color, transparency, etc. Addi- 

tionally, you can specify a different layer for locating construction lines using the 

CLINELAYER system variable. 

You can easily draw construction lines in any of the following ways: 

• Select a point along the construction line and then specify the direction of the line 

(default drawing method). 

• Horizontally, vertically, or both. 

• By bisecting an existing point, an entity, or two entities. 

• According to a specified angle. 

• Parallel to or on top of an existing entity. 
 

 

Construction lines are drawn to match the current UCS. 

You can quickly rotate the UCS using Draw > Construction Line > Rotate UCS Z and 

Rotate UCS World (also available on the Construction Lines toolbar). 
 

 

 

Drawing construction lines by specifying a basepoint 
There are many quick ways to draw construction lines, but the default method is by 

specifying a basepoint along the construction line and then its direction. Using this 

method you can quickly draw an array of construction lines. 
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To draw a construction line by specifying a basepoint 

1 Do one of the following to choose Construction Line > Array from Basepoint 

(  ): 

• On the ribbon, choose Draw > Construction Line > Array from Basepoint. 

• On the menu, choose Draw > Construction Line > Array from Basepoint. 

• On the Construction Line toolbar, click the Array from Basepoint tool. 

• Type cline then press Enter. 

2 Specify a point along the line. 

3 Specify the direction. 

4 To complete the command, press Enter. 
. 

 

 
Point along the construction line (A) and the direction (B). 

 

Drawing construction lines by bisecting an angle or 
entity   

Bisection is a quick way to draw construction lines. You can bisect an angle 
that you specify, or you can bisect one or two lines, arcs, or polyline 
segments. 

 

To draw a construction line by bisecting an angle 

1 Do one of the following to choose Construction Line > Bisect Angle (  ): 

• On the ribbon, choose Draw > Construction Line > Bisect Angle. 

• On the menu, choose Draw > Construction Line > Bisect Angle. 

• On the Construction Line toolbar, click the Bisect Angle tool. 

• Type cline, press Enter, then choose Bisect in the prompt box. 

2 Select an existing vertex point from which to reference the angle. 

3 Specify the first point of the bisection angle. 

4 Specify the second point of the bisection angle. 

5 To complete the command, press Enter. 

A 
B 
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. 

 

 
Point to bisect (A), start of the bisection angle (B), and the 
end of the bisection angle (C). 

To draw a construction line by bisecting a line, arc, or polyline segment 

1 Do one of the following to choose Construction Line > Bisect Entity (  ): 

• On the ribbon, choose Draw > Construction Line > Bisect Entity. 

• On the menu, choose Draw > Construction Line > Bisect Entity. 

• On the Construction Line toolbar, click the Bisect Entity tool. 

• Type cline, press Enter, choose Bisect in the prompt box, then choose Entity in 

the prompt box. 

2 Select a line, arc, or polyline segment to bisect. 
 

To draw a construction line by bisecting two lines, arcs, or polyline segments 

1 Do one of the following to choose Construction Line > Bisect Two Entities (  ): 

• On the ribbon, choose Draw > Construction Line > Bisect Two Entities. 

• On the menu, choose Draw > Construction Line > Bisect Two Entities. 

• On the Construction Line toolbar, click the Bisect Two Entities tool. 

• Type cline, press Enter, choose Bisect in the prompt box, then choose Two 

Entities in the prompt box. 

2 Select a line, arc, or polyline segment. 

3 Select the second line, arc, or polyline segment. 

 

Drawing construction lines horizontally and vertically 
Construction lines can be drawn parallel to the x-axis of the current UCS (horizontal), 

parallel to the y-axis of the current UCS (vertical), or parallel to both the x- and y-axis 

of the current UCS (both horizontal and vertical). 

B 
 

 
C 

A 
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To draw a horizontal construction line 

1 Do one of the following to choose Construction Line > Horizontal (  ): 

• On the ribbon, choose Draw > Construction Line > Horizontal. 

• On the menu, choose Draw > Construction Line > Horizontal. 

• On the Construction Line toolbar, click the Horizontal tool. 

• Type cline and then press Enter. 

2 Specify a point along the line. 

3 To complete the command, press Enter. 
. 

 

 

Point through which you want the horizontal construction 
line to pass (A). 

To draw a vertical construction line 

1 Do one of the following to choose Construction Line > Vertical (  ): 

• On the ribbon, choose Draw > Construction Line > Vertical. 

• On the menu, choose Draw > Construction Line > Vertical. 

• On the Construction Line toolbar, click the Vertical tool. 

• Type cline and then press Enter. 

2 Specify a point along the line. 

3 To complete the command, press Enter. 
. 

 

 
Point through which you want the vertical construction line 
to pass (A). 

 

A 

A 
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To draw both horizontal and vertical construction lines 

1 Do one of the following to choose Construction Line > Both Horizontal and Verti- 

cal (  ): 

• On the ribbon, choose Draw > Construction Line > Both Horizontal and 

Vertical. 

• On the menu, choose Draw > Construction Line > Both Horizontal and Vertical. 

• On the Construction Line toolbar, click the Both Horizontal and Vertical tool. 

• Type cline and then press Enter. 

2 Specify a point where both construction lines intersect. 

3 To complete the command, press Enter. 
 

 

Horizontal and vertical construction lines can also be drawn automatically. 

Choose Draw > Construction Line > Automatic Horizontal, Automatic Vertical, or 

Automatic Both, then select the entities around which you want to draw construction 

lines. Construction lines are drawn automatically without creating duplicates for 

overlapping vertices or entities. 
 

 

 

Drawing construction lines by specifying the angle 

You can also draw construction lines at a specific angle or at an angle relative to an 

existing entity. 
 

To draw a construction line at a specified angle relative to another entity 

1 Do one of the following to choose Construction Line > Angled (  ): 

• On the ribbon, choose Draw > Construction Line > Angled. 

• On the menu, choose Draw > Construction Line > Angled. 

• On the Construction Line toolbar, click the Angled tool. 

• Type cline, choose Angle, and then press Enter. 

2 In the prompt box, choose Reference. 

3 Select the reference entity. 

4 Specify the angle of the construction line in relation to the selected entity. 

5 Specify the location of the construction line. 

6 To complete the command, press Enter. 

 
 

 
Reference entity (A) and angle in relation to entity (B). 

 

A B 
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Drawing construction lines that parallel other entities 
There are two options for drawing construction lines that parallel existing entities: 

• Offset Draws a construction line parallel to an existing entity by a specified offset 

distance. 

• Match Draws a construction line on top of an existing entity. 

To draw a construction line that parallels another entity and specify an offset 

distance 

1 Do one of the following to choose Construction Line > Offset (  ): 

• On the ribbon, choose Draw > Construction Line > Offset. 

• On the menu, choose Draw > Construction Line > Offset. 

• On the Construction Line toolbar, click the Offset tool. 

• Type cline, choose Offset, and then press Enter. 

2 Enter the distance you want the construction line drawn from an entity. 

3 Select the entity that you want the construction line to parallel. 

4 Select the side of the entity where you want to draw the construction line. 

5 To complete the command, press Enter. 
. 

 

 
Entity you want to parallel (A) and the side for the 
construction line (B). 

To draw a construction line that parallels another entity and specify a through 

point 

1 Do one of the following to choose Construction Line > Offset (  ): 

• On the ribbon, choose Draw > Construction Line > Offset. 

• On the menu, choose Draw > Construction Line > Offset. 

• On the Construction Line toolbar, click the Offset tool. 

• Type cline, choose Offset, and then press Enter. 

2 Choose Through point. 

3 Select the entity that you want the construction line to parallel. 

4 Specify the point through which you want the construction line to pass. 

5 To complete the command, press Enter. 

 

 
B 

 

A 
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. 

 

 
Entity you want to parallel (A) and the point through which 
you want the construction line to pass (B). 

To draw a construction line that parallels another entity and matches its location 

1 Do one of the following to choose Construction Line > On Entity (  ): 

• On the ribbon, choose Draw > Construction Line > On Entity. 

• On the menu, choose Draw > Construction Line > On Entity. 

• On the Construction Line toolbar, click the On Entity tool. 

• Type cline, choose Match, and then press Enter. 

2 Select the entity that you want the construction line to match. 

3 To complete the command, press Enter. 

 

Erasing construction lines 
You can delete construction lines as you would any other entity, but there are two 

tools designed to make it easy to filter them automatically when selecting them for 

deletion. 
 

To delete one or more construction lines 

1 Do one of the following to choose Construction Line > Erase (  ): 

• On the ribbon, choose Draw > Construction Line > Erase. 

• On the menu, choose Draw > Construction Line > Erase. 

• On the Construction Line toolbar, click the Erase tool. 

• Type cline, choose Erase, and then press Enter. 

2 Select one or more construction lines to delete. 

3 To complete the command, press Enter. 
 

To delete all construction lines in a drawing 

1   Do one of the following to choose Construction Line > Clear (  ): 

• On the ribbon, choose Draw > Construction Line > Clear. 

• On the menu, choose Draw > Construction Line > Clear. 

• On the Construction Line toolbar, click the Clear tool. 

• Type cline, choose Clear, and then press Enter. 

 
B 

 

 
A 
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Drawing freehand sketches 
 

A freehand sketch consists of many straight line segments, created either as individ- 

ual line entities or as a polyline. 

 

Creating freehand sketches 
Before you begin creating a freehand sketch, you must set the length, or increment, of 

each segment. The smaller the segments, the more accurate your sketch, but segments 

that are too small can greatly increase the file size 

After you specify the length of the sketch segments, the crosshairs change to a Pencil 

tool. Your freehand sketch is not added to the drawing until you “write” the sketch 

into your drawing. This means that you temporarily save the segment that you’ve 

drawn and the segment length, and you can continue sketching. 
 

To create a freehand sketch 

1 Do one of the following to choose Freehand (  ): 

• On the ribbon, choose Draw > Freehand. 

• On the menu, choose Draw > Freehand. 

• On the Draw toolbar, click the Freehand tool. 

• Type freehand and then press Enter. 

2 Specify the length of the sketch segments. 

3 Click the mouse button to place the Pencil tool ( ) on the drawing to begin 

sketching. 

4 Move the pencil image to draw a temporary freehand sketch. 

5 Click the mouse button to lift the pencil up to stop sketching. 

6 In the prompt box, choose Write, Then Resume to write the temporary freehand 

sketch into the drawing. 

7 Click the mouse button to put the pencil down again and resume sketching. 

8 Click the mouse button again to lift the pencil up to stop sketching. 

9 In the prompt box, choose Done to write the temporary freehand sketch into the 

drawing and end the command. 

 
 

 
A freehand sketch consists of individual line entities or a polyline. 



 

 

128 C H A P T E R   4 

 
Erasing freehand sketch lines 
You can erase temporary freehand sketch lines that have not yet been written into the 

drawing by choosing the Delete On option in the prompt box. The pencil changes to 

an Eraser tool. You can erase portions of the line when you move the eraser over a 

temporary freehand line without clicking the mouse button. 
 

To erase freehand sketch lines 

1 Do one of the following to choose Freehand (  ): 

• On the ribbon, choose Draw > Freehand. 

• On the menu, choose Draw > Freehand. 

• On the Draw toolbar, click the Freehand tool. 

• Type freehand and then press Enter. 

2 Specify the length of the sketch segments. 

3 Select a point on the drawing to display the Pencil tool and begin sketching. 

4 Click the mouse button to lift the pencil up to stop sketching. 

5 In the prompt box, choose Delete On. 

6 Move the Eraser tool ( ) to the beginning or end of the freehand sketch line that 

you drew, and then move it as far along the line as you want to erase. 

7 Click the mouse button to put the Pencil tool down to resume sketching. 

 

Setting the sketch method and accuracy 
Using polylines for freehand sketches makes it easier to go back and edit sketches. 

You control whether to create freehand sketches using line segments or polylines in 

the Drawing Settings dialog box. You can also control the length of sketch segments 

in this dialog box. 
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To specify lines or polylines when sketching 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Choose the Entity Creation tab. 

3 Click the Freehand Sketches tab. 

4 Under Freehand Sketching Methods, click either Freehand Command Creates 

Lines or Freehand Command Creates A Polyline. 

5 Click OK. 

 

 
 

 

 

 

 

 

 

 
A 

 
 

 
B 

 
 
 
 

 

A Select the sketch method. B Specify the default length of sketch segments. 
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Creating complex entities 
 

Complex entities include polylines (including rectangles, squares, and polygons), 

spline curves, donuts, and planes. In addition, 4MCAD includes tools for adding 

wipeouts, revision clouds, leaders, hatching, and gradients to your drawings. 

In some cases, there are a number of different ways to create an entity. For the most 

part, one or two are given in this guide. Refer to the Command Reference in the 

online Help to learn how to create entities using other methods. 

When you type a drawing command or select a tool, the program prompts you to 

enter coordinate points, such as endpoints or insertion points. As you draw, the pro- 

gram displays a context-sensitive prompt box with appropriate additional options for 

the type of entity you are drawing. 

After you create complex entities, you can modify them using the entity-modification 

tools. Several of these entity types require special editing commands. 

 
 

 
 
 

 

5 
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Drawing rectangles and squares 
 

Rectangles are closed polylines with four sides and a square is a rectangle with four 

equal sides. 

You draw a rectangle by specifying its opposite corners. The rectangle is normally 

aligned parallel to the current snap and grid alignment, but you can use the Rotated 

option to align the rectangle to any angle. 

You draw a square using the Square option of the Rectangle command. The square is 

normally aligned parallel to the current snap and grid alignment, but you can use the 

Rotated option to align the square to any angle. 
 

To draw a rectangle 

1 Do one of the following to choose Rectangle (  ): 

• On the ribbon, choose Home > Rectangle or choose Draw > Rectangle. 

• On the menu, choose Draw > Rectangle. 

• On the Draw toolbar, click the Rectangle tool. 

• Type rectangle and then press Enter. 

2 Specify one corner of the rectangle. 

3 Specify the opposite corner of the rectangle. 

 
 

 
Opposite corners (A and B) and resulting rectangle. 

You can edit each side of a rectangle individually using the Edit Polyline tool (  ) 

on the Modify toolbar. You can convert the sides into individual line entities using 

the Explode tool (  ) on the Modify toolbar. You can control whether wide rectan- 

gle lines are shown filled or as outlines using the Fill tool (  ) on the Settings tool- 
bar. 

You can also use the Rectangle tool to draw a square. Instead of specifying the oppo- 

site corners, you specify the length of one side and the alignment of the square. 

B 
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To draw a square 

1 Do one of the following to choose Rectangle (  ): 

• On the ribbon, choose Home > Rectangle or choose Draw > Rectangle. 

• On the menu, choose Draw > Rectangle. 

• On the Draw toolbar, click the Rectangle tool. 

• Type rectangle and then press Enter. 

2 In the prompt box, choose Square. 

3 Specify one corner of the square. 

4 Specify the length of one side of the square by selecting its other end. 

The point you specify determines both the size and alignment of the square. 
 
 
 

 
B 

 
 
 

Endpoints of one side of the square (A and B) and resulting square. 

 
 

You can control the line width of rectangles. 

Choose the Width Of Line option in the prompt box. After you change the width of the 

line, the new width setting remains in effect for subsequent rectangles until you 

change it again. 
 

 

A 
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Drawing polygons 
 

Polygons are closed polylines composed of a minimum of three and a maximum of 

1,024 equal-length sides. The default method for drawing a polygon is to specify the 

center of the polygon and the distance from the center to each vertex. You can draw a 

polygon using any of the following methods: 

• Center-Vertex ( ) 

• Center-Side ( ) 

• Edge (  ) 

 

Drawing polygons by vertex 
You can create an equal-sided polygon defined by its center point and the distance to 

its vertices. First specify the number of sides, then the center point, and then the loca- 

tion of one vertex, which determines both the size and orientation of the polygon. 
 

To draw a polygon by vertex 

1 Do one of the following to choose Polygon Center-Vertex (  ): 

• On the ribbon, choose Home > Polygon Center-Vertex or choose Draw > 

Polygon Center-Vertex. 

• On the menu, choose Draw > Polygon > Polygon Center-Vertex. 

• On the Draw toolbar, click the Polygon Center-Vertex tool. 

• Type polygon and then press Enter. 

2 Type 5 to specify five sides for the polygon. 

3 Specify the center of the polygon. 

4 Specify the vertex of the polygon. 

 
 

 
The center (A) and vertex (B) and resulting polygon. 

 
B 

A 
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Drawing polygons by side 
You can create a polygon with equal-length sides defined by its center point and the 

distance to the midpoint of a side. First specify the number of sides, then the center 

point, and then the location of the midpoint of one side, which determines both the 

size and orientation of the polygon. 
 

To draw a polygon by side 

1 Do one of the following to choose Polygon Center-Side (  ): 

• On the ribbon, choose Home > Polygon Center-Side or choose Draw > Polygon 

Center-Side. 

• On the menu, choose Draw > Polygon > Polygon Center-Side. 

• On the Draw toolbar, click the Polygon Center-Side tool. 

• Type polygon and then press Enter. 

2 Type 3 to specify three sides for the polygon. 

3 Specify the center of the polygon. 

4 Specify the midpoint of the side. 

 
 

 
The center (A) and midpoint of one side (B) and resulting polygon. 

 

Drawing polygons by specifying the length of an edge 
You can create a polygon with equal-length sides defined by the length of one of the 

polygon edges. First specify the number of sides, then the edge start point, and then 

the edge end point, which determines both the size and orientation of the polygon. 
 

To draw a polygon by specifying the length of an edge 

1 Do one of the following to choose Polygon Edge (  ): 

• On the ribbon, choose Home > Polygon Edge or choose Draw > Polygon Edge. 

• On the menu, choose Draw > Polygon > Polygon Edge. 

• On the Draw toolbar, click the Polygon Edge tool. 

• Type polygon and then press Enter. 

2 Type 5 to specify three sides for the polygon. 

3 Specify the first point of an edge on the polygon. 

4 Specify the second point of the edge on the polygon. 

 

 

B 

A 
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Drawing polylines 

Start point of side (A) and end point of side (B) and resulting polygon. 

You can edit each side of a polygon individually using the Edit Polyline tool (  ) on 

the Modify toolbar. You can convert the sides into individual line entities using the 

Explode tool (  ) on the Modify toolbar. You can control whether wide polygon 
lines are shown filled or as outlines using the Fill tool ( ) on the Settings toolbar. 

 

A polyline is a connected sequence of arcs and lines that is treated as a single entity. 

You can draw a polyline with any linetype and using a width that either remains con- 

stant or tapers over the length of any segment. When editing a polyline, you can mod- 

ify the entire polyline or change individual segments. 

 

 
Curved polyline with tapered width, polyline with straight segments, and closed polyline. 

You can edit entire polylines and individual segments using the Edit Polyline tool ( 
 ) on the Modify toolbar. You can convert polylines into arc and line entities 

using the Explode tool (  ) on the Modify toolbar. You can control whether wide 

polylines are shown filled or as outlines using the Fill tool (  ) on the Settings 

toolbar. 

 

Drawing a polyline with straight segments 
After you specify the start point of a polyline, a prompt box provides several options 

as you draw, such as Distance, Halfwidth, and Width. You can specify different start- 

ing and ending widths to create a tapered polyline segment. 

After you draw at least one polyline segment, you can use the Undo tool ( ) to 

remove the previous segment. After you draw two or more polyline segments, you 

can use the Close option to complete the command by drawing a segment that ends at 

the start point of the first polyline segment you drew. Choose Done to complete the 

command without closing the polyline. 

 
B 

 
 

A 
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B 

A 
B 

B 

 
To draw a polyline with straight segments 

1 Do one of the following to choose Polyline (  ): 

• On the ribbon, choose Home > Polyline or choose Draw > Polyline. 

• On the menu, choose Draw > Polyline. 

• On the Draw toolbar, click the Polyline tool. 

• Type polyline and then press Enter. 

2 Specify the start point. 

3 Specify the endpoint of each segment. 

4 To complete the command, choose Close or Done. 

 

 

 
Polyline start point (A) and segment endpoints (B). 

 

Drawing a polyline with arc segments 
With the Draw Arcs option, you can continually draw arc segments until you select 

the Draw Lines option to go back to drawing line segments. When you draw arc seg- 

ments, the first point of the arc is the endpoint of the previous segment. By default, 

you draw arc segments by specifying the endpoint of each segment. Each successive 

arc segment is drawn tangent to the previous arc or line segment. If you choose Close 

while in the Draw Arcs option, the closing segment is created as an arc. 

B 
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You can also specify the arc using any of the following methods: 

• Start point, included angle, center point 

• Start point, included angle, radius 

• Start point, center point, endpoint 

• Start point, included angle, endpoint 

• Start point, center point, included angle 

• Start point, center point, chord length 

• Start point, direction, endpoint 

• Start point, radius, included angle 

• Start point, second point, endpoint 
 

To draw a line segment followed by an arc polyline segment 

1 Do one of the following to choose Polyline (  ): 

• On the ribbon, choose Home > Polyline or choose Draw > Polyline. 

• On the menu, choose Draw > Polyline. 

• On the Draw toolbar, click the Polyline tool. 

• Type polyline and then press Enter. 

2 Specify the start point. 

3 Specify the endpoint. 

4 In the prompt box, choose Draw Arcs. 

5 Specify the endpoint of the arc segment. 

6 To complete the command, choose Done. 

 
 

 
Polyline start point (A), line endpoint/arc start point (B), and arc endpoint (C). 

C 
A 

B 
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Drawing multilines 
 

A multiline is made from multiple parallel lines (two lines by default), which consist 

of linear segments connected together. The end of the current segment is the start of 

the next segment. Ends of segments are the vertices of the multiline. 

 

Drawing a multiline 

To draw a multiline 

1 Do one of the following to choose Multiline ( ): 

• On the ribbon, choose Draw > Multiline. 

• On the menu, choose Draw > Multiline. 

• On the Draw toolbar, click the Multiline tool. 

• Type mline and then press Enter. 

2 Specify the start point. 

3 Specify additional vertices. 

4 After specifying the last endpoint, choose Done or press Enter. 

 
 

 
Multiline startpoint (A), vertices (B), and endpoint (C). 

 

Specifying justification and scale 
When you draw a multiline, you specify the vertices of one of the lines that makes up 

the multiline — the additional parallel lines are drawn in position according to the 

justification. Vertices can be specified on the top, middle, or bottom of a multiline, 

according to the selected justification. 

You can also determine the overall width of the multiline, which affects the distance 

between parallel lines, by adjusting the multiline scale. 

 
 

NOTE If you change the multiline scale, you might need to make equivalent changes to 

the linetype scale to prevent dots or dashes from being disproportionately sized. 
 

 

C 

B 

A 
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To draw a multiline with different justification or scale 

1 Do one of the following to choose Multiline ( ): 

• On the ribbon, choose Draw > Multiline. 

• On the menu, choose Draw > Multiline. 

• On the Draw toolbar, click the Multiline tool. 

• Type mline and then press Enter. 

2 Select justification and choose one of the following options: 

• Top Specified vertices define the top line; additional parallel lines are drawn 

below the specified vertices. 

• Zero Specified vertices define the middle of the multiline. 

• Bottom Specified vertices define the bottom line; additional parallel lines are 

drawn above the specified vertices. 

3 Select Scale and enter a new scale value according to the following: 

• Greater than 1 — Multilines are wider. 

• Less than 1 — Multilines are narrower. 

• Equal to 1 — Multilines collapse into a single line. 

• Negative value — Flips the justification when multilines are drawn and alters 

the scale according to the set value. 

4 Specify the start point of the multiline. 

5 Specify additional vertices. 

6 After specifying the endpoint, choose Done or press Enter. 
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Working with multiline styles 
When you create a multiline, the program draws it on the current layer, using the cur- 

rent multiline style. Each multiline has a corresponding multiline style, which con- 

trols the appearance of the multiline, such as the number of parallel lines, the spacing 

between each line and each line’s color and linetype, start and end caps, and more. 

You can create, save, modify, and delete named multiline styles. You can also set any 

multiline style to be the current one that is assigned to new multilines as you add 

them to your drawing. Multiline styles can be exported and imported as .mln files 

which makes it easy to share them between computers. 

 
Creating or modifying a multiline style 
Multiline styles provide a way for you to change various settings that control the 

appearance of multilines. You can then save those settings for reuse. If you don’t 

define a multiline style before creating multilines, the program uses the Standard 

multiline style, which stores the default multiline settings. 

If you modify a multiline style, all multilines entities that are assigned that style will 

be updated. 
 

To create a multiline style 

1 Do one of the following to choose Multiline Styles Manager (  ): 

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools). 

• On the menu, choose Format > Multiline Styles Manager or choose Express 

Tools > Tools > Multiline Styles Manager. 

• On the Styles toolbar, click the Multiline Styles Manager tool. 

• Type mlstyle and then press Enter. 

2 Click New. 

3 In Style Name, type the name of the new multiline style. 

4 In Start With, select an existing multiline style on which to base the new multiline 

style. 

5 Click Continue. 

6 In the Create New Multiline Style dialog box, make your selections for the multi- 

line style as necessary. 

7 When finished, click OK. 
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To modify a multiline style 

1 Do one of the following to choose Multiline Styles Manager (  ): 

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools). 

• On the menu, choose Format > Multiline Styles Manager or choose Express 

Tools > Tools > Multiline Styles Manager. 

• On the Styles toolbar, click the Multiline Styles Manager tool. 

• Type mlstyle and then press Enter. 

2 Select the multiline style you want to modify, then click Modify. 

3 In the Modify Multiline Style dialog box, make your selections for the multiline 

style as necessary. 

4 When finished, click OK. 

 

 
 

A Enter a description for the multiline style. 

B Select whether to include a line to cap the start 
or end of multilines assigned this style. 

C Select whether to include an arc for outer lines to 
cap the start or end of multilines assigned this 
style. 

D Select whether to include an arc for inner lines to 
cap the start or end of multilines assigned this 
style. 

E Select whether to include an angled line to cap 
the start or end of multilines assigned this style. 

F Select the color fill for multilines assigned this 
style. 

G Select whether to include a line at joints of 
multilines assigned this style. If turned on, a line 
is drawn from the two outer vertices of the 
multiline's joint. 

H Click to select the linetype for the element. 

I Select the line color for the element. 

J Enter the distance to offset the element, or line, 
from the previous element. 

K Click to add a new element according to the 
current offset, color, and linetype selections. 

L Click to delete the selected element. 

M Displays a list of the offset, color, and linetype 
combinations assigned to each element, or line. 

A 

B 
C 

D 

E 

M 

L 
K 
J 

F 
I 

G H 
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Setting the current multiline style 
When you create a multiline, it is automatically assigned the multiline style that is set 

to current. By default, the program uses the Standard multiline style, which stores the 

default multiline settings. Or you can choose a different multiline style to be the cur- 

rent one. 

If you choose a different multiline style as current, that style is assigned to multilines 

that you create in the future, not existing multilines. 
 

To set a multiline style as current 

1 Do one of the following to choose Multiline Styles Manager (  ): 

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools). 

• On the menu, choose Format > Multiline Styles Manager or choose Express 

Tools > Tools > Multiline Styles Manager. 

• On the Styles toolbar, click the Multiline Styles Manager tool. 

• Type mlstyle and then press Enter. 

2 In the Multiline Styles Manager dialog box, select a multiline style from the list. 

3 Click Set Current. 

4 Click OK. 

 
Assigning a style to a multiline 
You can assign a different multiline style to a multiline at any time. 

 

To assign a style to a multiline 

1 Select a multiline in the drawing. 

2 Do one of the following: 

• On the Styles toolbar, select the style in the Multiline Style list. 

• Right-click the multiline, choose Properties, then in Style, select the style. 

 
Renaming a multiline style 
Use the Multiline Styles Manager dialog box to rename a multiline style. Note that 

the Standard multiline style cannot be renamed. 
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To rename a multiline style 

1 Do one of the following to choose Multiline Styles Manager (  ): 

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools). 

• On the menu, choose Format > Multiline Styles Manager or choose Express 

Tools > Tools > Multiline Styles Manager. 

• On the Styles toolbar, click the Multiline Styles Manager tool. 

• Type mlstyle and then press Enter. 

2 In the Multiline Styles Manager dialog box, select the multiline style to rename. 

3 Click Rename. 

4 Type the new name, then click OK. 

5 Click OK. 

 
Deleting a multiline style 
Use the Multiline Styles Manager dialog box to delete a multiline style. Note that the 

Standard multiline style cannot be deleted, and multiline styles that are in use also 

cannot be deleted. 
 

To delete a named multiline style 

1 Do one of the following to choose Multiline Styles Manager (  ): 

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools). 

• On the menu, choose Format > Multiline Styles Manager or choose Express 

Tools > Tools > Multiline Styles Manager. 

• On the Styles toolbar, click the Multiline Styles Manager tool. 

• Type mlstyle and then press Enter. 

2 In the Multiline Styles Manager dialog box, select the multiline style to delete. 

3 Click Delete. 

4 To confirm the deletion, click OK. 

5 Click OK. 

 
Importing and exporting multiline style files 
Multiline styles can be imported and exported as .mln files which makes it easy to 

move multiline styles between computers. 
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To export a multiline style file 

1 Do one of the following to choose Multiline Styles Manager (  ): 

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools). 

• On the menu, choose Format > Multiline Styles Manager or choose Express 

Tools > Tools > Multiline Styles Manager. 

• On the Styles toolbar, click the Multiline Styles Manager tool. 

• Type mlstyle and then press Enter. 

2 In the Multiline Styles Manager dialog box, select the multiline style to export. 

3 Click Export. 

4 Specify the name and location for the .mln file, then click Save. 

5 Click OK. 
 

To import a multiline style file 

1 Do one of the following to choose Multiline Styles Manager (  ): 

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools). 

• On the menu, choose Format > Multiline Styles Manager or choose Express 

Tools > Tools > Multiline Styles Manager. 

• On the Styles toolbar, click the Multiline Styles Manager tool. 

• Type mlstyle and then press Enter. 

2 In the Multiline Styles Manager dialog box, click Import. 

The Import Multiline Style from File dialog box displays a list of the multiline 

styles that have already been loaded. 

3 Click File. 

4 Navigate to and select the .mln file to import, then click Open. 

5 Click OK. 
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Drawing traces 
 

With the Trace command, you can draw a two-dimensional solid line of specified 

width. The Trace command is not commonly used — most users use the Polyline 

command instead. 
 

To draw a trace 

1 Type trace and then press Enter. Or on the ribbon, choose Draw > Trace. 

2 Specify the width of the trace. 

3 Specify the start point. 

4 Specify additional vertices. 

5 After specifying the last endpoint, choose Done or press Enter. 

 
 

 
Trace startpoint (A), vertices (B), and endpoint (C). 

C 
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Drawing splines 
 

A spline is a smooth curve defined by a set of points. You can use splines to create 

sculptured shapes such as the cross section of a turbine blade or an airplane wing. 
 

To draw a spline 

1 Do one of the following to choose Spline (  ): 

• On the ribbon, choose Draw > Spline. 

• On the menu, choose Draw > Spline. 

• On the Draw toolbar, click the Spline tool. 

• Type spline and then press Enter. 

2 Specify the first point of the spline. 

3 Specify the second point of the spline. 

4 Specify as many more points as you want. 

5 When you have finished, press Enter. 
 

You can add tangents to the spline, which are lines that give it shape. 
 

To add tangents to a spline 

1 Specify the starting tangent point. 

2 Specify the ending tangent point. 

 
 

 
Initial spline and resulting spline with starting tangent point (A) and ending tangent point (B). 

 
 
 

 
 
 

 
A B 
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Specifying fit tolerance 
By default, a spline passes through all of the control points. When you draw a spline, 

you can change this by specifying the fit tolerance. The fit tolerance value determines 

how closely the spline fits the set of points you specify. For example, a spline fit tol- 

erance value of 0 causes the spline to pass through the control points. A value of 0.01 

creates a spline that passes through the start and endpoints and within 0.01 units of 

the intermediate control points. 
 

To specify the fit tolerance 

1 Do one of the following to choose Spline (  ): 

• On the ribbon, choose Draw > Spline. 

• On the menu, choose Draw > Spline. 

• On the Draw toolbar, click the Spline tool. 

• Type spline and then press Enter. 

2 Specify the first point of the spline. 

3 Specify the second point of the spline. 

4 In the prompt box, choose Fit Tolerance. 

5 To accept the default of 0.0000, press Enter. 

To specify a different fit tolerance, type the number, and then press Enter. 

6 Specify the additional points you need to draw a spline or a closed spline. 
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Drawing a closed spline 
You can draw a closed spline, which is a spline for which the start point and endpoint 

are the same. Because the spline is closed, you specify only one tangent. 
 

To draw a closed spline 

1 Do one of the following to choose Spline (  ): 

• On the ribbon, choose Draw > Spline. 

• On the menu, choose Draw > Spline. 

• On the Draw toolbar, click the Spline tool. 

• Type spline and then press Enter. 

2 Specify the first point of the spline. 

3 Specify the second point of the spline. 

4 Specify as many more points as you want. 

5 When you have finished, in the prompt box, choose Close. 

6 To complete the command, specify the tangent point. 

 
 

 
The start point and endpoint (A) of a closed spline. 

 
 
 

A 



150 C H A P T E R   5 
 

 

Drawing helices 
 

A helix is a three-dimensional spiral that is open at both ends. The base and top can 

be equal values, similar to a coil or spring, or they can be different values, similar to a 

cone. 

 
 

Helices are often used to create other entities. 

In particular, the Sweep, Loft, and Revolve commands can all be used with helices in 

more complex drawings to create spiral stairs, spiral parts, and more. 
 

 

 
To draw a helix 

1 Do one of the following to choose Helix (  ): 

• On the ribbon, choose Draw > Helix. 

• On the menu, choose Draw > Helix. 

• On the Draw toolbar, click the Helix tool. 

• Type helix and then press Enter. 

2 Specify the center point of the helix. 

3 Specify the radius (or diameter) of the bottom of the helix. 

4 Specify the radius (or diameter) of the top of the helix. 

5 Optionally set any of the following: 

• Turns Specify the number of full turns. The default number of turns is three. The 

maximum is 500. 

• Turn height Specify the height of one full turn, which updates the number of 

turns automatically. This option is available only if you have not specified a 

number of turns. 

• Twist Specify the direction of helix turns: clockwise (CW) or counterclockwise 

(CCW). 

6 Specify the height and position of the helix by choosing one of the following: 

• Choose Axis endpoint and specify the endpoint of the helix, which determines 

the position and direction of the helix. 

• Specify the height of the helix. If the height is zero, the helix will be a two- 

dimensional spiral, but if the start and end radius are the same it will look like a 

circle. 
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Helix center point (A), bottom radius (B), top radius (C), and height (D). 

 

 

Drawing donuts 
 

Donuts are solid, filled circles or rings created as closed, wide polylines. You can 

draw a donut using one of several methods. The default method is to specify the 

inside and outside diameters of the donut, and then specify its center. You can then 

create multiple copies of the same donut by specifying different center points until 

you press Enter to complete the command. 
 

To draw a donut 

1 Do one of the following to choose Donut ( ): 

• On the ribbon, choose Draw > Donut. 

• On the menu, choose Draw > Donut. 

• On the Draw toolbar, click the Donut tool. 

• Type donut and then press Enter. 

2 Specify the inside diameter of the donut. 

3 Specify the outside diameter of the donut. 

4 Specify the center of the donut. 

5 Specify the center point to draw another donut, or choose Done to complete the 

command. 

 

D 
 

 
 

B,C 
 

 
A 
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Inside diameter (A) and outside diameter (B). 

The prompt box provides additional options for drawing donuts. For example, you 

can specify the width of the donut and two points on the diameter of the donut, or you 

can specify the width and three points on the donut. You can also draw a donut tan- 

gent to existing entities. 

 
 

A donut can be a completely filled circle. 

Donuts are completely filled if the inside diameter is zero. 
 

 

 
To draw a donut tangent to existing entities 

1 Do one of the following to choose Donut ( ): 

• On the ribbon, choose Draw > Donut. 

• On the menu, choose Draw > Donut. 

• On the Draw toolbar, click the Donut tool. 

• Type donut and then press Enter. 

2 In the prompt box, choose Radius Tangent Tangent. 

3 Specify the width of the donut. 

4 Specify the diameter of the donut. 

5 Select the first tangent entity to which to draw the donut. 

6 Select the second tangent entity to which to draw the donut. 

 
 

 
Width (A) and diameter (B) of the donut and tangent entities (C). 

B 

C 
 

 
C 

 
A 

 

B 
 

 
A 
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You can edit donuts using the Edit Polyline tool (  ) on the Modify toolbar. You 

can convert donuts into arc entities using the Explode tool (  ) on the Modify 

toolbar. You can control whether donuts are shown filled or as outlines using the Fill 
tool (  ) on the Settings toolbar. 

 
 

You can control the default outside and inside diameter of donuts. 

Choose Tools > Drawing Settings, click the Entity Creation tab, and choose the 

options you want. 
 

 

 

 
 

Creating planes 
 

With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled 

with a solid color. The default method is to specify the corners of the plane. After you 

specify the first two corners, the plane is displayed as you specify the remaining cor- 

ners. Specify corner points in a triangular manner. The program prompts you for the 

third point and then the fourth point. If you continue specifying points, the third- and 

fourth-point prompts toggle until you press Enter to complete the command. 

Creating planes in 4MCAD is similar to the Solid command in AutoCAD. 
 

To draw a quadrilateral plane 

1 Do one of the following to choose Plane ( ): 

• On the ribbon, choose Draw > Plane. 

• On the menu, choose Draw > Plane. 

• On the Draw toolbar, click the Plane tool. 

• Type plane and then press Enter. 

2 Specify the first point. 

3 Specify the second point. 

4 Specify the third point. 

5 Specify the fourth point. 

6 To complete the command, press Enter. 

 

 

 
After you select the first two points (A) and (B), the sequence in which you select the third (C) 
and fourth (D) points determines the shape of the resulting quadrilateral plane. 
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The prompt box provides additional options for drawing planes. For example, you 

can draw rectangular, square, or triangular planes. 

 
To draw a rectangular plane 

1 Do one of the following to choose Plane ( ): 

• On the ribbon, choose Draw > Plane. 

• On the menu, choose Draw > Plane. 

• On the Draw toolbar, click the Plane tool. 

• Type plane and then press Enter. 

2 Choose Rectangle. 

3 Specify the first point. 

4 Specify the opposite corner. 

5 Specify the rotation angle. 

6 To complete the command, specify the opposite corner to draw another rectangle, 

or press Enter. 

 
 

 
Opposite corners (A and B) and rotation angle (C) and resulting plane. 

You can control whether planes are shown filled or as outlines using the Fill tool 

(  ) on the Settings toolbar. You can convert planes into individual line entities cor- 

responding to the outline of the plane using the Explode tool (  ) on the Modify 

toolbar. 
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Drawing architectural entities 
 

Architectural entities, commonly called AEC entities, are custom entities that you can 

use to quickly draw walls, doors, windows, slabs, roofs, and more. 

 

Drawing a wall 
Walls can be drawn as interior, exterior, fireproof, foundational, and more. 

After you draw a wall, you can modify it as you would other entities using modify 

entity commands. You can also use the Properties pane to change the width, style, 

automatic cleanup, etc. And when you select a wall, grips display allowing you to 

resize and reorient the wall in real-time. 
 

To draw a wall 

1 Do one of the following to choose Walls ( ): 

• On the ribbon, choose Draw > Walls and then the wall style (in AEC Entities). 

• On the menu, choose Draw > AEC Entities > Walls and then the wall style. 

• On the Walls toolbar, click a wall style. 

• Type wall and then press Enter. 

2 Specify the start point of the wall. 

3 Specify the endpoint of each segment. 

4 After specifying the last endpoint, press Enter. 

 

Drawing a door 
Doors can be drawn in a wide variety of styles: single swing, double swing, sliding, 

revolving, and many more. 

After you draw a door, you can modify it as you would other entities using modify 

entity commands. For example, doors can be easily moved and resized within a wall. 

You can also use the Properties pane to change the width, style, etc. And when you 

select a door, grips display allowing you to resize and reorient the door in real-time. 

There is also a special arrow grip for doors that allows you to change the swing with a 

single click. 
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To draw a door 

1 Do one of the following to choose Doors ( ): 

• On the ribbon, choose Draw > Doors and then the door style (in AEC Entities). 

• On the menu, choose Draw > AEC Entities > Doors and then the door style. 

• On the Doors toolbar, click a door style. 

• Type door and then press Enter. 

2 Select the wall where you want to locate the door, or press Enter if not choosing an 

existing wall. 

3 Specify the point where you want to locate the door. 

4 After specifying the last location, press Enter. 

 

Drawing a window 
Windows can be drawn as single hung, double hung, picture, pivot, and many more. 

After you draw a window, you can modify it as you would other entities using modify 

entity commands. For example, windows can be easily moved and resized within a 

wall. You can also use the Properties pane to change the width, style, etc. And when 

you select a window, grips display allowing you to resize and reorient the window in 

real-time. There is also a special arrow grip for windows that allows you to change 

the opening orientation with a single click. 
 

To draw a window 

1 Do one of the following to choose Windows ( ): 

• On the ribbon, choose Draw > Windows and then the window style (in AEC 

Entities). 

• On the menu, choose Draw > AEC Entities > Windows and then the window 

style. 

• On the Windows toolbar, click a window style. 

• Type window and then press Enter. 

2 Select the wall where you want to locate the window, or press Enter if not choos- 

ing an existing wall. 

3 Specify the point where you want to locate the window. 

4 After specifying the last location, press Enter. 
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Drawing stairs 
Stairs can be drawn in different types and styles such as spiral, straight, cantilever, a 

ramp, and more. 

After you draw stairs, you can modify them as you would other entities using modify 

entity commands. For example, stairs can be easily moved and resized relative to a 

wall or slab. You can also use the Properties pane to change the stair width, tread 

dimensions, landing dimensions, turn on/off stringers, etc. When stairs are modified, 

any attached railings are updated to match the stair modifications (length, angle, 

width, etc.). And when you select stairs, grips display allowing you to resize and 

reorient them in real-time. 
 

To draw stairs 

1 Do one of the following to choose Stairs ( ): 

• On the ribbon, choose Draw > Stairs and then the stair style (in AEC Entities). 

• On the menu, choose Draw > AEC Entities > Stairs and then the stair style. 

• On the Stairs toolbar, click a stair style. 

• Type stair and then press Enter. 

2 If necessary, choose an option to change the default value for the stairs you want 

to draw. 

3 When done entering values, specify the point where you want to start the stairs. 

4 Enter the stair segment length, then press Enter. 

5 Specify the endpoint of the stairs. 
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Drawing a railing 
Railings can be drawn in different styles such as standard, bollard, vertical or hori- 

zontal cable, and many more. 

After you draw a railing, you can modify it as you would other entities using modify 

entity commands. For example, standalone railings can be easily moved and resized. 

You can also use the Properties pane to change the style, rail height, post placement, 

etc. And when you select a railing, grips display allowing you to resize and reorient 

the railing in real-time. 
 

To draw a railing attached to stairs 

1 Do one of the following to choose Railings ( ): 

• On the ribbon, choose Draw > Railings and then the railing style (in AEC 

Entities). 

• On the menu, choose Draw > AEC Entities > Railings and then the railing style. 

• On the Railings toolbar, click a railing style. 

• Type railing and then press Enter. 

2 Choose Attach. 

3 Specify the stairs where you want to attach a railing. 

4 Choose the location of the railing on the stairs: left, right, or center. 
 

To draw a railing that is not attached to stairs 

1 Do one of the following to choose Railings ( ): 

• On the ribbon, choose Draw > Railings and then the railing style (in AEC 

Entities). 

• On the menu, choose Draw > AEC Entities > Railings and then the railing style. 

• On the Railings toolbar, click a railing style. 

• Type railing and then press Enter. 

2 Specify the start point where you want to locate the railing. 

3 Specify additional points to create railing segments. 

4 After specifying the last point, press Enter. 



C R E A T I N G   C O M P L E X   E N T I T I E S 159 
 

 
Drawing a curtain wall 
Curtain walls can be drawn in different styles and can also be converted from existing 

two-dimensional entities such as lines, arcs, circles, and polylines. 

After you draw a curtain wall, you can modify it as you would other entities using 

modify entity commands. You can also use the Properties pane to change settings for 

divisions, infill, mullion and frame. And when you select a curtain wall, grips display 

allowing you to resize and reorient the curtain wall in real-time. 
 

To draw a curtain wall 

1 Do one of the following to choose Curtain Wall ( ): 

• On the ribbon, choose Draw > Walls > Curtain Wall (in AEC Entities) or Draw 

> Windows > Curtain Wall (in AEC Entities). 

• On the menu, choose Draw > AEC Entities > Walls > Curtain Wall or Draw > 

AEC Entities > Windows > Curtain Wall. 

• On the Walls toolbar, click a wall style. 

• Type curtainwall and then press Enter. 

2 If desired, choose Height to enter the height of the curtain wall. 

3 If desired, choose Style and enter the name of the curtain wall style. To view the 

list of all styles, choose ?. 

4 Specify the start point of the curtain wall. 

5 Specify the endpoint of each segment. 

6 If you want to add an arc segment, do the following: 

• Choose Arc. 

• Specify the midpoint of the arc segment. 

• Specify the endpoint of the arc segment. 

• Choose Line to continue adding line segments or choose Close to add the last 

endpoint at the start point. 

7 After specifying the last endpoint, press Enter. 
 

To convert two-dimensional entities to a curtain wall 

1 Do one of the following to choose Curtain Wall ( ): 

• On the ribbon, choose Draw > Walls > Curtain Wall (in AEC Entities) or Draw 

> Windows > Curtain Wall (in AEC Entities). 

• On the menu, choose Draw > AEC Entities > Walls > Curtain Wall or Draw > 

AEC Entities > Windows > Curtain Wall. 

• On the Walls toolbar, click a wall style. 

• Type curtainwall and then press Enter. 

2 Choose Convert. 
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3 Select lines, arcs, circles, or polylines to convert to curtain walls, then press Enter. 

4 Choose Yes to delete the original two-dimensional entities, or choose No to retain 

the original two-dimensional entities. 

 

Drawing steel 
Steel entities can be drawn in many different shapes. 

 

To draw steel 

1 Do one of the following to choose Steel ( ): 

• On the ribbon, choose Draw > Steel and then the steel style (in AEC Entities). 

• On the menu, choose Draw > AEC Entities > Detailing > Steel and then the steel 

shape. 

• On the Steel toolbar, click a steel shape. 

• Type steel and then press Enter. 

2 Select the steel dimensions from the list. 

3 Click OK. 

4 To mirror the shape about its x-axis, choose XFlip. To mirror the shape about its 

y-axis, choose YFlip. 

5 Specify the insertion point. 

6 Specify the angle of rotation. 

7 Specify the length. If the length is 0, a two-dimensional steel shape is created. 

 

Drawing a stud, joist, or track 
Studs, joists, and track can be drawn in many different shapes and styles. 

 

To draw studs, joists, or track 

1 Do one of the following to choose Studs, Joists, Track: 

• On the ribbon, choose Draw > Steel and then Stud, S-Stud, Joist, or Track (in 

AEC Entities). 

• On the menu, choose Draw > AEC Entities > Detailing > Steel and then Stud, 

S-Stud, Joist, or Track. 

• On the Steel toolbar, click Stud, S-Stud, Joist, or Track. 

• Type sjt and then press Enter. 

2 Select the desired dimensions of the shape from the list. 

3 Click OK. 

4 To mirror the shape about its x-axis, choose XFlip. To mirror the shape about its 

y-axis, choose YFlip. 
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5 Specify the insertion point. 

6 Specify the angle of rotation. 

7 Specify the length. If the length is 0, a two-dimensional shape is created. 

 

Drawing wood 
Wood details can be drawn as lumber and TJI joists shapes in many different standard 

sizes. 
 

To draw wood 

1 Do one of the following to choose Wood ( ): 

• On the ribbon, choose Draw > Wood and then Lumber or TJI Joists (in AEC 

Entities). 

• On the menu, choose Draw > AEC Entities > Detailing > Wood and then 

Lumber or TJI Joists. 

• Type wood and then press Enter. 

2 Select the desired dimensions from the list. 

3 Click OK. 

4 To mirror the shape about its x-axis, choose XFlip. To mirror the shape about its 

y-axis, choose YFlip. 

5 Specify the insertion point. 

6 Specify the angle of rotation. 

7 Specify the length. If the length is 0, a two-dimensional shape is created. 

 

Drawing a slab 
Slabs are foundations that are easy to draw at the beginning of an architectural project 

or at any time later relative to walls. 

After you draw a slab, you can modify it as you would other entities using modify 

entity commands. For example, slabs can be easily moved and resized relative to a 

wall. You can also use the Properties pane to change the thickness, style, etc. And 

when you select a slab, grips display allowing you to resize and reorient the slab in 

real-time. 
 

To draw a slab 

1 Do one of the following to choose Slab ( ): 

• On the ribbon, choose Draw > Slab (in AEC Entities). 

• On the menu, choose Draw > AEC Entities > Slab. 

• Type slab and then press Enter. 

2 Specify the start point of the slab. 
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3 Specify the endpoint of each segment. 

4 After specifying the last endpoint, press Enter. 

 

Drawing a roof 
A roof is similar to a slab except it is drawn above walls instead of below. 

After you draw a roof, you can modify it as you would other entities using modify 

entity commands. For example, roofs can be easily moved and resized relative to a 

wall. You can also use the Properties pane to change the thickness, style, etc. And 

when you select a roof, grips display allowing you to resize and reorient the roof in 

real-time. 
 

To draw a roof 

1 Do one of the following to choose Roof Slab ( ): 

• On the ribbon, choose Draw > Roof Slab (in AEC Entities). 

• On the menu, choose Draw > AEC Entities > Roof Slab. 

• Type roofslab and then press Enter. 

2 Specify the start point of the roof slab. 

3 Specify the endpoint of each segment. 

4 After specifying the last endpoint, press Enter. 

 

Converting 2D entities to walls and slabs 
You can convert several 2D entity types to walls or slabs: lines, circles, arcs, and 

polylines. 
 

To convert entities to a wall 

1 Do one of the following to choose Convert to Wall ( ): 

• On the ribbon, choose Draw > Convert to Wall (in AEC Entities). 

• On the menu, choose Draw > AEC Entities > Convert to Wall. 

• Type wall, press Enter, then choose Convert. 

2 Select the 2D entities to convert. 

3 Choose whether to delete the 2D entities when they are converted to walls. 
 

To convert entities to a slab 

1 Do one of the following to choose Convert to Slab ( ): 

• On the ribbon, choose Draw > Convert to Slab (in AEC Entities). 

• On the menu, choose Draw > AEC Entities > Convert to Slab. 

• Type slab, press Enter, then choose Convert. 

2 Select the 2D entities to convert. 

3 Choose whether to delete the 2D entities when they are converted to slabs. 
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Drawing a section line 
A section line can be drawn in any three-dimensional drawing to determine a two- 

dimensional projection of the area you want to view. The section line is a polyline 

that can consist of continuous segments that define the area you want to view. 

After you draw a section line in your drawing, you can modify its segments and 

length, then update the two-dimensional projection view. 
 

To draw a selection line 

1 Do one of the following to choose Section Line ( ): 

• On the ribbon, choose Draw > Section Line (in AEC Entities). 

• On the menu, choose Draw > AEC Entities > Section Line. 

• Type sectionline and then press Enter. 

2 Specify the start point of the section line. 

3 Specify the end point of each segment. 

4 Specify the end point of the section line, then press Enter. 

5 Specify the insertion point of the 2D projection. 
 

To add a new 2D projection from an existing section line 

1 Type sectionlinegenerate and then press Enter. 

2 Select the section line, then press Enter. 

3 Specify an insertion point for the new 2D projection view. 
 

 

Use a shortcut. 

Right-click the section line you want to generate a new projection for, then choose 

Generate 2D Section. 
 

 

 
To modify the position of an existing section line 

1 Select the section line. 

2 Move its start point, segments, end point, or length. 

3 If automatic updating is turned off, right-click the 2D projection, then choose 

Refresh. 

 

To modify the properties of a section line symbol 

1 Select the symbol of a section line. 

2 In the Properties pane, choose new properties, including the label text. Note that 

the symbol is annotative and can be scaled. 
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Use the AECAUTOUPDATE system variable to control automatic updating. 

If AECAUTOUPDATE is set to 1, two-dimensional projection views update automat- 

ically after a section line or elevation line changes. If set to 0, you need to manually 

refresh projection views after changes. 
 

 

 

Drawing an elevation line 
An elevation line can be drawn in any three-dimensional drawing to create a two- 

dimensional projection view of the drawing. 

You can modify existing elevation lines and therefore their related projection views. 

You can also modify the elevation symbol that marks the elevation line. 
 

To draw an elevation line 

1 Do one of the following to choose Elevation Line ( ): 

• On the ribbon, choose Draw > Elevation Line (in AEC Entities). 

• On the menu, choose Draw > AEC Entities > Elevation Line. 

• Type elevationline and then press Enter. 

2 Specify the start point of the elevation line. 

3 Specify the end point of the elevation line. 

If you want to include all entities in the 2D projection view, make sure the start 

and end points are beyond the start and end of the model. 

4 Specify the insertion point of the 2D projection view. 
 

To add a new 2D projection from an existing elevation line 

1 Type elevationlinegenerate and then press Enter. 

2 Select the elevation line, then press Enter. 

3 Specify an insertion point for the new 2D projection view. 
 

 

Use a shortcut. 

Right-click the elevation line you want to generate a new projection for, then choose 

Generate 2D Elevation. 
 

 

 
To reverse the direction of an existing elevation line 

1 Type elevationlinereverse and then press Enter. 

2 Select the elevation line, then press Enter. 

3 If automatic updating is turned off, right-click the 2D projection view, then choose 

Refresh. 
 

 

Use a shortcut. 

Right-click the elevation line you want to reverse, then choose Reverse. 
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To modify the position of an existing elevation line 

1 Select the elevation line. 

2 Move its start point, end point, or length. 

3 If automatic updating is turned off, right-click the 2D projection view, then choose 

Refresh. 

 

To modify the properties of an elevation line symbol 

1 Select the symbol of an elevation line. 

2 In the Properties pane, choose new properties, including the label text. Note that 

the symbol is annotative and can be scaled. 
 

 

Use the AECAUTOUPDATE system variable to control automatic updating. 

If AECAUTOUPDATE is set to 1, two-dimensional projection views update automat- 

ically after a section line or elevation line changes. If set to 0, you need to manually 

refresh projection views after changes. 
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Drawing wipeouts 
 

Wipeouts are unique entities that can help you hide areas of your drawing. They dis- 

play with the current background color, so the details behind the wipeout do not dis- 

play or print. 

Wipeouts are similar to other entities — you can copy, mirror, array, erase, rotate, 

and scale them, and they can be used in both model space and paper space. 

If you want to print the wipeout entities located in a drawing, you must print to a ras- 

ter-capable printer. Note that in some cases you may have unexpected results when 

printing drawings that contain wipeout entities, for example, if printing on colored 

paper. 

Wipeouts are created using existing polygons, closed zero-width polylines made up 

of only line segments, or new polylines that you draw while using the Wipeout com- 

mand. 

 
 

The display of wipeouts varies depending on your version of 4MCAD. 

If your 4MCAD version does not include raster image capability, wipeout entities 

display, but the details behind the wipeouts also display. 
 

 

 

Drawing a wipeout 

To draw a wipeout 

1 Do one of the following to choose Wipeout ( ): 

• On the ribbon, choose Annotate > Wipeout (in Markup). 

• On the menu, choose Draw > Wipeout. 

• On the Draw toolbar, click the Wipeout tool. 

• Type wipeout and then press Enter. 

2 Specify the start point. 

3 Specify the endpoint of each segment. 

4 After specifying the last endpoint, choose Done or press Enter. 
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Existing drawing. Drawing with wipeout. 

 

Creating a wipeout using existing polygons and polylines 

To create a wipeout using an existing polygon or polyline 

1 Do one of the following to choose Wipeout ( ): 

• On the ribbon, choose Annotate > Wipeout (in Markup). 

• On the menu, choose Draw > Wipeout. 

• On the Draw toolbar, click the Wipeout tool. 

• Type wipeout and then press Enter. 

2 Choose Polyline. 

3 Select the closed polyline to use for the wipeout. 

4 Choose one of the following: 

• Yes — Creates the wipeout and deletes the polyline used to create the wipeout. 

• No — Creates the wipeout and keeps the polyline used to create the wipeout. 

 

Turning wipeout frames on or off 
Each wipeout has a frame along its boundary. Wipeout frames can be turned on or off 

for any drawing. When wipeout frames are on, you can select and modify wipeouts. 

You may want to turn off wipeout frames when it’s time to print. 
 

To turn wipeout frames on or off 

1 Do one of the following to choose Wipeout ( ): 

• On the ribbon, choose Annotate > Wipeout (in Markup). 

• On the menu, choose Draw > Wipeout. 

• On the Draw toolbar, click the Wipeout tool. 

• Type wipeout and then press Enter. 

2 Choose Frames. 

3 Choose On or Off. 



168 C H A P T E R   5 
 

 

 

 

 
Wipeout frames turned on. Wipeout frames turned off. 

 

 

Drawing revision clouds 
 

Revision clouds are cloud shapes that mark areas of a drawing that require further 

attention. They are especially helpful when revising a drawing; add a revision cloud 

to each modified area so reviewers can find changes easily. 

Revision clouds are polylines, so you can work with and modify them in the same 

way you would a polyline: move, copy, mirror, and scale the entire revision cloud or 

select and move individual vertices to adjust the arcs that make up the revision cloud. 

 

Drawing a revision cloud 
Drawing a revision cloud is easy: simply select a start point and move the mouse. 

 

To draw a revision cloud 

1 Do one of the following to choose Revision Cloud ( ): 

• On the ribbon, choose Annotate > Revision Cloud (in Markup). 

• On the menu, choose Draw > Revision Cloud. 

• On the Draw toolbar, click the Revision Cloud tool. 

• Type revcloud and then press Enter. 

2 Specify the start point. 

3 Move the mouse, encircling the desired area. 

When you return to the starting point, the revision cloud command finishes auto- 

matically. 
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Select start point (A), then move the mouse 
around the desired area and back towards the 
start point (A). 

Resulting revision cloud. 

 
 

Edit revision clouds just as you would a polyline. 

Select the revision cloud and move its vertices or use the Edit Polyline tool (  ) on 

the Modify toolbar. 
 

 

 

Creating a revision cloud using existing entities 
In addition to drawing new revision clouds, you can also convert existing entities — 

lines, arcs, circles, 2D polylines, and splines — into revision clouds. 
 

To create a revision cloud using an existing entity 

1 Do one of the following to choose Revision Cloud ( ): 

• On the ribbon, choose Annotate > Revision Cloud (in Markup). 

• On the menu, choose Draw > Revision Cloud. 

• On the Draw toolbar, click the Revision Cloud tool. 

• Type revcloud and then press Enter. 

2 Choose Entity. 

3 Select the existing line, arc, circle, 2D polyline, or spline to be converted. 

4 Choose whether to reverse the direction of the individual arcs of the revision 

cloud. Choose No to keep the arcs pointing inward. Choose Yes to flip the arcs to 

point outward. 

A revision cloud is created, and the selected entity remains or is deleted depending 

on the DELOBJ system variable setting. 

 

Customizing default revision cloud settings 
All revision clouds are drawn using default settings that can be customized: 

• Minimum arc length — The individual arcs that make up a revision cloud can be 

made smaller or larger by setting the minimum arc length. 

• Maximum arc length — The individual arcs that make up a revision cloud can be 

made smaller or larger by setting the maximum arc length. 

 

A 
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• Style — Revision clouds can appear as if they had been drawn with a regular pen 

or a calligraphy pen. 

Only new revision clouds will be drawn with the new settings. Existing revision 

clouds are not affected. 
 

To customize revision cloud settings 

1 Do one of the following to choose Revision Cloud ( ): 

• On the ribbon, choose Annotate > Revision Cloud (in Markup). 

• On the menu, choose Draw > Revision Cloud. 

• On the Draw toolbar, click the Revision Cloud tool. 

• Type revcloud and then press Enter. 

2 Choose Arc Length. 

3 Enter the minimum length of the individual arcs that make up the revision cloud, 

then press Enter. 

4 Enter the maximum length of the individual arcs that make up the revision cloud, 

then press Enter. The value cannot be set to more than three times the minimum 

arc length. 
 

 

Arc lengths can also be scaled. 

The setting of the DIMSCALE system variable also affects arc length. 
 

 

 

5 Choose Style and select one of the following: 

• Normal — Draws new revision clouds as if they were drawn with a regular pen. 

• Calligraphy — Draws new revision clouds as if they were drawn with a callig- 

raphy pen. 
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Adding multileaders 
 

Multileaders consist of line segments or a spline curve that connects a feature in a 

drawing to multiline text or a block. Generally, you place an arrowhead at the first 

point, and the multiline text or block is placed immediately adjacent to the last point. 

Landing lines can also be placed horizontally between the leader and content (the 

multiline text or block). 

 

Creating multileaders 
By default when you create a multileader, the multileader includes an arrow, line seg- 

ments, and multiline text at the endpoint. However, you can choose a spline instead 

of line segments and a block (or nothing) instead of multiline text. 

There are more options too. Use the Multileader prompts once you start the Multi- 

leader command. For more control over format, use multileader styles. For more 

details, see “Working with multileader styles” on page 175 in this chapter. 
 

To create a multileader that includes multiline text 

1 Do one of the following to choose Multileader (  ): 

• On the ribbon, choose Annotate > Multileader (in Leaders). 

• On the menu, choose Dimensions > Multileader. 

• On the Multileader toolbar, click the Multileader tool. Or on the Dimensioning 

toolbar, click the Multileader tool. 

• Type mleader and then press Enter. 

2 Specify the starting point of the multileader. 

3 Specify the endpoint of the multileader line segment. 

4 Specify additional multileader line segment endpoints, if the maximum number of 

points is set to greater than two. 

5 After you specify the last endpoint, press Enter. 

6 In the Multiline Text editor, type the annotation. 

7 When finished, click outside the Multiline Text editor. 

 
 

 
Specify the starting point of the multileader (A) and the endpoint of the multileader (B). Then 
type multiline text (C). 

C 
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To create a multileader that includes a block 

1 Do one of the following to choose Multileader (  ): 

• On the ribbon, choose Annotate > Multileader (in Leaders). 

• On the menu, choose Dimensions > Multileader. 

• On the Multileader toolbar, click the Multileader tool. Or on the Dimensioning 

toolbar, click the Multileader tool. 

• Type mleader and then press Enter. 

2 Choose Options, choose Content Type, then choose Block. 

3 Type the name of the block to include at the end of the multileader, then press 

Enter. 

4 Choose Exit. 

5 Specify the starting point of the multileader. 

6 Specify the endpoint of the multileader line segment. 

7 Specify additional multileader line segment endpoints, if the maximum number of 

points is set to greater than two. 

8 After you specify the last endpoint, press Enter. 

 
 

 
Specify the starting point of the multileader (A) and the endpoint of the multileader (B). The 
specified block is drawn automatically. 

To create a multileader that does not include multiline text or a block 

1 Do one of the following to choose Multileader (  ): 

• On the ribbon, choose Annotate > Multileader (in Leaders). 

• On the menu, choose Dimensions > Multileader. 

• On the Multileader toolbar, click the Multileader tool. Or on the Dimensioning 

toolbar, click the Multileader tool. 

• Type mleader and then press Enter. 

2 Choose Options, choose Content Type, then choose None. 

3 Choose Exit. 

4 Specify the starting point of the multileader. 

5 Specify the endpoint of the multileader line segment. 

 

B 

A 
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6 Specify additional multileader line segment endpoints, if the maximum number of 

points is set to greater than two. 

7 After you specify the last endpoint, press Enter. 

 
 

 
Specify the starting point of the multileader (A) and the endpoint of the multileader (B). 

To specify options for a multileader before creating it 

1 Do one of the following to choose Multileader (  ): 

• On the ribbon, choose Annotate > Multileader (in Leaders). 

• On the menu, choose Dimensions > Multileader. 

• On the Multileader toolbar, click the Multileader tool. Or on the Dimensioning 

toolbar, click the Multileader tool. 

• Type mleader and then press Enter. 

2 Choose Options, then choose from the following: 

• Leader type Select whether the leader line type is straight, a spline, or has no 

leader line. 

• Leader landing Select whether to place a landing line horizontally between the 

leader and text or block content. 

• Content type Select whether a multileader with this style contains multiline text, 

a block, or neither. 

• Maxpoints Select to enter the number of maximum points for the leader line. 

• First angle Select to specify the constraint angle of the first line segment. 

• Second angle Select to specify the constraint angle of the second line segment. 

3 When finished, choose Exit, then continue creating the multileader. 

 
 

You can specify more multileader options using multileader styles. 

For more details, see “Working with multileader styles” on page 175 in this chapter. 
 

 

 

Adding and removing leader lines from multileaders 
Each multileader can have more than one leader line attached to it. 

 

B 

A 
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To add leader lines to a multileader 

1 Do one of the following to choose Add Leader Lines (  ): 

• On the ribbon, choose Annotate > Add Leader Lines (in Leaders). 

• On the Multileader toolbar, click the Add Leader Lines tool. 

• Type aimmleaderadd and then press Enter. 

2 Select the desired multileader. 

3 Select an arrowhead location for a new leader. 

4 Continue selecting points to add additional leader lines, then press Enter when fin- 

ished. 

 

To remove leader lines from a multileader 

1 Do one of the following to choose Remove Leader Lines (  ): 

• On the ribbon, choose Annotate > Remove Leader Lines (in Leaders). 

• On the Multileader toolbar, click the Remove Leader Lines tool. 

• Type aimmleaderremove and then press Enter. 

2 Select the entities to include in the selection set for leader removal. 

3 Select a leader line to remove. 

4 Continue selecting leader lines to remove, then press Enter when finished. 

 

Aligning multileaders 
It’s easy to align and distribute multileaders. You can also collect multileaders and 

place them in one location. Note that multileaders with block content can be col- 

lected, not multileaders with text content. 
 

To align multileaders 

1 Do one of the following to choose Align Multileader (  ): 

• On the ribbon, choose Annotate > Align Multileader (in Leaders). 

• On the Multileader toolbar, click the Align Multileader tool. 

• Type mleaderalign and then press Enter. 

2 Select the multileaders to align, then press Enter. 

3 Choose options if you want to customize the alignment, then choose from the fol- 

lowing: 

• Distribute Places multileader block or text content between two points that you 

select. 

• Make Leader Segments Parallel Places multileader block or text content where 

the last leader line segments will be parallel. 
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• Specify Spacing Places multileader block or text content according to the 

spacing that you specify. 

• Use Current Spacing Places multileader block or text content according to the 

current spacing that was previously specified. 

The following prompts display for the Distribute option, which is the default. 

4 Select the start point to use for distributing the multileader block or text content. 

5 Select the end point to use for distributing the multileader block or text content. 

Content will be aligned and distributed between the two points. 

To collect multileaders that include blocks into a row or column 

1 Do one of the following to choose Collect Multileader (  ): 

• On the ribbon, choose Annotate > Collect Multileader (in Leaders). 

• On the Multileader toolbar, click the Collect Multileader tool. 

• Type mleadercollect and then press Enter. 

2 Select the multileaders to collect, then press Enter. 

3 Choose how you want to collect and align multileader content: 

• Horizontal Places collected multileaders horizontally. 

• Vertical Places collected multileaders vertically. 

• Wrap Wraps the collected multileaders according to a width and number per row 

that you specify. 

4 Specify the upper left corner of the new location for the selected multileaders. 

 

Working with multileader styles 
When you create a multileader, the program draws it on the current layer, using the 

current multileader style. Each multileader has a corresponding multileader style, 

which controls the appearance of the multileader, such as the arrowhead type, text 

style, colors, and more. 

You can create, save, modify, and delete named multileader styles.You can also set 

any multileader style to be the current one that is assigned to new multileaders as you 

add them to your drawing. 

 

Creating a multileader style 
Multileader styles provide a way for you to change various settings that control the 

appearance of multileaders. You can then save those settings for reuse. If you don’t 

define a multileader style before creating multileaders, the program uses the Standard 

multileader style, which stores the default multileader settings. 
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To create a multileader style 

1 Do one of the following to choose Multileader Styles Manager (  ): 

• On the ribbon, choose Annotate > Multileader Styles Manager (in Leaders). 

• On the menu, choose Format > Multileader Styles Manager. 

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 

Or on the Format toolbar, click the Multileader tool. 

• Type mleaderstyle and then press Enter. 

2 Click New. 

3 In New Style Name, type the name of the new multileader style. 

4 In Start With, select an existing multileader style on which to base the new multi- 

leader style. 

5 In Annotative, select to make multileaders with this style affected by annotation 

scaling. 

6 Click Continue. 

7 In the Create New Multileader Styles dialog box, make your selections for the 

multileader style as necessary. For details about the available options, click [?] in 

the dialog box. 

8 When finished, click OK. 

 
Setting the current multileader style 
When you create a multileader, it is automatically assigned the multileader style that 

is set to current. By default, the program uses the Standard multileader style, which 

stores the default multileader settings. Or you can choose a different multileader style 

to be the current one. 

If you choose a different multileader style as current, that style is assigned to multi- 

leaders that you create in the future, not existing multileaders. 
 

To set a multileader style as current 

1 Do one of the following to choose Multileader Styles Manager (  ): 

• On the ribbon, choose Annotate > Multileader Styles Manager (in Leaders). 

• On the menu, choose Format > Multileader Styles Manager. 

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 

Or on the Format toolbar, click the Multileader tool. 

• Type mleaderstyle and then press Enter. 

2 In the Multileader Styles Manager dialog box, select a multileader style from the 

list. 

3 Click Set Current. 

4 Click Close. 
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Assigning a style to a multileader 
You can assign a different multileader style to a multileader at any time. 

 

To assign a style to a multileader 

1 Select a multileader in the drawing. 

2 Do one of the following: 

• On the ribbon, choose Annotate, then select the style in the Multileader Style list 

(in Leaders). 

• On the Multileader or Styles toolbar, select the style in the Multileader Style list. 

• Right-click the multileader, choose Properties, then in Style, select the style. 

 

Renaming a multileader style 

To rename a multileader style 

1 Do one of the following to choose Multileader Styles Manager (  ): 

• On the ribbon, choose Annotate > Multileader Styles Manager (in Leaders). 

• On the menu, choose Format > Multileader Styles Manager. 

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 

Or on the Format toolbar, click the Multileader tool. 

• Type mleaderstyle and then press Enter. 

2 In the Multileader Styles Manager dialog box, select the multileader style to 

rename. 

3 Click the name a second time, type the new name, then press Enter. 

4 Click Close. 

 
Deleting a multileader style 

To delete a named multileader style 

1 Do one of the following to choose Multileader Styles Manager (  ): 

• On the ribbon, choose Annotate > Multileader Styles Manager (in Leaders). 

• On the menu, choose Format > Multileader Styles Manager. 

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 

Or on the Format toolbar, click the Multileader tool. 

• Type mleaderstyle and then press Enter. 

2 In the Multileader Styles Manager dialog box, select the multileader style to 

delete. 

3 Click Delete. 

4 To confirm the deletion, click OK. 

5 Click Close. 
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Controlling leader format settings for multileader styles 
You can control leader format settings that affect the type, color, linetype, lineweight, 

arrowhead, and break size. Any changes you make affect the multileader style you’re 

working with (a new or existing one). The image tile on the right side of the Create 

New/Modify Multileader Styles dialog box shows the appearance of a multileader 

based on the current multileader style settings. 
 

To set the leader format for multileader styles 

1 Do one of the following to choose Multileader Styles Manager (  ): 

• On the ribbon, choose Annotate > Multileader Styles Manager (in Leaders). 

• On the menu, choose Format > Multileader Styles Manager. 

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 

Or on the Format toolbar, click the Multileader tool. 

• Type mleaderstyle and then press Enter. 

2 Select a multileader style, then click Modify. Or if you want to create a new multi- 

leader style instead, see “Creating a multileader style” on page 175 in this chapter. 

3 Click the Leader Format tab and make your selections. 

4 Click OK when finished. 
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A Select the leader line type: straight, spline, or no 

leader line. 

B Select the leader line color for multileaders 
assigned this style. 

C Select the leader linetype for multileaders 
assigned this style. 

D Select the leader lineweight for multileaders 
assigned this style. 

 
E Select the leader line arrowhead for multileaders 

assigned this style. 

F Enter or select the leader line arrowhead size for 
multileaders assigned this style. 

G Enter or select the leader break size for 
multileaders assigned this style. The break size 
is used when the DIMBREAK command is used 
with multileaders that are assigned this style. 
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Controlling leader structure settings for multileader styles 
You can control settings affecting leader constraints, landing settings, and leader 

scale. Any changes you make affect the multileader style you’re working with (a new 

or existing one). The image tile on the right side of the Create New/Modify Multi- 

leader Styles dialog box shows the appearance of a multileader based on the current 

multileader style settings. 
 

To set the leader structure for multileader styles 

1 Do one of the following to choose Multileader Styles Manager (  ): 

• On the ribbon, choose Annotate > Multileader Styles Manager (in Leaders). 

• On the menu, choose Format > Multileader Styles Manager. 

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 

Or on the Format toolbar, click the Multileader tool. 

• Type mleaderstyle and then press Enter. 

2 Select a multileader style, then click Modify. Or if you want to create a new multi- 

leader style instead, see “Creating a multileader style” on page 175 in this chapter. 

3 Click the Leader Structure tab and make your selections. 

4 Click OK when finished. 
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A Select to limit the number of points for leader 

line, then enter or select the maximum number of 
points. 

B Select to specify the angle of the first line 
segment, then enter or select the angle. 

C Select to specify the angle of the second line 
segment, then enter or select the angle. 

D Select to include a landing line horizontally 
between the leader and text content. 

E Select to specify the length of the landing line, 
then enter or select the length of the landing line. 

F Select to specify that multileaders with this style 
are affected by annotation scaling. 

G Select whether to scale multileaders 
automatically according to layout scaling or to 
enter a fixed scale. (Available for non-annotative 
styles.) 
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Controlling content settings for multileader styles 
You can control settings for the content located at the end of multileaders. Specifi- 

cally, choose whether the content is multiline text, a block, or none. Then you make 

further selections. The image tile on the right side of the Create New/Modify Multi- 

leader Styles dialog box shows the appearance of a multileader based on the current 

multileader style settings. 
 

To set the content settings for a multileader style with multiline text 

1 Do one of the following to choose Multileader Styles Manager (  ): 

• On the ribbon, choose Annotate > Multileader Styles Manager (in Leaders). 

• On the menu, choose Format > Multileader Styles Manager. 

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 

Or on the Format toolbar, click the Multileader tool. 

• Type mleaderstyle and then press Enter. 

2 Select a multileader style, then click Modify. Or if you want to create a new multi- 

leader style instead, see “Creating a multileader style” on page 175 in this chapter. 

3 Click the Content Settings tab. 

4 In Multileader Type, choose Mtext. 

5 Continue making your selections. 

6 Click OK when finished. 
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A Select whether a multileader with this style 
contains multiline text or a block, or none. The 
options in the dialog box change depending on 
your selection. 

B Displays the default text for the multiline text 
content. Click [...] to specify the default text. 

C Select a text style for the multiline text. Click [...] 
to manage text styles. 

D Select whether the rotation angle of multiline text 
is as-inserted, always right-reading, or always 
horizontal. 

E Select a color for the multiline text. 

F Enter or select the height of the multiline text. 

G Select to always left justify the multiline text. 

H Select to attach multiline text content to the 
multileader horizontally or vertically. The options 
that display depend on your selection. 

I Select the location of multiline text when it is 
attached to the left (for horizontal) or top (for 
vertical) of the leader line. 

J Select the location of multiline text when it is 
attached to the right (for horizontal) or bottom 
(for vertical) of the leader line. 

K Enter or select the distance between the landing 
line and multiline text. 

L Select to extend the multileader to the text when 
needed. (Available only for horizontal 
attachments.) 

M Select to add a frame around the multiline text. 
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To set the content settings for a multileader style with a block 

1 Do one of the following to choose Multileader Styles Manager (  ): 

• On the ribbon, choose Annotate > Multileader Styles Manager (in Leaders). 

• On the menu, choose Format > Multileader Styles Manager. 

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 

Or on the Format toolbar, click the Multileader tool. 

• Type mleaderstyle and then press Enter. 

2 Select a multileader style, then click Modify. Or if you want to create a new multi- 

leader style instead, see “Creating a multileader style” on page 175 in this chapter. 

3 Click the Content Settings tab. 

4 In Multileader Type, choose Block. 

5 Continue making your selections. 

6 Click OK when finished. 
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A Select whether a multileader with this style 

contains multiline text or a block, or none. The 
options in the dialog box change depending on 
your selection. 

B Select the block to use at the end of the 
multileader. 

C Select which point to use for attaching the block 
to the multileader: insertion point that you specify 
or center point. 

D Select the color of the block, which is applied if 
the block entity color is ByBlock. 

E Enter or select the scale of the block. 
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Creating boundary polylines 
 

A bounded polyline is an area bound by a single closed entity or by multiple entities 

that intersect and is used for hatching or dimensioning. 

For details about adding hatching after you create a boundary polyline, see “Adding 

hatching and gradients” on page 190 in this chapter. For details about adding dimen- 

sions after you create a boundary polyline, see “Creating dimensions” on page 430. 

 

Understanding boundary polylines 
With the Boundary command, you can designate a specific area of a drawing for 

operations such as hatching and dimensioning. You create a boundary polyline by 

selecting an area inside a closed loop. The area you select can be bounded by a single 

closed entity or by multiple entities that intersect. 

In cases where entities intersect, 4MCAD interprets the boundary as the closed loop 

closest to the point specifying the area. In the following figure, for example, the area 

point selected in the rectangle results in a boundary consisting of the closed loop 

nearest the point selection, as opposed to the closed loop formed by the rectangle 

itself. 

 
 

 

Selected point (A) and resulting boundary (B). 
 

To make boundaries more specific, you can create a boundary set. A boundary set 

specifies which entities are considered in determining the boundary path. This can 

make creating the boundary polyline faster if you are working with a complex draw- 

ing. 

In the following figure, the circle and triangle are the selected entities. If you select an 

area anywhere inside the circle or the triangle, the result is a polyline that bounds the 

shaded area. 

A 
 
 

B 
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Selected entities (A and B) and the point specified in the selected area (C), which results in a 
new boundary around the shaded area. 

 

Using islands and island detection 
Islands are closed loops that reside inside other closed loops. 4MCAD provides 

island-detection options so that you can specify which islands, if any, should be con- 

sidered in the area selection for a boundary. 

The following figure shows a rectangular polyline with two islands. The circle is 

referred to as the outer island, and the octagon is referred to as a nested island. 
 

 

Rectangular polyline (A) with outer island (B), with point (C) specifying the area selection, and nested island 
(D). 

 

You can choose from three island-detection methods. 

• Nested Islands The outer entity and all its islands are considered for the polyline. 

• Outer Only Only the outer entity and its outer island are considered for the 

polyline. 

• Ignore Islands Only the outer entity is considered for the polyline. 

C 
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Nested islands (A), with outer island (B), and with ignore islands (C). 
 

Creating a boundary polyline 
When you create a boundary polyline, you select an existing entity or multiple enti- 

ties to define the boundary. 
 

To draw a boundary polyline 

Advanced experience level 

1 Do one of the following to choose Boundary ( ): 

• On the ribbon, choose Home > Boundary (in Draw) or choose Draw > Boundary 

(in Draw). 

• On the menu, choose Draw > Hatch > Boundary. 

• On the Draw toolbar, click the Boundary tool. 

• Type boundary and then press Enter. 

2 Specify the entities that you want made available for the boundary polyline by 

doing one of the following: 

• All entities Select All Visible Entities to have all entities in the drawing 

considered when creating the boundary polyline. 

• Custom selection Define only specific areas to be considered when creating the 

boundary polyline, which can improve system performance if you are working 

with a complex drawing. Click Select Boundary Set. In the drawing, select the 

entities individually or by choosing a selection method from the prompt box, 

and then press Enter. The Current Selection Set option becomes selected 

automatically, which indicates that the entities you selected with the Select 

Boundary Set button will be considered when creating the boundary polyline. 
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You don’t have to select entities again using the Select Boundary Set button. 

The Current Selection Set option uses the last set of entities you selected with the 

Select Boundary Set button. 
 

 

 

3 Choose an island-detection option. 

4 Click Select Area. 

5 In the drawing, click inside the area whose closed perimeter forms the boundary, 

not on the polyline itself. If desired, continue clicking inside additional closed 

perimeters. 

6 To complete the selection, press Enter. 

7 In the Boundary dialog box, click OK. 
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A Opens the drawing area for selection of entities 
to be considered when creating the boundary 
polyline. 

B Choose to consider all visible entities when 
creating the boundary polyline. 

C Choose to use the entities you selected for the 
boundary set. (Becomes available after you click 
the Select Boundary Set button.) 

D Select an island-detection option. 

E Opens the drawing area for selection of the 
enclosed areas used to create new boundary 
polylines. 
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Adding hatching and gradients 
 

When you add hatching or gradients to a drawing, 4MCAD fills entities or enclosed 

areas with a pattern. 

Adding hatching or gradients is a three step process: 

1 Specify a hatch or gradient pattern. 

2 Specify entities or areas. 

3 Specify additional options. 
 

 

Hatch patterns and gradients are memory intensive. 

Because hatch and gradient patterns can take a considerable amount of time to draw 

and display, you may want to add hatching and gradients during the last steps of 

drawing creation or insert them on a separate layer that you can freeze as you con- 

tinue to work on your drawing. For example, instead of using a small-scaled line pat- 

tern to create a solid fill, use the SOLID hatch pattern instead as this will print and 

display much faster. 
 

 

 

Specifying a hatch or gradient pattern 
A hatch pattern consists of a repeating pattern of lines, dashes, and dots. You can 

select one from a set of predefined patterns, define a pattern of your own, or choose a 

pattern from a custom hatch library. 

A gradient pattern consists of a gradual or smooth change from one color to another 

color. You simply select colors and a pattern. 

 
 

Existing hatches and gradients can be modified. 

Type HATCHEDIT to modify an existing hatch or gradient, double-click it in the 

drawing, or change its settings in the Properties pane. 
 

 

 
Specifying a predefined hatch pattern 
Predefined hatch patterns are stored in the following hatch pattern library files: 

• icad.pat — American National Standards Institute (ANSI)-compliant patterns. 

• icadiso.pat — International Standards Organization (ISO)-compliant patterns. 
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To specify a predefined hatch pattern 

1 Do one of the following to choose Hatch (  ): 

• On the ribbon, choose Home > Hatch (in Draw) or Draw > Hatch (in Draw). 

• On the menu, choose Draw > Hatch > Hatch. 

• On the Draw toolbar, click the Hatch tool. 

• Type bhatch and then press Enter. 

2 Click the Hatch tab. 

3 In Type, select Predefined. 

4 In Pattern, select the desired pattern. You can also click [...] or click the swatch to 

open the Hatch Patterns dialog box and select a pattern from the ANSI, ISO, or 

Other Predefined tabs. 

5 Specify any of the following options: 

• Color In the first (left) color list, select the color of the hatch lines. In the second 

(right) color list, select the color of the hatch background. 

• Angle Enter the angle of the hatch pattern relative to the x-axis in degrees (1- 

360). The default angle is clockwise; you can change the angle by entering a 

numerical value. 

• Scale Enter the scale factor as a percentage of the default. Changing the scale 

factor makes the hatch pattern larger or smaller than the default size. If you 

selected an ISO standard pattern, the scale affects the ISO pen width. 

• Related to paper space Select to scale the hatch pattern relative to the units 

defined for paper space. (Available for named layouts.) 

• ISO pen width Enter the pen width if you selected an ISO standard pattern. 

6 In Hatch Origin, select whether to draw the hatch pattern from the default origin or 

a new origin. If you choose to specify a new origin, do one of the following: 

• Click (  ) to pick the new origin directly in the drawing. 

• Select Default to Boundary Extents to set the origin to the top left, top right, 

bottom left, bottom right, or center of the boundary extents. 

 
 

A new origin can be saved as the new default. 

To store the new hatch origin as the default, select Store as Default Origin. The 

hatch origin will be saved in the HPORIGIN system variable. 
 

 

 

7 To continue, specify entities or areas for hatching. For details, see “Specifying 

entities or areas for hatching and gradients” on page 198 in this chapter. 
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To specify a user-defined hatch pattern 

1 Do one of the following to choose Hatch (  ): 

• On the ribbon, choose Home > Hatch (in Draw) or Draw > Hatch (in Draw). 

• On the menu, choose Draw > Hatch > Hatch. 

• On the Draw toolbar, click the Hatch tool. 

• Type bhatch and then press Enter. 

2 Click the Hatch tab. 

3 In the Type list, select User Defined. 

4 Specify any of the following options: 

• Color In the first (left) color list, select the color of the hatch lines. In the second 

(right) color list, select the color of the hatch background. 

• Angle Enter the angle of the hatch pattern relative to the x-axis in degrees (1- 

360). The default angle is clockwise; you can change the angle by entering a 

numerical value. 

• Double Select to cross-hatch the pattern, which places another copy of the 

pattern at a 90-degree angle over the original. 

• Related to paper space Select to scale the hatch pattern relative to the units 

defined for paper space. (Available for named layouts.) 

• Spacing Enter the line spacing for the hatch pattern. 

5 In Hatch Origin, select whether to draw the hatch pattern from the default origin or 

a new origin. If you choose to specify a new origin, do one of the following: 

• Click (  ) to pick the new origin directly in the drawing. 

• Select Default to Boundary Extents to set the origin to the top left, top right, 

bottom left, bottom right, or center of the boundary extents. 

 
 

A new origin can be saved as the new default. 

To store the new hatch origin as the default, select Store as Default Origin. The 

hatch origin will be saved in the HPORIGIN system variable. 
 

 

 

6 To continue, specify entities or areas for hatching. For details, see “Specifying 

entities or areas for hatching and gradients” on page 198 in this chapter. 

 
Specifying a custom library hatch pattern 
You can use custom external hatch pattern libraries (.pat files), such as a standard 

library used in your office, customized patterns, and libraries available from vendors 

or standards organizations. The .pat files can be in any location. 
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Each .pat file contains one hatch pattern, and the filename must match the name of 

the hatch pattern. The hatch pattern definition is as follows: 

*[Name],[Description] 
 

angle, x-origin, y-origin, delta-x, delta-y [, dash1, dash2, …] 

Alternatively, you can add a custom hatch pattern to icad.pat and use predefined 

hatch patterns described previously instead of a custom library pattern below. 
 

To use a custom library pattern 

1 Do one of the following: 

• Copy the custom pattern file (.pat file) to the Patterns folder where you installed 

4MCAD. To check where 4MCAD searches for pattern files, choose Tools 

> Options, click Paths/Files, and check the folders listed for Hatch Patterns. 

• Choose Tools > Options, click Paths/Files, and add the location of the custom 

pattern file (.pat file) to the folders listed for Hatch Patterns. 

2 Do one of the following to choose Hatch (  ): 

• On the ribbon, choose Home > Hatch (in Draw) or Draw > Hatch (in Draw). 

• On the menu, choose Draw > Hatch > Hatch. 

• On the Draw toolbar, click the Hatch tool. 

• Type bhatch and then press Enter. 

3 Click the Hatch tab. 

4 In Type, choose Custom. 

5 In Custom Pattern, select a pattern from the list. You can also click [...] to open the 

Hatch Patterns dialog box and select a pattern from the Custom tab. 

6 Specify any of the following options: 

• Color In the first (left) color list, select the color of the hatch lines. In the second 

(right) color list, select the color of the hatch background. 

• Angle Enter the angle of the hatch pattern relative to the x-axis in degrees (1- 

360). The default angle is clockwise; you can change the angle by entering a 

numerical value. 

• Scale Enter the scale factor as a percentage of the default. Changing the scale 

factor makes the hatch pattern larger or smaller than the default size. 

• Related to paper space Select to scale the hatch pattern relative to the units 

defined for paper space. (Available for named layouts.) 

7 In Hatch Origin, select whether to draw the hatch pattern from the default origin or 

a new origin. If you choose to specify a new origin, do one of the following: 

• Click (  ) to pick the new origin directly in the drawing. 

• Select Default to Boundary Extents to set the origin to the top left, top right, 

bottom left, bottom right, or center of the boundary extents. 
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A new origin can be saved as the new default. 

To store the new hatch origin as the default, select Store as Default Origin. The 

hatch origin will be saved in the HPORIGIN system variable. 
 

 

 

8 To continue, specify entities or areas for hatching. For details, see “Specifying 

entities or areas for hatching and gradients” on page 198 in this chapter. 
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A Select to create a hatch pattern. 

B Select the type of hatch pattern. 

C Select a predefined hatch pattern from the list or click [...] to 
select it in the Hatch Patterns dialog box. 

D Click to select a hatch pattern. 

E Select the color of the hatch lines. 

F Select a custom hatch pattern from the list or click [...] to select 
it in the Hatch Patterns dialog box. 

G Enter the angle of the hatch pattern in relation to the x-axis. 

H Select to cross-hatch a user defined pattern. 

I Enter the line spacing for a user defined pattern. 

J Enter the pen width for an ISO-standard predefined pattern. 

K Select to use the default hatch origin or to specify a new origin. 

L Click to pick the new hatch origin in the drawing. 

M Select to set the new hatch origin to the top left, top right, 
bottom left, bottom right, or center of the boundary extents. 

N Select to save the new hatch origin as the new default. 

O Select to scale the hatch pattern relative to the units defined for 
paper space. (Available for named layouts.) 

P Enter the scale factor as a percentage of the default. 

Q Select the color of the hatch background. 
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Specifying a gradient pattern 
A gradient pattern consists of a gradual or smooth change from one color to another 

color. Simply select the colors, a pattern, and orientation settings. 
 

To specify a gradient pattern 

1 Do one of the following to choose Gradient (  ): 

• On the ribbon, choose Home > Gradient (in Draw) or Draw > Gradient (in 

Draw). 

• On the menu, choose Draw > Hatch > Gradient. 

• On the Draw toolbar, click the Gradient tool. 

• Type gradient and then press Enter. 

2 In Color, choose one of the following: 

• One Color Specify one color for the gradient pattern, then specify the color in 

Color1. The color you specify will be smoothed with the color white or black, 

depending on the GFCLRSTATE system variable. 

• Two Colors Specify two colors for the gradient pattern, then specify the colors 

in Color1 and Color2. Color1 will be smoothed with Color2. 

3 In the 3x3 display of gradient patterns, select a gradient pattern. 

4 Specify the orientation options: 

• Centered Select to center the gradient pattern. If not selected, the gradient 

pattern appears to have a light source above and to the left (the pattern is shifted 

up and to the left). 

• Angle Enter or select the angle of the gradient pattern. 

5 To continue, specify entities or areas for gradients. For details, see “Specifying 

entities or areas for hatching and gradients” on page 198 in this chapter. 
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A Select to create a gradient pattern. 

B Select to specify one or two colors for the gradient pattern. 

C Select the first color of the gradient pattern; click [...] for more 
color options. 

D Select the second color if creating a two-color gradient pattern; 
click [...] for more color options. 

E Select a gradient pattern. 

F Select to center the gradient pattern; if not selected, the pattern 
will shift up and to the left. 

G Enter or select an angle for the gradient pattern. 
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Specifying entities or areas for hatching and gradients 
You can specify either entities or areas in which to apply hatches and gradients: 

• Select entities — Add hatching or gradients to any entity that forms a closed 

boundary, for example, a circle or rectangle. You can assign hatching or gradients 

to a single entity or several entities at the same time. 

• Select areas — Add hatching or gradients to an area enclosed by entities that form 

a boundary. The hatch or gradient is created in the enclosed area, not the entities 

themselves. The entire hatch or gradient, once drawn, is treated as a single entity 

and it is either associative or independent of the boundary entities. 
 

To select entities or areas for hatching and gradients 

1 Do one of the following to choose Hatch (  ) or Gradient (  ): 

• On the ribbon, choose Home > Hatch or Home > Gradient (in Draw); or choose 

Draw > Hatch or Draw > Gradient (in Draw). 

• On the menu, choose Draw > Hatch > Hatch, or Gradient. 

• On the Draw toolbar, click the Hatch tool or Gradient tool. 

• Type bhatch or gradient and then press Enter. 

2 Click one of the following: 

• Add: Pick points Specifies areas for which to apply hatching and gradients. In 

the drawing, click inside the closed perimeter of a boundary, not on the 

boundary itself. If desired, continue clicking inside additional closed perimeters. 

To complete the selection, press Enter. 

• Add: Select entities Specifies entities for which to apply hatching and gradients. 

In the drawing, click the entities individually or by choosing a selection method 

from the prompt box, and then press Enter when done. 

• Remove boundaries Removes boundaries from the selection set. In the drawing, 

click the boundaries to remove from the selection set. 

• Recreate boundary Creates a polyline or region around a hatch or gradient. In 

the drawing, click the hatch or gradient for which you want to create a boundary. 

• View selections Displays the selection set. In the drawing, press Enter when 

done viewing the selection set. 

3 To continue, specify additional options. For details, see “Specifying additional 

hatch and gradient options” on page 199 in this chapter. 
 

 

A warning message displays when you create the hatch or gradient if the number of 

entities selected exceeds the HPOBJWARNING system variable value. 

If the warning displays, to improve performance before continuing with hatch cre- 

ation, select fewer entities. Hatch patterns are memory intensive and can take a 

considerable amount of time to draw. 
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A Click to select a point inside one or more entities that create 
a boundary. 

B Click to select one or more entities. 

C Click to remove a boundary from the selection set. 

D Click to view currently selected entities in the drawing. 

E Click to select a hatch or gradient for which to surround with 
a polyline or region. 

 

Specifying additional hatch and gradient options 
There are many options that can be specified for hatches and gradients, including for- 

matting options, island detection, and specific options related to boundaries. 

 
 

Existing hatches and gradients can be modified. 

Type HATCHEDIT to modify an existing hatch or gradient, double-click it in the 

drawing, or change its settings in the Properties pane. 
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To specify additional hatch and gradient options 

1 Do one of the following to choose Hatch (  ) or Gradient (  ): 

• On the ribbon, choose Home > Hatch or Home > Gradient (in Draw); or choose 

Draw > Hatch or Draw > Gradient (in Draw). 

• On the menu, choose Draw > Hatch > Hatch, or Gradient. 

• On the Draw toolbar, click the Hatch tool or Gradient tool. 

• Type bhatch or gradient and then press Enter. 

2 Select any of the following formatting options: 

• Annotative Makes the display and printing of the hatch or gradient pattern 

affected by annotation scaling. 

• Associative Associates the hatch or gradient pattern with its boundary entities. 

An associative pattern updates automatically if you move any of its boundaries. 

• Create Separate Hatches Creates multiple hatches or gradients when more than 

one closed boundary is selected. 

• Draw Order Determines the order in which the hatch or gradient pattern is drawn 

relative to its boundary. 

• Layer Determines the layer on which the hatch or gradient pattern is assigned. 

• Transparent Determines the transparency of the hatch or gradient. If you select 

Specify Value, enter the transparency value or use the slider. 

• Inherit Properties Allows selection of a hatch or gradient from which to copy 

settings and load those settings in the Hatch and Gradient dialog box. 

3 From the Hatch and Gradient dialog box, click > if necessary to expand the dialog 

box. 

4 If you want the boundary to be determined by islands, in Islands select Island 

Detection and then choose one of the following: 

• Normal The outer entity and all its islands are considered for hatching. 

• Outer Only the outer entity and its outer island are considered for hatching. 

• Ignore Only the outer entity is considered for hatching. 

 

   
A B C 

 

Normal or nested islands (A), with outer island (B), and with ignore islands (C). 

5 Select any of the following boundary-related options: 
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• Boundary Retention Keeps any new entities that are created for drawing the 

hatch or gradient. If turned on, select whether to create new entities as polylines 

or regions. Existing entities are always retained. 

• Boundary Set Determines the area of entities that is considered for creating a 

boundary when using the Add: Pick Points option. Choose Current Viewport to 

make available all entities within the current viewport. Choose Existing Set to 

make available only those entities within the area specified with the New option. 

Click New to specify a new area. 

• Gap Tolerance Determines the tolerance that non-touching entities can be 

within and still be used to create a boundary. For example, if two lines do not 

meet at the same point but the distance between their endpoints falls within the 

hatch tolerance, they will be considered closed and can be used to create a 

boundary. 4MCAD calculates the gap tolerance automatically, depending on 

the size of the 4MCAD window. 

• Inherit Options Determines whether to use the current origin or the original 

hatch origin when you use Inherit Properties. 

6 Click OK. 
 

 

Hatch patterns are memory intensive. 

Because hatch patterns can take a considerable amount of time to draw and display, 

you may want to add hatching during the last steps of drawing creation or insert 

hatches on a separate layer that you can freeze as you continue to work on your 

drawing. In addition, be sure to use the appropriate hatch scale and pattern. For 

example, instead of using a small-scaled line pattern to create a solid fill, use the 

SOLID hatch pattern instead as this will print and display much faster. 
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A Select to make the hatch or gradient annotative. 

B Select to update the hatch or gradient automatically if you move 
any of its boundaries. 

C Select to create a separate hatch or gradient when more than 
one closed boundary is selected. 

D Click to select a hatch or gradient in the drawing from which to 
copy settings. 

E Select the transparency of the hatches or gradients; if Specify 
Value, enter the transparency value or use the slider. 

F Select the layer of the hatches or gradients. 

G Choose the hatch or gradient origin to apply when using Inherit 
Properties. 

H Select the order of the hatch or gradient relative to the 
boundary. 

I Enter the tolerance that non-touching entities can be within and 
still be used to create the hatch pattern boundary. 

J Select the area of entities to consider for creating a boundary 
when using the Add: Pick Points option. 

K Click to specify a new area for boundary selection when using 
the Add: Pick Points option. 

L If Retain Boundaries is turned on, select whether to create 
boundaries as polylines or regions. 

M Select to keep any new entities that are created for drawing the 
hatch or gradient. 

N Determines how hatching and gradients interact with islands. 

O Select to detect islands when determining boundaries. 



 

 
 

 
 
 
 

Viewing your drawing 
 

4MCAD provides many ways to display and view your drawing. You can also 

change various display settings to speed up the display or printing of a drawing. This 

section explains how to: 

• Navigate within a drawing by scrolling, panning, and rotating the view. 

• Change the magnification of a drawing by zooming in and out. 

• View a drawing using annotation scales. 

• Choose visual styles. 

• Work with multiple windows or views of a drawing. 

• Control the display of elements to optimize performance when working with large 

or complex drawings. 

 
 
 
 
 
 

 
 
 
 
 
 
 
 

 

6 
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Redrawing and regenerating a drawing 
 

As you work on a drawing, visual elements may remain after the completion of a 

command. You can remove these elements by refreshing, or redrawing, the display. 
 

To redraw (refresh) the current window display 

Do one of the following to choose Redraw ( ): 

• On the ribbon, choose View > Redraw (in Navigate). 

• On the menu, choose View > Redraw. 

• On the Zoom toolbar, click the Redraw tool. 

• Type redraw and then press Enter. 

Information about drawing entities is stored in a database as floating point values, 

ensuring a high level of precision. Sometimes a drawing must be recalculated, or 

regenerated, from the floating-point database to convert those values to the appropri- 

ate screen coordinates. This occurs automatically. You can also manually initiate a 

regeneration. When the drawing is regenerated, it is also redrawn. 

To regenerate the current window, type regen in the command bar. If more than one 

window is displayed, type regenall to regenerate all the windows. 
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Moving around within a drawing 
 

You can move the view of a drawing displayed in the current viewport by scrolling, 

panning, or rotating the view. Doing this changes the portion of the drawing you are 

viewing without changing the current magnification. Scrolling lets you move around 

in the drawing horizontally and vertically. Panning lets you move the drawing in any 

direction. Rotating lets you view your drawing from any angle. 

You can also move to a different view using the following: 

• Model and Layout tabs. For more details, see “Viewing drawings in paper space 

and model space” on page 522. For more details, see Viewing drawings in paper 

space and model space. 

• Named views. For more details, see “Using named views” on page 296. For more 

details, see Using named views. 

 

Using scroll bars 
To assist you in navigating within a drawing, horizontal and vertical scroll bars are 

available in each drawing window. The size of the scroll box in relation to the scroll 

bar indicates the current level of drawing magnification. The position of the scroll 

box in relation to the scroll bar indicates the location of the center of the drawing in 

relation to the extents of the drawing (the smallest rectangle containing all the entities 

in the drawing). 
 

To turn scroll bars on or off 

Do one of the following to choose Scroll Bars: 

• On the ribbon, choose View > Scroll Bars (in Display). 

• On the menu, choose View > Display > Scroll Bars. 

• Choose Tools > Options > Display tab, and select Show Scroll Bars. 

• Type scrollbar, press Enter, and then select On, Off, or Toggle. 

 

Panning a drawing 
You can move the drawing in any direction using the Pan tool (  ) on the View 

toolbar. Panning shifts or slides the view of the drawing horizontally, vertically, or 

diagonally. The magnification of the drawing remains the same, as does its orienta- 

tion in space. The only change is the portion of the drawing displayed. 

 
 

If you often pan (and zoom) to a certain area of a drawing, you can create and re-use a 

view using the View Manager. 

For details, see “Using named views” on page 296. 
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Panning by specifying two points 
For precise panning, specify two points defining the magnitude and direction of the 

pan. The first point, or base point, indicates the starting point of the pan. The second 

point indicates the amount of pan displacement relative to the first point. 
 

To pan by specifying two points 

1 Do one of the following to choose Pan (  ): 

• On the ribbon, choose View > Pan (in Navigate). 

• On the menu, choose View > Pan > Pan. 

• On the View toolbar, click the Pan tool. 

• Type pan and then press Enter. 

2 Specify the pan base point either by typing the coordinates or by specifying a point 

in the drawing window. 

3 Specify the pan displacement point either by typing the coordinates or by specify- 

ing a point in the drawing window. 

 

  

Select the pan base point (A), and then select a 
second point (B) to specify the pan displacement. 

 

Panning in real time 

Result. 

By panning in real time, you control the pan at the same time you move your mouse. 

 
 

Using real-time pan in large drawing files can be memory intensive. 

It may be helpful to set the ZOOMDETAIL system variable to a higher number to 

reduce the number of entities that display. For example, if the value is set to 10, only 

the 10th entity will display when panning and zooming in real-time. 
 

 

A 
B 
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To pan in real time 

1 Do one of the following to choose Real-Time Pan (  ): 

• On the ribbon, choose View > Real-Time Pan (in Navigate). 

• Choose View > Pan > Real-Time Pan. 

• On the Zoom toolbar, click the Real-Time Pan tool. 

• Type rtpan and then press Enter. 

2 Click and hold the left mouse button. 

3 Move the cursor in the direction you want to pan. 

4 To stop panning, release the mouse button. 

 
Panning using a mouse with a wheel 
You can use the wheel of your mouse to help move around in a drawing. 

The MBUTTONPAN system variable controls this feature. 

To pan using a mouse with a wheel 

• Press and hold the wheel, and then move the mouse in the direction you want to 

pan. 

 

Panning using the arrow keys 
To pan in small increments, use the arrow keys. 

You can pan using the arrow keys if Use Up/Down Arrows for Command History 

Navigation is not marked on the Display tab in Tools > Options. 
 

To pan using the arrow keys 

• Press the up, down, right, or left arrow keys. 

 

Orbiting the drawing in real time 
4MCAD allows you to orbit the drawing, or rotate the view, in real time. This allows 

you to view your model from any angle while in model space. You cannot rotate the 

view while in paper space. 

 
 

Using 3D Orbit commands in large drawing files can be memory intensive. 

It may be helpful to set the ZOOMDETAIL system variable to a higher number to 

reduce the number of entities that display. For example, if the value is set to 10, only 

the 10th entity will display when panning and zooming in real-time. 
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To orbit the drawing 

1 Do one of the following to choose Constrained Orbit (  ): 

• On the ribbon, choose View > Constrained Orbit (in Navigate). 

• On the menu, choose View > 3D Orbit > Constrained Orbit. 

• On the 3D Orbit toolbar, click the Constrained Orbit tool. 

• Type 3dorbit and then press Enter. 

2 Do one of the following: 

• Click and drag the left mouse button to orbit the drawing. 

• Choose Set to pick a different point on which to orbit, then click and drag the 

mouse to orbit the drawing. 

3 To stop orbiting, release the mouse button. 

 
 

Use a shortcut. 

Press and hold Shift while viewing a drawing, then click and drag the middle mouse 

button (wheel) to orbit the drawing. 
 

 

 
To orbit the drawing using continuous motion 

1 Do one of the following to choose Continuous Orbit (  ): 

• On the ribbon, choose View > Continuous Orbit (in Navigate). 

• On the menu, choose View > 3D Orbit > Continuous Orbit. 

• On the 3D Orbit toolbar, click the Continuous Orbit tool. 

• Type 3dcorbit and then press Enter. 

2 Do one of the following: 

• Click and drag the left mouse button to orbit the drawing. 

• Choose Set to pick a different point on which to orbit, then click and drag the 

mouse to orbit the drawing. 

3 Release the mouse button. The view continues to orbit. 

4 When finished, press Enter or Esc, or right-click the drawing. 

 
 

You can orbit without locking any axis or choose a different axis to lock. 

Use the Free Orbit command to orbit the drawing without any axis locked. Use the 

Constrained X Orbit, Constrained Y Orbit, and Constrained Z Orbit commands to 

orbit the drawing while maintaining the chosen axis. You can also press Ctrl and use 

the right mouse button to rotate the view about the z-axis. 
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Using a camera to view the drawing 
Cameras define settings for 3D views of drawings according to a location and target. 

You can also specify the camera height, clipping boundaries for the view, and other 

options. 

To modify a camera, select it in the drawing and move its grips or change its proper- 

ties in the Properties pane. Cameras are named views that can also be changed using 

the View Manager. For more details about the Properties pane, see “Modifying the 

properties of entities” on page 350. For more details about View Manager, see 

“Using named views” on page 296. 
 

To create a camera 

1 Do one of the following to choose Create Camera (  ): 

• On the ribbon, choose View > Create Camera (in Views). 

• On the menu, choose View > Create Camera. 

• On the View toolbar, click the Create Camera tool. 

• Type camera and then press Enter. 

2 Specify the camera location. 

3 Specify the target point of the view. 

4 Choose one of the following to specify more options: 

• Name Enter a new name for the camera, then press Enter. 

• Location Specify a new camera location, then press Enter. 

• Height Specify the height of the camera, then press Enter. 

• Target Specify a new target point for the camera view, then press Enter. The 

target location is the center of the view. 

• Lens Enter the length of the lens. The greater the value, the more narrow the 

view. The value must be 600 or less millimeters. 

• Clipping There are two clipping planes that help define the view. Anything 

between the camera and the front clipping plane is hidden, and anything 

between the back clipping plane and the target is hidden. Choose Yes to specify 

a front (or back) clipping plane, enter a distance, and then press Enter. Choose 

No for either option to disable the clipping plane. 

• View Choose Yes to switch the current view to the camera settings when the 

camera is created. Choose No to keep the current view the same when the 

camera is created. 

5 When done, press Enter. 
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To switch to a camera view 

1 Do one of the following to choose View Manager (  ): 

• On the ribbon, choose View > View Manager (in Views). 

• On the menu, choose View > View Manager. 

• On the View toolbar, click the View Manager tool. 

• Type view and then press Enter. 

2 Select a camera view. 

3 Click Set Current. 
 
 

 

Changing the magnification of your drawing 
 

You can change the magnification of your drawing at any time by zooming. The 

cursor changes to a magnifying glass ( ) when a zoom tool is active. Zoom out to 

reduce the magnification so you can see more of the drawing, or zoom in to increase 

the magnification so you can see a portion of the drawing in greater detail. Changing 

the magnification of the drawing affects only the way the drawing is displayed; it has 

no effect on the dimensions of the entities in your drawing. 

 
 

If you often zoom (and pan) to a certain area of a drawing, you can create and re-use a 

view using the View Manager. 

For details, see “Using named views” on page 296. 
 

 

 
 

If you cannot zoom in a layout viewport, the layout viewport may be locked. 

The scale and view do not change in model space while panning or zooming in a 

locked layout viewport. For more details, see “Modifying layout viewports” on page 

531. For more details, see Modifying layout viewports. 
 

 

 

Understanding zoom 
One of the easiest ways to change the magnification of the drawing is to zoom in or 
out by a preset increment. On the Zoom toolbar, the Zoom In tool ( )doubles the 

current magnification of the drawing. The Zoom Out tool ( ) reduces the magnifi- 

cation of the drawing by half. The portion of the drawing located at the center of the 

current viewport remains centered on the screen as you zoom in and out. 
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Zoom in. Zoom out. 
 

Zooming in to an area using a window 
You can create a window that defines the portion of the drawing to which you want to 

zoom. 
 

To zoom in to an area using a window 

1 Do one of the following to choose Zoom Window (  ): 

• On the ribbon, choose View > Zoom Window (in Navigate). 

• On the menu, choose View > Zoom > Window. 

• On the Zoom toolbar, click the Zoom Window tool. 

• Type zoom and then press Enter. 

2 Select one corner of the window around the area you want to magnify. 

3 Specify the opposite corner of the window around the area you want to magnify. 

 
 

  

To specify a rectangular window around the 
area you want to magnify, select first one corner 
(A), and then select the opposite corner (B). 

Result. 

B 

A 
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Zooming in to one or more entities 
You can zoom in to specific entities that you select. The window fills with the entities 

that you select. 
 

To zoom in to one or more entities 

1 Select one or more entities. 

2 Do one of the following to choose Zoom Entity (  ): 

• On the ribbon, choose View > Zoom Entity (in Navigate). 

• On the menu, choose View > Zoom > Entity. 

• On the Zoom toolbar, click the Zoom Entity tool. 

 

Zooming in real time 
By zooming in real time, you control the zoom at the same time you move your 

mouse. 
 

To zoom in real time 

1 Do one of the following to choose Real-Time Zoom (  ): 

• On the ribbon, choose View > Real-Time Zoom (in Navigate). 

• On the menu, choose View > Zoom > Real-Time Zoom. 

• On the Zoom toolbar, click the Real-Time Zoom tool. 

• Type rtzoom and then press Enter. 

• Simultaneously press and hold Ctrl + Shift. 

2 Click and hold the left mouse button. 

3 To zoom in, move the cursor up the screen; to zoom out, move the cursor down the 

screen. 

4 To stop zooming, release the mouse button. 

 

Zooming using a mouse with a wheel 
Each rotation of the wheel away from you zooms out .8 times; each rotation toward 

you zooms in 1.25 times. 
 

To zoom using a mouse with a wheel 

• Rotate the wheel away from you to zoom in or toward you to zoom out. 

 
 

Customize the mouse wheel 

Settings for the mouse wheel can be customized to accommodate your work style 

using the ZOOMWHEEL (wheel direction), ZOOMPERCENT (display accuracy for 

curved entities), and ZOOMFACTOR (zoom factor for the wheel) system variables. 
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Displaying the previous view of a drawing 
After you zoom in or pan to view a portion of your drawing in greater detail, you may 

want to restore the previous view to see the entire drawing. 
 

To display the previous view of a drawing 

1   Do one of the following to choose Zoom Previous (  ): 

• On the ribbon, choose View > Zoom Previous (in Navigate). 

• On the menu, choose View > Zoom > Previous. 

• On the Zoom toolbar, click the Zoom Previous tool. 

Selecting this tool repeatedly steps back through up to 25 successive zoomed or 

panned views. 

 

Zooming to a specific scale 
You can increase or decrease the magnification of your view by a precise scale factor 

measured relative to the overall size of the drawing or in relation to the current dis- 

play. When you change the magnification factor, the portion of the drawing located at 

the center of the current viewport remains centered on the screen. 

To change the magnification of the view relative to the overall size of the drawing, 

type a number representing the magnification scale factor. For example, if you type a 

scale factor of 2, the drawing appears at twice its original size. If you type a magnifi- 

cation factor of .5, the drawing appears at half its original size. 

You can also change the magnification of the drawing relative to its current magnifi- 

cation by adding an x after the magnification scale factor. For example, if you type a 

scale factor of 2x, the drawing changes to twice its current size. If you type a magnifi- 

cation factor of .5x, the drawing changes to half its current size. 
 

To zoom to a specific scale relative to the current display 

1 Do one of the following to choose Zoom In ( ): 

• On the ribbon, choose View > Zoom In (in Navigate). 

• On the menu, choose View > Zoom > Zoom In. 

• On the Zoom toolbar, click the Zoom In tool. 

• Type zoom and then press Enter. 

2 Type the scale factor, followed by an x (such as 2x). 

3 Press Enter. 

 

Combining zooming and panning 
You can specify the point you want at the center of the view when you change the 

drawing magnification. You can specify the point you want at the lower left of the 

view when you change the magnification of the drawing with the Zoom Left tool 

(  ) on the Zoom toolbar. With the exception of the Zoom Window tool, the other 

zoom tools zoom in or out from the center of the current view. 
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To change the center of the current view 

1 Do one of the following to choose Zoom Center (  ): 

• On the ribbon, choose View > Zoom Center (in Navigate). 

• On the menu, choose View > Zoom > Center. 

• On the Zoom toolbar, click the Zoom Center tool. 

• Type zoom, press Enter, and then in the prompt box, choose Center. 

2 Select the point you want located at the center of the new view. 

3 Specify the zoom scale factor or the height of the drawing in drawing units. 
 

  

Current view showing the point to be centered in the new view (A), and the new view zoomed using a scale 
factor of 2x. 

 

Displaying the entire drawing 
There are two main ways you can zoom to display the entire drawing: 

• Zoom all — Displays the entire drawing. If you have drawn any entities outside 

the defined limits of the drawing, the extents of the drawing are displayed. If all 

entities are within the limits of the drawing, the drawing is displayed all the way to 

the drawing limits. 

• Zoom extents — Displays the drawing to include all entities (to its extents), mak- 

ing the image fill the display to the greatest possible magnification. 
 

To display the entire drawing 

1   To display the entire drawing, do one of the following to choose Zoom All (  ): 

• On the ribbon, choose View > Zoom All (in Navigate). 

• On the menu, choose View > Zoom > All. 

• On the Zoom toolbar, click the Zoom All tool. 

Or, to display the drawing to its extents, do one of the following to choose Zoom 

Extents (  ): 

• On the ribbon, choose View > Zoom Extents (in Navigate). 

• On the menu, choose View > Zoom > Extents. 

• On the Zoom toolbar, click the Zoom Extents tool. 

A 



V I E W I N G   Y O U R   D R A W I N G 215  
 

 

 

  

Zoom extents (displays all entities). Zoom all (displays to drawing limits). 

 

 

Changing the view of annotative entities 
 

If your drawing contains annotative entities, such as text and dimensions, you can 

change the scale, or size, of these entities by setting the annotation scale. 

Entities that can be annotative include text, multiline text, tolerances, dimensions, 

leaders, multileaders, attributes, hatches, and blocks. If Annotative is set to Yes for 

one of these types of entities and you change the annotation scale, the entity will dis- 

play at a different scale than other entities in the drawing. For example, if you set the 

annotation scale to 1:2, all annotative entities will display at that scale (if Automatic 

Annotation is turned on) or only those annotative entities that support the 1:2 scale 

will display at that scale (if Automatic Annotation is turned off). 

Text styles, dimension styles, and multileader styles also can be annotative, so text, 

dimensions, or multileaders assigned an annotative style can also be affected. 

 

Turning on scaling of annotative entities 
Annotation scaling allows you to control certain entities so their size will consistently 

display when a drawing is displayed or printed at different scales. You don’t have to 

use annotation scaling, but it is a convenient way to control the scaling of the follow- 

ing entities: text, tolerances, dimensions, leaders, multileaders, attributes, hatches, 

and blocks. 

Text styles, dimension styles, and multileader styles can also use annotation scaling. 

Text, dimension, and multileader entities that are assigned an annotative style will 

have annotation scaling turned on by default. For details about text styles, see “Work- 

ing with text styles” on page 407. For details about dimensions styles, see “Using 

dimension styles and variables” on page 447. 4MCAD supports the display of 

multileaders and their styles, but not editing.) 
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To turn annotation scaling on or off for one or more entities 

1 Do one of the following to choose Properties (  ): 

• On the ribbon, choose View > Properties (in Display). 

• On the menu, choose Modify > Properties. 

• On the Modify toolbar, click the Properties tool. 

• Type entprop and then press Enter. 

• Press Ctrl +1. 

The Properties pane displays. 

2 Select the desired entities. 

3 In Annotative, select one of the following: 

• Yes Entities display according to the currently set annotation scale. 

• No Entities are not affected by the currently set annotation scale. 

To assign a scale to all annotative entities automatically 

1 On the status bar, turn on automatic annotation by double-clicking Automatic 

Annotation On/Off. 

2 On the status bar, click Annotations Scales List. 

3 Choose the annotation scale. 

All annotative entities (all entities with Annotative set to Yes) will be assigned the 

selected annotation scale. 
 

To add the current annotation scale to one more entities 

1 Do one of the following to choose Add Current Scale (  ): 

• On the ribbon, choose Annotate > Add Current Scale (in Annotation Scaling). 

• On the menu, choose Modify > Annotative Scale > Add Current Scale. 

• Type aiobjectscaleadd and then press Enter. 

2 Select the desired entities. 
 

To remove the current annotation scale from one more entities 

1 Do one of the following to choose Delete Current Scale (  ): 

• On the ribbon, choose Annotate > Delete Current Scale (in Annotation Scaling). 

• On the menu, choose Modify > Annotative Scale > Delete Current Scale. 

• Type aiobjectscaleremove and then press Enter. 

2 Select the desired entities. 
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To add or remove annotation scales for one or more entities 

1 Do one of the following to choose Add/Delete Scales (  ): 

• On the ribbon, choose Annotate > Add/Delete Scales (in Annotation Scaling). 

• On the menu, choose Modify > Annotative Scale > Add/Delete Scales. 

• Type objectscale and then press Enter. 

2 Select the desired entities. 

The Annotation Scales dialog box displays a list of annotation scales that are 

assigned to the entities. 

3 Do one of the following: 

• Click Add to select a scale and it to all selected entities. 

• Select a scale and click Delete to remove it from all selected entities. 

4 Click OK. 

 

 

 
 

D 

C 

A 

 
 
 
 

B 

 
 

 
A Displays the annotation scales assigned to 

selected entities. 

B Select whether to display all annotation scales 
assigned to selected entities or only those that 
are in common. 

C Click to delete the selected annotation scale 
from selected entities. 

D Click to select an annotation scale to assign to 
selected entities. 

 

Changing the scale of annotative entities 
The annotation scale of a drawing determines the size of annotative entities without 

changing the scale of other, non-annotative entities. 

If automatic annotation is turned on, changing the annotation scale changes the scale, 

or size, of all entities that have annotation scaling turned on. If automatic annotation 

is turned off, the size is changed only for annotative entities that are assigned the 

selected annotation scale. 
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To set the annotation scale 

1 On the status bar, click Annotations Scales List. 

2 Choose the annotation scale. 

All enabled annotative entities that have the selected scale assigned to them will 

display at the new scale. 

 

To assign and set the scale automatically for all annotative entities 

1 On the status bar, turn on automatic annotation by double-clicking Automatic 

Annotation On/Off. 

2 On the status bar, click Annotations Scales List. 

3 Choose the annotation scale. 

All enabled annotative entities (all entities with Annotative set to Yes) will be 

assigned the selected annotation scale and display at that scale. 
 

 

Use a system variable. 

Automatic annotation can also be set using the ANNOAUTOSCALE system variable. 
 

 

 

Displaying and hiding certain annotative entities 
An annotative entity can be assigned numerous scales that are used for viewing and 

printing. By default, if an annotative entity is not assigned the current annotation 

scale, it still displays but at the default scale. Alternately, you can hide annotative 

entities that are not assigned the current annotation scale. 

You can set the display status for the Model tab and for each Layout tab. 
 

To display or hide annotative entities 

1 Click the desired Model tab or Layout tab. 

2 On the status bar, double-click Annotation Visibility On/Off. 

 

Returning scale views of annotative entities to their 
default positions 
Each scale view of an enabled annotative entity can be moved to different locations 

using grip editing. If various scale views of an annotative entity have been reposi- 

tioned, you can easily return those scale views to their original basepoint. 
 

To return scale views of annotative entities to their default positions 

1 Do one of the following to choose Synchronize Multiple-Scale Positions (  ): 

• On the ribbon, choose Annotate > Sync Scale Positions (in Annotation Scaling). 

• On the menu, choose Modify > Annotative Scale > Synchronize Multiple-Scale 

Positions. 

• Type annoreset and then press Enter. 

2 Select the desired entities. 
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Displaying a drawing with a visual style 
 

Visual styles allow you to easily view your drawing using different methods accord- 

ing to your needs. For example, if you’re just starting a new drawing, you might want 

to view it using a wireframe mode, which looks similar to a model made out of wire 

and displays faster than more complex visual styles. 

The following visual styles are available: 

• 2D Wireframe — Drawing displays in two dimensions with all lines drawn at the 

edge of entities. 

• 3D Wireframe — Drawing displays in three dimensions with all lines drawn at the 

edge of entities. 

• 3D Hidden — Drawing displays in three dimensions with all lines drawn at the 

edge of entities except those behind surfaces. 

• Realistic — Drawing displays in three dimensions with surfaces filled with 

assigned materials. 

• Conceptual — Drawing displays in three dimensions with surfaces filled with 

assigned materials and more conceptual detail. 

The more detail that displays on the screen, the greater the impact on performance. 
 

To change the visual style 

1   Do one of the following: 

• On the ribbon, choose View and in Visual Styles, make your selection. 

• Choose View > Visual Styles, then make your selection. 

• On the View toolbar, click the 2D Wireframe tool (  ). 

• On the View toolbar, click the 3D Wireframe tool (  ). 

• On the View toolbar, click the 3D Hidden tool ( ). 

• On the View toolbar, click the Realistic tool (  ). 

• On the View toolbar, click the Conceptual tool (  ). 

• Type vscurrent, press Enter, then make your selection. 
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Displaying multiple views 
 

When you begin a new drawing, it is displayed in a single window. You can view the 

drawing in a second window, or you can divide one window into multiple windows. 

You can also open and display multiple drawings. 

 

Working with multiple views of a single drawing 
You can open and work with several views of the same drawing simultaneously. 

There are two methods for dividing the current drawing into multiple views: 

• Open a new window of the open drawing. 

• Divide the current window into multiple views. 

After you divide a single window into multiple windows, you can control each win- 

dow separately. For example, you can zoom or pan in one window without affecting 

the display in any of the other windows. You can control the grid, snap, and view ori- 

entation separately for each window. You can restore named views in individual win- 

dows, draw from one window to another, and name window configurations 

individually so you can reuse them later. 

As you draw, any changes you make in one window are immediately visible in the 

others. You can switch from one window to another at any time, even in the middle of 

a command, by clicking the window’s title bar. 

 

Opening a new window of the same drawing 
You can open additional windows to create more than one view of a drawing. To 

open a new window, choose Window > New Window. After you open a new win- 

dow, you can change its display without affecting any of the other windows. 

When you open more than one window for a single drawing, each window is assigned 

a unique number (for example, mydrawing:1, mydrawing:2, and so on). If your cur- 

rent window is maximized, you can switch to another open window by selecting its 

name from the bottom of the Window menu. 

The names of other open drawings appear at the bottom of the Window menu. You 

can also use the Cascade, Tile Horizontally, and Tile Vertically commands to arrange 

all the open windows and drawings. To arrange all the windows and drawings into a 

stack of identically sized windows, choose Window > Cascade. Arranging windows 

and drawings in this way makes it easy to see the title bar for each window. 

To arrange all the windows and drawings horizontally so they are placed in order 

from top to bottom, choose Window > Tile Horizontally. Arranging windows and 

drawings in this way displays each open window. The windows are resized to fit 

within the available space. 

To arrange all the windows and drawings vertically so they are placed side by side, 

choose Window > Tile Vertically. Arranging windows and drawings in this way dis- 

plays each open window. The windows are resized to fit within the available space. 
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To manage all the windows from one dialog box, choose Window > Windows to 

open the Windows dialog box. 

4MCAD uses the commands in the following table to control its windows. 
 

4MCAD window-control commands 
 

 
vports Splits the current window into two, three, or four tiled windows. 

wcascade Cascades (overlaps) all open windows. 

close Closes the current window. 

closeall Closes all windows; also closes all drawings. 

closeallother Closes all windows except the current drawing window. 

wcloseall Closes all windows; also closes all drawings. 

wiarrange Arranges window icons. 

wopen Opens another window of the current drawing. 

wvtile Tiles all windows vertically. 
 

 

 

Dividing the current window into multiple views 
You can divide a single drawing window into multiple tiled windows (called view- 

ports) on the Model tab. You can control the number of windows created and the 

arrangement of the windows. You can also save and restore named window configu- 

rations and display a list of the current and saved window configurations. 

While working in a viewport, use the Maximize Viewport command to enlarge the 

view to full size, allowing you to easily work on the geometry in that view. When 

done, use the Minimize Viewport command to switch back to the original scale and 

center point of the viewport. 
 

To create multiple views 

1 Do one of the following to choose Viewports (  ): 

• On the ribbon, choose View > Viewports (in Model Viewports). 

• On the menu, choose View > Viewports. 

• On the View toolbar, click the Viewports tool. 

• Type viewports and then press Enter. 

2 In the prompt box, choose Create 2 Viewports, Create 3 Viewports, or Create 4 

Viewports. 

3 In the prompt box, choose the viewport orientation. 

Command Result 
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You can divide a drawing window into two windows arranged vertically (A) or horizontally (B); three windows 
arranged left (C), right (D), above (E), below (F), vertically (G), or horizontally (H); or four tiled windows (I). 

 

To join two views 

1 Do one of the following to choose Viewports (  ): 

• On the ribbon, choose View > Viewports (in Model Viewports). 

• On the menu, choose View > Viewports. 

• On the View toolbar, click the Viewports tool. 

• Type viewports and then press Enter. 

2 In the prompt box, choose Join. 

3 Click anywhere inside the window you want to keep. 

4 Click anywhere inside the adjacent window you want to join to the first window. 

5 Press Enter. 
 

To maximize the current view 

1   Do one of the following: 

• On the ribbon, choose View > Maximize Viewport (in Model Viewports). 

• On the menu, choose View > Viewports > Maximize Viewport. 

• On the status bar, click Maximize Viewport (  ). 

• Type vpmax and then press Enter. 

The viewport is enlarged. 
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To minimize the current view (if it is maximized) 

1   Do one of the following: 

• On the ribbon, choose View > Minimize Viewport (in Model Viewports). 

• On the menu, choose View > Viewports > Minimize Viewport. 

• On the status bar, click Minimize Viewport (  ). 

• Type vpmin and then press Enter. 

The viewport returns to its original scale and center point. 

 

Saving window configurations 
If you have divided the drawing window into multiple views, you can save the current 

window arrangement so that you can recall it to the screen later. The number and 

placement of the windows are saved exactly as they are currently displayed. The set- 

tings for each window are also saved. 
 

To name and save a window configuration 

1 Do one of the following to choose Viewports (  ): 

• On the ribbon, choose View > Viewports (in Model Viewports). 

• On the menu, choose View > Viewports. 

• On the View toolbar, click the Viewports tool. 

• Type viewports and then press Enter. 

2 In the prompt box, choose Save. 

3 Type a configuration name, and then press Enter. 

The name can be up to 255 characters in length and can contain letters, numbers, 

the dollar sign ($), hyphen (-), and underscore (_), or any combination. 
 

To restore a named window configuration 

1 Do one of the following to choose Viewports (  ): 

• On the ribbon, choose View > Viewports (in Model Viewports). 

• On the menu, choose View > Viewports. 

• On the View toolbar, click the Viewports tool. 

• Type viewports and then press Enter. 

2 In the prompt box, choose Restore. 

3 Type the name of the window configuration you want to restore. 
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Working with multiple drawings 
With the multiple-document interface (MDI) feature, you can open more than one 

drawing inside of 4MCAD. Because you can open and work on several drawings at 

one time, you can copy, cut, or paste an entity from one drawing to another. 

Each drawing appears in a drawing window, which has the following advantages: 

• You can see two or more drawings side by side. 

• You can easily copy entities from one drawing to another. 

• Using the 4MCAD Explorer, you can copy such elements as layers, linetypes, 

and text styles from one drawing to another. 

• Like viewports on the Model tab, you can tile or overlap drawing windows; unlike 

viewports on the Model tab, drawing windows maximize or reduce to an icon. 

 

 
 

One session of 4MCAD with four drawings open. 
 

Each drawing window that you open and work on retains in the Prompt History log 

all the commands that you perform, but the command line does not indicate when you 

have switched windows. 

When you work with more than one drawing open in its own window, you can easily 

move, cut, copy, and paste in between drawings. If you move an entity from one win- 

dow to another and then want to undo this action, you must undo it in both drawings 

for it to take effect. If you copy an entity from one window to another and then want 

to undo that action, you must undo it from the drawing into which you copied the 

entity. If you cut and paste an entity and then want to undo that action, you must undo 

it in both drawings. 
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Controlling visual elements 
 

The number of entities in your drawing and the complexity of the drawing affect how 

quickly 4MCAD can process commands and display your drawing. You can improve 

overall program performance by turning off the display of certain visual ele- ments, 

such as solid fills and text, while you work on the drawing. When you are ready to 

print your drawing, turn on the display of these elements so your drawing prints the 

way you want. 

You can also improve performance by turning off entity-selection highlighting, turn- 

ing off the display of marker blips created when you select locations in the drawing, 

and by turning off the display of lineweights. 

 

Displaying solid fills 
You can reduce the time it takes to display or print a drawing by turning off the dis- 

play of solid fill. When solid fills are turned off, all filled entities, such as wide 

polylines and planes, display and print as outlines. When you turn solid fills on or off, 

you must redraw the drawing before the change is displayed. 

A check mark appears next to the Fill command on the Settings menu when it is 

turned on. 
 

To turn the display of solid fills on or off 

1 Do one of the following to choose Fill (  ): 

• On the menu, choose View > Display > Fill. 

• On the Settings toolbar, click the Fill tool. 

• Type fill and then press Enter. 

2 Choose View > Redraw. 

 

 

 

Fill on. Fill off. 
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Displaying quick text 
Text entities require a considerable amount of time to display and print. You can 

reduce the time it takes to display or print a drawing by enabling quick text. For 

example, if you’re doing a preliminary check print of a drawing, you may want to 

turn quick text on to speed up printing. When quick text is enabled, text entities are 

replaced by rectangular boxes that indicate the outline of the area occupied by the 

text. When you turn quick text on or off, you must regenerate the drawing before the 

change is displayed. 
 

To turn the display of quick text on and off 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type qtext, press Enter, and then in the prompt box, choose On or Off. 

2 Click the Display tab. 

3 Click the secondary Display tab. 

4 Select or clear the Enable Quick Text check box. 

5 Click OK. 

6 To regenerate your drawing, do one of the following to choose Regen (  ): 

• On the ribbon, choose View > Regen. 

• On the menu, choose View > Regen. 

• On the View toolbar, click the Regen tool. 

• Type regen and then press Enter. 

 
 

 
Quick Text off. Quick Text on. 
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Displaying highlighting 
You can improve overall program performance by turning highlighting off. When 

you select entities to modify, the program highlights them using a dashed linetype. 

This highlight disappears when you finish modifying the entities or when the entities 

are cleared. Sometimes highlighting entities can take a considerable amount of time. 
 

To turn highlighting on and off 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type highlight, press Enter, and then in the prompt box, choose On or Off. 

2 Click the Display tab. 

3 Click the secondary Display tab. 

4 Select or clear the Highlight Item When Selected check box. 

5 Click OK. 

 

Displaying blips 
You can turn blips off. They are the temporary markers that appear on the screen 

when you select an entity or location. Blips are visible only until you redraw the 

drawing. You cannot select blips; they are used only for reference and never print. 
 

To turn the display of blips on and off 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type blipmode, press Enter, and then in the prompt box, choose On or Off. 

2 Click the Display tab. 

3 Click the secondary Display tab. 

4 Select or clear the Show Marker Blips check box. 

5 Click OK. 
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Blips on. Blips off. 
 

Displaying lineweights 
You can reduce the time it takes to display a drawing by turning off the display of lin- 

eweights. When you turn off lineweights, all entities display as outlines. 

You can also specify a lineweight scale. Specify a smaller scale to display thinner 

lines; specify a larger scale to display thicker lines. For example, a scale factor of 0.5 

would display a .80 millimeter lineweight as .40 millimeter; a scale factor of 2 would 

increase the same lineweight to display at 1.6 millimeters. This can help you differen- 

tiate various lineweights that display in a drawing. Adjusting the lineweight display 

scale affects how the lineweights appear on your screen, not how they appear when 

printed. 

 
 

Lineweight scale can affect performance. 

Setting the lineweight scale too high may result in slower system performance. 
 

 

 

You can also adjust the units for measuring lineweights, and the default lineweight. 
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To control the display of lineweights 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

• Type lweight and then press Enter. 

2 Click the Display tab. 

3 Click the Lineweights tab. 

4 Select or clear Display Lineweights. 

5 In Units for Listing, choose Millimeters or Inches. 

6 In Default, select the lineweight assigned to layers and entities that use the Default 

lineweight. 

7 In Adjust Display Scale, move the slider to the scale you want. By default, the 

slider begins at 1.00. 

8 Click OK. 

 
 

Use a shortcut. 

To turn the display of lineweights on or off, use the LWDISPLAY system variable or 

double-click the word LWT on the status bar. 
 

 

 

You can turn lineweights on or off when you print. For details, see “Specifying print 

options specifically for layouts” on page 542. 
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Working with coordinates 
 

For accuracy in a drawing, you can locate specific points by entering coordinates as 

you draw or modify entities. When you create two-dimensional entities, you enter 

two-dimensional coordinates; for three-dimensional entities, you specify three- 

dimensional coordinates. 

You can also specify coordinates in relation to other known locations or entities in a 

drawing. In particular, when you work in three-dimensional drawings, it is often eas- 

ier to specify coordinates in relation to a two-dimensional working plane, called a 

user coordinate system (UCS). 

This section explains how to work with coordinates, including how to: 

• Use two-dimensional and three-dimensional coordinate systems. 

• Specify absolute and relative coordinates. 

• Specify polar, spherical, and cylindrical coordinates. 

• Define and manipulate user coordinate systems. 

 
 

 

 
 

 

 

 
 

 

 

 

7 
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Using Cartesian coordinates 
 

Many commands in 4MCAD require that you specify points as you draw or modify 

entities. You can do so by selecting points with the mouse or by typing coordinate 

values in the command bar. The program locates points in a drawing using a Carte- 

sian coordinate system. 

 

Understanding how coordinate systems work 
The Cartesian coordinate system uses three perpendicular axes — x, y, and z — to 

specify points in three-dimensional space. Every location in a drawing can be repre- 

sented as a point relative to a 0,0,0 coordinate point, referred to as the origin. To draw 

a two-dimensional entity, you specify horizontal coordinate positions along the x-axis 

and vertical coordinate positions along the y-axis. Thus, every point on a plane can be 

represented as a coordinate pair composed of an x-coordinate and a y-coordinate. 

Positive coordinates are located above and to the right of the origin; negative coordi- 

nates are located to the left and below the origin. 

 

 
The three perpendicular axes of the Cartesian coordinate system. 

When you work in two dimensions, you need enter only the x- and y-coordinates; the 

program assumes that the z-axis value is always the current elevation. When you 

work in three dimensions, however, you must also specify the z-axis value. When you 

look at a plan view of your drawing (a view from above, looking down), the z-axis 

extends straight up out of the screen at a 90-degree angle to the xy plane. Positive 

coordinates are located above the xy plane, and negative coordinates are below the 

plane. 

-X 
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All 4MCAD drawings use a fixed coordinate system, called the World Coordinate 

System (WCS), and every point in a drawing has a specific x,y,z-coordinate in the 

WCS. You can also define arbitrary coordinate systems located anywhere in three- 

dimensional space. These are called user coordinate systems and can be located any- 

where in the WCS and oriented in any direction. 

You can create as many user coordinate systems as you want, saving or redefining 

them to help you construct three-dimensional entities. By defining a UCS within the 

WCS, you can simplify the creation of most three-dimensional entities into combina- 

tions of two-dimensional entities. 

To help you keep your bearings in the current coordinate system, the program dis- 

plays a coordinate system icon. When you begin a new drawing, you are automati- 

cally in the WCS, indicated by the letter W in the icon. When you display a drawing 

in plan view, you see the coordinate system icon from the top, with the z-axis directed 

straight toward you. When you display a three-dimensional drawing in a view other 

than plan view, the coordinate system icon changes to reflect your new viewpoint. 

 
 

The visible portions of the axes are the positive directions. 

The invisible portions are the negative directions. 
 

 

 

 
WCS icon. Plan UCS icon. 3D View WCS icon. 

The 4MCAD UCS icon looks different from the UCS icon in AutoCAD, because it 

presents more information. Three colors represent the three axes, making it easier for 

you to recognize the orientation in three-dimensional space: 

• x-axis: red 

• y-axis: green 

• z-axis: blue 

If you prefer a single color for the cursor and UCS icon, you can make that change 

with the config or options command. 



234 C H A P T E R   7 
 

 
Understanding how coordinates display 
The current position of the cursor is displayed as x,y,z-coordinates in the status bar 

and, by default, updates dynamically as you move the cursor. You can toggle the 

coordinate display to static mode by pressing F6, so that it updates only when you 

select a point in the drawing. 

You can also change the coordinate display to a different dynamic mode that shows 

the distance and angle (rather than x,y,z-coordinates) when the program displays a 

rubber-band line. To do this, choose Tools > Drawing Settings and select the Display 

tab. Under Coordinate Display, select the option for Coordinates In Polar Form For 

Distance And Angle Selection. 

 

 

 

You can control the coordinate display from the Drawing Settings dialog box. 
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Finding the coordinates of a point 
To find the x,y,z-coordinates for a point on an entity, such as the endpoint of a line, 

select an appropriate entity snap (such as Endpoint) before selecting the entity. If you 

have no entity snaps set, the x,y-coordinates of the point you specified is displayed, 

with the z-coordinate equal to the current elevation. 
 

To find the coordinate of a point in the drawing 

1 Do one of the following to choose ID Coordinates (  ): 

• On the ribbon, choose Tools > ID Coordinate (in Inquiry). 

• On the menu, choose Tools > Inquiry > ID Coordinates. 

• On the Inquiry toolbar, click the ID Coordinates tool. 

• Type idpoint and then press Enter. 

2 Select the point for which you want to find the coordinates. 

If the command bar is activated, the x,y,z-coordinates for the point you selected 

display in the command bar. 

If the command bar is not activated, the Prompt History window displays, show- 

ing the x,y,z-coordinates for the point you selected. 

 
 

 

Using two-dimensional coordinates 
 

When working in two dimensions, you specify points on the xy plane. You can spec- 

ify any point as an absolute coordinate (or Cartesian coordinate), using the exact x- 

coordinate and y-coordinate locations in relation to the origin (the 0,0 coordinate 

point at which the two axes intersect), or as a relative coordinate in relation to the pre- 

vious point. You can also specify points using relative or absolute polar coordinates, 

which locate a point using a distance and an angle. 

 

Entering absolute Cartesian coordinates 
To enter absolute Cartesian coordinates, type the coordinate location of the point in 

the command bar. For example, to use absolute Cartesian coordinates to draw a line 

from the origin (0,0) to a point 3 units to the right and 1 unit above the origin, start the 

Line command and respond to the prompts as follows: 

Start of line: 0,0 
 

Angle • Length • <Endpoint>: 3,1 
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Drawing a line using the absolute Cartesian coordinate method. 

When using absolute Cartesian coordinates, you need to know the exact point loca- 

tions for anything you draw. For instance, to use absolute Cartesian coordinates to 

draw an 8.5-unit square with its lower left corner at 4,5, you must determine that the 

upper left corner is at coordinate 4,13.5, the upper right corner at 12.5,13.5, and the 

lower right corner at 12.5,5. 

 

Entering relative Cartesian coordinates 
Another, simpler method is to use relative Cartesian coordinates: you specify a 

location in the drawing by determining its position relative to the last coordinate you 

specified. To use relative Cartesian coordinates, type the coordinate values in the 

command bar, preceded by the at symbol (@). The coordinate pair following the @ 

symbol represents the distance along the x-axis and the y-axis to the next point. For 

example, to draw an 8.5-unit square with its lower left corner at 4,5 using relative 

Cartesian coordinates, start the Line command, and then respond to the prompts as 

follows: 

Start of line: 4,5 
 

Angle • Length • <Endpoint>: @8.5,0 
 

Angle • Length • Follow • Undo • <Endpoint>: @0,8.5 
 

Angle • Length • Follow • Close • Undo • <Endpoint>: @-8.5,0 
 

Angle • Length • Follow • Close • Undo • <Endpoint>: C 

Y 3 

(0, 0) 
(3, 1) 

-X 

1 
X 

-Y 
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Drawing a square using the relative Cartesian coordinates method; enter C to close. 

The first relative coordinate (@8.5,0) locates the new point 8.5 units to the right 

(along the x-axis) from the previous point of 4,5; the second relative coordinate 

(@0,8.5) locates the next point 8.5 units above (along the y-axis) the previous point, 

and so on. Entering C (for Close) draws the final line segment back to the first point 

specified when you started the Line command. 

 

Entering polar coordinates 
Using relative polar coordinates makes drawing a square tilted at a 45-degree angle a 

simple task. Polar coordinates base the location of a point on a distance and angle 

from either the origin (absolute coordinate) or from the previous point (relative coor- 

dinate). 

To specify polar coordinates, type a distance and an angle, separated by the open 

angle bracket (<). For example, to use relative polar coordinates to specify a point 1 

unit away from the previous point and at an angle of 45 degrees, type @1<45. 

To draw the square from the example in the previous section, “Entering relative Car- 

tesian coordinates,” this time tilted at a 45-degree angle, start the Line command, and 

then respond to the prompts as follows: 

Start of line: 4,5 
 

Angle • Length • <Endpoint>: @8.5<45 
 

Angle • Length • Follow • Undo • <Endpoint>: @8.5<315 
 

Angle • Length • Follow • Close • Undo • <Endpoint>: @8.5<225 
 

Angle • Length • Follow • Close • Undo • <Endpoint>: C 

Y @-8.5, 0 
13 

C 

@0, 8.5 

(4, 5) @8.5,0 

(0, 0) 
-X X 

-Y 4 12 
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Drawing a tilted square using the relative polar coordinates method; enter C to close. 

 
 

This example assumes the program’s default settings. 

Like all examples in this guide, the example assumes default settings: Angles increase 

counterclockwise and decrease clockwise. An angle of 315 degrees is the same as -45 

degrees. 
 

 

 
 

 

Using three-dimensional coordinates 
 

Specifying coordinates in three-dimensional space is similar to working in two 

dimensions, except that you also use the z-axis to locate coordinates. Three-dimen- 

sional coordinates are represented in the format x,y,z (for example, 2,3,6). 

 

Using the right-hand rule 
To visualize how 4MCAD works with three-dimensional space, use a technique 

known as the right-hand rule. Hold up your right hand in a loose fist with your palm 

facing you. Extend your thumb in the direction of the positive x-axis and your index 

finger upward in the direction of the positive y-axis. Then extend your middle finger 

straight toward you in the direction of the z-axis. These three fingers are now pointing 

in the positive x, y, and z directions, respectively. 

You can also use the right-hand rule to determine the positive rotation direction. Point 

your thumb in the positive direction of the axis about which you want to rotate, and 

then curl the rest of your fingers toward your palm. These fingers are curling in the 

positive rotation direction. 

Y 

@8.5<45 
@8.5<315 

5 (4, 5) 

@8.5<225 

(0, 0) C 
-X X 

-Y 4 
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The right-hand rule helps you determine the positive direction of the x-, y-, and z-axes and the 
positive rotation direction. 

 

Entering x,y,z-coordinates 
When working in three dimensions, you can specify x,y,z-coordinates as absolute dis- 

tances in relation to the origin (the 0,0,0 coordinate point at which the three axes 

intersect) or as relative coordinates based on the last point selected. For example, to 

specify a point 3 units along the positive x-axis, 4 units along the positive y-axis, and 

2 units along the positive z-axis, specify the coordinate 3,4,2. 

 

Entering spherical coordinates 
When working in three-dimensional space, you can use spherical coordinates to spec- 

ify a three-dimensional point by entering its distance from either the origin (absolute 

distance) or the last point (relative distance), along with its angle in the xy plane and 

its angle up from the xy plane. In spherical format, you separate each angle with the 

open angle bracket (<). 

Thus, to draw a line from the origin to a point 10.2500 drawing units away, at an 

angle of 45 degrees from the x-axis and 35 degrees from the xy plane, start the Line 

command, and then respond to the prompts as follows: 

Start of line: 0,0,0 
 

Angle • Length • <Endpoint>: 10.2500<45<35 

Y 
 
 
 
 

 
Z 

X 
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When you draw a line from a start point (A) to an endpoint (B) using spherical coordinates, you 
specify its length (C, in this case 10.2500 units), the angle in the xy plane (D, in this case 45 
degrees), and the angle from the xy plane (E, in this case 35 degrees). 

 

Entering cylindrical coordinates 
When working in three-dimensional space, you can also use cylindrical coordinates 

to specify a three-dimensional point. You specify a point by entering its distance from 

either the origin (absolute distance) or the last point (relative distance), its angle in the 

xy plane, and its z-coordinate value. 

In cylindrical format, you separate the distance and angle with the open angle bracket 

(<) and separate the angle and z value with a comma. For example, to draw a line 

from the last point to a point 7.4750 units away, at an angle of 27 degrees from the x- 

axis in the xy plane and 3 units up in the z direction, start the Line command, and then 

respond to the prompts as follows: 

Start of line: (select point A) 
 

Angle • Length • <Endpoint>: @7.4750<27,3 

 

 

When you draw a line from a start point (A) to an endpoint (B) using cylindrical coordinates, 
you specify its length (C, in this case 7.4750), the angle in the xy plane (D, in this case 27 
degrees), and the distance in the z direction (E, in this case 3 units). 

Z 

C 
B Y 

E 

A D 

X 

Z 

B 

C 
E Y 

A D 

X 
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Using xyz point filters 
 

Point filters provide a method of locating a point in a drawing relative to another 

point without specifying the entire coordinate. Using a point filter, you can enter par- 

tial coordinates, and then the program prompts you for the remaining coordinate 

information. To use xyz point filters, respond to the prompt for a coordinate with a 

filter in the following form: 

.coordinate 

where coordinate is one or more of the letters x, y, and z. The program then prompts 

you for the filtered coordinate(s). For example, if you type .xy, the program prompts 

you to select a point whose xy-coordinate you want, and then prompts you for the z- 

coordinate. The filters .x, .y, .z, .xy, .xz, and .yz are all valid filters. 

 

Using point filters in two dimensions 
You can use point filters when you work in two dimensions to locate points in rela- 

tion to existing entities. For example, to draw a circle centered in a rectangle, start the 

Circle command, and then respond to the prompts as follows: 

2Point • 3Point • RadTanTan • Arc • Multiple • <Center of circle>: .y 
 

Select Y of: mid 
 

Snap to midpoint of: (select the left side of the rectangle) Still need XZ 

of: mid 

Snap to midpoint of: (select top of the rectangle) Diameter • 

<Radius>: (specify radius of circle) 

 

 
You can use point filters to center the circle by separately selecting the midpoints of 
two sides of the rectangle (A and B) and then specifying its radius. 

B 

 
A 
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Using point filters in three dimensions 
You can use point filters when you work in three-dimensional space to locate points 

in two dimensions and then specify the z-coordinate as the elevation above the xy 

plane. For example, to begin drawing a line from a point with a z-coordinate 3 units 

above the center of a circle, insert the circle, and then start the Line command and 

respond to the prompts as follows: 

ENTER to use last point • Follow • <Start of line>: .xy 
 

Select XY of: cen 
 

Snap to centerpoint of: (select a point on the circle) 
 

Still need Z of: 3 (locates the starting point 3 units above the center of 

the circle) 

Length of line: (specify the length of the line) 

 

 
You can use point filters to draw a line by first selecting a point in the xy plane (A), 
specifying the z-coordinate (B), and then specifying the length of the line (C). 

B 
 

C 

A 
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Defining user coordinate systems 
 

A user coordinate system (UCS) is a Cartesian coordinate system with origins and 

orientation defined by the user. 

 

Understanding user coordinate systems 
When working in three-dimensional space, you can define a UCS with its own 0,0,0 

origin and orientation separate from the WCS. You can create as many user coordi- 

nate systems as you want, and then save and recall them as you need them to simplify 

construction of three-dimensional entities. 

For example, you can create a separate UCS for each side of a building. Then, by 

switching to the UCS for the east side of the building, you can draw the windows on 

that side by specifying only their x- and y-coordinates. When you create one or more 

user coordinate systems, the coordinate entry is based on the current UCS. 

 

 

UCS aligned with the front wall of the house. 
 

Defining a user coordinate system 
To define a UCS, you can use any of the following methods: 

• Specify a new origin and points on the positive x- and y-axes. 

• Specify a new origin and point on the positive z-axis. 

• Align the UCS with an existing entity. 

• Rotate the current UCS around any of its axes. 

• Align the UCS with its z-axis parallel to the current viewing direction. 

• Align the UCS xy plane perpendicular to the current view. 

When you define a new UCS, the UCS icon changes to indicate the origin and orien- 

tation of the new UCS. 
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To define a UCS by specifying a new origin and points on the positive x- and y- 

axes 

1 Do one of the following to choose User Coordinate Systems ( ): 

• On the ribbon, choose Draw > User Coordinate Systems or choose 

View > User Coordinate Systems. 

• On the menu, choose Tools > User Coordinate Systems > Select a Predefined 

UCS. 

• On the UCS toolbar, click the Select a Predefined UCS tool. 

• Type setucs and then press Enter. 

2 In the User Coordinate Systems dialog box, click Explore UCSs. 

3 In 4MCAD Explorer, be sure that Coordinate Systems is selected, and click the 

New Item tool ( ). 

4 In the prompt box, choose 3 Point. 

5 Select the new origin. 

6 Select a point on the positive x-axis. 

7 Select a point in the positive y direction. 

8 In the 4MCAD Explorer - Coordinate Systems dialog box, type the name for the 

new UCS, and then close the dialog box. 
 

 

Define the new UCS by selecting the origin (A), a point on the positive x-axis 
(B), and a point in the positive y direction (C). 

 

Using a preset user coordinate system 
4MCAD lets you select a preset UCS. The six planes defined by looking along the 

x,y,z-axes align the UCS with the top, left, front, bottom, right, or back, based on 

either the WCS or the current UCS in effect when you select the tool. You can also 

select the previous UCS, align the UCS to the current view, or select the WCS. 

When you select a UCS, the cursor orientation and UCS icon change to reflect the 

new UCS. The display does not change, however, unless you select the Change View 

To Plan View Of The Selected UCS check box. 

 
 

C 
 

 
A 

 

 
B 
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After you align the UCS to a preset UCS, you can use the 4MCAD Explorer to save 

the UCS. To do this, in the 4MCAD Explorer window, choose Edit > New > UCS, 

and then select Current. 
 

To select a preset UCS 

1 Do one of the following to choose User Coordinate Systems ( ): 

• On the ribbon, choose Draw > User Coordinate Systems or choose 

View > User Coordinate Systems. 

• On the menu, choose Tools > User Coordinate Systems > Select a Predefined 

UCS. 

• On the UCS toolbar, click the Select a Predefined UCS tool. 

• Type setucs and then press Enter. 

2 Under Set The Selected UCS Relative To, select either Current UCS to change to 

the new UCS by reorienting relative to the current UCS or World Coordinate Sys- 

tem (WCS) to base the new UCS orientation on the WCS. 

3 Under Select UCS, click the button corresponding to the UCS you want as the new 

current UCS. 
 

 

Preset UCSs are also available with a dialog box. 

Choose Format > User Coordinate Systems, then select a predefined UCS from the 

list. The preset UCSs are also available directly on the UCS toolbar. 
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Working with 4MCAD Explorer 
 

4MCAD Explorer provides a powerful and convenient way to maintain and man- age 

many of the features and settings of your drawings. You can use 4MCAD Explorer to 

work with layers, linetypes, text styles, coordinate systems, named views, blocks, and 

dimension styles within the current drawing or to copy this information between 

drawings. 

This section explains how to use 4MCAD Explorer to: 

• Manage elements related to settings and entities in your drawings. 

• Organize information on layers, manage layers, and work with layer states. 

• Create and use linetypes. 

• Load text fonts and create text styles. 

• Select and control coordinate systems. 

• Save and restore named views. 

• Work with layouts. 

• Save, insert, and manage blocks and external references. 

• Work with groups. 

• Copy, cut, and paste dimension styles between .dwg files. 

 

8 
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Using 4MCAD Explorer 
 

4MCAD Explorer is a separate window that allows you to view, create, copy, and 

edit layers, layer states, linetypes, text styles, coordinate systems, blocks, dimension 

styles, and views within your drawings. You can also use 4MCAD Explorer to copy 

these elements from one open drawing to another. 4MCAD Explorer is a great way 

to manage and maintain your drawings. 

 

Displaying 4MCAD Explorer 
4MCAD Explorer opens in its own, separate window, which you can move or 

resize. The 4MCAD Explorer window has its own menu and tools. 
 

To display 4MCAD Explorer 

Do one of the following to choose 4MCAD Explorer ( ): 

• On the ribbon, choose Tools > 4MCAD Explorer (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Layers (or any other 

item). 

• On the Tools toolbar, click the 4MCAD Explorer tool. 

• Type explayers and then press Enter. 

• Type la and then press Enter. 

• On the status bar, right-click the current layer, and from the list, select Properties. 

4MCAD Explorer displays elements, such as layers, layer states, linetypes, and 

more, on the left and corresponding drawing settings on the right. 
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A Tools on the 4MCAD Explorer toolbar provide controls common to 
all elements. 

B The Elements pane shows the name of every drawing currently 
open and lists the elements you can control in each drawing. 

 

C Click on a setting to change it. 

D The named settings for the selected element. 

E Other toolbars appear, depending on the Elements pane selection. 

Using 4MCAD Explorer, you can create, delete, or modify any of the settings for the 

currently selected element for a given drawing. You can also copy the contents of any 

element from one drawing to another. The tools and menu items in the 4MCAD 

Explorer window provide the following functions: 
 

4MCAD Explorer tools 
 

 
 

( ) New Item Creates a new layer, linetype, text style, coordinate system, view, block, 
external reference, or dimension style. 

 

( ) Current Makes the selection current. 

(  ) Cut Cuts the selection to the Clipboard. 

(  ) Copy Copies the selection to the Clipboard. 

(  ) Paste Pastes the selection from the Clipboard into the appropriate list of a 
different drawing. 

 

( ) Delete Deletes the selection from the list. 

 

 
( ) Purge Eliminates unreferenced elements from your drawing file. 

Tool Function 
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4MCAD Explorer tools 

 

 
(  ) Regen Recalculates the display for the current window. 

(  ) On/Off Regen     Turns on and off the display recalculation. 

 

 

Copying settings 
A particularly powerful feature of the 4MCAD Explorer is its capability of copying 

many of the settings — layers, linetypes, text styles, coordinate systems, views, 

blocks, or dimension styles — from one drawing to another. If you have more than 

one drawing open, the 4MCAD Explorer makes it easy to reuse information. For 

example, when you copy layers from one drawing to another, the layer names as well 

as their linetypes, colors, and other settings are also copied, but not the entities on 

those layers. 
 

To copy layers from one open drawing to another open drawing 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 In the Elements pane, select the drawing from which you want to copy layers. 

3 If necessary, click the plus (+) symbol to expand the Elements list for the drawing, 

and then click Layers. 

4 In the Layers Settings In Drawing list (right pane), select the layers you want to 

copy. 

5 Choose Edit > Copy, or click the Copy tool (  ). 

6 In the Elements pane, select the drawing to which you want to copy the layers. 

7 If necessary, click the plus (+) symbol to expand the Elements list for the drawing, 

and then click Layers. 

8 Choose Edit > Paste, or click the Paste tool ( ). 

( ) Help Displays online help for 4MCAD Explorer. 

Tool Function 
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Deleting settings 
You can use the 4MCAD Explorer to delete many of the items that appear in the 

Elements list. You can delete a layer, linetype, text style, coordinate system, view, 

block, or dimension style. 

Because you may have already created entities on a particular layer or using a partic- 

ular linetype or text style, deleting one of these elements requires that you make cer- 

tain choices from options the program presents. For example, if you attempt to delete 

a layer, the program prompts you to specify whether you want to move any entities 

from that layer to another layer. Every drawing has at least one layer, the default 

layer, named “0.” You cannot delete or rename this layer. Your drawing can also con- 

tain an unlimited number of additional layers, each of which you assign a unique 

name. 

If you try to delete a linetype, the program prompts you to specify whether you want 

to convert all entities drawn using that linetype to a different linetype. If you attempt 

to delete a text style, the program prompts you to specify whether you want to convert 

all text entities created using that style to a different style. 
 

To delete a layer and relocate its entities to another layer 

1 Do one of the following to choose Explore Layers (  ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 From the Layer Name list, select the layer that you want to delete. 

If that layer is the current layer, layer 0 automatically becomes the current layer. 

3 Choose Edit > Delete, or click the Delete tool ( ). 

4 From the dialog box, click the Change option and then select the layer to which 

you want to relocate entities. 
 

 

Delete a layer and its entities. 

In the command bar, type LAYDEL, then select an entity that is assigned the layer 

you want to delete. Using this method also deletes all entities assigned the layer. 
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Purging elements 
From within 4MCAD Explorer, you can eliminate unused blocks, layers, line- types, 

text styles, dimension styles, or annotation scales from your drawing file. Purg- ing 

unused elements can significantly reduce the drawing file size. 
 

To purge an element 

1 Do one of the following to choose 4MCAD Explorer ( ): 

• On the ribbon, choose Tools > 4MCAD Explorer (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer. 

• On the Tools toolbar, click the 4MCAD Explorer tool. 

• Type explayers and then press Enter. 

2 Select the element from which you want to purge unreferenced elements. 

3 Choose Edit > Purge, or click the Purge tool ( ). 
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Organizing information on layers 
 

Understanding layers 
Layers in 4MCAD are like the transparent overlays you use in manual drafting. You 

use layers to organize different types of drawing information. In 4MCAD, each 

entity in a drawing exists on a layer. When you draw an entity, it is created on the 

current layer. 

You can control the visibility of layers in individual viewports. When you turn a layer 

off, entities drawn on that layer are no longer visible, and they do not print. Although 

a layer may be invisible, you can still select it as the current layer, in which case new 

entities are also invisible until you turn the layer back on. Entities on invisible layers 

can also affect the display and printing of entities on other layers. For example, enti- 

ties on invisible layers can hide other entities when you use the Hide command to 

remove hidden lines. 

You can also freeze and thaw layers. Entities drawn on frozen layers do not display, 

do not print, and do not regenerate. When you freeze a layer, its entities do not affect 

the display or printing of other entities. For example, entities on frozen layers do not 

hide other entities when you use the Hide command to remove hidden lines. In addi- 

tion, you cannot draw on a frozen layer until you thaw it, and you cannot make a fro- 

zen layer current. 

You cannot freeze the current layer. If you attempt to freeze the current layer, a dia- 

log box appears prompting you to specify a different layer. You also cannot freeze or 

thaw a viewport layer unless you are working in a Layout tab. 

You can lock or unlock layers. The entities on a locked layer are still visible and will 

print, but you cannot edit them. Locking a layer prevents you from accidentally mod- 

ifying entities. 

Each layer has its own properties, such as color, linetype, lineweight, transparency, 

print visibility, and more. For drawings that use named print styles, layers can also 

have their own print style. Entities you draw on a particular layer are displayed in the 

color, linetype, and lineweight associated with that layer unless you override these 

settings. You control all of the associated settings for layers using the Layers element 

in the 4MCAD Explorer. You can also access layer settings for entities using the 

Entity Properties toolbar. 

Some drawings contain large lists of layers, in which case you can search for layers 

by name, or you can organize layers into subsets using layer filters. Layer states are 

also useful for drawings that contain many layers. With layer states, you can assign 

properties to individual layers and save them in a layer state, then apply those settings 

at any time. 
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Displaying layer information in 4MCAD Explorer 

To display layer information 

1 Do one of the following to choose Explore Layers (  ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Tools toolbar, click the 4MCAD Explorer tool (  ). 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 If desired, view information for only certain layers by doing one of the following: 

• On the toolbar, type the name of the desired layers, including wildcards, and 

press Enter. 

• In the list of layer filters, select All Used Layers to display only those layers that 

are used in the drawing. 

• In the list of layer filters, select an existing group filter or properties filter. 

For details about filtering and searching layers, see “Filtering and finding layers” 

on page 257 in this chapter. 
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A Click to display layer settings. 

B Select to display all layers or a filtered subset. 

C Click a column title to sort by category. 

D Double-click to collapse or expand layer filters or simply drag to move. 

E Click to collapse or expand layer filters. 

F Lists named layers in the current drawing. The list contains all layers or 
a subset if viewing by filter or only used layers. A check mark indicates 
the current layer. 

G Displays the color assigned to each layer. 

H Displays the linetype assigned to each layer. 

I Indicates the visibility status of each layer. 

J Indicates the locked or unlocked status of each layer. 

K Indicates the frozen or thawed status of each layer for all viewports. 

L Indicates the lineweight assigned to each layer. 

M Indicates the transparency assigned to each layer. 

N Indicates the print style assigned to each layer. 

O Indicates the print status of each layer. 

 

Creating  and  naming  layers 
You can create an unlimited number of layers in every drawing and use those layers 

for organizing information. When you create a new layer, it is initially assigned the 

color white (or black, depending on your system settings) and the linetype CONTIN- 

UOUS. By default, a new layer is also visible. After you create and name a layer, you 

can change its color, linetype, visibility, and other properties. 
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To create a new layer 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Do one of the following: 

• Choose Edit > New > Layer. 

• Click the New Item tool ( ). 

A new layer is added to the Layer Name list, with the default name NewLayer1. 

3 Type a name for the new layer over the highlighted default name, and then press Enter. 

4 To complete the command and return to your drawing, close the window. 
 

To change a layer name in the current drawing 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 In the Layer Name list, select the layer you want to rename. 

3 Do one of the following: 

• Choose Edit > Rename, type a new name, and then press Enter. 

• Highlight the layer name you want to change, type a new name, and then press 

Enter. 

• Right-click the layer name you want to change, and from the shortcut menu, 

select Rename, type a new name, and then press Enter. 

4 To complete the command and return to your drawing, close the window. 

 
 

The layer named “0” is reserved. 

You cannot rename it. 
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Filtering and finding layers 
Some drawings contain large lists of layers. To limit the layers that appear in the list, 

you can search layers by name (including wildcards) and you can also create layer fil- 

ters. 

By default, there are two predefined filters. One displays all layers and the other dis- 

plays all layers that are used in the drawing. 

There are two types of layer filters that you can create: 

• Properties filter — Includes layers according to properties that you specify. 

• Group filter — Includes layers that you include in the group. 

After you create a layer filter, you can turn all of its layers on or off, thaw or freeze 

the layers, and lock or unlock the layers. Layer filters can also be inverted, imported, 

and exported. 
 

 

 
0 

 
 
 

 

A Displays the list of layer filters. 

B Click to create a new layer property filter. 

C Click to create a new layer group filter. 

D Click to invert the currently selected layer filter. 

E Click to display the Layer States Manager. 

F Click to export the currently selected layer filter to an .lft file. 

G Click to import a layer filter (.lft file). 

H Type a search term, including wildcards, then press Enter to search 
layer names. 
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Searching layers by name 

To search for layers by name 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 In the 4MCAD Explorer toolbar, type the search name, including the following 

wildcards: 

• * Matches any character or series of characters. 

• ? Matches a single character. 

• # Matches any numerical character. 

• @ Matches any alphabetic character. 

• . Matches any character that is not alphabetic or numeric. 

• [ ] Matches any of the characters inside the brackets. 

• ~ Matches any characters except for those after the tilde. 

• [~] Matches any of the characters except for those inside the brackets. 

• [-] Matches a range of characters inside the brackets. 

• ’ Matches the exact characters located after the quote mark. This is most often 

used when searching for layer names that include wildcards, for example, 

@Floor or Field#. 

3 To view all layers again in the list, delete the search term. 

4 Click OK. 
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Filtering layers by property 
Layer property filters include layers according to properties that you specify. For 

example, a property filter can display all layers with a dashed linetype, then you can 

easily turn those layers on or off. 
 

To create a properties filter 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Click the Properties Filter tool (  ). 
 

 

Filters can be nested. 

To create a sub-filter of an existing filter, right-click the existing filter and choose 

New Properties Filter or New Group Filter. 
 

 

 

3 Type a name for the filter. 

4 Do any of the following in Filter Definition: 

• Click the column of an empty row to specify the property to match. All layers 

that match the specified properties of any row will be included. 

• Click the column of an existing row to specify an additional property that a layer 

must match to be included in the filter. All layer properties in a single row must 

be matched for the layer to be included. 

• Right-click a row and choose Delete Row to delete a row you no longer need. 

• Right-click a row and choose Duplicate Row to make a copy of an existing row. 

The filter preview displays the layers that will be included in the filter. 

5 Click OK. 

6 To complete the command and return to your drawing, close the window. 
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B
 
C 

 
 
 

 
D 

 
 
 
 

 
A T

ype a name of the new layer properties filter. 

B Click the column of an existing filter to specify an 
additional property that a layer must match to be 
included in the filter. 

To modify a properties filter 

 
C Click the column of an empty row to select the 

property to match. 

D Displays the layers that match the settings of the 
layer properties filter. 

1   In 4MCAD Explorer, select Layers, then do one of the following: 

• To rename a properties filter, select it and type a new name. 

• To delete a properties filter, select it and press Delete. 

• To change the definition of a properties filter, double-click it. 
 

 

Use a shortcut. 

Right-click a properties filter to modify it. 
 

 

 
To modify the layers in a properties filter 

1 In 4MCAD Explorer, select Layers. 

2 To change the visibility of all layers in a properties filter, right-click the properties 

filter, choose Visibility, then choose one of the following: 

• On 

• Off 

• Thaw 

• Freeze 
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3 To change the accessibility of all layers in a properties filter, right-click the prop- 

erties filter, choose Lock, then choose one of the following: 

• Lock 

• Unlock 

 
Filtering layers by group 
Layer group filters include any layer that you select for the group. For example, a 

group filter can display all layers that contain text entities, then you can freeze or 

thaw those layers as needed. 
 

To create a group filter 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Click the Group Filter tool (  ). 
 

 

Filters can be nested. 

To create a sub-filter of an existing filter, right-click the existing filter and choose 

New Properties Filter or New Group Filter. 
 

 

 

3 Type a name for the new group filter, then press Enter. 

4 To choose layers for the group filter, do one of the following: 

• Right-click the group filter, choose Select Layers > Add, then select entities in 

your drawing that reside on layers to include in the group. Press Enter when 

done. Choose Select Layers > Replace if the group filter has existing layers that 

you want to remove before adding new layers. 

• Double-click the group filter, then mark and unmark the desired layers. 

5 Click OK. 

6 To complete the command and return to your drawing, close the window. 

 
 

Create a group filter by converting an existing property filter. 

In 4MCAD Explorer, view layer filters, right-click a property filter, and choose 

Convert to Group Filter. 
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A Click the circle green to include its layer in the 
layer group filter. Click again to exclude it. 

 

To modify a group filter 

 

B Displays layers in the drawing. 

C Displays the layer description, if available. 

1   In 4MCAD Explorer, select Layers, then do one of the following: 

•  To rename a group filter, select it and type a new name. 

•  To delete a group filter, select it and press Delete. 

•  To change the layers included in a group filter, double-click it. 

•  To select new layers for the group filter directly in the drawing, right-click the 

group filter. Choose Select Layers > Add if you want to keep all existing layers 

in the group filter and select new ones to add directly in the drawing. Choose 

Select Layers > Replace if you want to remove all existing layers from the group 

filter and select new ones directly in the drawing. 

 
 

Use a shortcut. 

Right-click a group filter to modify it. 
 

 

 
To modify the layers in a group filter 

1 In 4MCAD Explorer, select Layers. 

2 To change the visibility of all layers in a group filter, right-click the group filter, 

choose Visibility, then choose one of the following: 

• On 

• Off 

• Thaw 

• Freeze 
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3 To change the accessibility of all layers in a group filter, right-click the group fil- 

ter, choose Lock, then choose one of the following: 

•  Lock 

•  Unlock 

 
Inverting layer filters 
Layer filters can be inverted, for example, you can invert the All Used Layers filter to 

display a list of all layers that are unused in the drawing. 
 

To invert a layer filter 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Select a layer filter. 

3 Click the Invert Filter tool (  ). 

4 To complete the command and return to your drawing, close the window. 

 
 

The filter stays inverted until it’s turned off. 

If the contents of a filter look incorrect, it could be because it is inverted. 
 

 

 
Importing and exporting layer properties filters 
Layer properties filters can be imported and exported as .lst files. 

 

To import layer properties filters 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Click the Import Layer Filter tool (  ). 

3 Navigate to where you want to save the layer filter, type a name, then click Save. 

4 To complete the command and return to your drawing, close the window. 
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To export layer properties filters 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Select the layer filter you want to export. 

3 Click the Export Layer Filter tool (  ). 

4 Locate the layer filter (.lft file) and select it. 

5 Click Open. 

6 To complete the command and return to your drawing, close the window. 

 

Setting the current layer 
When you create new entities, they are drawn on the current layer. To draw new enti- 

ties on a different layer, you must first make that layer the current layer. 
 

To make a layer current 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 In the Layer Name list, select the layer you want to make current. 

3 Do one of the following: 

• Choose Edit > Current. 

• In the Layer Name list, select the name you want to make current, and then click 

the Current tool ( ). 

• Double-click the layer name in the Layer Name list. 

• Right-click the layer name you want to change, and from the shortcut menu 

select Current. 

4 To complete the command and return to your drawing, close the window. 
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To set the current layer to that of an existing entity 

1 Do one of the following to choose Set Layer By Entity (  ): 

• On the ribbon, choose Home > Set Layer By Entity (in Layers). 

• On the menu, choose Format > Layer Tools > Set Layer By Entity. 

• On the Layer Tools toolbar, click the Set Layer By Entity tool. 

• Type setlayer and then press Enter. 

2 Select the entity to set the current layer. 

 
 

Use the command bar. 

In the command bar, type LAYBYENT and choose Set or type LAYMCUR, then select 

an entity that is assigned the layer you want to be current. 
 

 

 

Controlling layer visibility 
A layer can be visible or invisible. Entities on invisible layers are not displayed and 

do not print. By controlling layer visibility, you can turn off unnecessary information, 

such as construction lines or notes. By changing layer visibility, you can put the same 

drawing to multiple uses. 

For example, if you are drawing a floor plan, you can draw the layout of light fixtures 

on one layer and the location of plumbing lines on another. By selectively turning 

layers on and off, you can print the electrical engineering drawings and the plumbing 

drawings from the same drawing file. For even more convenience, you can control 

the visibility of layers within individual viewports, so that layers that display in one 

viewport are invisible in other viewports in the same drawing. 

When you turn a layer off, entities drawn on that layer are no longer visible. When 

you turn the layer back on, the entities on that layer are redisplayed. 
 

To turn layers on or off 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Click in the On/Off column for the layer you want to turn on or off. 

3 To complete the command and return to your drawing, close the window. 
 

You can also freeze layers to improve the performance of operations such as zooming 

and panning or producing hidden lines or shaded images. When a layer is frozen, 

entities drawn on that layer are no longer visible. 
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Select an entity that is assigned to the layer you want to turn off. 

In the command bar, type LAYBYENT and choose Off or type LAYOFF, then select 

an entity that is assigned the layer you want to turn off. 
 

 

 
 

Use a shortcut to turn on all layers. 

Choose Format > Layer Tools > Turn All Layers On or type LAYON in the command 

bar to turn on all layers in a drawing. 
 

 

 

To control the visibility of external reference layers and save any changes made to 

them in the current drawing, turn on Xref Visibility. 
 

To turn on Xref Layer visibility 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter 

2 Choose View > Records from Xref Visibility. 

 
 

Use the system variable. 

You can also turn on xref layer visibility by typing visretain to access the system vari- 

able. 
 

 

 
To freeze or thaw layers 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Click in the All Viewports column for the layer you want to freeze or thaw. 

3 To complete the command and return to your drawing, close the window. 

 
 

Select an entity that is assigned to the layer you want to freeze. 

In the command bar, type LAYBYENT and choose Freeze or type LAYFRZ, and select 

an entity that is assigned the layer you want to freeze. 
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Use a shortcut to thaw all layers. 

Choose Format > Layer Tools > Thaw All Layers or type LAYTHW in the command 

bar to thaw all layers in a drawing. 
 

 

 

Locking and unlocking layers 
Locking a layer makes it easy to refer to information contained on the layer, but pre- 

vents you from accidentally modifying its entities. When a layer is locked (but visible 

and thawed), its entities remain visible, but you cannot edit them. If you lock the cur- 

rent layer, you can still add new entities to it. Unlocking a layer restores full editing 

capabilities. 
 

To lock or unlock layers 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Click in the Locked column for the layer you want to lock or unlock. 

3 To complete the command and return to your drawing, close the window. 

 
 

Select an entity that is assigned to the layer you want to lock or unlock. 

In the command bar, type LAYBYENT and choose Lock or Unlock or type LAYLCK 

or LAYULK, then select an entity that is assigned the layer you want to lock or 

unlock. 
 

 

 

Controlling layer printing 
Controlling layer printing is another way you can specify which entities print in your 

drawing. 

By controlling layer printing, you can turn off unnecessary information during print- 

ing. For example, if you are drawing a floor plan, you can draw the layout of light fix- 

tures on one layer and the location of plumbing lines on another. By selectively 

turning layers on and off when you print, you can print the electrical engineering 

drawings and the plumbing drawings from the same drawing file. By changing layer 

printing, you can put the same drawing to multiple uses. 

When you turn off printing for a layer, entities drawn on that layer are still visible, but 

they do not print. If you turn off a layer’s visibility, entities drawn on that layer do not 

display or print. Controlling layer printing can be especially helpful if you want layer 

visibility on, but do not want to print entities on that layer. 
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Layer visibility must be turned on in order to print entities drawn on that layer. 
 

To turn layer printing on or off 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Click in the Print column for the layer you want to turn printing on or off for. 

 

Setting the layer color 
Each layer in a drawing is assigned a color. 4MCAD uses the BYLAYER color as 

the default color setting for entity creation so that new entities are drawn in the color 

of the layer on which they are inserted (set in the Drawing Settings dialog box). 

Using the 4MCAD Explorer, you can set or change the color assigned to a layer. 

With the direct-editing feature, you can click on the color you want to change, and 

then select a new color from the dialog box that appears. Changing a layer’s color 

automatically changes the color of all entities on that layer with the BYLAYER color. 
 

To change the layer color 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Click in the Color column for the layer you want to change. 

3 In the Color dialog box, select a color on one of the following tabs: 

• Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. 

You can also type the color number in the Index box. 

• True Color — Click a basic color, click a color in the color palette, enter the Hue, 

Saturation, and Luminance (HSL) values, or enter the Red, Green, Blue (RGB) 

values. There are more than 16 million true colors from which you can choose. 

• Color Books — Select a color book from the list, then click a color. You can 

select Show Only Color Book Colors Used in Drawing to limit the selection to 

only those color book colors that are used in the current drawing. If necessary, 

create or edit color books by clicking Color Book Editor. For more details, see 

“Using color books” on page 71. 

4 Click OK. 
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Entities don’t have to use the layer’s color. 

You can assign a specific color to an entity, which overrides the layer’s color setting. 

When you create a new entity, use the Format > Colors > Select Color command to 

change the current color. For an existing entity, select the entity, right-click for the 

shortcut menu, and choose Properties to change the entity’s color using the Proper- 

ties pane. 
 

 

 

For more details about using color in the many aspects of your drawing, see “Work- 

ing with colors” on page 72. 

 

Setting the layer linetype 
Each layer uses a default linetype (a repeating pattern of dashes, dots, or blank spaces). 

Linetype determines the appearance of entities both on the screen and when printed. 

It’s a good idea to assign the BYLAYER linetype to any entities that you draw on that 

layer. 4MCAD uses the BYLAYER linetype as the default linetype setting for Entity 

Creation (in the Drawing Settings dialog box). 

Using the 4MCAD Explorer, you can set or change the linetype assigned to a layer. 

With the direct-editing feature, you can click on the linetype you want to change, and 

then select a new linetype from the dialog box that appears. Changing the linetype 

assigned to a layer changes the linetype of all entities drawn on that layer with the 

BYLAYER linetype. 

Only those linetypes already set in the drawing can be assigned to layers. For more 

information about setting additional linetypes, see “Working with linetypes” on page 

279 in this chapter. 
 

To change the linetype assigned to one or more layers 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Click in the Linetype column for the layer you want to change. 

3 In the Linetype dialog box, select a new linetype for the layer, or click Browse to 

select your linetype file. 
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Entities don’t have to use the layer’s linetype. 

You can also assign a specific linetype to an entity, which overrides the layer’s line- 

type setting. When you create a new entity, use the Tools > 4MCAD Explorer > 

Explore Linetypes command to change the current linetype through the 4MCAD 

Explorer. For an existing entity, select the entity, right-click for the shortcut menu, 

and choose Properties. You can then modify the entity’s linetype using the Properties 

pane. 
 

 

 

Setting the layer lineweight 
Each layer uses a default lineweight. Lineweights determine the thickness of entities 

both on the screen and when printed. 

All new layers are assigned the DEFAULT lineweight, which is .25 millimeters or 

.01 inches. If you want a different lineweight assigned to a layer, you can easily 

change it using 4MCAD Explorer. For example, you may want different line- 

weights on each layer of your drawing to show separate elements, such as walls, 

dimensions, structural steel, and electrical plans. Changing the lineweight assigned to 

a layer changes the lineweight of all entities drawn on that layer with the BYLAYER 

lineweight. 

When you create new entities, it’s a good idea to assign the BYLAYER lineweight to 

any entities that you draw on that layer, unless you want to override the layer line- 

weight. 4MCAD uses the BYLAYER lineweight as the default lineweight setting 

when you create entities (in the Drawing Settings dialog box). 

 
 

You can change the default lineweight. 

To change the DEFAULT lineweight, choose Tools > Drawing Settings, click the 

Display tab, click the Lineweights tab, and then select a new default. 
 

 

 
To change the lineweight assigned to one or more layers 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Click in the Lineweight column for the layer you want to change. 

3 In the Lineweight list, select a new lineweight for the layer, then click OK. 
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Entities don’t have to use the layer’s lineweight. 

You can assign a specific lineweight to an entity, which overrides the layer’s line- 

weight setting. When you create a new entity, use the Tools > Drawing Settings > 

Entity Creation tab to change the current lineweight. For an existing entity, select the 

entity, right-click for the shortcut menu, and choose Properties. You can then modify 

the entity’s lineweight using the Properties pane. 
 

 

 

Setting the layer transparency 
Each layer uses a transparency value from 0 to 90, where zero is no transparency (reg- 

ular visibility) and 90 is the most transparency (almost invisible). 

By default, each layer is assigned zero transparency. If you want a different transpar- 

ency assigned to a layer, you can easily change it using 4MCAD Explorer. 
 

To change the transparency assigned to one or more layers 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Click in the Transparency column for the layer you want to change. 

3 Enter a new value for the transparency, then press Enter. 
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Setting the layer print style 
If your drawing uses named print style tables, you can specify a print style for each 

layer. Named print style tables contain print styles that you set up to control what enti- 

ties look like when they print, without actually changing the entities in the drawing. 

If your drawing uses color-dependent print style tables, you cannot specify a print 

style for a layer. These types of print style tables automatically determine printing 

requirements by the color assigned to a layer or an entity. For details about converting 

a drawing that uses color-dependent print style table to use named print style tables, 

see “Changing the print style table type of a drawing” on page 555. 

In drawings that use named print style tables, the default print style is Normal for all 

new layers. If desired, you can assign a print style using 4MCAD Explorer. Chang- 

ing the print style assigned to a layer changes the print style of all entities drawn on 

that layer with the BYLAYER print style. 

When you create new entities, it’s a good idea to assign the BYLAYER print style to 

any entities that you draw on that layer, unless you want to override the layer print 

style. 4MCAD uses the BYLAYER print style as the default print style setting when 

you create entities (in the Drawing Settings dialog box). 
 

To change the print style assigned to one or more layers (only in a drawing that 

uses named print style tables) 

1 Do one of the following to choose Explore Layers ( ): 

• On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer). 

• On the menu, choose Format > Explore Layers or choose Tools > 4MCAD 

Explorer > Explore Layers. 

• On the Explorer toolbar, click the Explore Layers tool. 

• Type explayers and then press Enter. 

2 Click in the Print Style column for the layer you want to change. 

3 If necessary, select a different print style table in the Active Print Style Table list. 

4 In Print Styles, select a print style. 

5 Click OK. 
 

 

Entities don’t have to use layer’s print style. 

For drawings that use named print style tables, you can also assign a specific print 

style to an entity, which overrides the layer’s print style setting. When you create a 

new entity, use the Tools > Drawing Settings > Entity Creation tab to change the cur- 

rent print style. For an existing entity, select the entity, right-click for the shortcut 

menu, and choose Properties. You can then modify the entity’s print style using the 

Properties pane. 
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Working with layer states 
Layer states are collections of individual layers and their properties. You can restore 

layer states at any time, which makes it easy to switch between layer configurations 

according to your tasks. 

Layer states can also be imported and exported. For example, to quickly create all the 

layers you need in a new drawing, create and export a layer state from an existing 

drawing that has the layers you need, and then import the layer state to the new draw- 

ing. 

Layer states are saved in the drawing, including drawing templates and exported or 

imported drawings. 

For each layer included in a layer state, you can set the following properties: 

• Color 

• Linetype 

• On/Off 

• Lock/Unlock 

• Freeze/Thaw 

• Lineweight 

• Transparency 

• Print 

• New Viewports 

 
Displaying layer states in the Layer States Manager 

To display the Layer States Manager 

1   Do one of the following to choose Layer State Manager (  ): 

• On the ribbon, choose Home > Layer States Manager (in Layers). 

• On the menu, choose Format > Layer State Manager or choose 

Format > Explore Layers, then click the Layer States Manager tool. 

• On the Format toolbar, click the Layer States Manager tool. 

• Type layerstate and then press Enter. 
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A Displays layer states. 

B Click to hide layer states located in externally 
referenced drawings. 

C Click to turn off drawing layers that are not in the 
selected layer state when it is restored. 

D Click to freeze drawing layers in the current viewport 
that are not in the selected layer state when it is 
restored. 

E Click to create a new layer state. 

F Click to modify the settings of the selected layer state. 

G Click to copy current layer settings from the drawing to 
the selected layer state. 

H Click to change the name or description of the selected 
layer state. 

I Click to delete the selected layer state. 

J Click to export the selected layer state to an .las file. 

K Click to import a layer state (.las file). 

L Click to mark all checkboxes. 

M Click to remove marks from all checkboxes. 

N Select which properties to restore for the selected layer 
state. 

 

Creating layer states 
In addition to loading predefined linetypes from a linetype library file, you can create 

new linetypes. You can save new linetypes you create to a linetype library file for use 

in other drawings. 
 

To create a layer state 

1   Create all of the layers that you want to be in the layer state. 

Although you can modify the layer state layer, first you should set up your draw- 

ing with its layers and properties so when you create the layer state, it captures all 
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of the settings. If you don’t want to lose your current layer settings, simply save 

them as a layer state that you can restore later. 

2 Do one of the following to choose Layer States Manager (  ): 

• On the ribbon, choose Home > Layer States Manager (in Layers). 

• On the menu, choose Format > Layer State Manager or choose Format > 

Explore Layers, then click the Layer States Manager tool. 

• On the Format toolbar, click the Layer States Manager tool. 

• Type layerstate and then press Enter. 

3 Click New. 

4 Enter a name and description, then click OK. 

5 Click Edit and do any of the following: 

• Click any column for any layer to change its setting. The new setting applies 

only when this layer state is applied (restored). 

• Click the Add Layer tool and select a layer to add to the layer state. 

• Select a layer and click the Delete Layer tool to remove a layer from the layer 

state. 

6 Click OK. 

7 Click Close. 
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A Displays the layers included in the layer state. 
Click to select a layer. 

B Click to add a layer to the layer state. 

C Click to delete the selected layer from the layer 
state. 

D Click to change a layer’s color for this layer 
state only. 

E Click to change a layer’s linetype for this layer 
state only. 

F Click to toggle a layer’s on/off status for this 
layer state only. 

G Click to toggle a layer’s lock/unlock status for 
this layer state only. 

H Click to toggle a layer’s freeze/thaw status for 
this layer state only. 

I Click to change a layer’s lineweight for this 
layer state only. 

J Click to change a layer’s transparency for this 
layer state only. 

K Click to change a layer’s print style for this 
layer state only. 

L Click to change a layer’s print status for this 
layer state only. 

M Click to change a layer’s visibility in new 
viewports for this layer state only. 

N Click a column title to sort by category. 
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Applying a layer state 

To apply the settings of a layer state 

1 Do one of the following to choose Layer State Manager (  ): 

• On the ribbon, choose Home > Layer States Manager (in Layers). 

• On the menu, choose Format > Layer State Manager or choose 

Format > Explore Layers, then click the Layer States Manager tool. 

• On the Format toolbar, click the Layer States Manager tool. 

• Type layerstate and then press Enter. 

2 Select the layer state to apply. 

3 Layer states by design don’t always contain all layers of a drawing. Make selec- 

tions for the following: 

• Layers not found in state are turned off — After the layer state is applied, the only 

layers that will be turned on are those that are included in the layer state. If 

unmarked, the on/off status of unmatched layers is not changed. 

• Layers not found in state are frozen in current viewport — After the layer state is 

applied, the only layers that will be thawed in the current viewport are those that 

are included in the layer state. If unmarked, the freeze/thaw statuses of 

unmatched layers are not changed. 

4 In Layer Properties to Restore, mark which properties of all layers included in the 

layer state to apply. If a property is not marked, that property will not be applied 

for matching layers. 

5 Click Restore. 
 
 

Displaying layer states in 4MCAD Explorer 

To display layer states 

Do one of the following or choose Explore Layer States (  ): 

• On the ribbon, choose Tools > Layer States (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Layer States. 

• On the Explorer toolbar, click the Explore Layer States tool. 

• Type explayerstates and then press Enter. 

• Choose Tools > 4MCAD Explorer, and then click the Layer States element. 
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Importing and exporting layer states from files 
Layer states can be imported and exported as .las files. Exporting layer states from 

one drawing and importing them in a new drawing is a quick way to create all the 

new layers you need for the new drawing. 
 

To import a layer state from a file 

1 Do one of the following to choose Layer States Manager (  ): 

• On the ribbon, choose Home > Layer States Manager (in Layers). 

• On the menu, choose Format > Layer State Manager or choose Format > 

Explore Layers, then click the Layer States Manager tool. 

• On the Format toolbar, click the Layer States Manager tool. 

• Type layerstate and then press Enter. 

2 Click Open. 

3 Select the .las file to import. 

4 Click Import. 
 

To export a layer state to a file 

1 Do one of the following to choose Layer State Manager (  ): 

• On the ribbon, choose Home > Layer States Manager (in Layers). 

• On the menu, choose Format > Layer State Manager or choose Format > 

Explore Layers, then click the Layer States Manager tool. 

• On the Format toolbar, click the Layer States Manager tool. 

• Type layerstate and then press Enter. 

2 Select the layer state to export. 

3 Click Export. 

4 Enter a name for the .las file. 

5 Click OK. 



W O R K I N G   W I T H   4M C A D   E X P L O R E R 279  
 

 

Working with linetypes 
 

Linetypes are sequences of alternating line segments, dots, and blank spaces that 

affect the appearance of a line. 

 

Understanding linetypes 
4MCAD provides simple and complex linetypes: 

• A simple linetype consists of a repeating pattern of dots, dashes, or blank spaces. 

• A complex linetype contains embedded shape and text entities along with 

dots, dashes, and spaces. 

You can use different linetypes to represent specific kinds of information. For exam- 

ple, if you are drawing a site plan, you can draw roads using a continuous linetype, a 

fence using a using a linetype of dashes with square posts, or a gas line using a com- 

plex linetype showing the text “GAS”. 

 

 

By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, 

and BYBLOCK. You cannot rename or delete these linetypes. Your drawing may 

also contain an unlimited number of additional linetypes. You can load more line- 

types into the program from a linetype library file or create and save linetypes you 

define. 
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Displaying linetype information in 4MCAD Explorer 

To display the 4MCAD Explorer Linetypes element 

Do one of the following to choose Explore Linetypes (  ): 

• On the ribbon, choose Tools > Linetypes (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Linetypes. 

• On the Explorer toolbar, click the Explore Linetypes tool. 

• Type expltypes and then press Enter. 

 

 

 

 
 
 

A Click to display linetype settings. 

B Lists names of linetypes loaded in the current drawing. A check 
mark indicates the current linetype. 

C Describes linetypes loaded in the current drawing. 

D Shows how linetypes will appear in the drawing. 

E Click a column title to sort by category. 
 

Setting the current linetype 
You normally draw an entity using the linetype assigned to the current layer, indi- 

cated as BYLAYER. You can also assign linetypes on a per-entity basis, which over- 

rides the layer’s linetype setting. A third option is to assign the BYBLOCK linetype, 

whereby you draw new entities using the default linetype until you group them into a 

block. The entities inherit the current linetype setting when you insert the block into 

the drawing. 
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To make the linetype current 

1 Do one of the following to choose Explore Linetypes (  ): 

• On the ribbon, choose Tools > Linetypes (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Linetypes. 

• On the Explorer toolbar, click the Explore Linetypes tool. 

• Type expltypes and then press Enter. 

2 In the Linetype Name list, select the linetype you want to make current. 

3 Do one of the following: 

• Choose Edit > Current. 

• Select it in the Linetype Name list and click the Current tool ( ). 

• Double-click the linetype name. 

4 To complete the command and return to your drawing, close the window. 

 
 

Use the status bar. 

On the status bar, right-click on the word BYLAYER for the current linetype, click 

Properties, and then choose the linetype that you want to make current. 
 

 

 

Loading additional linetypes 
Before you can select a new linetype to use in a drawing, you must either create the 

linetype definition or load a predefined linetype from a linetype library file (*.lin). 

4MCAD includes a linetype library file, icad.lin, which contains more than 100 

predefined linetypes. 
 

To load a new linetype from a linetype library 

1 Do one of the following to choose Explore Linetypes (  ): 

• On the ribbon, choose Tools > Linetypes (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Linetypes. 

• On the Explorer toolbar, click the Explore Linetypes tool. 

• Type expltypes and then press Enter. 

2 Using one of the following methods, open the New Linetype dialog box: 

• Choose Edit > New > Linetype. 

• Click the New Item tool ( ). 

• With the cursor in the right side of the window, right-click to display the 

shortcut menu, and then choose New > Linetype. 
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3 Select the linetype to load. 

4 If necessary, click Browse to choose a different linetype library file that contains 

the linetype definitions you want to load. 

5 Click OK. 

 

 
 

A Displays the name of the current linetype library 
file that contains the linetype definitions from 
which you can choose. 

B Click to select and load a linetype. 

C Click to create a new linetype definition for the 
current linetype library file. 

 

Creating and naming 
linetypes 

D Click a column title to sort by category. 

E Click to open a different linetype library file that 
contains the linetypes you want to choose. 

In addition to loading predefined linetypes from a linetype library file, you can create 

new linetypes. You can save new linetypes you create to a linetype library file for use 

in other drawings. 

 
Creating a new simple linetype 

To create a new simple linetype 

1   Do one of the following to choose Explore Linetypes (  ): 

• On the ribbon, choose Tools > Linetypes (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Linetypes. 

• On the Explorer toolbar, click the Explore Linetypes tool. 

• Type expltypes and then press Enter. 

A E 

D 

B 

C 
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2   Using one of the following methods, open the New Linetype dialog box: 

•  Choose Edit > New > Linetype. 

•  Click the New Item tool ( ). 

•  With your cursor in the right side of the window, right-click to display the 

shortcut menu, and choose New > Linetype. 

3   Click New. 

4   Type the name of the line linetype. Do not use spaces between words in the new 

linetype name. 

5   If necessary, in Linetype File Name, specify a different linetype library file to 

which you want to add the new linetype. 

6   In Linetype Description, type the linetype description. 

You can type anything in this field that will help you remember the purpose or 

appearance of this linetype. For example, it is helpful to type text or symbols such 

as    ..__.. that approximate the appearance of the linetype. 

7   In Linetype Definition, type the linetype definition. 

The definition consists of positive and negative numbers separated by commas. A 

positive number draws a solid line segment for the specified number of drawing 

units; a negative number creates a gap for the specified number of units; a zero 

creates a dot. 

8   Click OK. 

 
 

 
 

A Type a name of the new linetype. 

B Enter the path to the linetype library file to which 
you want to add the new linetype. 

C Type any description in this box that helps you 
remember the purpose or appearance of the 
linetype. 

D Type the definition of the linetype, consisting of 
positive and negative numbers separated by 
commas. 

E Click to browse and select a different linetype 
library file. 

A 

B D 

C 

D 
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Creating a new complex linetype 

To create a new complex linetype 

A complex linetype can denote utilities, boundaries, contours, and so on. As with 

simple linetypes, complex lines are dynamically drawn as the user specifies vertices. 

Shapes and text entities embedded in lines are always displayed completely; they are 

never trimmed. 

1 Do one of the following to choose Explore Linetypes (  ): 

• On the ribbon, choose Tools > Linetypes (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Linetypes. 

• On the Explorer toolbar, click the Explore Linetypes tool. 

• Type expltypes and then press Enter. 

2 Using one of the following methods, open the New Linetype dialog box: 

• Choose Edit > New > Linetype. 

• Click the New Item tool ( ). 

• With your cursor in the right side of the window, right-click to display the shortcut 

menu, and choose New > Linetype. 

3 Click New. 

4 Type the name of the line linetype. Do not use spaces between words in the new 

linetype name. 

5 In Linetype Description, type the linetype description. 

You can type anything in this field that will help you remember the purpose or 

appearance of this linetype. For complex linetypes, it is helpful to type a text 

description of the linetype. 

6 In Linetype Definition, type the linetype definition. 

As for the simple linetypes, the syntax for a complex linetype is a comma delimi- 

nated list of pattern descriptors. For more details, see “Syntax for a complex line- 

type definition” on page 285 in this chapter. 

7 Click OK. 
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Syntax for a complex linetype definition 
Complex linetypes can include shape and text entities as pattern descriptors, as well 

as the dash and dot descriptors of simple linetypes. 
 

The shape descriptor syntax 

You can add a shape entity to a complex linetype using the following syntax: 

[shape_name, shape_filename] or [shape_name, shape_filename, transform] 

The definitions of the fields in the syntax are as follows. 

shape_name 

The name of the shape to add to the linetype. The shape name must exist in the 

specified shape file (shape_filename). 

shape_filename 

The name of a compiled shape definition file (extension *.shx). If no path is 

defined for the shape file name, the library path is searched for the file. 

transform 

The transform argument is optional and can be any series of the following (each 

preceded by a comma): 

R=value Relative rotation 

A=value Absolute rotation 

S=value Scale 

X=value         X offset 

Y=value         Y offset 

In this syntax, value represents a signed decimal number. The rotation is expressed 

in degrees while the other options are in linetype scaled drawing units. 

rotation 

R=value or A=value 

R= determines a relative or tangential rotation with respect to the line’s elabora- 

tion. 

A= determines an absolute rotation of the shape with respect to the origin. All 

shapes have the same rotation regardless of their relative position to the line. The 
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value can be appended with a d for degrees (default), r for radians, or g for grads. 

If rotation is omitted, 0 relative rotation is used. 

scale 

S=value 

Determines a factor by which the shape's internal scale is multiplied. If the shape's 

internal scale is 0, the scale value is used as the scale. 

X offset 

X=value 

Determines a shift of the shape along the X axis of the linetype computed from the 

end of the linetype definition vertex. If X offset is omitted or is 0, the shape is 

elaborated with no offset. Include this field if you want a continuous line with 

shapes. This value is not scaled by the scale factor defined by S. 

Y offset 

Y=value 

Determines a shift of the shape along the Y axis of the linetype computed from the 

end of the linetype definition vertex. If Y offset is omitted or 0, the shape is elabo- 

rated with no offset. This value is not scaled by the scale factor defined by S. 
 

The text descriptor syntax 

You can add a text entity to a complex linetype using the following syntax: 

["string", style_name] or ["string", style_name, transform] 

The definitions of the fields in the syntax are as follows. 

string 

The text to be used in the complex linetype. You cannot use the ` or the " charac- 

ters in the text string. To use these characters, enter a control code (%%) with the 

ASCII value for the character instead. 

style_name 

The name of the text style to be elaborated. The specified text style must be 

included. If it is omitted, use the currently defined style. 

transform 

The transform argument is optional and can be any series of the following (each 

preceded by a comma): 

R=value Relative rotation 

A=value Absolute rotation 

S=value       Scale 

X=value      X offset 

Y=value      Y offset 
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In this syntax, value represents a signed decimal number. The rotation is expressed 

in degrees while the other options are in linetype scaled drawing units. 

rotation 

R=value or A=value 

R= determines a relative or tangential rotation with respect to the line’s elabora- 

tion. 

A= determines an absolute rotation of the text with respect to the origin. All text 

has the same rotation regardless of its relative position to the line. The value can 

be appended with a d for degrees (default), r for radians, or g for grads. If rotation 

is omitted, 0 relative rotation is used. 

Rotation is centered between the baseline and the nominal cap heights box. 

scale 

S=value 

Determines a factor by which the style's height is multiplied. If the style's height is 

0, the scale value is used as the scale. 

Because the final height of the text is defined by both the scale value and the 

height assigned to the text style, you will achieve more predictable results by set- 

ting the text style height to 0. It is recommended that you create separate text 

styles for text in complex linetypes to avoid conflicts with other text in your draw- 

ing. 

X offset 

X=value 

Determines a shift of the text along the X axis of the linetype computed from the 

end of the linetype definition vertex. If X offset is omitted or is 0, the text is elab- 

orated by using the lower left corner of the text as the offset. Include this field if 

you want a continuous line with text. This value is not scaled by the scale factor 

that is defined by S. 

Y offset 

Y=value 

Determines a shift of the text along the Y axis of the linetype computed from the 

end of the linetype definition vertex. If Y offset is omitted or is 0, the text is elab- 

orated by using the lower left corner of the text as the offset. This value is not 

scaled by the scale factor that is defined by S. 



288 C H A P T E R   8 
 

 
Modifying linetypes 

To change a linetype name 

1 Do one of the following to choose Explore Linetypes (  ): 

• On the ribbon, choose Tools > Linetypes (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Linetypes. 

• On the Explorer toolbar, click the Explore Linetypes tool. 

• Type expltypes and then press Enter. 

2 Do one of the following: 

• Select the linetype, and then choose Edit > Rename. 

• Click the linetype name you want to change, and then type the new name. 

• Right-click the linetype name you want to change, and from the shortcut menu, 

select Rename. 

3 To complete the command and return to your drawing, close the window. 

 
 

The linetypes named CONTINUOUS, BYBLOCK, and BYLAYER are reserved. 

You cannot rename them. 
 

 

 
 

 

Working with text styles 
 

A text style is a named, saved collection of format settings that determines the 

appearance of text. 

 

Understanding text styles 
When you add text to a drawing, it is created using the current text style. The text 

style determines the font, size, angle, orientation, if the text is annotative by default, 

and other text characteristics. 

Every drawing has at least one text style, named Standard, which initially uses the 

Arial font. You cannot delete the Standard style, but you can rename it or modify it. 

For example, you can change the font or the oblique angle applied to the font. You 

also can use an unlimited number of additional text styles in your drawing. 

From the 4MCAD Explorer, you can directly edit any setting associated with a text 

style by using the single-click editing method to change the setting. 



W O R K I N G   W I T H   4M C A D   E X P L O R E R 289  
 

 
Displaying text style information in 4MCAD Explorer 

To display the 4MCAD Explorer Text Styles element 

Do one of the following to choose Explore Text Styles (  ): 

• On the ribbon, choose Tools > Text Styles (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Text Styles. 

• On the Explorer toolbar, click the Explore Text Styles tool. 

• Type expstyles and then press Enter. 

 

 

A Click to display text style settings. 

B Lists names of text styles defined in the current drawing. A check mark 
indicates the current style. 

C Indicates whether text will be annotative by default; you can click to 
turn the option on or off. 

D Indicates whether annotative text in paper space will be oriented 
according to the layout viewport; you can click to turn the option on or 
off. 

E Displays the height for the text style; you can type a new height. 

F Displays the width factor for the text style; you can type a new width 
factor. 

G Displays the oblique angle for the text style; you can enter a new 
oblique angle. 

H Displays the font name on which the style is based; you can select a 
new font. 

I Displays the font style, such as bold or italic; you can select a new font 
style. 

J Displays the language on which the text style is based; you can select 
a new language. 

K Displays whether Asian language big font files are used (for .shx file 
fonts only). 

L Indicates whether text will appear backward; you can click to turn the 
option on or off. 

M Indicates whether text will appear upside down; you can click to turn 
the option on or off. 

N Indicates whether text will appear vertically; you can click to turn the 
option on or off. 

O Click a column title to sort by category. 
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Creating and naming text styles 
Fonts are character sets that consist of letters, numbers, punctuation marks, and sym- 

bols. Each font is stored in its own font file. Text styles apply additional formatting to 

fonts. You can create multiple text styles based on the same font, changing the vari- 

ous characteristics to alter the appearance of the font. To create a new text style, you 

assign formatting characteristics to a font. 

4MCAD uses *.shx font files and provides a selection of fonts. These fonts are 

located in the 4MCAD/Fonts directory. You can also use any font designed to 

work with AutoCAD as well as Windows system fonts. Many fonts are available 

from third-party vendors. 
 

To create a new text style 

1 Do one of the following to choose Explore Text Styles (  ): 

• On the ribbon, choose Tools > Text Styles (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Text Styles. 

• On the Explorer toolbar, click the Explore Text Styles tool. 

• Type expfonts and then press Enter. 

2 Do one of the following: 

• Choose Edit > New > Text Style. 

• Click the New Item tool ( ). 

A new style is added to the text styles list with the default name, NewStyle1. 

3 Type the name for the new style by typing over the highlighted default text, and 

then press Enter. 

4 Click the columns for the items you want to change and make your selections for 

the new text style. 

5 To complete the command, close the window. 
 

To change a text style name in the current drawing 

1   Do one of the following to choose Explore Text Styles (  ): 

• On the ribbon, choose Tools > Text Styles (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Text Styles. 

• On the Explorer toolbar, click the Explore Text Styles tool. 

• Type expfonts and then press Enter. 
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2 Do one of the following: 

• Select the text style, choose Edit > Rename, type a new name, and then press 

Enter. 

• Click the text style name you want to change, type a new name, and then press 

Enter. 

• Right-click the text style name you want to change, and from the shortcut menu, 

select Rename, type a new name, and then press Enter. 

3 To complete the command and return to your drawing, close the window. 

 

Modifying text styles 
A new text style is initially assigned default values for height, width factor, oblique 

angle, and other characteristics. You can change these values for both new and exist- 

ing text styles. You can also change the font assigned to the text style. If you change 

the font or orientation properties of a text style assigned to text previously inserted in 

the drawing, all text using that style is regenerated to reflect the changes. Oblique 

angle and height, if specified, are given by the style definition when text is created, 

but are not updated for existing text when the style is changed. 

A fixed text height value of 0 allows you to specify the text height at the time you 

insert text into the drawing. Any other value sets height of the text to that value; the 

program does not prompt for the text height when you insert text into the drawing. 

The width factor determines the horizontal scaling of text. A value less than 1 com- 

presses the text (for example, 0.75 compresses the text 25 percent); a value greater 

than 1 expands the text (for example, 1.50 expands the text 50 percent). The oblique 

angle determines the forward or backward slant of text as an angle offset from 90 

degrees. Negative values slant text to the left; positive values slant text to the right. 
 

To modify a text style 

1 Do one of the following to choose Explore Text Styles (  ): 

• On the ribbon, choose Tools > Text Styles (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Text Styles. 

• On the Explorer toolbar, click the Explore Text Styles tool. 

• Type expfonts and then press Enter. 

2 Click in the desired column for the text style you want to change, then make the 

desired changes. 

3 To complete the command, close the 4MCAD Explorer window. 

 

Setting the current text style 
When you insert text in a drawing, the text is created using the current text style. You 

can also select a different text style when you create text. 
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To make the text style current 

1 Do one of the following to choose Explore Text Styles (  ): 

• On the ribbon, choose Tools > Text Styles (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Text Styles. 

• On the Explorer toolbar, click the Explore Text Styles tool. 

• Type expfonts and then press Enter. 

2 In the Text Style Name list, click the style you want to make current. 

3 Use one of the following methods to make the style the current style: 

• Choose Edit > Current. 

• Click the Current tool ( ). 

• With the cursor in the right side of the window, right-click to display the 

shortcut menu, and choose Current. 

4 To complete the command and return to your drawing, close the 4MCAD 

Explorer window. 

 
 

Use a shortcut. 

You can also make a text style current by selecting it in the Text Style Name list and 

clicking the Current tool ( ) or by double-clicking the text style name in the Text 

Style Name list. 
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Working with coordinate systems 
 

A coordinate system is a system of points that represents the drawing space in rela- 

tion to an origin (0,0,0) and a set of axes that intersect at the origin. 

 

Understanding coordinate systems 
When you create entities in a drawing, they are located in relation to the drawing’s 

underlying Cartesian coordinate system. Every drawing has a fixed coordinate system 

called the World Coordinate System (WCS). You cannot delete or modify the WCS. 

Your drawing may contain additional coordinate systems, however, each with its own 

0,0,0 origin and orientation. You can create as many user coordinate systems as you 

want, and then save and recall them as you need them. You can edit the origin of a 

coordinate system from within the 4MCAD Explorer by single-clicking the origin 

coordinates and then typing new coordinates. 

For example, you can create a separate user coordinate system (UCS) for each side of 

a building. Then, by switching to the UCS for the east side of the building, you can 

draw the windows on that side by specifying only their x- and y-coordinates. 

You can create and then switch between various user coordinate systems by selecting 

Coordinate Systems in the 4MCAD Explorer. 

 

Displaying coordinate system information in 4MCAD 
Explorer 

To display the Coordinate Systems element 

Do one of the following to choose Explore Coordinate Systems (  ): 

• On the ribbon, choose Tools > Coordinate Systems (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Coordinate Systems. 

• Choose Tools > User Coordinate Systems > Explore Coordinate Systems. 

• On the Explorer toolbar, click the Explore Coordinate Systems tool. 

• Type expucs and then press Enter. 



294 C H A P T E R   8 
 

 

 

 
 

 
 

 

A Click to display the coordinate system settings. 

B Lists names of coordinate systems defined in the current 
drawing. A check mark indicates the current coordinate 
system. 

C Displays the origin of the coordinate system in relation to 
the WCS. 

D Displays the x-axis direction of the coordinate system in 
relation to the WCS. 

E Displays the y-axis direction of the coordinate system in 
relation to the WCS. 

F Click a column title to sort by category. 

 

Defining and naming user coordinate systems 
A drawing can contain as many coordinate systems as you want and can be named 

appropriate names so you can remember how they are used in your drawing for 

recalling them later. 
 

To define new user coordinate systems in the 4MCAD Explorer 

1 Do one of the following to choose Explore Coordinate Systems (  ): 

• On the ribbon, choose Tools > Coordinate Systems (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Coordinate 

Systems. 

• On the Explorer toolbar, click the Explore Coordinate Systems tool. 

• Type expucs and then press Enter. 

2 Do one of the following: 

• Choose Edit > New > UCS. 

• Click the New Item tool ( ). 

• With your cursor in the right side of the window, right-click to display the 

shortcut menu, and choose New > UCS. 
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3 Select a method from the prompt box or command bar by which to define the UCS 

in the drawing window. 

For example, select 3 Point and then specify three points in the drawing window 

to define the x, y, and z axes for your coordinate system. 

4 Type the name for the new user coordinate system by typing over the highlighted 

default text, and then press Enter. 

5 To complete the command, close the window. 
 

To change a user coordinate system name in the current drawing 

1 Do one of the following to choose Explore Coordinate Systems (  ): 

• On the ribbon, choose Tools > Coordinate Systems (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Coordinate 

Systems. 

• On the Explorer toolbar, click the Explore Coordinate Systems tool. 

• Type expucs and then press Enter. 

2 Do one of the following: 

• Select the user coordinate system, and then choose Edit > Rename, type a new 

name, and then press Enter. 

• Click the user coordinate system name you want to change, type a new name, 

and then press Enter. 

• Right-click the user coordinate system name you want to change, and from the 

shortcut menu, select Rename, type a new name, and then press Enter. 

3 To complete the command and return to your drawing, close the window. 

 

Setting the current user coordinate system 
When you draw new entities, they are created in relation to the current coordinate 

system. You can set the current UCS from the 4MCAD Explorer. 
 

To set the current UCS from the 4MCAD Explorer 

Do one of the following: 

• Double-click the UCS name in the UCS Name list. 

• Select the UCS in the UCS Name list, and then choose Edit > Current. 

• Select the UCS in the UCS Name list, and then click the Current tool ( ). 
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Using named views 
 

As you work on a drawing, you may find that you frequently switch among different 

portions of it. For example, if you are drawing the floor plan of a house, you may 

zoom in to particular rooms of the house and then zoom out to display the entire 

house. Although you can repeat the Pan and Zoom commands to do this, it is much 

easier to save various views of the drawing as named views. You can then quickly 

switch among these views. You can save and later restore named views using either 

the View command or the Views element in the 4MCAD Explorer. 

 

Displaying views in the 4MCAD Explorer 

To display views in the 4MCAD Explorer 

Do one of the following to choose Explore Views (  ): 

• On the ribbon, choose Tools > Views (in Explorer). 

• Choose Tools > Explore Views. 

• On the Explorer toolbar, click the Explore Views tool. 

• Type expviews and then press Enter. 
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Choose Tools > 4MCAD Explorer, and then click the Views element. 

 

 

 
 

 
 

 
A Click to display view settings. 

 

D Displays the width of the view in drawing units. 

B Lists names of views defined in the current drawing. 
A check mark indicates the current view. 

C Displays the height of the view in drawing units. 

E Displays the direction of the view, expressed as a three- 
dimensional coordinate in the WCS. 

F Click a column title to sort by category. 
 

Saving and naming views 

You can save the view displayed in the current window as a named view. After you 

save a named view, you can restore that view in the current window at any time. 
 

To save the current view as a named view 

1 Do one of the following to choose View Manager (  ): 

• On the ribbon, choose View > View Manager (in Views). 

• Choose View > View Manager. 

• On the View toolbar, click the View Manager tool. 

• Type view and then press Enter. 

2 Click New. 

3 In Name, type a name for the view, and then click OK. 

4 To complete the command and return to your drawing, close the window. 
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To save a portion of the current view as a named view 

1 Do one of the following to choose Explore Views (  ): 

• On the ribbon, choose Tools > Views (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Views. 

• On the Explorer toolbar, click the Explore Views tool. 

• Type expviews and then press Enter. 

2 Do one of the following: 

• Choose Edit > New > View. 

• On the 4MCAD Explorer toolbar, click the New Item tool ( ). 

3 In the prompt box, choose Window. 

4 Specify the first corner of the view window. 

5 Specify the opposite corner of the view window. 

6 Rename the new view, and then press Enter. 

Do not use spaces between words in the new view name. 

7 To complete the command and return to your drawing, close the window. 
 

To change a saved view name in the current drawing 

1 Do one of the following to choose Explore Views (  ): 

• On the ribbon, choose Tools > Views (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Views. 

• On the Explorer toolbar, click the Explore Views tool. 

• Type expviews and then press Enter. 

2 Do one of the following: 

• Select the view, choose Edit > Rename, type a new name, and then press Enter. 

• Click the view name you want to change, type a new name, and then press Enter. 

• Right-click the view name you want to change, and from the shortcut menu, 

select Rename, type a new name, and then press Enter. 

3 To complete the command and return to your drawing, close the window. 
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Restoring named views 

After you save one or more named views, you can restore any of those views in the 

current window using either the View command or the 4MCAD Explorer. 
 

To restore a named view using the View command 

1 Do one of the following to choose View Manager (  ): 

• On the ribbon, choose View > View Manager (in Views). 

• On the menu, choose View > View Manager. 

• On the View toolbar, click the View Manager tool. 

• Type view and then press Enter. 

2 Select the view you want to restore. 

3 Click Set Current. 
 

To restore a named view from the 4MCAD Explorer 

Do one of the following: 

• Select the view name in the list of View settings, and then choose Edit > Current. 

• Select the view name in the list of View settings, and then click the Current tool 

( ). 

• Double-click the view name in the View list. 

 
Changing named view properties 

Once you create a named view you can modify its properties, such as the target direc- 

tion and twist angle. This gives you access to many of the view settings after a view 

has been defined. Some properties are available directly in 4MCAD Explorer, while 

others are available in the Views Manager. 
 

To change the view options 

1 Do one of the following to choose Explore Views (  ): 

• On the ribbon, choose Tools > Views (in Explorer). 

• On the menu, choose Tools > Explore Views. 

• On the Explorer toolbar, click the Explore Views tool. 

• Type expviews and then press Enter. 

2 Click in the Height, Width, or Target Direction column for the view you want to 

change, and then make the changes. 

3 To make additional changes, click the View Manager tool (  ), change the 

desired settings, and then close the dialog box. 

4 To complete the command and return to your drawing, close the window. 
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Working with layouts 
 

Each drawing that you create contains the area where you do most of your work on 

the Model tab and can also contain numerous layouts on Layout tabs that simulate the 

paper on which you will print a copy of the drawing. 

Using 4MCAD Explorer, you can manage the layouts in a drawing, assign a page 

setup, and you can also easily copy layouts to be reused in other drawings. 

Making a layout active in 4MCAD Explorer is the equivalent of clicking its corre- 

sponding tab in the drawing window. 

 

Displaying layouts in the 4MCAD Explorer 

To display layouts in the 4MCAD Explorer 

Do one of the following to choose Explore Layouts (  ): 

• On the ribbon, choose Tools > Layouts (in Explorer). 

• On the menu, choose Tools > Explore Layouts. 

• On the Explorer toolbar, click the Explore Layouts tool. 

• Type explayouts and then press Enter. 

• Choose Tools > 4MCAD Explorer, and then click the Views element. 
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A Click to display layouts and their settings. 

B Lists names of layouts defined in the current drawing. 
A check mark indicates the current layout. 

 

D Click to view or specify the currently assigned page setup 
for the corresponding layout. 

E Click a column title to sort by category. 

C Displays the name of the block to which the layout belongs. 
 

Creating and naming layouts 
Each drawing can contain one layout for the model and up to 255 other layouts. 

 

To create a new layout 

1 Do one of the following to choose Explore Layouts (  ): 

• On the ribbon, choose Tools > Layouts (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Layouts. 

• On the Explorer toolbar, click the Explore Layouts tool. 

• Type explayouts and then press Enter. 

2 Do one of the following: 

• Choose Edit > New > Layout. 

• Click the New Item tool ( ). 

A new layout is added to the layouts list with a default name. 

3 Type the name for the new layout by typing over the highlighted default text, and 

then press Enter. 

4 To complete the command, close the window. 
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To change a layout name using 4MCAD Explorer 

1 Do one of the following to choose Explore Layouts (  ): 

• On the ribbon, choose Tools > Layouts (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Layouts. 

• On the Explorer toolbar, click the Explore Layouts tool. 

• Type explayouts and then press Enter. 

2 Do one of the following: 

• Select the layout, choose Edit > Rename, type a new name, and then press Enter. 

• Click the layout name you want to change, type a new name, and then press 

Enter. 

• Right-click the layout name you want to change, and from the shortcut menu, 

select Rename, type a new name, and then press Enter. 

3 To complete the command and return to your drawing, close the window. 

 

Specifying page setup options for a layout 
Each layout can have its own page setup assigned to it. This enables you to accommo- 

date unique print settings for each layout. If some layouts use the same print settings, 

those layouts can be assigned the same page setup. 

Assigning a page setup to a model or layout doesn’t mean it will always print with the 

specified settings. All of the print settings specified for a page setup can be overrid- 

den at print time. 

For more details about page setups, see “Working with page setups” on page 532. 
 

To assign a page setup to a layout 

1 Do one of the following to choose Explore Layouts (  ): 

• On the ribbon, choose Tools > Layouts (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Layouts. 

• On the Explorer toolbar, click the Explore Layouts tool. 

• Type explayouts and then press Enter. 

2 Click in the Page Setup column for the desired layout. 

3 Select the desired page setup, click Set Current, then click Close. 

4 To complete the command, close the 4MCAD Explorer window. 
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To modify the settings of an assigned page setup 

1 Do one of the following to choose Explore Layouts (  ): 

• On the ribbon, choose Tools > Layouts (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Layouts. 

• On the Explorer toolbar, click the Explore Layouts tool. 

• Type explayouts and then press Enter. 

2 Click in the Page Setup column for the desired layout. 

3 Select the page setup that requires changes, then click Modify. 

4 Select the new options, then click OK. 

5 If necessary, select the page setup that you want to assign to the layout, then click 

Set Current. 

6 Click Close. 

7 To complete the command, close the 4MCAD Explorer window. 
 
 

 

Working with blocks 
 

Blocks represent a special type of entity that, once saved, can be inserted and manip- 

ulated in the drawing as a single entity. 

 

Understanding blocks 
A block can consist of visible entities such as lines, arcs, and circles as well as visible 

or invisible data called attributes. You can use attributes to track things such as part 

numbers and prices and to export attribute information to an external database. You 

can also track the number of parts by counting the number of times a block has been 

inserted into the drawing. Blocks are stored as part of the drawing file. 

External references have similar uses to blocks. Using external references, you can 

attach entire drawings to your current drawing. Unlike a block, however, an external 

reference does not become part of the current drawing. 

You can save blocks in the 4MCAD Explorer. You can also use the 4MCAD 

Explorer to manage and insert copies of blocks. The 4MCAD Explorer lists the 

names of all blocks contained in the current drawing, along with other information 

about each block or external reference. 

You can also rename a block, modify its insertion point, and change the path of an 

externally referenced drawing by single-clicking on the property and making your 

edits within the 4MCAD Explorer. 
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In addition to 4MCAD Explorer, you can also work with blocks by using the Block 

Editor, by using various block commands, and by adding blocks to tool palettes. For 

more details about the Block Editor and various block commands, see “Working with 

blocks” on page 470. For more details about tool palettes, see “Customizing tool pal- 

ettes” on page 713. 

 

Displaying block information in 4MCAD Explorer 

To display blocks in the 4MCAD Explorer 

Do one of the following to choose Explore Blocks (  ): 

• On the ribbon, choose Tools > Blocks (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Blocks. 

• On the Explorer toolbar, click the Explore Blocks tool. 

• Type expblocks and then press Enter. 

The Blocks element in the 4MCAD Explorer defaults with icons on. The Icons view 

shows you a small image of each block. 

 

 

 

The Images view shows an image of each block in the selected drawing. Click an image to select it. 
 

When blocks are displayed, additional tools on the Block toolbar provide the func- 

tions described in the following table: 
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Additional tools on the Block toolbar 

 

 
( ) Icons Displays an image of each block. 

(  ) Details Displays information about each block. 

( ) Insert Inserts a block. 

( ) Insert External File Block Inserts a drawing available from disk as a block.        

(  ) Save Block Saves the selected block as an independent.dwg file. 

( ) Edit Block Reference Redefines the definition of a block. 

To see more information about each block, click the Details tool (  ). In the Details 

view, you can edit the path and the insertion point by clicking the setting and typing 
your changes. 

Tool Function 
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A Click to display block settings. 

B Lists names of blocks defined in the current drawing. Click and type 
to modify it. 

C Displays the number of occurrences of the block in the current 
drawing. 

D Displays the insertion point of the block in the current drawing. Click 
and type to modify it. 

E Indicates whether the block is annotative by default; click to turn the 
option on or off. 

F Indicates whether the block, when located in paper space, is oriented 
automatically according to the layout viewport; click to turn the option 
on or off. (Available only for annotative blocks.) 

G Indicates whether the block must scale proportionately; click to turn the 
option on or off. 

H Indicates whether the block can be exploded; click to turn the option on 
or off. 

I Displays the description of the block. Click and type to modify it. 

J Click a column title to sort by category. 
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Creating and naming blocks 
You can combine any number of entities into a single block. After you create a block, 

you can insert copies of it into a drawing. Each block insertion is treated as a single 

entity; for example, you can rotate or scale each block when you insert it. The program 

adds the name of the new block you insert to the Block Name list in the 4MCAD 

Explorer. 
 

To create a block 

1 Do one of the following to choose Explore Blocks (  ): 

• On the ribbon, choose Tools > Blocks (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Blocks. 

• On the Explorer toolbar, click the Explore Blocks tool. 

• Type expblocks and then press Enter. 

2 Do one of the following: 

• Choose Edit > New > Block. 

• On the 4MCAD Explorer toolbar, click the New Item tool ( ). 

3 In the Block definition dialog box, enter a name and description for the new block. 

4 Specify the insertion point for the block by doing one of the following: 

• Specify on Screen Mark this check box to select the base point in the drawing 

after you click OK. 

• Pick Base Point Click (  ) to temporarily close the dialog box immediately, 

select the base point in the drawing, then return to the dialog box. This option is 

available only if Specify on Screen is not marked. 

• X, Y, and Z Enter the x-, y-, and z-coordinates of the base point. This option is 

available only if Specify on Screen is not marked. 

5 Select the entities to be combined into the block by doing one of the following: 

• Specify on Screen Mark this check box to select the entities in the drawing after 

you click OK. 

• Select entities Click ( ) to temporarily close the dialog box immediately, 

select the entities in the drawing, then return to the dialog box. Or you can click  

( ) to select entities by type or value. This option is available only if Specify 

on Screen is not marked. 

6 Select what to do with the entities after the block is created: 

• Retain entities Entities selected for the block remain in the drawing. 

• Convert to block Entities selected for the block are converted to the block, 

which remains in the drawing. 

• Delete entities Entities selected for the block are removed from the drawing. 
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7 Select any of the following options for the block: 

• Annotative Determines whether the block is annotative by default. The display 

and printing of annotative blocks is affected by annotation scaling. If annotative 

by default, you can determine whether the block, when located in paper space, 

is oriented automatically according to the layout viewport. 

• Scale uniformly Mark this check box to retain the aspect ratio if the block is 

scaled. Annotative blocks must be scaled proportionately. 

• Allow exploding Mark this check box to allow the block to be exploded into 

separate entities. 

• Unit Defines the unit of the block, for example inches or millimeters. 

8 Click OK. 

The program adds a new block to the blocks list, with the name you entered for it. 

 

 
F G H I 

A Enter the name of the block. 

B Enter a description of the block. 

C Select to pick the base point in the drawing after 
you click OK. 

D Select to pick the base point now in the drawing. 

E Displays the base point coordinates or you can 
enter them manually. 

F Select to select entities to include in the block 
after you click OK. 

G Click to select entities now in the drawing. 

H Select whether to keep, convert, or delete 
entities after the block is created. 

I Click to select entities by type or value. 

J Choose block units. 

K Select to allow the block to be exploded into 
entities. 

L Select to maintain aspect ratio if the block is 
scaled. 

M Select to make the block, when located in paper 
space, oriented according to the layout viewport 
(available only if Annotative is marked). 

N Mark to make the block annotative by default. 

A 

B 

N 

C 

D 
 
 

E 

N 

M 

L 

K 

J 
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To change a block name in the current drawing 

1 Do one of the following to choose Explore Blocks (  ): 

• On the ribbon, choose Tools > Blocks (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Blocks. 

• On the Explorer toolbar, click the Explore Blocks tool. 

• Type expblocks and then press Enter. 

2 Do one of the following: 

• Select the block, choose Edit > Rename, type a new name, and then press Enter. 

• Click the block name you want to change, type a new name, and then press 

Enter. 

• Right-click the block name you want to change, and from the shortcut menu, 

select Rename, type a new name, and then press Enter. 

3 To complete the command and return to your drawing, close the window. 

 

Inserting a block 
You can insert into a drawing any block listed in the Block Name list in the 4M- 

CAD Explorer. This includes blocks contained within any open drawing. 
 

To insert a block 

1 Do one of the following to choose Explore Blocks (  ): 

• On the ribbon, choose Tools > Blocks (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Blocks. 

• On the Explorer toolbar, click the Explore Blocks tool. 

• Type expblocks and then press Enter. 

2 If you want to insert a block from another open drawing, select the drawing in the 

left side of the 4MCAD Explorer window. (If the block is contained within the 

same drawing, you can skip this step.) 

3 Select the block to be inserted. 

4 On the 4MCAD Explorer toolbar, click the Insert tool ( ). 

5 In the drawing, specify the insertion point. 

6 Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, 

select Done. 

7 To complete the command and return to your drawing, close the window. 
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Use a shortcut. 

You can insert a block by choosing Tools > 4MCAD Explorer, and then double- 

clicking the name of the block you want to insert in the Block Name list. And, you can 

also insert a block from the Insert menu, see Chapter 13, “Working with other files in 

your drawings.” 
 

 

 

Inserting a drawing as a block 

You can insert another drawing as a block into the current drawing. After you do this, 

the block name is added to the Block Name list in the 4MCAD Explorer. Changes 

made later to the inserted drawing will not be reflected in this drawing. 
 

To insert a drawing as a block 

1 Do one of the following to choose Explore Blocks (  ): 

• On the ribbon, choose Tools > Blocks (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Blocks. 

• On the Explorer toolbar, click the Explore Blocks tool. 

• Type expblocks and then press Enter. 

2 On the 4MCAD Explorer toolbar, click the Insert External File Block tool ( 

). 

3 In the Insert Block dialog box, select the drawing you want to insert, and then 

click Open. 

4 In the drawing, specify the insertion point. 

5 Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, 

select Done. 

6 To complete the command and return to your drawing, close the window. 

 

Saving a block as a separate drawing 
You can save a block as a separate drawing, and then you can open and modify that 

drawing as you would any other drawing. 
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To save a block as a separate drawing file 

1 Do one of the following to choose Explore Blocks (  ): 

• On the ribbon, choose Tools > Blocks (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Blocks. 

• On the Explorer toolbar, click the Explore Blocks tool. 

• Type expblocks and then press Enter. 

2 Select the block you want to save. 

3 On the 4MCAD Explorer toolbar, click the Save Block tool (  ). 

4 In the Save Block dialog box, select the folder in which you want to save the 

block. 

5 In the File Name field, type a name for the new drawing file (or accept the default, 

in which case the new drawing name is the same as the name of the block), and 

then click Save. 

 
 

 

Working with references to external files 
 

In 4MCAD Explorer, you can work with any file that is referenced from an open 

drawing. In addition to commonly used xrefs, or externally referenced drawing files, 

you can also manage raster images, .dwf files, .dgn files, .pdf files, and point clouds 

directly from 4MCAD Explorer. 

When you reference an external file from a drawing, the contents of referenced file 

appear in the current drawing, but the contents themselves are not added to the draw- 

ing. 

 

Displaying information about referenced files in 4MCAD 
Explorer 

To display information about referenced files 

1 Do one of the following to choose Explore External References (  ): 

• On the ribbon, choose Tools > External References (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore External 

References. 

• On the Explorer toolbar, click the Explore External References tool. 

• Type exprefs and then press Enter. 

2 Do one of the following: 

• Click the Icons tool (  ) to see a small image of each referenced file, 

• Click the Details tool ( ) to see more detailed information about each block. 
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A Click to display the externally referenced file settings. 

B Lists names of files referenced from the current drawing. 

C Displays the load status of the file in the current drawing. 

D Displays the number of times the file is referenced from the 
current drawing. 

E Displays the size of the file. 

F Displays the type of file. 

G Displays the date of the file. 

H Displays the location of the file. 

I lick a column title to sort by category. 
 

Attaching referenced files 

To attach an externally referenced file 

1   Do one of the following to choose Explore External References (  ): 

• the ribbon, choose Tools > External References (in Explorer). 

• n the menu, choose Tools > 4MCAD Explorer > External References. 

• the Explorer toolbar, click the Explore External Reference tool. 

• exprefs and then press Enter. 
 

2 Do one of the following:  

 • Choose Edit > New > External Reference. 

• On the 4MCAD Explorer toolbar, click the New Item tool ( 

 

). 

3 In Files of type, select the type of file to attach, then click Open.  

4 Specify the insertion point for the file and complete the additional prompts. 

5 To complete the command and return to your drawing, close the window. 
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Modifying the settings for referenced files 
Any referenced file can be modified from the 4MCAD Explorer, including renam- 

ing, linking to a new location, clipping, and more. 
 

To change the name of a referenced file in the current drawing 

1   Do one of the following to choose Explore External References (  ): 

•  On the ribbon, choose Tools > External References (in Explorer). 

•  On the menu, choose Tools > 4MCAD Explorer > Explore External 

References. 

•  On the Explorer toolbar, click the Explore External Reference tool. 

•  Type exprefs and then press Enter. 

2   Do one of the following: 

•  Select the file, choose Edit > Rename, type a new name, and then press Enter. 

•  Click the file name you want to change, type a new name, and then press Enter. 

•  Right-click the file name you want to change, and from the shortcut menu, select 

Rename, type a new name, and then press Enter. 

3   To complete the command and return to your drawing, close the window. 
 

To change the name of a referenced file in the current drawing 

1 Do one of the following to choose Explore External References (  ): 

• On the ribbon, choose Tools > External References (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore External 

References. 

• On the Explorer toolbar, click the Explore External Reference tool. 

• Type exprefs and then press Enter. 

2 Do one of the following: 

• Select the file, choose Edit > Rename, type a new name, and then press Enter. 

• Click the file name you want to change, type a new name, and then press Enter. 

• Right-click the file name you want to change, and from the shortcut menu, select 

Rename, type a new name, and then press Enter. 

3 To complete the command and return to your drawing, close the window. 
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To manage an externally referenced file 

1 Do one of the following to choose Explore External References (  ): 

• On the ribbon, choose Tools > External References (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore External 

References. 

• On the Explorer toolbar, click the Explore External Reference tool. 

• Type exprefs and then press Enter. 

2 Do one of the following: 

• Select a file in the list, choose Edit, then the desired option. 

• Right-click the desired file, and from the shortcut menu, select the desired 

option. 

• Click either the Image Manager tool (  ) or the Xref Manager tool (  ). 

3 To complete the command and return to your drawing, close the window. 
 

For more details about working with external references, see “Working with external 

references” on page 490. 

 
 

 

Working with dimension styles 
 

From 4MCAD Explorer, you can use the Dimension Styles element to cut, copy, 

and paste dimension styles from one drawing to another. 

A dimension style contains the settings that control the appearance of a dimension. 

Although you cannot control these settings from within the 4MCAD Explorer, you 

can use the Dimension Styles dialog box to control settings related to the appearance 

of arrows, lines, text, units, and other formatting characteristics. 

 

Displaying dimension style information in 4MCAD 
Explorer 

To display the 4MCAD Explorer Dimension Styles element 

Do one of the following to choose Explore Dimension Styles (  ): 

• On the ribbon, choose Tools > Dimension Styles (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Dimension Styles. 

• On the Explorer toolbar, click the Dimension Styles tool. 

• Type setdim and then press Enter. 
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A To display the dimension styles settings, select Dimension 
Styles. 

B Lists the names of dimension styles defined in the current 
drawing. 

 

C Click to edit the corresponding dimension style. 

D Click a column title to sort by category. 

 

Creating and naming dimension styles 

By using the Dimension Styles element in combination with the Dimension Styles 

dialog box, you can create new dimension styles, modify them, and copy them into a 

different drawing. 
 

To create a dimension style 

1 Do one of the following to choose Explore Dimension Styles (  ): 

• On the ribbon, choose Tools > Dimension Styles (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Dimension Styles. 

• On the Explorer toolbar, click the Explore Dimension Styles tool. 

• Type expdimstyles and then press Enter. 

2 In the Dimension Styles Manager dialog box, click New. 

3 Type the name of the new dimension style. 

4 Click the Edit icon for the new dimension style. 

5 In the Modify Dimension Styles dialog box, select the desired options. 

6 Click OK. 
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To change a dimension style name in the current drawing 

1 Do one of the following to choose Explore Dimension Styles (  ): 

• On the ribbon, choose Tools > Dimension Styles (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Dimension Styles. 

• On the Explorer toolbar, click the Explore Dimension Styles tool. 

• Type expdimstyles and then press Enter. 

2 Do one of the following: 

• Select the dimension style, choose Edit > Rename, type a new name, and then 

press Enter. 

• Click the dimension style name you want to change, type a new name, and then 

press Enter. 

• Right-click the dimension style name you want to change, and from the shortcut 

menu, select Rename, type a new name, and then press Enter. 

3 To complete the command and return to your drawing, close the window. 

 

Copying dimension styles 
You can copy and paste dimension styles between drawings. In addition to the steps 

below, you can also select a dimension style and use the Windows shortcut keys 

(Ctrl+A to select all, Ctrl+X to cut, Ctrl+C to copy, Ctrl+V to paste) to copy it in 

4MCAD Explorer. You can use these shortcut keys with all other 4MCAD Explorer 

elements as well. 
 

To copy a dimension style from one drawing to another 

1 Do one of the following to choose Explore Dimension Styles (  ): 

• On the ribbon, choose Tools > Dimension Styles (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Dimension Styles. 

• On the Explorer toolbar, click the Explore Dimension Styles tool. 

• Type expdimstyles and then press Enter. 

2 Right-click the dimension style name you want to copy. 

3 From the shortcut menu, select Copy. 

4 In the left pane, select the drawing to which you want to copy the dimension style. 

5 Click the Dimension Styles element for that drawing. 

6 In the right pane, right-click, and then from the shortcut menu, select Paste. 
 

 

Each drawing contains a dimension style named Standard. 

You cannot delete this dimension style, but you can rename it from within the 

4MCAD Explorer or modify its properties in the Dimension Styles dialog box. 
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Working with groups 
 

In 4MCAD Explorer, you can manage groups — collections of entities saved 

together as one unit — that exist in an open drawing, create new groups, manage the 

entities contained in a group, and change the settings of groups. 

 

Displaying information about groups in 4MCAD 
Explorer 

To display groups in 4MCAD Explorer 

1   Do one of the following to choose Explore Groups (  ): 

• On the ribbon, choose Tools > Groups (in Explorer). 

• On the menu, choose Tools > 4MCAD Explorer > Explore Groups. 

• On the Format toolbar, click the Explore Groups tool. 

• Type expgroups and then press Enter. 

 

Creating a new group using 4MCAD Explorer 

To create a new group using 4MCAD Explorer 

1 Do one of the following: 

• Choose Edit > New > Group. 

• On the 4MCAD Explorer toolbar, click the New Item tool ( ). A 

new group is added as Anonymous. 

2 Type the name for the new group by typing over the highlighted default text, and 

then press Enter. 

3 Click the [+] tool to select the entities to be included in the group; click the [-] tool 

to select the entities to remove from the group. 

You can also click the Number of Entities column and choose Add Entities or 

Remove Entities. 

4 Press Enter when done selecting entities. 

5 To complete the command, close the window. 
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Modifying groups 

To modify a group using 4MCAD Explorer 

1 In Explorer, select Groups. 

2 To rename a group, do one of the following: 

• Select the group, choose Edit > Rename, type a new name, and then press Enter. 

• Click the group name you want to change, type a new name, and then press 

Enter. 

• Right-click the group name you want to change, and from the shortcut menu, 

select Rename, type a new name, and then press Enter. 

3 To add entities to a group, select the group and click the [+] tool, select the entities 

in the drawing to be included in the group, then press Enter when done selecting 

entities. 

4 To remove entities from a group, select the group and click the [-] tool, select the 

entities in the drawing to remove from the group, then press Enter when done 

selecting entities. 

5 To make a group selectable or unselectable in the drawing, click Selectable for it. 

6 To reorder the entities in a group, select the group and click the Reorder tool, 

make you selections, then click OK. 

7 To select a group in the drawing and have that group highlighted in the list of 

groups, click the Highlight tool, select the desired group, then press Enter. The 

appropriate group will be highlighted in the list. 

8 To complete the command, close the window. 
 

For more details about working with groups, see “Grouping entities” on page 384. 



 

 
 

 
 

 

 

 

Getting drawing information 
 

4MCAD stores accurate, detailed information about all the entities in a drawing. You 

can get details about an existing drawing and its entities using the tools for mea- 

suring distances and calculating areas. You can also track the amount of time you 

spend editing a drawing. This section explains how to: 

• Measure distances along an entity. 

• Measure distances and angles. 

• Divide an entity into a number of equal segments. 

• Calculate areas. 

• Display information about entities in a drawing. 

• Track the amount of time spent editing a drawing. 

Many of the functions described in this section require that you set 4MCAD to the 

advanced experience level. 

 
 
 
 
 
 
 
 

 
 
 
 
 
 
 

9 
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Specifying measurements and divisions 
 

You can divide a line, arc, circle, polyline, ellipse, or spline into a number of equal 

segments or mark off intervals of a specific length along an entity. (Note that divide is 

not the same as break.) For example, you may want to place station-point markers 

every 50 feet along the centerline of a roadway or divide the plan view of a window 

into three equal-width sections of glass, placing a mullion at each division point. 

 

Understanding measurements and divisions 
To specify measurements and divisions, use these commands: 

• For the length of the segments, use the Measure command. 

• For the number of equal-length segments, use the Divide command. 

You can measure or divide arcs, circles, lines, polylines, ellipses, and splines. With 

either command, you can identify the segments by placing either a block or point 

entity at the end of each interval. If you use points, you can snap to the ends of inter- 

vals using the point entity snap. The appearance of the point entities is determined by 

the current point display type, which you control in the Drawing Settings dialog box. 

To use a block as the marker, the block must already be defined in the current draw- 

ing. You can further indicate whether to rotate the block to align perpendicularly to 

the entity you are measuring or dividing. 

 
 

 
Block not aligned with entity. Block aligned with entity. 

4MCAD begins measuring or dividing based on the point at which you select the 

entity and the type of entity with which you are working. For most entities, measuring 

starts from the endpoint closest to the point you used to select the entity. If you select 

the entity to be measured or divided using a method other than pointing (for example, 

using a window or fence selection), the program prompts you to specify the end from 

which you want to begin measuring. 
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Measuring intervals on entities 
You can mark specified length increments along a selected entity using either a point 

entity or a block. 
 

To measure intervals along an entity and mark them using point entities 

Advanced experience level 

1 Do one of the following to choose Measure (  ): 

• On the ribbon, choose Edit > Measure (in Modify). 

• On the menu, choose Modify > Measure. 

• On the Modify toolbar, click the Measure tool. 

• Type measure and then press Enter. 

2 Select the entity. 

3 Specify the segment length, and then press Enter. 

 
 

 
When you select the entity by pointing, intervals are measured from the end 
closest to the point at which you select the entity (A). Blocks or point entities (B) 
are placed along the entity at the specified interval. 

To measure intervals along an entity and mark them using blocks 

Advanced experience level 

1 Do one of the following to choose Measure (  ): 

• On the ribbon, choose Edit > Measure (in Modify). 

• On the menu, choose Modify > Measure. 

• On the Modify toolbar, click the Measure tool. 

• Type measure and then press Enter. 

2 Select the entity. 

3 In the prompt box, choose Insert Blocks. 

4 Type the name of the block you want to insert as the marker. 

5 In the prompt box, choose either Yes-Align Blocks to rotate each insertion of the 

block so that its vertical alignment is always perpendicular to the entity or No-Do 

Not Align to insert each copy of the block with a zero rotation angle. 

6 Specify the segment length, and then press Enter. 

 

A B 
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Dividing entities into segments 
You can place markers along a selected entity, dividing that entity into a specified 

number of equal-length segments. You can use either a point entity or a block to mark 

the segments. 
 

To divide an entity into segments and mark them using point entities 

Advanced experience level 

1 Do one of the following to choose Divide (  ): 

• On the ribbon, choose Edit > Measure (in Modify). 

• On the menu, choose Modify > Divide. 

• On the Modify toolbar, click the Divide tool. 

• Type divide and then press Enter. 

2 Select the entity. 

3 Specify the number of segments, and then press Enter. 

 
 

 
When you select the entity by pointing, divisions are marked beginning from the end closest to the 
point at which you select the entity (A). Blocks or point entities (B) are placed along the entity to 
mark it in equal intervals. 

To divide an entity into segments and mark them using blocks 

Advanced experience level 

1 Do one of the following to choose Measure (  ): 

• On the ribbon, choose Edit > Measure (in Modify). 

• On the menu, choose Modify > Divide. 

• On the Modify toolbar, click the Divide tool. 

• Type divide and then press Enter. 

2 Select the entity. 

3 In the prompt box, choose Insert Blocks. 

4 Type the name of the block you want to insert as the marker. 

5 In the prompt box, choose either Yes-Align Blocks to rotate each insertion of the 

block so that its vertical alignment is always perpendicular to the entity or 

No-Do Not Align to insert each copy of the block with a zero rotation angle. 

6 Specify the number of segments, and then press Enter. 

 

A 
 
 

B 
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Calculating areas 
 

You can calculate the area and perimeter of a polygon based on a series of points you 

specify or enclose with a circle or closed polyline. You can also determine the area of 

several combined entities and add or subtract the area of one or more entities from a 

total combined area. 

 

Calculating areas defined by points 
You can find the area and perimeter of any closed region by specifying a series of 

points. The program calculates the area and perimeter of the space that is enclosed by 

an imaginary polygon consisting of straight-line segments connecting each point. 
 

To calculate the area defined by points you specify 

1 Do one of the following to choose Area (  ): 

• On the ribbon, choose Tools > Area (in Inquiry). 

• On the menu, choose Tools > Inquiry > Area. 

• On the Inquiry toolbar, click the Area tool. 

• Type area and then press Enter. 

2 Specify the first point. 

3 Specify the second point. 

4 Continue specifying points in sequence to define the perimeter of the area you 

want to measure. 

As you select each successive point, the resulting polygon is displayed on the 

screen. 

5 To complete the calculation, press Enter. 

The area and perimeter of the region you defined are displayed. For example, the 

following type of information is displayed: 

Area = 11.0583, Perimeter = 15.3092 

 
 

 
Select the points (A, B, C) that form a polygon. The area and 
perimeter of the region are then calculated. 

C 
 
 

B 
A 
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Calculating areas of closed entities 
You can find the area of any closed entity. In addition, the program calculates either the 

circumference or the perimeter of the entity, depending on the type of entity you select. 
 

To calculate the area of a closed entity 

1 Do one of the following to choose Area (  ): 

• On the ribbon, choose Tools > Area (in Inquiry). 

• On the menu, choose Tools > Inquiry > Area. 

• On the Inquiry toolbar, click the Area tool. 

• Type area and then press Enter. 

2 In the prompt box, choose Find Area Of One Entity. 

3 Select the entity. 

The following type of information is displayed: 
 

Area = 62.3837, Circumference = 27.9989 

 

Calculating combined areas 
You can find the total area of several combined regions by specifying points or by 

selecting entities. You can also subtract the areas of entities or polygons from a 

running total. 
 

To add areas to calculate a combined area 

1 Do one of the following to choose Area (  ): 

• On the ribbon, choose Tools > Area (in Inquiry). 

• On the menu, choose Tools > Inquiry > Area. 

• On the Inquiry toolbar, click the Area tool. 

• Type area and then press Enter. 

2 In the prompt box, choose Add Areas Together. 

3 Using one of the following methods, identify the first area: 

• Specify points defining a polygon, and then in the prompt box, choose Done 

Specifying Area. 

• In the prompt box, choose Add Entities To Area, select the entities you want to 

add, and then press Enter to complete the calculations. 

4 To complete the command, choose Done in the prompt box. 
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To subtract areas when calculating a combined area 

1 Do one of the following to choose Area (  ): 

• On the ribbon, choose Tools > Area (in Inquiry). 

• On the menu, choose Tools > Inquiry > Area. 

• On the Inquiry toolbar, click the Area tool. 

• Type area and then press Enter. 

2 In the prompt box, choose Add Areas Together. 

3 Using one of the following methods, identify the first area: 

• Specify points defining a polygon, and then in the prompt box, choose Done 

Specifying Area. 

• In the prompt box, choose Add Entities To Area, select the entities you want to 

add, and then press Enter to complete the calculations. 

4 In the prompt box, choose Subtract Areas. 

5 Using one of the following methods, identify the area to be subtracted: 

• Specify points defining a polygon, and then in the prompt box, choose Done 

Specifying Area. 

• In the prompt box, choose Subtract Entities From Area, select the entities you 

want to subtract, and then press Enter to complete the calculations. 

6 To complete the command, choose Done in the prompt box. 

 
 

 
To calculate the area of the gasket using the Area command, first add 
the area of the entire gasket (A), and then subtract the areas of the two 
circles (B and C). 

 

B 
A 

 

 
C 
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Viewing calculated area details 
As you select entities, the program displays the calculations. If the command bar is 

displayed, the information appears there. If the command bar is not displayed, the 

program opens the Prompt History window and displays the calculations. The follow- 

ing type of information is an example of what is displayed: 

Entity • Add • Subtract • <First point>: Choose Add Areas Together Adding: 

Entity • Subtract • <First point>: Choose Add Entities to Area Adding area: 

<Select entities>: Select the first entity 

Area = 64.6259, Perimeter = 33.3049 Total 

length = 33.3049 

Total area = 64.6259 
 

Adding area: <Select entities>: press Enter 
 

Adding: Entity • Subtract • <First point>: Choose Subtract Areas 
 

Subtracting: Entity • Add • <First point>: Choose Subtract Entities from Area 

Subtracting area: <Select entities>: Select the first entity to subtract 
 

Area = 3.1597, Circumference = 6.3012 Total 

length = 27.0036 

Total area = 61.4662 
 

Subtracting area: <Select entities>: Select the second entity to subtract 
 

Area = 3.1597, Circumference = 6.3012 Total 

length = 20.7024 

Total area = 58.3066 
 

Subtracting area: <Select entities>: Press Enter 
 

Subtracting: Entity • Add • <First point>: Choose Done 
 

 

 

 

Calculating distances and angles 
 

You can calculate the distance between any two points you select to determine the 

following information: 

• The distance between the points, measured in drawing units. 

• Their angle in the xy plane. 

• Their angle measured from the xy plane. 

The change (delta) in the x, y, and z distances between the two points. 
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A 
F 

B D 

E 

 
Calculating the distance between two points and their 
angle 
When calculating the distance between points, it is often helpful to use entity snaps to 

specify precise points. 
 

To calculate the distance between two points and their angle 

1 Do one of the following to choose Distance ( ): 

• On the ribbon, choose Tools > Distance (in Inquiry). 

• On the menu, choose Tools > Inquiry > Distance. 

• On the Inquiry toolbar, click the Distance tool. 

• Type distance and then press Enter. 

2 Specify the first point. 

3 Specify the second point. 

 
 

 
Use the Distance command to calculate the distance (A) between two points (B 
and C), the angle in the xy plane (D), the angle from the xy plane, and the delta 
x (E), delta y (F), and delta z distances between the two points. 

 

Viewing calculated distance details 
As you select entities, the program displays the calculations. If the command bar is 

displayed, the information appears there. If the command bar is not displayed, the 

program opens the Prompt History window and displays the calculations. The follow- 

ing type of information is an example of what is displayed: 

Distance = 13.2850, Angle in XY Plane = 31º, Angle from XY Plane = 0º Delta X = 

11.3878, Delta Y = 6.8418, Delta Z = 0.0000 
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Displaying information about your drawing 
 

You can display a variety of information about a drawing and the entities it contains, 

including: 

• Information in the drawing database about selected entities. 

• The current drawing status. 

• The time spent working on the drawing. 

This information is displayed in the Prompt History window and in the command bar. 

 

Displaying information about entities 
You can display information about the selected entities. The information varies, 

depending on the type of entities you select. All of the listings display the following 

information: 

• Entity type. 

• Layer. 

• Color. 

• Linetype. 

• The location of the entity (its xyz-coordinates relative to the current user 

coordinate system [UCS]). 

• The current space (model space on the Model tab or paper space on a Layout tab). 

• The size of the entity (the information varies, depending on the entity type). 
 

To display information about an entity 

Advanced experience level 

1 Do one of the following to choose List Entity Info (  ): 

• On the ribbon, choose Tools > List Entity Info (in Inquiry). 

• On the menu, choose Tools > Inquiry > List Entity Info. 

• On the Inquiry toolbar, click the List Entity Info tool. 

• Type list and then press Enter. 

2 Select one or more entities. 

3 Press Enter. 

 
 

Use a shortcut. 

To return to the drawing window, press F2. 
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The following type of information is displayed: 

------ Circle --------------------------------------------------- 
 

Handle: 2C 
 

Current space: Model Layer: 

0 

Color: BYLAYER Linetype: 

CONTINUOUS Handle: 4C 

Current space: Model 
 

Center point: X= -5.8583 Y= 7.2752 Z= 0.0000 
 

Radius: 4.4562 
 

Circumference: 27.9989 

Area: 62.383y 

 

Displaying property information about external 
references and blocks 
You can display property information about a selected external reference or block. 

All of the listings display the following information: 

• Entity type 

• Name 

• Color 

• Layer 

• Linetype and linetype scale 

• Print style 

• Lineweight 

• Material 

• Transparency 

• Thickness 

To display property information about an external reference or block 

1 Do one of the following to choose List Xref/Block Properties (  ): 

• On the ribbon, choose Express Tools > List Xref/Block Properties (in Blocks). 

• On the menu, choose Express Tools > Blocks > List Xref/Block Properties. 

• Type xlist and then press Enter. 

2 Select an external reference or block. 

 

Displaying the drawing status 
You can display information about the current status of a drawing, including: 
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• Drawing name. 

• Limits. 

• Insertion base point. 

• Snap and grid settings. 

• Current layer, color, and linetype. 

• Current settings for various modes (fill, grid, orthogonal, snap, blips, and so on). 

To display the drawing status 

Advanced experience level 

Do one of the following to choose Drawing Status (  ): 

• On the ribbon, choose Application button > Drawing Utilities > Drawing Status or 

choose Tools > Drawing Status (in Inquiry). 

• On the menu, choose Tools > Inquiry > Drawing Status. 

• On the Inquiry toolbar, click the Drawing Status tool. 

• Type status and then press Enter. 
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The following type of information is displayed: 

Current drawing name: Site Plan 
 

Drawing limits are: X=0.0000 Y=0.0000 Z=0.0000 X=12.0000 

Y=9.0000 Z=0.0000 

Paper space limits are: X=0.0000 Y=0.0000 Z=0.0000 X=12.0000 Y=9.0000 

Z=0.0000 

Screen width (pixels): 971 Screen 

height (pixels): 569 

Insertion base is: X=0.0000 Y=0.0000 Z=0.0000 Snap 

resolution is: X=0.5000 Y=0.5000 Z=0.0000 Grid spacing 

is: X:0.5000 Y:0.5000 Z=0.0000 Current layer: 0 

Current color: BYLAYER Current 

linetype: BYLAYER Current 

elevation: 0.0000 

Current thickness: 0.0000 Fill: on 

Grid: off Ortho: 

off Snap: off 

Blips: off Drag: 

on 

Command echo: on 
 

Positive angle direction: Counterclockwise Angular units: 

Decimal degrees 

Dimension units: Decimal Pick 

box height: 3 Entities in 

drawing: 288 

 

Tracking time spent working on a drawing 
You can display information about the amount of time you have spent working on a 

drawing, including: 

• The date and time the drawing was created. 

• The date and time the drawing was most recently saved. 

• The total amount of time spent working on the drawing. 

• The time spent working on the drawing during the current editing session. 

You can turn the elapsed-time timer on and off or reset it to zero. 
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To display the timer information 

Advanced experience level 

1 Do one of the following to choose Time Variables ( ): 

• On the ribbon, choose Tools > Time Variables (in Inquiry). 

• On the menu, choose Tools > Inquiry > Time Variables. 

• On the Inquiry toolbar, click the Time Variables tool. 

• Type time and then press Enter. 

2 Select any of the prompt box options: 

• Choose Timer On to turn the elapsed timer on. 

• Choose Timer Off to turn the elapsed timer off. 

• Choose Display Timer to redisplay the timer information. 

• Choose Reset Timer to reset the elapsed timer to zero. 

3 In the prompt box, choose Cancel to exit the command. 
 

Each time you display the timer information, the following type of information is 

displayed: 

The current time is Fri Dec 19 09:58:43 1997 
 

Drawing was created on: Wed 17 Dec 1997 at 16:17:59.8090 Drawing was last 

updated on: Thur 18 Dec 1997 at 09:58:43.3040 Total editing time: 1 2: 

35:4.2345 

Elapsed timer (on): 0 1: 21:5.6324 



 

 
 

 
 

 

 

 

Modifying entities 
 

4MCAD provides many editing tools for modifying a drawing. You can easily move, 

rotate, or stretch drawing entities, or change their scale. When you want to remove an 

entity, you can delete it with a few clicks of the mouse. You can also make multiple 

copies of any entity and copy entities from one drawing to another. 

You can modify most entities using general-purpose editing commands. Some com- 

plex entities require special commands. This section explains how to: 

• Select entities using entity-selection methods and grips. 

• Change the properties of entities. 

• Rearrange entities by moving, rotating, or changing the display order. 

• Resize entities by stretching, scaling, extending, trimming, or editing their lengths. 

• Split and combine entities by breaking, joining, exploding, and grouping them. 

• Edit polylines. 

• Create chamfers and fillets. 

 

 
 

 

 

 

10 
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Selecting entities 
 

You can create a selection set that consists of one or more entities for modification. 

Use any of the following methods to create a selection set: 

• Choose a command or tool first, and then select entities. 

• Select entities first, and then choose a command or tool (most entities). 

• Select entities by pointing, and then use grips to modify them. 

 

Understanding when to select entities 
You can select entities before or after you choose a command. 

 

Selecting entities first 

When you select entities and then issue a command, the program immediately acts on 

the entities you’ve selected. In many cases, a command-specific prompt box provides 

additional options for that editing operation. If you want to modify the selection set at 

that point, right-click to display the prompt box with the selection options and choose 

the option you want. To redisplay the command-specific prompt box, right-click 

again. 

After you select one or more entities, you can choose an entity-modification com- 

mand, such as the Copy or Move command. You can also click the right mouse but- 

ton to display a shortcut menu containing the entity-modification commands 

appropriate for the selected entities, and then choose the command from the menu. 
 

Choosing a command first 

When you choose an entity-modification tool or command first, the program prompts 

you to select entities and displays a prompt box from which you can choose a selec- 

tion method. You can select individual entities or use other techniques such as selec- 

tion windows to select multiple entities. 

When you select entities, you add them to the selection set. After you select at least 

one entity, you can remove entities from the selection set. To finish adding entities to 

the selection set, press Enter. Most entity-modification commands then act on the 

entire selection set. 
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Understanding entity-selection methods 
When you choose a command that requires you to select entities (when you’re delet- 

ing or changing entity properties, for example), you can use any of the following 

selection methods by choosing them in the prompt box or entering them in the com- 

mand bar: 

 
Entity-selection methods 

 

 
Select all 
entities 

ALL Selects all entities in the current drawing. 

Add to set + or A Adds one or more entities to the selection set. 

Subtract from set - or R Removes one or more entities from the selection set. 

Previous selection  P Selects entities included in the previous selection set. 

Last entity in 
drawing 

L Selects the entity most recently added to the drawing. 

Window-Inside W Selects entities contained entirely within a rectangular 
selection window. 

Crossing window C Selects entities contained within or crossing the boundary of 
a rectangular selection window. 

Outside window O Selects entities falling completely outside a rectangular 
selection window. 

Window polygon WP Selects entities contained entirely within a polygon selection 
window. 

Crossing polygon CP Selects entities contained within or crossing the boundary of 
a polygon selection window. 

Outside polygon OP Selects entities falling completely outside a polygon selection 
window. 

Window circle WC Selects entities contained entirely within a circular selection 
window. 

Crossing circle CC Selects entities contained within or crossing the boundary of 
a circular selection window. 

Outside circle OC Selects entities falling completely outside a circular selection 
window. 

Point PO Selects any closed entities that surround the selected point. 

Fence F Selects entities crossing a line or line segments. 

Quick Select QSELECT Selects entities by type according to a specified value or 
range of values. 

Select by 
Properties 

PRO  Selects entities that match a particular set of properties—for 
example, all entities on a particular layer or drawn in a certain 
color. 

 

 

Selection method Command bar Description 
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You can also use a few selection methods automatically, without displaying the 

prompt box: 

• Click one or more entities to select them. 

• Click an entity to select it, then Ctrl + click to cycle through the entities below the 

cursor, selecting one at a time. 

• Click two opposite corners of a rectangular selection window. The direction in 

which you define the points of the rectangle (left-to-right or right-to-left) deter- 

mines which type of window you create. 

 

Selecting entities by clicking them 
You can click entities to select them. 

 

To select entities by clicking them 

1   Click an entity. 

 

Selecting entities by drawing a selection window 
You can draw a selection window to include the entities contained within the win- 

dow. 
 

To create a selection window from left to right 

1 Click to select a point in the drawing. 

2 Click to the right of the first point to select a second point in the drawing. 

 
 

 
Window-Inside by selecting the first (A) and second (B) 
points. 

To create a selection window from right to left 

1 Click to select a point in the drawing. 

Resulting selection. 

2 Click to the left of the first point to select a second point in the drawing. 

 

 
 

B 

A 
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Crossing Window by selecting the first (A) and second 
(B) points. 

Resulting selection. 

In addition to a rectangular window, you can define a selection window using other 

shapes such as a polygon or circle. 
 

To select entities using a polygon selection window 

1 Activate an entity-modification command. 

2 In the prompt box, choose Window Polygon. 

3 Specify the vertices of the polygon. 

4 To complete the selection polygon, press Enter. 

 
 

 
Window Polygon by specifying the vertices of the 
polygon (A, B, and C). 

 

Selecting entities using a 
fence 

Resulting selection.

A selection fence is a multisegmented line that selects entities it crosses. 
 

To select entities using a fence 

1 Activate an entity-modification command. 

2 In the prompt box, choose Fence. 

3 Specify the endpoints of the Fence segments. 

4 To complete the Fence, press Enter. 

 

A 
 
 
 
 

C 
 

 
B 

 
 
 

A 

B 
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Fence by specifying the endpoints of the fence segments 
(A, B, and C). 

 

Filtering entity selection 

Resulting selection. 

Filtering a selection is an efficient way to select a set of entities that have something 

in common. For example, you can select all entities with the same property such as 

color, all entities that are proxies, or all entities with the same value, block name, or 

type. You can even add or remove more filters to a set of entities to further customize 

the selection. 

 

Selecting entities by property 
4MCAD makes it easy to select entities according to their common properties, 

allowing you to modify large sets of entities quickly and efficiently. When selecting 

entities, simply use a filter to add or remove entities according to these common prop- 

erties: color, layer, linetype scale, linetype, lineweight, thickness, and width. 

 
 

Use the List command to get more information for filtering. 

If you are unsure what properties are available for filtering, type list to select an area 

of the drawing and list the selected entities and their properties. 
 

 

 
To select entities by property using a properties filter 

1 Activate an entity-modification command, or type select. 

2 Choose Filter. 

3 Choose a filter option: 

• Color — Enter the color of entities you want to select. 

• Layer — Enter the layer name of entities you want to select. 

• LinetypeScale — Enter the linetype scale of entities you want to select. 

• Linetype — Enter the linetype of entities you want to select. 

• Lineweight — Enter the lineweight of entities you want to select. 

• Thickness — Enter the thickness of entities you want to select. Note that some 

entities have thickness, however, lines, circles, arcs, and polylines all have 

thickness. 

• Width — Enter the width of entities you want to select. Note that only polylines 

have width. 



M O D I F Y I N G   E N T I T I E S 339 
 

 

 
 

Names of properties are case sensitive. 

For example, a drawing with layers SAMPLE Layer 1, sample Layer 2, and SAM- 

PLE Layer 3 will return no selection if you specify “SAMPLE” for the layer name. 

Specifying “SAMPLE*” returns two layers, “*Layer*” returns all layers, and 

“sample*” returns one layer. 
 

 

 

4 If desired, add or remove more entities using a filter: 

• Choose any other filter option to add more entities to the selection set. 

• Choose Remove to remove entities from the selection set according to the filter 

you choose next. 

A prompt displays the total number of entities in the selection set. 

5 To complete the selection, press Enter. 

 
 

 
Selection by specifying the smaller of two lineweight 
properties. 

 

Selecting proxy entities using a filter 

Resulting selection. 

Proxy entities are entities or custom objects that 4MCAD does not support. When a 

drawing containing proxy entities is loaded into 4MCAD, a message displays indi- 

cating that some entities will not display, however, the entities reappear when you 

open the drawing later in a CAD application that supports those entities. 

Proxy entities can be selected using typical selection methods, but they can also be 

selected using a filter, for example, you might want to select all proxies and place 

them on a hidden layer or delete them if you know they won’t be needed in the future. 
 

To select proxy entities using a filter 

1 Activate an entity-modification command, or type select. 

2 Choose Filter. 

3 Choose Proxy. 

4 If desired, add or remove more entities using a filter: 

• Choose any other filter option to add more entities to the selection set. 

• Choose Remove to remove entities from the selection set according to the filter 

you choose next. 
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A prompt displays the total number of entities in the selection set. 

5 To complete the selection, press Enter. 

 
Selecting blocks of the same name 
Some drawings contain many of the same blocks, which are easy to select as a set 

using a filter. 

 
 

Use the List command to get block names. 

If you are unsure what blocks are available for filtering, type list to select an area of 

the drawing and list the selected entities and their block names. 
 

 

 
To select entities by block name 

1 Activate an entity-modification command, or type select. 

2 Choose Filter. 

3 Choose Block. 

4 Enter the block name of the entities you want to select. 

5 If desired, add or remove more entities using a filter: 

• Choose any other filter option to add more entities to the selection set. 

• Choose Remove to remove entities from the selection set according to the filter 

you choose next. 

A prompt displays the total number of entities in the selection set. 

6 To complete the selection, press Enter. 

 
Selecting entities by type 
You can filter entities in a selection set according to their type, for example, a circle, 

line, text, attribute, or block type. 

 
 

Use the List command to get type names. 

If you are unsure what entity types are available for filtering, type list to select an 

area of the drawing and list the selected entities and their types. 
 

 

 
To select entities by type using the filter option 

1 Activate an entity-modification command, or type select. 

2 Choose Filter. 

3 Choose Type. 

4 Enter the type name (a string value) of the entities you want to select. 
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5 If desired, add or remove more entities using a filter: 

• Choose any other filter option to add more entities to the selection set. 

• Choose Remove to remove entities from the selection set according to the filter 

you choose next. 

A prompt displays the total number of entities in the selection set. 

6 To complete the selection, press Enter. 
 

 

Use the Selection pane and the Quick Select command to select entities by type. 

You can also type selfilter or qselect to select entities by type. 
 

 

 
Selecting entities by value 
You can filter entities in a selection set according to common properties and their val- 

ues. For example, you can filter a selection set to include all the entities that are the 

color red and use the Dashed2 linetype, and then change the value of the linetype. 
 

To select entities by value using the Selection Filter pane 

1 Do one of the following to choose Selection Filter (  ): 

• On the ribbon, choose View > Selection Filter (in Display). 

• On the menu, choose View > Display > Selection Filter. 

• Type selfilter and then press Enter. 

2 Click the Layer, Color, Entity Type, or Linetype tab. 

The Selection Filter pane lists all layers, colors, entity types, and linetypes that are 

available in the drawing. 

3 In the On column, select a corresponding cell to either include or exclude all enti- 

ties with the corresponding value. The clicked cell then displays blank (selection 

is off) or with a black circle (selection is on), depending on its status before click- 

ing it. 

This can affect the On status of other values on other tabs. The On column for all 

tabs indicates the following: 

• Blank — No entities with the corresponding value are selected in the drawing. 

• Black circle — All entities with the corresponding value are selected in the 

drawing. 

• Gray circle — Only some entities with the corresponding value are selected in 

the drawing (due to specified values on other tabs or your entity selections in the 

drawing). 
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A Click to deselect all entities in the drawing. 

B Click to view and select entities in the drawing 
according to their assigned layer. 

C Displays all layers, colors, entity types, or 
linetypes that are available in the drawing 
depending on the selected tab. 

D Click to change the selection to include or 
exclude all entities with the corresponding 
value. 

E Click to view and select entities in the drawing 
according to their assigned linetype. 

F Click to view and select entities in the drawing 
according to their entity type. 

G Click to view and select entities in the drawing 
according to their color. 

To select entities by value using Quick Select 

1 Do one of the following to choose Quick Select (  ): 

• On the ribbon, choose Home > Quick Select (in Utilities). 

• On the menu, choose Tools > Quick Select. 

• On the Properties pane or Save Block to Disk dialog box, click the Quick Select 

tool. 

• Type qselect. 

2 In Apply To, specify which entities to consider for selection. For example, select 

Entire Drawing to consider all entities in the drawing. To specify a portion of the 

A 

 
B 

G 

F 

E 

C D 
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drawing to consider for selection, click (  ) and make your selection directly in 
the drawing. 

3 In Entity Type, specify the type of entity you want to select. 

4 Specify the property to filter for selection, its operator, and value. The options 

vary by entity type. 

5 Select one of the following: 

• Include in New Selection Set Creates a new selection that includes only those 

entities that meet the selected options. 

• Exclude from New Selection Set Creates a new selection set that includes all of 

the entities except those that meet the selected options. 

6 To add the newly selected entities to a current selection set (available if entities 

were selected before using the Quick Select command), mark Append to Current 

Selection Set. 

7 Click OK. 

 

 

 

A H 

B 

 
 

 
C 

 
 
 

D 

E 

 

F 

G 

 
A Choose which entities to consider for 

selection. 

B Choose the type of entity to select. 

C Choose the desired property. 

D Choose how to compare the value and 
property. 

E Choose the desired value. 

F Choose whether to include or exclude 
selected entities in the new selection set. 

G Select to add the newly selected entities to a 
previously specified selection set (if available). 

H Click to specify a portion of the drawing to 
consider for selection. The option Current 
Selection will appear in Apply To. 
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To select entities by value using the filter option 

1 Activate an entity-modification command, or type select. 

2 Choose Filter. 

3 Choose Value. 

4 Enter the value (a string) of the entities you want to select. 

5 If desired, add or remove more entities using a filter: 

• Choose any other filter option to add more entities to the selection set. 

• Choose Remove to remove entities from the selection set according to the filter 

you choose next. 

A prompt displays the total number of entities in the selection set. 

6 To complete the selection, press Enter. 
 

 

Use the List command to get values. 

If you are unsure what values are available for filtering, type list to select an area of 

the drawing and list the selected entities and their values. 
 

 

 
Selecting entities that match the properties of other entities 
You can select all entities in a drawing that have the same color, layer, linetype, line- 

type scale, lineweight, print style, entity style, name, entity type, or any combination 

of these properties. First you select one or more entities that have the properties you 

want to match, then you specify which properties to search for and match. The 

matched entities are then added to the selection set. 

The selection set can be reused in other commands either through the pick-first selec- 

tion or by selecting the previous selection. 
 

To select entities that match one or more properties of other entities 

1 Do one of the following to choose Select Similar (  ): 

• On the ribbon, choose Express Tools > Select Similar (in Tools). 

• On the menu, choose Express Tools > Tools > Select Similar. 

• Type selectsimilar and then press Enter. 

2 Select one or more entities that have the properties you want to match. 

3 Choose Settings. 

4 In the Select Similar Settings dialog box, mark the properties of the selected enti- 

ties that you want to match. 
 

 

The SELECTSIMILARMODE system variable also controls the dialog box settings. 

See the System Variables online help for details about using this system variable. 
 

 

 

5 Click OK. 

Entities with matched properties are added to the selection set. 
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Creating filters used to select entities 
Creating a filter that you can reuse is helpful if you regularly filter entities using the 

same parameters. Reusable filters are as easy to create even for complicated selection 

sets. 
 

To create a filter used to select entities 

1 Type filter. 

2 In Select Filter, select an item for the filter list. For example, choose Line to 

include line entities in the selection set. 

3 Specify the item’s parameters if necessary. For example, if you chose Linetype, 

click Select to choose the linetype; if you chose Line End, enter the x-, y-, and z- 

coordinates. 

4 Click Add to List. 

5 Repeat for additional filter items, and include operators as necessary: 

• AND — Add BEGIN AND before one or more items to add them; add BEGIN 

END after the items. 

• OR — Add BEGIN OR before one or more items to compare them and include 

only one; add BEGIN OR after the items. 

• XOR — Add BEGIN XOR before multiple items to specify exclusions; add 

BEGIN XOR after the items. 

• NOT — Add BEGIN NOT before one item to specify an exclusion; add BEGIN 

NOT after the item. 

6 In Save As, enter a filter name. 

7 Click Save As. 
 

To select entities using a filter you created 

1 Type filter. 

2 In Current, select the desired filter. 

3 Click Apply. 
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A Lists the parameters that define the filter. 

B Select an item to include in the filter. 

C Enter the x-, y-, and z-coordinates if applicable 
to the filter item. 

D Click to add the specified item to the filter. 

E Click to add the currently selected entity in the 
drawing to the filter. 

F Click to replace the currently selected line in 
the filter list with the currently specified item. 

G Click to specify a value for the selected filter 
item. 

 

H Click to delete the named filter that is selected 
in Current. 

I Click to save the filter. 

J Enter a name for the filter. 

K Select a previously saved filter to load it. 

L Click to edit the settings of the currently 
selected line in the filter. 

M Click to remove all line items from the filter. 

N Click to remove the currently selected line item 
from the filter. 
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Deselecting entities 
If an entity is no longer needed in a selection set, you can deselect it to remove it from 

the selection set. 
 

To remove an entity from the selection set 

1   Press Shift, and then select the entity again. 
 

 

Use a shortcut. 

Pressing Shift while selecting entities using a crossing window removes all entities 

from the specified selection set. 
 

 

 
To remove all entities from the selection set 

1   Press Escape. 

 

Using grips 
To use grips for editing, you select an entity to display the grips, and then click a grip 

to make it active. You do not need to enter a command when using grips. 

There are two types of grips: 

• Entity grips — Grips that display for each selected entity and allow you to quickly 

move and scale entities one-by-one. 

• Selection grips — Grips that display for an entire selection set and allow you to 

quickly move, scale, and rotate all selected entities. These types of grips can be 

helpful for schematic drawings where precise scale or sizing is not required. 

 
Turning grips on and off 
You can turn the use of grips on and off and control the size and color of grips. 

 

To change grip settings 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type ddgrips and then press Enter. 

2 In the Drawing Settings dialog box, click the Display tab. 

3 Click the Grips tab and choose from these options: 

• Enable entity grips — Click to activate separate grips for each entity you select. 

• Enable selection grips — Click to activate one set of grips for all entities in a 

selection set. 
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• Grip size — Specify the grip size. 

• Grip color — Click to assign the color for grips. 

4 Click OK. 

 
Using entity grips for editing 
You can select entities first and then choose how to modify them. As you select each 

entity, it is highlighted with small squares called grips, which appear at strategic 

points on the entity. 

The entity grip you select depends on the type of grips that are active, the type of 

entity you’re modifying, and the editing operation you’re performing. For example, 

to move a line entity with entity grips active, drag it by its midpoint grip. To stretch 

the line, drag one of the endpoint grips. With selection grips active, however, you 

move a line entity by repositioning the base point grip. 

The locations of entity grips depend on the type of entity selected. For example, grips 

appear at the endpoints and midpoint of a line, at the quadrant points and center point 

of a circle, and at the endpoints, midpoint, and center of an arc. 

Arrow grips are different from square grips. For example, the arrow grips on a line 

allow you to change the line length but at the same angle. Square grips at the end of 

lines allow you to change the endpoints, that is, the length and the angle. 

 
 

 
Examples of entity grip locations. 

To edit using entity grips 

1 Make sure entity grips are turned on. For details, see “Turning grips on and off” on 

page 347. 

2 Click an entity to select it and display grips. 

3 Click a grip to make it active. 

4 Do any of the following: 

• Drag the grip to move it. 

• Choose a command, such as Copy or Move. 

• Press the Spacebar to cycle through available commands, such as Copy, Move, 

Rotate, and more, depending on the entity and the selected grip. 
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Using selection grips for editing 
With selection grips you can quickly move, scale and rotate all selected entities. 

Selection grips are particularly useful for schematic drawings where precise scale or 

sizing is not required. In addition, this standard interface for manipulating images and 

objects in Windows applications, can be helpful to users who may not be familiar 

with precision CAD editing interfaces. 

Selection grips are similar to entity grips, but they display as a single set of grips for 

all entities in the selection set. When single blocks are selected, additional grips 

appear for non-uniform scaling for all three axis. 

The locations of entity grips are uniform for the selection set. Grips at the corners of 

the selection set are for scaling, the bottom center grip is for moving, the top grip is 

for rotating, and the center grip is for positioning the rotation orientation. 

 
 

 
Examples of selection grip locations. The rotation grip is located at the top and the move grip is located 
bottom center. 

To edit using selection grips 

1 Make sure entity grips are turned on. For details, see “Turning grips on and off” on 

page 347. 

2 Click an entity to select it and display selection grips. If you select more than one 

entity, a single set of selection grips displays for the entire selection set. 

3 Click a grip to make it active. 

4 Drag the grip to move it. 
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Displaying selected entities highlighted 
You can specify whether to display selected entities highlighted, which makes the 

selection set easier to see. By default, the highlighting feature is turned on. 
 

To turn the highlighting feature on or off 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the Display tab. 

3 Click the secondary Display tab. 

4 Select or clear the Highlight Item When Selected check box. 

5 Click OK. 
 
 

 

Modifying the properties of entities 
 

You can change the layer, thickness, linetype, color, and linetype scale of one or 

more entities. Depending on the type of entity or entities you select, you can also 

change other properties, such as the start point and endpoint of lines, the center point 

and radius of circles, and the vertices of polylines. 

 

Modifying entity properties 

To modify properties of entities 

1 Do one of the following to choose Properties (  ): 

• On the ribbon, choose View > Properties (in Display). 

• On the menu, choose Modify > Properties. 

• On the Modify toolbar, click the Properties tool. 

• Type entprop and then press Enter. 

• Press Ctrl +1. 

The Properties pane displays. 

2 Select the desired entities. 

3 Make changes to the properties. 
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The 4MCAD Entity Properties pane (varies for each entity). 

 
 

You can also use the Entity Properties toolbar. 

Click a tool on the Entity Properties toolbar to change the properties of selected enti- 

ties. Note that the Entity Properties toolbar settings that display when no entities are 

selected determine the properties of new entities when you draw them. 
 

 

 

Modifying the properties of multiple entities 
You can modify all the properties of all selected entities simultaneously. For exam- 

ple, using the entprop command, select all entities on a particular layer, and then 

move the entities to another layer by simply selecting a name from the Layer text box. 

Additionally, using the select command and the Select by Properties option, select all 

blue entities and change their color to green. 

In the Properties pane, changes that you make in the Layer, Color, Thickness, Line- 

weight, Linetype, Linetype Scale, and Print Style (if using named print style tables) 

fields affect all selected entities. To change the properties of a single entity in the 

selection set, choose the entity from the list at the top of the Properties pane. 

You can select the entities to be changed using any entity-selection method. 
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Changing multiple properties to ByLayer 
The Set to ByLayer command sets properties of selected entities to ByLayer. Proper- 

ties that can be changed using the Set to ByLayer command include: color, linetype, 

lineweight, material, print style, and transparency. 
 

To modify properties of entities 

1 Do one of the following to choose Set to ByLayer (  ): 

• On the ribbon, choose Home > Set to ByLayer (in Layers). 

• On the menu, choose Format > Layer Tools > Set to ByLayer. 

• On the Layer Tools toolbar, click the Set to ByLayer tool. 

• Type setbylayer and then press Enter. 

2 Press Enter. 

3 In the SetByLayer Settings dialog box, make your selections for the properties you 

want to change: 

• Color — Resulting entities will have a Color property set to ByLayer. 

• Linetype — Resulting entities will have a Linetype property set to ByLayer. 

• Lineweight — Resulting entities will have a Lineweight property set to 

ByLayer. 

• Material — Resulting entities will have a Material property set to ByLayer. 

• Print Style — Resulting entities will have a Print Style property set to ByLayer. 

• Transparency — Resulting entities will have a Transparency property set to 

ByLayer. 

4 Click OK. 

5 At the prompt, select the desired entities. 

6 Choose Yes to change any found ByBlock properties to ByLayer. Otherwise, 

choose No. 

7 Choose Yes to change the properties of blocks that are selected. Blocks must be on 

unlocked layers. Otherwise, choose No. 
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Deleting entities 
 

You can remove entities from a drawing. You can delete entities using any of the 

entity-selection methods. 
 

To delete a selection set 

1 Do one of the following to choose Delete ( ): 

• On the ribbon, choose Home > Delete (in Modify) or choose Edit > Delete (in 

Modify). 

• On the menu, choose Edit > Delete. 

• On the Standard toolbar, click the Delete tool. 

• Type delete and then press Enter. 

2 Select the entities, and then press Enter. 

 
 

Typing the Undelete command restores the most recently deleted selection set. 

If you have made additional modifications since deleting the entities, use Undelete 

rather than Undo to restore those entities without reversing those modifications. 
 

 

 
 

The Overkill command deletes extra entities all at once. 

If a drawing has overlapping or duplicate entities that you want to delete or combine, 

for example polylines with too many vertices, use the Overkill command to clean up 

the drawing. 
 

 

 

 
 

Copying entities 
 

You can copy one or more entities, making one copy or multiple copies within the 

current drawing. You can also copy entities between drawings. 

Use any of the following methods to copy entities within the current drawing: 

• Create a copy at a location referenced from the original. 

• Create a copy aligned parallel to the original. 

• Create a copy as a mirror image of the original. 

• Create several copies in a rectangular or circular pattern. 
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Copying entities within a drawing 
You can duplicate entities within the current drawing. The default method is to create 

a selection set and then specify a starting point, or base point, and an endpoint, or dis- 

placement point, for the copy. You can also make multiple copies or copy the selec- 

tion set to a location you specify, using a direction vector. You can also create an 

array of copied entities; for more details, see “Arraying entities” on page 360 in this 

chapter. 

In addition to copying regular entities in a drawing, you can also copy entities that are 

contained within blocks, external references, and underlays. 
 

To copy a selection set 

1 Do one of the following to choose Copy (  ): 

• On the ribbon, choose Edit > Copy (in Modify). 

• On the menu, choose Modify > Copy. 

• On the Modify toolbar, click the Copy tool. 

• Type copy and then press Enter. 

2 Select the entities, and then press Enter. 

3 Specify the base point. 

4 Specify the insertion point. 

5 Continue specifying insertion points to place additional copies. 

6 To complete the command, press Enter. 

 
 

 
To make a single copy of an entity, select the 
entity to copy (A), base point (B), and then 
displacement point (C). 

Result. 

C 
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To make multiple copies of an entity, select the 
entity to copy (A), specify the base point (B), and 
then specify the displacement points (C, D, and 
E). 

Result. 

 
 

Use a shortcut. 

Press and hold Ctrl, then click and drag the left mouse button to copy an entity. 
 

 

 
 

Use a system variable. 

The COPYMODE system variable controls whether you are prompted for multiple 

copies. 
 

 

 
 

Use the Move/Copy/Rotate command. 

You can move, copy, rotate, and scale selected entities using a single command. 

Choose the Move/Copy/Rotate express tool or type mocoro. 
 

 

 
To copy nested entities within blocks, external references, or underlays 

1 Do one of the following to choose Copy Nested Entities ( ): 

• On the ribbon, choose Express Tools > Copy Nested Entities (in Blocks). 

• On the menu, choose Express Tools > Blocks > Copy Nested Entities. 

• Type ncopy and then press Enter. 

2 Select the entities nested within blocks, external references, or underlays, and then 

press Enter. 

3 Specify the base point. 

4 Specify the insertion point. 

5 Continue specifying insertion points to place additional copies. 

6 To complete the command, press Enter. 



356 C H A P T E R   1 0  
 

 
Copying between drawings 
You can use the Clipboard to cut or copy entities from one drawing to another. 

Cutting removes the selected entities from a drawing and stores them on the 

Clipboard. Copying duplicates the selected entities from a drawing and places them 

on the Clipboard. 
 

To cut entities to the Clipboard 

1 Select the entities you want to cut. 

2 Do one of the following to choose Cut ( ): 

• On the ribbon, choose Edit > Cut (in Modify). 

• On the menu, choose Edit > Cut. 

• On the Standard toolbar, click the Cut tool. 

• Type cutclip and then press Enter. 

To copy entities to the Clipboard 

1 Select the entities you want to copy. 

2 Do one of the following to choose Copy to Clipboard (  ): 

• On the ribbon, choose Home > Copy to Clipboard (in Clipboard). 

• On the menu, choose Edit > Copy to Clipboard. 

• On the Standard toolbar, click the Copy to Clipboard tool. 

• Type copyclip and then press Enter. 

Anything that you can copy to the Clipboard can be pasted into a drawing. The format 

in which the program adds the Clipboard contents to the drawing depends on the type 

of information in the Clipboard. For example, if you copy 4MCAD drawing enti- ties 

to the Clipboard, the program pastes them into the drawing as 4MCAD enti- ties. If 

you copy items to the Clipboard from other programs, they are pasted into the current 

drawing as embedded ActiveX® objects. 

 
 

Sometimes the format you want to paste is not available on the Clipboard. 

This is mostly likely due to the settings on the Clipboard tab in Tools > Options. For 

details, see “Changing the options on the Selection Cycling tab” on page 712. 
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To paste entities from the Clipboard 

1 Do one of the following to choose Paste ( ): 

• On the ribbon, choose Home > Paste (in Clipboard) or choose Edit > Paste (in 

Modify). 

• On the menu, choose Edit > Paste. 

• On the Standard toolbar, click the Paste tool. 

• Type pasteclip and then press Enter. 

2 Specify the insertion point. 
 

 

Clipboard contents can also be inserted as a block. 

Type pasteblock to convert Clipboard contents into a block upon insertion. 
 

 

 

Copying between spaces 
You can copy entities from model space to paper space or from paper space to model 

space. You must be viewing a Layout tab that has at least one layout viewport in 

order to copy entities between spaces. You can also move entities between spaces 

using the same Change Space command. 

For more details about model space and paper space, see see “Understanding paper 

space and model space” on page 520. 
 

To copy entities between spaces 

1 Click a Layout tab. 

2 Select the entities you want to copy. 

3 Do one of the following to choose Change Space ( ): 

• On the ribbon, choose Edit > Change Space (in Modify). 

• On the menu, choose Modify > Change Space. 

• On the Modify toolbar, click the Change Space tool. 

• Type chspace and then press Enter. 

4 Choose Copy. 
 

 

If using the command bar, the Copy option can get confused with crossing selections.  

To use the Crossing selection method, type the full keyword “crossing”. Typing “c” 

calls the Copy option. 
 

 

 

Making parallel copies 
You can use the offset feature to copy selected entities and align them parallel to the 

original entities at a specified distance. You can make parallel, offset entities using 

arcs, circles, ellipses, elliptical arcs, lines, two-dimensional polylines, rays, and infi- 

nite lines. 
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B 

C 
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Making parallel, offset copies of curved entities creates larger or smaller curves, 

depending on which side of the original entity you place the copy. For example, plac- 

ing a parallel copy of a circle outside the circle creates a larger concentric circle; posi- 

tioning the copy inside the circle creates a smaller concentric circle. 
 

To make a parallel copy by specifying the distance 

1 Do one of the following to choose Offset (  ): 

• On the ribbon, choose Edit > Offset (in Modify). 

• On the menu, choose Modify > Basic Editing > Offset. 

• On the Modify toolbar, click the Offset tool. 

• Type offset and then press Enter. 

2 Specify the distance by selecting two points or by entering a distance. 

3 Select the entity to copy. 

4 Specify on which side of the entity to place the parallel copy. 

5 Select another entity to copy, or press Enter to complete the command. 

 
 

 
To make a parallel copy, specify the distance between copies 
by entering a distance or selecting two points (A and B), select 
the entity to copy (C), and specify on which side to place the 
copy (D). 

To make a parallel copy passing through a point 

1 Do one of the following to choose Offset (  ): 

• On the ribbon, choose Edit > Offset (in Modify). 

Result. 

• On the menu, choose Modify > Basic Editing > Offset. 

• On the Modify toolbar, click the Offset tool. 

• Type offset and then press Enter. 

2 In the prompt box, choose Through Point. 

3 Select the entity to copy. 

4 Specify the point for the entity to pass through. 

5 Repeat steps 3 and 4, or press Enter to complete the command. 

A 
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To make a parallel copy passing through a point, select the entity to copy (A) and then specify the through 
point (B). 

 

Mirroring entities 
You can create a mirror image of an entity. You mirror the entity about a mirror line, 

which you define by specifying two points in a drawing. You can delete or retain the 

original entities. 
 

To mirror entities 

1 Do one of the following to choose Mirror (  ): 

• On the ribbon, choose Edit > Offset (in Modify). 

• On the menu, choose Modify > Mirror. 

• On the Modify toolbar, click the Mirror tool. 

• Type mirror and then press Enter. 

2 Select the entity, and then press Enter. 

3 Specify the first point of the mirror line. 

4 Specify the second point of the mirror line. 

5 In the prompt box, choose one of the following: 

• Yes, Delete Entities – deletes the original entities. 

• No, Keep Entities – retains the original entities. 

 
 

 
To mirror an entity, select it (A), and then specify the 
first point (B) and second point (C) of the mirror line. 

Result. 

B 
 

 
A 
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Arraying entities 
You can copy an entity in a pattern that creates an array. There are three ways to cre- 

ate arrays: 

• Linear array — Use the Copy command to control the number of copies in the 

array and the line along which the copies are placed. 

• Rectangular array — Use the Array command to control the number of copies in 

the array by specifying the number of rows and columns. You also specify the dis- 

tance between each row and column. 

• Polar (circular) array — Use the Array command to control the number of cop- 

ies that compose the array and whether to rotate the copies. 
 

To create a linear array 

1 Do one of the following to choose Copy (  ): 

• On the ribbon, choose Edit > Copy (in Modify). 

• On the menu, choose Modify > Copy. 

• On the Modify toolbar, click the Copy tool. 

• Type copy and then press Enter. 

2 Select the entities, and then press Enter. 

3 Specify the start point of the line along which you want to place entities. 

4 Choose Array. 

5 Enter the number of items in the array, then press Enter. 

6 Specify the second point of the line along which you want to place entities; this is 

the point where the first entities in the array will be placed. Or if you choose Fit, it 

is the point where the last entities in the array will be placed. 

7 Continue specifying points to place additional copies if desired, or press Enter 

when done. 
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To create a polar array 

1   Do one of the following to choose Array ( ): 

• On the ribbon, Edit > Array (in Modify). 

• On the menu, choose Modify > Array. 

• On the Modify toolbar, click the Array tool. 

• Type array and then press Enter. 
 

2 Select the entities, and then press Enter.  

3 In the Array dialog box, choose Polar Array.  

4 Specify the center point of the array, or click ( 

drawing. 

) to select the center point in the 

5 Select the method, which determines the two variables that are used to create the 

array, then specify the two variables: 

• Total number of items — Enter the number of items to create in the array, 

including one for the original selection set. 

• Angle to fill — Enter the angle to fill: 0 to 360 degrees. The default setting for 

the angle is 360 degrees. Positive values create the array in a counterclockwise 

direction; negative values create the array in a clockwise direction. You can also 

click (  ) to select the angle in the drawing. 

• Angle between items — Enter the angle between lines. The default setting is 90 

degrees. You can also click ( ) to select the angle in the drawing. 

6 In Rotate Entities as Copied, mark the checkbox to rotate entities as they are 

arrayed or unmark it to retain the original orientation of each copy as it is arrayed. 

7 To specify a new base point for the array, do the following: 

• Click More. 

• Unmark Set to Entity’s Default. 

• In Base Point, enter a new entity base point to use for the array, or click ( ) 

to select the base point in the drawing. 

 
 

 
To create a polar array, select the entity to copy (A), specify the center point of the array (B), and then 
specify other options. 

A 

B 



362 C H A P T E R   1 0  
 

 

 

 
 

A Select Polar to create a circular array. 

B Click to specify the center point directly in the 
drawing. 

C Enter the X and Y coordinates for the center 
point around which you want the entities arrayed. 

D Select to create an array using a combination of 
two of the following: total number of items to 
array, angle the array will fill, and the angle 
between items. 

E Enter the number of items to create in the array. 

F Enter the angle the array will fill. 

G Enter the degree of the angle between the items 
arrayed. 

H Click to specify the angle between items directly 
in the drawing. 

I Click to specify the angle to fill directly in the 
drawing. 

J Select to automatically rotate items as they are 
arrayed. 

K Select to use the entity's default base point for 
the array. 

L Enter a new entity base point to use for the 
array. 

M Click to preview the array in the drawing (only 
available after entities are selected for the array). 

N Click to specify the base point directly in the 
drawing. 

O Click to display or hide more options. 

P Displays the number of entities that are selected 
in the drawing for the array. 

Q Click to switch temporarily to the drawing to 
select entities to include in the array. 

Q 
A 
B 
C P 

D 

E 

F 

G 

H 

 

I 
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K 
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To create a rectangular array 

1 Do one of the following to choose Array ( ): 

• On the ribbon, Edit > Array (in Modify). 

• On the menu, choose Modify > Array. 

• On the Modify toolbar, click the Array tool. 

• Type array and then press Enter. 

2 Select the entities, and then press Enter. 

3 In the Array dialog box, choose Rectangular Array. 

4 Enter the number of rows and the number of columns. 

A rectangular array must have at least two rows or two columns. 

5 In Row Offset, specify the distance between the rows. You can also click ( ) to 

specify the row and column offset at the same time in the drawing, or you can 

click (  ) to select only the row offset. 

6 In Column Offset, specify the distance between the columns. You can also click 

( ) to specify the row and column offset at the same time in the drawing, or you 

can click (  ) to select only the column offset. 

7 In Angle of Array, enter the angle at which to rotate the array, or click (  ) to 

select the angle directly in the drawing. 

 

 
To create a rectangular array, select the entity to copy (A), type the number of rows and columns, and then 
specify the distance between each row (B) and column (C). 

 

C 
 

 
B 

 

 
A 
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A Select Rectangular to create a rectangular array. 

B Enter the number of rows and columns for the 
array. 

C Click to specify the row offset directly in the 
drawing. 

D Click to specify both row offset and column offset 
directly in the drawing. 

E Enter the amount of vertical space you want 
between each row in the array. 

F Enter the amount of horizontal space you want 
between each column in the array. 

G Enter the angle at which to rotate the array. 

H Click to specify the angle of array directly in the 
drawing. 

I Click to specify the column offset directly in the 
drawing. 

J Click to preview the array in the drawing (only 
available after entities are selected for the array). 

K Displays the number of entities that are selected 
in the drawing for the array. 

L Click to switch temporarily to the drawing to 
select entities to include in the array. 

L 
A 

B 
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Rearranging entities 
 

You can move one or more entities, and you can also rotate entities about a specified point. 

If you have entities that overlap, you can also change the display order. 

 

Moving entities 
You can move entities around within the current drawing or from one drawing to 

another. The default method is to create a selection set and then specify a starting 

point, or base point, and an endpoint, or displacement point, to define the relocation 

of the entities. You can also relocate the entities using a direction vector. 
 

To move a selection set 

1 Do one of the following to choose Move (  ): 

• On the ribbon, choose Edit > Move (in Modify). 

• On the menu, choose Modify > Move. 

• On the Modify toolbar, click the Move tool. 

• Type move and then press Enter. 

2 Select the entities, and then press Enter. 

3 Specify the base point. 

4 Specify the displacement point. 

 
 

 
To move an entity, select it (A), and then specify the 
base point (B) and the displacement point (C). 

Result. 

 
 

Use the Move/Copy/Rotate command. 

You can move, copy, rotate, and scale selected entities using a single command. 

Choose the Move/Copy/Rotate express tool or type mocoro. 
 

 

 

You can also move entities using grips. To move an entity using grips, select the 

entity to display its grips, and then click a grip and drag it. The grip you select 

depends on the type of entity you’re modifying. For example, to move a line entity, 

select the midpoint grip. To move a curved entity, such as an arc, circle, or ellipse, 

select the center point grip. Not all entities can be moved using grips. 

B 
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To move an entity using grips 

1 Select the entity. 

2 Click a grip to select it. 

3 Drag the entity to where you want to relocate it. 

4 Click to release. 

 

Moving entities between spaces 
You can move entities from model space to paper space or from paper space to model 

space. You must be viewing a Layout tab that has at least one layout viewport in 

order to move entities between spaces. You can also copy entities between spaces 

using the same Change Space command. 

For more details about model space and paper space, see see “Understanding paper 

space and model space” on page 520. 
 

To move entities between spaces 

1 Click a Layout tab. 

2 Select the entities you want to move. 

3 Do one of the following to choose ( ): 

• On the ribbon, choose Edit > Change Space (in Modify). 

• On the menu, choose Modify > Change Space. 

• On the Modify toolbar, click the Change Space tool. 

• Type chspace and then press Enter. 

4 Choose Move. 
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Rotating entities 
You can rotate entities about a specified point at a specified rotation angle or by an 

angle referenced to a base angle. The default method rotates the entities using a rela- 

tive rotation angle from their current orientation. 
 

To rotate a selection set 

1 Do one of the following to choose Rotate ( ): 

• On the ribbon, choose Edit > Rotate (in Modify). 

• On the menu, choose Modify > Rotate. 

• On the Modify toolbar, click the Rotate tool. 

• Type rotate and then press Enter. 

2 Select the entities, and then press Enter. 

3 Specify the rotation point. 

4 If desired, choose Copy to rotate a copy of selected entities. 

5 Specify the rotation angle. 

 
 

 
To rotate an entity, select the entity to rotate (A), and then specify the rotation point (B) and the rotation angle 
(C). 

To rotate a selection set in reference to a base angle 

1 Do one of the following to choose Rotate ( ): 

• On the ribbon, choose Edit > Rotate (in Modify). 

• On the menu, choose Modify > Rotate. 

• On the Modify toolbar, click the Rotate tool. 

• Type rotate and then press Enter. 

2 Select the entities, and then press Enter. 

3 Specify the rotation point. 

4 If desired, choose Copy to rotate a copy of selected entities. 

5 In the prompt box, choose Base Angle. 

6 Specify the base angle, then specify the new angle. 
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To rotate an entity in reference to a base angle, select the entity (A), specify the rotation point (B), select the 
base angle and pick point (B) again (or type the @ symbol), specify the second point (C), and then specify 
the point representing the new angle (D). 

 
 

There are other ways to rotate entities too. 

You can move, copy, and rotate selected entities using a single command. Choose the 

Move/Copy/Rotate express tool or type mocoro. 

 
You can rotate single-line text, multiline text, attribute definitions, and block attribute 

text using an express tool, which has a convenient option for choosing the rotation 

that is easiest to read. Choose the Rotate Text express tool or type torient. 
 

 

B 
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Reordering entities 
When multiple entities overlap, you can change the order in which they are displayed 

and printed. You can move entities to the front, back, or on top or below of another 

entity. 

You can also change the draw order of hatches to be drawn and printed behind all 

other entities in a drawing. 
 

To reorder entities: 

1 Do one of the following to choose Draw Order ( ): 

• On the ribbon, choose Edit > Draw Order (in Draworder). 

• On the menu, choose Tools > Draw Order. 

• On the Tools toolbar, click the Draw Order tool or use the Draworder toolbar. 

• Type draworder and then press Enter. 

2 Select the entity you want to reorder, and then press Enter. 

3 In the prompt box, specify the new drawing order, and then press Enter. 

4 If you are reordering above or under, select the entity you want the first entity to 

be above or below, and then press Enter. 
 

 

The SORTENTS system variable automatically turns on. 

The SORTENTS system variable automatically turns on, which may affect system per- 

formance. 
 

 

 
To reorder hatches to the back: 

1   Do one of the following to choose Send Hatches Back ( ): 

• On the ribbon, choose Home > Modify expander > Send Hatches Back (in Draw 

Order tools) or choose Edit > Send Hatches Back. 

• On the menu, choose Modify > Draw Order > Send Hatches Back. 

• On the Draw Order - Annotation toolbar, click the Send Hatches Back tool. 

• Type hatchtoback and then press Enter. 

The number of hatches affected is reported in the command bar. 
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Resizing entities 
 

You can change the size of an entity or set of entities by stretching, scaling, extend- 

ing, trimming, or editing their lengths. 

 

Stretching entities 
You can change the size of entities by stretching them. When you stretch entities, you 

must select the entities using either a crossing window or a crossing polygon. You 

then specify a displacement distance or select a base point and a displacement point. 

Entities that cross the window or polygon boundary are stretched; those completely 

within the crossing window or crossing polygon are simply moved. 
 

To stretch an entity 

1 Do one of the following to choose Stretch (  ): 

• On the ribbon, choose Home > Stretch (in Edit). 

• On the menu, choose Modify > Stretch. 

• On the Modify toolbar, click the Stretch tool. 

• Type stretch and then press Enter. 

2 In the prompt box, choose Crossing Window or Crossing Polygon. 

3 Select the entities, and then press Enter. 

4 Specify the base point. 

5 Specify the second point of displacement. 

 
 

 
To stretch entities, select them using a crossing window (A) or crossing polygon, and then specify the base 
point (B) and displacement point (C). 

To stretch an entity using grips, you select it to display its grips and then select a grip 

to make it the active grip. This becomes the base point. Then you move the active 

grip to a new location. The grip you select depends on the type of entity you’re modi- 

fying. For example, to stretch one corner of a rectangle, select the corner point grip. 

To stretch a line, select an endpoint grip. Not all entities can be stretched using grips. 

 
C 

 
B 

 

 

A 
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To stretch an entity using grips 

1 Select the entity. 

2 Click a grip to activate it. 

3 Drag the grip. 

4 Click to release. 

 
 

 
To stretch an entity using grips, select the entity 
(A), select a grip (B), and drag the grip to its new 
location (C). 

 

Scaling entities 

Result. 

You can change the size of a selected entity by scaling it in relation to a base point. 

You can change the size of an entity by specifying a base point and a length, which is 

used as a scale factor based on the current drawing units, or by specifying a scale fac- 

tor. You can also use a scale factor referenced to a base scale factor, for example, by 

specifying the current length and a new length for the entity. 
 

To scale a selection set by a scale factor 

1 Do one of the following to choose Scale (  ): 

• On the ribbon, choose Edit > Scale (in Modify). 

• On the menu, choose Modify > Scale. 

• On the Modify toolbar, click the Scale tool. 

• Type scale and then press Enter. 

2 Select the entities, and then press Enter. 

3 Specify the base point. 

4 Specify the scale factor. 

 
 

 
To scale an entity by a scale factor, select the entity (A), and then 
specify the base point (B) and the scale factor. 

Result. 

 
A 

B 

C 
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You can also scale some entities using grips. To scale an entity, you select the entity, 

and then click a grip. You then change the size of the entity by moving the grip. The 

grip you select depends on the type of entity you’re modifying. For example, to scale 

a circle, select a quadrant point grip. 
 

To scale an entity using grips 

1 Select the entity. 

2 Click a grip to select it. 

3 Drag the grip. 

4 Click to release. 

 
 

 
To scale using grips, select the entity (A), click a grip (B), and 
scale the entity by dragging the grip to its new location (C). 

Result. 

 
 

Use the Move/Copy/Rotate command. 

You can move, copy, rotate, and scale selected entities using a single command. 

Choose the Move/Copy/Rotate express tool or type MOCORO. 
 

 

 
 

To scale selected text entities use the Scale Text express tool or type SCALETEXT. 
 

 

 

Extending entities 
You can extend entities so that they end at a boundary defined by other entities. You 

can also extend entities to the point at which they would intersect an implied bound- 

ary edge. When extending entities, you first select the boundary edges, and then spec- 

ify the entities to extend, selecting them either one at a time, using the fence selection 

method, or the projection selection method. 

You can extend arcs, lines, two-dimensional polylines, and rays. Arcs, circles, 

ellipses, lines, splines, polylines, rays, infinite lines, and viewports on a Layout tab 

can act as boundary edges. 

 

A 
 

B 
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To extend an entity 

1 Do one of the following to choose Extend (  ): 

• On the ribbon, choose Edit > Extend (in Modify). 

• On the menu, choose Modify > Extend. 

• On the Modify toolbar, click the Extend tool. 

• Type extend and then press Enter. 

2 Select one or more entities as boundary edges, and then press Enter. 

3 Select the entity to extend. 

4 Select another entity to extend, or press Enter to complete the command. 

 

 
To extend entities, select the boundary edge (A), and then 
select the entities to extend (B). 

To extend an entity to an implied boundary 

1 Do one of the following to choose Extend (  ): 

• On the ribbon, choose Edit > Extend (in Modify). 

• On the menu, choose Modify > Extend. 

• On the Modify toolbar, click the Extend tool. 

• Type extend and then press Enter. 

Result. 

2 Select one or more boundary edges, and then press Enter. 

3 In the prompt box, choose Edge Mode. 

4 In the prompt box, choose Extend. 

5 Select the entity to extend. 

6 Select another entity to extend, or press Enter to complete the command. 
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To extend several entities using the fence selection method 

1 Do one of the following to choose Extend (  ): 

• On the ribbon, choose Edit > Extend (in Modify). 

• On the menu, choose Modify > Extend. 

 

B 
 

 

 
B 
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• On the Modify toolbar, click the Extend tool. 

• Type extend and then press Enter. 

2 Select one or more boundary edges, and then press Enter. 

3 In the prompt box, choose Fence. 

4 Specify the first point of the fence. 

5 Specify the second point of the fence. 

6 Specify the next fence point, or press Enter to complete the command. 

 

 

 
Select the boundary edge (A), and then specify the first point (B) 
and second point (C) of the fence. 

Result. 

When you extend a wide polyline, its centerline intersects the boundary edge. 

Because the end of the polyline is always cut at a 90-degree angle, part of the polyline 

may extend past the boundary edge. A tapered polyline continues to taper until it 

intersects the boundary edge. If this would result in a negative polyline width, the 

ending width changes to 0. 

 

 
A tapered polyline (A) continues to taper until it intersects the 
boundary edge (B). 

Result. 

B 

 

B 
 

A 
 

C 



376 C H A P T E R   1 0  
 

 
Trimming entities 
You can clip, or trim, entities so they end at one or more implied cutting edges 

defined by other entities. You can also trim entities to the point at which they would 

intersect an implied cutting edge. When trimming entities, you first select the cutting 

edges and then specify the entities to trim, selecting them either one at a time or using 

the fence selection method. 

You can trim arcs, circles, lines, open two-dimensional and three-dimensional 

polylines, and rays. Arcs, circles, lines, polylines, rays, infinite lines, and viewports 

on a Layout tab can act as cutting edges. An entity can be both a cutting edge and one 

of the entities being trimmed. 
 

To trim an entity 

1 Do one of the following to choose Trim (  ): 

• On the ribbon, choose Edit > Trim (in Modify). 

• On the menu, choose Modify > Trim. 

• On the Modify toolbar, click the Trim tool. 

• Type trim and then press Enter. 

2 Select one or more cutting edges, and then press Enter. 

3 Select the entity to trim. 

4 Select another entity to trim, or press Enter to complete the command. 

 
 

 
To trim entities, select the cutting edge (A), and then select 
the entities to trim (B). 

To trim an entity to an implied boundary 

1 Do one of the following to choose Trim (  ): 

• On the ribbon, choose Edit > Trim (in Modify). 

• On the menu, choose Modify > Trim. 

• On the Modify toolbar, click the Trim tool. 

• Type trim and then press Enter. 

Result. 

2 Select one or more cutting edges, and then press Enter. 

3 In the prompt box, choose Edge Mode. 

4 In the prompt box, choose Extend. 

5 Select the entity to trim. 

6 Select another entity to trim, or press Enter to complete the command. 

 

A 

 
B 
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Select the implied boundary edge (A), and then select 
the entities to trim (B). 

Result. 

To trim several entities using the fence selection method 

1 Do one of the following to choose Trim (  ): 

• On the ribbon, choose Edit > Trim (in Modify). 

• On the menu, choose Modify > Trim. 

• On the Modify toolbar, click the Trim tool. 

• Type trim and then press Enter. 

2 Select one or more cutting edges, and then press Enter. 

3 In the prompt box, choose Fence. 

4 Specify the first point of the fence. 

5 Specify the second point of the fence. 

6 Specify the next fence point, or press Enter to complete the command. 

 
 

 
Select the boundary edge (A), and then specify the first 
point (B) and second point (C) of the fence. 

 

Editing the length of entities 

Result. 

You can change the length of entities or the included angle of arcs. Use any of the fol- 

lowing methods to change the length of an entity: 

• Dynamically drag the endpoint or angle. 

• Specify an incremental length or angle measured from an endpoint. 

• Specify the new length as a percentage of the total length or angle. 

• Specify a new length or included angle. 

You can change the length of arcs, lines, and open polylines. 
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To change the length of an entity by dragging 

1 Do one of the following to choose Edit Length (  ): 

• On the ribbon, choose Edit > Edit Length (in Modify). 

• On the menu, choose Modify > Edit Length. 

• On the Modify toolbar, click the Edit Length tool. 

• Type editlen and then press Enter. 

2 In the prompt box, choose Dynamic. 

3 Select the entity you want to change. 

4 Specify the new endpoint or included angle. 

 

 

 
Select the entity (A), and then select the new 
endpoint (B). 

Result. 

A 
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Splitting and combining entities 
 

You can break and combine entities using the following methods: 

• Break — Separate a single entity into two parts, removing a portion of the entity in 

the process. 

• Join — Combine two entities into a single entity. 

• Explode — Separate a complex entity, such as a block or polyline, into its various 

component parts. 

• Group — Combine multiples entities to behave as a single unit. 

 

Breaking entities 
You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When 

breaking entities, you must specify two points for the break. By default, the point you 

use to select the entity becomes the first break point; however, you can use the First 

option to select a break point different from the one that selects the entity. 
 

To break an entity 

1 Do one of the following to choose Break (  ): 

• On the ribbon, choose Edit > Break (in Modify). 

• On the menu, choose Modify > Break. 

• On the Modify toolbar, click the Break tool. 

• Type break and then press Enter. 

2 Select the entity. 

3 Specify the second break point. 

 
 

 
Select the entity (A), and then specify the second break 
point (B). 

Result. 

 

B 
 

A 
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To select an entity and then specify the two break points 

1 Do one of the following to choose Break (  ): 

• On the ribbon, choose Edit > Break (in Modify). 

• On the menu, choose Modify > Break. 

• On the Modify toolbar, click the Break tool. 

• Type break and then press Enter. 

2 Select the entity. 

3 In the prompt box, choose First. 

4 Specify the first break point. 

5 Specify the second break point. 

 

 
Select the entity (A), and then specify the first (B) and 
second (C) break points. 

Result. 

 
 

You can break an entity in two without removing a portion of the entity. 

Specify the same point for the first and second break points by typing the at sign (@) 

and pressing Enter instead of specifying the second break point. 
 

 

C 

B 
A 
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Joining entities 
You can join two entities into a single entity. You can join either two lines or two arcs. 

The two lines must be parallel; the two arcs must share the same center point and radius. 

When you join two lines, the farthest endpoints remain at their existing locations; the 

program draws a new line between these points. Arcs are joined counterclockwise, 

from the first arc you select to the second. 
 

To join two entities 

1 Do one of the following to choose Join (  ): 

• On the ribbon, choose Edit > Join (in Modify). 

• On the menu, choose Modify > Join. 

• On the Modify toolbar, click the Join tool. 

• Type join and then press Enter. 

2 Select the first arc or line. 

3 Select the second arc or line. 
 

 
Select the first arc or line (A), and then select the 
second arc or line (B). 

Result. 

 
 

The Overkill command can also combine entities. 

If a drawing has overlapping or duplicate entities that you want to combine, for 

example polylines with too many vertices, you can use the Overkill command to clean 

up the drawing. 
 

 

 
B 

A 
 
 

 
 
 
 
 
 

B 
 

A 
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Exploding entities 
You can convert a complex entity, such as a block or polyline, from a single entity 

into its component parts. Exploding a polyline, rectangle, donut, polygon, dimension, 

or leader reduces it to a collection of individual line and arc entities that you can then 

modify individually. 

Blocks are converted to the individual entities, possibly including other, nested 

blocks that composed the original entity. When exploding blocks, you can also use 

the Explode Attributes command to ungroup blocks, creating separate entities for 

each element and converting attributes to text. The resulting exploded entities are 

placed on the block layer (not the layer of the original entities) while the exploded 

attributes are placed on the layer of the original attribute. The Explode Attributes 

command is best used if you want to explode a block with attributes and have it retain 

the same visual appearance for properties and text. However, if you want to explode 

the block to modify the block definition and redefine it, you should use the Explode 

command, not Explode Attributes. 

Exploding multiline text or single-line text using the Text Explode command reduces 

the text to polylines. 

With the following exceptions, exploding an entity usually has no visible effect on a 

drawing: 

• If the original polyline had a width, the width information is lost when you explode 

it. The resulting lines and arcs follow the centerline of the original polyline. 

• If you explode a block containing attributes, the attributes are lost, but the original 

attribute definitions remain. 

• Colors, linetypes, lineweights, and print styles assigned BYBLOCK may be dif- 

ferent after exploding an entity, because they will adopt the default color, linetype, 

lineweight, and print style until inserted into another block. 
 

To explode an entity 

1 Do one of the following to choose Explode (  ): 

• On the ribbon, choose Home > Explode (in Modify) or choose Edit > Explode 

(in Modify). 

• On the menu, choose Modify > Explode. 

• On the Modify toolbar, click the Explode tool. 

• Type explode and then press Enter. 

2 Select the entities to explode. 

3 Press Enter. 
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To explode multiline text or single-line text 

1 Do one of the following to choose Explode Text (  ): 

• On the ribbon, choose Express Tools > Explode Text (in Text). 

• On the menu, choose Express Tools > Text > Explode Text. 

• Type txtexp and then press Enter. 

2 Select the text to explode. 

3 Press Enter. 
 

To explode a bock and its attributes 

1 Do one of the following to choose Explode Attributes (  ): 

• On the ribbon, choose Express Tools > Explode Attributes (in Blocks). 

• On the menu, choose Express Tools > Blocks > Explode Attributes. 

• Type burst and then press Enter. 

2 Select the blocks that have attributes you want to explode. 

3 Press Enter. 
 

To explode an entity and specify properties of the resulting entities 

1 Do one of the following to choose Xplode (  ): 

• On the ribbon, choose Edit > Xplode (in Modify). 

• On the menu, choose Modify > Xplode. 

• On the Modify toolbar, click the Xplode tool. 

• Type xplode and then press Enter. 

2 Select the entities to explode. 

3 Choose an option: 

• All — Displays prompts for specifying all available properties: color, layer, 

linetype, and lineweight. 

• Color — Enter a color. You can enter an index color, true color, or color from a 

colorbook. 

• Layer — Enter a layer for the resulting entities. 

• LType — Enter a linetype for the resulting entities. 

• LWeight — Enter a lineweight for the resulting entities. 

• Inherit — Explodes selected entities and assigns the same color, layer, linetype, 

and lineweight properties to sub-entities as the parent entity if the sub-entity 

layer is 0 and other properties are BYBLOCK. 

• Explode — Explodes selected entities in the same way as the Explode 

command. 
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Grouping entities 
A group is a collection of entities saved together as one unit. After you select the enti- 

ties that belong in the group, you can later add more entities, remove entities, and 

reorder the entities. If necessary, you can also ungroup the entities at any time to 

work with the entities separately. 

 

Creating groups 
When you create a group, you enter a group name and description, and then select the 

entities for the group. 
 

To create a group 

1 Do one of the following to choose Group (  ): 

• On the ribbon, choose Home > Group (in Utilities) or Tools > Group (in 

Manage). 

• On the menu, choose Tools > Group. 

• On the Tools toolbar, click the Group tool. 

• Type group and then press Enter. 

2 Under Create New Group, enter the name and description of the group. 

3 Click Selectable if you want all entities in the group to be selected when you select 

one entity of the group in the drawing. 

4 Click Select Entities and Create Group. 

5 Select the entities for the group, and then press Enter. 

6 In the Group dialog box, click OK. 
 

 

You can select entities using groups. 

Enter the name of a group in the command bar when selecting entities. 
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The Group dialog box controls the settings for all groups in a drawing. 
 

 
 

Modifying groups 

To modify a group and its entities 

1 Do one of the following to choose Group (  ): 

• On the ribbon, choose Home > Group (in Utilities). 

• On the menu, choose Tools > Group. 

• On the Tools toolbar, click the Group tool. 

• Type group and then press Enter. 

2 Select the group you want to modify. 

3 Under Modify Selected Group, do one or more of the following: 

• Enter a new name, and then click Rename Group. 

• Enter a new description, and then click Change Group Description. 

• Select whether you want the group to be selectable in the drawing. 



386 C H A P T E R   1 0  
 

 

• Click Add Entities to Group, select the entities to add to the group, and then 

press Enter. 

• Click Remove Entities from Group, select the entities to remove from the group, 

and then press Enter. 

4 In the Group dialog box, click OK. 
 

To change the order of entities in a group 

1 Do one of the following to choose Group (  ): 

• On the ribbon, choose Home > Group (in Utilities). 

• On the menu, choose Tools > Group. 

• On the Tools toolbar, click the Group tool. 

• Type group and then press Enter. 

2 Under Modify Selected Group, click Reorder Entities. 

3 In the Reorder Grouped Entities dialog box, select the group you want to reorder. 

4 To see the order of entities in the group, click Highlight. Follow the prompts that 

display to view the entities one by one. 

5 To reverse the order of all entities in the group, click Reverse Order. 

6 To change the order of specific entities or a range of entities: 

• In Remove from Position, enter the current position of the entity. 

• In Place to Position, enter the new position of the entity. 

• In Number of Entities, enter the number of entities or range of entities to reorder. 

For example, if you are changing the order of only one entity, enter 1. 

• Click Reorder. 

The entities in a group are numbered 0, 1, 2, 3, and so on. 

7 Click OK, and then click OK again. 
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Ungrouping entities 
When you ungroup entities, the entities remain in the drawing but the group is deleted 

from the drawing. 
 

To ungroup entities 

1 Do one of the following to choose Group (  ): 

• On the ribbon, choose Home > Group (in Utilities). 

• On the menu, choose Tools > Group. 

• On the Tools toolbar, click the Group tool. 

• Type group and then press Enter. 

2 Select the group to delete. 

3 Under Modify Selected Group, click Ungroup Entities. 

4 Click OK. 

 

 

Editing polylines 
 

You can modify any type of two-dimensional or three-dimensional polyline. Entities 

such as rectangles, polygons, and donuts, as well as three-dimensional entities such as 

pyramids, cylinders, and spheres, are all variations of polylines that you can edit. 

You can edit a polyline by opening or closing it, by changing its overall width or the 

widths of individual segments, and by converting a polyline with straight line seg- 

ments into a flowing curve or an approximation of a spline. In addition, you can use 

the Edit Polyline tool to edit individual vertices, adding, removing, or moving verti- 

ces. You can also add new segments to an existing polyline, change the linetypes of a 

polyline, and reverse the direction or order of the vertices. 

 

Converting an entity to a polyline 
To modify a polyline, you first select the polyline, and then select a polyline editing 

option. The available options vary depending on whether the selected polyline is a 

two-dimensional or three-dimensional entity. If the selected entity is not a polyline, 

the Edit Polyline tool provides the option of turning it into one. You can convert only 

arcs and lines into polylines. If several arcs or lines are joined endpoint to endpoint, 

they can all be selected and turned into one polyline. 
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To convert an entity into a polyline 

1 Do one of the following to choose Edit Polyline (  ): 

• On the ribbon, choose Edit > Edit Polyline (in Modify). 

• On the menu, choose Modify > Edit Polyline. 

• On the Modify toolbar, click the Edit Polyline tool. 

• Type editpline and then press Enter. 

2 Select the entity. 

3 In the prompt box, choose Yes-Turn Into Polyline. 

4 In the prompt box, choose another option, or choose Done to complete the 

command. 

 

Opening and closing polylines 
When you close a polyline, the program draws a straight polyline segment from the 

last vertex of the polyline to the first vertex. Opening a polyline removes the closing 

segment. When you select a polyline for editing, the prompt box displays either the 

Open or Close option, depending on whether the polyline you select is closed or 

open. 
 

To close an open polyline 

1 Do one of the following to choose Edit Polyline (  ): 

• On the ribbon, choose Edit > Edit Polyline (in Modify). 

• On the menu, choose Modify > Edit Polyline. 

• On the Modify toolbar, click the Edit Polyline tool. 

• Type editpline and then press Enter. 

2 Select the polyline. 

3 In the prompt box, choose Close. 

4 In the prompt box, choose another option, or choose Done to complete the com- 

mand. 

 
 

 
Closing an open polyline adds a straight 
polyline segment between the first (A) and last 
(B) vertices. 

Result. 
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Curving and decurving polylines 
You can convert a multisegment polyline into a smooth curve using either the Fit or 

Spline option. The Fit option creates a smooth curve connecting all the vertices. The 

Spline option computes a smooth curve that is pulled toward the vertices but passes 

through only the first and last vertices. The Decurve option removes Fit or Spline 

curves and arcs, leaving straight segments between the vertices. 
 

To fit a curve to a polyline 

1 Do one of the following to choose Edit Polyline (  ): 

• On the ribbon, choose Edit > Edit Polyline (in Modify). 

• On the menu, choose Modify > Edit Polyline. 

• On the Modify toolbar, click the Edit Polyline tool. 

• Type editpline and then press Enter. 

2 Select the polyline. 

3 In the prompt box, choose Fit. 

4 In the prompt box, choose another option, or choose Done to complete the 

command. 

 
 

 
Original polyline. After applying Fit curve. After applying Spline. 

 

Joining polylines 
You can add an arc, line, or polyline entity to an existing open polyline, forming one 

continuous polyline entity. To join an entity to a polyline, that entity must already 

share an endpoint with an end vertex of the selected polyline. 

When you join an entity to a polyline, the width of the new polyline segment depends 

on the width of the original polyline and the type of entity you are joining to it: 

• A line or an arc assumes the same width as the polyline segment for the end vertex 

to which it is joined. 

• A polyline joined to a tapered polyline retains its own width values. 
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• A polyline joined to a uniform-width polyline assumes the width of the polyline to 

which it is joined. 

 

To join an arc, line, or polyline to an existing polyline 

1 Do one of the following to choose Edit Polyline (  ): 

• On the ribbon, choose Edit > Edit Polyline (in Modify). 

• On the menu, choose Modify > Edit Polyline. 

• On the Modify toolbar, click the Edit Polyline tool. 

• Type editpline and then press Enter. 

2 Select the polyline. 

3 In the prompt box, choose Join. 

4 Select the arc, line, or polyline to join. 

5 In the prompt box, choose another option, or choose Done to complete the 

command. 

 

Changing the polyline width 
You can change the width of an entire polyline, applying a uniform width to the entire 

entity or tapering the polyline uniformly along its entire length. 
 

To apply a uniform width to an entire polyline 

1 Do one of the following to choose Edit Polyline (  ): 

• On the ribbon, choose Edit > Edit Polyline (in Modify). 

• On the menu, choose Modify > Edit Polyline. 

• On the Modify toolbar, click the Edit Polyline tool. 

• Type editpline and then press Enter. 

2 Select the polyline. 

3 In the prompt box, choose Width. 

4 Specify the new polyline width. 

5 In the prompt box, choose another option, or choose Done to complete the 

command. 
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To taper a polyline uniformly along its length 

1 Do one of the following to choose Edit Polyline (  ): 

• On the ribbon, choose Edit > Edit Polyline (in Modify). 

• On the menu, choose Modify > Edit Polyline. 

• On the Modify toolbar, click the Edit Polyline tool. 

• Type editpline and then press Enter. 

2 Select the polyline. 

3 In the prompt box, choose Taper. 

4 Specify the starting width. 

5 Specify the ending width. 

6 In the prompt box, choose another option, or choose Done to complete the 

command. 

 

Editing polyline vertices 
You can use the Edit Vertices option to modify individual polyline vertices. When 

you select this option, the program switches into a special vertex editing mode and 

places an x on the first vertex. The x indicates the vertex you are editing. The Next 

and Previous options move the x to the next or previous vertex. You can edit only one 

vertex at a time. 

When editing vertices, you can modify the polyline in the following ways: 

• Convert a polyline segment into a curve by specifying a new tangent angle. 

• Break a polyline into two separate polylines. 

• Insert a new vertex after the current vertex. 

• Move the current vertex. 

• Straighten the polyline segment between two vertices. 

• Change the width of the polyline segment between two vertices. 
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To move a polyline vertex 

1 Do one of the following to choose Edit Polyline (  ): 

• On the ribbon, choose Edit > Edit Polyline (in Modify). 

• On the menu, choose Modify > Edit Polyline. 

• On the Modify toolbar, click the Edit Polyline tool. 

• Type editpline and then press Enter. 

2 Select the polyline. 

3 In the prompt box, choose Edit Vertices. 

4 In the prompt box, choose Next Vertex. 

Repeat until the x reaches the vertex you want to move. 

5 In the prompt box, choose Move. 

6 Specify the new location for the vertex. 

7 In the prompt box, choose another option, or choose Exit to stop editing vertices. 

8 In the prompt box, choose another option, or choose Done to complete the com- 

mand. 
 

 
Select the polyline (A), move the current vertex 
marker to the vertex you want to move (B), and then 
specify the new vertex location (C). 

Result. 
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To taper the width of an individual polyline segment 

1 Do one of the following to choose Edit Polyline (  ): 

• On the ribbon, choose Edit > Edit Polyline (in Modify). 

• On the menu, choose Modify > Edit Polyline. 

• On the Modify toolbar, click the Edit Polyline tool. 

• Type editpline and then press Enter. 

2 Select the polyline. 

3 In the prompt box, choose Edit Vertices. 

4 In the prompt box, choose Next Vertex. 

Repeat until the x reaches the first vertex of the segment you want to taper. 

5 In the prompt box, choose Width. 

6 Specify the starting width. 

7 Specify the ending width. 

8 In the prompt box, choose another option, or choose Exit to stop editing vertices 

and update the display. 

9 In the prompt box, choose another option, or choose Done to complete the com- 

mand. 

 
 

 
Select the polyline (A), move the current vertex 
marker to the first vertex of the segment you want to 
taper (B), and then specify the new starting and 
ending widths for that segment. 

Result. 

 

A B 
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Chamfering and filleting entities 
 

You can chamfer or fillet entities. A chamfer connects two nonparallel entities with a 

line to create a beveled edge. A fillet connects two entities with an arc of a specified 

radius to create a rounded edge. If both entities you are working with are on the same 

layer, the chamfer or fillet is drawn on that layer. If they are on different layers, the 

chamfer or fillet is drawn on the current layer. 

 

Modifying the chamfer and fillet settings 
The Chamfer/Fillet settings in the Drawing Settings dialog box control the chamfer 

and fillet settings. The portions of the entities that extend beyond the chamfer or fillet 

are normally deleted when you create the chamfer or fillet. You can retain these 

original entities, however, by changing the settings in the dialog box. 
 

To modify the chamfer and fillet settings 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 In the Drawing Settings dialog box, click the Entity Modification tab. 

3 Click the Chamfer/Fillet tab and choose from the following: 

• Corners — Select to remove or retain portions of entities that extend beyond the 

chamfer or fillet. 

• Fillet radius — Specify the fillet radius or click Select to specify it by selecting 

two points in the drawing. 

• Chamfer Distances and Angles — Choose to use the distance-distance method 

or distance-angle method when creating chamfers. The distance-distance 

method creates a chamfer using two chamfer distances that you specify. The 

distance-angle method creates a chamfer using a chamfer length and angle that 

you specify. 

4 Click OK. 

 

Chamfering entities 
You can connect two nonparallel entities by extending or trimming them and then 

joining them with a line to create a beveled edge. You can chamfer lines, polylines, 

rays, and infinite lines. When creating a chamfer, you can specify how far to trim the 

entities back from their intersection (distance-distance method), or you can specify 

the length of the chamfer and the angle it forms along the first entity (distance-angle 

method). 
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When chamfering a polyline, you can chamfer multiple segments between two 

selected polyline segments, or you can chamfer the entire polyline. 

 
Chamfering two entities using the distance-distance method 

To chamfer two entities using the distance-distance method 

1 Do one of the following to choose Chamfer (  ): 

• On the ribbon, choose Modify > Chamfer (in Modify). 

• On the menu, choose Modify > Chamfer. 

• On the Modify toolbar, click the Chamfer tool. 

• Type chamfer and then press Enter. 

2 In the prompt box, choose Chamfer Settings. 

3 In the Drawing Settings dialog box, click the Entity Modification tab. 

4 Under Chamfer Distances And Angles, click Distance-Distance. 

5 Under Chamfer Distances And Angles, specify the first and second chamfer 

distances. 

6 Click OK. 

7 Select the first entity. 

8 Select the second entity. 

 
 

 
Select the first (A) and second (B) entities. The chamfer is drawn, based on the first (C) and second (D) 
chamfer distances. 

D 
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Chamfering two entities using the distance-angle method 

To chamfer two entities using the distance-angle method 

1 Do one of the following to choose Chamfer (  ): 

• On the ribbon, choose Modify > Chamfer (in Modify). 

• On the menu, choose Modify > Chamfer. 

• On the Modify toolbar, click the Chamfer tool. 

• Type chamfer and then press Enter. 

2 In the prompt box, choose Chamfer Settings. 

3 In the Drawing Settings dialog box, click the Entity Modification tab. 

4 Under Chamfer Distances And Angles, click Distance-Angle. 

5 Under Chamfer Distances And Angles, specify the chamfer distance and angle. 

6 Click OK. 

7 Select the first entity. 

8 Select the second entity. 

 

 

 
Select the first (A) and second (B) entities. The chamfer is drawn, based on the distance measured along the 
first entity (C) and the angle (D) formed with the first entity. 

 

Chamfering all vertices in a polyline 

To chamfer all vertices in a polyline 

1 Do one of the following to choose Chamfer (  ): 

• On the ribbon, choose Modify > Chamfer (in Modify). 

• On the menu, choose Modify > Chamfer. 

• On the Modify toolbar, click the Chamfer tool. 

• Type chamfer and then press Enter. 

2 In the prompt box, choose Polyline. 

3 Select the polyline. 
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Original polyline. Result after chamfering. 

 

Chamfering selected vertices in a polyline 

To chamfer selected vertices in a polyline 

1 Do one of the following to choose Chamfer (  ): 

• On the ribbon, choose Modify > Chamfer (in Modify). 

• On the menu, choose Modify > Chamfer. 

• On the Modify toolbar, click the Chamfer tool. 

• Type chamfer and then press Enter. 

2 Select the polyline along the segment where you want to begin the chamfer. 

3 Select the polyline along the segment where you want to end the chamfer. 

 
 

 
Select the polyline along the (A) and (B) 
segments. 

Result after chamfering. 

 
 
 
 

A B 
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Filleting entities 
You can connect two entities with an arc of a specified radius to create a rounded 

edge. You can fillet pairs of line segments, straight polyline segments, arcs, circles, 

rays, and infinite lines. You can also fillet parallel lines, rays, and infinite lines. When 

filleting a polyline, you can fillet multiple segments between two selected segments, 

or you can fillet the entire polyline. 

 

Filleting two entities 

To fillet two entities 

1 Do one of the following to choose Fillet (  ): 

• On the ribbon, choose Modify > Fillet (in Modify). 

• On the menu, choose Modify > Fillet. 

• On the Modify toolbar, click the Fillet tool. 

• Type fillet and then press Enter. 

2 In the prompt box, choose Fillet Settings. 

3 In the Drawing Settings dialog box, specify the fillet radius. 

4 Click OK. 

5 Select the first entity. 

6 Select the second entity. 

 
 

 
Select the first (A) and second (B) entities. Result after filleting. 

 

Filleting an entire polyline 

To fillet an entire polyline 

1 Do one of the following to choose Fillet (  ): 

• On the ribbon, choose Modify > Fillet (in Modify). 

• On the menu, choose Modify > Fillet. 

• On the Modify toolbar, click the Fillet tool. 

• Type fillet and then press Enter. 

2 In the prompt box, choose Polyline. 

3 Select the polyline. 

A 
 

B 
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Select the polyline (A). Result after filleting. 

 

Filleting selected vertices in a polyline 

To fillet selected vertices in a polyline 

1 Do one of the following to choose Fillet (  ): 

• On the ribbon, choose Modify > Fillet (in Modify). 

• On the menu, choose Modify > Fillet. 

• On the Modify toolbar, click the Fillet tool. 

• Type fillet and then press Enter. 

2 Select the polyline along the segment where you want to begin the fillet. 

3 Select the polyline along the segment where you want to end the fillet. 

 
 

 
Select the polyline along the (A) and (B) 
segments. 

Result after filleting. 

When you fillet circles and arcs, more than one fillet can exist between the entities. 

The point at which you select the entities determines the fillet. 

 
 

 
A B 

 

A 
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Select entities (A and B). Results after filleting. 

You can fillet parallel lines, rays, and infinite lines. The first entity must be a line or 

ray; the second entity can be a line, ray, or infinite line. The diameter of the fillet arc 

is always equal to the distance between the parallel entities. The current fillet radius is 

ignored. 

 
 

 
Original entities. Result after filleting. 
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Working with text 
 

You can insert text into your drawing and control its appearance, allowing you to pro- 

vide additional information for your 4MCAD drawings. This section explains how to: 

• Create line text, including along an arc. 

• Create paragraphs. 

• Create text styles. 

• Format text. 

• Change line text and paragraph text. 

• Convert line text to paragraph text. 

• Check the spelling of text. 

• Use an alternate text editor. 

• Working with text written in different languages. 

 

 

 
 

 

 

 
 

 

11 
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Creating line text 
 

Most commonly, lines of text are created using the Text command which creates sin- 

gle-line text entities. A line of text can also be created along an arc using the Arc- 

Aligned Text command. 

 

Creating a line of text 
When you create single-line text, you end each line of text by pressing Enter. Each 

line of text is created as a separate entity that you can modify. 
 

To create a line of text 

1 Do one of the following to choose Text (  ): 

• On the ribbon, choose Home > Text (in Annotation) or choose Annotate > Text 

(in Text). 

• On the menu, choose Draw > Text. 

• On the Draw toolbar, click the Text tool. 

• Type text and then press Enter. 

2 Specify the insertion point for the first character. 

3 Specify the height of the text. 

4 Specify the text rotation angle. 

5 Type the text, and then press Enter at the end of each new line. 

6 To complete the command, press Enter again. 

 
 

If you’ve already created text, new text can appear immediately below the previous text. 

Choose Insert > Text. When prompted for an insertion point, press Enter. The new 

text will keep the same height and rotation angle as the previous text. 
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Creating a single line of text along an arc 
You can create a single line of text positioned along an arc. Arc-aligned text is its 

own special type of text entity; it is not exactly the same as a single-line text entity. 
 

To create a line of text along an arc 

1 Do one of the following to choose Arc-Aligned Text (  ): 

• On the ribbon, choose Express Tools > Arc-Aligned Text (in Text). 

• On the menu, choose Express Tools > Text > Arc-Aligned Text. 

• Type arctext and then press Enter. 

2 Select the arc along which you want to align text. 

3 In Text, type the text. 

4 Select arc-aligned text options. 

5 Click OK. 

 

 
 

A Click to maintain the arrangement of text relative 
to the arc while moving the arc. 

B Click to reverse the text flow direction. 

C Click to align text to the left, right, fit (text fills the 
length of the arc), or center. 

D Select a text style. 

E Type the text to display along the arc. 

F Type the text font height. 

G Type the font width factor. 

H Type the spacing between characters. 

I Enter the spacing between text and the right 
edge of the arc. This option is not available when 
alignment is set to the right and to the center of 
the arc. 

J Enter the spacing between text and the left edge 
of the arc. This option is not available when 
alignment is set to the left and to the center of the 
arc. 

K Enter the spacing between arc and text. 

L Displays a sample of the text. 

M Click to orient text characters either outward from 
or inward to the center of the arc. 

N Click to set the text color to BYLAYER, 
BYBLOCK, one of the standard colors, or choose 
Select Color for more options. 

O Click to apply bold, italics, and underline to the 
text. 

P Click to place text either on the convex side of 
the arc or on the concave side of the arc. 

P 
O 

A 
B 
C 
D 
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G 

H 
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J 
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Creating paragraph text 
 

Paragraph text consists of one or more lines of text or paragraphs that fit within a 

boundary width that you specify. Each paragraph text entity you create is treated as a 

single entity regardless of the number of individual paragraphs or lines of text it 

contains. 

When you create paragraph text, you first determine the paragraph’s boundary width 

by specifying the opposite corners of a rectangle. The paragraph text automatically 

wraps so that it fits within this rectangle. The first corner of the rectangle determines 

the default attachment point of the paragraph text. You can determine the direction in 

which text flows within the rectangle, and you can also select the text and paragraph 

format, text style, text height, and the rotation angle of the entire paragraph text 

entity. 
 

To create paragraph text 

1 Do one of the following to choose Multiline Text ( ): 

• On the ribbon, choose Home > Multiline Text (in Annotate). 

• On the menu, choose Draw > Multiline Text. 

• On the Draw toolbar, click the Multiline Text tool. 

• Type mtext and then press Enter. 

2 Select the first corner of the text area. 

3 In the MTEXT prompt box, choose the properties you want to set, or proceed 

directly to the next step. You can also choose these properties later for the result- 

ing multiline text entity using the Properties pane. 

4 Select the second corner of the text area. 

5 Type the text you want. 

To create paragraphs, press Enter and continue typing. 

6 On the ribbon (or floating toolbar if not viewing the ribbon), use the Text Editor 

tools to make your selections for highlighted text, or if no text is highlighted, the 

changes affect new text when you type it. 

7 Click Close Editor to accept your changes and close the editor. 

 

 

 
     Text Style Select a text style. 

                   Text Height Select or type the text font height. 

Bold and Italics Click to bold and/or italicize text. 

 
 

Tool Name Description 
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Underline and 

                                      Overline 

Uppercase and 
                                      Lowercase 

Click to underline and/or overline text. 

 

Click to make text uppercase or lowercase. 

            Text Font Select the text font. 

Text Color Select BYBLOCK, BYLAYER, the color of 

your choice, or choose Select Color to 
select from additional colors. 

Background Mask Click to set the background settings for text. 

                                                                For more details, click Help in the dialog box 

that displays. 

   
          Oblique Angle Select or type the angle of text. 

Tracking Select or type the factor representing 
                                                                                 spacing between letters. 

   
          Width Factor Select or type the font width factor. 

Justification Select the text box justification. 

 
 

List Select the type of list for the text. You can 
                                                                                 also specify to continue or restart numbered 

lists. 

Line Spacing Select the spacing between lines. 

 

Default, Left, and 
                                Center 

Right, Justify, and 
                                Distribute 

Click to set the paragraph justification to 
default, left, or center. 

Click to set the paragraph justification to 
right, justify, or distribute. 

Undo and Redo Click to redo or undo the previous action. 
 
 

Symbol Click to insert a symbol where the cursor is 
                                                                                 located in the text editor. 

Insert Field Click to insert a field where the cursor is 

                                                                located in the text editor. For more details, 

click Help in the dialog box that displays. 

 
Columns Click to specify columns for the text, and 

                                                                                 options for the columns. For more details, 
click Help in the program. 

Find and Replace Click to find and replace text in the text 

                                                                editor. 

Import Text Click to select a file that contains text to 

                                                    import. 

AutoCAPS Click to turn on or off capitalizing text 
automatically as you type. 

 
 

Tool Name Description 
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Ruler Click to show or hide the ruler in the text 

                                                                                 editor. 

Stacked Text Click to stack or unstack selected text, for 

                                                                example, fractions can display as stacked 

text. 

 
More Click to display a menu of additional options, 

                                                                                 including the character set, settings for the 
text editor, and online help. 

Close Editor Accepts your changes and close the editor. 

 
 

 
 

Access more options by right-clicking the text editor. 

Right-click the text editor to access additional options, including Select All, Cut, 

Copy, and Paste. You can also use typical shortcuts such as Ctrl + V to paste text 

from the clipboard. 
 

 

 
 

 
 

A Click to accept your changes and close the 
editor. 

B Type and select text. 

C Click and drag to resize the editor vertically. 

D Click and drag to resize the editor horizontally. 

E Displays the ruler. 

 
 

There are two multiline text editors. 

The in-place text editor, described previously, has some missing features when com- 

pared with the older dialog box version. To switch to the dialog box version of the 

multiline text editor, set the MTEXTED system variable to "oldeditor". 
 

 

E 

A D 

B 

C 

Tool Name Description 
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Working with text styles 
 

When you add text to a drawing, it uses the current text style. Text style determines 

the font, size, angle, orientation, whether the text is annotative by default, and other 

characteristics. 

Every drawing has a default text style, named Standard, which initially uses the Arial 

font. You cannot delete the Standard style, but you can rename it or modify it. You 

can change the font, the size of the font, and the obliquing angle applied to it. If you 

change the font or orientation of an existing style, all existing text entities created 

using that style are automatically updated to reflect the new font or orientation. 

Changing any other characteristic has no effect on existing text. You also can create 

and use an unlimited number of additional text styles. 

The text style determines the characteristics shown in the following table. 

 
Style characteristic Default Description 

Style name Standard The name of the style, up to 255 characters. 

Font file Arial The font file on which the style is base, and whether Asian language big font files are used (for 
.SHX file fonts only). 

Language Western The character height. A value of 0 prompts for text height upon insertion. 

Annotative No Determines whether text is annotative by default and therefore its display and print is affected by 
annotation scaling. If annotative by default, also determines whether the text, when displayed in 
paper space, is oriented automatically according to the layout viewport. 

Text height 0 The character height. A value of 0 prompts for text height upon insertion. The text height is the 
paper text height if the text style is annotative. 

Width factor 1 The horizontal expansion or compression of the text. Values less than 1 compress the text; 
values greater than 1 expand the text. 

Obliquing angle 0 The slant of the text, in degrees. Negative values slant the text to the left; positive values slant 
the text to the right. 

Backward No Determines whether text appears backward. 

Upside down No Determines whether text appears upside down. 

Vertical No Determines whether text has a vertical orientation. 

 

To create a text style 

1 Do one of the following to choose Text Styles Manager (  ): 

• On the ribbon, choose Annotate > Text Styles Manager (in Text). 

• On the menu, choose Format > Text Styles Manager. 

• On the Format or Styles toolbar, click the Text Styles Manager tool. 

• Type style and then press Enter. 

2 Click New. 

3 Type a new text style name, then click OK. 
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4 Under Text Font, select the name, style, and language of the font you want to use. 

5 Under Text Measurements, select the check boxes if you want annotative text; you 

can also enter a Fixed Text Height (Paper Text Height if annotative), Width Fac- 

tor, or Oblique Angle measurement. 

6 Under Text Generation, select the check boxes you want to indicate the direction 

for printed text to appear. 

7 Click OK. 

8 To begin using the new style, choose Draw > Text. 

9 In the prompt box, select Use Defined Style. 

 

 

Formatting text 
 

When you create text, you choose the text style and set the alignment. The style deter- 

mines the font characteristics for the text. For single-line text, the alignment point 

determines how the text aligns with the text insertion point. For paragraph text, the 

alignment point determines the location of the attachment point in relation to the 

paragraph text boundary and the direction in which text flows within the boundary. 

You can also use the Express Tools > Text area for commands that scale text, justify 

text, enclose text in shapes, and more. All of these options are described in the online 

help. 

 

 
 

Setting the line text style 
You can set the text style before you specify the insertion point. You select the text 

style by typing the name of a previously defined style. 
 

To specify a line text style 

1 Do one of the following to choose Text (  ): 

• On the ribbon, choose Home > Text (in Annotation) or choose Annotate > Text 

(in Text). 

• On the menu, choose Draw > Text. 

• On the Draw toolbar, click the Text tool. 

• Type dtext and then press Enter. 

2 In the prompt box, choose Use Defined Style. 

3 Type the name of a previously defined text style, and then press Enter. 

To display a list of available text styles, type a question mark (?), and then press 

Enter. 

4 Specify the text insertion point. 
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5 Specify the text height. 

6 Specify the rotation angle. 

7 Type the text line, and then press Enter. 

8 To complete the command, press Enter again. 

 

Setting the paragraph text style 
You can set the paragraph text style before you specify the insertion point. You select 

the text style by typing the name of a previously defined style. 
 

To specify a paragraph text style 

1 Do one of the following to choose Multiline Text ( ): 

• On the ribbon, choose Home > Multiline Text (in Annotate). 

• On the menu, choose Draw > Multiline Text. 

• On the Draw toolbar, click the Multiline Text tool. 

• Type mtext and then press Enter. 

2 Specify the first point of the text box. 

3 In the prompt box, choose Text Style. 

4 Type the name of a previously defined text style, and then press Enter. 

5 Specify the text height. 

6 Specify the rotation angle. 

7 Specify the opposite corner of the text box. 

8 Type the text. 

9 To complete the command, click Close Editor. 
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Setting the line text alignment 
When you create text, you can set the text alignment before you specify the insertion 

point. You set the alignment by choosing it in the prompt box. By default, text is left 

justified. You can align text at the left, center, or right and at the top, middle, or base- 

line of the text or at the bottom of descending letters. 

 

 

 

 

 

 

 
 

H 

 
 

A Top left 

B Middle left 

C Left 

D Bottom left 

E Center 

F Bottom center 

G Bottom right 

 
H Baseline 

I Right 

J Middle right 

K Top right 

L Middle 

M Middle center 

N Top center 

You can also align text so that it fits or aligns between two points. The Align option 

creates text that scales up or down while maintaining a constant height/width ratio; 

the Fit option expands or compresses the text to fit between the two points. 

 

 

 

Text aligned between two points maintains a 
constant height/width ratio. 

Text fit between two points expands or compresses 
to fit. 

To specify the line text alignment before entering text 

1 Do one of the following to choose Text (  ): 

• On the ribbon, choose Home > Text (in Annotation) or choose Annotate > Text 

(in Text). 

• On the menu, choose Draw > Text. 

• On the Draw toolbar, click the Text tool. 

• Type dtext and then press Enter. 

2 In the prompt box, choose an alignment option, or choose Justification Options to 

display all the justification options. 
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3 Specify the text insertion point, and then continue creating the line text. 
 

To specify the justification for existing line text entities 

1 Do one of the following to choose Justify Text (  ): 

• On the ribbon, choose Express Tools > Justify Text (in Text > Modify Text). 

• On the menu, choose Express Tools > Text > Justify Text. 

• Type tjust and then press Enter. 

2 Select text entities. In addition to single-line text, you can also choose multiline 

text and attribute text. 

3 Choose one of the following: 

• Center Justification point of the text is center aligned. 

• Middle Justification point of the text is middle aligned (left/right and top/ 

bottom). 

• Right Justification point of the text is right aligned. 

• TL Justification point of the text is top-left aligned. 

• TC Justification point of the text is top-center aligned. 

• TR Justification point of the text is top-right aligned. 

• ML Justification point of the text is middle-left aligned. 

• MC Justification point of the text is middle-center aligned. 

• MR Justification point of the text is middle-right aligned. 

• BL Justification point of the text is bottom-left aligned. 

• BC Justification point of the text is bottom-center aligned. 

• BR Justification point of the text is bottom-right aligned. 

To fit existing line text within two points 

1 Do one of the following to choose Text Fit (  ): 

• On the ribbon, choose Express Tools > Fit Text (in Text > Modify Text). 

• On the menu, choose Express Tools > Text > Fit Text. 

• Type textfit and then press Enter. 

2 Select single-line text entities. 

3 Specify a new desired ending point or choose Start Point to specify a new starting 

point and then specify the ending point. 

 
 

The Text Fit command works with single-line text only. 

To fit multiline text within two points, first use the Explode command to convert it to 

single-line text. 
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To change the scale of existing line text 

1 Do one of the following to choose Scale Text ( ): 

• On the ribbon, choose Express Tools > Scale Text (in Text > Modify Text). 

• On the menu, choose Express Tools > Text > Scale Text. 

• Type scaletext and then press Enter. 

2 Select single-line text entities. 

3 Choose a base point option for scaling. 

4 Choose one of the modes of scaling text and follow the prompts. Refer to online 

help for more details. 

 

Setting the paragraph text alignment 
When you create paragraph text, you can set the text alignment by specifying the 

direction in which text flows within the boundary. You can set the paragraph text 

alignment either in the prompt box displayed after you specify the first corner of the 

paragraph text boundary, from the Properties pane, or using the Justify Text express 

tool command. You can specify the attachment point at the top left, top center, top 

right, middle left, middle center, middle right, bottom left, bottom center, or bottom 

right. The paragraph text can flow left to right, right to left, top to bottom, or bottom 

to top. You can change the scale of existing paragraph text using the Scale Text 

express tool command. 

 

Including special text characters 

You can use control codes to overscore or underscore text or to include special char- 

acters. Both overscore and underscore can be active at the same time. To include con- 

trol codes, as you type text, type two percent symbols (%%) followed by the special 

control code or character. A single percent sign is treated as a normal text character. 

A triple-percent control code is provided for those instances where a control-code 

sequence must follow a percent sign in the text. 

 
 

Special text characters 
 

 
%%o Toggles overscore mode on and off. 

%%u Toggles underscore mode on and off. 

%%d Draws a degree symbol (º). 

%%p Draws the plus-or-minus symbol (±). 

%%c Draws the circle diameter symbol (Ø). 

%%% Forces a single percent sign. 

%%nnn Draws special character number nnn. 
 

 

Control code Function 
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Text created using special text characters: Ut wisi %%uenim%%d ad%%p%%u minim %%c %%oveniam. 
 

Creating a frame around text 
You can draw a frame around each selected line text, paragraph text or attribute text, 

that is enclose text with shape. Frames can be in the shape of a circle, rectangle or a 

slot. 
 

To draw a frame around text 

1 Do one of the following to choose Enclose Text with Shape ( ): 

• On the ribbon, choose Express Tools > Enclose Text with Shape (in Text > 

Modify Text). 

• On the menu, choose Express Tools > Text > Enclose Text with Shape. 

• Type tcircle and then press Enter. 

2 Select line text, paragraph text or attribute text. 

3 Specify which shape you want to draw around text. Refer to online help for more 

details. 
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Changing text 
 

You can change line and paragraph text in your drawing. 

 

Changing line text 
You can edit and modify the text as you would any other drawing entity. That is, you 

can delete, move, rotate, and scale text. 
 

To edit text and its properties 

1 Do one of the following to choose Edit Text (  ): 

• On the ribbon, choose Annotate > Edit Text (in Text). 

• On the menu, choose Modify > Entities > Text. 

• On the Modify toolbar, click the Edit Text tool. 

• Type ddedit and then press Enter. 

2 Select the text entity. 

3 In the Text dialog box, edit the text. 

4 Change the text properties you want. 
 

 

The Text dialog box displays when EDITTEXTMODE is set to 3 (the default). 

If the TEXTEDITMODE system variable is set to 1 or 2, line text is edited in the com- 

mand bar or Properties pane respectively instead of the Text dialog box. 
 

 

 

Changing paragraph text 
You can modify the text as you would any other drawing entity. That is, you can 

delete, move, rotate, and scale text. 
 

To edit paragraph text and its properties 

1 Do one of the following to choose Edit Text (  ): 

• On the ribbon, choose Annotate > Edit Text (in Text). 

• On the menu, choose Modify > Entities > Text. 

• On the Modify toolbar, click the Edit Text tool. 

• Type ddedit and then press Enter. 

2 Select the text entity. 

3 In the text editor, edit the text. 

4 Change the text properties you want. 

5 Click Close Editor. 
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Finding and replacing text 
You can search and optionally replace text throughout a drawing, within a layout, or 

within selected entities. 

4MCAD searches and displays a list of matching text. Each found text item has an 

associated entity type to help you identify its location in the drawing. Entity types can 

include single-line text, multiline text, dimension leaders, hyperlinks, alternate text, 

paperspace and modelspace. Note that some types of dimension leaders are listed as 

multiline text because of the way dimensions are created. 

Any replacements made to the text are visible in the drawing after you click Done. 
 

To find an optionally replace text 

1 Do one of the following to choose Find and Replace (  ): 

• Choose Edit > Find and Replace. 

• On the Standard toolbar, click the Find and Replace tool. 

• Type find and then press Enter. 

2 In Find What, type the text you want to search for, or select previously entered text 

from the list. 

3 In Find Where, select the location where you want to search: 

• Entire drawing Searches the entire drawing. 

• Current layout Searches the current layout only. 

• Selected entities Searches selected entities only. You can click (  ) to switch 

to the drawing temporarily and select entities. 

4 In Text Types, select the text types you want to include in the search. 

5 In Search Options, select the desired search options. 

6 Click Find to displays a list of all matching text. 

7 To replace text, do the following: 

• In Replace With, enter or select the new text. 

• In the list of found text, select the text to replace. 

• Click Replace. 

 
 

Use a shortcut for replacing text. 

Click Replace All to replace all matching text without finding it first. 
 

 

8 Click Done to view text changes (if any) in the drawing. 
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A Type or select the text to find. 

B Type or select the text to replace found text with 
(optional). 

C Displays all found text. 

D Select to find only text that matches the upper and 
lower case specified in Find What. 

E Select to find only whole words that match the text in 
Find What. 

F Select to include external references in the search. 

G Select to include blocks in the search. 

H Click to replace selected text in the Location list with 
text from Replace With. 

I Click to replace all matching text without searching 
first. 

J Click to find matching text. 

K Click when finished and to see changes in the 
drawing. 

L Select to search block attribute values. 

M Select to search both dimension and leader text. 

N Select to search both single-line and multiline text. 

O Select to search hyperlinks. 

P Select to search hyperlink descriptions. 

Q Select where to search for text: the entire drawing, 
the current layout, or selected entities. 

R Click to switch to the drawing and select entities to 
search. 
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Changing capitalization of letters 
You can quickly change the capitalization of single-line and multiline text entities to 

these capitalization methods: sentence case, all lower case, all uppercase, title case, 

and toggle case. 
 

To set capitalization formatting 

1 Do one of the following to choose Change Text Case (  ): 

• On the ribbon, choose Express Tools > Change Text Case (in Text > Modify 

Text). 

• On the menu, choose Express Tools > Text > Change Text Case. 

• Type tcase and then press Enter. 

2 Select text entities. 

3 Choose one of the following: 

• Sentence case The first letter of the first text character is upper case. 

• lowercase All text characters are lower case letters. 

• UPPERCASE All text characters are upper case letters. 

• Title The first letters of all text characters are upper case. 

• tOGGLE cASE The first letters of all text characters are lower case and the rest 

of the letters are upper case. 

 

Converting line text to paragraph text 
When converting line text to paragraph text, one or more text entities created with the 

Text command are combined into one multiline text entity. During the conversion, 

the selected text entities are removed from the drawing and a multiline text entity is 

created. 
 

To convert line text to paragraph text 

1 Do one of the following to choose Text to Multiline Text (  ): 

• On the ribbon, choose Home > Text to Multiline Text (in Annotation), 

Annotate > Text to Multiline Text (in Text) or Express Tools > Text to Multiline 

Text (in Text). 

• On the menu, choose Draw > Text to Multiline Text or choose Express Tools > 

Text > Text to Multiline Text. 

• On the Text toolbar, click the Text to Multiline Text tool. 

• Type txt2mtxt and then press Enter. 

2 Select one or more text entities. 

3 When finished with selection, press Enter. 
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To customize options while converting line text to paragraph text 

1 Do one of the following to choose Text to Multiline Text (  ): 

• On the ribbon, choose Home > Text to Multiline Text (in Annotation), 

Annotate > Text to Multiline Text (in Text) or Express Tools > Text to Multiline 

Text (in Text). 

• On the menu, choose Draw > Text to Multiline Text or choose Express Tools > 

Text > Text to Multiline Text. 

• On the Text toolbar, click the Text to Multiline Text tool. 

• Type txt2mtxt and then press Enter. 

2 Press Enter. 

3 Select one of the following: 

• Selection set order Select to add single-line text to multiline text in the order 

that you select. 

• Top-down order Select to add single-line text to multiline text in the order that 

they appear in the drawing, from the top downwards. 

4 Mark Create Word-Wrap MText to add spaces within individual lines of text, 

which helps balance multiple lines of text. 

5 Click OK. 

6 Select one or more text entities. 

7 When finished with selection, press Escape. 

All text entities are combined into a single multiline text entity. 

 
 

 
 

A 
 

B 

 

 
A Choose to add text in the order selected or in top- 

down order. 
B Click to add spaces within text lines to balance 

multiple lines of text. 
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Checking the spelling 
 

You can check the spelling of text in your drawing, customize the dictionary to recog- 

nize new words, and use a different spelling dictionary that supports another lan- 

guage. 

 

Checking the spelling of text 
You can use the Check Spelling command to check the spelling of single-line text, 

multiline text, paragraph text, attributes, attribute definitions, and dimension text. 
 

To check the spelling of text 

1 Do one of the following to choose Check Spelling (  ): 

• On the ribbon, choose Annotate > Check Spelling (in Text). 

• On the menu, choose Tools > Check Spelling. 

• On the Standard toolbar, click the Check Spelling tool. 

• Type spell and then press Enter. 

2 Select one or more text entities. 

3 In the Check Spelling dialog box, misspelled words display one at a time. Do one 

of the following for each found word: 

• Keep text unchanged — Click Ignore to keep the found word unchanged in the 

drawing, or click Ignore All to keep all instances of the found word unchanged 

in the drawing. 

• Change text — Select or type a word in the Suggestions box, then click Change 

to change the found word in the drawing to the new text, or click Change All to 

change all instances of the found word in the drawing. 

4 Click Add if you want to add the currently found word to a list of custom spelling 

words. The Check Spelling dialog will recognize the added word as spelled cor- 

rectly the next time the word is checked for spelling. 
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A Displays the current dictionary. 

B Displays the misspelled word and its context in the 
drawing. 

C Displays (or you can type) a new word to replace the 
misspelled word in the drawing. 

D Click to select a new word to replace the currently 
found misspelled word. 

E Click to select a new dictionary or modify a custom 
dictionary. 

F Click to add the suggested word to the custom 
dictionary. 

G Click to suggest additional words based on the 
selected word in the Suggestions list. 

H Click to change all instances of the misspelled word 
to the suggested word. 

I Click to change a single instance of the misspelled 
word to the suggested word. 

J Click to skip all instances of the misspelled word. 

K Click to skip a single instance of the misspelled word 
without changing it. 

 

Customizing the spelling words 
Most drawings contain text that is not recognized as spelled correctly, even though it 

is spelled correctly. For example, if your company name Zaffer, Inc. appears in all of 

your drawings, the company name will appear as misspelled every time you check the 

spelling of drawing text. You can easily add words to a custom dictionary so that any 

word in the custom dictionary is recognized as spelled correctly. 

The custom dictionary is independent of any spelling dictionary you have chosen to 

use. You can check the spelling of text using one dictionary, check the spelling of the 

same or other text using a different dictionary, and in both cases your custom diction- 

ary is used. 
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To create and manage a custom dictionary 

1 Do one of the following to choose Check Spelling (  ): 

• On the ribbon, choose Annotate > Check Spelling (in Text). 

• On the menu, choose Tools > Check Spelling. 

• On the Standard toolbar, click the Check Spelling tool. 

• Type spell and then press Enter. 

2 Select one or more text entities. 

3 In the Check Spelling dialog box, click Change Dictionaries. 

4 To add a custom word, type a word in Custom Dictionary Words, then click Add. 

5 To delete a custom word, select a word in Custom Dictionary Words, then click 

Delete. 

6 Click OK. 

 

 

A Type a word for the custom dictionary. 

B Displays the words in the custom dictionary. 

C Click to delete the currently selected word from the 
custom dictionary. 

D Click to add the current word in the edit box (A) to the 
custom dictionary. 

E Click to select a different custom dictionary. 

F Displays the custom dictionary filename. You can 
type a new path and filename or click Browse to 
select a file. 

 
 

You can also add custom words to the custom dictionary during spell checking of text. 

In the Check Spelling dialog box, click Add to add the currently found word to the 

custom dictionary. 
 

 

F 

E 

A 

B 

D 

C 
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Changing the dictionary 
The Check Spelling command compares text found in the drawing with correctly 

spelled words in an installed dictionary (.dic file). There are many different dictionar- 

ies that can be used with 4MCAD, including dictionaries in different languages. 

You can download and install a new dictionary or use a dictionary already installed 

on your computer. 
 

To download and install a new dictionary 

1 Do one of the following to choose Check Spelling (  ): 

• On the ribbon, choose Annotate > Check Spelling (in Text). 

• On the menu, choose Tools > Check Spelling. 

• On the Standard toolbar, click the Check Spelling tool. 

• Type spell and then press Enter. 

• On the ribbon, choose Annotate > Check Spelling (in Text). 

2 Select one or more text entities, then in the Check Spelling dialog box, click 

Change Dictionaries. 

3 Click Download. 

4 From the web page that displays (or from a different web page), download the 

desired dictionary. 

5 Unzip the contents of the downloaded file to \MyDocuments\Spelling, or the loca- 

tion where you installed spelling dictionaries for 4MCAD. 

6 Click Change Dictionaries again, which will load the newly installed dictionary. 

7 In Main Dictionary, select the desired dictionary. 

8 Click OK. 
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A 

B 

 
 
 
 
 
 
 
 
 
 
 
 

 
A Select the desired spelling dictionary. B Click to open the default Internet browser to a web 

page where you can download spelling dictionaries in 
different languages. 

 

To use a dictionary already installed on your computer 

1 Do one of the following: 

• Copy the existing dictionary (.dic file) to \MyDocuments\Spelling, or to the 

location where you install spelling dictionaries for 4MCAD. 

• Add the folder of the existing dictionary to the list of folders where 4MCAD 

searches for dictionaries. Choose Tools > Options, click Paths/Files and add the 

folder location to the Dictionary paths. For more details, see “Changing the 

options on the Paths/Files tab” on page 680. 

2 Choose Tools > Check Spelling, select one or more text entities, then in the 

Check Spelling dialog box, click Change Dictionaries. 

3 In Main Dictionary, select the desired dictionary. 

4 Click OK. 
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Using an alternate text editor 

 
4MCAD includes a built-in text editor for creating paragraph text using the Multi- 

line Text command. You can also specify an alternate text editor for the Multiline 

Text command. 

 

Selecting an alternate text editor 
Before you can use an alternate text editor, you must specify the editor by setting the 

MTEXTED system variable. 
 

To select an alternate text editor 

1 Type mtexted and then press Enter. 

2 Enter the path and name of the executable file for the text editor you want to use to 

create or edit multiline text. For example, to use Microsoft® Wordpad, you would 

type something similar to the following (adjusting the path name as necessary): 

C:\Program    Files\Windows\Accessories\Wordpad.exe 

 

Creating paragraph text in an alternate text editor 
After you set up 4MCAD to use an alternate text editor, you can start using it to 

include text in your drawings. 
 

To use an alternate text editor 

1 Do one of the following to choose Multiline Text ( ): 

• On the ribbon, choose Home > Multiline Text (in Annotate). 

• On the menu, choose Draw > Multiline Text. 

• On the Draw toolbar, click the Multiline Text tool. 

• Type mtext and then press Enter. 

2 Select the first and second corners of the text area. 

3 In the text editor, type the text you want, using the special characters from the 

table shown next to achieve special formatting. Enter \P to end a paragraph and 

start a new paragraph on the next line. For example, to use an alignment value of 1 

and stack two numbers to display them as a fraction: 

{\A1;\S1/2;}\P 

4 When your text is complete, save the changes and exit the text editor. 
 

 
\0...\o Toggles overscore mode on and off. 

\L...\l Toggles underscore mode on and off. 

\~ Inserts a nonbreaking space. 

\\ Inserts a backslash. 
 

 

Special format character Function 
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\{...\} Inserts an opening and closing brace. 

\Cvalue; Sets the color to a specified value. 

\File name; Sets the font based on a specified font file name. 

\Hvalue; Sets the text height to a specified value. 

\Hvaluex; Sets the text height to a multiple of the current text height. 

\S...^...; Stacks the subsequent text at the /, #, or ̂  symbol. 

\Tvalue; Adjusts the space between characters, from 0.75 to 4 times. 

\Qangle; Changes obliquing angle. 

\Wvalue; Changes width factor to produce wide text. 

\A Sets the alignment value. 

\P Ends paragraph. 

\p[i],[l],[tX1,X2,...,X32] Formats paragraph: i = first line indent; l = paragraph offset; t = tab 
positions. 

 
 

 
 
 

Working with text written in different languages 
 

You can include text in your drawings that is written in different languages. 

 

Using Unicode characters 
4MCAD supports the Unicode character encoding standard, which enables you to 

display and write text in different languages using different letters. Unicode fonts 

contain many more characters than typically defined in a system. The following table 

describes only a small set that is available 

 

 
\U+00B0 Draws a degree symbol (º). 

\U+00B1 Draws the plus-or-minus symbol (±). 

\U+0394 Draws the delta symbol (Δ). 

\U+2205 Draws the circle diameter symbol (Ø). 

\U+03A9 Draws the omega symbol (Ω). 

\U+2260 Draws the not equal symbol (≠). 
 

 

 

For details about using other special characters, see “Including special text charac- 

ters” on page 412 in this chapter. You can also use a different text editor; see “Using 

an alternate text editor” on page 424 in this chapter. 

Unicode control code Function 

Special format character Function 



426 C H A P T E R   1 1  
 

 
Specifying character sets for drawings 
The character set used to display text in drawings typically depends on the character 

set specified by your operating system, for example, ANSI_1252 is Latin 1, 

ANSI_1253 is Greek, and ANSI_1254 is Turkish. This is also called the code page. 

4MCAD allows you to manage which code page is assigned to a drawing. This 

unique feature is usually not necessary if you distribute drawings within the same 

geographic region, but it can be very helpful when sharing or distributing drawings 

between different geographic regions. Changing the code page is highly desirable 

especially in geographic regions where several languages are used that require differ- 

ent character sets to display text properly. 

Setting the code page doesn’t change the language of your text; instead it specifies 

the character set in which the text displays. Some fonts can display its characters sev- 

eral different ways depending on the code page setting. 

There are two system variables that relate to the code page of a drawing: 

• SYSCODEPAGE — Character set defined for your operating system. 

• DWGCODEPAGE — Character set defined for an individual drawing that over- 

rides the operating system code page. 

 

To select a code page for the current drawing 

1 Type codepage and then press Enter. 

The Code Page Manager dialog box opens. 

2 If you want to convert the drawing to use a code page that is different from the 

operating system code page, in Drawing Code Page, select the new code page for 

the drawing. 

3 Click OK. 

 

 

 
A 

B 

 
 

 
A Displays the code page for the operating system. B Select the code page for the current drawing. 



 

 
 

 
 
 
 
 

Dimensioning your drawing 
 

The 4MCAD dimensioning tools let you add measurements to a drawing. You can 

quickly add dimensions by simply pointing to entities. You can also add tolerance 

symbols to your drawings. 

The program’s many dimensioning variables let you control the appearance of the 

dimensions. With dimension styles, you can save dimension variable settings so you 

can reuse them without having to re-create them. 

This section explains how to: 

• Create dimensions as linear, angular, arcs, diametral, radial, and ordinate. 

• Create leaders and annotations. 

• Edit dimensions. 

• Use dimension styles and variables. 

• Add geometric tolerances. 

• Control dimension tolerance. 

• Control alternate dimension units. 

 

 

 
 

 

 

 
 

 

12 
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Understanding dimensioning concepts 

You can create five basic types of dimensions: linear, angular, radial, diametral, and 

ordinate. You can create dimensions for existing entities by selecting them, or you 

can create dimensions by selecting points within a drawing. For example, you can 

create a linear dimension either by selecting the entity to be dimensioned or by speci- 

fying the first and second extension line origins. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A Radial dimension. 

B Vertical linear dimension. 

C Angular dimension. 

D Linear continued dimensions. 

 
 

 
 
 

 
 
 

 
 
 

 
 
 

 
 
 

 
 
 

 
 
 

 
 

E Aligned dimension. 

F Diametral dimension. 

G Horizontal linear dimension. 

H Linear baseline dimension. 

When you create a dimension, the program draws it on the current layer, using the 

current dimension style. Each dimension has a corresponding dimension style, which 

controls the appearance of the dimension, such as the types of arrowheads, text style, 

and colors of various components. You can modify existing dimension styles by 

changing one of the dimension variable settings and then updating the dimension 

style to reflect the new settings. 

Each dimension you create consists of several parts. A dimension line shows where a 

dimension begins and ends. When you create an angular dimension, the dimension 

line is a dimension line arc that subtends the measured angle. 

A 
F 

H E 

B 

C 

G 

D 
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Extension lines, also called projection lines, are lines that extend away from the entity 

for which you are creating a dimension, so that you can place the dimension line 

away from the entity. Arrowheads form the termination at each end of the dimension 

line. 

Dimension text contains the measured dimension and can also include prefixes, suf- 

fixes, tolerances, and other optional text. As you insert dimensions, you can control 

the dimension text and specify its position and orientation. 

 

 

 
A Extension line. 

B Arrowhead. 

C Dimension line. 

D Dimension text. 

Dimensions can also contain other optional components. A leader is a line leading 

from a feature of the drawing to an annotation. Leaders begin with an arrowhead, and 

you can use them to place a dimension away from the dimension line or to add notes. 

When you create a radial dimension, you can add a center mark, which is a small 

cross that marks the center of a circle or an arc, or you can add centerlines, which are 

crossing lines that extend out from the center of a circle or an arc. 

 
 

 
Leader. Center mark. Centerlines. 

Dimensions can be one of three types: 

• Associative — A dimension is linked with the entities it measures. If the entities 

being measured by the dimension are modified, the dimension is updated automat- 

ically. Newly created dimensions are associative when DIMASSOC is set to 2 

(default) and created using entity snaps. 
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• Non-associative — A dimension is not linked with the entities it measures. If the 

entities being measured by the dimension are modified, the dimension is not 

updated automatically. Newly created dimensions are non-associative when 

DIMASSOC is set to 1. 

• Exploded — Dimensions are created as separate entities, not a single dimension 

entity. Newly created dimensions are exploded when DIMASSOC is set to 0. 

 
 

 

Creating dimensions 
 

You can create dimensions by: 

• Selecting the entity to dimension and specifying the dimension line location. 

• Specifying the extension line origins and the dimension line location. 

When you create dimensions by selecting an entity, the program automatically places 

the extension line origins at the appropriate definition points based on the type of 

entity you select. For example, the definition points are located at the endpoints of 

arcs, lines, and polyline segments. When you create dimensions by specifying the 

extension line origins, the points you specify determine the definition points. To 

establish these points precisely, use entity snaps. 

You can create dimensions in model space or paper space. 

 

Creating linear dimensions 
Linear dimensions annotate linear distances or lengths and can be oriented horizon- 

tally, vertically, or aligned parallel to an existing entity or to the selected extension 

origin points. After you create a linear dimension, you can add a baseline dimension 

or a continued dimension. A linear baseline dimension inserts an additional dimen- 

sion from a common first extension line origin of a previous linear dimension. A lin- 

ear continued dimension continues a linear dimension from the second extension line 

of a previous linear dimension. 

 
 

Selecting exact points is important when creating dimensions. 

Use entity snaps to select precise ordinate points. 
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To create a horizontal or vertical dimension 

1 Do one of the following to choose Linear ( ): 

• On the ribbon, choose Annotate > Linear (in Dimensions). 

• On the menu, choose Dimensions > Linear. 

• On the Dimensioning toolbar, click the Linear tool. 

• Type dimlinear and then press Enter. 

2 Press Enter, and then select the entity to dimension. 

Or, you can insert the dimension by specifying the first and second extension line 

origins. 

3 Specify the dimension line location. 

 
 

 
To insert a linear dimension by selecting the entity, select 
the entity (A) to dimension, and then specify the 
dimension line location (B). 

Result. 

 

 
To insert a linear dimension by selecting the extension 
line origins, select the first extension origin (A), select the 
second extension origin (B), and then specify the 
dimension line location (C). 

Result. 

 

B 

A 
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To create an aligned dimension 

1 Do one of the following to choose Aligned ( ): 

• On the ribbon, choose Annotate > Aligned (in Dimensions). 

• On the menu, choose Dimensions > Aligned. 

• On the Dimensioning toolbar, click the Aligned tool. 

• Type dimaligned and then press Enter. 

2 Press Enter, and then select the entity to dimension. 

Or, you can insert the dimension by specifying the first and second extension line 

origins. 

3 Specify the dimension line location. 

 
 

 
To insert an aligned dimension by selecting the entity, select 
the entity (A) to dimension, and then select the dimension line 
location (B). 

Result. 

 

 
To insert an aligned dimension by selecting the extension line 
origins, select the first extension origin (A), select the second 
extension origin (B), and then specify the dimension line location 
(C). 

Result. 

B 

A 
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To create a linear baseline dimension 

1 Create a dimension. 

2 Do one of the following to choose Baseline (  ): 

• On the ribbon, choose Annotate > Baseline (in Dimensions). 

• On the menu, choose Dimensions > Baseline. 

• On the Dimensioning toolbar, click the Baseline tool. 

• Type dimbaseline and then press Enter. 

3 To select a starting dimension, press Enter. 

4 Select the next extension line origin, and then press Enter. 

Or press Enter, and then select an existing dimension for the baseline. Select the 

origin of the next extension line, and then press Enter. 

The program automatically places the new baseline dimension above or below the 

previous dimension line. The distance between the two dimension lines is determined 

by the Baseline Offset value in the Dimension Styles dialog box. 

 
 

 
To add a baseline dimension to an existing linear dimension, select the existing dimension (A), select the 
next extension line origin (B), and select as many additional points as you want (C). 

 

 
Result. 
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To create a linear continued dimension 

1 Create a dimension. 

2 Do one of the following to choose Continue (  ): 

• On the ribbon, choose Annotate > Continue (in Dimensions). 

• On the menu, choose Dimensions > Continue. 

• On the Dimensioning toolbar, click the Continue tool. 

• Type dimcontinue and then press Enter. 

3 To select a starting dimension, press Enter. 

4 Select the next extension line origin, and then press Enter. 

Or press Enter, and then select an existing dimension to continue. 

5 To add continued dimensions, continue selecting extension line origins. 

6 To end the command, press Enter twice. 
 

 
To add a continued dimension to an existing linear dimension, select the existing dimension (A), select the 
next extension line origin (B), and select another extension line origin (C). 

 

 
Result. 
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Creating angular dimensions 
Angular dimensions annotate the angle measured between two lines. You can also 

dimension an angle by selecting an angle vertex and two endpoints. After you create 

an angular dimension, you can add a baseline dimension or a continued dimension. 

An angular baseline dimension inserts an additional dimension from a common first 

extension line origin of a previous angular dimension. An angular continued dimen- 

sion continues an angular dimension from the second extension line of a previous 

angular dimension. 
 

To dimension an angle encompassed by an arc 

1 Do one of the following to choose Angular (  ): 

• On the ribbon, choose Annotate > Angular (in Dimensions). 

• On the menu, choose Dimensions > Angular. 

• On the Dimensioning toolbar, click the Angular tool. 

• Type dimangular and then press Enter. 

2 Select the arc. 

3 Specify the dimension arc location. 

 
 

 
To dimension the angle subtended by an arc, select 
the arc (A), and then specify the dimension arc 
location (B). 

Result. 

 

B 
 
 

A 
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To dimension an angle between two lines 

1 Do one of the following to choose Angular (  ): 

• On the ribbon, choose Annotate > Angular (in Dimensions). 

• On the menu, choose Dimensions > Angular. 

• On the Dimensioning toolbar, click the Angular tool. 

• Type dimangular and then press Enter. 

2 Select one line. 

3 Select the other line. 

4 Specify the dimension line location. 

 
 

 
Select one line (A), select the other line (B), and then 
specify the dimension line location (C). 

Result. 

 

C 

B 

 
A 
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Creating arc dimensions 
Arc dimensions annotate the length of an arc or arc segment. You can also dimension 

a portion of an arc by selecting two points. After you create an arc dimension, you 

can change its text to the arc angle or to any other text. 
 

To dimension an arc length 

1 Do one of the following to choose Arc (  ): 

• On the ribbon, choose Annotate > Arc (in Dimensions). 

• On the menu, choose Dimensions > Arc. 

• On the Dimensioning toolbar, click the Arc tool. 

• Type dimarc and then press Enter. 

2 Select the arc or arc segment. 

3 Specify the dimension arc location. 

 
 

 
To dimension the length of an arc, select the arc (A), 
and then specify the dimension arc location (B). 

Result. 

 

To dimension part of an arc length 

1 Do one of the following to choose Arc (  ): 

• On the ribbon, choose Annotate > Arc (in Dimensions). 

• On the menu, choose Dimensions > Arc. 

• On the Dimensioning toolbar, click the Arc tool. 

• Type dimarc and then press Enter. 

2 Choose Partial. 

3 Select the start point of the arc length you want to measure. 

4 Select the end point. 

B 
 
 

A 
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To dimension part of an arc length, select the arc (A), 
select the start point (B) and end point (C) of the 
portion to measure, then specify the dimension arc 
location (D). 

Result. 

 

Creating diametral and radial dimensions 
Diameter and radius dimensions annotate the radii and diameters of arcs and circles. 

You can optionally include centerlines or center marks. 
 

To create a diametral dimension 

1 Do one of the following to choose Diameter (  ): 

• On the ribbon, choose Annotate > Diameter (in Dimensions). 

• On the menu, choose Dimensions > Diameter. 

• On the Dimensioning toolbar, click the Diameter tool. 

• Type dimdiameter and then press Enter. 

2 Select the arc or circle. 

3 Specify the dimension line location. 

 
 

 
Select the circle (A), and then specify the dimension 
line location (B). 

Result. 

A B 
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To create a radial dimension 

1 Do one of the following to choose Radius (  ): 

• On the ribbon, choose Annotate > Radius (in Dimensions). 

• On the menu, choose Dimensions > Radius. 

• On the Dimensioning toolbar, click the Radius tool. 

• Type dimradius and then press Enter. 

2 Select the arc or circle. 

3 Specify the dimension line location. 

 
 

 
Select the circle (A), and then specify the dimension line 
location (B). 

 

Creating ordinate 
dimensions 

Result. 

An ordinate dimension annotates the perpendicular distance from an origin or base 

point (the origin of the current user coordinate system [UCS]). Ordinate dimensions 

consist of an x- or y-coordinate and a leader. An x-ordinate dimension measures dis- 

tances along the x-axis; a y-ordinate dimension measures distances along the y-axis. 

As you select ordinate points, the program automatically determines whether the 

point is an x- or y-ordinate based on which direction you drag the second point. You 

can also specify whether the ordinate represents an x- or y-ordinate. Ordinate dimen- 

sion text is always aligned with the ordinate leader lines, regardless of the text orien- 

tation specified by the current dimension style. 

 

 
Ordinate dimensions measure the distance along the x- or y-axis from an origin to a selected ordinate point. 

A B 
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To create an ordinate dimension 

1 Do one of the following to choose Ordinate (  ): 

• On the ribbon, choose Annotate > Ordinate (in Dimensions). 

• On the menu, choose Dimensions > Ordinate. 

• On the Dimensioning toolbar, click the Ordinate tool. 

• Type dimordinate and then press Enter. 

2 Select the point for ordinate dimension. 

3 Specify the ordinate leader endpoint. 

 
 

 
Select the ordinate point (A), and then specify the ordinate leader endpoint (B). 

 
 

Selecting exact points is important when creating dimensions. 

Use entity snaps to select precise ordinate points. 
 

 

 

Creating leaders and annotations 
Leaders consist of a line or series of lines that connects a feature in a drawing to an 

annotation. Generally, you place an arrowhead at the first point. An annotation, cre- 

ated as dimension text, is placed immediately adjacent to the last point. By default, 

the text placed at the end of the leader line consists of the most recent dimension. You 

can also type an annotation as a single line of text. 
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To create a leader and an annotation 

1 Do one of the following to choose Leader (  ): 

• On the ribbon, choose Annotate > Leader (in Dimensions). 

• On the menu, choose Dimensions > Leader. 

• On the Dimensioning toolbar, click the Leader tool. 

• Type dimleader and then press Enter. 

2 Specify the starting point of the leader. 

3 Specify the endpoint of the leader line segment. 

4 Specify additional leader line segment endpoints. 

5 After you specify the last endpoint, press Enter. 

6 Type the annotation, or press Enter to accept the most recent dimension as the 

default annotation. 

 
 

 
Specify the starting point of the leader (A) 
and the endpoint of the leader line segment 
(B). 

Result. 

 

Dimensioning model space entities in paper space 
To increase efficiency, you can separate your drawing model from annotations using 

the Model and Layout tabs. 

It takes time to display dimensions, title blocks, keynotes, and other annotations. If 

you draw these on a Layout tab, display-time and visual clutter are reduced when you 

work on your model (on the Model tab). 4MCAD allows you to dimension model 

space entities on either the Model tab or a Layout tab — you can make the choice 

depending on the method that works best for your needs. 

 

B 

A  
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To dimension model space entities in paper space 

1 Click a Layout tab. 

2 Create at least one layout viewport. For details, see “Creating layout viewports” 

on page 527. 

3 Lock the desired layout viewport by doing the following: 

• Right-click the edge of the layout viewport that you want to use for creating 

dimensions. 

• Choose Properties. 

• Mark Lock Viewport, and then click OK. 

Locking the viewport is not required, but it is extremely helpful when you zoom or 

pan in the layout viewport; it prevents the viewport scale and view center from 

changing. 
 

 

You can work in a layout viewport without having it clutter your display or selections. 

Place layout viewports on their own layer, and after locking the layout viewports, 

hide the layer that contains them. 
 

 

 

4 Make sure you are working in paper space by verifying that the Model/Paper 

Space toggle in the status bar begins with “P.” If necessary, switch to paper space 

by double-clicking the Model/Paper Space toggle in the status bar. 

5 Create a dimension. You can select the model space entities directly, specify defi- 

nition points, or use entities snaps to help accurately select the definition points. 

The dimension is created in paper space. 
 

For more details about using paper space and model space, see “Understanding paper 

space and model space” on page 520. 
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Editing dimensions 
 

You can use grips to edit entity dimensions. You can also edit the dimension text. 

You can rotate dimension lines and dimension text at any angle, and you can reposi- 

tion the dimension text anywhere along the dimension line. 

 

Making dimensions oblique 
Extension lines are normally created at a perpendicular angle to the dimension line. 

You can change the angle of the extension lines, however, so that they tilt relative to 

the dimension line. 
 

To make oblique extension lines 

1 Do one of the following to choose Make Oblique ( ): 

• On the ribbon, choose Annotate > Make Oblique (in Dimensions). 

• On the menu, choose Dimensions > Make Oblique. 

• On the Dimensioning toolbar, click the Make Oblique tool. 

• Type dimedit, press Enter, and then in the prompt box, choose Oblique Lines. 

2 Select the linear dimension, and then press Enter. 

3 Type the obliquing angle, and then press Enter. 

 
 

 
Select the dimension to be made oblique (A), and then type 
the obliquing angle. 

Result. 

 
 

You can align the oblique angle if you don’t know the exact measurement. 

Use entity snaps to pick two points on the entity. 
 

 

 
A 
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Editing dimension text 
You can rotate the text of an existing dimension, move the dimension text to a new 

position, or replace selected dimension text with new text. You can also restore 

dimension text to its original position as defined by the current dimension style. 

When you rotate or replace selected text, you specify the change first, and then select 

one or more dimensions to which to apply the change. All the selected dimensions are 

updated simultaneously. 
 

To rotate dimension text 

Advanced experience level 

1 Do one of the following to choose Rotate Dimension Text ( ): 

• On the ribbon, choose Annotate > Rotate Dimension Text (in Dimensions). 

• On the menu, choose Dimensions > Rotate Dimension Text. 

• On the Dimensioning toolbar, click the Rotate Dimension Text tool. 

• Type dimedit, press Enter, and then in the prompt box, choose Rotate Text. 

2 Type the new dimension text angle, and then press Enter. 

3 Select the dimension to be rotated, and then press Enter. 

 
 

 
Select the dimension to be rotated (A), and then 
type the rotation angle. 

Result. 

 
 

The dimension text angle is relative to the dimension line. 

If the dimension text rotation is set to zero, the text angle is defined by the dimension 

type and the dimension style. 
 

 

 

A 
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To move dimension text 

Advanced experience level 

1 Do one of the following to choose Reposition Dimension Text ( ): 

• On the ribbon, choose Annotate > Reposition Dimension Text (in Dimensions). 

• On the menu, choose Dimensions > Reposition Dimension Text. 

• On the Dimensioning toolbar, click the Reposition Dimension Text tool. 

• Type dimtedit and then press Enter. 

2 Select the dimension to reposition text. 

3 Select the new text position. 
 

 
Select the dimension to be moved (A), and then select 
the new text position (B). 

To restore dimension text to its home position 

Advanced experience level 

Result. 

1 Do one of the following to choose Restore Text Position ( ): 

• On the ribbon, choose Annotate > Restore Text Position (in Dimensions). 

• On the menu, choose Dimensions > Restore Text Position. 

• On the Dimensioning toolbar, click the Restore Text Position tool. 

• Type dimedit, press Enter, and then in the prompt box, choose Restore Text. 

2 Select the dimension text to restore, and then press Enter. 
 

To replace existing dimension text with new text 

Advanced experience level 

1 Do one of the following to choose Edit Dimension Text ( ): 

• On the ribbon, choose Annotate > Edit Dimension Text (in Dimensions). 

• On the menu, choose Dimensions > Edit Dimension Text. 

• On the Dimensioning toolbar, click the Edit Dimension Text tool. 

• Type dimedit and then in the prompt box, choose Edit Text. 

2 Type the new dimension text, and then press Enter. 

3 Select the dimension to be replaced, and then press Enter. 

 

A 
B 
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To restore dimension text to its original text value 

1 Do one of the following to choose Reset Dimension Text ( ): 

• On the ribbon, choose Express Tools > Reset Dimension Text (in Dimension). 

• On the menu, choose Express Tools > Dimensions > Reset Dimension Text. 

• Type dimreassoc and then press Enter. 

2 Select the dimension text to restore, and then press Enter. 
 

To reassociate dimension text with a new entity or point on an entity 

1 Do one of the following to choose Reassociate Dimensions ( ): 

• On the ribbon, choose Annotate > Reassociate Dimensions (in Dimensions). 

• On the menu, choose Dimensions > Reassociate Dimensions. 

• Type dimreassociate and then press Enter. 

2 Select the dimensions you want to reassociate with a different entity or point, and 

then press Enter. 

3 Follow the prompts to select a new entity or point on an entity. The prompts that 

display vary according to the type of dimensions you selected. 
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Using dimension styles and variables 
 

Dimensions that you insert are created using the current dimension style. You can 

create, save, restore, and delete named dimension styles. 

To display information about the current dimension style and compare it with other 

style names, you can use the dimstyle command. 

 

Creating a dimension style 
Dimension styles provide a way for you to change various settings that control the 

appearance of dimensions. You can then save those settings for reuse. If you don’t 

define a dimension style before creating dimensions, the program uses the Standard 

dimension style, which stores the default dimension variable settings. Each option in 

the Dimension Styles dialog box relates to a variable that you can set manually. See 

the online Command Reference for more information. 
 

To create a dimension style 

1 Do one of the following to choose Dimension Styles Manager (  ): 

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions). 

• On the menu, choose Dimensions > Dimension Styles Manager or choose 

Format > Dimension Styles Manager. 

• On the Dimensioning toolbar, click the Dimension Styles tool. 

• Type setdim and then press Enter. 

2 In the Dimension Styles Manager dialog box, click New. 

3 Type the name of the new dimension style. 

4 Click Continue. 

5 In the Dimension Styles dialog box, make your selections for the dimension style 

as necessary. 

6 When finished, click OK. 
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Selecting a dimension style 

To select a dimension style 

1 Do one of the following to choose Dimension Styles Manager (  ): 

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions). 

• On the menu, choose Dimensions > Dimension Styles Manager or choose 

Format > Dimension Styles Manager. 

• On the Dimensioning toolbar, click the Dimension Styles tool. 

• Type setdim and then press Enter. 

2 In the Dimension Styles Manager dialog box, select a dimension style from the 

list. 

3 Click Set Current. 

4 Click Close. 

 

Renaming a dimension style 

To rename a dimension style 

1 Do one of the following to choose Dimension Styles Manager (  ): 

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions). 

• On the menu, choose Dimensions > Dimension Styles Manager or choose 

Format > Dimension Styles Manager. 

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 

tool. 

• Type setdim and then press Enter. 

2 In the Dimension Styles Manager dialog box, click Rename. 

3 In the Rename list, select the dimension style you want to rename. 

4 Type the new dimension style name. 

5 Click Rename. 

6 Click OK. 
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Deleting a dimension style 

To delete a named dimension style 

1 Do one of the following to choose Dimension Styles Manager (  ): 

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions). 

• On the menu, choose Dimensions > Dimension Styles Manager or choose 

Format > Dimension Styles Manager. 

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 

tool. 

• Type setdim and then press Enter. 

2 In the Dimension Styles dialog box, select the dimension style to delete. 

3 Click Delete. 

4 To confirm the deletion, click OK. 

5 Click OK. 
 

To display information about the current style 

1 Type dimstyle and then press Enter. 

2 Type v and then press Enter to display information about the variables. 

3 Type the dimension style name, and press Enter. 

 
Controlling line settings 

You can control settings affecting dimension lines, extension lines, and center marks. 

Any changes you make affect the current dimension style. The image tile on the right 

side of the Dimension Styles dialog box shows the appearance of the dimensions 

based on the current dimension style settings. 

 

 
A Extend past dimension. B Baseline offset  C Offset from origin. 

 

 

A 
 

B 
 
 
 
 
 

C 
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To set the color for dimension lines 

1 Do one of the following to choose Dimension Styles Manager (  ): 

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions). 

• On the menu, choose Dimensions > Dimension Styles Manager or choose 

Format > Dimension Styles Manager. 

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 

tool. 

• Type setdim and then press Enter. 

2 Click the Lines tab. 

3 Make your selections. 

4 Click OK. 
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A Select the dimension line color. 

B Select the dimension linetype. 

C Click to manage linetypes in 4MCAD Explorer. 

D Select the dimension lineweight. 

E Type or select the distance that dimension lines 
extend beyond tick marks. 

F Type or select the baseline offset distance (the 
distance to offset successive dimension lines 
when creating baseline dimensions) and the 
offset from origin (the distance extension lines 
are offset from their origin points). 

G Click to prevent the creation of the first or second 
dimension line. 

H Select the extension line color. 

I Select the first extension line linetype. 

J Select the second extension line linetype. 

K Select the extension lineweight. 

L Click to prevent the creation of the first or second 
extension line. 

M Click to set the length of extension lines to 
always be a set length, then type or select the 
extension line length. 

N Type or select the distance to offset extension 
lines from dimension lines. 

O Type or select the distance to offset extension 
lines from their origin. 

A 

B 

C 

D 

E 

F 

G 

 

H 

I 

J 

K 

L 

O 
N 

M 
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Controlling dimension arrows 
You can control the appearance and size of arrowheads or tick marks placed at the 

ends of dimension lines. Any changes you make affect the current dimension style. 

The arrowheads you choose display in the image tile on the right side of the Dimen- 

sion Styles dialog box. 

You can choose from a number of arrowhead types. You can specify different arrow- 

heads for each end of a dimension line and for leader lines. The Starting arrow corre- 

sponds to the first extension line; the Ending arrow corresponds to the second 

extension line. Blocks defined in the drawing also display in the three Arrowhead  

lists as user-defined arrows. You can use these blocks to create and assign your own 

arrowheads. 

The Arrow Size value determines the size of the arrowhead, measured in drawing 

units. You can also use tick marks instead of arrowheads. 
 

To choose an arrowhead 

1 Do one of the following to choose Dimension Styles Manager (  ): 

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions). 

• On the menu, choose Dimensions > Dimension Styles Manager or choose 

Format > Dimension Styles Manager. 

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 

tool. 

• Type setdim and then press Enter. 

2 Click the Symbols and Arrows tab. 

3 In the Starting Arrowhead or Ending Arrowhead list, click to select the starting or 

ending arrowhead, respectively. If necessary, mark Allow Separate Arrowheads if 

you want to use different starting and ending arrowheads. 

4 In the Leader Arrowhead list, click to select a leader arrowhead for leader lines. 

5 Click OK. 

 
 

Use the system variable. 

The DIMLDRBLK system variable also specifies leader arrow types. 
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A Select to enable the ability to use different 
starting and ending arrowheads. 

B Click to select a starting arrowhead, or click the 
arrowhead picture to scroll the list automatically. 

C Click to select an ending arrowhead, or click the 
arrowhead picture to scroll the list automatically. 

D Click to select a leader arrowhead, or click the 
arrowhead picture to scroll the list automatically. 

E Type or select arrowhead size. 

F Select to enable tick marks instead of 
arrowheads, then type or select tick mark size. 

G Select the symbol for center marks. 

H Type or select center mark size. Positive values 
create a center mark. Negative values create 
centerlines. 

I Type or select the angle for the jog of radius 
dimensions. 

J Type or select the scale factor for the jog height 
of linear dimensions. 

K Select where to position arc symbols for arc 
dimensions. 

A 
 
B 

C 

D 

E 

F 
K 

G 

H J 

I 
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Controlling dimension text 
You can control the settings affecting the appearance of dimension text. Any changes 

you make affect the current dimension style. The image tile on the right side of the 

Dimension Styles dialog box shows the appearance of the dimensions based on the 

current dimension style settings. 

 

 
Text between extension lines aligned 
horizontally. 

Text between extension lines 
aligned with dimension line. 

 

To align dimension text with the dimension line 

1 Do one of the following to choose Dimension Styles Manager (  ): 

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions). 

• On the menu, choose Dimensions > Dimension Styles Manager or choose 

Format > Dimension Styles Manager. 

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 

tool. 

• Type setdim and then press Enter. 

2 Click the Text tab. 

3 Make your selections. 

4 Click OK. 
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A Click to select the text style used for dimension 
text. Click Explorer to manage text styles in 
4MCAD Explorer. 

B Select the dimension text color. 

C Select none, drawing color, or user color for the 
dimension text background color. 

D Select the color for dimension text backgrounds 
(available if User Color is selected for Text 
Background). 

E Type or select the text height, measured in 
drawing units. 

F Select the vertical justification of dimension text. 

G Type or select the vertical text offset distance. 

H Select the horizontal justification of dimension text. 

I Select the view direction of dimension text. 

J Select the alignment when dimension text is 
outside extension lines. 

K Select the alignment when dimension text is inside 
extension lines. 

L Type or select the distance around the dimension 
text. 

M Click to include a frame around dimension text. 
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Controlling dimension fit 
You can control the way dimension text and arrowheads are placed in relation to the 

dimension lines. You can also control how the dimension scales by choosing whether 

it is annotative by default or whether it scales according to a specific scale or accord- 

ing to the layout. Any changes you make affect the current dimension style. The 

image tile on the right side of the Dimension Styles dialog box shows the appearance 

of dimensions based on the current dimension style settings. 

The program determines whether both dimension text and arrowheads will fit 

between the extension lines by comparing the distance between the extension lines to 

the size of the dimension text, the size of the arrowheads, and the amount of space 

required around dimension text. The program applies the best fit method based on the 

available space. If possible, both the dimension text and arrowheads are placed 

between the extension lines. If both will not fit between the extension lines, you can 

determine how text and arrowheads are placed using the Fit Method settings on the 

Dimension Styles dialog box. 

 

 
Text and arrowheads placed 
outside extension lines. 

Text placed between extension 
lines and arrowheads outside 
extension lines. 

Text placed above 
dimension line with a leader 
connecting the text to the 
dimension line. 

 

To format the fit of dimensions 

1 Do one of the following to choose Dimension Styles Manager (  ): 

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions). 

• On the menu, choose Dimensions > Dimension Styles Manager or choose 

Format > Dimension Styles Manager. 

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 

tool. 

• Type setdim and then press Enter. 

2 Click the Fit tab. 

3 Click the options that you want. 

4 Click OK. 

 
 

Use the system variables. 

The DIMATFIT system variable specifies how dimension text and arrows are 

arranged. The DIMTMOVE system variable specifies how dimension text is moved. 
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A Select how to fit text and arrows if they both do 
not fit inside extension lines. 

B Select to always place text inside extension 
lines. 

C Select to prevent the creation of arrows if they 
don’t fit inside extension lines. 

D Select to draw dimension lines between 
extension lines when text and arrows are placed 
outside extension lines. 

E Select how to position text relative to dimension 
lines and whether to include a leader. 

F Select to be prompted for text placement when 
creating dimensions. 

G Select to scale the dimension according to the 
layout or enter a specific scale to apply to all 
dimension style settings (available only if 
Annotative is not selected.) 

H Select to make the dimension support annotative 
scaling by default. 

A 

B 

C 
 

D 

E 

 
F 

H 

G 
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Controlling primary dimension units 
You can determine the appearance and format of the primary dimension units. The 

image tile on the right side of the Dimension Styles dialog box shows the appearance 

of the dimensions based on the current dimension style settings. 

 

 
Round off distance set to .0100 
(original dimension before 
rounding). 

Round off distance set to 
0.2500. 

Round off distance set 
to 1.0000. 

 

To set the primary units of dimensions 

1 Do one of the following to choose Dimension Styles Manager (  ): 

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions). 

• On the menu, choose Dimensions > Dimension Styles Manager or choose 

Format > Dimension Styles Manager. 

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 

tool. 

• Type setdim and then press Enter. 

2 Click the Primary Units tab. 

3 Make your selections. 

4 Click OK. 

 
 

Use the system variables. 

The DIMLUNIT system variable specifies units for linear dimensions. The DIMFRAC 

system variable specifies fraction formats. 
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A Select the linear dimension unit format. 

B Type or select the number of decimal places for 
text of linear dimensions. 

C Select the format for text fractions of linear 
dimensions. 

D Enter the marker symbol used for decimals. 

E Type or select the nearest value to round to for 
linear distances. 

F Type a prefix to be appended to linear dimension 
text. 

G Type a suffix to be appended to linear dimension 
text. 

H Select to prevent the inclusion of trailing zeros 
for linear dimension text. 

I Select to prevent the inclusion of leading zeros 
for linear dimension text. 

J Select to prevent the inclusion of inches or feet 
in dimension text when the corresponding 
number of inches or feet is zero. 

K Select to prevent the inclusion of leading zeros 
for angular dimensions. 

L Select the angular dimension unit format. 

M Type or select the number of decimal places for 
angular dimensions. 

N Select to prevent the inclusion of trailing zeros 
for angular dimesions. 

O Type or select te linear scale factor applied to 
all lengths measured by dimensioning 
commands. 

P Type or select the scale factor applied to all 
dimensions. 
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Controlling alternate dimension units 
You can include alternate dimensions in addition to the primary dimension text. You 

can also determine the appearance and format of the alternate dimensions, including 

the scale factor applied to generate alternate dimensions. The image tile on the right 

side of the Dimension Styles dialog box shows the appearance of the dimensions 

based on the current dimension style settings. 

 

 
Alternate dimension created using a scale factor of 25.4, with an appended suffix. 

 

To control alternate dimension units 

1 Do one of the following to choose Dimension Styles Manager (  ): 

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions). 

• On the menu, choose Dimensions > Dimension Styles Manager or choose 

Format > Dimension Styles Manager. 

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 

tool. 

• Type setdim and then press Enter. 

2 Click the Alternate Units tab. 

3 Select Display Alternate Units. 

4 Make your selections. 

5 Click OK. 
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A Select to include alternate units with dimension 
text. 

B Click to select the format for alternate dimension 
text. 

C Type or select the number of decimal places 
displayed in alternate dimension text. 

D Type or select the scale factor applied to 
measured dimensions to generate the alternate 
dimension text. 

E Type or select any rounding for alternate 
dimension text. 

F Type a prefix to be appended to alternate 
dimension text. 

G Type a suffix to be appended to alternate 
dimension text. 

H Select the placement of alternate dimension text. 

I Select to prevent the inclusion of trailing zeros 
for alternate dimension text. 

J Select to prevent the inclusion of leading zeros 
for alternate dimension text. 

K Select to prevent the inclusion of inches or feet 
in alternate dimension text when the 
corresponding number of inches or feet is zero. 

L Select to prevent the inclusion of leading zeros 
for tolerances included as part of alternate 
dimensions. 

M Select to prevent the inclusion of trailing zeros 
for tolerances included as part of alternate 
dimensions. 

N Select to prevent the inclusion of inches or feet 
for tolerances included as part of alternate 
dimensions when the corresponding number of 
inches or feet is zero. 

O Type or select the number of decimal places 
displayed in limits or tolerances included as part 
of alternate dimensions. 
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Adding geometric tolerances 
 

Geometric tolerances indicate the maximum allowable variations in the geometry 

defined by a drawing. 4MCAD draws geometric tolerances using a feature control 

frame, which is a rectangle divided into compartments. 

 

Understanding geometric tolerances 
Each feature control frame consists of at least two compartments. The first compart- 

ment contains a geometric tolerance symbol that indicates the geometric characteris- 

tic to which the tolerance is applied, such as location, orientation, or form. For 

example, a form tolerance may indicate the flatness or roundness of a surface. The  

geometric tolerance symbols and their characteristics are shown in the following 

table. 
 

Geometric tolerance symbols  

Symbol Characteristic Type 

 
Position Location 

 
Concentricity or coaxiality Location 

 Symmetry Location 

  
Parallelism 

 
Orientation 

 Perpendicularity Orientation 

  

Angularity 
 

Orientation 

  
Cylindricity 

 
Form 

 Flatness Form 

  

Circularity or roundness 

 

Form 

 Straightness 

 

Profile of a surface 

Form 

 

Profile 

  

Profile of a line 

 

Profile 

 Circular runout Runout 

 
Total runout Runout 
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The second compartment contains the tolerance value. When appropriate, the toler- 

ance value is preceded by a diameter symbol and followed by a material condition 

symbol. The material conditions apply to features that can vary in size. The material 

condition symbols and their meanings are shown in the following table. 
 

Material conditions 
 

 
At maximum material condition (MMC), a feature contains the maximum amount of 
material stated in the limits. 

At least material condition (LMC), a feature contains the minimum amount of 
material stated in the limits. 

Regardless of feature size (RFS) indicates that the feature can be any size within 
the stated limits. 

 
 

 

The tolerance value can then be followed by primary, secondary, and tertiary datum 

reference letters, along with the material conditions of each datum. Datum reference 

letters are generally used as reference tolerances to one of up to three perpendicular 

planes from which a measurement is made, although datum reference letters can also 

indicate an exact point or axis. 

 

 

A Geometric characteristic symbol. 

B Diameter symbol. 

C Tolerance value. 

D Material condition symbol. 

E Datum reference. 

 

When two tolerances apply to the same geometry, you can also add a composite toler- 

ance consisting of a primary tolerance value followed by a secondary tolerance value. 

To make a tolerance even more specific, it can also contain a projected tolerance con- 

sisting of a height value followed by a projected tolerance symbol. For example, you 

can use a projected tolerance to indicate the perpendicularity of an embedded part. 

 
 
 
 

 

A B C D E 

Symbol Definition 
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Adding a geometric tolerance 

To add a geometric tolerance 

1 Do one of the following to choose Tolerance ( ): 

• On the ribbon, choose Annotate > Tolerance (in Dimensions). 

• On the menu, choose Dimensions > Tolerance. 

• On the Dimensioning toolbar, click the Tolerance tool. 

• Type tolerance and then press Enter. 

2 To display the geometric tolerance symbols, on the first line, click the Sym box. 

3 Click to select a geometric tolerance symbol. 

4 Under Tolerance 1, click the Dia box to add a diameter symbol. 

5 In the field, type the first tolerance value. 

6 To display the material condition symbols, click the M.C. box. 

7 Click to select a material condition. 

8 Under Tolerance 2, repeat steps 4 through 7 to add a secondary tolerance value, if 

appropriate. 

9 Under Datum 1, type the primary datum reference letter. 

10 To display the material condition symbols, click the M.C. box. 

11 Click to select a material condition. 

12 Repeat steps 9 through 11 to add secondary and tertiary datum, if appropriate. 

13 In the second row, repeat steps 2 through 12 to add composite tolerances, if 

appropriate. 

14 In the Height box, type a projected tolerance zone height value, if appropriate. 

15 To insert a projected tolerance zone symbol, click the Projected Tolerance Zone 

box, if appropriate. 

16 Click OK. 

17 In the drawing, specify the location of the feature frame. 
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Q P O N   M L K J I H G F E 

 
 

A Use this row to include composite tolerances. 

B Type a projected tolerance height value. 

C Type a datum identifier. 

D Click to include a projected tolerance symbol. 

E Click to select the material condition symbol for tertiary 
data. 

F Type the tertiary datum reference letter. 

G Click to select the material condition symbol for 
secondary datum. 

H Type the secondary datum reference letter. 

I Click to select the material condition symbol for primary 
datum. 

J Type the primary datum reference letter. 

K Click to select the material condition symbol for the 
second tolerance value. 

L Type the second tolerance value. 

M Click to include a diameter symbol for the second 
tolerance value. 

N Click to select the material condition symbol for the first 
tolerance value. 

O Type the first tolerance value. 

P Click to include a diameter symbol for the first tolerance 
value. 

Q Click to select a geometric tolerance symbol. 

 

Controlling dimension tolerances 

You can create dimensions as either tolerance or limits dimensions. When creating a 

tolerance dimension, you can control the upper and lower tolerance limits as well as 

the number of decimal places of the dimension text. The image tile on the right side 

of the Dimension Styles dialog box shows the appearance of tolerance and limits 

dimensions based on the current dimension style settings. 

 

 
Tolerance dimension. Limits dimension. 

A 
 

B 

C 

D 
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To control dimension tolerances 

1 Do one of the following to choose Dimension Styles Manager (  ): 

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions). 

• On the menu, choose Dimensions > Dimension Styles Manager or choose 

Format > Dimension Styles Manager. 

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 

tool. 

• Type setdim and then press Enter. 

2 Click the Tolerance tab. 

3 Make your selections. 

4 Click OK. 

 

 

 

 
 

 

A 

B 

C 

D 

E 

F 

G 

H 

I 

 

J 
K 

 
 

 
A Select to insert a plus and minus tolerance value 

with dimension text. 

B Select to insert upper and lower tolerance limits 
with dimension text. 

C Type or select the number of decimal places 
displayed in limits or tolerance dimension text. 

D Type or select the minimum tolerance or lower 
limit value. 

E Type or select the maximum tolerance or upper 
limit value. 

 
F Type or select the scale factor applied to the 

height of limits or tolerance dimension text. 

G Select the vertical justification of limits or 
tolerance dimension text. 

H Select to prevent the inclusion of trailing zeros in 
limits or tolerance dimension text. 

I Select to prevent the inclusion of leading zeros in 
limits or tolerance dimension text. 

J Select to prevent the inclusion of inches or feet 
in limits or tolerance dimension text when the 
corresponding number of inches or feet is zero. 
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Working with other files in your drawings 
 

Blocks, attributes, and external references provide mechanisms for managing entities 

in your drawings and for including additional information with the standard drawing 

entities. With blocks, you can combine numerous entities into a single entity, and 

then reuse it, inserting multiple copies. With attributes, you can associate text, such as 

part numbers or prices, with blocks, and then extract the text-attribute information to 

a separate file, such as a database, for further analysis. With external references, you 

can link separate reference drawing files to a drawing to combine information without 

adding the contents of the reference drawings to the current drawing. If you make 

changes to the referenced file, all references are updated automatically. 

This section explains how to: 

• Create, insert, and redefine blocks. 

• Create, edit, and insert attributes. 

• Extract attribute data to a separate file. 

• Attach and work with external references and underlays. 

• Use images in your drawings. 

 

 
 

 

 
 

 

 

 
 

 

13 
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Working with blocks 
 

Usually, blocks are several entities combined into one that you can insert into a draw- 

ing and manipulate as a single entity. A block can consist of visible entities such as 

lines, arcs, and circles, as well as visible or invisible data called attributes. Blocks are 

stored as part of the drawing file. 

 

Understanding blocks 
Blocks can help you better organize your work, quickly create and revise drawings, 

and reduce drawing file size. Using blocks, you can create a library of frequently used 

symbols. Then you can insert a symbol as a block rather than redraw the symbol from 

scratch. 

After you create a block from multiple entities, you save it once, which also saves 

disk space. You insert only multiple references to a single block definition. You can 

change the block definition to quickly revise a drawing, and then update all instances 

of the block. 

If you insert a block that contains entities originally drawn on layer 0 and assigned 

color and linetype BYLAYER, it is placed on the current layer and assumes the color 

and linetype of that layer. If you insert a block that contains entities originally drawn 

on other layers or with explicitly specified colors or linetypes, the block retains the 

original settings. 

If you insert a block that contains entities originally assigned color and linetype 

BYBLOCK, and the block itself has the color and linetype BYLAYER, those entities 

adopt the color and linetype of the layer onto which they are inserted. If the block is 

assigned an explicit color or linetype, such as red or dashed, those entities adopt those 

qualities. 

A procedure called nesting occurs when you include other blocks in a new block that 

you are creating. Nesting is useful when you want to combine and include small com- 

ponents, such as nuts and bolts, into a larger assembly and you need to insert multiple 

instances of that assembly into an even larger drawing. 

The quickest way to create and save blocks is using the Block Editor. It allows you to 

draw and save the block in-place, directly in the drawing area. You can also create 

blocks using individual block commands and contain more options. A third way of 

creating blocks is using 4MCAD Explorer. For details about creating blocks using 

4MCAD Explorer, see “Working with blocks” on page 303. 

 

Creating and saving a block using the Block Editor 
When you create a block using the Block Editor, you specify its name and then draw 

the entities that compose the block directly in the drawing area. While creating the 

block in-place, you can save the block with its existing name or a new name. 

The insertion point of the created block is automatically defined relative to the UCS. 
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To create a block using the Block Editor 

1 Do one of the following to choose Block Editor ( ): 

• On the ribbon, choose Home > Block Editor (in Block Definition) or choose 

Insert > Block Editor (in Block Definition). 

• Type bedit and then press Enter. 

2 In the Edit Block Definition dialog box, enter a name and description for the new 

block. 

3 Click OK. 

4 Draw the entities that make up the block. 

5 Do one of the following to choose Save Block : 

• On the ribbon, choose Block Editor > Save Block. 

• On the floating toolbar (if the ribbon is not displayed), choose Save Block. 

• Type bsave and then press Enter. 

6 Do one of the following to choose Close Block Editor ( ): 

• On the ribbon, choose Block Editor > Close Block Editor. 

• On the floating toolbar (if the ribbon is not displayed), choose Close Block 

Editor. 

• Type bclose and then press Enter. 

The program adds the new block to the blocks list, with the name you entered for 

it. 

If you often include blocks in your drawings, you can create a tool palette that con- 

tains the blocks you use most often. For details, see “Creating tool palettes and add- 

ing commands and blocks” on page 713. 

 

Creating and saving a block using individual commands 
When you create a block using the Block command, you specify its name, its inser- 

tion point, and the entities that compose the block. The insertion point is the base 

point for the block and serves as the reference point when you later insert the block 

into a drawing. 

The new block you create exists only in the current drawing, unless you save it sepa- 

rately using the Save Block to Disk command. 
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Creating a block for use within the current drawing 

To create a block for use within a current drawing 

Advanced experience level 

1 Do one of the following to choose Create Block ( ): 

• On the ribbon, choose Home > Create Block (in Block) or choose Insert > Create 

Block (in Block Definition). 

• On the menu, choose Draw > Block > Create Block. 

• On the Tools toolbar, click the Create Block tool. 

• Type block and then press Enter. 

2 In the Block definition dialog box, enter a name and description for the new block. 

3 Specify the insertion point for the block by doing one of the following: 

• Specify on Screen Mark this check box to select the base point in the drawing 

after you click OK. 

• Pick Base Point Click (  ) to temporarily close the dialog box immediately, 

select the base point in the drawing, then return to the dialog box. This option is 

available only if Specify on Screen is not marked. 

• X, Y, and Z Enter the x-, y-, and z-coordinates of the base point. This option is 

available only if Specify on Screen is not marked. 

4 Select the entities to be combined into the block by doing one of the following: 

• Specify on Screen Mark this check box to select the entities in the drawing after 

you click OK. 

• Select entities Click ( ) to temporarily close the dialog box immediately, 

select the entities in the drawing, then return to the dialog box. Or you can click  

( ) to select entities by type or value. This option is available only if Specify 

on Screen is not marked. 

5 Select what to do with the entities after the block is created: 

• Retain entities Entities selected for the block remain in the drawing. 

• Convert to block Entities selected for the block are converted to the block, 

which remains in the drawing. 

• Delete entities Entities selected for the block are removed from the drawing. 
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6 Select any of the following options for the block: 

• Annotative Determines whether the block is annotative by default. The display 

and printing of annotative blocks is affected by annotation scaling. If annotative 

by default, you can determine whether the block, when located in paper space, 

is oriented automatically according to the layout viewport. 

• Scale uniformly Mark this check box to retain the aspect ratio if the block is 

scaled. Annotative blocks must be scaled proportionately. 

• Allow exploding Mark this check box to allow the block to be exploded into 

separate entities. 

• Unit Defines the unit of the block, for example inches or millimeters. 

7 Click OK. 

The program adds a new block to the blocks list, with the name you entered for it. 

 
 

 
F G H I 

A Enter the name of the block. 

B Enter a description of the block. 

C Select to pick the base point in the drawing after 
you click OK. 

D Select to pick the base point now in the drawing. 

E Displays the base point coordinates or you can 
enter them manually. 

F Select to select entities to include in the block 
after you click OK. 

G Click to select entities now in the drawing. 

H Select whether to keep, convert, or delete 
entities after the block is created. 

I Click to select entities by type or value. 

J Choose block units. 

K Select to allow the block to be exploded into 
entities. 

L Select to maintain aspect ratio if the block is 
scaled. 

M Select to make the block, when located in paper 
space, oriented according to the layout viewport 
(available only if Annotative is marked). 

N Mark to make the block annotative by default. 

If you often include blocks in your drawings, you can create a tool palette that con- 

tains the blocks you use most often. For details, see “Creating tool palettes and add- 

ing commands and blocks” on page 713. 
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Some users frequently restore original entities after defining a block. 

To restore the original entities to the drawing while retaining the new block, type 

undelete or oops. You might also want to add the Undelete command to a menu or 

toolbar by choosing Tools > Customize. 
 

 

 
Saving blocks 
You can create a block as a separate drawing file that you can insert into other drawings. 

 

To save a block as a separate drawing file 

Advanced experience level 

1 Do one of the following to choose Save Block To Disk (  ): 

• On the ribbon, choose Insert > Save Block to Disk (in Block Definition). 

• On the menu, choose Tools > Save Block To Disk. 

• On the Tools toolbar, click the Save Block To Disk tool. 

• Type wblock and then press Enter. 

2 In Source, choose Block, then select the desired block from the list. 

3 In File Name and Path, type the name and path of the destination drawing file you 

want to create, or click [...] to browse for it. 

4 In Insert Units, select the units used for inserting the separate drawing file. 

5 Click OK. 
 

 

The program assigns the 0,0,0 coordinate as the insertion base point. 

You can change the base point by opening the drawing and redefining the block. 
 

 

 
To save the current drawing as a separate drawing file 

Advanced experience level 

1 Do one of the following to choose Save Block to Disk (  ): 

• On the ribbon, choose Insert > Save Block to Disk (in Block Definition). 

• On the menu, choose Tools > Save Block To Disk. 

• On the Tools toolbar, click the Save Block To Disk tool. 

• Type wblock and then press Enter. 

2 In Source, choose Entire Drawing. 

3 In File Name and Path, type the name and path of the destination drawing file you 

want to create, or click [...] to browse for it. 

4 In Insert Units, select the units used for inserting the separate drawing file. 

5 Click OK. 
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The program assigns the 0,0,0 coordinate as the insertion base point. 

You can change the base point by opening the drawing and redefining the block. 
 

 

 
To select entities and save them as a separate drawing file 

Advanced experience level 

1 Do one of the following to choose Save Block to Disk (  ): 

• On the ribbon, choose Insert > Save Block to Disk (in Block Definition). 

• On the menu, choose Tools > Save Block To Disk. 

• On the Tools toolbar, click the Save Block To Disk tool. 

• Type wblock and then press Enter. 

2 In Source, choose Entities. 

3 In Base Point, enter the x,y,z coordinates of the base point to save with the sepa- 

rate drawing file, or click (  ) to select it directly in the current drawing. 

4 Click (  ) and then select the source entities directly in the current drawing. Or 

you can click ( ) to select entities by type or value. 

5 Choose what action to take with selected entities in the current drawing after the 

separate drawing file is created: 

• Retain Keeps the selected source entities in the current drawing. 

• Convert to block Converts the selected source entities to a block in the current 

drawing. 

• Delete from drawing Deletes the selected source entities from the current 

drawing. 

If no entities are selected, a separate drawing file is not created. 

6 In File Name and Path, type the name and path of the destination drawing file you 

want to create, or click [...] to browse for it. 

7 In Insert Units, select the units used for inserting the separate drawing file. 

8 Click OK. 

If you often include blocks in your drawings, you can create a tool palette that con- 

tains the blocks you use most often. For details, see “Creating tool palettes and add- 

ing commands and blocks” on page 713. 
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A Select what content to save to a separate drawing 
file. If Entities is selected, the Base Point and 
Entities options are available. 

B Click to select in the current drawing the x,y,z 
coordinates of the base point to save with the 
separate drawing file. 

C Enter the x,y,z coordinates of the base point to 
save with the separate drawing file. 

D Enter the path and filename of the new drawing 
file, or click [...] to browse to it. 

E Select the insertion units for the new drawing file. 

F Displays the number of entities currently selected 
to save to a separate drawing file. If no entities are 
selected, a separate drawing file is not created. 

G Select what action to take with selected entities in 
the current drawing after the separate drawing file 
is created. 

H Click to select entities by type or value. 

I Click to select in the current drawing the entities to 
save to a separate drawing file. 

J Select the block to save to a separate drawing file. 
Available only if Block is selected as the source. 
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Inserting blocks 
You can insert blocks and other drawings into the current drawing. When you insert a 

block, it is treated as a single entity. When you insert a drawing, it is added to the cur- 

rent drawing as a block. You can then insert multiple instances of the block without 

reloading the original drawing file. If you change the original drawing file, those 

changes have no effect on the current drawing unless you redefine the block by rein- 

serting the changed drawing. 

You can also insert blocks from another drawing into the current drawing, using the 

4MCAD Explorer. Both drawings must be open at the same time to do this. 

When you insert a block or drawing, you must specify the insertion point, scale, and 

rotation angle. The block’s insertion point is the reference point specified when you 

created the block. When you insert a drawing as a block, the program takes the speci- 

fied insertion point as the block insertion point. You can change the insertion point, 

however, by first opening the original drawing and redefining the block. 

 
 

Block settings can also be set before block insertion. 

You can specify the insertion point, scale factors, and rotation angle in the Insert 

Block dialog box before inserting the block. You can also control whether the block is 

exploded back into its original component entities after insertion. Under Positioning, 

clear the Position Block When Inserting check box, and specify the appropriate coor- 

dinates. If you want to explode the block immediately, select the Explode Upon Inser- 

tion check box. 
 

 

 
To insert a block 

1 Do one of the following to choose Insert Block (  ): 

• On the ribbon, choose Home > Insert Block (in Block) or choose Insert > Insert 

Block (in Block). 

• On the menu, choose Insert > Block. 

• On the Draw toolbar, click the Block tool. 

• Type ddinsert and then press Enter. 

2 In the Insert Block dialog box, under Insert, click Block Name. 

3 In the Block Name box, select the name of the block you want to insert. 

4 Click Insert. 

5 Specify the insertion point for the block. 

6 Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept 

the default values. 
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To insert an entire drawing into the current drawing 

1 Do one of the following to choose Insert Block (  ): 

• On the ribbon, choose Home > Insert Block (in Block) or choose Insert > Insert 

Block (in Block). 

• On the menu, choose Insert > Block. 

• On the Draw toolbar, click the Block tool. 

• Type ddinsert and then press Enter. 

2 In the Insert Block dialog box, under Insert, click From File. 

3 Type the path and the drawing file name, or click Browse to specify the file from 

the Insert Drawing dialog box, and click Open. 

4 Click Insert. 

5 Specify the insertion point for the block. 

6 Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept 

the default values. 

 
 

You can also insert drawings while browsing files on your computer. 

If the DRAGOPEN system variable is set to 0, you can drag a .dwg file to the drawing 

area in 4MCAD to insert it as a block. If DRAGOPEN is set to 1 (the default), the 

drawing opens in 4MCAD. 
 

 

 
 

Blocks can be converted to external references. 

Use the Convert Block to Xref command which is an express tool that quickly 

changes all occurrences of a block into external references. 
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A Click and then enter the path and drawing file 

name to insert the entire drawing file as a block. 

B Click to position the block when inserting. 

C Specify the insertion point, scale factors, and 
rotation angle before you insert the block 
(available only when Position Block When 
Inserting is cleared). 

D Click to explode the block on insertion. 

E Specify columns, column spacing, rows, and row 
spacing. 

F Click to insert the block. 

G Click to select the block insertion point in the 
drawing before inserting the block (available only 
when the Position Block When Inserting check 
box is cleared). 
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Modifying blocks 
There are several ways you can modify a block. After you modify it, all blocks in the 

drawing are updated automatically. 

 
Editing blocks using the Block Editor 
You can redefine all instances of a block within the current drawing. To redefine a 

block that was created in the current drawing, you create a new block using the same 

name. You can update all the blocks in the current drawing by redefining the block. If 

the block was inserted from a separate drawing file that was subsequently updated, 

reinsert that block to update all other instances in the current drawing. 
 

To redefine a block in the current drawing 

Advanced experience level 

1 Do one of the following to choose Block Editor ( ): 

• On the ribbon, choose Home > Block Editor (in Block Definition) or choose 

Insert > Block Editor (in Block Definition). 

• Type bedit and then press Enter. 
 

 

Use a shortcut. 

Double-click a block to open it in the Block Editor. Note that the 

BLOCKEDITLOCK system variable controls the double-click action for blocks: if 

set to 0, the Block Editor opens; if set to 1, the Properties pane opens. 
 

 

 

2 In the Edit Block Definition dialog box, select the block you want to edit. 

3 Click OK. 

4 In the drawing area, make changes to the block. 

5 Do one of the following to choose Save Block : 

• On the ribbon, choose Block Editor > Save Block. 

• On the floating toolbar (if the ribbon is not displayed), choose Save Block. 

• Type bsave and then press Enter. 

You can also choose Save Block As ( ) to save the block with a new name. 

6 Do one of the following to choose Close Block Editor ( ): 

• On the ribbon, choose Block Editor > Close Block Editor. 

• On the floating toolbar (if the ribbon is not displayed), choose Close Block 

Editor. 

• Type bclose and then press Enter. 

The program updates all instances of the block. 
 

You can update all instances of a block inserted from a separate drawing by reinsert- 

ing the drawing. 
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Redefining blocks 
You can redefine all instances of a block within the current drawing. To redefine a 

block that was created in the current drawing, you create a new block using the same 

name. You can update all the blocks in the current drawing by redefining the block. If 

the block was inserted from a separate drawing file that was subsequently updated, 

reinsert that block to update all other instances in the current drawing. 
 

To redefine a block in the current drawing 

Advanced experience level 

1 Do one of the following to choose Create Block ( ): 

• On the ribbon, choose Home > Create Block (in Block) or choose Insert > Create 

Block (in Block Definition). 

• On the menu, choose Draw > Block > Create Block. 

• On the Tools toolbar, click the Create Block tool. 

• Type block and then press Enter. 

2 In Name, select the name of the block you want to redefine from the list. 

3 Specify the insertion point for the block. 

4 Select the entities for the block. 

5 Make selections about the behavior. 

6 Click OK. 

7 When prompted, choose Yes to redefine the block. 

The block is redefined, and all instances of the block in the drawing are updated. 

8 To restore the original entities to the drawing while retaining the new block, type 

undelete or oops. 

You can update all instances of a block inserted from a separate drawing by reinsert- 

ing the drawing. 



482 C H A P T E R   1 3  
 

 

Editing blocks in-place 
After a block is inserted in a drawing, it can be edited directly in 4MCAD, and the 

source block and all references to the block are updated automatically. Editing in- 

place is an easy way to make changes to a block without having to locate and load it. 
 

To edit blocks in-place 

1 Do one of the following: 

• On the ribbon, choose Insert > Edit Reference in Place (in Reference). 

• On the menu, choose Tools > Edit Block or X-Ref In-Place > Edit In-Place. 

• Type refedit and then press Enter. 

2 At the prompt, select the block you want to edit. 

The Reference Edit dialog box displays. 

3 In Reference Name, select the block you want to edit. 

4 Select the Settings tab and select from the following options: 

• Create Unique Layer, Style and Block Names Select to create unique names for 

layers, styles, and blocks that you change. A prefix is added to the original name 

of a changed layer, style, or block. Names of unchanged layers, styles, and 

blocks do not change. 

• Display Attribute Definitions for Editing Select to hide attributes and display 

attribute definitions while editing. After saving, changed attribute definitions 

affect new block insertions only. Existing blocks are not affected. 

5 Click OK. 

6 Make changes to the contents of the block. 

7 To add an entity from the drawing to the block, select the entity and do one of the 

following: 

• Choose Tools > Edit Block or X-Ref In-Place > Add to Working Set. 

• Type refset, press Enter, then choose Add. 

8 To remove an entity from the block, select the entity and do one of the following: 

• Choose Tools > Edit Block or X-Ref In-Place > Remove from Working Set. 

• Type refset, press Enter, then choose Remove. 

9 When you’re finished editing the block, do one of the following: 

• Choose Tools > Edit Block or X-Ref In-Place > Close Reference. 

• Type refclose and then press Enter. 

10 Choose Save to save changes or Discard to cancel changes. 

If changes are saved, all instances of the block are updated in the current drawing. 
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Exploding blocks 
You can explode an inserted block to its original component entities. When you 

explode a block, only that single instance of the block is affected. The original block 

definition remains in the drawing, and you can still insert additional copies of the 

original block. If you explode a block that contains attributes, the attributes are lost, 

but the original attribute definitions remain. 

Exploding dissociates component entities to their next simplest level of complexity; 

blocks or polylines in a block become blocks or polylines again 
 

To explode a block 

1 Do one of the following to choose Explode (  ): 

• On the ribbon, choose Home > Explode (in Modify) or choose Edit > Explode 

(in Modify). 

• On the menu, choose Modify > Explode. 

• On the Modify toolbar, click the Explode tool. 

• Type explode and then press Enter. 

2 Select the block. 

3 Press Enter. 
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Working with attributes 
 

An attribute is a particular entity that you can save as part of a block definition. Attri- 

butes consist of text-based data. You can use attributes to track such things as part 

numbers and prices. Attributes have either fixed or variable values. When you insert a 

block containing attributes, the program adds the fixed values to the drawing along 

with the block, and you are prompted to supply any variable values. 

After you insert blocks containing attributes, you can extract the attribute information 

to a separate file and then use that information in a spreadsheet or database to produce 

a parts list or bill of materials. You can also use attribute information to track the 

number of times a particular block is inserted into a drawing. 

Attributes can be visible or hidden. Hidden attributes are neither displayed nor 

printed, but the information is still stored in the drawing and written to a file when 

you extract it. 

 

Defining attributes 
You add an attribute to a drawing by first defining it and then saving it as part of a 

block definition. To define an attribute, you specify the characteristics of the attri- 

bute, including its name, prompt, and default value; the location and text formatting; 

and optional modes (hidden, fixed, validate, predefined, and locked). 
 

To define an attribute 

Advanced experience level 

1 Do one of the following to choose Define Attributes (  ): 

• On the ribbon, choose Insert > Define Attributes (in Block Definition). 

• On the menu, choose Draw > Block > Define Attributes. 

• On the Tools toolbar, click the Define Attributes tool. 

• Type ddattdef and then press Enter. 

2 In the Define Attribute dialog box, type the name, prompt, and default value. 

3 Under Insert Coordinates, specify the location of the attribute, or click Select to 

select a point in the drawing. 

4 Under Attribute Flags, select the optional attribute modes. 

5 Under Text, specify the text characteristics. 

6 To add the attribute to the drawing, do one of the following: 

• Click Define to add the attribute and keep the dialog box active so you can 

define another attribute. 

• Click Define And Exit to add the attribute and end the command. 
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A Type the name you want to assign to the 
attribute. 

B Enter the identifying prompt information 
displayed when you insert a block containing the 
attribute. 

C Enter the default or constant value. For variable 
attributes, the default value is replaced by the 
actual value when you later insert a block 
containing the attribute. 

D Specify the x-, y-, and z-coordinates for the 
attribute insertion point. 

E Select to create a hidden attribute. 

F Select to create a fixed-value attribute. 

G Select to create an attribute whose value must 
be validated when you later insert a block 
containing the attribute. 

H Select to create an attribute whose value is 
defined and not requested when you later insert 
a block containing the attribute, but that you can 
edit after the block is inserted. 

I Select to create an attribute whose position is 
locked. 

K L 

J Select to create an attribute whose default text 
contains multiple lines of text. 

K Click to add the attribute and keep the dialog box 
active so you can define another attribute. 

L Click to add the attribute and end the command. 

M Specify the text rotation angle, or click to specify 
the rotation angle by selecting two points in the 
drawing. 

N Specify the text height, or click to specify the 
height by selecting two points in the drawing. 

O Choose the text justification. 

P Choose the text style from those styles already 
defined in the drawing. 

Q Select to create an attribute that is annotative by 
default. 

R Click to specify the attribute insertion point by 
selecting a point in the drawing. 

S Click to enter multiple lines of default text. 
Available only if Multiple line is selected. 
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Editing attribute definitions 
You can edit an attribute definition before you associate it with a block and before it 

is saved as part of a block definition. 
 

To edit an attribute definition 

Advanced experience level 

1 Select the attribute definition text to edit. 

2 Do one of the following to choose Properties (  ): 

• On the ribbon, choose View > Properties (in Display). 

• On the menu, choose Modify > Properties. 

• Right-click the attribute definition text, then choose Properties. 

• Type entprop and then press Enter. 

3 Modify the properties, including name, prompt, default value, and other attribute- 

specific properties. 

 

Attaching attributes to blocks 
You can attach attributes to a block after you define it and select it as one of the enti- 

ties to include. Include the attributes when the program prompts you for the entities to 

include in the selection set for a block. After the attribute is incorporated into a block, 

the program prompts you each time you insert the block, so you can specify different 

values for the attributes each time you insert it into a new drawing. 

 

Editing attributes attached to blocks 
You can edit the attribute values of a block that has been inserted into a drawing. 

 

To edit an attribute attached to a block 

Advanced experience level 

1 Do one of the following to choose Edit Block Attributes (  ): 

• On the ribbon, choose Insert > Edit Block Attributes (in Block Definition). 

• On the menu, choose Tools > Edit Block Attributes. 

• On the Tools toolbar, click the Edit Block Attributes tool. 

• Type ddatte and then press Enter. 

2 Select the block to edit. 

The Edit Block Attributes dialog box displays all the attributes attached to the 

block you select. 

3 Edit the attribute values as necessary. 

4 Click OK. 
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A Identifies the name of the block. 

B Click to select attribute. 

C Type the new value for the selected attribute. 

 

Extracting attribute 
information 

D Click to update the attribute values and exit. 

E Displays the names, prompts, and values of all 
attributes attached to the block. 

You can extract attribute information from a drawing and save it to a separate text file 

for use with a database program. You can save the file in any of the following for- 

mats: 

• Comma Delimited Format (CDF) Contains one line for each instance of a block, 

with individual attribute fields separated by commas. Character string fields are 

enclosed with single quotation marks. You must specify a template file when 

extracting to a CDF file. 

• Space Delimited Format (SDF) Contains one line for each instance of a block. 

Each attribute field has a fixed length; there are no separators or character string 

delimiters. You must specify a template file when extracting to a SDF file. 

• Drawing Exchange Format (DXF) Creates a subset of a standard DXF file (a *.dxx 

file) containing all the information about each block, including the insertion 

points, rotation angles, and attribute values. No template file is required. 

Before extracting attributes to a CDF or SDF file, you must create a template file. The 

template file is an ASCII text file that specifies the attribute data fields to be written 

in the extract file. Each line of the template file specifies one attribute field. 

4MCAD recognizes 15 different fields, which contain elements such as the block 

name, the x-, y-, and z-coordinates of its insertion point, the layer on which it is 

inserted, and so on. You can include any of these fields. The template file must 

include at least one attribute name. 
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Each line in the template file must start with the field name. Block name and inser- 

tion-point values must begin with BL:. The next nonblank character must be either a 

C (indicating a character string field) or an N (indicating a numeric field). This char- 

acter is then followed by three digits indicating the width of the field (in characters). 

The final three digits indicate the number of decimal places (for numeric fields). In 

the case of character fields, the last three digits must be zeros (000). A typical tem- 

plate file is similar to the one shown here: 

 

 
A Field name. 

B Block name. Block names must begin with BL:. 

C Insertion point. Insertion-point values must begin 
with BL:. 

D Attribute tags. 

To create a template file 

E Number of decimal places for numeric fields or 
000 for character fields. 

F Field width for character or numeric fields. 

G C for character fields; N for numeric fields. 

1 Create a template file using any ASCII text editor (such as Microsoft® Notepad or 

Microsoft® WordPad) or a word-processing program such as Microsoft® Word. 

2 Include the necessary fields in the template file. 

3 Save the template file in ASCII text format. 
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To extract attribute information 

1 Do one of the following to choose Extract Attributes (  ): 

• On the ribbon, choose Insert > Extract Attributes (in Block Definition). 

• On the menu, choose Tools > Extract Attributes. 

• On the Tools toolbar, click the Extract Attributes tool. 

• Type ddattext and then press Enter. 

2 Click Select, specify the entities from which to extract attributes, and then press 

Enter. 

3 Specify the format of the extracted file. 

4 For CDF and SDF formats, specify the template file. 

5 Specify the extract output file. 

6 Click Extract. 

 

 
 

A Click to select blocks in the drawing containing 
attributes you want to extract. 

B Click to specify the format of the extracted file. 

C Specify the template file for CDF and SDF 
extracts. 

D Specify the extract output file. 

E Click to extract attributes. 

F Click to specify the output file using a file dialog 
box. 

G Click to specify the template file using a file 
dialog box. 

H Indicates the number of blocks with attributes 
selected for extraction. 

A H 

B 

C 

D 
E 

G 

F 
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Working with external references 
 

You can link entire drawings to the current drawing as external references. Unlike 

inserting a drawing as a block, in which you add all the entities from the separate 

drawing into the current drawing, external references attach a pointer to the external 

file. The entities in the external reference appear in the current drawing, but the enti- 

ties themselves are not added to the drawing. Thus, attaching an external reference 

does not significantly increase the size of the current drawing file. 

 

Understanding external references 
External references provide additional capabilities not available when you insert a 

drawing as a block. When you insert a drawing as a block, the entities are stored in 

the drawing. Any changes you make to the original drawing are not reflected in the 

drawing in which you inserted it. When you attach an external reference, however, 

any changes you make to the original drawing file are reflected in the drawings that 

reference it. These changes appear automatically each time you open the drawing 

containing the external reference. If you know that the original drawing was modi- 

fied, you can reload the external reference anytime you’re working on the drawing. 

External references are useful for assembling master drawings from component draw- 

ings. Use external references to coordinate your work with others in a group. External 

references help reduce drawing file size and ensure that you are always working with 

the most recent version of a drawing. However, if you send or receive drawings that 

contain external references, it is important to include with the master drawing all of 

the external references attached to it. When you open a drawing that contains external 

references, the source external reference files must be accessible for the external ref- 

erences to display in the drawing. 

The Xref Manager helps you easily attach and work with external references. 
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A Click to display a detailed list or hierarchical tree. 

B Select an external reference to modify its 
attachment. 

C Type or click Browse to specify the external 
reference location. 

D Type or click Browse to specify other search 
directories where external references may be 
located. 

E Click to open the source drawing for the external 
reference. 

F Click to make the external reference a permanent 
part of the drawing. 

G Click to remove the external reference, but keep 
elements and path information for easy reloading. 

H Click to update with changes from the external 
reference. 

I Click to completely remove the external reference. 

J Click to link a drawing. 

 

Attaching external references 
Attaching a separate drawing to the current one creates an external reference. The 

external reference appears in the drawing as a block definition, but the drawing enti- 

ties are linked rather than added to the current drawing. If you modify the linked 

drawing, the current drawing that contains the external reference is updated automati- 

cally when you open it, or you can reload the external reference manually so it  

reflects the latest version of the external reference. 

When you attach an external reference, its layers, linetypes, text styles, and other ele- 

ments are not added to the current drawing. Rather, these elements are also linked 

from the referenced file. 

A 

B 

J 

I 

H 

G 

F 

E 

C 

 
D 
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There are two ways you can attach an external reference: 

• An attachment is an inserted drawing that contains a link to the original file. 

Attachments can themselves contain other, nested reference files. When you attach 

an external reference, any nested references contained in the file also appear          

in the current drawing. 

• An overlay is an inserted drawing that contains a link to the original file. Overlays 

allow you to lay a drawing on top of another drawing, similar to the way you work 

manually with transparencies. When a drawing that contains overlaid external ref- 

erences is itself attached or overlaid as an external reference in another drawing, 

the overlays do not appear as part of the external reference. Use overlaying when 

you want to see reference geometry in a drawing but you do not need to include 

that geometry in drawings that will be used by others (nested external references). 

You can attach as many copies of an external reference file as you want. Each copy 

can have a different position, scale, and rotation angle. 
 

To attach an external reference 

1 Do one of the following to choose Xref Manager ( ): 

• On the ribbon, choose Insert > Xref Manager (in Reference). 

• On the menu, choose Insert > Xref Manager. 

• On the Tools toolbar, click the Xref Manager tool. 

• Type xrm and then press Enter. 

2 Click Attach. 

3 Specify the drawing file to attach as an external reference, and then click Open. 

4 In Reference Type, choose how you want to insert the drawing: 

• Attachment – inserts a copy of the drawing and includes any other drawings that 

are externally referenced within the referenced drawing. 

• Overlay – lays a copy of a drawing over your original drawing; it does not 

include any nested external references from the externally referenced drawing. 

5 Make any additional selections. 

6 Click OK. 

7 If you marked Specify On-Screen for any items, follow the prompts to attach the 

external reference. 
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A Displays the external reference to attach, or select 
one from the list. 

B Click Attachment to link a drawing, including any of 
its own external references. Click Overlay to link a 
drawing, omitting any of its own nested external 
references. 

C Choose to specify the insertion point in the 
drawing, or enter x-, y-, and z-coordinates. 

D Choose to specify the scale in the drawing, or enter 
x-, y-, and z-scale factors. 

E Choose to specify the rotation angle in the drawing, 
or enter a rotation angle. 

F Select to save the folder location of the referenced 
drawing. If not selected, the referenced drawing 
must be located in the same folder as the current 
drawing. 

G Click to locate and select a different external 
reference. 

 

Viewing the list of external references 
You can view a list of the external references that are linked to the current drawing 

two different ways using the Xref Manager: 

• List View displays the external references in a list, which allows you to sort the list 

of references by name, status, size, type, date, or saved path. 

• Tree View displays a hierarchical representation of the external references and the 

relationships between them. The tree view shows the level of nesting relationships 

of the attached external references. 
 

To view a list of external references 

1 Do one of the following to choose Xref Manager ( ): 

• On the ribbon, choose Insert > Xref Manager (in Reference). 

• On the menu, choose Insert > Xref Manager. 

• On the Tools toolbar, click the Xref Manager tool. 

• Type xrm and then press Enter. 

2 Click List View ( ) or Tree View ( ). 

A G 

B F 

E 

C 

D 
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Opening external references 
From the Xref Manager you can quickly open the source drawing for any external 

reference. This is especially helpful if you are working with nested external refer- 

ences, which you cannot bind or detach. From the Xref Manager, open the source 

drawing, make changes, and then save and close the source drawing. When the Xref 

Manager displays again, simply reload the external reference. 
 

To open an external reference 

1 Do one of the following to choose Xref Manager ( ): 

• On the ribbon, choose Insert > Xref Manager (in Reference). 

• On the menu, choose Insert > Xref Manager. 

• On the Tools toolbar, click the Xref Manager tool. 

• Type xrm and then press Enter. 

2 Select the external reference to open. 

3 Click Open. 

 
 

Use a shortcut. 

Type xopen to open an external reference without using the Xref Manager. To see any 

changes that you make to the external reference while it is open, reload it. 
 

 

 

Removing external references 
Removing external references from the current drawing is easy with the Xref Man- 

ager. You can unload an external reference, which keeps some information about the 

external reference in the current drawing for easy reloading later, or you can detach 

the external reference entirely. 

When you unload an external reference, you remove it from the current drawing. 

However, its elements, such as layers and linetypes, remain in the drawing and it is 

still listed in the Xref Manager. By detaching an external reference you remove it and 

all of its elements from the current drawing, and it is no longer listed in the Xref Man- 

ager. 
 

To unload an external reference 

1 Do one of the following to choose Xref Manager ( ): 

• On the ribbon, choose Insert > Xref Manager (in Reference). 

• On the menu, choose Insert > Xref Manager. 

• On the Tools toolbar, click the Xref Manager tool. 

• Type xrm and then press Enter. 

2 Select the external reference to unload. 

3 Click Unload. 
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To detach an external reference 

1 Do one of the following to choose Xref Manager ( ): 

• On the ribbon, choose Insert > Xref Manager (in Reference). 

• On the menu, choose Insert > Xref Manager. 

• On the Tools toolbar, click the Xref Manager tool. 

• Type xrm and then press Enter. 

2 Select the external reference to detach. 

3 Click Detach. 

 
 

Nested external references cannot be detached. 

Only the external references that are attached directly to the current drawing can be 

detached. 
 

 

 

Reloading external references 
When you open or print a drawing, any external references in the drawing are updated 

automatically. If a drawing is already open and a referenced drawing is modified, you 

can update the current drawing manually to display the latest version of the refer- 

enced drawing. 

You may also want to reload an external reference that has been unloaded temporar- 

ily. 

To reload an external reference 

1 Do one of the following to choose Xref Manager ( ): 

• On the ribbon, choose Insert > Xref Manager (in Reference). 

• On the menu, choose Insert > Xref Manager. 

• On the Tools toolbar, click the Xref Manager tool. 

• Type xrm and then press Enter. 

2 Select the external reference to reload. 

3 Click Reload. 

 
 

Use a system variable to control notifications about modified external references. 

By default, when an external reference is modified outside of 4MCAD, a notifica- 

tion appears in a balloon message and in the Event Log. To turn off these notifica- 

tions, set the XREFNOTIFY system variable to 0; to turn on notifications, set it to 2. 
 

 



496 C H A P T E R   1 3  
 

 
Changing the path for external references 
If the file associated with an external reference is moved to a different directory or 

renamed, the program displays a message indicating that it cannot load the external 

reference. You can re-establish the link to the file by doing any of the following: 

• Change the path for the external reference. 

• Specify additional directories for 4MCAD to search. This is especially helpful if 

you have several external references that have moved to a new directory. 

 

To change the path for a single external reference 

1 Do one of the following to choose Xref Manager ( ): 

• On the ribbon, choose Insert > Xref Manager (in Reference). 

• On the menu, choose Insert > Xref Manager. 

• On the Tools toolbar, click the Xref Manager tool. 

• Type xrm and then press Enter. 

2 Select the external reference whose path you want to change. 

3 In Xref Path, do one of the following: 

• Enter a new filename or location. 

• Click Browse to locate and select the referenced drawing. 

4MCAD reloads the specified external reference automatically. 

 
 

External references cannot be recursive. 

You cannot recursively reference a drawing from the same original drawing. 
 

 

 
To change the search paths for all external references in the drawing 

1 Do one of the following to choose Xref Manager ( ): 

• On the ribbon, choose Insert > Xref Manager (in Reference). 

• On the menu, choose Insert > Xref Manager. 

• On the Tools toolbar, click the Xref Manager tool. 

• Type xrm and then press Enter. 

2 In Additional Xref Search Paths, do one of the following: 

• Enter a new directory and its path. Separate multiple paths with a semicolon, for 

example, c:\My Drawings;d:\My Drawings\Backup. 

• Click Browse to locate and select a directory. 

4MCAD searches the specified directories; any found external references are 

reloaded automatically. 
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Binding external references to drawings 
External references are not part of the drawing. Rather, they are links to an externally 

referenced file. To provide a copy of a drawing containing external references to 

someone else, you must also provide all the external reference files. In addition, the 

person receiving the drawings must either re-create the same paths you used when 

linking the external references or change the paths for the external references. 

To provide a copy of a drawing that contains external references, it is often easier to 

first bind the external references to the drawing. Binding the external references 

makes them a permanent part of the drawing, which is similar to inserting a separate 

drawing as a block. 

You can bind external references that are attached directly to the current drawing; you 

cannot bind nested external references. 
 

To bind an existing external reference to a drawing 

1 Do one of the following to choose Xref Manager ( ): 

• On the ribbon, choose Insert > Xref Manager (in Reference). 

• On the menu, choose Insert > Xref Manager. 

• On the Tools toolbar, click the Xref Manager tool. 

• Type xrm and then press Enter. 

2 Select the external reference to bind. 

3 Click Bind. 

4 Choose one of the following: 

• Bind Binds the external reference and creates a unique name for each named 

entity, such as a layer or block, that is located in the external reference. For 

example, a layer named Electric in the external reference will be named 

Xref$0$Electric in the current drawing. If the current drawing already has a 

layer or block with the same name, the name is changed incrementally, for 

example, Xref$1$Electric. 

• Insert Binds the external reference, but does not change the names of any named 

entities in the external reference. For example, a layer named Electric in the 

external reference will have the same name, Electric, in the current drawing. If 

the current drawing has a layer or block with the same name, the named entity 

in the external reference takes on the properties of the named entity in the 

current drawing. 

5 Click OK. 
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Clipping external references 
When you attach a drawing as an external reference, all of the referenced drawing 

displays in the current drawing. However, after you attach an external reference, you 

can define a clipping boundary that determines which portion of the referenced draw- 

ing is visible or hidden. 

You can edit, move, or copy clipped external references the same way you modify 

unclipped external references. The boundary moves with the reference. If an external 

reference contains nested clipped external references, they also appear clipped in the 

drawing. 

In addition to clipping external references, you can also partially hide blocks using 

clipping boundaries. 

 

 

Example of an external reference clipped using a clipping boundary. The clipping boundary is the rectangle 
in the top window. 
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Adding clipping boundaries 
When you create a clipping boundary, it affects only the display of the referenced 

drawing; it does not affect the original referenced drawing or any referenced geome- 

try. The portion of the external reference within the clipping boundary is visible and 

the remainder of the external reference becomes hidden. 
 

To define a rectangular clipping boundary 

1 Do one of the following: 

• On the ribbon, choose Insert > Clip Xref (in Reference). 

• On the menu, choose Modify > Xref Clip. 

• Type xclip and then press Enter. 

2 Select the external references to clip. If desired, you can also select blocks. 

3 Press Enter. 

4 Press Enter to create a new clipping boundary. 

5 If prompted, press Enter to delete any existing boundaries. 

6 Choose Rectangular. 

7 Define the first corner of the clipping rectangle. 

8 Define the second corner of the clipping rectangle. 

The selected external references are clipped by the rectangle. 
 

 

Use the shortcut. 

You can first select all external references, right-click the selection, and then select 

Xref Clip from the shortcut menu. 
 

 

 
To define a clipping boundary using a polyline 

1 Draw a polyline where you want to clip external references. 

2 Do one of the following: 

• On the ribbon, choose Insert > Clip Xref (in Reference). 

• On the menu, choose Modify > Xref Clip. 

• Type xclip and then press Enter. 

3 Select the external references to clip. If desired, you can also select blocks. 

4 Press Enter. 

5 Press Enter to create a new clipping boundary. 

6 If prompted, press Enter to delete any existing boundaries. 

7 Choose Select Polyline. 

8 Select the polyline to use as clipping boundary. 
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Turning clipping boundaries on and off 
You can turn xref clipping on or off. When a clipping boundary is turned off, the 

boundary does not display and the entire external reference is visible, provided that 

the geometry is on a layer that is on and thawed. When a clipping boundary is turned 

off, it still exists and can be turned on. However, deleting a clipping boundary is per- 

manent. 
 

To turn clipping boundaries on and off 

1 Do one of the following: 

• On the ribbon, choose Insert > Clip Xref (in Reference). 

• On the menu, choose Modify > Xref Clip. 

• Type xclip and then press Enter. 

2 Select the desired external references. 

3 Press Enter. 

4 To turn off clipping boundaries, choose Off. To turn on existing clipping boundar- 

ies, choose On. 

5 Press Enter. 

If you are turning off a clipping boundary, click the clipped portion of the external 

reference to view the previously hidden portion of the referenced drawing. 

 
 

Use the XCLIPFRAME system variable. 

When the XCLIPFRAME system variable is on (set to 1), you can select and print the 

clipping boundary frame. 
 

 

 
Deleting clipping boundaries 
If you no longer need a clipping boundary for an external reference, you can delete it. 

 

To delete a clipping boundary 

1 Do one of the following: 

• On the ribbon, choose Insert > Clip Xref (in Reference). 

• On the menu, choose Modify > Xref Clip. 

• Type xclip and then press Enter. 

2 Select the desired external references. 

3 Press Enter. 

4 Choose Delete, and then press Enter. 

5 Click the clipped portion of the external reference. 

The previously hidden portion of the referenced drawing displays. 
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Editing external references in-place 
After an external reference is inserted in a drawing, it can be edited directly in 

4MCAD, and the source drawing file is updated automatically. Editing in-place is an 

easy way to make changes to the source file without having to locate the file and load 

it. 
 

To edit an external reference in-place 

1 Do one of the following: 

• On the ribbon, choose Insert > Edit Reference in Place (in Reference). 

• On the menu, choose Tools > Edit Block or choose X-Ref In-Place > Edit In- 

Place. 

• Type refedit and then press Enter. 

2 At the prompt, select the external reference you want to edit. 

The Reference Edit dialog box displays. 

3 In Reference Name, select the external reference you want to edit. 

4 Select the Settings tab and select from the following options: 

• Create Unique Layer, Style and Block Names Select to create unique names for 

layers, styles, and blocks that you change. A prefix is added to the original name 

of a changed layer, style, or block. Names of unchanged layers, styles, and 

blocks do not change. 

• Display Attribute Definitions for Editing Select to hide attributes and display 

attribute definitions while editing. After saving, changed attribute definitions 

affect new insertions only. 

5 Click OK. 

6 Make changes to the contents of the external reference. Any new entities created 

during edit in-place are automatically added when the external reference is closed 

and saved. 

7 To add an existing entity from the drawing to the external reference, select the 

entity and do one of the following: 

• Choose Tools > Edit Block or X-Ref In-Place > Add to Working Set. 

• Type refset, press Enter, then choose Add. 
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8 To remove an entity from the external reference, select the entity and do one of the 

following: 

• Choose Tools > Edit Block or X-Ref In-Place > Remove from Working Set. 

• Type refset, press Enter, then choose Remove. 

9 When you’re finished editing the external reference, do one of the following: 

• Choose Tools > Edit Block or X-Ref In-Place > Close Reference. 

• Type refclose and then press Enter. 

10 Choose Save to save changes or Discard to cancel changes. 

11 The external reference is updated and the current drawing displays the changes. 
 

 

You can also type xopen to open an external reference directly. 

To see any changes that you make to the external reference while it is open, reload it. 
 

 

 
 

 

Attaching underlays created in other file formats 
 

When you attach an underlay, a picture representation of the file’s contents is inserted 

into the drawing. An underlay is similar to an image and different from an external 

reference in that it cannot be linked and automatically updated. 

You can attach underlays using files that have the following formats: 

• PDF format — Portable document format viewable using Adobe® Acrobat® 

Reader® and Adobe® Acrobat. The PDF format uses the .pdf file extension. 

• Autodesk® DWFformat — Autodesk Design Web Format(used with .dwf 

files) is used to distribute a drawing for others to view in a Web browser, review, 

and edit using free Autodesk software and tools. The DWF format uses the .dwf 

file extension. 

• DGN format — Drawing files used with BentleyMicrostation. The DGN for- 

mat uses the .dgn file extension. 

• PCG format — Point cloud files used by Autodesk® software and tools. The PCG 

format uses the .pcg file extension. 

• RCP/RCS format — Point cloud files. The RCP/RCS format uses the .rcp or .rcs 

file extension. 

• IFC format — BIM files in the Industry Foundation Classes format for building 

and construction data. 

• RVT/RFA format — BIM files used by Autodesk Revit® for building and con- 

struction data. 
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Attaching a PDF underlay 
Attaching a .pdf file is similar to attaching an image file. 

 

To attach a PDF underlay 

1 Use one of the following methods: 

• On the ribbon, choose Insert > PDF Underlay (in Data). 

• On the menu, choose Insert > PDF Underlay. 

• Type pdfattach and then press Enter. 

2 Choose the .pdf file you want to attach. 

3 Click Open. 

4 Specify which page of the .pdf file to attach. 

5 Select an insertion point. 

6 Enter the scale in which to insert the .pdf file. 

7 Enter the rotation to use for the insertion. 

 

Attaching a DWF underlay 
Attaching a .dwf file is similar to attaching an image file. 

 

To attach a DWF underlay 

1 Use one of the following methods: 

• On the ribbon, choose Insert > DWF Underlay (in Data). 

• On the menu, choose Insert > DWF Underlay. 

• Type dwfattach and then press Enter. 

2 Choose the .dwf file you want to attach. 

3 Click Open. 

4 Select an insertion point. 

5 Enter the scale in which to insert the .dwf file. 

6 Enter the rotation to use for the insertion. 
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Attaching a DGN underlay 
Attaching a .dgn file is similar to attaching an image file. 

 

To attach a DGN underlay 

1 Use one of the following methods: 

• On the ribbon, choose Insert > DGN Underlay (in Data). 

• On the menu, choose Insert > DGN Underlay. 

• Type dgnattach and then press Enter. 

2 Choose the .dgn file you want to attach. 

3 Click Open. 

4 Select an insertion point. 

5 Enter the scale in which to insert the .dgn file. 

6 Enter the rotation to use for the insertion. 

 

Attaching a point cloud underlay 
A point cloud is a set of 3D points that represents the surface of an entity in three 

dimensions. Point cloud files are typically created by 3D-scanners. 

Attaching a point cloud file (.pcg, .rcp, or .rcs file) is similar to attaching an image 

file. 
 

To attach a point cloud underlay 

1 Do one of the following to choose Point Cloud Underlay ( ): 

• On the ribbon, choose Insert > Point Cloud Underlay (in Data). 

• On the menu, choose Insert > Point Cloud Underlay. 

• Type pointcloudattach and then press Enter. 

2 Choose the .pcg, .rcp, or .rcs file you want to attach. 

3 Click Open. 

4 In the Attach Point Cloud dialog box, select an insertion point. 

5 Enter the scale in which to insert the point cloud file. 

6 Enter the rotation to use for the insertion. 

7 If you want to lock the point cloud so it cannot be moved or rotated after insertion, 

mark Lock Point Cloud. 

8 If you want to zoom in to the point cloud automatically after insertion, mark Zoom 

to Point Cloud. 

9 Click OK. 
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Attaching a BIM underlay 
A Building Information Modeling (BIM) file is a drawing that typically contains a 3D 

model of a building that can be used for visualization, design, analysis, and to gener- 

ate building construction documents. You can attach the following types of BIM 

files: 

• RVT format — Drawing files used by Autodesk Revit® for building and construc- 

tion data. You can attach .rvt files only using a 64-bit version of the program. 

• RFA format — Family files used by Autodesk Revit® typically for storing build- 

ing and construction elements. You can attach .rfa files only using a 64-bit version 

of the program. 

• IFC format — Files in the IFC (Industry Foundation Classes) format used for 

building and construction data. 

Attaching a BIM file is similar to attaching an image file. 

After you attach a BIM underlay, note the following: 

• Layers Even though BIM files do not contain layers, you can control visibility by 

enabling/disabling floors or categories using the pane that displays for the BIM 

file. Use the BIMPANE command to open the corresponding pane (and use BIM- 

PANECLOSE to close the pane). 

• Entity snapping BIM underlays support entity snapping if you enable snapping 

using the UOSNAP system variable (or RVTOSNAP for only .rvt and .rfa files or 

IFCOSNAP for only .ifc files). You can also use the Options command, Snapping 

tab. 

• Exploding BIM underlays can be exploded into 4MCAD primitives. The 3D AEC 

entities contained in the BIM file will be converted into 4MCAD meshes. All 

BIM object intelligence is lost, but the geometry is converted to simple meshes 

and can be edited. 

 
 

Import an .ifc file to retain its entities. 

When importing an .ifc file, all entities are available and construction and architec- 

tural entities are converted to AEC entities. For more details, see “Importing an IFC, 

RVT, or RFA format file” on page 650. 
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To attach a BIM underlay 

1 Do one of the following to choose BIM Underlay ( ): 

• On the ribbon, choose Insert > BIM Underlay (in Data). 

• On the menu, choose Insert > BIM Underlay. 

• Type bimattach and then press Enter. 

2 Choose the .rvt, rfa, or .ifc file you want to attach. 

3 Click Open. 

4 Select an insertion point. 

5 Enter the scale in which to insert the file, then press Enter. 

6 Enter the rotation to use for the insertion, then press Enter. 
 
 

 

Working with images 
 

You can modify and view raster images directly inside of 4MCAD. You can load, 

edit, and modify multiple images as overlays or underlays to your 4MCAD draw- 

ings. The images can be selected for use with 4MCAD commands by selecting the 

image frame, which can be turned on or off for printing or selection purposes. 

4MCAD supports numerous image file formats, including BMP, JPG, GIF, EMF, 

TIF, PNG, WMF, SID, and many more. 

 

Attaching images 
When you attach an image to a drawing, the image displays in the drawing but is not 

saved in the drawing. The image file remains saved in its original location on your 

computer, network, or other media. 

If you send or receive drawings that contain images, it is important to include with the 

drawing all of the image files attached to it. When you open a drawing that contains 

images, the source image files must be accessible for the images to display in the 

drawing. 
 

To attach an image 

1 Do one of the following to choose Attach Image: 

• On the ribbon, choose Insert > Attach Image (in Data). 

• Choose Insert > Image > Attach Image. 

• On the Image toolbar, click the Attach Image tool. 

• Type imageattach and then press Enter. 

2 Specify a file to attach, and then click Open. 
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3 In Image Path will be Saved As, enter a different image file location, if necessary. 

You can click [ > ] to choose how you want to save the image path: 

• Full Path — The image is referenced using its full path, for example, c:\My 

Pictures\MyImage.jpg. Use this option if the image is saved in a folder unrelated 

to the current drawing folder. 

• Relative Path — The image is referenced using a path relative to the current 

drawing folder, for example, ..\My Pictures\MyImage.jpg. Use this option if the 

image is stored in a subfolder of the current drawing folder. 

• File Name Only — The image is referenced using its file name in the current 

drawing folder, for example, MyImage.jpg. Use this option if the image is saved 

in the same folder as the current drawing. 

4 In the Attach Image dialog box, specify the position, scale, rotation, transparency, 

and clipping options, and then click OK. 
 

 

NOTE Transparency works for images that support alpha transparency, that is, 

images that have at least one color that can be viewed as a transparent color. 
 

 

 

5 In the drawing, specify an insertion point, scale, and rotation if you chose to spec- 

ify those on the screen. 
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A Enter a different image file location, if necessary. 

B Choose to place the image automatically in the 
drawing using specifications located in a positioning 
file. Enter the TWF file associated with the image or 
click [...] to select it. 

C Choose to specify the insertion point in the drawing 
upon insertion, or enter coordinates. 

D Choose to specify the size of the image in the 
drawing upon insertion, or enter the size values. 

E Choose whether to turn clipping display on or off for 
the image. 

F Choose whether entities located under the image are 
visible (for images that support alpha transparency). 

G Choose to specify rotation in the drawing upon 
insertion, or enter how many degrees to rotate the 
image to the left. 

H Click to view image information, including color depth 
and resolution. 

I Choose to save the image path as its full path, 
relative path to the current drawing folder, or file 
name in the current drawing folder. 

 
 

You can also attach images using the Image Manager or 4MCAD Explorer 

Choose Insert > Image > Image Manager, and then click Attach to specify an 

image and then attach it, or if you want to quickly add another occurrence of an 

image already located in the drawing, select the image in the Image Manager and 

then click Add. Or, choose Tools > 4MCAD Explorer and attach an image as an 

externally reference file. 
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Modifying images 
You can modify an image by changing its brightness, contrast, fade, size, rotation, or 

transparency. These changes affect the image in the drawing only — not the original 

image file. 

In addition to modifying a single image or multiple images that you select, you can 

also modify all occurrences of an image within a drawing. For example, if your com- 

pany logo appears in multiple locations throughout a drawing, you can use the Image 

Manager to specify the changes once and apply them to all occurrences of the logo. 

You can use other 4MCAD commands for typical modifications, such as Delete, 

Move, Layer, and more. 
 

To modify images 

1 Do one of the following to choose Image Manager (  ): 

• On the ribbon, choose Insert > Image Manager (in Data). 

• On the menu, choose Insert > Image > Image Manager. 

• On the Image toolbar, click the Image Manager tool. 

• Type image and then press Enter. 

 
 

TIP You can also modify images by selecting one or more images in a drawing, 

and then choosing Modify > Properties. 
 

 

 

2 In the Images list, select the image you want to modify. If there is more than one 

occurrence of the image in the drawing, do one of the following: 

• To modify all occurrences of the image, select a top-level image in the list. 

• To modify a single occurrence of the image, expand a top-level image in the list, 

and then select the individual image. 

3 Adjust the Brightness, Contrast, and Fade by moving the slider to the setting you 

want or by entering an exact number. The image preview shows how your changes 

will affect the image. 
 

 

TIP If you want to restore the image to the default brightness, contrast, and fade 

settings, click Reset. 
 

 

 

4 Adjust the Size by making changes to the width (X) and height (Y) in drawing 

units. Mark Keep Aspect Ratio if you want the width and height to change 

together to retain the aspect ratio of the image. 

5 Adjust the Rotation by entering the number of degrees you want to rotate the 

image to the left. Zero degrees indicates no rotation. 

6 Mark Use Transparency if you want entities located under the image to be visible 

(for images that support alpha transparency, that is, images that have at least one 

color that can be viewed as a transparent color). 
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7 Mark Show Clipping Boundary if you want to show the image clipped, if a clip- 

ping boundary is defined for the image. Unmarking this option displays the whole 

image, even if a clipping boundary is defined. 

8 Click OK. 

 

 

 

 

 

A 
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D 
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G 
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A Click a top-level image to modify all occurrences 
located in the drawing. Expand a top-level image and 
click an individual image to modify that occurrence 
only. 

B Move the slider or enter an exact number for image 
brightness. 

C Move the slider or enter an exact number for image 
contrast. 

D Move the slider or enter an exact number for image 
fade, which fades the image without displaying 
entities located under the image. 

F 

E Click to return to the default brightness, contrast, and 
fade settings. 

F Enter the width (X) and height (Y) in drawing units. 
Mark Keep Aspect Ratio to change width and height 
together. 

G Choose whether to turn clipping display on or off for 
the image. 

H Choose whether entities located under the image are 
visible (for images that support alpha transparency). 

I Enter how many degrees to rotate the image to the 
left. 
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Changing the display of images 
You can change the following for how all images display in a drawing: 

• Image quality — Images can display in high or low resolution. 

• Image frames — Images can display with or without frames on their edges. 

 
Changing the display quality for all images 
High quality displays images in high resolution and requires more system resources. 

Draft quality displays images in low resolution and consumes fewer system 

resources. Changing the quality setting affects all images in the drawing. 
 

To change the display quality for all images 

1 Do one of the following to choose Image Quality (  ): 

• On the ribbon, choose Insert > Image Quality (in Data). 

• On the menu, choose Insert > Image > Image Quality. 

• On the Image toolbar, click the Image Quality tool. 

• Type imagequality and then press Enter. 

2 Choose High or Draft. 

 
Turning image frames on or off for all images 
When image frames are turned on, a frame displays and prints on the edge of all 

images in the drawing. When image frames are turned off, none of the images display 

or print with a frame, which also makes images unselectable. Each image frame dis- 

plays with the properties (layer, color, linetype, etc.) that are assigned to the image. 

Turning image frames off may be helpful, for example, if the images are part of a 

background in the drawing. 
 

To turn image frames on or off for all images 

1 Do one of the following to choose Display Image Frame ( ): 

• On the ribbon, choose Insert > Display Image Frame (in Data). 

• On the menu, choose Insert > Image > Display Image Frame. 

• On the Image toolbar, click the Display Image Frame tool. 

• Type imageframe and then press Enter. 

2 Choose On or Off. 
 

 

TIP You can use IMAGEFRAMEMODE to turn image frames on or off while dis- 

play and printing images. 
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Clipping images 
You can clip images so that only a portion of the image is visible in a drawing. The 

visible portion (or the invisible portion for inverted clips) can be in the shape of a 

rectangle or polygon. 

Image clipping can be turned on an off. If you turn off clipping for an image, the 

entire image is visible provided that the image is on a layer that is on and thawed. The 

clipping information is retained however, and you can turn clipping back on at any 

time. 

If you delete clipping from an image, the clipping is removed permanently but the 

image itself remains in the drawing. 

 
Clipping images in the shape of a rectangle 

To clip an image in the shape of a rectangle 

1 Make sure that image frames are turned on — so you can select images — by 

choosing Image > Display Image Frame, and then choose On. 

2 Do one of the following to choose Clip Image (  ): 

• On the ribbon, choose Insert > Clip Image (in Data). 

• On the menu, choose Insert > Image > Clip Image. 

• On the Image toolbar, click the Clip Image tool. 

• Type imageclip and then press Enter. 

3 Select the edge of the image you want to clip. 

4 If prompted, choose New to create a new clipping boundary. 

5 Choose Rectangle. If you want to invert the clip, that is, hide the area inside the 

boundary, choose Invert clip before choosing Rectangle. 

6 Define the first corner of the clipping rectangle. 

7 Define the opposite corner of the clipping rectangle. 

Only the portion of the image located within the clipping rectangle is visible. 
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Clipping images in the shape of a polygon 

To clip an image in the shape of a polygon 

1 Make sure that image frames are turned on — so you can select images — by 

choosing Image > Display Image Frame, and then choose On. 

2 Do one of the following to choose Clip Image (  ): 

• On the ribbon, choose Insert > Clip Image (in Data). 

• On the menu, choose Insert > Image > Clip Image. 

• On the Image toolbar, click the Clip Image tool. 

• Type imageclip and then press Enter. 

3 Select the edge of the image you want to clip. 

4 If prompted, choose New to create a new clipping boundary. 

5 Choose Polygon. If you want to invert the clip, that is, hide the area inside the 

boundary, choose Invert clip before choosing Polygon. 

6 Select the points for the polygon, and then press Enter when the polygon is com- 

plete. 

Only the portion of the image located within the clipping polygon is visible. 

 
Turning clipping on or off for images 

To turn clipping on or off for an image 

1 Make sure that image frames are turned on — so you can select images — by 

choosing Image > Display Image Frame, and then choose On. 

2 Do one of the following to choose Clip Image (  ): 

• On the ribbon, choose Insert > Clip Image (in Data). 

• On the menu, choose Insert > Image > Clip Image. 

• On the Image toolbar, click the Clip Image tool. 

• Type imageclip and then press Enter. 

3 Select the edge of the image for which you want to turn clipping on or off. 

4 Choose On or Off. 
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Removing clipping from images 

To remove clipping from an image 

1 Make sure that image frames are turned on — so you can select images — by 

choosing Image > Display Image Frame, and then choose On. 

2 Do one of the following to choose Clip Image (  ): 

• On the ribbon, choose Insert > Clip Image (in Data). 

• On the menu, choose Insert > Image > Clip Image. 

• On the Image toolbar, click the Clip Image tool. 

• Type imageclip and then press Enter. 

3 Select the edge of the image for which you want to remove clipping. 

4 Choose Delete. 

 

Unloading and reloading images 
If you find that including an image affects system performance, you can unload it so 

only the image frame displays to mark its location. If you want an unloaded image to 

print, reload it before printing. You may also want to reload an image if the original 

file contains new content. 
 

To unload and reload an image 

1 Do one of the following to choose Image Manager (  ): 

• On the ribbon, choose Insert > Image Manager (in Data). 

• On the menu, choose Insert > Image > Image Manager. 

• On the Image toolbar, click the Image Manager tool. 

• Type image and then press Enter. 

2 In the Images list, select the desired image. If there is more than one occurrence of 

the image in the drawing, do one of the following: 

• To unload or reload all occurrences of the image, select a top-level image in the 

list. 

• To unload or reload a single occurrence of the image, expand a top-level image 

in the list, and then select the individual image. 

3 Do one of the following: 

• To unload the image so only its outer edge displays, click Unload. 

• To reload the image so its contents display and print, click Reload. 



W O R K I N G   W I T H   O T H E R   F I L E S   I N   Y O U R   D R A W I N G S 515 
 

 
Changing the path for images 
If the file associated with an image is renamed or moved to a different location, the 

program displays a message indicating that it cannot load the image. You can re- 

establish the link to the file by changing the path for the image. 
 

To change the path for an image 

1 Do one of the following to choose Image Manager (  ): 

• On the ribbon, choose Insert > Image Manager (in Data). 

• On the menu, choose Insert > Image > Image Manager. 

• On the Image toolbar, click the Image Manager tool. 

• Type image and then press Enter. 

2 In the Images list, select the desired image. If there is more than one occurrence of 

the image in the drawing, do one of the following: 

• To change the path for all occurrences of the image, select a top-level image in 

the list. 

• To change the path for a single occurrence of the image, expand a top-level 

image in the list, and then select the individual image. 

3 Click the [...] button. 

4 Select the file with its new name or in its new location, and then click Open. 

5 Click Set Path. 

 

Deleting images 
Once an image is no longer required in the drawing, you can delete it from the draw- 

ing. Deleting an image removes it from the drawing, and from the list of images in the 

Image Manager dialog box. 
 

To delete an image 

1 Do one of the following to choose Image Manager (  ): 

• On the ribbon, choose Insert > Image Manager (in Data). 

• On the menu, choose Insert > Image > Image Manager. 

• On the Image toolbar, click the Image Manager tool. 

• Type image and then press Enter. 

2 In the Images list, select the image you want to delete. If there is more than one 

occurrence of the image in the drawing, do one of the following: 

• To delete all occurrences of the image, select a top-level image in the list. 

• To delete a single occurrence of the image, expand a top-level image in the list, 

and then select the individual image. 

3 Click Detach. 
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Printing drawings 
 

You can print a copy of your drawing exactly as you created it, or you can add 

formatting and specify print controls to change how your drawing looks when it is 

printed. 

Sometimes you may require multiple printed drawings, each with a different look or 

layout. For example, you may need one printed drawing for a client presentation, 

along with several other variations for production contractors. For each type of 

printed drawing that you require, you can create a layout that defines its 

characteristics, including scale, area to print, print style tables, and more. 

This section explains how to: 

• Start printing right away. 

• Set up a drawing to print multiple layouts from paper space on a Layout tab. 

• Customize how you want your drawing to look when it is printed. 

• Define how to print your drawing further using print styles. 

• Print or plot your drawing. 

• Publish your drawing. 

 

 

 
 

 

 

 

 

14 
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Getting started printing 
 

When you create a drawing, you do most of your work on the Model tab. At any time 

you can print your drawing to see how it looks on paper. It’s easy to get started print- 

ing, and then later create layouts and custom print settings to enhance your printed 

output. 

 

To start printing 

1 From the Model tab, do one of the following to choose Print ( ): 

• On the ribbon, choose the Application button then choose Print, or choose 

Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Print. 

• On the Standard toolbar, click the Print tool. 

• Type print and then press Enter. 

2 Click Print. 
 

There are many print options detailed in this section, such as the scale of the drawing, 

print area, print style tables, and more. 

 
 

Type qprint and then press Enter to print the current viewport. 

The Print dialog box is bypassed and the drawing is sent directly to the selected 

printer. 
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Defining layouts for printing 
 

You can print your drawing directly from the Model tab where you created it, or you 

can create custom layouts for printing on Layout tabs. 

When printing from the Model tab, you can print your drawing exactly the way it 

appears, or you can modify the drawing before printing by adding dimensions, a leg- 

end, or a title block. 

You typically use the Layout tabs for printing if you require multiple print layouts. 

You may also want to use a Layout tab for printing even if you want your drawing 

printed only one way. For example, if you want to include large amounts of text on 

your printed drawing, you can add the text to a Layout tab so it does not clutter your 

drawing while you work on the Model tab. 

 

Understanding layouts 
When you create a drawing, you do most of your work on the Model tab. Each draw- 

ing that you create can contain numerous layouts that simulate the paper on which you 

will print a copy of the drawing. Each of these layouts is created on a Layout tab. 

You can prepare a separate layout for each way you want to print your drawing. The 

layout allows you to organize different views to control which portion of your draw- 

ing prints and at what scale. 

Before you print, you can also include additional entities and layout settings that con- 

trol how your drawing prints. Additional items only appear on the Layout tab, not on 

the Model tab. For example, a layout can contain dimensions, title blocks, legends, or 

keynotes that print with your model, but do not clutter the screen when you work with 

your model on the Model tab. 

Use these general steps to prepare your drawing for printing multiple layouts: 

1 On the Model tab, create your drawing. 

2 Create a new layout. You can use an existing Layout1 or Layout2 tab, or you can 

create a new Layout tab. For details, see “Creating a new layout” on page 523 in 

this chapter. 

3 Create at least one layout viewport on the Layout tab. Use each viewport to help 

control which portion of the drawing prints and at what scale. For details, see 

“Working with layout viewports” on page 526 in this chapter. 

4 Include any additional items that may be required for the specific layout, such as 

dimensions, a legend, or a title block. 

5 Specify additional settings for the layout, such as the scale of the drawing, print 

area, print style tables, and more. For details, see “Customizing and reusing print 

settings” on page 532 in this chapter. 

6 Print or plot your drawing. For more details, see “Printing or plotting your draw- 

ing” on page 558 in this chapter. 
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Understanding paper space and model space 
When you start a drawing session, your initial working area is called model space. 

Model space is an area in which you create two-dimensional and three-dimensional 

entities based on either the World Coordinate System (WCS) or a user coordinate 

system (UCS). You view and work in model space while using the Model tab. 

Your view of this area is a single viewport that fills the screen. You can create addi- 

tional views on the Model tab, called viewports, which can show the same or differ- 

ent two-dimensional or three-dimensional views, all of which are displayed in a tiled 

manner. You can work in only one of these viewports at a time on the Model tab, and 

you can print only the current viewport. 

 

 
Model space with two viewports. 

4MCAD provides an additional work area, called paper space. The contents of paper 

space represent the paper layout of your drawing. In this work area, you can create 

and arrange different views of your model similar to the way you arrange detail 

drawings or orthogonal views of a model on a sheet of paper. You can also add 

dimensions, keynotes, annotations, borders, title blocks, and other print-related 

entities in paper space, which reduces clutter when you work with your model in 

model space. 

You view and work in paper space while using a Layout tab. Each view, or layout 

viewport, that you create in paper space provides a window of your drawing in model 

space. You can create one layout viewport or several. You can place layout viewports 

anywhere on the screen; their edges can be touching or not; and you can print them all 

at the same time. 
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You do not need to use paper space to print your drawing, but it offers several advan- 

tages: 

• Print the same drawing with different print settings that you save with each layout, 

for example, printer configuration files, print style tables, lineweight settings, 

drawing scale, and more. 

• Add print-related entities that are not essential to the model itself, such as key- 

notes or annotations, to reduce clutter when you work with your model in model 

space on the Model tab. 

• For a single layout, create multiple layout viewports that print the model at differ- 

ent views and scales. 
 

 
 
 

Paper space with layout viewports. 

 
 

You can copy and move entities between model space and paper space. 

Choose Modify > Change Space, then select the entities you want to copy or move 

from paper space to model space or from model space to paper space. 
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Viewing drawings in paper space and model space 
When you work in paper space on a Layout tab, you can still view your drawing in 

model space. First you need to create a layout viewport in paper space; this allows 

you to view your model space entities from paper space. 

Within a layout viewport you can modify and snap to model space entities while 

working in model space and even snap to model space entities from paper space. 

Snapping to model space entities from paper space allows you to accurately dimen- 

sion model space entities in paper space. And although it is generally more conve- 

nient to modify entities on the Model tab, there are often times when it is convenient 

to make modifications from a layout viewport on a Layout tab. 

Zooming or panning the drawing in model space or paper space affects the entire 

drawing, unless you use multiple windows or viewports. Additionally, if you are 

working from paper space, you can lock the layout viewport so the viewport scale and 

view center do not change while panning and zooming in the layout viewport. 
 

To view a drawing in model space on the Model tab 

Do one of the following: 

• Click the Model tab. 

• Right-click the Model/Paper Space toggle in the status bar, and then choose 

Model. 
 

To view a drawing in paper space on a Layout tab 

Do one of the following: 

• Click one of the Layout tabs. 

• Type layout and then press Enter. In the prompt box, choose Set. Type a name for 

the layout you want to make current, and then press Enter. 

• Double-click the Model/Paper Space toggle in the status bar. For example, double- 

click “Model” or “M:Tab Name” in the status bar to switch to paper space. 

• While using a Layout tab, type pspace and then press Enter. 

• While using a Layout tab, double-click outside of the layout viewport. 
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To view a drawing in model space on a Layout tab 

Do one of the following: 

• Click the desired Layout tab, and then create and view a layout viewport. For more 

details, see “Working with layout viewports” on page 526 in this chapter. 

• Double-click the Model/Paper Space toggle in the status bar. For example, double- 

click “P:Tab Name” in the status bar to switch to model space on the current Lay- 

out tab. 

• Type mspace and then press Enter. 

• While using a Layout tab, double-click inside of the layout viewport. 

 

Displaying the Model and Layout tabs 
The Model and Layout tabs can be hidden, if desired. You may want to hide the tabs 

if you only work on the Model tab or if you use the command bar and status bar to 

switch between tabs. 
 

To turn the Model and Layout tabs display on or off 

Do one of the following: 

• On the ribbon, choose View > Model and Layout tabs (in Display). 

• Choose View > Display > Model and Layout tabs. 

• Choose Tools > Options > Display tab, and choose Show Tabs. 

 

Creating a new layout 
In 4MCAD, you can create multiple layouts for a single drawing. Each layout rep- 

resents a sheet of paper. For each layout you can specify the print area, print styles, 

print scale, lineweight scale, pen mappings, and add viewports, dimensions, a title 

block, and other geometry specific to the layout. 

The entities you add to a layout in paper space do not appear in model space. 

Each layout requires at least one layout viewport, which is created automatically 

when you create a new layout. This viewport displays the drawing’s model space 

entities. 

When you create a new drawing, the drawing automatically contains two default lay- 

outs: Layout1 and Layout2. You can start by using one of the default layouts, you can 

create your own, or your can create a new layout from another template (.dwt) file, 

drawing (.dwg) file, or drawing interchange (.dxf) file. You can also use 4MCAD 

Explorer to create and manage layouts. 

Each drawing can contain up to 255 layouts. 
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To create a new layout using the Layout1 or Layout2 tab 

1 Click the Layout1 or Layout2 tab. 

2 If necessary, set up at least one layout viewport. For details, see “Working with 

layout viewports” on page 526 in this chapter. 

3 If desired, rename the layout. For details, see “To rename a layout” on page 525 in 

this chapter. 

 

To create a new layout using a new Layout tab 

1 Do one of the following to choose New Layout (  : 

• On the ribbon, choose View > New Layout (in Layouts). 

• Choose Insert > Layout > New Layout. 

• On the Layouts toolbar, click the New Layout tool. 

• Type layout, press Enter, and choose New. 

2 Type a unique name for your layout and then press Enter. 

The name can be up to 255 characters in length and can contain letters, numbers, 

the dollar sign ($), hyphen (-), and underscore (_), or any combination. 

3 Set up at least one layout viewport. For details, see “Working with layout view- 

ports” on page 526 in this chapter. 

 

To create a new layout from an existing file 

1 Do one of the following :to choose Layout from Template (  

• On the ribbon, choose View > Layout from Template (in Layouts). 

• On the menu, choose Insert > Layout > Layout from Template. 

• On the Layouts toolbar, click the Layout from Template tool. 

• Type layout, press Enter, and choose Template. 

• Right-click a Layout tab and choose From Template. 

2 Select the desired template, drawing, or drawing interchange file that contains the 

layout you want, and then click Open. 

3 Select the layout(s), and then click OK. You can choose multiple layouts by hold- 

ing down Ctrl while selecting layout names. 

 

Reusing layouts from other files 
Save time by re-using layouts that you have already created. Within the same draw- 

ing, you may want to make a copy of a layout that contains most of the settings you 

want, and then make changes to the new copy. If you created layouts that you want to 

use again when you create new drawings, you can save the layouts as a drawing tem- 

plate. 
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To make a copy of a layout 

1 Type layout and then press Enter. 

2 In the prompt box, choose Copy. 

3 Type the name of the layout you want to copy, and then press Enter. 

4 Type a name for the new layout, and then press Enter. 
 

To save a layout as a drawing template 

1 Type layout and then press Enter. 

2 In the prompt box, choose Save. 

3 Type the name of the layout that you want to save, and then press Enter. 

4 Specify the file name and location for the template, and then click Save. 
 

After you save a layout as a template, you can use the template when you create new 

drawings. You can also import the template’s layouts into another drawing. 

 

Managing layouts in a drawing 
You can rename layouts, delete layouts, and view a list of all layouts available in a 

drawing. You can also change the order in which the Layout tabs appear; the Model 

tab is always stationary. 

If you want to rename, delete, or reorder a layout when the Layout tabs are hidden, 

you can type layout to make your changes or choose View > Display > Model and 

Layout Tabs to display the tabs. 
 

To rename a layout 

1 Right-click the Layout tab to rename. 

2 Type a new name for the layout. 

3 Click OK. 

The name can be up to 255 characters in length and can contain letters, numbers, 

the dollar sign ($), hyphen (-), and underscore (_), or any combination. 

 

To delete a layout 

1 Right-click the Layout tab to delete. 

2 Click OK to confirm the deletion. 

 
 

You cannot delete the Model tab or the last remaining Layout tab. 

To delete all geometry from the Model tab or a Layout tab, first select all geometry 

and then use the Erase command. 
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To reorder the Layout tabs 

1 Right-click the Layout tab you want to move. 

2 Do one of the following: 

• Choose Move Right, and then choose a new location. 

• Choose Move Left, and then choose a new location. 

To view a list of all layouts 

1 Type layout and then press Enter. 

2 In the prompt box, choose ? to list all layouts. 

3 Type s or press Enter to scroll through the layouts. 

 

Working with layout viewports 
A layout viewport is a window in a Layout tab (paper space) that displays all or a por- 

tion of a drawing’s model space entities. 

 
Understanding layout viewports 
When you begin working in a drawing on the Model tab, it consists of a single view 

of your model. You may have created additional views by dividing the drawing space 

into multiple windows; each window is a separate viewport on the Model tab. 

Similarly, when you begin working in a drawing on a Layout tab, it consists of a sin- 

gle view from paperspace of your model. You can also create multiple layout view- 

ports that display unique views of your model. Each layout viewport functions as a 

window into your model space drawing — with each window looking different from 

the next. You can customize the view center, scale, layer visibility, and contents of 

each layout viewport. Each layout viewport is created as a separate entity that you can 

move, copy, or delete. 

Click any layout viewport to make it the current viewport, and then add or modify 

model space entities in that viewport, even while snapping to model space entities 

from paper space. Any changes you make in one layout viewport are immediately 

visible in the other viewports (if the other layout viewports are displaying that portion 

of the drawing). Zooming or panning in the current viewport affects only that view- 

port. 

This section focusses on working with layout viewports in paper space on a Layout 

tab. For additional information about viewports in model space, see “Dividing the 

current window into multiple views” on page 221. 
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Creating layout viewports 
The first time you switch to a Layout tab, your model displays in a default layout 

viewport. You can create other layout viewports anywhere inside the drawing area. 

You can control the number of viewports created and the arrangement of the view- 

ports. 
 

To create layout viewports 

1 Do one of the following to choose Layout Viewports (  ): 

• On the ribbon, choose View > Layout Viewports (in Layouts). 

• On the menu, choose View > Viewports > Layout Viewports. 

• On the Viewports toolbar, click the Layout Viewports tool. 

• Type mview and then press Enter. 

2 Specify two opposing corners to create a custom rectangular viewport, or in the 

prompt box, choose one of the following: 

• Fit To View — Creates a layout viewport that fills the screen. 

• Entity — Converts a closed entity to a layout viewport. You can convert a circle, 

ellipse, closed polyline, spline, or region. 

• Polygonal — Creates a non-rectangular layout viewport. 

• Create 2 Viewports, Create 3 Viewports, Create 4 Viewports — Creates two, 

three, or four layout viewports using an orientation that you specify. You can 

select whether to arrange the viewports to fill the current graphic area or a 

rectangular area that you specify. 

 
 

The border of a new layout viewport is created on the current layer. 

You can make layout viewport borders invisible by creating a new layer before you 

create layout viewports and then turning off that layer after you create the layout 

viewports. To select a layout viewport’s borders, you must turn that layer back on 

before you can rearrange or modify the layout viewport. 
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You can create a single layout viewport, or you can divide the graphic area into two viewports arranged 
vertically (A) or horizontally (B); three viewports arranged left (C), right (D), above (E), below (F), vertically 
(G), or horizontally (H); or four viewports (I). 
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Viewing and scaling layout viewports 
If you have created numerous layout viewports, your system performance may be 

affected. If necessary, you can turn a layout viewport on or off. Turning off a layout 

viewport does not delete the viewport or its contents; it simply turns off its display. 

You can also change how you view items within a layout viewport by specifying a 

scale factor, which changes how large or small model space entities appear within the 

layout viewport. 

While working in a layout viewport, you can use the Maximize Viewport command 

to enlarge the view to full size and emulate model space, allowing you to easily work 

on the geometry in that view. When done, use the Minimize Viewport command to 

switch back to the original scale and center point of the layout viewport. 
 

To turn layout viewports on or off 

1 Click the desired Layout tab. 

2 Do one of the following to choose Layout Viewports (  ): 

• On the ribbon, choose View > Layout Viewports (in Layouts). 

• On the menu, choose View > Viewports > Layout Viewports. 

• On the Viewports toolbar, click the Layout Viewports tool. 

• Type mview and then press Enter. 

3 Choose On or Off. 

4 Select the edge of the layout viewport to turn on or off, and then press Enter. 
 

To maximize a layout viewport 

1 On a Layout tab, select a layout viewport. Or, skip this step to maximize the cur- 

rent layout viewport. 

2 Do one of the following: 

• On the ribbon, choose View > Maximize Viewport (in Model Viewports). 

• On the menu, choose View > Viewports > Maximize Viewport. 

• On the status bar, click Maximize Viewport (  ). 

• Type vpmax and then press Enter. 

The layout viewport is enlarged. 

To minimize a layout viewport (if it is maximized) 

1   Do one of the following: 

• On the ribbon, choose View > Minimize Viewport (in Model Viewports). 

• On the menu, choose View > Viewports > Minimize Viewport. 

• On the status bar, click Minimize Viewport (  ). 

• Type vpmin and then press Enter. 

The layout viewport returns to its original scale and center point. 
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To change the layout viewport scale 

1 Do one of the following to choose Properties (  ): 

• On the ribbon, choose View > Properties (in Display). 

• On the menu, choose Modify > Properties. 

• On the Modify toolbar, click the Properties tool. 

• Type entprop and then press Enter. 

2 Select the edge of the layout viewport. 

3 In Custom Scale, enter the scale at which you want to view model space entities 

from within the layout viewport. 

4 Click OK. 
 

To report the scale of a layout viewport scale 

1 Do one of the following to choose List Viewport Scale (  ): 

• On the ribbon, choose Express Tools > List Viewport Scale (in Layout). 

• On the menu, choose Express Tools > Layout > List Viewport Scale. 

• Type vpscale and then press Enter. 

2 Select the edge of the layout viewport, then press Enter. 

The viewport scale (paperspace to model space) displays in the command bar. 
 

To change the scale of model space entities relative to paper space 

1 Click the Model tab. 

2 Click a viewport to make it current. 

3 Choose View > Zoom > Zoom. 

4 Type the zoom scale factor relative to paper space by appending the suffix xp to 

the scale factor, and then press Enter. 

For example, to increase the scale of the entities in the viewport on the Model tab 

to twice the size of paper space units, type 2xp. To decrease the scale to half the 

size of paper space units, type .5xp. 

 

To synchronize layout viewports 

1 Do one of the following to choose Synchronize Viewports (  ): 

• On the ribbon, choose Express Tools > Synchronize Viewports (in Layout). 

• On the menu, choose Express Tools > Layout > Synchronize Viewports. 

• Type vpsync and then press Enter. 

2 Select the master layout viewport that has the desired zoom factor. 

3 Select one or more viewports to align with the master viewport, then press Enter. 
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Modifying layout viewports 
After you create layout viewports, you can modify them as needed. On the Layout 

tab, you can snap to the viewport borders using entity snaps. You can copy, delete, 

move, scale, and stretch layout viewports as you would any other drawing entity. 

Additionally, you can lock a layout viewport so the viewport scale and view center do 

not change in model space while panning or zooming in the layout viewport. If you 

are working on model space entities from a Layout tab, locking the layout viewport 

prevents you from constantly changing the layout viewport scale and view center. 

And assigning a UCS to each viewport allows you to quickly switch between layout 

viewports and immediately draw in a different UCS. This can greatly increase pro- 

ductivity, especially when creating complex 3D models. 

Modifying a layout viewport on a Layout tab does not affect the model space entities 

within the layout viewport. 
 

To modify layout viewport properties 

1 Click the desired Layout tab. 

2 Do one of the following to choose Properties (  ): 

• On the ribbon, choose View > Properties (in Display). 

• On the menu, choose Modify > Properties. 

• On the Modify toolbar, click the Properties tool. 

• Type entprop and then press Enter. 

3 Select the edge of the layout viewport you want to modify. 

4 Adjust the center point, width, or height of the viewport. 

5 In Custom Scale, enter the scale at which you want to view model space entities 

from within the layout viewport. 

6 In Display Locked, choose True to lock the viewport scale and view in model 

space while panning or zooming in the layout viewport. 

7 Mark UCS per Viewport if you want to use a unique UCS for each layout view- 

port. 

8 Click OK. 
 

 

You can select only layout viewports for modification. 

If you click a viewport on the Model tab, it makes that viewport active, not available 

for modification. 
 

 

 
Clipping layout viewports 
You can clip layout viewports so that only a portion of the viewport is visible on a 

Layout tab. You can clip layout viewports in the shape of a new polygon or an exist- 

ing circle, ellipse, closed spline, closed polyline, or region. 
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If you delete clipping from a layout viewport, the clipping is removed permanently 

but the viewport itself and its contents remain in the drawing. 
 

To clip a layout viewport in the shape of an existing entity 

1 Click a Layout tab, and select the desired layout viewport. 

2 Type vpclip and then press Enter. 

3 In the drawing, select an existing circle, ellipse, closed spline, closed polyline, or 

region to use as a clipping boundary. 
 

To clip a layout viewport in the shape of a new polygon 

1 Click a Layout tab, and select the desired layout viewport. 

2 Type vpclip and then press Enter. 

3 Press Enter to create a new clipping boundary. 

4 Define the first point of the clipping polygon. 

5 Define additional points. 

6 Press Enter when done. 
 

To delete a clipping boundary 

1 Click a Layout tab, and select the desired layout viewport. 

2 Type vpclip and then press Enter. 

3 Choose Delete, and then press Enter. 
 
 

 

Customizing and reusing print settings 
 

Most drawings require adjustments to print settings in order to print the way you 

want. You can make adjustments to the print settings each time you print, but you can 

also create page setups, which save the print settings and assign them to different lay- 

outs in your drawing. If you have several perspectives of your drawing that require 

printing, using page setups is the most efficient way to print. 

 

Working with page setups 
Page setups store printer information for specific models or layouts, which eliminates 

the need to completely reconfigure your print settings each time you print a drawing 

and helps ensure that each perspective of a drawing prints as planned. 

 
Assigning a page setup to a model or layout 
Because the main model on the Model tab and the various layouts for printing on the 

Layout tabs all may require unique print settings, the model and each layout can be 

assigned a separate page setup. If some layouts use the same print settings, those 

layouts can be assigned the same page setup. 
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Assigning a page setup to a model or layout doesn’t mean it will always print with the 

specified settings. All of the print settings specified for a page setup can be overrid- 

den at print time. 
 

To assign a page setup to a model or layout 

1 Click the Model tab or Layout tab that you want to assign a page setup. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Select the desired page setup. 

4 Click Set Current. 

5 Click OK. 

 
 

You can also choose a page setup at print time. 

In the Print dialog box, select a different page setup from the Page Setup list before 

you click Print. 
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A Displays the name of the model or layout to which 
the current page setup is assigned. 

B Displays a list of all model page setups or layout 
page setups, depending on whether you were 
viewing the Model tab or a Layout tab before 
opening the dialog box. 

C Displays details about the currently selected page 
setup. 

D Click to delete the currently selected page setup. 

E Click to modify the settings for the currently 
selected page setup. 

F Click to create a new page setup. 

G Click to assign the currently selected page setup to 
the current layout. 

 

Creating a page setup 
There are two types of page setups: 

• Model page setup — Contains print settings available for the model on the Model 

tab. 

• Layout page setup — Contains print settings available for one or more layouts on 

the Layout tabs. 

4MCAD comes with two default page setups — one model page setup and one lay- 

out page setup. You can create as many additional page setups, of either type, as 

required for any drawing. Each page setup specifies many aspects of printing, includ- 

ing page size, default printer or plotter, page orientation, print scale, and more. 
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To create a page setup 

1 To create a model page setup, click the Model tab. To create a layout page setup, 

click any Layout tab. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Click Add. 
 

 

You can create a new page setup based on the print settings of an existing page setup. 

Select an existing page setup in the list, then click Add. The new page setup uses 

the print settings of the existing page setup as a starting point. 
 

 

 

4 Enter a name for the page setup, then click OK. 

5 Select the desired print options. 

6 Click OK. 
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A Displays “Layout” if creating a layout page setup or 
“Model” if creating a model page setup. 

B Enter any changes to page setup name. 

C Click to specify options for the selected printer. 

D Select the printer and view its details. 

E Select a paper size supported by the selected 
printer. 

F Select a predefined print scale, or choose Custom 
to specify your own. 

G Select to fit the specified print area to the current 
paper size. 

H Specify the custom scale for the print area by typing 
the ratio of drawing units to printed inches or printed 
millimeters. 

I Click to specify drawing units and paper size in 
millimeters or inches. 

J Select to center the print area on the printed page. 

K Type x- and y-coordinates to specify the origin of 
the print area. 

L Click to select the area of the drawing that you want 
to print. 

M Type the x- and y-coordinates of the two opposing 
corners of the rectangular area to print, or click 
Select Print Area to specify coordinates in the 
drawing window. (Available only if Window is 
selected for What to print.) 

N Select to print the drawing upside down on your 
printer. 

O Select portrait (vertical) or landscape (horizontal) 
orientation. 

P Select how to print lineweights and print styles. 

Q Select to prevent paperspace entities from printing. 

R Select to print paperspace entities after printing 
modelspace entities. 

S Select to show print styles when viewing the layout. 

T Select to print entities with their assigned 
lineweights. If you turn off lineweight printing, 
entities print with a default outline. 

U Select options for shaded viewports. Quality and 
DPI are not currently implemented. 

V Select a print style table to apply during printing, or 
select None. Click [...] to modify the selected print 
style table. 
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Modifying an existing page setup 
You can change any of the print settings associated with a page setup, which elimi- 

nates the need to override the settings when it comes time to print the model or each 

layout that is assigned the page setup. 

If you change the settings for a layout print setup, all layouts assigned that print setup 

will print using the new settings. 
 

To modify an existing page setup 

1 To modify a model page setup, click the Model tab. To modify a layout page 

setup, click any Layout tab. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Select the page setup you want to change. 

4 Click Modify. 

5 Select the desired print options. 

6 Click OK. 

 
Deleting a page setup 
If you delete a page setup that is assigned to the model or a layout, that model or lay- 

out will no longer be assigned a page setup. 
 

To delete a page setup 

1 To delete a model page setup, click the Model tab. To delete a layout page setup, 

click any Layout tab. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Select the page setup you want to delete. 

4 Click Delete. 

5 Click Yes to confirm the deletion. 
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Setting the paper size and orientation 
You can specify a paper size and paper orientation for all drawings. You can also 

adjust the orientation by printing a drawing upside down on the paper. Each layout in 

your drawing can specify whether to print upside down. 
 

To select the paper size and orientation 

1 Click the Layout tab or Model tab for which you want to set paper size and orien- 

tation. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Select the desired page setup, then click Modify. 

4 In Paper size, select a paper size supported by the currently selected printer. 

5 In Orientation, select the following settings: 

• Portrait or Landscape — Select Portrait for vertical paper orientation or 

Landscape for horizontal paper orientation. 

• Print upside down — Select to print the drawing upside down on your printer. 

6 Click OK. 

7 Click OK. 
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Selecting a printer or plotter 
You can specify a printer or plotter to be used when printing any drawing. You can 

print your drawing on any printer or plotter that is compatible with Windows, includ- 

ing raster printers. 

Instead of a physical printer, you can choose to print directly to a file, including .pdf, 

dwf, .png, and .jpg. Printing to a file is not the same as exporting. If you need to 

export a drawing to one of the various file formats available, see “Exporting draw- 

ings” on page 655. 
 

To select a printer or plotter 

1 Click the Layout tab or Model tab for which you want to select a printer. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Select the desired page setup, then click Modify. 

4 From the Printer Name list, select a printer or plotter. 

5 If desired, click Properties to choose options for the currently selected printer. 

6 Click OK. 

7 Click OK. 
 

The printer or plotter you select for a page setup is also used when you publish sheet 

lists. For details, see “Publishing a sheet list to the printer named in page setup” on 

page 565 in this chapter. 

 

Setting the scale and view 
You can print or plot the entire drawing or a selected portion of a drawing. You can 

choose to print what is visible on the screen, or you can specify to print an area of the 

drawing. 

You can control the position of the drawing on the paper by specifying the origin of 

the print area, the location of the lower left corner of the print area, in relation to the 

lower left corner of the paper. The origin is normally set to 0,0, which places the 

lower left corner of the print area as close to the lower left corner of the paper as the 

printer or plotter will allow. You can specify a different origin, however, by 

specifying different coordinates. 

When you create a drawing, you generally draw entities full-size. When you print the 

drawing, you can specify the scale of the resulting print or let the program adjust the 

size of the drawing to fit the paper. To print the drawing at a specific scale, specify 

the scale as a ratio of drawing units to printed units. 
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If you are printing from a Layout tab, the scale and view options you specify can be 

different for each layout that you create. 
 

To automatically scale the drawing for printing 

1 Click the Layout tab or Model tab for which you want to set to scale automati- 

cally. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Select the desired page setup, then click Modify. 

4 In Print Scale, select Fit to Paper to scale the drawing to fit on one printed page. 

5 Click OK. 

6 Click OK. 
 

To specify the scale factor yourself 

1 Click the Layout tab or Model tab for which you want to specify the scale factor. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Select the desired page setup, then click Modify. 

4 In Print Scale, do one of the following: 

• Select a pre-defined scale in the Scale list. For example, choose 1:2 if you want 

1 printed unit (inch or millimeter) to equal 2 drawing units. The list of available 

scales is set up using the Scales List command. For more details, see “Custom- 

izing the scales list” on page 62. 

• Type the ratio of printed units of measure (inches or millimeters) to drawing 

units. 

5 To specify the printed units of measure, choose Inches or Millimeters. 

6 Click OK. 

7 Click OK. 
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To specify a portion of the drawing to print 

1 Click the Layout tab or Model tab for which you want to specify the area to print. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Select the desired page setup, then click Modify. 

4 In What to Print, click one of the following: 

• Display — Prints the view on the screen. 

• Extents — Prints the area that contains entities in the drawing. 

• Limits — Prints to the limits defined for the drawing. (Available for model page 

setups only.) 

• Layout — Prints to the edge of the layout. (Available for layout page setups 

only.) 

• View — Prints the selected saved view. (Available for drawings that have saved 

views.) 

• Window — Prints the portion of the drawing contained in the specified window, 

maintaining the aspect ratio of the windowed area to the drawing. 

If you clicked Window, you must specify the window. Under Windowed Print 

Area, enter the diagonal x- and y-coordinates of the window, or select the area on 

the screen. 

5 Click OK. 

6 Click OK. 
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To specify the print area origin 

1 Click the Layout tab or Model tab for which you want to setting paper size and ori- 

entation. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Select the desired page setup, then click Modify. 

4 Under Print Offset, do one of the following: 

• To center the specified print area on the printed page, select Center on Page. 

• To specify an origin for the print area, type the x- and y-coordinates. 

5 Click OK. 

6 Click OK. 

 

Specifying print options specifically for layouts 
Each layout in your drawing can specify certain print settings that apply only to lay- 

outs: lineweight scaling, print style display, and paperspace print options. 
 

To set print options for only layouts 

1 Click a Layout tab. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Select the desired page setup, then click Modify. 

4 In the Layout Tab Options area, choose the desired print settings: 

• Scale lineweights — Select to print lineweights in proportion to the specified 

Print Scale settings; if not selected, lineweights print at their assigned size. 

Note that print styles can also affect how lineweights print. 

• Display print styles — Select to show print styles when viewing the layout. 
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• Print paperspace last — Select to print paperspace entities after printing model- 

space entities. By default, paperspace entities print first. 

• Hide paperspace entities — Select to prevent paperspace entities from printing. 

5 Click OK. 

6 Click OK. 

 

Specifying shaded viewport print options 
Each model page setup can specify how to print shaded viewports: as displayed, wire- 

frame, hidden, or rendered. Note that Quality and DPI are not currently implemented. 
 

To set print options for shaded viewports 

1 Click the Layout tab or Model tab for which you want to set shaded viewport set- 

tings. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Select the desired page setup, then click Modify. 

4 In the Shaded Viewport Options area, choose the desired settings: 

• Shade — Select how to print shaded viewports 

• Quality — Select the resolution to use for the printed viewport. (Not currently 

implemented.) 

• DPI — Enter the custom dots per inch to use for printing the viewport shading. 

Available only if Quality is set to Custom. (Not currently implemented.) 

5 Click OK. 

6 Click OK. 

 

Specifying pen and line printing options 
Each layout in your drawing can specify certain print settings that apply only to lay- 

outs: lineweight scaling, print style display, and paperspace print options. 
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To set pen and line printing options 

1 Click the Layout tab or Model tab for which you want to set pen and line printing 

options. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Select the desired page setup, then click Modify. 

4 Choose the desired settings: 

• Print style table — Select a print style table to apply during printing, or select 

None. If you select a print style table, you can click [...] to modify its settings. 

• Print with entity lineweights — Select to print entities with their assigned 

lineweights. If you turn off lineweight printing, entities print with a default 

outline. This option is available if Print with Print Styles option is disabled. 

• Print with print styles — Select to print according to the print style settings in 

the currently selected print style table. Entity lineweights are ignored. 

5 Click OK. 

6 Click OK. 

 

Using printer configuration files 
Printer configuration files store the printer information you use for specific drawings 

or layouts, which eliminates the need to completely reconfigure your print settings 

each time you print a drawing. Printer configuration files also allow you to share and 

reuse print settings between different drawings and layouts. 

4MCAD supports the printer configuration files (PCP and PC3 files) used by Auto- 

CAD. This feature makes it possible to use existing PCP files saved in AutoCAD, as 

well as to save your 4MCAD print configuration settings to a PC3 format. 

You can convert an AutoCAD PC2 file to PCP format using the Device And Default 

selection feature in the AutoCAD Print dialog box. 
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To save printer settings in a PC3 file 

1 Do one of the following to choose Options: 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Printing tab. 

3 Click Add or Configure Printers. 

4 To add a PC3 file, click Add to create a new PC3 file. In the Add Printer Configu- 

ration File dialog box that opens, select the desired printer for the new PC3 file, 

click Continue, and select the options you want for the PC3 file. If you don’t select 

any custom options, a PC3 file will not be created. 

5 To modify or delete a PC3 file, select the desired file in the list and click Modify 

or Delete. 

6 Click OK. 
 

To assign a PCP file 

1 If necessary, click the desired Layout tab or the Model tab. 

2 Do one of the following: 

• Choose File > Print. 

• On the Standard toolbar, click the Print tool ( ). 

• Type print and then press Enter. 

3 In Name for the printer, select the printer configuration file from the list. 

 

Using plotter drivers 
To print your drawing, the program sends the output to any printer driver in up to 256 

colors, but with no width specified. Initially, the printed output will have a uniform 

fine width that is the finest line that the plotter device can produce. 

The driver then passes colored vectors to the printer, which creates color output on 

color printers and grayscale output on laser printers. (Color output that converts to 

grayscale on a laser printer usually is unacceptable by CAD users for final printing.) 

With print style tables, you can map all colors to black and set all lineweights to a 

width you choose. You must use a value appropriate to your printing capabilities. 

With these features, you can meet most non-presentation print needs. 
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Using print styles 
 

4MCAD uses print styles to change the appearance of your printed drawing with- 

out modifying the actual entities in your drawing. Assigning print styles allows you to  

customize the color, pen width, linetype, and lineweight that are used to print your 

drawing. 

Print styles help you control what your drawing looks like when it is printed. Rather 

than describe what an entity looks like on your screen, print styles describe what an 

entity will look like when you print it. For example, you can map all yellow entities in 

your drawing to print in blue without modifying the actual entities. You could also 

map all yellow entities to print with whatever lineweight, linetype, or pen width that 

you specify. 

Because print styles are saved in print style tables, which are files located on your 

computer, disk, or server, you can reuse them to help eliminate the need to reconfig- 

ure your print settings each time you print a drawing. For example, you may have 

multiple clients who have their own printing preferences. You can save print styles in 

a named file for each of your clients. You can even share the file with co-workers, or 

store the files on a network to ensure that everyone in your office uses the same stan- 

dards. 

 

Understanding print style tables 
A print style table is a collection of print styles that allows you to change the appear- 

ance of your printed drawing without modifying the actual entities in your drawing. 

Each print style table is saved in a file that can be located on your computer, disk, or 

server. 

A drawing can use one type of print style table at a time. There are two types of print 

style tables: 

• Color-dependent print style tables (CTB) contain a collection of print styles based on 

each of the 255 index colors available in a drawing. True colors and color books 

are not applicable to color-dependent print style tables. 

• Named print style tables (STB) contain a collection of print styles that you define. 

They can vary regardless of color. 

With color-dependent print style tables, you cannot assign print styles to individual 

entities or layers. To use these print styles, you assign a specific color to an entity or 

layer. When you specify a color-dependent print style table at printing time, the entity 

colors and layer colors map to color-based print styles in the print style table that you 

specify. 
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With named print style tables, you can assign named print styles to individual entities 

and layers. Entities and layers assigned print styles are printed according to the print 

style table that you specify at printing time. If you specify a print style for a specific 

entity, that print style overrides any print style assigned to the layer on which the 

entity resides. 

Sometimes a named print style assigned to an entity or layer is not located in the print 

style table that is assigned to a layout or drawing. This can happen if the print style 

has been deleted from the named print style table or if you assign a different named 

print style table to the drawing that does not contain the named print style. In this 

case, the entity is printed using its default properties, which is similar to assigning the 

Normal print style to an entity or layer. If you plan on interchanging named print style 

tables within the same drawing, it’s a good idea to coordinate the tables to use the 

same print style names. 

If a new drawing is based on a template, the new drawing uses the same type of print 

style table as the template. If a new drawing is created without a template, the type of 

print style table is specified in the New Drawing Wizard; by default, the new drawing 

uses the print style table type specified in Tools > Options on the Printing tab. Every 

drawing is designed to use print style tables, but you decide whether to implement 

them. 

 
Comparison of print style table types 

 

 
Description Contains pre-defined print styles 

according to color; there is one print style 
for each of the 255 index colors available 
in the drawing. Entities with the same 
color are printed the same way. 

Example All blue entities print with a .5 millimeter 
lineweight. 

Contains unique print styles that you 
create. Entities with the same color can 
have different print settings. 

 
 

One entity prints with a .7 millimeter 
lineweight; a second blue prints with a .5 
millimeter lineweight. 

Number of 
print styles 

255 (fixed). At least one (varies). 

Print style 
names 

 

Add, delete, 
and modify 
print styles 

Print style names range from “Color_1” 
to “Color_255”. You cannot rename print 
styles. 

You can modify the existing print styles, 
but you cannot add or delete print styles. 

You define new print style names. You 
can rename all print styles except the 
Normal print style. 

You can add and delete print styles. You 
can modify all print styles except the 
Normal print style, which uses the 
default characteristics of the entity. 

 
 

Color-dependent print 
style table (CTB) Named print style table (STB) 
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Comparison of print style table types 

 

 
Create 
additional 
tables 

Yes. Yes. 

Assignment Current print style: New entities always 
assigned BYCOLOR. 

 

Print styles: Assigned to colors in the 
print style table. 

Current print style: Assigned to new 
entities. 

 

Print styles: Assigned to entities and 
layers. 

 
 

 

Legacy file 
support 

 

Print style tables: Assigned to a Layout 
tab or the Model tab. 

You can import existing printer 
configuration files (PCP) files into the 
print style table. CTB files are similar to 
PCP files primarily used in previous 
versions of 4MCAD. 

 

Print style tables: Assigned to a Layout 
tab or the Model tab. 

Not applicable. 

 
 

 

Implementing print style tables 
Every drawing is designed to use print style tables, but you decide whether to imple- 

ment them. Even if you use one of the default print style tables available with 

4MCAD, using print style tables requires planning ahead of time to ensure that your 

drawing prints as planned. 

For example, a single drawing of a floor plan might require the printing of the follow- 

ing drawing sheets: 

• Main Floor Plan Walls print with thick, black lines. 

• Electrical Plan Walls print with normal gray lines, indicating that they are not the 

focus. 

• HVAC Plan Walls print with normal gray lines, indicating that they are not the 

focus. 

• Roof Plan Walls print with thin, gray lines and a hidden linetype, indicating that 

they are hidden under the roof in a plan view. 

In this example, you can create four named print style tables, each containing a print 

style named “WallPstyle”. Each print style table contains its own settings for 

“WallPstyle” to control how the walls print. Assign WallPstyle to either the wall enti- 

ties or to a wall layer. Then, assign a different named print style table each time you 

print, or create four layouts and assign a different print style table to each layout. 

The following table describes, in order, the steps to get you started using both color- 

dependent and named print style tables. 

Color-dependent print 
style table (CTB) Named print style table (STB) 
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Getting started using print style tables 

 

 
X X Create a new drawing. Select a drawing 

template that uses the desired print style 
table type or choose it in the New Drawing 
Wizard. 

File > New Creating a new drawing, page 46 

X X (Optional) Create a new print style table. File > Print Styles Manager Creating new print style tables, 
page 551 

X Assign colors to entities and layers that 
correspond with print style table settings. 

 
 

X Set the current print style assigned to new 
entities. 

Modify > Properties 
Tools > 4MCAD Explorer 

 

 

Tools > Drawing Settings > 
Entity Creation tab; status 
bar; printstyle 

Setting the current entity color, 
page 51; Modifying the properties 
of entities, page 350; Setting the 
layer color, page 268 

Setting the current print style, 
page 57 

X Assign print styles to entities. Modify > Properties; Entity 
Properties toolbar; printstyle 

Modifying the properties of 
entities, page 350 

X Use 4MCAD Explorer to assign print 
styles to layers. 

X X Assign a print style table to the Model tab, 
a layout, or to all layouts in the drawing. 

Tools > 4MCAD Explorer Setting the layer print style, page 
272 

File > Print > Advanced tab  Assigning print style tables, page 
550 

X X (Optional) Make changes to the assigned 
print style table. 

File > Print Styles Manager 
File > Print > Advanced tab 

Modifying print style tables, page 
552 

X X Print the drawing. File > Print Printing or plotting your drawing, 

page 558 
 

 

Color- 
dependent Named Task Command Where to get details 
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The following table describes how to further customize how print styles work within 

your drawings. 
 

Further customizing print style tables 
 

 
Copy, rename, or delete print style 
tables. 

 
 

Change a drawing to use another type 
of print style table, for example, change 
a drawing that uses color-dependent 
print style tables to one that uses 
named print style tables. 

Convert a color-dependent print style 
table to a named print style table. 

File > Print Styles Manager Copying, renaming, or 

deleting print style tables, 

page 555 

convertpstyles Changing the print style 
table type of a drawing, 
page 555 

 

 

convertctb Converting print style 
tables, page 556 

Change the default location where print 
style tables are stored. 

Tools > Options > Paths/Files 
tab 

Changing the options on 

the Paths/Files tab, page 

680 

Customize how print styles work with 
new drawings that you create and older 
drawings that you open. 

Tools > Options > Printing tab Changing the options on 

the Printing tab, page 704 

 
 

 

Assigning print style tables 
Select a print style table before printing if you want to change how your drawing 

appears when you print it. Print style tables can modify how colors, pen widths, line- 

types, and lineweights look when they are printed. 

You can assign print style tables globally for all layouts (including the Model tab), or 

individually for the Model tab or a Layout tab. Assigning a print style table to an indi- 

vidual layout allows you to further customize the layouts you use to print a drawing. 

However, assigning different named print style tables to various layouts may result in 

mismatched print style names; a named print style assigned to an entity or layer may 

not be located in the assigned print style table at print time. In this case, entities are 

printed using their default properties, which is similar to assigning the Normal print 

style to an entity or layer. 
 

To assign a print style table at the same time you print 

1 If necessary, click the desired Layout tab, or click the Model tab. 

2 Do one of the following to choose Print ( ): 

• On the ribbon, choose the Application button then choose Print, or choose 

Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Print. 

• Type print and then press Enter. 

Task Command Where to get details 
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You can assign a print style table to a page setup. 

Use the Page Setup Manager to assign a print style table to a page setup that you 

use for printing. For more details, see Specifying pen and line printing options. 
 

 

 

3 Under Print Style Table (Pen Assignments), select a print style table that you cre- 

ated or one of the following: 

• None — Applies no print style table. Entities print according to their own 

properties. 

• Icad — Uses the default print style table and its color assignments. 

• Monochrome — Prints all colors as black. 

4 Select Save Changes to Layout, and then click OK. 

 
 

When a drawing is first created it is assigned to use either color-dependent or named print 

style tables. 

For details on converting a drawing to use a different type of print style table, see 

“Understanding print style tables” on page 546 in this chapter. 
 

 

 

Creating new print style tables 
4MCAD offers several print style tables to help you get started. If you want to cus- 

tomize your print output further, you can create your own print style table. You can 

create a new print style table entirely from scratch, based on 4MCAD registry set- 

tings, or by importing a printer configuration file (PCP file). 
 

To create new print style tables 

1 Do one of the following to choose Print Styles Manager ( ): 

• On the ribbon, choose the Application button then choose Print > Print Styles 

Manager, or choose Output > Print Styles Manager (in Plot). 

• On the menu, choose File > Print Styles Manager or choose Format > Print 

Styles Manager. 

• On the Format toolbar, click the Print Styles Manager tool. 

• Type stylesmanager and then press Enter. 

2 Click Add. 

3 Complete the setup wizard. 

On the last wizard page, you can click Print Style Table Editor to set up the print 

styles for the table. For more details about the Print Style Table Editor options, see 

the next section. 
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A 
 

E 

D 

C 
B 

 
 
 
 
 
 

 
A Displays the location where print style tables are 

located. 

B Displays a list of all print style tables available in the 
named folder. 

 
C Click to delete the currently selected print style 

table. 

D Click to modify the settings for the currently 
selected print style table. 

E Click to create a new print style table. 
 

Modifying print style tables 
When your drawing was created, it was set up to use color-dependent or named print 

style tables: 

• Color-dependent print style tables (.ctb files) — You can modify individual print 

styles within the table, but you cannot add, rename, or delete print styles. Color- 

dependent print style tables always have 255 print styles, each named for a spe- 

cific color. Your changes affect all entities and layers assigned that color. 

• Named print style tables (.stb files) — You can add, modify, rename, and delete 

individual print styles within the table. However, you cannot modify, rename, or 

delete the Normal print style. Your changes affect all entities and layers that are 

assigned that print style name. 

 
 

Use a system variable to determine the type of print style table your drawing uses. 

If you can’t remember what type of print style table is assigned to your drawing, use 

the PSTYLEMODE system variable to determine the print style table type. 
 

 

 

Each print style within a print style table specifies a color, pen numbers, linetype, and 

lineweight. 4MCAD recognizes additional characteristics for compatibility with 

AutoCAD only, including: dither, grayscale, screening, adaptive, line end style, line 

join style, and fill style. 

When specifying print style characteristics, be sure to consider the limitations of your 

output device. 
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It is recommended that you only modify print style tables that you have created. 

If you modify a default print style table that came with 4MCAD, you overwrite the 

original information which is then lost. 
 

 

 
To modify print style tables 

1 Do one of the following to choose Print Styles Manager ( ): 

• On the ribbon, choose the Application button then choose Print > Print Styles 

Manager, or choose Output > Print Styles Manager (in Plot). 

• On the menu, choose File > Print Styles Manager or choose Format > Print 

Styles Manager. 

• On the Format toolbar, click the Print Styles Manager tool. 

• Type stylesmanager and then press Enter. 

2 Select the print style table you want to modify. 

3 Click Modify. 

4 Click the General tab, and then do any of the following: 

• Enter a new table description. 

• Select Apply Global Scale Factor to Non-ISO Linetypes to apply the scale factor 

to non-ISO linetypes used for any print style in the current print style table. This 

also applies to fill patterns, which are not used in 4MCAD, but are recognized 

for compatibility with AutoCAD. 

• Enter a scale factor to apply to non-ISO linetypes used for any print style in the 

current print style table. 

5 Click the Form View tab, and then do any of the following: 

• Make format changes to a print style by selecting it in the Print Styles list, then 

make color, pen map, linetype, or lineweight changes for the print style. Your 

changes are saved automatically for the selected print style. 

• Add a new print style by clicking Add Style. Enter a new name, and then click 

OK. Select the options for the print style. (Available for named print styles 

only.) 

• Rename a print style by selecting it in the Print Styles list. Single-click the print 

style again, and then enter a new name. (Available for named print styles only.) 

• Delete a print style by selecting it in the Print Styles list. Click Delete Style. 

(Available for named print styles only.) 
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6 Click OK. 

 

 

 

 
 
 
 

A Select a print style to modify it. 

B Enter a description for the selected print style. 

C Click to create a new print style. (Named print 
style tables only.) 

D Click to delete the selected print style. (Named 
print style tables only.) 

E Click to modify the list of available lineweights for 
the current print style table. 

F Click to save the print style table with a new name 
or in a new location. 

G Choose a fill style for the selected print style. 

H Choose a line join style for the selected print 
style. 

I Choose a line end style for the selected print 
style. 

J Choose a lineweight for the selected print style. 

 
K Choose whether to adjust the linetype scale 

automatically to complete the linetype pattern 
when necessary. 

L Choose a linetype for the selected print style. 

M Select the level of color intensity for the selected 
print style: 100 is full intensity, 0 is white. (Dither 
must be on.) 

N Type or scroll to the width of the virtual pen for the 
selected print style (for printers that don’t have 
physical pens, such as laser or inkjet printers). 

O Type or scroll to the width of the physical pen for 
the selected print style. 

P Choose whether to print the selected print style in 
grayscale. 

Q Choose whether to turn on dithering for the 
selected print style. 

R Choose a color for the selected print style. 
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Copying, renaming, or deleting print style tables 
Copy, rename, or delete a print style table just as you would any other file on your 

computer. Regardless of which print style table type your drawing uses, you can use 

the Print Style Manager to manage both color-dependent and named print style tables. 
 

To delete print style tables 

1 Do one of the following to choose Print Styles Manager ( ): 

• On the ribbon, choose the Application button then choose Print > Print Styles 

Manager, or choose Output > Print Styles Manager (in Plot). 

• On the menu, choose File > Print Styles Manager or choose Format > Print 

Styles Manager. 

• On the Format toolbar, click the Print Styles Manager tool. 

• Type stylesmanager and then press Enter. 

2 Select a print style table, then click Delete. 

Color-dependent print style tables are .ctb files and named print style tables are 

.stb files. 
 

To copy, rename, or delete print style tables 

1 On your computer, open the folder that stores print style tables, for example, 

\CompanyName\ProductVersion\Print    Styles. 

2 Copy, rename, or delete the print style table just as you would any other file on 

your computer. 

 

Changing the print style table type of a drawing 
When your drawing was created, it was set up to use color-dependent print style 

tables (.ctb files) or named print style tables (.stb files). A drawing can use one type 

of print style table at a time. If necessary, after a drawing is created you can convert 

the drawing to use the other type of print style table. 

If you can’t remember what type of print style table is assigned to your drawing, use 

the PSTYLEMODE system variable to determine the print style table type. 
 

To change a drawing to use named print style tables 

1 If you want to reuse any of the existing print style information, convert your color- 

dependent print style tables to named print style tables. For details, see “To con- 

vert a color-dependent print style table to a named print style table” on page 557 in 

this chapter. 

2 Open the drawing that uses color-dependent print style tables (.ctb files). 

3 Type convertpstyles, and then press Enter. 
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4 If you have already converted your individual color-dependent print style tables to 

named tables, click OK in the prompt that displays. 

If you have not converted the tables, click Cancel. First use convertctb to convert 

your color-dependent print style tables to named tables. If you do not, all of the 

print style information you specified in your drawing will be lost. 

5 Select a named print style table (.stb file) that you want to use with the drawing. 

6 Click Open. 
 

 

Errors will occur if you have not converted print style tables. 

If you have not converted a color-dependent print style table to a named print style 

table, you will be warned that the table you have selected does not contain color map- 

ping and the drawing cannot be converted. 
 

 

 
To change a drawing to use color-dependent print style tables 

1 Open the drawing that uses named print style tables (.stb files). 

2 Type convertpstyles, and then press Enter. 

3 If you are sure you want to convert the drawing and lose all print style assign- 

ments, click OK in the prompt that displays. 

If you do not want to lose the print style assignments, click Cancel. 
 

 

Converting a drawing to use color-dependent print style tables will remove all of the 

named print style information from entities and layers. 

However, the named print style tables are not deleted from your computer. 
 

 

 

Converting print style tables 
You can convert a color-dependent print style table to a named print style table. You 

cannot convert a named print style table to a color-dependent print style table because 

color-dependent tables contain only print styles that are named after the 255 colors to 

which they map. 

Converting a color-dependent print style table to a named print style table can be 

helpful in the following situations: 

• You don’t want to create a named print style table from scratch. 

• You want to create a named print style table that has the same settings as a color- 

dependent print style table, but with some new print styles or other custom set- 

tings. 

• You want to convert a drawing to use named print style tables and you want to 

reuse most of print styles already defined in a color-dependent print style table. 
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To convert a color-dependent print style table to a named print style table 

1 Type convertctb, and then press Enter. 

2 Select the color-dependent print style table (.ctb file) that you want to convert. 

3 Click Open. 

4 Enter a name for the new named print style table (.stb file). 

5 Click Save. 
 

The print styles in the new table are named Style 1, Style 2, and so on. If want to use 

different print style names, rename the print styles before you assign them to entities 

and layers in your drawing. If you rename the print styles after assigning them, they 

will not match when you print your drawing. For information about renaming print 

styles, see “Modifying print style tables” on page 552 in this chapter. 

 

Turning print style tables on or off 
When you turn off print style tables, entities print according to their own properties. 

However, all of the print style information is saved so you can easily turn on print 

styles again. Actual print style table files are not deleted, and for drawings that use 

named print style tables, entities and layers retain their assigned print styles. 
 

To turn off print style tables 

1 Click the Layout tab or Model tab for which you want to turn on or off print style 

tables. 

2 Do one of the following to choose Page Setup Manager ( ): 

• On the ribbon, choose the Application button then choose Page Setup Manager, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool. 

• Type pagesetup and then press Enter. 

3 Select the desired page setup, then click Modify. 

4 In Print style table, select a print style table to turn on print style tables, or select 

None to turn off print style tables. 

5 Click OK. 

6 Click OK. 



558 C H A P T E R   1 4  
 

 

Printing or plotting your drawing 
 

After you have configured your drawing and any layouts for printing, you are ready 

to print. If desired, you can preview your page before printing. 

 

Previewing a drawing before printing 
Viewing a drawing before printing gives you a preview of what your drawing will 

look like when it is printed. This helps you see if there are any changes you want to 

make before actually printing the drawing. 

If you are using print style tables, the preview shows how your drawing will print 

with the assigned print styles. For example, the preview may display different colors 

or lineweights than those used in the drawing because of assigned print styles. 
 

To preview a drawing before printing 

1 If necessary, click the desired Layout tab or the Model tab. 

2 Do one of the following to choose Print Preview ( ): 

• On the ribbon, choose the Application button then choose Print > Print Preview, 

or choose Output > Page Setup Manager (in Plot). 

• On the menu, choose File > Print Preview. 

• On the Standard toolbar, click the Print Preview tool. 

• Type ppreview and then press Enter. 

3 After checking the preview image, do one of the following: 

• To print the drawing, click Print. 

• To return to the drawing, click Cancel. 
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A B C D 
 

 
 

A Click to zoom in. 

B Click to zoom out. If you have zoomed in 
several times, click multiple times to restore 
the entire preview image. 

C Click to print the drawing. 

D Click to close the preview and return to the 
drawing. 
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Printing a drawing 
The Print dialog box has print settings described in the previous sections for page set- 

ups. 

 
 

You cannot print a rendered image directly to a printer. 

To print a rendered image, you must first save the drawing to a different format and 

then print it from another graphics program. 
 

 

 
To print a drawing 

1 If necessary, click the desired Layout tab or the Model tab. 

2 Do one of the following to choose Print ( ): 

• On the ribbon, choose the Application button then choose Print, or choose 

Output > Print (in Plot). 

• On the menu, choose File > Print. 

• On the Standard toolbar, click the Print tool. 

• Type print and then press Enter. 

3 In Page Setup Name, select the page setup to apply for printing. The print options 

in the Print dialog box change to reflect the settings of the selected page setup. 

4 Make any necessary adjustments, including for the following options that are 

available only at print time (not when setting up a page setup): 

• Print to file — Select to print to a file instead of a printer. 

• Number of copies — Enter the number of copies to print. 

• Print transparency — Select to print entities with their assigned transparency. 

Note that turning on this option can slow printing. 

• Print in background — Print in the background of other tasks being performed 

by the computer. 

• Print stamp on — Select to print with a header and footer. Click [...] to modify 

the text of the print stamp. 

• Save changes to layout — Select to save the print settings for the model or 

layout. 

5 Click Print. 
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A Select to print to a file instead of a printer. 

B Enter the number of copies to print. 

C Select to save the print settings for the model or 
layout. 

D Select to print with a header and footer. Click [...] to 
modify the text of the print stamp. 

E Select to print in the background of other tasks 
being performed by the computer. 

F Select to print entities with their assigned 
transparency. 
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Saving print settings for a model or layout 
All print settings can be saved with a model or layout, which can be particularly help- 

ful if you don’t use page setups. The next time you print the model or layout, the 

saved print settings automatically load in the Print dialog box. 

 
 

Saved print settings are also used when publishing. 

If you’re publishing drawings using sheets that don’t have a page setup assigned, the 

print settings saved for the model or layout are used by default. 
 

 

 
To save print settings with a model or layout 

1 Click the desired Layout tab or the Model tab for which you want to save print set- 

tings. 

2 Do one of the following to choose Print ( ): 

• On the ribbon, choose the Application button then choose Print, or choose 

Output > Print (in Plot). 

• On the menu, choose File > Print. 

• On the Standard toolbar, click the Print tool. 

• Type print and then press Enter. 

3 Make your print selections. 

4 Click Apply to Layout. 

5 Do one of the following: 

• Click OK to print and close the dialog box. 

• Click Cancel to close the dialog box without printing. 
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Publishing drawings 
 

Rather than print one drawing at a time, you can use the Publish command to save 

and print a collection of drawings and their layouts. 

First you create a sheet list by specifying the desired layouts, which can be a combi- 

nation of model space and paper space layouts from any drawing. Save the sheet list, 

then print it. 

 

Creating a sheet list to publish 
A sheet list is a collection of sheets that you want to publish. Each sheet in the list ref- 

erences a layout, which can be model space or a paper space layout from any draw- 

ing. 

Sheet lists are saved as Drawing Set Description files (.dsd files). 
 

To create a sheet list to publish 

1 Do one of the following to choose Publish (  ): 

• On the ribbon, choose the Application button, then choose Publish > Publish, or 

choose Output > Publish. 

• On the menu, choose File > Publish. 

• On the Standard toolbar, click the Publish tool. 

• Type publish and then press Enter. 

2 To add sheets, do the following: 

• Click Add. 

• Select one or more drawings that contain the models and layouts you want to 

add as sheets. 

• Click Open. 

3 To add sheets from all open drawings, mark Automatically Load All Open Draw- 

ings. The models and layouts from all drawings that are currently open will be 

added as sheets. 

4 To remove unwanted sheets from the sheet list, select a sheet, then click Remove. 

5 To move sheets up or down in the list, select the sheet and click Move Up or click 

Move Down. Sheets are published in the order in which they display. 

6 Click Save. 

7 In the Save DSD File dialog box, enter a name for the sheet list, then click Save. 
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A Mark to load models and layouts as sheets from all 
open drawings. 

B Click to delete the currently selected sheet from the 
sheet list. 

C Click to select a drawing that contains the model 
and layouts to add as sheets. 

D Displays the sheets to publish. 

E Displays details about the currently selected sheet. 

F Click to move the currently selected sheet up one 
position. 

G Click to move the currently selected sheet down 
one position. 

H Click to change the page setup for the currently 
selected sheet. 

I Click to save the list of layouts as a sheet list. 
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Modifying an existing sheet list 
Open, or load, an existing sheet list (.dsd file) to modify it. During loading, drawings 

that are specified in the sheet list must be accessible in the referenced folder location. 
 

To modify a sheet list 

1 Do one of the following to choose Publish (  ): 

• On the ribbon, choose the Application button, then choose Publish > Publish, or 

choose Output > Publish. 

• On the menu, choose File > Publish. 

• On the Standard toolbar, click the Publish tool. 

• Type publish and then press Enter. 

2 Click Load. 

3 Locate and select the .dsd file to modify. 

4 Click Open. 

5 To add sheets, do the following: 

• Click Add, or press insert when a sheet is selected. 

• Select one or more drawings that contain the models and layouts you want to 

add as sheets. 

• Click Open. 

6 To remove unwanted sheets from the sheet list, select a sheet, then click Remove 

or press delete. 

7 To assign a different page setup to a sheet, select a page setup from the list for the 

sheet. To change the page setup, do the following: 

• Select the sheet and click Change. You can also double-click the sheet. 

• Select the page setup to change, then click Modify. 

• Make your selections, then click OK. 

• Click Close. 

8 To move sheets up or down in the list, select the sheet and click Move Up or click 

Move Down. Sheets are published in the order in which they display. 

9 Click Save. 

 

Publishing a sheet list to the printer named in page 
setup  
Publishing a sheet list prints all referenced sheets at the same time. The 

sheets are printed to the printer named in the assigned page setup for 

each sheet. If the Page Setup column indicates None for a sheet, the 
sheet is published using the print options specified for the layout. 
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To publish a sheet list to the printer named in page setup 

1 Do one of the following to choose Publish (  ): 

• On the ribbon, choose the Application button, then choose Publish > Publish, or 

choose Output > Publish. 

• On the menu, choose File > Publish. 

• On the Standard toolbar, click the Publish tool. 

• Type publish and then press Enter. 

2 Open the desired sheet list: 

• Click Load. 

• Locate and select the .dsd file to publish. 

• Click Open. 

For details about creating a sheet list, see “Creating a sheet list to publish” on page 

563 in this chapter. 

3 In Publish To, select Printer Named in Page Setup. 

4 If you regularly publish to the page setup’s printer instead of other formats, 

optionally click Set as Default. 

5 To assign a different page setup to a sheet, select a page setup from the list for the 

sheet. To change the page setup, do the following: 

• Select the sheet and click Change. You can also double-click the sheet. 

• Select the page setup to change, then click Modify. 

• Make your selections, then click OK. 

• Click Close. 

6 Verify the status of each sheet in the list: 

• No Errors — The sheet is ready for publishing. 

• Layout Not Initialized — The sheet’s layout is not assigned a valid printer. If 

the sheet is assigned a page setup, choose File > Page Setup and specify a valid 

printer for the page setup. If no page setup is assigned, open the source drawing 

file, click the referenced Model or Layout tab, choose File > Print, specify a 

printer, then click Apply to Layout. 

7 Specify any of the following options: 

• Number of copies — Enter the number of copies to print. 

• Include print stamp — Select to print with a header and footer. Click [...] to 

modify the text of the header and footer. 

• Publish in background — Select to print in the background of other tasks being 

performed by the computer. 

8 Click Publish. 
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A Click to open a sheet list. 

B Select a sheet list to publish. 

C Select to print to the page setup named for each 
sheet. Click Set as Default to make this the default 
setting each time you open the dialog box. 

D Displays the sheets to publish. 

E Displays details about the selected sheet. 

F Enter the number of copies to print. 

G Mark to publish in the background of other tasks 
being performed by the computer. 

H Mark to publish with a header and footer. Click [...] 
to modify the text of the print stamp. 

I Click to change the page setup for the currently 
selected sheet. 

J Click to save the list of layouts as a sheet list. 

 

Publishing a sheet list to PDF 
Publishing a sheet list to PDF prints all referenced sheets at the same time to a .pdf 

file. PDF files allow you to distribute your drawing to others for viewing in Adobe® 

Acrobat® Reader®, which is free software that users can download. PDF files can 

also be viewed, reviewed, and edited in Adobe Acrobat. 

If the Page Setup column indicates None for a sheet, the sheet is published using the 

print options specified for the layout. 
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To publish a sheet list to PDF 

1 Do one of the following to choose Publish (  ): 

• On the ribbon, choose the Application button, then choose Publish > Publish, or 

choose Output > Publish. 

• On the menu, choose File > Publish. 

• On the Standard toolbar, click the Publish tool. 

• Type publish and then press Enter. 

2 Open the desired sheet list: 

• Click Load. 

• Locate and select the .dsd file to publish. 

• Click Open. 

For details about creating a sheet list, see “Creating a sheet list to publish” on page 

563 in this chapter. 

3 In Publish To, select PDF. 

4 If you regularly publish to PDF instead of other formats, optionally click Set as 

Default. 

5 Click Publish Options and do any of the following: 

• Select options for the published .pdf file. 

• Click Custom Properties to select additional options, then click OK when done. 

• Click [?] to see details about each option. 

6 Click OK when done setting PDF options. 

7 To assign a different page setup to a sheet, select a page setup from the list for the 

sheet. To change the page setup, do the following: 

• Select the sheet and click Change. You can also double-click the sheet. 

• Select the page setup to change, then click Modify. 

• Make your selections, then click OK. 

• Click Close. 

8 Verify the status of each sheet in the list: 

• No Errors — The sheet is ready for publishing. 

• Layout Not Initialized — The sheet’s layout is not assigned a valid printer. If 

the sheet is assigned a page setup, choose File > Page Setup and specify a valid 

printer for the page setup. If no page setup is assigned, open the source drawing 

file, click the referenced Model or Layout tab, choose File > Print, specify a 

printer, then click Apply to Layout. 

9 Click Publish. 
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A Click to open a sheet list. 

B Select a sheet list to publish. 

C Select to publish to PDF. Click Set as Default to 
make this the default setting each time you open the 
dialog box. 

D Displays the sheets to publish. 

E Displays details about the currently selected sheet. 

F Click to set options for publishing to PDF. 

G Click to change the page setup for the currently 
selected sheet. 

H Displays details about the currently selected PDF 
settings. 
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Publishing a sheet list to DWF or DWFx 
Publishing a sheet list to DWF or DWFx prints all referenced sheets at the same time 

to a .dwf or .dwfx file, depending on the format you choose. DWF and DWFx files 

allow you to distribute your drawing to others for online viewing, reviewing, and 

editing. 

If the Page Setup column indicates None for a sheet, the sheet is published using the 

print options specified for the layout. 
 

To publish a sheet list to DWF or DWFx 

1 Do one of the following to choose Publish (  ): 

• On the ribbon, choose the Application button, then choose Publish > Publish, or 

choose Output > Publish. 

• On the menu, choose File > Publish. 

• On the Standard toolbar, click the Publish tool. 

• Type publish and then press Enter. 

2 Open the desired sheet list: 

• Click Load. 

• Locate and select the .dsd file to publish. 

• Click Open. 

For details about creating a sheet list, see “Creating a sheet list to publish” on page 

563 in this chapter. 

3 In Publish To, select DWF or DWFx. 

4 If you regularly publish to DWF or DWFx instead of other formats, optionally 

click Set as Default. 

5 Click Publish Options and select options for the published .dwf or .dwfx file. 

Click [?] to see details about each option. 

6 Click OK when done setting publish options. 

7 To assign a different page setup to a sheet, select a page setup from the list for the 

sheet. To change the page setup, do the following: 

• Select the sheet and click Change. You can also double-click the sheet. 

• Select the page setup to change, then click Modify. 

• Make your selections, then click OK. 

• Click Close. 
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8 Verify the status of each sheet in the list: 

• No Errors — The sheet is ready for publishing. 

• Layout Not Initialized — The sheet’s layout is not assigned a valid printer. If 

the sheet is assigned a page setup, choose File > Page Setup and specify a valid 

printer for the page setup. If no page setup is assigned, open the source drawing 

file, click the referenced Model or Layout tab, choose File > Print, specify a 

printer, then click Apply to Layout. 

9 Click Publish. 
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A Click to open a sheet list. 

B Select a sheet list to publish. 

C Select to publish to DWF or DWFx. Click Set as 
Default to make this the default setting each time 
you open the dialog box. 

D Displays the sheets to publish. 

E Displays details about the currently selected sheet. 

F Click to set options for publishing to DWF/DWFx. 

G Click to change the page setup for the currently 
selected sheet. 

H Displays details about the currently selected DWF/ 
DWFx settings. 
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Publishing automatically 
Drawings can be automatically published whenever they are saved or closed, with or 

without prompting. During automatic publishing, .dwf, dwfx, or .pdf files are saved 

according to predefined options that you specify. By default, automatic publishing is 

turned off, so don’t forget to turn it on after you set it up. 
 

To set up auto publishing 

1 Do one of the following to choose Auto Publish (  ): 

• On the ribbon, choose the Application button, then choose Publish > Auto 

Publish. 

• On the menu, choose File > Auto Publish. 

• Type autopublish and then press Enter. 

2 Choose Options. 

3 Make your selections, then click OK. 

4 To publish, for example a test publish with your new settings, press Enter. To not 

publish, press Esc. 
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A Select when to auto publish: when the file is saved 

or closed, and with or without a prompt. 

B Select whether to save published files to the same 
folder as the drawing, a subfolder of the drawing 
folder, or a different folder. 

C Select the folder where you want to save published 
files. (Available only if User Location is selected in 
Location.) 

D Select whether the model, layouts or both the model 
and layouts are published. 

 
E Select whether to publish the drawing to a .dwf, 

.d wfx or .pdf file. 

F Select whether to publish all sheets to a single file 
or each sheet to its own file. 

G Select whether to include layer information. 

H Select whether overlapping lines include only the 
last line or are merged together. 



P R I N T I N G   D R A W I N G S 573  
 

 
To turn automatic publishing on 

1 Type automaticpub and then press Enter. 

2 Type 1, then press Enter. 
 

 

Turn automatic publishing off using the same AUTOMATICPUB system variable. 

Set AUTOMATICPUB to 0 to turn off automatic publishing. 
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Drawing in three dimensions 
 

Paper drawings typically represent two-dimensional views of three-dimensional 

objects. With 4MCAD, you can create three-dimensional models of three-dimen- 

sional objects. 

This section explains how to: 

• View entities in three dimensions. 

• Create three-dimensional entities. 

• Edit entities in three-dimensional space. 

• Edit three-dimensional solids. 

• Display hidden-line and shaded views of three-dimensional entities. 

The tools and commands for many of the functions described in this section appear 

on the Draw 3D toolbar and the Insert menu, respectively, when you set the program 

to the Advanced experience level. 

 
 
 
 

 
 
 
 
 

15 
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Viewing entities in three dimensions 
 

You can view an 4MCAD drawing from any position in three-dimensional space. 

From any selected viewing position, you can add new entities and modify existing 

entities. You can also generate hidden-line and shaded views from any viewing posi- 

tion. 

You view three-dimensional drawings by setting the viewing direction. The viewing 

direction establishes the viewing position, the Cartesian coordinate corresponding to 

the viewpoint looking back at the origin point, the 0,0,0 coordinate. When you view a 

drawing from the default viewpoint (0,0,1), you see a plan view of the drawing. 

On the View toolbar, you can view a three-dimensional drawing using any of the fol- 

lowing methods: 

• Preset Viewpoints ( ) 

• Dynamic View Control (  ) 

• Plan View (  ) 

 

Setting a new viewing direction 
You can change the viewing direction to look at the drawing from a different vantage 

point or to work on a three-dimensional model from a different orientation. 
 

To set a new viewing direction 

1 Do one of the following to choose Preset Viewpoints ( ): 

• On the ribbon, choose View > Preset Viewpoints (in Views). 

• On the menu, choose View > Preset Viewpoints. 

• On the View toolbar, click the Preset Viewpoints tool. 

• Type setvpoint and then press Enter. 

2 Click the preset view you want to use. 
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A Click to select an isometric viewpoint. B Click to select an orthographic viewpoint. 
 

Setting a viewing direction dynamically 

You can dynamically rotate the viewpoint within the xy plane and relative to the xy 

plane, and you can pan and zoom the drawing. As you change the viewpoint settings, 

the drawing display automatically updates. 
 

To dynamically set a view direction 

1 Do one of the following to choose Dynamic View Control ( ): 

• On the ribbon, choose View > Dynamic View Control (in Views). 

• On the menu, choose View > Dynamic View Control. 

• On the View toolbar, click the Dynamic View Control tool. 

• Type viewctl and then press Enter. 

2 Make your selections to change the viewpoint. 

3 To complete the command, click OK. 
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A Select whether the viewing direction is relative to 
the World Coordinate System or User 
Coordinate System. 

B Displays the current viewing direction settings. 
Click to select a new viewing direction. 

C Enter the angle from the x-axis. 

D Click to set the viewing direction to the plan view. 

E Enter the angle from the xy-plane. 

F Click to open the Preset Viewpoints dialog box 
and set the viewing direction using predefined 
settings. 

G Click to open the View Control dialog box and set 
the viewing direction interactively with the 
drawing. 

H Indicates the current viewpoint. 

To set a view direction interactively with the drawing 

1 Do one of the following to choose Dynamic View Control ( ): 

• On the ribbon, choose View > Dynamic View Control (in Views). 

• On the menu, choose View > Dynamic View Control. 

• On the View toolbar, click the Dynamic View Control tool. 

• Type viewctl and then press Enter. 

2 Click Adjust. 

3 Make your selections to change the 3D viewing direction within the drawing. 

4 Click OK. 

5 To complete the command, click OK. 
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A Indicates the current viewpoint. 

B Click to pan the drawing. 

C Click to zoom extents. 

D Click to zoom out. 

E Click to zoom in. 

F Shows the current viewpoint orientation. 

G Click to rotate the view about a predefined axis. 

H Type or select the rotation angle increment. 

 

Displaying a plan view of the current drawing 
You can set the current viewing direction to the plan view of the current user coordi- 

nate system (UCS), a previously saved UCS, or the World Coordinate System 

(WCS). 
 

To display a plan view of the current drawing 

1 Do one of the following to choose Plan View (  ): 

• On the ribbon, choose View > Plan View (in Views). 

• On the menu, choose View > Plan View. 

• On the View toolbar, click the Plan View tool. 

• Type plan and then press Enter. 

2 In the prompt box, choose one of the following: 

• Current displays the plan view of the current UCS. 

• UCS displays the plan view of a saved UCS. The program prompts you for the 

name of the UCS. 

• World displays the plan view of the WCS. 



580 CHAPTER 15  

 

Creating three-dimensional entities 
 

4MCAD supports the following types of three-dimensional models: 

• Wire-frame models, which consist of lines and curves that define the edges of a 

three-dimensional entity. You can create a wire-frame model by drawing lines, 

arcs, polylines, and other two-dimensional entities anywhere in three-dimensional 

space. Wire-frame models have no surfaces; they always appear as outlines. 

Because you must individually draw and position each entity that makes up a 

wire-frame model, creating one can be exacting and time-consuming. 

• Surface models, which consist of both edges and the surfaces between those  

edges. You can create a surface model by applying elevation and thickness to two- 

dimensional planar entities or by using specific three-dimensional entity-creation 

commands. Surface models consist of individual planes forming a faceted, polyg- 

onal mesh. 

• Facet model meshes, which are smart surface model entities that can be combined 

into composite meshes and rendered more like solids. 

• 3D solids, which are three-dimensional ACIS entities that consist of faces and 

edges. 3D solids appear to have volume and are easier to work with than wire- 

frame and surface models. 4MCAD supports viewing and limited editing of 3D 

solids, including moving, rotating and scaling. Additionally, some versions of 

4MCAD allow you to create and more completely edit 3D solids. 

 

Applying elevation and thickness 
By default, the program creates new two-dimensional entities with a zero elevation 

and thickness. The easiest way to create a three-dimensional entity is to change the 

elevation or thickness property of an existing two-dimensional entity. 

The elevation of an entity is its z-coordinate position in relation to the xy plane in 

which the entity is drawn. An elevation of 0 indicates that the entity is drawn on the 

xy plane of the current UCS. Positive elevations are above this plane; negative eleva- 

tions are below it. 
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The thickness of an entity is the distance it is extruded above or below its elevation. A 

positive thickness extrudes the entity upward in the positive z direction of the entity; 

a negative thickness extrudes it downward in the negative z direction. The thickness 

is applied uniformly to the entire entity. You can extrude any two-dimensional entity 

into a three-dimensional entity by changing the thickness of the entity to a nonzero 

value. For example, a circle becomes a cylinder, a line becomes a three-dimensional 

plane, and a rectangle becomes a box. 
 

 
Two-dimensional entities. Two-dimensional entities with thickness added. 

 

You can create three-dimensional entities using any of the following methods: 

• Draw two-dimensional entities in three-dimensional space. 

• Convert two-dimensional planar entities into three-dimensional entities by apply- 

ing elevation and thickness. 

• Convert two-dimensional planar entities into three-dimensional entities by revolv- 

ing or extruding. 

• Create three-dimensional entities such as boxes, cylinders, cones, domes, spheres, 

and wedges. 

 
 

Three-dimensional solids are drawn as true solids with versions of 4MCAD that support 

three-dimensional ACIS solids. 

Three-dimensional solids that you can create include: box, cone, cylinder, dish, 

dome, pyramid, sphere, torus, and wedge. 
 

 

 

You can change the default elevation and thickness values to create new entities with 

an elevation and thickness already applied. 
 

To set the current elevation 

1 Do one of the following to choose Elevation (  ): 

• On the ribbon, choose Draw > Elevation (in Settings). 

• On the menu, choose Format > Elevation. 

• On the Format toolbar, click the Elevation tool. 

• Type elev and then press Enter. 

2 Specify the New Current Value For Elevation, and then press Enter. 



582 CHAPTER 15  

 
To set the current thickness 

1 Do one of the following to choose Thickness (  ): 

• On the ribbon, choose Draw > Thickness (in Settings). 

• On the menu, choose Format > Thickness. 

• On the Format toolbar, click the Thickness tool. 

• Type thickness and then press Enter. 

2 Specify the New Current Value For Thickness, and then press Enter. 
 

To set the current elevation and thickness using a dialog box 

1 Do one of the following to choose Drawing Settings (  ): 

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 

Settings (in Utilities); or Tools > Drawing Settings (in Manage). 

• On the menu, choose Tools > Drawing Settings. 

• On the Tools toolbar, click the Drawing Settings tool. 

• Type settings and then press Enter. 

2 Click the 3D Settings tab. 

3 Click the Surfaces tab. 

4 To change the current thickness, in the Current 3D Thickness box, type a new 

thickness value or click the arrows to select a new thickness. 

5 To change the current elevation, in the Current 3D Elevation box, type a new ele- 

vation value or click the arrows to select a new elevation. 

6 Click OK. 
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A Type or select the current three-dimensional 
thickness. 

B Type or select the current three-dimensional 
elevation. 

 

To change the thickness and elevation of an existing entity 

1 Do one of the following to choose Properties (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Modify > Properties. 

• On the Modify toolbar, click the Properties tool. 

• Type entprop and then press Enter. 

2 Select the entity, and then press Enter. 

4MCAD displays the Properties palette (its exact appearance depends on the type 

of entity you select). 

3 To change the thickness, in the Thickness box, type a new thickness value or click 

the arrows to select the new thickness. 

4 To change the elevation, in the Z coordinate box (or some entities have an Eleva- 

tion box), type a new elevation value or click the arrows to select the new eleva- 

tion. 

5 Click OK. 
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When you change the thickness of an entity, you do not change the entity type. 

If you want to extrude an entity and convert it to a three-dimensional solid, use the 

Extrude command. If you want to thicken a surface or mesh entity and convert it to a 

three-dimensional solid, use the Thicken command. 
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A Type or select the new thickness. B Type or select the new elevation. 
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Creating three-dimensional faces 
You can create a three-dimensional face, which consists of a section of a plane in 

three-dimensional space. You define a three-dimensional face by specifying the x,y,z 

coordinates of three or more corners. After you specify the fourth point, the program 

continues to prompt you for additional faces by alternating prompts for the third point 

and fourth point to allow you to build a complex three-dimensional entity. Each 

three- or four-sided plane is created as a separate three-dimensional face entity. 
 

To create a three-dimensional face 

Advanced experience level 

1 Do one of the following to choose Face ( ): 

• On the ribbon, choose Draw 3D > 3D Face (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Face. 

• On the Draw 3D Meshes toolbar, click the Face tool. 

• Type face and then press Enter. 

2 Specify the first point of the three-dimensional face. 

3 Specify the second, third, and fourth points. 

4 Specify the third and fourth points for additional faces. 

5 To complete the command, press Enter. 

 
 

Any or all edges of a three-dimensional face can be invisible to allow you to more accu- 

rately model entities with holes in them. 

As the program prompts you for the corner points, in the prompt box, choose Invisi- 

ble Edge to make the next edge invisible. Or after the 3D face is drawn, use the Edge 

command. For details about the Edge command, 
 

 

 

 
An example of a three-dimensional model created using three-dimensional faces. 
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Creating rectangular meshes 
You can create a three-dimensional rectangular mesh consisting of four-sided poly- 

gons. You determine the size of the mesh by specifying the number of vertices along 

the primary (M-direction) and secondary (N-direction) mesh axes and then specifying 

the coordinates for each vertex. 
 

To create a rectangular mesh 

Advanced experience level 

1 Do one of the following to choose Mesh (  ): 

• On the ribbon, choose Draw 3D > Meshes (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Mesh. 

• On the Draw 3D Meshes toolbar, click the Mesh tool. 

• Type mesh and then press Enter. 

2 Specify the number of vertices along the primary mesh axis. 

3 Specify the number of vertices along the secondary mesh axis. 

4 Specify the coordinates for each vertex. 

Specifying the coordinates for the last vertex completes the mesh and ends the 

command. 
 

 

Although creating rectangular meshes manually can be exacting, they are useful for repre- 

senting complex surfaces such as three-dimensional terrain models. 

The Mesh tool is most useful when combined with scripts or LISP programs that 

mathematically calculate the coordinates of the vertices. 
 

 

 

 
An example of a three-dimensional terrain model created using rectangular meshes. 
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Creating polyface meshes 
You can create a polygon mesh consisting of faces connecting three or more vertices. 

You first determine the coordinates of each vertex and then define each face by enter- 

ing the vertex numbers for all the vertices of that face. As you create each face, you 

can control the visibility and color of each edge and assign each edge to specific lay- 

ers. 
 

To create a polyface mesh 

Advanced experience level 

1 Do one of the following to choose Polyface Mesh (  ): 

• On the ribbon, choose Draw 3D > Polyface Mesh (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Polyface Mesh. 

• On the Draw 3D Meshes toolbar, click the Polyface Mesh tool. 

• Type pface and then press Enter. 

2 Specify the coordinates of each vertex. 

After each vertex that you specify, the next vertex number is displayed, and you 

are prompted for the coordinates of the vertex. Specify the coordinates, and then 

press Enter. Continue to specify the coordinates for each numbered vertex. 

3 To finish specifying vertex coordinates, press Enter. 

4 Specify the vertex numbers that define the first face. 

You specify the face by entering the vertex numbers that were defined when you 

specified coordinates in step 2. Each face can be composed of three or more num- 

bered vertices. 

5 To finish defining the first face, press Enter. 

6 Specify the next face by entering its vertex numbers. 

7 To complete the command, press Enter. 

 
 

Edges can be made invisible. 

Type the vertex number as a negative value. 
 

 

 

Creating ruled surface meshes 
You can create a ruled surface, which is a three-dimensional polygon mesh that 

approximates the surface between two existing entities. You select the two entities 

that define the ruled surface. These entities can be arcs, circles, lines, points, or 

polylines. 
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To create a ruled surface mesh 

Advanced experience level 

1 Do one of the following to choose Ruled Surface (  ): 

• On the ribbon, choose Draw 3D > Ruled Surface (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Ruled Surface. 

• On the Draw 3D Meshes toolbar, click the Ruled Surface tool. 

• Type rulesurf and then press Enter. 

2 Select the first defining entity. 

3 Select the second defining entity. 
 

 
Select the first (A) and second (B) defining entities. The resulting ruled surface mesh. 

 
 

The value of the Number of M-Direction Surfaces controls the density of the mesh. 

Choose Tools > Drawing Settings, click the 3D Settings tab. click the Surfaces tab, 

then under Surface Settings, change the Number Of M-Direction Surfaces value. 
 

 

 

Creating extruded meshes 
You can create an extruded mesh, which is a three-dimensional polygon mesh that 

approximates the surface generated by extruding a path curve along a direction vec- 

tor. You select the two entities that define the path curve and direction vector. The 

length of the direction vector determines the distance the path curve is moved along 

the direction vector. The extruded entity can be an arc, circle, line, or polyline. You 

can choose a line or open polyline as the direction vector. The resulting mesh consists 

of a series of parallel polygonal planes running along the specified path. 

You can create two types of extruded meshes: 

• Facet model meshes are smart meshes that can be modified with advanced features 

such as boolean operations. They are similar to solids but are more lightweight 

and don’t have mass properties. 

• Surface meshes are simple meshes. 
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To create an extruded facet model mesh 

1 Do one of the following to choose Extrude (  ): 

• On the ribbon, choose Draw 3D > Extrude (in Facet Model Meshes). 

• On the menu, choose Draw > Facet Model Meshes > Extruded. 

• On the Facet Model Meshes toolbar, click the Extrude tool. 

• Type fmextrude and then press Enter. 

2 Select the entity to extrude. 

3 Select the extrusion path, specify the direction, or specify the height. 
 

To create an extruded surface mesh 

1 Do one of the following to choose Extruded Surface (  ): 

• On the ribbon, choose Draw 3D > Extruded Surface (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Extruded Surface. 

• On the Draw 3D Meshes toolbar, click the Extruded Surface tool. 

• Type ai_tabsurf and then press Enter. 

2 Select the entity to extrude. 

3 Select the extrusion path. 
 

 
Select the entity to extrude (A) and the extrusion 
path (B). 

The resulting extruded 
surface mesh. 

 
 

The value of the Number of M-Direction Surfaces controls the density of the mesh. 

Choose Tools > Drawing Settings, click the 3D Settings tab, click the Surfaces tab, 

then under Surface Settings, change the Number Of M-Direction Surfaces. 
 

 

 
 

An extruded mesh is different from an extruded solid. 

If you want to extrude an entity and convert it to a three-dimensional solid, use the 

Extrude command. 
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Creating revolved meshes 
You can create a revolved mesh, which is a three-dimensional polygon mesh that 

approximates the surface generated by rotating a two-dimensional profile around an 

axis. You select the two entities that define the profile and the axis. You also specify 

the starting angle and the number of degrees to revolve the profile. 

Revolving the profile 360 degrees creates a closed three-dimensional mesh. 

You can create two types of revolved meshes: 

• Facet model meshes are smart meshes that can be modified with advanced features 

such as boolean operations. They are similar to solids but are more lightweight 

and don’t have mass properties. 

• Surface meshes are simple meshes. Note that the Number Of M-Direction Sur- 

faces value determines the mesh density (the number of mesh segments) in the M- 

direction (around the axis of revolution). The N-Direction Mesh Density value 

determines the mesh density (the number of mesh segments) in the N-direction 

(along the axis of revolution). 
 

To create a revolved facet model mesh 

1 Do one of the following to choose Revolve (  ): 

• On the ribbon, choose Draw 3D > Revolve (in Facet Model Meshes). 

• On the menu, choose Draw > Facet Model Meshes > Revolve. 

• On the Facet Model Meshes toolbar, click the Revolve tool. 

• Type fmrevolve and then press Enter. 

2 Select the entity to revolve. 

3 Do one of the following to define the axis of revolution: 

• Specify a start point and an end point. 

• Choose Entity and press Enter to select an entity that determines the axis. 

• Choose Xaxis to select the x-axis. 

• Choose Yaxis to select the y-axis. 

4 Specify the angle of revolution. 
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To create a revolved surface mesh 

1 Do one of the following to choose Revolved Surface (  ): 

• On the ribbon, choose Draw 3D > Revolved Surface (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Revolved Surface. 

• On the Draw 3D Meshes toolbar, click the Revolved Surface tool. 

• Type revsurf and then press Enter. 

2 Select the entity to revolve. 

3 Select the entity to be used as the axis of revolution. 

4 Specify the starting angle. 

5 Specify the number of degrees to revolve the entity. 
 

 
Select the entity to be revolved (A) and the 
axis of revolution (B). 

The resulting revolved surface 
mesh. 

 
 

The values of the Number of M-Direction Surfaces and N-Direction Mesh Density control 

the density of the mesh. 

Choose Tools > Drawing Settings, click the 3D Settings tab, click the Surfaces tab, 

then under Surface Settings, change the Number Of M-Direction Surfaces and N- 

Direction Mesh Density values. 
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Creating edge-defined Coons surface patch meshes 
You can create a surface called a Coons surface patch, a mesh connecting four edges. 

You select the entities that define the edges. Edge entities can be arcs, lines, or 

polylines. The four edge entities must form a closed loop and share endpoints. A 

patch is a bicubic surface (one curve extends in the M-direction and the other in the 

N-direction) interpolated between the four adjoining edges. You can select the edges 

in any order. The first edge you select determines the M-direction of the mesh. 
 

To create an edge-defined Coons surface patch mesh 

Advanced experience level 

1 Do one of the following to choose Coons Surface ( ): 

• On the ribbon, choose Draw 3D > Coons Surface (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Coons Surface. 

• On the Draw 3D Meshes toolbar, click the Coons Surface tool. 

• Type edgesurf and then press Enter. 

2 Select the first edge. 

3 Select the second, third, and fourth edges. 
 

 
Select the entities to be used as the four 
edges (A, B, C, and D). 

The resulting Coons surface patch mesh. 

 
 

The values of the Number of M-Direction Surfaces and N-Direction Mesh Density control 

the density of the mesh. 

Choose Tools > Drawing Settings, click the 3D Settings tab, click the Surfaces tab. 

then under Surface Settings, change the Number Of M-Direction Surfaces and N- 

Direction Mesh Density values. 
 

 

 

Creating boxes 
You can create rectangular boxes, or cubes. A box consists of six rectangular surface 

planes. The base of the box is always parallel with the xy plane of the current UCS. 

You position the box by specifying either a corner or the center of the box. You deter- 

mine the size of the box by either specifying a second corner and the height; defining 

the box to be a cube and then providing its length; or specifying the length, width, and 

height. 
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To create a box as an ACIS solid 

1 Do one of the following to choose Box (  ): 

• On the ribbon, choose Draw 3D > Box (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Box. 

• On the Draw 3D Solids toolbar, click the Box tool. 

• Type box and then press Enter. 

2 Specify the first corner of the base. 

3 Specify the opposite corner of the base. 

4 Specify the height. 
 

To create a box as a Facet Model mesh 

1 Do one of the following to choose Box (  ): 

• On the ribbon, choose Draw 3D > Box (in Facet Model Meshes). 

• On the menu, choose Draw > Facet Model Meshes > Box. 

• On the Facet Model Meshes toolbar, click the Box tool. 

• Type fmbox and then press Enter. 

2 Specify the first corner of the base. 

3 Specify the opposite corner of the base. 

4 Specify the height. 
 

To create a box as a 3D mesh 

1 Do one of the following to choose Box (  ): 

• On the ribbon, choose Draw 3D > Box (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Box. 

• On the Draw 3D Meshes toolbar, click the Box tool. 

• Type ai_box and then press enter. 

2 Specify the first corner of the base. 

3 Specify the opposite corner of the base. 

4 Specify the height. 
 

 
First corner of the base (A), the opposite corner of the base (B), and the height (C). 
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Creating wedges 
You can create three-dimensional wedges consisting of five surface planes. The base 

of the wedge is always parallel with the xy plane of the current UCS with the sloped 

face opposite the first corner. The height is always parallel with the z-axis. You posi- 

tion the wedge by specifying either a corner or the center of the wedge. You deter- 

mine the size of the wedge by either specifying a second corner and the height; 

defining the wedge based on a cube having a given length; or specifying the length, 

width, and height. 
 

To create a wedge as an ACIS solid 

1 Do one of the following to choose Wedge (  ): 

• On the ribbon, choose Draw 3D > Wedge (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Wedge. 

• On the Draw 3D Solids toolbar, click the Wedge tool. 

• Type wedge and then press Enter. 

2 Specify the first corner of the base. 

3 Specify the opposite corner of the base. 

4 Specify the height. 
 

To create a wedge as a 3D mesh 

1 Do one of the following to choose Wedge ( ): 

• On the ribbon, choose Draw 3D > Wedge (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Wedge. 

• On the Draw 3D Meshes toolbar, click the Wedge tool. 

• Type ai_wedge and then press Enter. 

2 Specify the first corner of the base. 

3 Specify the opposite corner of the base. 

4 Specify the height. 
 

 
First corner of the base (A), the opposite corner of the base (B), and the height (C). 
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Creating cones 
You can create three-dimensional cones defined by a circular base and tapering to a 

point perpendicular to the base. The base of the cone is always parallel with the xy 

plane of the current UCS; the height of the cone is always parallel with the z-axis. 

You position the cone by specifying the center of the base. You determine the size of 

the cone by specifying either the radius or the diameter of the base and the height. 
 

To create a cone as an ACIS solid 

1 Do one of the following to choose Cone (  ): 

• On the ribbon, choose Draw 3D > Cone (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Cone. 

• On the Draw 3D Solids toolbar, click the Cone tool. 

• Type cone and then press Enter. 

2 Specify the center of the base of the cone. 

3 Specify the radius or diameter. 

4 Specify the height. 
 

To create a cone as a Facet Model mesh 

1 Do one of the following to choose Cone (  ): 

• On the ribbon, choose Draw 3D > Cone (in Facet Model Meshes). 

• On the menu, choose Draw > Facet Model Meshes > Cone. 

• On the Facet Model Meshes toolbar, click the Cone tool. 

• Type fmcone and then press Enter. 

2 Specify the center of the base of the cone. 

3 Specify the radius or diameter. 

4 Specify the height. 
 

To create a cone as a 3D mesh 

1 Do one of the following to choose Cone (  ): 

• On the ribbon, choose Draw 3D > Cone (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Cone. 

• On the Draw 3D Meshes toolbar, click the Cone tool. 

• Type ai_cone and then press Enter. 

2 Specify the center of the base of the cone. 

3 Specify the radius or diameter. 

4 Specify the height. 
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Center of the base (A), the radius of the base (B), and the height (C). 

 

Creating pyramids 
You can create tetrahedrons (three-sided pyramids) or four-sided pyramids. The sides 

of the resulting pyramid can meet at a point (the apex) or can form a three- or four- 

edged top. The sides of a four-sided pyramid can also meet along a ridge defined by 

two points. The base of the pyramid is always parallel with the xy plane of the current 

UCS. You position the pyramid by specifying a corner of the base. You determine the 

size of the pyramid by specifying the base points and either the apex, the corners of 

the top surface, or the endpoints of the ridge. 
 

To create a tetrahedron as an ACIS solid 

1 Do one of the following to choose Pyramid (  ): 

• On the ribbon, choose Draw 3D > Pyramid (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Pyramid. 

• On the Draw 3D Solids toolbar, click the Pyramid tool. 

• Type pyramid and then press Enter. 

2 Specify the first point for the base of the pyramid. 

3 Specify the second and third points. 

4 In the prompt box, choose Tetrahedron. 

5 Specify the apex of the tetrahedron. 
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To create a tetrahedron as a 3D mesh 

1 Do one of the following to choose Pyramid (  ): 

• On the ribbon, choose Draw 3D > Pyramid (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Pyramid. 

• On the Draw 3D Meshes toolbar, click the Pyramid tool. 

• Type ai_pyramid and then press Enter. 

2 Specify the first point for the base of the pyramid. 

3 Specify the second and third points. 

4 In the prompt box, choose Tetrahedron. 

5 Specify the apex of the tetrahedron. 
 

 
The first point (A), second point (B), and third point (C) of the base, and the apex (D). 

To create a pyramid as a Facet Model mesh 

1 Do one of the following to choose Pyramid (  ): 

• On the ribbon, choose Draw 3D > Pyramid (in Facet Model Meshes). 

• On the menu, choose Draw > Facet Model > Pyramid. 

• On the Facet Model Meshes toolbar, click the Pyramid tool. 

• Type fmpyramid and then press Enter. 

2 Specify the center point for the base of the pyramid. 

3 Specify the radius for the base of the pyramid. 

4 Specify the height. 
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To create a pyramid with a planar top as an ACIS solid 

1 Do one of the following to choose Pyramid (  ): 

• On the ribbon, choose Draw 3D > Pyramid (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Pyramid. 

• On the Draw 3D Solids toolbar, click the Pyramid tool. 

• Type pyramid and then press Enter. 

2 Specify the first point for the base of the pyramid. 

3 Specify the second, third, and fourth points. 

4 In the prompt box, choose Top Surface. 

5 Specify the first point on the top surface of the pyramid. 

6 Specify the second, third, and fourth points. 
 

To create a pyramid with a planar top as a 3D mesh 

1 Do one of the following to choose Pyramid (  ): 

• On the ribbon, choose Draw 3D > Pyramid (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Pyramid. 

• On the Draw 3D Meshes toolbar, click the Pyramid tool. 

• Type ai_pyramid and then press Enter. 

2 Specify the first point for the base of the pyramid. 

3 Specify the second, third, and fourth points. 

4 In the prompt box, choose Top Surface. 

5 Specify the first point on the top surface of the pyramid. 

6 Specify the second, third, and fourth points. 
. 

 
The first point (A), second point (B), third point (C), and fourth point (D) of the base, and the first point (E), 
second point (F), third point (G), and fourth point (H) of the top surface. 
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Creating cylinders 
You can create cylinders defined by a circular base. The base of a cylinder is always 

parallel with the xy plane of the current UCS; the height of a cylinder is always paral- 

lel with the z-axis. You position a cylinder by specifying the center of the base. You 

determine the size of a cylinder by specifying either the radius or diameter of the base 

and the height. 
 

To create a cylinder as an ACIS solid 

1 Do one of the following to choose Cylinder ( ): 

• On the ribbon, choose Draw 3D > Cylinder (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Cylinder. 

• On the Draw 3D Solids toolbar, click the Cylinder tool. 

• Type cylinder and then press Enter. 

2 Specify the center of the base of the cylinder. 

3 Specify the radius or diameter. 

4 Specify the height. 
 

To create a cylinder as a Facet Model mesh 

1 Do one of the following to choose Cylinder (  ): 

• On the ribbon, choose Draw 3D > Cylinder (in Facet Model Meshes). 

• On the menu, choose Draw > Facet Model > Cylinder. 

• On the Draw Facet Model toolbar, click the Cylinder tool. 

• Type fmcylinder and then press Enter. 

2 Specify the center of the base of the cylinder. 

3 Specify the radius or diameter. 

4 Specify the height. 
 

To create a cylinder as a 3D mesh 

1 Do one of the following to choose Cylinder (  ): 

• On the ribbon, choose Draw 3D > Cylinder (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Cylinder. 

• On the Draw 3D Meshes toolbar, click the Cylinder tool. 

• Type ai_cylinder and then press Enter. 

2 Specify the center of the base of the cylinder. 

3 Specify the radius or diameter. 

4 Specify the height. 
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Center of the base (A), radius of the base (B), and the height (C). 

 

Creating spheres 
You can create spheres. The latitude lines of a sphere are always parallel with the xy 

plane of the current UCS; the central axis is always parallel with the z-axis. You posi- 

tion a sphere by specifying its center point. You determine the size of a sphere by 

specifying either its radius or its diameter. 
 

To create a sphere as an ACIS solid 

1 Do one of the following to choose Sphere (  ): 

• On the ribbon, choose Draw 3D > Sphere (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Sphere. 

• On the Draw 3D Solids toolbar, click the Sphere tool. 

• Type sphere and then press Enter. 

2 Specify the center of the sphere. 

3 Specify the radius or diameter. 
 

To create a sphere as a Facet Model mesh 

1 Do one of the following to choose Sphere (  ): 

• On the ribbon, choose Draw 3D > Sphere (in Facet Model Meshes). 

• On the menu, choose Draw > Facet Model > Sphere. 

• On the Draw Facet Model toolbar, click the Sphere tool. 

• Type fmsphere and then press Enter. 

2 Specify the center of the sphere. 

3 Specify the radius or diameter. 

 



 
 

 
To create a sphere as a 3D mesh 

1 Do one of the following to choose Sphere (  ): 

• On the ribbon, choose Draw 3D > Sphere (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Sphere. 

• On the Draw 3D Meshes toolbar, click the Sphere tool. 

• Type ai_sphere and then press Enter. 

2 Specify the center of the sphere. 

3 Specify the radius or diameter. 

4 Specify the number of longitudinal sections that are perpendicular to the xy plane. 

5 Specify the number of latitudinal sections that are parallel to the xy plane. 
 

 
Center (A) and radius (B) of the sphere. The resulting sphere. 

 

Creating dishes 
You can create a three-dimensional dish. The latitude lines of a dish are always paral- 

lel with the xy plane of the current UCS; the central axis is always parallel with the z- 

axis. You position a dish by specifying its center point. You determine the size of a 

dish by specifying either its radius or its diameter. 
 

To create a dish as an ACIS solid 

1 Do one of the following to choose Dish (  ): 

• On the ribbon, choose Draw 3D > Dish (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Dish. 

• On the Draw 3D Solids toolbar, click the Dish tool. 

• Type dish and then press Enter. 

2 Specify the center of the dish. 

3 Specify the radius or diameter. 
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To create a dish as a 3D mesh 

1 Do one of the following to choose Dish (  ): 

• On the ribbon, choose Draw 3D > Dish (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Dish. 

• On the Draw 3D Meshes toolbar, click the Dish tool. 

• Type ai_dish and then press Enter. 

2 Specify the center of the dish. 

3 Specify the radius or diameter. 
. 

 

 
Center (A) and radius (B) of the dish. 

 

Creating domes 
You can create a three-dimensional dome. The latitude lines of a dome are always 

parallel with the xy plane of the current UCS; the central axis is always parallel with 

the z-axis. You position a dome by specifying its center point. You determine the size 

of a dome by specifying either its radius or its diameter. 
 

To create a dome as an ACIS solid 

1 Do one of the following to choose Dome (  ): 

• On the ribbon, choose Draw 3D > Dome (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Dome. 

• On the Draw 3D Solids toolbar, click the Dome tool. 

• Type dome and then press Enter. 

2 Specify the center of the dome. 

3 Specify the radius or diameter. 

 



 
 

 
To create a dome as a 3D mesh 

1 Do one of the following to choose Dome (  ): 

• On the ribbon, choose Draw 3D > Dome (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Dome. 

• On the Draw 3D Meshes toolbar, click the Dome tool. 

• Type ai_dome and then press Enter. 

2 Specify the center of the dome. 

3 Specify the radius or diameter. 
 

 
Center (A) and radius (B) of the dome. 

 

Creating tori 
You can create a three-dimensional donut or ring-shaped entity known as a torus. The 

diameter of a ring is always parallel with the xy plane of the current UCS. A torus is 

constructed by revolving a circle about a line drawn in the plane of the circle and par- 

allel with the z-axis of the current UCS. You position a torus by specifying its center 

point. You determine the size of a torus by specifying its overall diameter or radius 

and the diameter or radius of the tube (the circle being revolved). 
 

To create a torus as an ACIS solid 

1 Do one of the following to choose Torus (  ): 

• On the ribbon, choose Draw 3D > Torus (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Torus. 

• On the Draw 3D Solids toolbar, click the Torus tool. 

• Type torus and then press Enter. 

2 Specify the center of the whole torus. 

3 Specify the radius or diameter of the whole torus. 

4 Specify the radius or diameter of the body of the torus. 
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To create a torus as a Facet Model mesh 

1 Do one of the following to choose Torus ( ): 

• On the ribbon, choose Draw 3D > Torus (in Facet Model Meshes). 

• On the menu, choose Draw > Facet Model Meshes > Torus. 

• On the Draw Facet Model toolbar, click the Torus tool. 

• Type fmtorus and then press Enter. 

2 Specify the center of the whole torus. 

3 Specify the radius or diameter of the whole torus. 

4 Specify the radius or diameter of the body of the torus. 
 

To create a torus as a 3D mesh 

1 Do one of the following to choose Torus (  ): 

• On the ribbon, choose Draw 3D > Torus (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Torus. 

• On the Draw 3D Meshes toolbar, click the Torus tool. 

• Type ai_torus and then press Enter. 

2 Specify the center of the whole torus. 

3 Specify the radius or diameter of the whole torus. 

4 Specify the radius or diameter of the body of the torus. 

5 Specify the number of longitudinal sections that are perpendicular to the xy plane. 

6 Specify the number of latitudinal sections that are parallel to the xy plane. 
 

 
Center (A) and radius of the whole torus (B), and the radius of the body (C). 

 

Creating regions 
You can convert a closed entity into a two-dimensional region. After you create a 

region, you can modify it using the various three-dimensional tools. For example, you 

can create a region from a square, and then extrude the square to create a three- 

dimensional cube. 



 
 

  

 

You can create regions from closed entities, such as polylines, polygons, circles, 

ellipses, closed splines, and donuts. 

Creating regions typically has no visible effect on a drawing. However, if the original 

entity had a width or lineweight, that information is lost when you create the region. 
 

To create a region 

1 Do one of the following to choose Region (  ): 

• On the ribbon, choose Draw 3D > Region (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Region. 

• On the Draw 3D Solids toolbar, click the Region tool. 

• Type region and then press Enter. 

2 Select the entities to create the region. 

3 Press Enter. 

The command bar displays a message that describes how many regions were cre- 

ated. 

 

Creating extruded solids 
You can create three-dimensional solids by extruding closed entities, such as 

polylines, polygons, circles, ellipses, closed splines, donuts, and regions. You can 

extrude the entity along a selected path, or you can specify its height and taper angle. 
 

To create an extruded solid 

1 Do one of the following to choose Extrude (  ): 

• On the ribbon, choose Draw 3D > Extrude (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Extrude. 

• On the Draw 3D Solids toolbar, click the Extrude tool. 

• Type extrude and then press Enter. 

2 Select the entity to extrude. 

3 Select the extrusion path, or specify the height. 
 

 
Select the entity to extrude (A) and the extrusion 
path (B). 

The resulting extruded 
solid. 
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Creating revolved solids 
You can create three-dimensional solids by revolving closed entities, such as 

polylines, polygons, circles, ellipses, and regions. You can revolve the entity about a 

defined axis, line, polyline, or two points. 
 

To create a revolved solid 

1 Do one of the following to choose Revolve (  ): 

• On the ribbon, choose Draw 3D > Revolve (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Revolve. 

• On the Draw 3D Solids toolbar, click the Revolve tool. 

• Type revolve and then press Enter. 

2 Select the entity to revolve. 

3 Do one of the following to define the axis of revolution: 

• Specify a start point and an end point. 

• Type o and press Enter to select an entity that determines the axis. 

• Type x and press Enter to select the x-axis. 

• Type y and press Enter to select the y-axis. 

4 Specify the angle of revolution. 
 

 
Select the entity to revolve (A) and the 
axis (B) about which to revolve it., 
followed by the angle of revolution. 

The resulting revolved 
solid. 



 
 

 

Creating lofted solids and surfaces 
Creates a three-dimensional solid or surface between two or more cross sections. 

Cross sections can be open or closed entities. Open cross sections create three-

dimen- sional surfaces. Closed cross sections create three-dimensional solids or 

surfaces, depending on the specified mode. 

 

Cross sections can be 2D polylines, lines, arcs, circles, ellipses, elliptical arcs, 2D 

splines, helices, traces, edges of entities, faces of a solid or surface, points of the first 

or last cross section, regions, and 2D solids. 

Guides can be 2D polylines with a single segment, 3D polylines, lines, arcs, elliptical 

arcs, 2D and 3D splines, and edges of entities. 

Paths can be 2D and 3D polylines, lines, arcs, circles, ellipses, elliptical arcs, 2D and 

3D splines, helices, and edges of entities. 
 

To create a lofted solid or surface 

1 Do one of the following to choose Loft ( ): 

• On the ribbon, choose Draw 3D > Loft (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Loft. 

• On the Draw 3D Solids toolbar, click the Loft tool. 

• Type loft and then press Enter. 

2 Select the cross sections in the order you want them to loft. You must select at 

least two cross sections. 

3 If desired, choose Point to taper the loft entity. Select the taper point on a cross 

section, then press Enter. 

4 If desired, choose Join multiple edges to create a cross section from edges. Select 

the edges, which must share start and end points, to be considered as a cross sec- 

tion. When done selecting edges, press Enter. 

5 If needed, choose Mode to change whether a three-dimensional solid or surface is 

created, then press enter. 

6 Press Enter to continue. 

7 Choose one of the following: 

• Guides — Creates the loft entity using guide curves which help shape the entity. 

Select the guide curves for the loft entity. Guide curves must intersect each cross 

section and begin and end at the first and last cross section. You can also 

combine multiple edges to form a guide. 

• Path — Creates the loft entity along a path. Select the path for the lofted entity. 

The path must intersect the solid or surface on all planes. 

• Cross sections only — Creates the loft entity between the cross sections without 

using guides or paths. 

• Settings — Opens the Loft Settings dialog box to specify various settings. 
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Creating swept solids and surfaces 
You can create three-dimensional solids or surfaces by sweeping an entity along a 

path. 

Entities that you can sweep include 2D polylines, lines, arcs, circles, ellipses, ellipti- 

cal arcs, 2D and 3D splines, 3D solid faces, and 2D solids. 

Entities that can be the path include 2D and 3D polylines, lines, arcs, circles, ellipses, 

elliptical arcs, 2D and 3D splines, helices, and edges of solids, surfaces, or meshes. 
 

To create a swept solid or surface 

1 Do one of the following to choose Sweep ( ): 

• On the ribbon, choose Draw 3D > Sweep (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Sweep. 

• On the Draw 3D Solids toolbar, click the Sweep tool. 

• Type sweep and then press Enter. 

2 Select one or more entities to sweep. 

You can choose Mode to change whether a three-dimensional solid or surface is 

created. 

3 Select the path. 

4 If desired, choose any of the following options: 

• Alignment — Aligns the sweep entity to be perpendicular (normal) to the 

tangent direction of the sweep path. 

• Base point — Determines the base point of the sweep entity. 

• Scale — Determines the scale factor for the sweep entity. If there are multiple 

sweep entities, the scale factor is applied to each entity. You can also choose 

Reference to select reference points in the drawing for scaling. 

• Twist — Determines the degrees in which to rotate the sweep entity along the 

path. If there are multiple sweep entities, the twist angle is applied to each entity. 

You can also choose Bank to determine whether the sweep entity being swept 

rotates along a 3D path such as a 3D polyline, spline, or helix. 



 
 

 
Creating polysolids 
You can create three-dimensional solids with a rectangular profile from a new 

polyline that you draw or from an existing line, arc, polyline, or circle. 
 

To create a polysolid without converting any entities 

1 Do one of the following to choose Polysolid ( ): 

• On the ribbon, choose Draw 3D > Polysolid (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Polysolid. 

• On the Draw 3D Solids toolbar, click the Polysolid tool. 

• Type polysolid and then press Enter. 

2 Select the start point of the polysolid. 

3 Continue selecting points. You can choose Arc to create an arc segment. You can 

also choose Undo to erase the previous point. 

4 Choose Height and specify the height of the polysolid. The default height is speci- 

fied by the PSOLHEIGHT system variable. 

5 Choose width and specify the width of the polysolid. The default height is speci- 

fied by the PSOLWIDTH system variable. 

6 Choose Justify to specify whether the width and height should be justified to the 

left, center, or right. Justification orientation is determined according to the direc- 

tion of the first profile segment. 

 

To create a polysolid from an existing entity 

1 Do one of the following to choose Polysolid ( ): 

• On the ribbon, choose Draw 3D > Polysolid (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Polysolid. 

• On the Draw 3D Solids toolbar, click the Polysolid tool. 

• Type polysolid and then press Enter. 

2 Choose Entity, then press Enter. 

3 Select the entity you want to convert to a polysolid. You can select a line, arc, 

polyline, or circle. 

4 Choose Height and specify the height of the polysolid. The default height is speci- 

fied by the PSOLHEIGHT system variable. 

5 Choose width and specify the width of the polysolid. The default height is speci- 

fied by the PSOLWIDTH system variable. 

6 Choose Justify to specify whether the width and height should be justified to the 

left, center, or right. Justification is determined according to the direction of the 

first profile segment. 
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Creating composite three-dimensional entities 
You can create composite three-dimensional facet model meshes by combining, sub- 

tracting, and finding the intersection of two or more facet model meshes. 

Composite three-dimensional entities can also be created using 3D solids. 

 
Combining three-dimensional entities 
Combine two or more facet model meshes to create one facet model mesh. 

You can also combine two or more 3D solids. 

To combine facet model meshes 

1 Do one of the following to choose Union (  ): 

• On the ribbon, choose Draw 3D > Union (in Facet Model Meshes). 

• On the menu, choose Draw > Facet Model Meshes > Union. 

• On the Facet Model Meshes toolbar, click the Union tool. 

• Type fmunion and then press Enter. 

2 Select the facet model meshes to combine. 

 
To combine solids 

1 Do one of the following to choose Union (  ): 

• On the ribbon, choose Draw 3D > Union (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Union. 

• On the Solids Editing toolbar, click the Union tool. 

• Type union and then press Enter. 

2 Select the 3D solids to combine. 
 

 
Select the entities to combine (A and B). The resulting combined 

entity. 

Subtracting three-dimensional entities 
Subtract two or more facet model meshes to create one facet model mesh. 

You can also subtract two or more 3D solids. 

 



 
 

 
To subtract facet model meshes 

1 Do one of the following to choose Subtract (  ): 

• On the ribbon, choose Draw 3D > Subtract (in Facet Model Meshes). 

• On the menu, choose Draw > Facet Model Meshes > Subtract. 

• On the Facet Model Meshes toolbar, click the Subtract tool. 

• Type fmsubtract and then press Enter. 

2 Select the facet model meshes to subtract from one another. 
 

To subtract solids 

1 Do one of the following to choose Subtract (  ): 

• On the ribbon, choose Draw 3D > Subtract (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Subtract. 

• On the Solids Editing toolbar, click the Subtract tool. 

• Type subtract and then press Enter. 

2 Select the 3D solids to subtract from one another. 
 

 
Select the entities to subtract (A and B). The resulting entity. 

 

Intersecting three-dimensional entities 
Create a composite three-dimensional entity from the intersection of two or more 

facet model meshes. Areas outside of the intersection are removed. 

You can also intersect two or more 3D solids. 
 

To intersect facet model meshes 

1 Do one of the following to choose Intersect (  ): 

• On the ribbon, choose Draw 3D > Intersect (in Facet Model Meshes). 

• On the menu, choose Draw > Facet Model Meshes > Intersect. 

• On the Facet Model Meshes toolbar, click the Intersect tool. 

• Type fmintersect and then press Enter. 

2 Select the facet model meshes to intersect. 
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To intersect solids 

1 Do one of the following to choose Intersect (  ): 

• On the ribbon, choose Draw 3D > Intersect (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Intersect. 

• On the Solids Editing toolbar, click the Intersect tool. 

• Type intersect and then press Enter. 

2 Select the 3D solids to intersect. 
 

 
Select the entities to combine (A and B). The resulting combined 

entity. 



 
 

 

Converting three-dimensional entities 
 

Various types of three-dimensional entities can be converted into other entity types: 

• Convert to 3D surfaces — Select closed 2D entities, 3D solids, regions, lines, arcs 

and open polylines with thickness, mesh entities and 3D faces to convert to 3D 

surfaces. 

• Convert to 3D meshes — Select 3D solids, 3D faces, polyface meshes and poly- 

gon meshes, regions, and closed polylines to convert to 3D meshes. 

• Convert to polyface meshes — Select 3D solids to convert to polyface meshes. 

• Convert to 3D solids — Select surfaces to apply thickness and convert to 3D sol- 

ids. 

 

Converting three-dimensional entities to surfaces 
You can convert the following entities into three-dimensional surfaces: closed 2D 

entities, 3D solids, regions, lines, arcs and open polylines with thickness, mesh enti- 

ties and 3D faces. 
 

To convert a three-dimensional entity to a surface 

1 Do one of the following to choose Convert to Surface (  ): 

• On the ribbon, choose Draw 3D > Convert to Surface (in Convert). 

• On the menu, choose Modify > 3D Convert > Convert to Surface. 

• Type convtosurface and press Enter. 

2 Select the entities you want to convert, then press Enter when done. 

 

Converting three-dimensional entities to meshes 
You can convert the following entities into three-dimensional surfaces: 3D solids, 3D 

faces, polyface meshes and polygon meshes, regions, and closed polylines. 
 

To convert a three-dimensional entity to a mesh 

1 Do one of the following to choose Convert to Mesh (  ): 

• On the ribbon, choose Draw 3D > Convert to Mesh (in Convert). 

• On the menu, choose Modify > 3D Convert > Convert to Mesh. 

• Type convtomesh and press Enter. 

2 Choose Settings to view or change settings for the conversion: 

• Show Edges Click this check box to display the edges that form the mesh. 

• Subdivide Level Enter a value from 0 to 3 to determine the level of detail. The 

higher the number, the greater the detail applied to the converted mesh. 

3 Click OK. 

4 Select the entities you want to convert, then press Enter when done. 
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Converting solids to polyface meshes 
You can convert three-dimensional solids to polyface meshes using the 3D Convert 

command. 
 

To convert a solid 

1 Do one of the following to choose 3D Convert (  ): 

• On the ribbon, choose Draw 3D > 3D Convert (in Convert). 

• On the menu, choose Modify > 3D Convert > 3D Convert. 

• On the Solids Editing toolbar, click the 3D Convert tool. 

• Type 3dconvert and press Enter. 

2 Select the entities you want to convert. 

 

Converting surfaces to solids 
You can apply thickness to surface and mesh entities and convert them to three- 

dimensional solids using the Thicken command. 
 

To convert a surface or mesh to a solid 

1 Do one of the following to choose Thicken (  ): 

• On the ribbon, choose Draw 3D > Thicken (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Thicken. 

• On the Solids Editing toolbar, click the Thicken tool. 

• Type thicken and press Enter. 

2 Select the surface or mesh entity you want to convert and apply thickness to. 

3 Enter the thickness value. 
 
 

 

Editing in three dimensions 
 

You can copy, move, rotate, array, mirror, and align two-dimensional and three- 

dimensional entities in both two-dimensional and three-dimensional space. You can 

also change and edit properties of three-dimensional entities much like you change 

and edit properties for two-dimensional entities. When you modify three-dimensional 

entities in two-dimensional space, you modify the entity in relation to the current 

UCS. 



 
 

 
 

 
Rotating in three dimensions 
You can rotate selected entities about a specified axis in three-dimensional space. 

You select the entities to rotate and then define the axis of rotation either by specify- 

ing two points; selecting an existing entity; aligning the axis with the x-, y-, or z-axis 

of the current UCS; or aligning the axis with the current view. 
 

To rotate an entity about an axis in three dimensions 

1 Do one of the following to choose 3D Rotate (  ): 

• On the ribbon, choose Edit > 3D Rotate (in Modify). 

• On the menu, choose Modify > 3D Rotate. 

• On the Modify toolbar, click the 3D Rotate tool. 

• Type rotate3D and then press Enter. 

2 Select the entities to rotate, and then press Enter. 

3 Choose from one of the following options: Entity, Last, View, Xaxis, Yaxis, 

Zaxis. 

4 Specify the rotation angle. 

5 Specify the reference angle. 
 

 
Select the entities to rotate (A), specify the 
endpoints of the axis of rotation (B and C), and then 
specify the rotation angle (D). 

 

Arraying in three 
dimensions 

Result after rotating the entities. 

You can copy selected entities and arrange them in a three-dimensional rectangular or 

polar (circular) pattern. For a rectangular array, you control the number of copies in 

the array by specifying the number of rows and columns and the number of levels. 

You also specify the distance between each. For a polar array, you specify the axis 

around which to array the entities, the number of copies of the entities to create, and 

the angle subtended by the resulting array. 
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To create a three-dimensional rectangular array 

1 Do one of the following to choose 3D Array: 

• On the ribbon, choose Edit > 3D Array (in Modify). 

• On the menu, choose Modify > 3D Array. 

• On the Modify toolbar, click the 3D Array tool. 

• Type 3Darray and then press Enter. 

2 Select the entities, and then press Enter. 

3 In the prompt box, choose Rectangular. 

4 Type the number of rows in the array. 

5 Type the number of columns. 

6 Type the number of levels. 

7 Specify the vertical distance between the rows. 

8 Specify the horizontal distance between the columns. 

9 Specify the depth between the levels. 
 

 
To create a three-dimensional rectangular array, select the entity to copy (A), type the number of rows, 
columns, and levels, and then specify the distance between each row (B), column (C), and level (D). 



 
 

 
To create a three-dimensional polar array 

1 Do one of the following to choose 3D Array (  ): 

• On the ribbon, choose Edit > 3D Array (in Modify). 

• On the menu, choose Modify > 3D Array. 

• On the Modify toolbar, click the 3D Array tool. 

• Type 3Darray and then press Enter. 

2 Select the entities, and then press Enter. 

3 In the prompt box, choose Polar. 

4 Type the number of copies to make, including the original selection set. 

5 Specify the angle the array is to fill, from 0 to 360 degrees. 

The default setting for the angle is 360 degrees. Positive values create the array in 

a counterclockwise direction; negative values create the array in a clockwise 

direction. 

6 In the prompt box, choose one of the following: 

• Yes-Rotate Entities to rotate entities as they are arrayed. 

• No-Do Not Rotate to retain the original orientation of each copy as it is arrayed. 

7 Specify the center point of the array. 

8 Specify a second point along the central axis of the array. 
 

 
To create a three-dimensional polar array, select the entity to copy (A), type the number of copies to make, 
specify the angle the array is to fill (B), and then specify the center point of the array (C) and a second point 
along the central axis of the array (D). 

 



Working with other programs 618  

  

 

 

 
Mirroring in three dimensions 
You can create a mirror image of selected entities in three-dimensional space. You 

mirror the entities about a mirror plane that you define by either specifying three 

points; selecting an existing two-dimensional planar entity; aligning the plane parallel 

with the xy, yz, or xz plane of the current UCS; or aligning the plane with the current 

view. You can delete or retain the original entities. 
 

To mirror an entity about a three-dimensional plane 

1 Do one of the following to choose 3D Mirror (  ): 

• On the ribbon, choose Edit > 3D Mirror (in Modify). 

• On the menu, choose Modify > 3D Mirror. 

• On the Modify toolbar, click the 3D Mirror tool. 

• Type mirror3D and then press Enter. 

2 Select the entities, and then press Enter. 

3 In the prompt box, choose 3 Points, or press Enter to select the default. 

4 Specify the first point on the mirror plane. 

5 Specify the second and third points on the plane. 

6 In the prompt box, choose one of the following: 

• Yes-Delete Entities to delete the original entities. 

• No-Keep Entities to retain the original entities. 
 

 
Select the entity to mirror (A), and then specify 
the first point (B), second point (C), and third 
point (D) defining the mirror plane. 

 

Aligning in three 
dimensions 

The resulting mirrored entity. 

You can align one or more selected entities with other entities in three-dimensional 

space. First you select the entities you want to move and align, then you specify pairs 

of points to move and align the selected entities: 

• One pair of points — Moves selected entities. 



 
 

 

 Two pairs of points — Moves then rotates selected entities. The second pair of 

points can also determine the scale of moved entities (scaling is available only 

when using two pairs of points). 

 Three pairs of points — Moves, rotates, then again rotates selected entities. 
 

To align entities by moving them 

1 Do one of the following to choose Align (  ): 

• On the ribbon, choose Edit > Align (in Modify). 

• On the menu, choose Modify > Align. 

• On the Modify toolbar, click the Align tool. 

• Type align and then press Enter. 

2 Select the entities that will be moved, and then press Enter. Do not include desti- 

nation entities in the selection set. 

3 Specify the first source point. 

4 Specify the first destination point, then press Enter. 
 

 
Select one or more entities to move, and 
then specify the first source point (A) and 
the first destination point (B). 

The resulting entities. 
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To align entities by moving and rotating them 

1 Do one of the following to choose Align (  ): 

• On the ribbon, choose Edit > Align (in Modify). 

• On the menu, choose Modify > Align. 

• On the Modify toolbar, click the Align tool. 

• Type align and then press Enter. 

2 Select the entities that will be moved and rotated, and then press Enter. Do not 

include destination entities in the selection set. 

3 Specify the first source point then the first destination point. 

4 Specify the second source point then the second destination point, then press 

Enter. 

5 If desired, choose Yes to scale the moved entities. Otherwise, choose No. If scal- 

ing, the selected entities scale proportionately so that the distance between the two 

source points is the same as the distance between the two destination points. 

The scaling option is available only when selecting two pairs of points. 
 

 
Select one or more entities to move and 
rotate, and then specify the first source 
point (A), the first destination point (B), the 
second source point (C), and the second 
destination point (D). 

The resulting entities, not scaled. 

 



 
 

 

 

 
 

 
To align entities by moving and then rotating them twice 

1 Do one of the following to choose Align (  ): 

• On the ribbon, choose Edit > Align (in Modify). 

• On the menu, choose Modify > Align. 

• On the Modify toolbar, click the Align tool. 

• Type align and then press Enter. 

2 Select the entities that will be moved and rotated, and then press Enter. Do not 

include destination entities in the selection set. 

3 Specify the first source point then the first destination point. 

4 Specify the second source point then the second destination point. 

5 Specify the third source point then the third destination point, then press Enter. 
 

 
Select one or more entities to move and 
rotate, and then specify the first source 
point (A), the first destination point (B), the 
second source point (C), the second 
destination point (D), the third source point 
(E), and the third destination point (F). 

The resulting entities. 
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Editing three-dimensional solids 
 

You can edit three-dimensional solids in several unique ways, including: chamfer, fil- 

let, section, and slice. You can also modify individual faces and edges of solids, as 

well as imprint, separate, shell, and check solids. 

You can edit three-dimensional ACIS solids, including: boxes, cones, cylinders, 

dishes, domes, pyramids, spheres, tori, and wedges. 

 

Chamfering and filleting solids 
You can chamfer or fillet a three-dimensional solid much like you chamfer or fillet a 

two-dimensional entity. 
 

To chamfer a solid 

1 Do one of the following to choose Chamfer (  ): 

• On the ribbon, choose Edit > Chamfer (in Modify). 

• On the menu, choose Modify > Chamfer. 

• On the Modify toolbar, click the Chamfer tool. 

• Type chamfer and then press Enter. 

2 Select the edge of the base surface to chamfer. (One of two surfaces adjacent to 

the selected edge will be highlighted.) 

3 Do one of the following: 

• To select a different surface, type n and press Enter. 

• To use the current surface, press Enter. 

4 Specify the base surface distance (measured from the selected edge to the base 

surface). 

5 Specify the adjacent surface distance (measured from the selected edge to the 

adjacent surface). 

6 Do one of the following: 

• Specify the edges to chamfer. 

• To select all edges around the base surface, type l and press Enter. 



 
 

 
To fillet a solid 

1 Do one of the following to choose Fillet ( ): 

• On the ribbon, choose Edit > Fillet (in Modify). 

• On the menu, choose Modify > Fillet. 

• On the Modify toolbar, click the Fillet tool. 

• Type fillet and then press Enter. 

2 Select the edge of the solid to fillet. 

3 Specify the fillet radius. 

4 Select additional edges to fillet, and press Enter to fillet. 

 

Sectioning and slicing solids 

You can section or slice a three-dimensional solid, region, or body (typically a sheet). 

When you section a solid, you obtain an “inside view” by creating a cross-section 

through the solid as a region or block. When you section a region or body, the result- 

ing intersections are curves. 

When you slice a solid, region, or body, you create a new entity by cutting the origi- 

nal entity and removing a specific side. 
 

To section an entity 

1 Do one of the following to choose Section (  ): 

• On the ribbon, choose Draw 3D > Section (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Section. 

• On the Draw 3D Solids toolbar, click the Section tool. 

• Type section and then press Enter. 

2 Select the entities to cross-section. 

3 Do one of the following: 

• Specify three points to define the cross-section plane. (The first point defines the 

origin, while the second point defines the x-axis and the third point defines the 

y-axis.) 

• Type o and press Enter to select an entity that defines the cross-sectional plane. 

• Specify an axis by typing the appropriate letter and pressing Enter. 
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To slice an entity 

1 Do one of the following to choose Slice (  ): 

• On the ribbon, choose Draw 3D > Slice (in Draw 3D Solids). 

• On the menu, choose Draw > 3D Solids > Slice. 

• On the Draw 3D Solids toolbar, click the Slice tool. 

• Type slice and then press Enter. 

2 Select the entities to slice. 

3 Do one of the following: 

• Specify three points to define the cross-section plane. (The first point defines the 

origin, while the second point defines the x-axis and the third point defines the 

y-axis.) 

• Type o and press Enter to select an entity that defines the cross-sectional plane. 

• Specify an axis by typing the appropriate letter and pressing Enter. 

4 Specify which side to retain, or type b to retain both sides. 
 
 

Modifying faces 
You can edit three-dimension solids by extruding, moving, rotating, offsetting, taper- 

ing, deleting, or copying individual faces. You can also change the color of individual 

faces. 

 
Extruding solid faces 

To extrude a solid face 

1 Do one of the following to choose Extrude Face (  ): 

• On the ribbon, choose Draw 3D > Extrude Face (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Extrude Face. 

• On the Solids Editing toolbar, click the Extrude Face tool. 

2 Select the entity with the face you want to extrude. 

3 Select the face(s) to extrude, and press Enter. 

4 Do one of the following: 

• Specify the height of extrusion. 

• Type p and press Enter to select a path for extrusion. 

5 If you specified a height, specify a taper angle. 



 
 

  

 

 

 
Select the entity to extrude, and then specify the 
face(s) to extrude (A), and the height of 
extrusion or path. 

 

Moving solid faces 

The resulting entity with the face extruded to 
position (B). 

To move a solid face 

1 Do one of the following to choose Move Face (  ): 

• On the ribbon, choose Draw 3D > Move Face (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Move Face. 

• On the Solids Editing toolbar, click the Move Face tool. 

2 Select the entity with the face you want to move. 

3 Select the face(s) to move, and press Enter. 

4 Specify a base point. 

5 Specify an end point. 
 

 
Select the entity, and then specify the 
face(s) to move (A), the base point (B), 
and the end point (C). 

The resulting entity with the face moved 
to the new position. 
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Rotating solid faces 

To rotate a solid face 

1 Do one of the following to choose Rotate Face (  ): 

• On the ribbon, choose Draw 3D > Rotate Face (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Rotate Face. 

• On the Solids Editing toolbar, click the Rotate Face tool. 

2 Select the entity with the face you want to rotate. 

3 Select the face(s) to rotate, and press Enter. 

4 Specify a base point. 

5 Specify another point on the rotation axis. 

6 Specify the rotation angle. 
 

 
Select the entity, and then specify the face(s) to 
rotate (A), the base point (B), a second point on 
the rotation axis (C), and a rotation angle. 

 

Offsetting solid faces 

The resulting entity with the face rotated to position 
(D). 

To offset a solid face 

1 Do one of the following to choose Offset Face (  ): 

• On the ribbon, choose Draw 3D > Offset Face (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Offset Face. 

• On the Solids Editing toolbar, click the Offset Face tool. 

2 Select the entity with the face you want to offset. 

3 Select the face(s) to offset, and press Enter. 

4 Specify an offset distance. 



 
 

 

 

 
Select the entity, and then specify the face(s) to 
offset (A) and the distance to offset. 

 

Tapering solid faces 

The resulting entity with the face offset to position 
(B). 

To taper a solid face 

1 Do one of the following to choose Taper Face (  ): 

• On the ribbon, choose Draw 3D > Taper Face (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Taper Faces. 

• On the Solids Editing toolbar, click the Taper Face tool. 

2 Select the entity with the face you want to taper. 

3 Select the face(s) to taper, and press Enter. 

4 Specify a base point. 

5 Specify another point along the axis. 

6 Specify a taper angle. 
 

 
Select the entity, and then specify the face(s) to 
taper (A), a base point, a second point along the 
taper axis, and a taper angle. 

The resulting entity with the face tapered to position 
(D). 
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Deleting solid faces 

To delete a solid face 

1 Do one of the following to choose Delete Face (  ): 

• On the ribbon, choose Draw 3D > Delete Face (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Delete Face. 

• On the Solids Editing toolbar, click the Delete Face tool. 

2 Select the entity with the face you want to delete. 

3 Select the face(s) to delete, and press Enter. 
 

 
Select the entity, and then specify the face(s) to 
delete (A). 

 

Copying solid faces 

The resulting entity with the face deleted. 

To copy a solid face 

1 Do one of the following to choose Copy Face (  ): 

• On the ribbon, choose Draw 3D > Copy Face (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Copy Face. 

• On the Solids Editing toolbar, click the Copy Face tool. 

2 Select the entity with the face you want to copy. 

3 Select the face(s) to copy, and press Enter. 

4 Specify a base point. 

5 Specify an end poin



 
 

 

Coloring solid faces 
 

To color a face 

1 Do one of the following to choose Color Face (  ): 

• On the ribbon, choose Draw 3D > Color Face (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Color Face. 

• On the Solids Editing toolbar, click the Color Face tool. 

2 Select the entity with the face you want to color. 

3 Select the face(s) to color, and press Enter. 

4 Specify a color. 
 

 
Select the entity, and then specify the face(s) to 
color (A). 

The resulting entity with the face colored. 
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Modifying edges 
In addition to modifying faces of solids, you can modify individual edges. You can 

copy individual edges or change the color of individual edges. 
 

To copy an edge 

1 Do one of the following to choose Copy Edge (  ): 

• On the ribbon, choose Draw 3D > Copy Edge (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Copy Edge. 

• On the Solids Editing toolbar, click the Copy Edge tool. 

2 Select the entity with the edge you want to copy. 

3 Select the edge(s) to copy, and press Enter. 

4 Specify a base point. 

5 Specify an end point. 
 

 
Select the entity, and then specify the edge(s) to 
copy (A), the base point (B), and the end point 
(C). 

To color an edge 

The resulting entity with the edge copied. 

1 Do one of the following to choose Color Edge (  ): 

• On the ribbon, choose Draw 3D > Color Edge (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Color Edge. 

• On the Solids Editing toolbar, click the Color Edge tool. 

2 Select the entity with the edge you want to color. 

3 Select the edge(s) to color, and press Enter. 

4 Specify a color. 



  

 
Imprinting solids 
You can modify the face of a solid by imprinting another entity on it. For example, 

you can imprint a line, arc, or polyline onto the face of a box. 
 

To imprint a solid entity 

1 Do one of the following to choose Imprint (  ): 

• On the ribbon, choose Draw 3D > Imprint (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Imprint. 

• On the Solids Editing toolbar, click the Imprint tool. 

2 Select the solid entity you want to imprint. 

3 Select the entity you want to imprint on the solid. 

 

Separating solids 
You can separate solids that have been combined. After you separate them, they are 

separated into individual solids. 
 

To separate solids 

1 Do one of the following to choose Separate (  ): 

• On the ribbon, choose Draw 3D > Separate (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Separate. 

• On the Solids Editing toolbar, click the Separate tool. 

2 Select the solid you want to separate. 

 

Shelling solids 

You can create a shell or a hollow thin wall from your 3D solid entity. 4MCAD 

offsets existing faces to create new faces. 
 

To shell a solid 

1 Do one of the following to choose Shell (  ): 

• On the ribbon, choose Draw 3D > Shell (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Shell. 

• On the Solids Editing toolbar, click the Shell tool. 

2 Select the entity you want to shell. 

3 Remove any faces you don’t want to include. 

4 Specify an offset distance. 



  
 

 

 
Select the entity, and then select faces to 
remove (A) and (B), then specify an offset 
distance. 

 

Cleaning solids 

The resulting shelled entity. 

You can remove redundant edges or vertices from solids when they are not needed. 
 

To clean a solid 

1 Do one of the following to choose Clean (  ): 

• On the ribbon, choose Draw 3D > Clean (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Clean. 

• On the Solids Editing toolbar, click the Clean tool. 

2 Select the entity you want to clean. 

 
Checking solids 

You can check whether a selected entity is a valid three dimensional ACIS solid. If it 

is a valid 3D solid, you can modify the entity using the 3D solid editing commands; if 

not, you cannot edit the entity using these commands. 
 

To check a solid 

1 Do one of the following to choose Check (  ): 

• On the ribbon, choose Draw 3D > Check (in Solids Editing). 

• On the menu, choose Modify > Solids Editing > Check. 

• On the Solids Editing toolbar, click the Check tool. 

2 Select the entities to check. 



  

 

Hiding, shading, and rendering 
 

As you create three-dimensional entities, the program displays both wire-frame and 

surface models in wire-frame view, which makes it difficult to visualize your three- 

dimensional models. To better visualize the model, you can remove all the lines that 

are hidden behind other entities or surfaces when seen from the current viewpoint. 

Shading goes a step further by removing hidden lines and then assigning flat colors to 

the visible surfaces, making them appear solid. Shaded images are useful when you 

want to quickly visualize your model as a solid entity, though they lack depth and 

definition. 

Rendering provides an even more realistic image of your model, complete with light 

sources, shadows, surface material properties, and reflections, giving your model a 

photo-realistic look. As shown in the following illustrations, when you render a 

model, the program removes hidden lines and then shades the surfaces as though they 

were illuminated from imaginary light sources. 

 

 
Wire-frame model. Hidden-line image. Shaded image. Rendered image. 

 

Creating hidden-line images 
Creating a hidden-line view of your drawing removes all the lines that are hidden 

behind other surfaces when seen from your vantage point. When you remove hidden 

lines or shade a model, the program treats the entities differently, depending on how 

you created them. Wire-frame models always appear transparent, because they have 

no surfaces. Surface models appear filled, with surfaces applied to all visible sides. 

You can also control the hidden-line view on an entity-by-entity basis by showing 

and hiding edges of selected 3D faces, meshes, and polyface meshes. 
 

To create a hidden-line image 

• Type hide and then press Enter. 
 

 

Use a visual style. 

Choosing View > Visual Styles > 3D Hidden is similar to using the Hide command. 

For more details, see “Displaying a drawing with a visual style” on page 219. 
 

 



  
 

 

 
Before creating a hidden-line image. After removing hidden lines. 

To hide edges of 3D faces, meshes, and polyface meshes 

1 Do one of the following to choose Hide Edges (  ): 

• On the ribbon, choose Draw 3D > Hide Edges (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Hide Edges. 

• Type hideedges and then press Enter. 

2 Select the entities with edges that you want to hide, then press Enter when done. 

 
 

Individual edges can be hidden for 3D faces. 

The Hide Edges command hides all edges of selected entities, but if you are working 

with 3D faces, you can also use the Edge command to hide individual edges. 
 

 

 
To show edges of 3D faces, meshes, and polyface meshes 

1 Do one of the following to choose Show Edges (  ): 

• On the ribbon, choose Draw 3D > Show Edges (in Draw 3D Meshes). 

• On the menu, choose Draw > 3D Meshes > Show Edges. 

• Type showedges and then press Enter. 

2 Select the entities with edges that you want to show, then press Enter when done. 

 
 

Individual edges can be displayed for 3D faces. 

The Show Edges command shows all edges of selected entities, but if you are working 

with 3D faces, you can also use the Edge command to show individual edges. 
 

 

 

Creating shaded images 
Creating a shaded image of your drawing removes hidden lines and then applies 

shading to the visible surfaces based on their entity color. Because they are intended 

to provide a quick visualization, shaded images do not have a light source and use 

continuous colors across surfaces, causing them to appear flat and unrealistic. 
 

To create a shaded image 

• Type shade and then press Enter. 



  

 

To control the appearance of the shaded image, choose Tools > Drawing Settings, 

and then click the 3D Settings tab and select the options you want. You can shade the 

surfaces and edges of the model in four ways: 

 Faces shaded; edges not highlighted. 

 Faces shaded; edges highlighted in the background color. 

 Faces filled in the background color; edges drawn using the entity color (similar to 

a hidden-line view). 

 Faces filled using the entity color; edges highlighted in the background color. 

 
 

Use a visual style. 

Choosing View > Visual Styles > 3D Realistic is similar to using the Shade com- 

mand. For more details, see “Displaying a drawing with a visual style” on page 219. 
 

 

 

Creating rendered images 
Creating a rendered image of your drawing removes hidden lines and then shades the 

surface as though it were illuminated from multiple light sources. 

Full rendering creates a photo-realistic image of your model, complete with light 

sources, shadows, surface material properties, and reflections. You can illuminate 

your image with spotlights, distant lighting to simulate sunshine, and ambient light. If 

you choose not to customize the light sources, the program generates default light 

sources for you. 

Rays from these imaginary light sources are traced as they reflect off and refract 

through the surfaces of the model, a process called ray tracing. Ray tracing deter- 

mines where shadows fall and how reflections on shiny materials such as metal and 

glass appear. You can modify the reflective properties of the materials that make up 

your model to control how the light rays reflect off its surfaces. 

Full rendering automatically creates a base on which your model is displayed, if you 

don’t already have one, so it does not appear suspended in space. A background is 

also automatically added to the image. A background such as a cloudy sky or an 

imported raster graphic such as a stone wall can also be added behind the image, 

making it even more realistic. 
 

To create a quickly rendered image 

Do one of the following to choose Render (   ): 

 On the ribbon, choose Render > Render. 

 On the ribbon, choose View > Visual Styles and select Realistic or Conceptual 
rendering. 

 On the Quick Access Toolbar, select Realistic or Conceptual rendering. 

 On the menu, choose Render > Render. 

 On the Rendering toolbar, click the Render tool. 

 Type render and then press Enter. 



  

 
 
 

 
Fully rendered image. 

 

Creating custom rendered images 
4MCAD allows you to create custom rendered images by applying materials, 

backgrounds, and lighting (including shadows) to your drawing: 

 Materials Specify materials for different surfaces and define how the materials 

map to those surfaces. Predefined materials are available in the materials library, 

which can be customized further using the built-in editor. You can choose to use 

procedural or bitmap materials.  

This option opens the Material Libraries that are included in the program and 

the user can select the materials which will be used in the project. More 

specifically, if the option "Material Library" is selected, the following dialog 

box appears: 



  

 

On the left side there is a list of the materials that are available at that moment 

for the needs of the particular project, while on the right side there is a list of the 

materials that you have generally at your disposal, from the material library 

(e.g. the Render.mln). 

In case you need a material from the General List of the Library in your project, 

all you have to do is to select this material (it is highlighted in blue color) and 

click "Insert". You can then see that this material is transferred on the left side. 

Before you "Insert" it, you can view this material through the "Preview" option 

in the window in the middle of the dialog box. Preview can be performed either 

in the form of spheres or in the form of cubes, selecting accordingly from the 

list right below the "Preview" button. The rest of the dialog box options are the 

following: 

Export: This is the reverse of the "Insert" option, e.g. you can transfer a 

material from the project in the Material Libraries.  

Delete: Deletes a material, either from the project file or from the Material 

Library that is open. 

Purge: Deletes the materials that have not been linked (to object, color or layer) 

in the current drawing. 

Open: Another library list (file) can open and materials can be saved in or 

selected from this library. 

Save: Saves the modifications that have been made in the open library or saves 

this library with a different name. 

To enable the Material library 

Do one of the following to select materials ( ):  

 Choose Render > Material Library 



  
 On the Render toolbar, click the Material Library tool 

 Type matlib and then press Enter 

 

Through the "Edit Materials" option the following dialog box appears with the 

materials that have been selected for the project, but there is also the possibility 

to activate the previous dialog box in order to select materials from the "Material 

Library".  

 

Apart from the "Preview" option, which can be performed here as well, there are 

also the following possibilities: 

Attach: This option associates the selected material with an object that is going 

to be selected later on. Selecting the desired material and then pressing 

“Attach” displays the drawing and you are prompted to select the entities where 

the specified material should be applied. This command applies for user-drawn 

objects and not for entities inserted from libraries or typical elements (such as 

walls, openings etc).  

To modify the materials for drawings inserted from a library, you should run the 

"Edit 3D Objects" command which is described further down. Moreover, to 

modify the materials of typical elements (walls, openings etc), you should open 

the corresponding dialog box selecting "3D Color" and "2D Color". 

Detach: Similarly, pressing “Detach”, you are prompted to select the objects 

from which you want to remove the selected material. This option also does not 

apply for entities inserted from libraries or typical elements (walls, openings 

etc). 

By ACI: This option allows assigning colors to materials. Upon selecting the 

desired material, press “By ACI…”; a dialog box entitled “Assign color to 

material” opens. 

First, select the desired material (left column); then, select the position where it 

should be located (right column). It is recommended to use a blank location and 

then press “Attach”. As a result, the selected material appears in the right 

column. Then, press OK to close this dialog box and return to the “Materials” 



  
window. A color is now assigned to the specified material and, selecting any 

menu with colors, this material appears in the specified location. 

By layer: This option allows assigning layers to materials. First, select the 

desired material (left column); then, select the layer name which should be 

assigned to it (right column) and press “Attach”. As a result, the selected 

material appears in the right column. Then, press OK to close this dialog box 

and return to the “Materials” window. A color is now assigned to the specified 

material and, selecting any menu with colors, this material appears in the 

specified location. 

Modify: This option opens the following dialog box that helps you modify the 

selected material: 

 

More specifically, you can modify anyone of the material "Attributes" that 

appear on the left side, by specifying a "Value" with the sliding key on the upper 

side. You can also modify "Color", by altering the ratios of Red, Green and Blue 

or selecting between the color systems RGB and HLS. More specifically, the 

material properties which you can modify are: 

1. Color/Pattern: Color is the basic color that reflects from the object. In order 

to import a drawing through "File selection", select the image (Bitmap) that 

will be used as a drawing. 

2. Ambient: The option for lighting the material with the ambient light 

determines the quantity of the ambient light that will illuminate the material. 

In general, keep the ambient value lower that 0.3. The greater the value the 

more faded the image will appear. 

3. Reflection: Here it is determined the amount of the striking on the material 

light that will be reflected, as well as the reflection color. For shiny objects 

set the refection value at 0.7 and the color at 0.3. If you wish the color of the 

highlighted areas to be white, change the value of Red, Green and Blue 

until it becomes 1. 

4. Roughness: The roughness value determines the size of the highlighted 

areas. Roughness has no meaning at all if reflection has no value. The 

lower the roughness value is, the smaller the highlighted area that will 

appear on the object will be. 

5. Transparency: The transparency value enables the user to make an 

object, or just a part of it, transparent. You can set the transparency value 

from "0" to "1". The greater the value is, the more transparent the object will 

be displayed. Transparency increases the photorealism period. In many 



  
cases it can double or triple this period. 

6. Refraction: Through this option you can specify a value for the refraction 

coefficient of a transparent material. The refraction value has a meaning 

only if transparency has a value. Indicative values for the refraction 

coefficient are: 1.0 for air, 1.33 for water, 1.5 for glass and 2.4 for diamonds. 

7. Bump-Map: This option supports the creation of a file, according to which 

the height differences will appear on a material, e.g. the grooves among the 

bricks. In this file, the lighter an area appears, the higher it is above the 

others. 

Adjust Bitmap: Through this option it is possible to set the size of the image 

that is positioned as a material, so that it will appear in its natural dimensions. 

The existing image has some natural dimensions. If you maintain the default 

values for offset and scale, then it is possible the image not to be visible on a 

natural scale. A methodology so that the image is displayed with natural 

dimensions is the following: 

Suppose you have a bitmap with the following natural dimensions in meters: a 

for the horizontal dimension and b for the vertical one. Next, insert the following 

values: 

For example, you have an image with a tile with dimensions 0.15m x 0.15m, 

and you should insert the following values: 

The materials specified in Render have a natural scale, but the user may 

modify them, if this is desired. 

Attention! If you want to save a material in a material library (e.g. the 

Render.mli) in scale, type the actual size and not the reciprocal (e.g. in the 

above example, concerning the tile, you should type 0.15 and 0.15). 

Upon completing the modification of the selected material properties, press OK 

to save the changes and return to the “Materials” window.  

Dublicate: Copies a material to a new material, in order to modify it. 



  

 

New: Creates a new material, through the adjacent dialog screen, by typing its 

name and specifying the color and the other properties, similarly to the "Modify" 

section. 

The type of the new material that is created can be one of the following: 

 Basic 

 Granite 

 Marble 

 Wood 

For example, if a new material of "Wood" type is selected and the proper values 

for its parameters are specified (Light color, Dark color, Reflection etc) the 

desired type of wood can be selected. Performing successive tests and 

previews after each parameter modification, the desired material can be 

approached satisfactorily. 



  

 

 

To enable the Material library 

Do one of the following to edit materials ( ):  

 Choose Render > Edit Materials 

 On the Render toolbar, click the Material tool 

 Type rmat and then press Enter 
 

 Backgrounds Specify the background or backdrop for a rendered image. Several 

predefined backgrounds are available. By default, no background is used and it 

appears black. The background is an infinite, planar surface and reflects off of any 

reflective surfaces in your model. The background is not affected by lighting how- 

ever, so no shadows or highlights are seen on the background. 

To set the Background (  ) 

Do one of the following:  

 Choose Render > Background. 

 Type background and then press Enter 

If the "Background" option is selected, the following dialog window appears, on 

the top of which there are 2 options: "Solid" and "Image". Each of these options 

excludes the possibility to activate the other one. 



  

 

Solid Background: Solid Background may simply correspond to the existing 

CAD background (since the relevant box is checked) or any other color (since 

this box is not checked). In the last case the user may select the color he wishes 

to use for the background from the color palette shown below. 

Moreover, after the user has selected the color, he can modify it slightly by 

setting accordingly the 3 sliding bars that exist for this purpose, and activate the 

"Preview" window at every change in order to view the background color in the 

frame. 

Image: Select, through the "File" option, the image-file of the "Landscape" where 

your drawing will be inserted. 

 

  

For example, if you select the "Cloud.jpg" file from the "Textures" subfolder, the 

corresponding background will appear. 

 

 

 



  
 

 

 Lighting Specify the placement of lights, light color, and light intensity to deter- 

mine how your drawing or scene is lit, including shadows and reflections in the 

scene. Lights can be placed either outside the field of view or inside to illuminate 

different areas of the scene. If you want to have natural light photorealism, the sun 

position can be easily defined via this command. In the appearing dialog window select 

the city you want (e.g. Athens) and the month for which the sun position is taken into 

account (e.g. September) as well as the day and time (normal or daylight saving) you wish 

photorealism to take place. 

Based on the above data and in conjunction with the setting of the north direction, which 

can be defined by placing the relevant symbol via the "Set North" command within the 

Topographic (AutoREG), the program automatically places the sun, so that the 

photorealism scene that will be created complies with the natural lighting completely. 

To Define the Sun ( ) 

Do one of the following:  

 Choose Render > Sun. 

 Type sun and then press Enter 

Through this option the user may define, easily and quickly, the position of a 

lighting source. When "Illuminator Position" is selected, the program prompts you 

to insert (in the command line), first of all, the illuminator name (e.g. 1), then its x 

and y co-ordinates, indicating its location on the ground plan, which is easily done 

with the mouse, and finally type its height. After entering all the above 

information, the illuminator appears at the location and the height that you 

positioned it, with the symbol shown above and its name in the middle. 

To place lights ( ) 

Do one of the following:  

 Choose Render > Lights Placement. 

 Type phota and then press Enter 

To edit lights ( ) 

Do one of the following:  

 Choose Render > Edit Lights. 

 Type light and then press Enter 

This option opens directly the following illuminator editing dialog box, including 

the options which are described below. 



  

 

Ambient light: Through this option you can adjust the intensity of the ambient 

light. Ambient light is the lighting that exists in a specific space, without coming 

directly from a certain light source, e.g. the natural lighting that exists in a room 

on a cloudy day. The intensity is constant for all surfaces in all directions. 

The greater the value is, the more intensely the areas that are not directly 

illuminated by a source will be lighted. You may select a different color for 

ambient light, except the white, through the "color" option. 

Point light: It is the fixed light source that emits to all directions. You may define 

or modify the intensity, the color and whether there will be any fading or shadows. 

Spot Light: Spotlight creates a light cone. You can define the direction, the size 

of the central cone of the middle beam (define the angle of the cone vertex), the 

size of the penumbra cone (define the angle of the penumbra cone vertex), the 

color, the fading and whether shadows are created from objects. 

Distant light: Distant light creates parallel light beams in only one direction. The 

sun is an example of such a light source. In Render, of course, it will not be 

necessary to select the "Distant light" option to define the sun since you can easily 

do so by running the "Sun" command instead. 

 

One another capability is Fog, which is used to activate the fog directly through 

the Render menu dialog window. 

To set the Fog ( ) 

Do one of the following:  

 Choose Render > Fog. 

 Type fog and then press Enter 

 Landscape and Bitmap Objects from which you may insert objects from a picture 

(e.g. trees, human figures etc) in your drawing. These objects have the advantage of 
occupying limited space on the drawing while they have an impressive impact on 

photorealism. 

In the appearing screen, select the desired object from the library list. Run "Preview" 
to see the object on the screen. 

In the Geometry option you may define the geometry of the appearing linear 
drawing because this is a bitmap (image). 

The first option "Single face" places a triangle to determine the object location or 

two triangles vertical to each other. The selected type affects the shadow created by 
the object. 



  
 

Through the "Height" option you can define in meters the height of the object in 

the drawing (e.g. 1.8 m for a human figure). 
Through the "Position" option you can position the object to the drawing. 

NOTE If you want to edit a landscape object then you may run the "Edit Landscape 

Objects" (LSEDIT) command. In order to save a new object in the library, run the 
"Landscape Object Library" (LSLIB) command. The landscape objects are saved in 

files with the extension "lli" (e.g. Render_eg.lli). 

 

To insert landscape objects ( ) 

Do one of the following:  

 Choose Render > landscape objects. 

 Type lsnew and then press Enter 

To edit bitmap objects ( ) 

Do one of the following:  

 Choose Render > edit bitmap objects. 

 Type lsedit and then press Enter 

Bitmap Object Library 

You can find and edit Bitmaps into the Bitmap Object Library. You are enabled to 

modify them, create new objects as well as edit objects of another library 

(render_en.lli etc) via the "Open" command and save them in any other desired 

library. 

  

   

 

To enable the Bitmap object library ( ) 

Do one of the following:  

 Choose Render > Bitmap objects library. 

 Type lslib and then press Enter 

 

 
 

 
 

You can specify additional rendering options. 

Choose Render > Render Options( ).  
 

 

 

 



  
 

Printing a rendered image 
You cannot print a rendered image directly to a printer. Instead, you must first save 

the drawing to a different format — either a bitmap (.bmp), TrueVision TGA (.tga), or 

Portable Network Graphic (.png). After you save a rendered image, you can print it 

from another graphics program. 

To save a rendered image of your drawing. 

Do one of the following:  

 Select Render > Render Settings. 

 On the Render toolbar, click the Render Preferences tool ( ). 

 Type rpref and press <Enter>. 

In Destination, select File and define the file output options 

 

 
Render and Render options 

Rendering will be based on a series of parameters. These parameters include the 

selection of a rendering algorithm, the shading method and many other options, 

which are described in detail below.  

Selecting the “Render Settings” command displays the following dialog box. 

 

OpenGL: This option allows very quick rendering as well as moving within the 

4MCAD environment. In particular, you can run the “Pan”, “Zoom in”, “Zoom out” 

and “3D Orbit” commands, while in rendering mode, to get a rendered image of the 

drawing from every side. This way, the user is able to have an overall view of the 

rendering effects, for all the objects and materials he/she has selected, without 

having to repeat the "Render" option segment by segment. 



  
 

Render: The "Render" option shows the materials on the surfaces (e.g. Brick) but 

does not create shadows. 

Circumambient Lighting: If this option is activated, you can see shadows on the 

surfaces from circumambient lighting (e.g. Sun). 

Shadows: Provided this option is active, rendering will create shadows from the 

various surfaces. 

Lights: If this option is activated, you can see shadows from lighting sources (point 

light, distant light, spotlight).  

Materials: If this option is active, with rendering you can see the materials that have 

been specified before. 

Optical: If this option is active, with rendering surfaces will be properly updated 

according to all the above (shades, materials, lights). 

The other options in this window are described below: 

Destination: Define where rendering will be performed. By selecting the button 

under the "Destination" indication, an option list appears, where you can define the 

rendering mean. 

 Window: Rendering will be performed on your screen as shown. 

 File: This option is used when you want to save the image in a file, in order 

either to save it to a diskette or to further edit it through another application. 

File Type: By clicking the pull down menu box of this section option list, an option 

menu appears, from where you may select the file type on which photorealism will 

be applied. 4MCAD supports the following file types: BMP, TGA (compressed and 

uncompressed), and PNG. Clicking the lower pull down menu box of this section 

option list, an option menu appears from which you may select the image 

dimensions in pixels. These dimensions are proportional to the desired screen 

resolution. If you select a standard image size (e.g. 800x600 or 640x480), the 

readings "Χ:", "Y:" and the "Aspect Ratio" are automatically adjusted and cannot be 

selected. But if a user-defined size is selected instead, you may then modify them. 

Through "Χ:", "Y:" adjust the image size that will be created within the file. 

Aspect Ratio: Here you can adjust the ratio of the screen pixel size to the file pixel 

size (for user-defined resolution). 

Colors: In this section, you may set the colors of the image created through 

rendering. 

After you have completed the settings, click “ΟΚ” to return to the previous dialog 

box. 

To control the render options. 

Do one of the following:  

 Select Render > Render Options. 

 On the Render toolbar, click the Render Preferences tool ( ). 

 Type rpref and press <Enter>. 

 

Through Render command you can have the desired scene rendered. The command 

is executed by typing "render" (and pressing "enter") in the line command, by 

clicking the corresponding icon or from the menu. 

Creating a rendered image of your drawing removes hidden lines and then shades 

the surface as though it were illuminated from multiple light sources.  



  
Full rendering creates a photo-realistic image of your model, complete with light 

sources, shadows, surface material properties, and reflections. You can illuminate 

your image with spotlights, distant lighting to simulate sunshine, and ambient light. 

If you choose not to customize the light sources, the program generates default light 

sources for you.  

Rays from these imaginary light sources are traced as they reflect off and refract 

through the surfaces of the model, a process called ray tracing. Ray tracing 

determines where shadows fall and how reflections on shiny materials such as metal 

and glass appear. You can modify the reflective properties of the materials that make 

up your model to control how the light rays reflect off its surfaces.  

Full rendering creates automatically a base on which your model is displayed, if you 

don’t already have one, so it does not appear suspended in space. A background is 

also automatically added to the image. A background such as a cloudy sky or an 

imported raster graphic such as a stone wall can also be added behind the image, 

making it even more realistic.  

When the Photorealism procedure is completed, the corresponding image appears on 

your screen. You may repeat the whole procedure as many times as you wish, after 

modifying any of the above parameters, until the desired outcome is achieved. 

To create a rendered image. 

Do one of the following:  

 Select Render > Render. 

 On the Render toolbar, click the Render tool ( ). 

 Type render and press <Enter>. 

 

 
 

 

NOTE In order to print a photo, you should either define the destination 

(destination render window) or copy it to a file and then run a Windows "Painting" 

program (such as Paintbrush or Paint) to load (through "Open") the file (e.g. BMP 

or TGA type) and print it (through "Print"). Apparently, a color photo requires a 

color printer and of course the relevant printer driver to be correctly set. 
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Working with other programs and computers 
 

4MCAD offers great flexibility in its capability to be used with other programs. You 

can include an 4MCAD drawing in a Microsoft® Word document or insert a 

Microsoft® Excel spreadsheet containing a parts list into an 4MCAD drawing. To 

include 4MCAD drawings in other programs and documents from other programs in 

4MCAD drawings, you either link or embed them. You can also save 4MCAD 

drawings in other file formats that can be used directly with other programs or send 

4MCAD drawings to coworkers via e-mail. 

This section explains how to: 

• Save and view snapshots. 

• Use object linking and embedding. 

• Export 4MCAD drawings to other file formats. 

• Convert one or more drawings to other file formats. 

• Use 4MCAD data on other computers. 

• Use 4MCAD with the Internet. 

 

 

 
 

 

 

16 
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Saving and viewing snapshots 
 

You can save snapshots of a drawing to view later. A snapshot saves the current 

drawing in either *.emf, *.wmf, or *.sld format exactly as it appears on the screen. A 

snapshot is not a drawing file. You cannot edit or print the snapshot; you can only 

view it. 

You can use snapshots in the following ways: 

• Make presentations by showing snapshots of your drawings. 

• Reference a snapshot of a drawing while working on a different drawing. 

• Present a number of snapshots as a slide show by using scripts. 

When you view a snapshot, it temporarily replaces the current drawing. When you 

refresh the display of the current drawing (by redrawing, panning, zooming, minimiz- 

ing, maximizing, or tiling), the snapshot image disappears, and you are returned to  

the current drawing. 

 

Creating snapshots 
You create a snapshot by saving the current view as a snapshot. A snapshot does not 

include any entities on layers that are not currently visible. The contents of the snap- 

shot also depend on the current drawing space. In model space, the snapshot shows 

only the current viewport. In paper space, the snapshot contains all visible viewports. 
 

To create a snapshot 

1 Display the drawing exactly as you want to capture it as a snapshot. 

2 Do one of the following to choose Make Snapshot (  ): 

• On the ribbon, choose Tools > Make Snapshot (in Manage). 

• On the menu, choose Tools > Make Snapshot. 

• On the Tools toolbar, click the Make Snapshot tool. 

• Type msnapshot and then press Enter. 

3 In the Create Snapshot dialog box, specify the name of the snapshot file you want 

to create. 

4 From the Files Of Types list, choose either *.emf, *.wmf, or *.sld. 

5 Click Save. 
 

The current drawing remains on the screen, and the snapshot is saved to the directory 

that you specify. 

 

Viewing snapshots 
You can view previously saved snapshots, and you can also view snapshots created 

using AutoCAD. 
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To view a snapshot 

1 Do one of the following: 

• On the ribbon, choose Tools > View Snapshot (in Manage). 

• Choose Tools > View Snapshot. 

• On the Tools toolbar, click the View Snapshot tool (  ). 

• Type vsnapshot and then press Enter. 

2 In the View Snapshot dialog box, specify the name of the snapshot file you want 

to view. 

3 Click Open. 

4MCAD displays the snapshot in the current drawing window. 
 
 

 

Using data from other programs in 4MCAD drawings 
 

You can include data from other programs in 4MCAD drawings by using either 

embedding or linking. The method you choose depends on the type of object or file 

you want to include in your 4MCAD drawing and what you want to do with it after it 

is there. 

 

Embedding objects into drawings 
Embed an object into your 4MCAD drawing when you want to keep all the data you 

work with in one file or if you want to transfer the file to other computers. You can 

embed data from programs that support object linking and embedding. 

For example, if you want to distribute data about a department’s computer equipment 

along with an 4MCAD drawing of the department’s floor plan, you can embed a 

Microsoft® Excel spreadsheet into the floor plan. 

When you embed data from another program, 4MCAD becomes the container for 

that data. The object embedded in the 4MCAD drawing becomes part of the 

4MCAD file. When you edit the data, you open its program from within the 4MCAD 

drawing. 

Any changes you make to the embedded data exist only in the 4MCAD drawing, so it 

is not necessary to keep that data in a separate file. If the data does exist in a sepa- 

rate file, the original file does not change when you modify the embedded object in 

4MCAD. Also, changes to the original file do not affect the embedded object in the 

4MCAD drawing. 
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To embed another program’s object into an 4MCAD drawing 

1 Open the file that contains the data you want. 

2 In the file, select the data you want to embed in the 4MCAD drawing. 

3 Choose that program’s command to place data on the Clipboard. 

Usually, you choose Edit > Copy. 

4 In the 4MCAD window, display the drawing in which you want to embed the 

object. 

5 Do one of the following to choose Paste ( ): 

• On the ribbon, choose Home > Paste (in Clipboard) or choose Edit > Paste (in 

Modify) 

• On the menu, choose Edit > Paste. 

• On the Standard toolbar, click the Paste tool. 

• Type paste and then press Enter. 

The data on the Clipboard is pasted into the drawing as an embedded object. The 

object appears in the center of the view, but you can select and move it by moving 

the cursor. 
 

To embed an object from an existing file within 4MCAD 

1 Do one of the following: 

• On the ribbon, choose Insert > Object (in Data). 

• On the menu, choose Insert > Object. 

• Type insertobj and then press Enter. 

2 In the Insert Object dialog box, click Create From File. 

3 Specify the file by doing one of the following: 

• Type a path and file name in the File box. 

• Click Browse to select a file. 

4 Select Display As Icon if you want that program’s icon to appear in the drawing 

instead of the data. 

5 Click OK. 

The first page of the file appears in the 4MCAD drawing, unless you chose to 

display it as an icon. You can select the object and drag to reposition it. 
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To create a new embedded object from within 4MCAD 

1 Do one of the following: 

• On the ribbon, choose Insert > Object (in Data). 

• On the menu, choose Insert > Object. 

• Type insertobj and then press Enter. 

2 In the Insert Object dialog box, click Create New. 

3 From the Object Type list, select the type of object you want to create, and then 

click OK. 

The program for creating that object opens within 4MCAD. If the program is 

compatible with ActiveX, it opens in place (within the other program) in the 

4MCAD drawing; otherwise, the program opens in its full window. 

4 Create the object in the other program. 

5 If the program is running within the other document (in place), click anywhere 

outside the embedded object to close the program. 

If the program is running in its full window, choose File > Exit. 

 

Linking objects to drawings 
If another program supports ActiveX, you can link its data to 4MCAD drawings. Use 

linking when you want to include the same data in many files. When you update the 

data, all links to other files reflect the changes. 

For example, if you created your company logo in an ActiveX-compatible drawing 

program, and you want to include it in the title block of every drawing you create 

with 4MCAD, you can link it to each 4MCAD drawing. When you change the 

original logo in the drawing program, the 4MCAD drawing updates automatically. 

When you link data from another program, the 4MCAD drawing stores only a ref- 

erence to the location of the file in which you created the data. You link data from a 

saved file, so 4MCAD can find the data and display it. 

Because linking adds only a reference to a file, the data does not significantly 

increase the file size of the 4MCAD drawing. However, links require some mainte- 

nance. If you move any of the linked files, you need to update the links. In addition, if 

you want to transport linked data, you must include all linked files. 

You can update a linked object automatically every time you open the drawing, or 

you can do so only when you specify. Anytime a link is updated, changes made to the 

object in its original file also appear in the 4MCAD drawing, and the changes also 

appear in the original file if they were made through 4MCAD. 
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To link a file to an 4MCAD drawing 

1 Save the original file. 

Because a link consists of a reference to the original file, you must save the file 

before you can link to it. 

2 In the original file, select the data you want in the 4MCAD drawing. 

3 Choose that program’s command to place data on the Clipboard. 

Usually, you choose Edit > Copy. 

4 Display the 4MCAD drawing to which you want to link the file. 

5 In 4MCAD, choose Edit > Paste Special. 

6 In the Paste Special dialog box, select Paste Link. 

7 Click OK. 
 

To create a linked object from within 4MCAD 

1 Display the 4MCAD drawing in which you want to display the linked object. 

2 Do one of the following: 

• On the ribbon, choose Insert > Object (in Data). 

• On the menu, choose Insert > Object 

• Type insertobj and then press Enter. 

3 In the Insert Object dialog box, click Create From File. 

4 Specify the file by doing one of the following: 

• Type a path and file name in the File box. 

• Click Browse to select the file using a file dialog box. 

5 Select the Link check box. 

6 Select Display As Icon if you want that program’s icon to appear in the drawing 

instead of the data. 

7 Click OK. 

The first page appears in the 4MCAD drawing, unless you chose to display it as 

an icon. To reposition the object, select and drag it. 

 

Editing an embedded or linked object from within 4MCAD  
 
You can modify an embedded or linked object in its original program from within 

4MCAD. When you modify an embedded object, you change the object only in 

4MCAD, not its original file (if you pasted the object from an existing file). When 

you modify a linked file, however, you open and change the original file. 
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Most programs include a submenu of actions you can perform on an embedded or 

linked ActiveX object. Usually, the commands for editing ActiveX objects are Edit 

and Open. If the object is embedded and its program supports in-place editing, the 

Edit command opens the object in place. The Open command opens the object in the 

full program window. In 4MCAD, this command appears at the bottom of the Edit 

menu. 
 

To edit an embedded or linked object 

 In the 4MCAD drawing, double-click the object. 

If the object is embedded and the program in which you created the object supports 

in-place editing, the object opens in place. 

If the object is linked, or if its program does not support in-place editing, the other 

program opens in its full window and displays the object. 
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Importing files created in other formats 
You can import files that have the following formats: 

 Autodesk DXFformat — Autodesk Drawing Exchange Format is an ASCII 

description of a drawing file with a .dxf file extension. 

 Autodesk DXBformat — Autodesk Drawing Exchange Format is a binary 

description of a drawing file with a .dxb file extension. 

 Autodesk DWFformat — Autodesk Design Web Format(used with .dwf 

files) is used to distribute a drawing for others to view in a Web browser, review, 

and edit. The DWF format uses the .dwf file extension. 

 DWT format — Drawing templates contain predefined settings that you can reuse 

when you create new drawings. Drawing templates use the .dwt file extension. 

 DGN format — Drawing files used with BentleyMicrostation. The DGN for- 

mat uses the .dgn file extension. 

 Spatial Technologies ACIS format — Three-dimensional ACIS solids saved as an 

.sat file. 

 IGES format — Model data in the IGES (Initial Graphics Exchange Specification) 

format as an .iges or .igs file. 

 STEP format — Model data in the STEP (Standard for the Exchange of Product) 

format as an .step, .ste or .stp file. 

 IFC format — Drawing files in the IFC (Industry Foundation Classes) format used 

for building and construction data. 

 Autodesk RVT and RFA format — Drawing files in the RVT and RFA formats 

used for building and construction data. 

 DAE format — Collada files are an interactive three-dimensional graphics file for- 

mat used by 3D graphics applications (three-dimensional entities are exported, 

including ACIS entities). Collada files use the .dae file extension. 
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Importing a DXF, DWF, DWT, DGN, or DAE format file 
Importing .dxf files, two-dimensional .dwf files, .dwt, .dae, and .dgn files is similar to 

opening a standard drawing file. 
 

To import a DXF, DWF, DWT, DGN, or DAE format file 

1 Do one of the following to choose Import (  ): 

• On the ribbon, choose the Application button then choose Import, or choose 

Insert > Import. 

• On the menu, choose File > Import. 

• On the Standard toolbar, click the Open tool. 

• Type import and then press Enter. 

2 Choose the folder that contains the drawing. 

3 In Files of Type, choose the type of drawing you want to import. 

4 Choose the file you want to open. 

5 Click Open. 

 
Importing a DXB format file 
A DXB format file is a drawing file used for building and construction data. 

 

To import a DXB format file 

1 Do one of the following: 

• Type dxbin and then press Enter. 

2 Choose the file you want to open. 

3 Click Open. 
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Importing an IFC, RVT, or RFA format file 
An IFC, RVT, or RFA format file typically contains a 3D model of a building that 

can be used for visualization, design, analysis, and to generate building construction 

documents. 

Importing an .ifc, .rvt, or .rfa file creates separate entities for each item in the file and 

converts those items to AEC entities where possible. 
 

To import an IFC, RVT, or .RFA format file 

1 Do one of the following to choose BIM IN: 

• On the ribbon Application button, choose Import > BIM In (  ). 

• Type bimimport and then press Enter. 

2 Choose the file you want to open. 

3 Click Open. 

 
Importing an ACIS format file 
An ACIS format file contains three-dimensional solids, regions, or bodies that are 

saved as an ASCII .sat file. 

 
To import an ACIS format file 

1 Do one of the following: 

• On the ribbon Application button, choose Import > ACIS In. 

• On the menu, choose File > ACIS In or choose Insert > ACIS File. 

• Type acisin, and then press Enter. 

2 Choose the directory containing the .sat file. 

3 Choose the .sat file you want to open. 

4 Click Open. 
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Importing an IGES format file 
The IGES (Initial Graphics Exchange Specification) format is an exchange format 

that typically contains 3D surfaces saved in an .iges or .igs file. IGES data is imported 

as three-dimensional solids. 

 
To import an IGES format file 

1 Do one of the following to choose IGES In (  ): 

• On the ribbon, choose the Application button then choose Import > IGES In. 

• On the menu, choose File > Import. 

• Type igesimport and then press Enter. 

2 Choose the .iges or .igs file you want to import. 

3 Click Open. 

Processing begins. When the selected file is ready to be imported a balloon mes- 

sage displays in the status bar. 

4 Click the file name in the balloon message to complete the import. 

5 Zoom to extents to see the imported entities. 

 
Importing a STEP format file 
STEP (Standard for the Exchange of Product) is an ISO standard exchange format 

that typically contains 3D objects saved in an .step, .ste or .stp file. STEP data is 

imported as three-dimensional solids. 

 

To import an STEP format file 

1 Do one of the following to choose STEP In (  ): 

• On the ribbon, choose the Application button then choose Import > STEP In. 

• On the menu, choose File > Import. 

• Type stepimport and then press Enter. 

2 Choose the .step, .ste or .stp file you want to import. 

3 Click Open. 

Processing begins. When the selected file is ready to be imported a balloon mes- 

sage displays in the status bar. 

4 Click the file name in the balloon message to complete the import. 

5 Zoom to extents to see the imported entities. 
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Using 4MCAD data in other programs 
 

You can use any of the following methods to include 4MCAD data in a document 

created in another program: 

• Embedding 

• Linking 

• Dragging 

• Exporting 

• E-mailing 

The method you choose depends on the capabilities of the other program and how 

you want to work with the 4MCAD data after you’ve placed it in the other 

document. 

 
 

Each method except exporting uses ActiveX to integrate data from different programs. 

With ActiveX, you can open 4MCAD drawings from within the other program to 

modify the 4MCAD drawings. 
 

 

 

Embedding drawings 
When you embed an 4MCAD drawing, it becomes part of the other program’s doc- 

ument file. When you edit the drawing, you edit only the version that is embedded in 

the other document. 

Embedding is useful when you don’t want to maintain a link to the 4MCAD draw- 

ing for the data you include in the other document. Edits made to the new drawing do 

not affect the original drawing. To transfer the file to other computers, you can trans- 

fer all the data in one file, but embedded objects increase the file size. 

From within a document in a program that supports ActiveX, such as Microsoft® 

Word, you can either create a new embedded 4MCAD drawing or embed an exist- 

ing 4MCAD drawing. 
 

To create an 4MCAD drawing in another document 

1 In the document, choose Insert > Object (or the equivalent command for that 

program). 

2 In the dialog box, click the options for creating a new file. 

3 Under Object Type, choose 4MCAD Drawing, and then click OK. 

4 Create the 4MCAD drawing. 

5 If 4MCAD is running in its own window, choose File > Exit. 

If 4MCAD is running within the other document (in place), click somewhere in 

the document outside the 4MCAD drawing to close 4MCAD. 
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6 To edit the 4MCAD drawing from within the document, double-click the 

drawing. 

 
 

You can also embed an existing 4MCAD drawing from within another document. Follow 

step 1 in the preceding procedure, and then click the option for creating an object 

from an existing file. 
 

 

 
To embed selected 4MCAD entities 

1 In 4MCAD, select the entities you want to embed. 

2 Choose Edit > Copy (or press Ctrl+C). 

3 Open the document in which you want to embed the entities. 

4 Choose Edit > Paste (or the equivalent command). 
 

To embed an entire 4MCAD drawing 

1 Open the document in which you want to embed the drawing. 

2 Do one of the following: 

• On the ribbon, choose Insert > Object (in Data). 

• On the menu, choose Insert > Object 

• Type insertobj and then press Enter. 

3 Click Create From File. 

4 Click Browse, and then choose the file you want to embed. 

5 Click Insert, and then click OK. 

 

Editing an embedded 4MCAD object in place 
In many ActiveX-compatible programs you can edit an embedded 4MCAD object 

without leaving the program (or container application). This is called in-place editing. 

A different set of 4MCAD menus and toolbars temporarily replaces most of the 

menus and controls in the active window while you edit the 4MCAD object. 
 

To edit an embedded 4MCAD object in place 

1 In the container application, double-click the embedded 4MCAD object. A 

different set of 4MCAD menus and controls appears. 

2 Edit the 4MCAD drawing. 

3 Click anywhere outside the drawing window to exit the in-place editing controls. 

 

Linking drawings 
When you link an 4MCAD drawing to another document, the other document con- 

tains only a reference to the 4MCAD drawing file, rather than the actual drawing. 

You link data in a saved 4MCAD file so that the other program can find the data and 

display it. 
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Linking works well when you want to include the same 4MCAD data in more than 

one document. When you update the data, you need update it in only one location. 

The versions that are linked to other documents reflect the changes automatically. 

Linking an 4MCAD file to another document does not increase the file size the way 

embedding an 4MCAD object does. However, links require more maintenance. To 

transport the data, you must make sure to transfer all linked files to the other 

computer. 
 

To link an 4MCAD file to another document 

1 Open the drawing you want to link. 
 

 

Because a link is a reference to a file, the referenced file must be saved on a local or 

remote disk. 

If you haven’t saved the drawing you want to link, choose File > Save. 
 

 

 

2 In the other program, open the document in which you want to include the 

4MCAD drawing. 

3 Choose that program’s command for inserting objects. 

In Microsoft® Office programs, choose Insert > Object. In the Object dialog box, 

click the Create From File tab. Specify the name of the drawing file you want to 

link. Select the Link To File check box, and then click OK. 

The drawing appears in the document, with a link to the original 4MCAD file. 

 

Dragging 4MCAD drawings into other programs 
If the other program in which you want to include 4MCAD drawings is compatible 

with ActiveX, an alternative to pasting drawings with menu commands is to drag 

drawing file icons from Windows Explorer into the other document. Dragging and 

dropping drawings does not use the Clipboard, so data on the Clipboard is not 

affected. 

When you drag an 4MCAD drawing file from Windows Explorer, you link or embed 

the entire drawing in the other document. When you drag the file, the cursor changes 

in response to the action you take. 

 
How the cursor changes 

 

 
 

Drag to embed the selected file to the other 
document. 

 
Cannot drop drawings in that document. 

 
 

Cursor appearance Action 
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For easy drag-and-dropping, position the application windows side by side. 

Before you drag a drawing, position the Windows Explorer window and the other 

program’s window so you can see the file icon and the document in which you want 

to drop it. 
 

 

 
To drag and embed drawings into another document 

 Select the icon for the drawing file, and then drag the drawing into the document. 

 

Exporting drawings 
You can save or export 4MCAD drawings in a number of different formats for use 

with other programs. When you save a drawing in a different format, the program 

saves all the entities in the drawing to the new file. Or, you can choose which entities 

are included in the new file. 

 

File formats that can be exported 
The following table describes the file formats that can be exported. 

 

Export formats 
 

 
Bitmap .bmp Graphics file 

Enhanced Windows Metafile .emf Graphics file 

Windows Metafile .wmf Graphics file 

Portable Document Format .pdf Distribute your drawing in 2D or 3D to others 

for using with Adobe® Acrobat® Reader® and 
Adobe® Acrobat 

Design Drawing .dgn Distribute your drawing to other for using with 

other CAD programs such as drawing to others 
for review, editing, and markup using other 
CAD programs such as Bentley® Microstation® 

Design Web Format .dwf Distribute your drawing to others for using with 
Autodesk® software and tools 

Scalable Vector Graphics .svg Graphics file and Web development language 

Stereolithography .stl Graphics file used for prototyping three- 
dimensional models 

Collaborative Design Activity 
(Collada) 

.d ae Interactive three-dimensional graphics file 
format used by 3D graphics applications 
(three-dimensional entities are exported, 
including ACIS entities) 

 
 

 

You can also export ACIS solids, regions, and surfaces to an ASCII file (*.sat) that 

you can use in other programs. 

Format File extension Details 
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Exporting to a BMP, EMF, WMF, STL, DAE, or SVG format file 
Exporting to a file is similar to saving a standard file. 

 

To export a drawing to a .bmp, .emf, .wmf, .stl, .dae, or .svg file 

1 Do one of the following: 

• On the ribbon, choose the Application button then choose Export, or choose 

Output > Export. 

• On the menu, choose File > Export. 

• Type export and then press Enter. 

2 In the Export Drawing As File dialog box, under Save As Type, choose the file 

format. 

3 Specify the name of the file you want to create. 

4 Click Save. 

5 If the selection prompt box displays, choose the entity-selection method, and then 

create the selection set. 

6 When you have finished selecting entities, press Enter. 

 
Exporting to a PDF format file 
PDF format files allow you to distribute your drawing to others for viewing in 

Adobe® Acrobat® Reader®, which is free software that users can download. PDF files 

can also be viewed, reviewed, and edited in Adobe® Acrobat. 

You can export drawings to two-dimensional and three-dimensional PDF files. 
 

To export a drawing to a .pdf file 

1 Do one of the following: 

• On the ribbon, choose the Application button then choose Export, or choose 

Output > Export. 

• On the menu, choose File > Export. 

• Type export and then press Enter. 

2 In Save As Type, choose Portable Document Format (pdf). 

3 Specify the name of the file you want to create. 

4 Click Save. 

5 Choose the entity-selection method, and then create a selection set that contains 

the entities you want to export. 

6 When you have finished selecting entities, press Enter. 

7 To create a 3D .pdf file instead of 2D, mark Enable Layer Support and then mark 

3D PDF Export. 
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8 Choose additional options for how you want to export to the .pdf file. Click [?] to 

see details about each option. 

9 Click Export. 
 

 

You can also print and publish to .pdf files. 

If instead of exporting you need to print to a .pdf file, you can print or publish directly 

to a .pdf file. For details about printing to .pdf, see “Selecting a printer or plotter” on 

page 539. For details about publishing to .pdf, see “Publishing a sheet list to the 

printer named in page setup” on page 565. 
 

 

 
Exporting to a DWF format file 
DWF format files allow you to publish your drawings so they can be viewed on the 

Internet using a Web browser. 4MCAD exports your drawing to a Design Web 

Format (.dwf) file, which can be viewed in a Web browser if Autodesk Design 

Review is also installed on the computer. Design Review is a free tool from 

Autodesk. 

You can export your drawing to a 2D .dwf file or a 3D .dwf file. 2D .dwf files have 

smaller file sizes, but cannot be viewed in three dimensions. 3D .dwf files can be 

viewed in three dimensions using the Autodesk® Design Review, but have larger file 

sizes. 
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To export a drawing to a .dwf file 

1 Do one of the following: 

• On the ribbon, choose the Application button then choose Export, or choose 

Output > Export. 

• On the menu, choose File > Export. 

• Type export and then press Enter. 

2 In Save As Type, choose Design Web Format (dwf). 

3 Specify the name of the file you want to create. 

4 Click Save. 

5 Choose the entity-selection method, and then create a selection set that contains 

the entities you want to export. 

6 Choose how you want to export: 

• DWF File Version — Choose the file version you want. Version 4.2 can export 

entities on the Model tab only (no layouts). Version 5.5 can export the current 

layout only. Version 6.0 can export the current layout or all layouts. 

• DWF File Format — Choose the desired file format. Compressed binary files 

have a smaller file size than uncompressed binary files (both are 2D .dwf files). 

ASCII files have the largest file size for 2D .dwf files, but 3D .dwf files have 

larger file sized and can be viewed in three dimensions. 

• Layout to Export — Choose whether to export the current layout only, or all 

layouts in the drawing. 

7 Click OK. 

8 When you have finished selecting entities, press Enter. 
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Exporting to a DGN format file 
DGN format files allow you to distribute your drawing to others for review, editing, 

and markup using other CAD programs such as Bentley®  Microstation®. Files are 

exported to DGN version 8 files. 
 

To export a drawing to a .dgn file 

1 Do one of the following: 

• On the ribbon, choose Output > DGN Out (in Export). 

• Type dgnexport and then press Enter. 

2 Specify the name of the file you want to create. 

3 Click Save. 

4 At the prompt, choose a master unit for the .dgn file such as kilometers or feet. 

5 At the prompt, choose a sub unit for the .dgn file such as inches or mils. 

The drawing is exported. 

 

Exporting to an ACIS format file 
You can export ACIS entities such as surfaces, regions, and solids to an ACIS format 

file in ASCII (SAT) format. 
 

To export an ACIS format file 

1 Do one of the following: 

• On the ribbon, choose the Application button then choose Export, or choose 

Output > Export. 

• On the menu, choose File > ACIS Out. 

• Type acisout and then press Enter. 

2 Select the ACIS entities you want to save. 

3 Specify the name of the file you want to create. 

4 Click Save. 

 

Converting drawings to other file versions and formats 
Several types of drawings can be converted to other file versions and formats. You 

can convert a batch of drawings in a folder or specify a single drawing to convert. 

The following formats can be converted from and converted to: 

• Autodesk DWGformat — Autodesk Drawing Format is a drawing with a .dwg 

file extension. 

• Autodesk DXFformat — Autodesk Drawing Exchange Format is an ASCII 

description of a drawing file with a .dxf file extension. 

• DGN format — Drawing files used with BentleyMicrostation. The DGN for- 

mat uses the .dgn file extension. 
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To convert a single drawing 

1 Do one of the following to choose 4MCAD Converter ( ): 

• On the ribbon, choose the Application button then choose Drawing Utilities > 

4MCAD Converter, or choose Tools > 4MCAD Converter (in Manage). 

• On the menu, choose File > 4MCAD Converter. 

• Type intelliconvert and then press Enter. 

2 Choose Single file, then click Next. 

3 Select an input file. Click [...] to browse to the location. 

4 Name an output file. Click [...] to browse to the location. 

5 In Convert to version, select the file format and version for the output file. 

6 If you are converting to a .dgn file, select any of the following: 

• Master unit — Assigns the selected master unit to the output .dgn file. 

• Sub unit — Assigns the selected sub unit to the output .dgn file. 

• Bind external references when possible — Makes external references a 

permanent part of the .dgn file, similar to a block, if external references are 

found in the input drawing. 

7 If you have more files to convert, mark Convert more files. 

8 Click Finish. 
 

 

A log file is created automatically if converting to a .dgn file and errors occur. 

The file <output_dgnfilename>.log is saved in the same folder where the output .dgn 

file is created. 
 

 

 
To convert a batch of drawings 

1   Do one of the following to choose 4MCAD Converter ( ): 

• On the ribbon, choose the Application button then choose Drawing Utilities > 

4MCAD Converter, or choose Tools > 4MCAD Converter (in Manage). 

• On the menu, choose File > 4MCAD Converter. 

• Type intelliconvert and then press Enter. 
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2 Choose Multiple files, then click Next. 

3 Specify the input files by doing the following: 

• Enter an input folder. Click [...] to browse to the location. 

• To include files located in subfolders within the input folder, mark Process 

subfolders. 

• Choose which files to include: .dwg, .dxf, and .dgn. 

4 Click Next. 

5 Review the list of files that are found, then click Next to proceed using all of the 

named files. You can also click Back to specify different files. 

6 Enter an output folder. Click [...] to browse to the location. 

7 Mark Convert, then select the output format and file version. 

8 To audit and fix files during the conversion, mark Audit files and fix errors. You 

can also choose to save audit log files, which will also be saved in the output 

folder. 

9 Select what to do, if while processing, files with the same name are found in the 

output folder: 

• Replace existing — Replaces existing files with the new files. To make a 

backup copy of the existing file before it is overwritten, mark Create backup 

files (*.bak), and backup files will be created in the same output folder. 

• Skip existing — Skips adding a new file if an existing file is found with the same 

name. 

• Add suffix to output files — Adds the specified suffix to all new files created in 

the output folder. 

10 If you are converting to a .dgn file, select any of the following: 

• Master unit — Assigns the selected master unit to the output .dgn file. 

• Sub unit — Assigns the selected sub unit to the output .dgn file. 

• Bind external references when possible — Makes external references a 

permanent part of the .dgn file, similar to a block, if external references are 

found in the input drawing. 

11 Click Next. 

New files are generated based on your specifications. 
 

 

A log file is created automatically if converting to a .dgn file and errors occur. 

The file <output_dgnfilename>.log is saved in the output folder that was specified for 

batch file conversion. 
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Using 4MCAD data on other computers 
 

Within 4MCAD there are two ways to move drawings and related files to another 

computer: 

• Create a package that contains all related drawings and files. This option uses the 

eTransmit command and is best for moving multiple drawings or a drawing that 

has supporting files such as external reference files and font files. 

• Send a drawing through e-mail from 4MCAD. This option uses the Send Mail 

command and is best for moving single drawings. 

 

Packaging drawings and files for use on another 
computer 
Use the eTransmit command to package together drawings and their related files, 

such as external references and fonts. The resulting package can be a self-extracting 

.exe file, a .zip file, or a separate folder that contains the files. 

The eTransmit command uses transmittal setups to define how packages are created, 

with options for filenaming, password control, whether to include fonts, and more. 

The default transmittal setup is named Standard, which you can modify. Or you can 

create new transmittal setups. 

 

Creating a package that contains drawings and related files 

To package drawings and their related files 

1 Do one of the following to choose eTransmit ( ): 

• On the ribbon, choose the Application button then Publish > eTransmit, or 

choose Output > eTransmit (in Export). 

• On the menu, choose File > eTransmit. 

• Type etransmit and then press Enter. 

2 Review the available files in the list. The files display in either hierarchical format 

(click the File Tree tab) or in a table (click the File Table tab). 

3 Mark the files to include in the package; unmark the files to exclude from the 

package. 

4 To include files that are not listed, click Add Files, navigate to and select the 

desired files, then click Open. 

5 In Select a Transmittal Setup, choose the transmittal setup that defines how you 

want the package to be created. The transmittal setup specifies the package file- 

type (.exe, .zip, or folder), filenaming, and more. 

6 To view or create a transmittal setup, click Transmittal Setups. For more details, 

see “Working with transmittal setups” on page 664 in this chapter. 
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7 Optionally enter notes to include in the transmittal report. 

8 Click OK. 

The package is created. 
 

 
 

A Click to view files in a hierarchy. 

B Click to view files in a table. 

C Mark the files to include in the package; unmark files 
to exclude. 

D Click to add files to the list. 

E Enter details to include in the package report. 

F Click to view the report that will be included in the 
package. 

G Displays a preview of the file selected in the list. 

H Click to view, create, and modify transmittal setups. 

I Displays a description of the selected transmittal 
setup. 

J Select the transmittal setup that defines the options 
you want to use when creating the package. 
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Working with transmittal setups 
Each time you create a package using the eTransmit command, you choose a trans- 

mittal setup to define how the package is created. Each transmittal setup defines the 

type of package that will be created (.exe, .zip, or folder), filenaming, password con- 

trol, whether to include font files, and more. 

You can create, modify, and delete transmittal setups. Creating more than one trans- 

mittal setup is especially helpful if you often need to package files for different recip- 

ients with different requirements. 
 

To create or modify a transmittal setup 

1 Do one of the following to choose eTransmit ( ): 

• On the ribbon, choose the Application button then Publish > eTransmit, or 

choose Output > eTransmit (in Export). 

• On the menu, choose File > eTransmit. 

• Type etransmit and then press Enter. 

2 Click Transmittal Setups. 

3 Do one of the following: 

• To create a transmittal setup, click New, enter a name, in Based On select a 

transmittal setup that has the settings closest to the one you want to create, then 

click Continue. 

• To modify an existing transmittal setup, select it from the list, then click Modify. 

The Modify Transmittal Setup dialog box displays. 

4 In Transmittal Package Type, select the type of package to create when using this 

transmittal setup. All files can be contained in a new folder, a self-extracting .exe 

file, or a .zip file. 

5 In File Format, select the file format for files packaged with this transmittal setup. 

Files in the package can keep their existing file format, or they can all be con- 

verted to the same file format. 

6 In Transmittal File Folder, enter the default location where this transmittal setup 

will save packages when they are created. You can type a location, select a recent 

location from the list, or click [...] to select a folder. 

7 In Transmittal File Name, select how to name .exe and .zip packages that are cre- 

ated with this transmittal setup. (Available for EXE and ZIP package types.) The 

following options are available: 

• Prompt for a filename — Allows you to enter a filename each time you create a 

package using this transmittal setup. The prompt displays after clicking OK in 

the Create Transmittal dialog box. 

• Overwrite if necessary — Uses the same filename that you enter each time you 

create a package using this transmittal setup, and overwrites existing files of the 

same name. Enter the filename in the field that becomes available. 
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• Increment filename if necessary — Uses the same filename that you enter each 

time you create a package using this transmittal setup, and increments the 

filename if an existing file exists with the same name. Enter the filename in the 

field that becomes available. 

8 In Path Options, select one of the following: 

• Place all files in one folder — Saves all files in one folder when files are 

unpackaged. 

• Keep files and folders as is — Saves all files in the original folder structure, 

which is recreated on the destination computer when files are unpackaged. This 

can help with file linking when the files are used on another computer. 

9 Use any of the following options to further define the transmittal setup settings: 

• Transmittal Setup Description — Enter an optional description for the trans- 

mittal setup. The description will display when you select this transmittal setup 

in the Create Transmittal dialog box. 

• Send E-Mail with Transmittal — Select to send the package as an email 

attachment; the default email application will open after the package is created. 

• Set Print Options to Default — Select to remove local printer settings from the 

package if they will not be applicable on other systems. 

• Bind External References — Select to bind or insert all .dwg file external refer- 

ences in the package. Binding makes external references a permanent part of the 

original drawing file, similar to a block. 

• Prompt for Password — Select to prompt for a password when the package is 

created and when it is unpackaged. 

• Purge Drawings — Select to purge all drawings when the package is created. 

• Include Fonts — Select to add associated font files (for example, TTF, SHX) in 

the package. 

• Include Unloaded File References — Select to include in the package any 

unloaded external references, including images and underlays; unloaded files 

are listed in the Create Transmittal dialog box. 
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A Select the type of package the transmittal setup will 
create. 

B Select a file format option. 

C Specify the default folder location where to save 
packages. Enter the location, select it, or click [...]. 

D Select how to name packages. (Available for EXE 
and ZIP package types.) 

E Select folder options to use when unpackaging files. 

F Enter a description of the transmittal setup. 

G Select to include any unloaded external references in 
the package. 

H Select to include font files in the package. 

I Select to purge all drawings when the package is 
created. 

J Select to protect the package with a password. 

K Select to bind or insert all .dwg file external 
references in the package. 

L Select to remove local printer settings from the 
package. 

M Select to send the package as an email attachment. 
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To rename a transmittal setup 

1 Do one of the following to choose eTransmit ( ): 

• On the ribbon, choose the Application button then Publish > eTransmit, or 

choose Output > eTransmit (in Export). 

• On the menu, choose File > eTransmit. 

• Type etransmit and then press Enter. 

2 Click Transmittal Setups. 

3 Select the transmittal setup you want to rename. 

4 Click rename. 

5 Enter the new name, then press Enter. 
 

To delete a transmittal setup 

1 Do one of the following to choose eTransmit ( ): 

• On the ribbon, choose the Application button then Publish > eTransmit, or 

choose Output > eTransmit (in Export). 

• On the menu, choose File > eTransmit. 

• Type etransmit and then press Enter. 

2 Click Transmittal Setups. 

3 Select the transmittal setup you want to delete. 

4 Click Delete, then confirm the deletion. 
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Sending a drawing through e-mail 
You can send an 4MCAD drawing to another user via e-mail. 4MCAD is com- 

patible with e-mail programs that support the Messaging Application Program Inter- 

face (MAPI) protocol. 
 

To include a drawing file in an e-mail message 

1 While the drawing file is open, do one of the following: 

• On the ribbon, choose the Application button then Publish > Send Mail. 

• On the menu, choose File > Send Mail. 

• Type mail and then press Enter. 

If your mail program is not already running, it starts; a new e-mail message con- 

taining the 4MCAD icon and file name appears. 

2 Address the e-mail, type a message, and send the e-mail message as you would 

any other message. 

 

To view an 4MCAD file sent by e-mail 

• Open the e-mail message, and then double-click the 4MCAD icon. 4MCAD 

software must be installed on the computer used to open drawings from e-

mail. 
 

 

Use the eTransmit command for e-mail if the drawing has supporting files. 

If the drawing is dependent on files such as external references or font files, use the 

eTransmit command to combine the files in a single package and send it by e-mail. 

When creating the package, use a transmittal setup with the Send Mail with Transmit- 

tal option turned on. For more details, see “Packaging drawings and files for use on 

another computer” on page 662 in this chapter. . 
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Using 4MCAD with the Internet 
 

You can use 4MCAD to access the Internet and exchange drawing information and 

perform other tasks, including: 

• Add hyperlinks to a drawing. 

• Publish drawings to the Internet. 

• Drag drawings (.dwg files) directly from a Web site into 4MCAD. 

• Access the Internet during a drawing session. 

 
 

You need an Internet browser to use hyperlinks. 

Internet Explorer Version 5.0 or later is required to access to the Internet to fully use 

these features. 
 

 

 

Adding hyperlinks to a drawing 

In your 4MCAD drawings, you can include hyperlinks, which are pointers that take 

you to another location, such as a Web address or a file on a particular computer. 

You can attach a hyperlink to any entity in your drawing. Then, when you select that 

entity, you can open the link and jump to the specific Web address or file location. 

You can create absolute hyperlinks, which store the full path to a file, or relative 

hyperlinks, which store a partial path relative to a base folder or a Uniform Resource 

Locator (URL). 

 
 

The PICKFIRST system variable must be set to on. 

Files associated with hyperlinks can be opened only if the PICKFIRST system vari- 

able is turned on. 
 

 

 
To create a hyperlink 

1 Type hyperlink and then press Enter. 

2 Select an entity or entities that you would like to associate with a hyperlink; then 

press Enter to display the Edit Hyperlink dialog box. 

3 Do one of the following: 

• Click Browse to specify a file. 

• In the Link to File or URL box, type a Web address. 

4 If you want to use a common path for all hyperlinks in the drawing, select the Use 

relative path for hyperlinks check box. Relative paths provide flexibility if you 

move files to a different folder, since you can change multiple hyperlink paths at 

once, rather than change them all individually. 

5 Click OK to close the Edit Hyperlink dialog box. 
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The HYPERLINKBASE system variable defines the relative path used for all hyperlinks in 

the current drawing. 

To use the default drawing path, leave the value blank by entering a period (“.”). 
 

 

 
To remove a hyperlink 

1 Type hyperlink and then press Enter. 

2 Select an entity or entities with a hyperlink; then press Enter to display the Edit 

Hyperlink dialog box. 

3 Click Remove Link. 

4 Click OK to close the Edit Hyperlink dialog box. 
 

To access a hyperlink 

1 Select an entity with a hyperlink. 

2 Right-click anywhere in the drawing area. 

3 In the pop-up menu, choose Open Link. 

 

Publishing drawings to the Internet 
You can publish your drawings so they can be viewed on the Internet using a Web 

browser. 4MCAD exports your drawing to a Design Web Format (.dwf) file, which 

can be viewed in a Web browser if Design Review is also installed on the computer. 

Design Review is a free tool from Autodesk®. 

For details about creating a DWF file, see “Click Export.” on page 657 in this chap- 

ter. 
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Inserting drawings from a Web site 

Some Web sites are configured to allow you to drag drawings from the Web site 

directly into your drawing. You can drag-and-drop drawings from any Web site that 

supports the Autodesk® i-droptechnology. 
 

To insert a drawing from a Web site 

1 Open your Web browser. 

2 Navigate to a Web site that supports Autodesk® i-drop. 

3 Position the Web browser and 4MCAD windows so they are both visible. 

4 Click the drawing in your Web browser and drag it to your drawing in 4MCAD. 

The drawing file is downloaded and inserted into your drawing in 4MCAD. 

 

Accessing the 4MCAD Web site during a drawing session 
In addition to using hyperlinks to access the Internet, you can access a company Web 

site at any time. At the Web site, you can obtain company information as well as 

product information and news. 
 

To access the 4MCAD Web site 

1 Do one of the following: 

• On the ribbon, choose Help > 4MCAD on the Web. 

• On the menu, choose Help > 4MCAD on the Web. 

• Type onweb and then press Enter. 

2 Navigate to the section of your choice on the 4MCAD Web site. 
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Working with Plus Menu 
 

4MCAD includes a large group of options under the general menu PLUS. These 
are a series of additional drawing tools, which have been embodied in the package 

in order to help the user during drawing such as. 

• General. 

• Text and Text frame editing. 

• Adding notes, lines. 

• Working with blocks and layers 
 

General 
Printing scale 
The first option included in the PLUS menu of options is “Printing Scale”, which is 

used to specify a scale: 
  

 
Delete duplicate objects 
Using this command, you can erase all the duplicate entities. After running the 

command, you are asked to select entities and then the following dialog box appears 
where you can define your criteria: 
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Selection filter 
Using this command, you can select a group of entities based on a specific property 
(layer, color, thickness,etc). 
Internet transmission 
This command packages a set of files for Internet transmission. 
Multiview setup 

This command sets up the specifications of a drawing. Different prompts are 
displayed, depending on whether you are currently in Model space or in Paper space. 
Convert PDF to DWG 
The PDF to CAD feature allows to save time by easily transferring projects, 
drawings, parts of existing in vectorial PDFs catalogs and manuals to CAD drawings 

to use them as native DWG files. Convert PDF to DWG function supports all 
versions of Adobe PDF file. It is just needed to select the PDF file and the software 

converts it to dwg displaying the corresponding message in order to store it. 
Set Elevation 
This command defines the current elevation z. 
Library manager 
Library Manager is used to store and manage typical block drawings. Once you 

execute the command the following dialog box is appeared.   
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Text and Text frame editing  

The text menu of options includes a number of tools, especially useful for 

manipulating text inside drawings. 

These tools are described next, in the order they appear in the menu. The use of 
parentheses indicates commands, which are identical with the corresponding 

commands in 4MCAD. 

Text Height  

Using the above command, you can set the current height of the drawing, in drawing 

millimetres. 

 

Select Style  

Using the above command you can specify the font you want to use. 
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Text 

The above command enables you to write text directly on your drawing, as soon as 
you specify the height and the angle of the text, requested by the application. If you 

press <Enter> twice, the default values of height and angle are maintained, in which 
case you immediately write the desired text. 

Edit Paragraph (Ptext) 

The above command activates a paragraph text editor. Using this command, the 
following prompts appear: 

Center/Edit/Fit/Right/Slack/?/<Startpoint>: Specify the starting point of the text. 

Text height <0.2000>: Specify the height of the text in drawing units (Drawing Units). 
By pressing <Enter>, the default value is assumed. 

Rotation angle <0>: Specify the angle of writing of the text. 

Ιnter_line spacing <0.3000>: Specify the distance between lines of text. 

Maximum line length <2.000>: You set the maximum length of a line of text in 
drawing units (Drawing units) 

Text: Write the text. If you want to write in a new line, before you reach the end of the 
current one, simply press <Enter>. 

Sequence (Arithmetic Progression) 

The above command places a sequence of letters or digits (consecutively) on your 
drawing. It is useful for the automatic numbering of identical objects (eg. switches, 
lights, fire boxes etc.). During the execution of the command, the following prompts 

appear: 

Alphabetic <Α> or Numerical <Ν> Sequence<A or N>?: Type “A” if an alphabetic 

sequence is needed, or “N” if a numeric sequence is needed. 

If you type “A”, these prompts will follow: 

Which is the first letter?: Specify the starting letter of the sequence eg. B. 

Text alignment <Left Right Center Middle>?: Specify the text alignment to be left, 
right, middle etc. 

Writing Angle?: Specify the angle of writing of the text (in degrees). 

Add Prefix <P> or Suffix <S>?: Specify if you want to add a prefix or a suffix to the 
text which results from the numbering. 

Added Text: Specify the text that will be used as Prefix or Suffix. 

Give Text Points: Specify the points where you want the text to be placed. 

If you type “N”, these prompts will follow: 

Which is the first number?: Specify the starting digit of the numbering. 

Number to be added?: Specify the step that will be used to create the sequence. 

  

Text Alignment <Left Right Center Middle>?: Specify the text alignment to be left, 
right, middle etc. 

Writing Angle?:  Specify the angle of writing of the text (in degrees). 

Add Prefix <P> or Suffix <S >?: Specify if you want to add a Prefix or a Suffix to the 

text that results from the numbering. 
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Added text: Specify the text that will be used as Prefix or Suffix. 

Give Text Points (Text Location): Specify the points where you want the text to be 
placed. 

Get Style (StyleSet) 

The above command is used when you want to write text using the parameters of the 
existing text (fonts, character height etc.). The command prompts are the following: 

Select existing Text: Select the piece of text that will be used as the basis for writing 
new text. 

Justify/style/<start point>: Specify the starting point of the text. You can, however, 
modify the alignment of the text (justify) by pressing J, or the character style, by 

pressing S. 

Rotation angle <0>: Specify the angle of writing of the text. 

Text: Write the text. 

Change Style (CSTYLE) 

The above command is used to change the character style (style). More specifically, 

the command prompts are: 

Global <G> or Selective <S>: Pressing G will modify all the existing text, whereas, 
pressing S only the selected text: 

Select Objects: Select the text you want to edit. 

New style (or?): Specify the new character style. 

Capital-Lower case (TCASE)  

The above command is useful for converting lowercase characters to uppercase and 

vice versa. More specifically, the prompts are: 

Select entities: Select the text you want to edit. 

Convert Text: <Upper (U) or Lower (L)>?: Pressing U (Upper) will convert the text to 

Uppercase, whereas pressing L (Lower) to lowercase. 

Change Height (Τheight) 

The above command is used to modify the height of the text, in the case you want to. 
As soon as you select it, you are prompted to: 

Select entities: Select the text you want to edit. 

Enter new text height in Printing mm: Specify the new character height in drawing 
units. 

Stretch (TSTRETCH) 

The above command is used to stretch or shrink text. As soon as you select it, the 

command prompts are: 

Select text to stretch: Select the text you want to stretch. 

Select Side to stretch <Left or Right>?: Select the side towards which you want to 
stretch the text. 

Justify (TJUSTIFY) 

The above command is useful in aligning text. As soon as you select it, you are 
prompted to: 

Select objects: Select the text you want to edit. 
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New Justification Left/Right/Center/Middle: Specify the new alignment. 

Add (TAPPPEND) 

The above command is used to extend a word towards the left or the right side (prefix 

or ending). As soon as you select this command, select the desired word, answer the 
question “left or right” and write the additional desired text, in which case you can 

view the result of your actions. 

Replace (TREPLACE)  

This command is useful for replacing a piece of text with another one in a drawing. 
The execution of the command is simple: first, specify the word you want to replace 

and next, type the new word. 

Search-Replace (TSEARCH) 

This command is useful in replacing a piece of text with another one in a drawing. If 

the text to be replaced is located in more than one places in the drawing, that is, it is 
repeated, it will be replaced in each one of them. The execution of the command is 

simple: first, specify the word you want to replace and next, type the new word. 

Explode Attributes to Text 

This command is useful in exploding a block into the parts it consists of and at the 
same time converts its attributes into text. 

Convert Attibutes to Text 

This command is useful to convert an attribute directly into text. 

Orthogonal (Boxtxt) 

This command is used to place a word or a piece of text inside a box (orthogonal 
frame). The only required action is to select the desired word and then press <Enter> 

(or the right mouse button), in which case you can view, on your screen, the selected 
word being enclosed by a frame. 

Circular (Cirtxt) 

This command is used to place a word or a piece of text inside a circle. The only 

required action is to select the desired word and then press <Enter> (or the right mouse 
button), in which case you can view, on your screen, the selected word being enclosed 

by a circle. 

Elliptical (Eliptxt) 

This command is used to place a word or a piece of text inside an ellipse (elliptical 
frame). The only required action is to select the desired word and then press <Enter> 

(or the right mouse button), in which case you can view, on your screen, the selected 
word being enclosed by an ellipse. 

Polygonal (Polgtxt) 

This command is used to place a word or a piece of text inside a polygon  (polygonal 
frame). The only required action is to select the desired word and then press <Enter> 

(or the right mouse button), in which case you can view, on your screen, the selected 
word being enclosed by a polygon. 

Adding notes and lines 

The Lines menu of options includes tools for drawing different types of line, as the 
ones that appear in the adjacent figure (continuous, dashed, dash-dotted etc.), as well 

as tools for manipulating lines. These tools are described in the order they appear in 
the menu. 
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Continuous 

This command is used to draw a continuous line on the current layer. As soon as you 
select the command, you can start drawing the line using the mouse. 

Dotten (Hidden) 

This command is used to draw a discontinuous line on the current layer. As soon as 
you select the command, you can start drawing the line using the mouse. 

Dashed 

This command is used to draw a dashed discontinuous line on the current layer. As 

soon as you select the command, you can start drawing the line using the mouse. 

Dash-Dotted (Dashdot)  

This command is used to draw a dash-dotted line on the current layer. As soon as you 
select the command, you can start drawing the line using the mouse. 

Dash-Double-Dotted (Divide) 

This command is used to draw an dash-double-dotted line on the current layer. As 
soon as you select the command, you can start drawing the line using the mouse. 

Dash-Triple-Dotted (3Dot) 

This command is used to draw an dash-triple-dotted line on the current layer. As soon 

as you select the command, you can start drawing the line using the mouse. 

Dash-Spaced (Center) 

This command is used to draw a dash-spaced line on the current layer. As soon as you 
select the command, you can start drawing the line using the mouse. 

Double 

This command is used to draw an double line on the current layer. As soon as you 
select the command, you can start drawing the line using the mouse. 

Change Width 

This command is used to modify the width of an existing line. More specifically, the 

command prompts are: 

Select objects: Select the lines, the width of which you want to modify. 

New width for selected objects: Specify the new width in drawing units (drawing 

units). 
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Multiple Trim/Extend 

The above command performs a multiple TRIM or EXTEND. More specifically, the 
series of command prompts is: 

Do you want to Trim or Extend <T or E>: Specify the new width in drawing units 
(drawing units). 

Select cutting edges: Select the edges you want to cut. 

Select objects: Select the desired lines. 

First Point: specifies the first point of a line intersecting the lines that will be trimmed. 

Second Point: specifies the second point. 

If you specify E (Extend) in the above command, the following prompts will appear: 

Select entities: Select the desired lines. 

First Point: specifies the first point of a line intersecting the lines that will be extended. 

Second Point: specifies the second point. 

Clear 

This command clears the drawing from multiple lines (one lying exactly upon the 
other). 

Working with blocks and layers 

The Layers menu of options includes tools for manipulating layers. These tools are 
described in the order they appear in the menu. 

Set Layer by Entity 

This command enables you to set the current layer by simply selecting an object 

which belongs to that layer. The command prompt is: 

Select an entity to set the current layer: Select an object that is part of the layer that 
you want to switch to. 

Layer Match 

This command enables you to match the layer of an entity with the layer of another 
entity. 

The command prompts are: 

FILter/<Select entities>: Select the entity to change its layer 

Select entity on destination layer: Select the entity to match its layer with the selected 
entities in the first step 

Change to Current Layer 

This command enables you change the layer of the selected entity into the current 
one. 

The command prompt is: 

Select entities to be changed to the current layer "phaseone": Select the entities you 
wish to be changed to the current layer 

Layer Isolate 

This command specifies the layer of a selected object to be the current one, while 
freezing all the other layers. The command prompt is: 

FILter/<Select entities>:: Select an object of the layer that you want to become the 
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current one 

Layer Unisolate 

This command restores the layers that have been frozen. 

Layers Off 

The above command deactivates the layer of the object you select. If this layer is the 
current layer, a message appears, stating that it is not possible to freeze this layer. The 
LAYOFF command does not deactivate any blocks that are contained in blocks of the 

layer in question. Consider, for example, the top view of a building that has been 
drawn with AutoBUILD, in which case the windows are blocks inside the “wall” 

block. If you use the LAYOFF command to deactivate the layer of the walls, the 
windows will still be active, whereas if you used the LAYFRZ command (that is 

described below) both walls and windows would “freeze". 

Turn All Layers On 

This command activates all the layers in the drawing. 

Layer Freeze 

This command freezes the layer of the object you select. If this layer is the current 

layer, a message appears, stating that it is not possible to freeze this layer. 

Thaw All Layers 

This command activates all the layers in the drawing that have been frozen. 

Layer Lock  

This command locks the layer of the object you select. This command can 
additionally be used on the current layer. 

Layer Unlock 

This command is the opposite of the command above, meaning that, it unlocks a 
layer that was previously locked using the Layer Lock command. 

Layer Delete 

This command deletes all the objects that exist in a layer that you will select by 
selecting an object belonging to that layer. That is, after you activate this command, 
you should simply select an object which belongs to the layer that you want to delete. 

All the objects of the layer are deleted. 

LAYER Info 

Using this command, which is entirely auxiliary, you can view the layer of the object 
you select. 

Change 

This command enables you to change the layer of existing objects to another one. Its 
function is simple: Select the objects, the layer of which you want to change. After 

you select them, you press <Enter> (or the right mouse button), in which case you 
should next select an object of the layer that you want the previously selected objects 

to be moved to. 

Change Color 

This command changes the colour of a layer. Initially, you are asked to select the 
object, the colour of which you want to change, in which case you use the mouse to 

select it. Next, you are asked to specify the serial number of the new colour. 

Replace 
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Using the above command, blocks can be replaced by some other block (replace). 

The command prompts are: 

Select objects: Select the blocks you want to replace. 

Enter the name of new block: Specify the name of the block that will replace the 

previously selected blocks. 

Block Replace 

Using the above command, blocks can be replaced by some other block with the help 
of a list of all the blocks of the drawings. In the dialog box that is activated you can 

select from the list the block to be replace and the block to replace or you can press 
the button “Select < -“ to define the blocks in the drawings. 

 

Xplode 

The above command explodes the blocks of 4MCAD (and the mirrored blocks of 
4MCAD). 

Count 

This command can count the number of times a block has been inserted into the 
drawing. The command prompts are: 

Enter the name of the block that will be count: Specify the name of the block to count 

the number of times it has been inserted. 

Block Count 

This command can count the number of times a block has been inserted into the 
drawing. The command prompts is to select entities (you can select the whole 

drawing) and then a list of the blocks and their count appear in the command line. 

View (Show) 

Using the above command, you can view the positions that a block has been inserted 
into, while deactivating the rest of the objects of the drawing. The command prompts 

are: 

Enter the name of the block : Specify the name of the block you want to view. 
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Customizing 4MCAD 
 

You can customize 4MCAD in a number of ways. For example, you can change 

the appearance of many aspects of the program and modify the existing menus and 

toolbars or create new ones. This section explains how to: 

• Set the program’s preferences. 

• Customize the user interface, including tool palettes, menus, toolbars. 

• Customize the keyboard. 

• Create aliases for frequently used commands. 

• Customize entities. 

• Create and use scripts. 

• Use add-on programs with 4MCAD. 

• Use a digitizer tablet for menu selection and calibrated drawing. 

 

 
 

 

 

 

 

17 
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Setting and changing options 
 

You can change many of the options that control the program’s behavior and appear- 

ance, such as setting the experience level, specifying file paths and default files, con- 

figuring display features, and configuring how certain features work. 

 

Changing the options on the General tab 
In the Options dialog box, the General tab contains settings for experience level and 

save options. You can also set VBA security. 

 

 

A Click to enable AutoSave feature. 

B Select the default file format that displays when 
saving drawings using the Save As dialog box. 

C Select to check all drawings for errors when 
using the Open command, and attempt recovery, 
as needed. 

D Select to hide warning messages when opening 
drawings, if the check box Open Drawings using 
Recover is marked. 

E Displays the name of the current profile selected 
on the Profiles tab. 

F Click to turn off error reporting when a crash 
issue is encountered while running 4MCAD. 

G Click to disable VBA CommonProject macros on 
startup. (Available if supported by your version of 
4MCAD.) 

H Click to select which filetypes are associated 
with 4MCAD. 

I Click to send a complete report of crash data. 
(Available if error reporting is turned on.) 

J Type the file extension for AutoSaved files. 

K Enter frequency of AutoSave in minutes. 

L Select the experience level. 

L 

A K 

J 

B 

 
C 
D 

E 

F I 

G 

H 
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Setting the experience level 
You can control which menus and tools are available by setting the experience level. 

You can choose from the following experience levels: 

• Beginner Menus and toolbars display only basic commands. 

• Intermediate Menus and toolbars display most two-dimensional entity creation 

and modification commands. 

• Advanced Menus and toolbars display all available commands. 
 

To set the experience level 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the General tab. 

3 Under Experience level, select Beginner, Intermediate, or Advanced. 

4 When you have finished, click OK. 

 
Saving your drawings automatically 
To avoid losing data in the event of a power failure or other system error, save your 

drawing files often. You can configure the program to periodically save your draw- 

ings automatically. The Minutes setting determines the interval between automatic 

saves. The program restarts this interval timer whenever you save the drawing file. 

When AutoSave is enabled, the program creates a copy of your drawing. The file is 

saved in the folder specified in Options > Paths/Files for Temporary Files, with the 

file extension specified in the AutoSave Drawing Extension box (by default, .SV$). 
 

To set how drawings are saved automatically 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the General tab. 

3 Under AutoSave, select the check box to enable the AutoSave feature, and select 

the frequency. 

If you want to change the default extension assigned to your AutoSave files, type 

the new extension in AutoSave Drawing Extension. 

4 When you have finished, click OK. 
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Setting the default Save As format 
You can control the default file format that you want to display in the Save Drawing 

As dialog box. For example, if you use the Save As command to save most of your 

drawings in a legacy file format, you can select that file format as the default so you 

don’t have to select it each time you save a drawing using the Save As command. 

This setting has no effect on saving existing or new drawings using commands other 

than Save As — 4MCAD always saves existing drawings in their current file for- 

mat and saves new drawings with the most current file format. 
 

To set the default Save As format 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the General tab. 

3 Under Save As, select the default drawing format that displays when using the 

Save As command. You can always specify a different format in the Save Draw- 

ing As dialog box. 

4 When you have finished, click OK. 

 
Setting how drawings are opened 
There are several options that determine how drawings are opened in 4MCAD. You 

can specify which file extensions are associated with 4MCAD, allowing you to 

open files such as .dwg files automatically using 4MCAD. 

Additionally, you can set up 4MCAD to open drawings automatically using the 

Recover command, for example, if you are a new 4MCAD user and your original 

drawings were created using different CAD software and those drawings regularly 

contain errors or damaged data. The Open Drawings using Recover option automati- 

cally checks all drawings for errors when using the Open command, and attempts 

recovery, as needed. Viewing warning messages when opening drawings allows you 

to know which files are being fixed by 4MCAD and what errors have occurred; 

however, you can also choose to hide the warnings. 
 

To set how drawings are opened 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the General tab. 
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3 To specify the file types that open automatically using 4MCAD, click Set Files 

Association and make your selections. 

4 If you want to use the Recover command automatically each time you use the 

Open command, mark the check box for Open Drawings using Recover. 

5 If you want to hide warnings when errors are found in a drawing, mark the check 

box for Hide Warnings when Opening Drawings using Recover. Errors will still 

be logged in an ASCII file with an .adt extension. 

6 When you have finished, click OK. 

 
Setting error reporting options 
Error reporting occurs when 4MCAD encounters a crash issue. You can specify 

whether error reporting occurs and whether a full report is generated. It is recom- 

mended to generate the full report only if requested for troubleshooting purposes. The 

completed report of crash data can be up to 100MB in size, and while it contains help- 

ful information for troubleshooting issues, is more likely to fail during transmission 

due to its file size. 
 

To change the options on the General tab 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the General tab. 

3 If you want to turn off error reporting, mark the check box for Disable Error 

Reporting. 

4 If you want to generate a full report when error reporting is turned on, mark the 

check box for Generate Full Report. 

5 When you have finished, click OK. 

 
Disabling VBA CommonProject macros 
Each time you start 4MCAD, macros are automatically loaded for the Visual Basic 

Application (VBA) CommonProject. If you do not plan to use VBA, disabling the 

macros may improve performance. In addition, disabling the macros can enhance 

security if you are running 4MCAD at a low security level. 
 

To change the options on the General tab 

1   Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 
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2 Click the General tab. 

3 If you do not want the CommonProject macros to be loaded when you start 

4MCAD, under VBA Security, click the check box for Disable VBA 

CommonProject Macros On Startup. 

4 When you have finished, click OK. 

 

Changing the options on the Paths/Files tab 
You can specify locations for various file types such as those used for drawings, 

fonts, and menus in the Options dialog box on the Paths/Files tab. You can even 

specify multiple paths for the same file type. In addition, you can change the names 

of the default system files that are used for functions such as font mapping and error 

logging. 

 
Specifying the user paths 
You can enter paths to your 4MCAD directories by selecting them in the Options 

dialog box. This feature includes directories for drawings, fonts, help, external refer- 

ences, menus, tool palettes, hatch patterns, blocks, print style tables, print output files, 

temporary files, templates, and color books. 4MCAD searches directories for sup- 

port files in the following order: 

• The 4MCAD program directory. 

• The current drawing directory. 

• The Windows search path. 

• The search path specified in the Options dialog box. 

 
 

You can enter multiple paths for each item. 

If, for example, the Drawings item has more than one directory associated with it, 

click Add to specify additional paths. You can also separate multiple paths with a 

semicolon if typing them. 4MCAD searches the directories in the order in which they 

are listed. 
 

 

 
To specify a user path 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Paths/Files tab. 
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3 In the upper half of the dialog box, do one of the following: 

• Right-click and choose from the shortcut menu of options. 

• Click a category to view its search paths, then single-click the path you want to 

modify, and type the path. 

If you do not know the path or directory name, click Browse, and then browse to 

the location of the directory you want. 

4 When you have finished, click OK. 

 
Changing the default system files 
You can change the default system files, including the log file, default template, alter- 

nate font, and font mapping file. 
 

To change a default system file 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Paths/Files tab. 

3 In the lower half of the dialog box, under Program Files, do one of the following: 

• Right-click and choose from the shortcut menu of options. 

• Click the file name for the default system file you want to change, and type a 

new file name. 

If you don’t know the file name, click Browse, and then browse to the location of 

the file you want. 

4 When you have finished, click OK. 
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A Click to view default paths. Click or press the F2 
key to modify a selected path. Double-click a 
path to open the path in Windows Explorer. 

B Click or press the Insert key to add a new path 
for the current category. 

C Click or press the Delete key to remove the 
selected path. 

D Select the default file to change. 

E Click to locate and specify a new default file. 

F Click to move the selected path up one position 
in search order. 

G Click to move the selected path down one 
position in search order. 

H Click to remove custom paths and use the 
default paths for the selected category. 

I Click to locate and specify a new path. 
 

Changing the options on the Display tab 

In the Options dialog box, the Display tab contains settings for displaying the 

command bar, 4MCAD window, menus, mouse actions, and program language. 

A 

B 
C 

I 
H 
G 
F 

D 

E 
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A Type or select the maximum number of 
command lines to track. 

B Select to use Up and Down arrows for scrolling 
the command history instead of panning. 

C Select to suggest command names 
automatically when typing in the command bar. 

D Select to show or hide paper sheet in paper 
space on Layout tabs. 

E Select to zoom out when spinning the mouse 
wheel forward and zoom in when spinning the 
mouse wheel backward. 

F Click to show or hide the Model and Layout tabs. 

G Click to show or hide scroll bars. 

H Turn off hardware acceleration if you notice 
problems during rendering. 

I Click to show or hide prompt boxes. 

J Click to show or hide grip menus. 

K Displays the language used to show options 
throughout the program. Click Set Language to 
select language settings. 

L Select to display the drive and folder location of 
the drawing in the drawing title bar in addition to 
the filename. 

M Click to activate any messages that were 
previously set to not display again. 

N Click to specify options for tabs that can display 
for each drawing in the main window. 

O Select the look you want for all 4MCAD 
windows. 

P Type or select the percentage of transparency to 
apply to prompt boxes when they display. 

Q Type or select the number of recently used 
drawings to list on the File menu. 

R Click to set the fading percentage for external 
references, entities on locked layers and in-place 
reference editing 

S Click to select the action to take when you right- 
click the mouse. 

T Click to assign colors to various parts of the 
drawing window. 

U Click to determine how the pointer displays. 

V Click to determine how command names are 
suggested when typing in the command bar. 

W Enter a font size for the command bar. 
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Setting how the command bar works 
The command bar is a dockable window in which you type 4MCAD commands and 

view prompts and other program messages. To display the command bar, choose 

View > Display > Command Bar. To customize how the command bar works, change 

the options on the Display tab. 
 

To set how the command bar works 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Display tab. 

3 In Command Lines to Track, enter the desired number of previous command and 

command prompts that are tracked in the command bar. The default value is 256. 

You can also display the commands in the Prompt History window by pressing 

F2. To close the window, press F2 again. 

4 In Font Size, enter the desired font size. The default is 16. 

5 Mark the Use Up/Down Arrows for Command History Navigation check box if 

you want to scroll the command history text when using the Up and Down arrows 

on the keyboard. This can be a convenient way to review and even repeat previous 

commands. If unchecked, using the keyboard arrows pans your view of the draw- 

ing. 
 

 

Use alternate keyboard shortcuts. 

For panning, you can use Alt+arrow keys. For scrolling the command history, you 

can use Ctrl+K and Ctrl+L. 
 

 

 

6 Mark the Enable AutoComplete check box to use the AutoComplete feature when 

typing commands in the command bar. For more details about AutoComplete, see 

“Customizing how suggestions display in the command bar” on page 685 in this 

chapter. 

7 When you have finished, click OK. 
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Customizing how suggestions display in the command bar 
When you type in the command bar, 4MCAD suggests names of matching com- 

mands as you type. The suggested names appear in an AutoComplete window that 

automatically opens when you type and closes when you activate a command. 

Using AutoComplete is an efficient way to select commands, and it is also a conve- 

nient way to view a list of related commands. For example, if you type "LA" in the 

command bar to work with layers, all layer-related commands that begin with "LA" 

display in the AutoComplete window. 

In addition to command names, suggestions can include names of external com- 

mands, system variables, aliases, and LISP functions. Each name displays with a col- 

ored icon that indicates its type: 

• Red — 4MCAD command 

• Green — External command 

• Yellow — System variable 

• Blue — LISP function 

To customize how suggestions display in the command bar 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Display tab. 

3 Mark the Enable AutoComplete check box to turn on automatic suggestions of 

names as you type in the command bar. 

4 Click AutoComplete Options. 
 

 

Use a shortcut. 

Type INPUTSEARCHOPTIONS and then press enter to access autocomplete 

options directly from the command bar. 
 

 

 

5 In AutoComplete Timeout, enter the number of milliseconds to wait between key- 

strokes before displaying the AutoComplete window. The higher the number, the 

longer the delay allowed between keystrokes (the AutoComplete window displays 

less frequently). 
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Fast typists usually increase the timeout setting. 

If the AutoComplete window often conflicts with your typing in the command bar, 

try setting the number of milliseconds to 1,000 or more. 
 

 

 

6 In Minimum Length of Text, enter the number of letters to be typed in the com- 

mand bar before displaying the AutoComplete window. 

7 In Transparency, enter the percentage of transparency, between 0 and 50, in which 

to display the AutoComplete window. The higher the number, the more transpar- 

ent the window is. Enter zero for an opaque window. 

8 Determine how selection works: 

• Mark Use Recent Commands to search for and automatically select a recently 

used command, when possible. 

• Mark Show Suggestions in Command Line to pre-fill the command line with the 

name as you scroll the list. If turned off, the name does not pre-fill in the 

command line, however, you can still select the desired name in the AutoCom- 

plete window by clicking it or pressing CTRL + Enter. 

• Mark Cycle Selection if you want to allow Arrow key scrolling from the end to 

beginning (and vice versa) in the list. 

• Mark Mouse-Over Selection to allow selection by hovering the mouse, and not 

clicking it, over the desired name. 

9 Mark Show Command Icons to display icons, if available, for each command in 

the list. 

10 Mark Use Command Line Colors to display the AutoComplete window using the 

same background and text colors that are selected for the command bar. For more 

details about selecting command bar colors, see “Setting colors of the main win- 

dow” on page 690 in this chapter. 

11 Mark which items to include in the list of suggested names: aliases, external com- 

mands, system variables, and/or LISP functions. If selected, LISP functions dis- 

play when you enter a parenthesis, “(“, when first typing. 

12 Click OK. 

13 Click OK. 
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A Enter the number of milliseconds to wait 
between keystrokes before displaying the 
AutoComplete window. 

B Enter the minimum number of letters to be typed 
before displaying the AutoComplete window. 

C Enter the percentage of transparency in which to 
display the AutoComplete window. 

D Click to search for and automatically select a 
recently used command. 

E Click to pre-fill the command line with the full 
name as you scroll the list. 

F Click to allow Arrow key scrolling from the end of 
the list to the beginning (and vice versa). 

G Click to allow selection by hovering the mouse 
over a desired name. 

H Click to show or hide icons for commands. 

I Click to use the same colors in the 
AutoComplete window as specified for the 
command bar. 

J Click to include LISP function names. 

K Click to include system variable names. 

L Click to include external command names. 

M Click to include alias names. 
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Setting the main window options 
The main 4MCAD window can be customized in many ways to best accommodate 

your work style. For example, hiding window elements if you do not use them can 

help increase drawing space in the 4MCAD window. 
 

To set the main window options 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Display tab. 

3 Mark the Show Paper Sheet in Paper Space checkbox if you want to display a 

bounded sheet of paper for Layout tabs. When unmarked, the paper sheet does not 

display. 

4 Mark the Show Tabs checkbox if you want to display the Model tab and Layout 

tabs in the main window. When unmarked, the tabs do not display, which can be 

helpful if you only work on the Model tab or if you use the command bar and sta- 

tus bar to switch between tabs. 

5 Mark the Show Scroll Bars checkbox if you want to display the scroll bars on the 

right side and bottom of the 4MCAD window or viewport. When unmarked, the 
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scroll bars do not display, which can improve performance and can also be helpful 

if you only use the Pan command to scroll drawings. 

6 Unmark the Hardware Acceleration check box if you experience performance 

problems or issues during rendering. By default, Hardware Acceleration is turned 

on, but infrequently it can complicate performance and rendering. 

7 Click Cursor Options to determine how the pointer displays: 

• Pointer Defaults to Crosshairs Click this check box to always display the 

pointer as the crosshairs (instead of the default arrow cursor with a selection 

pick box). Note that if this check box is not selected, all subsequent options are 

unavailable. 

• Crosshairs Size Enter a number for the percentage of the screen to be used by 

the crosshairs cursor, or use the up and down arrows to scroll to the number. 

Note that depending on your graphics device, a large percentage can negatively 

affect display performance. 

• Gun Sight Crosshairs Click this check box to display the pointer as the gun sight 

crosshairs instead of the regular crosshairs. You can also control this option by 

clicking Toggle Gun Sight Crosshairs On/Off in the status bar. 

• Crosshairs Use XOR Invert Colors Click this check box to turn on use of a 

logical XOR for the cursor color. Mark the Pointer Defaults to Crosshairs 

checkbox if you want to use crosshairs as the default pointer shape (instead of 

an arrow cursor with a selection pick box). You can also control this option by 

clicking Toggle XOR Cursor On/Off in the status bar. 

8 Click Fade Control to determine the fading percentage for entities and files: 

• Xref Display Enter a value or move the slider to specify the fade percentage 

applied to .dwg file external references. 

• Entities on Locked Layers Enter a value or move the slider to specify the fade 

percentage applied to entities that are located on locked layers. 

• In-place Edit and Annotation Representations Enter a value or move the slider 

to specify the fade percentage applied when editing an external reference in 

place. Fading is applied to the entities of the external reference that are not 

currently being edited. 

9 When you have finished, click OK. 
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Setting colors of the main window 
You can control the color of many aspects of the main drawing window, such as 

background color, crosshairs color, and more. 
 

To set colors of the main drawing window 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Display tab. 

3 Click Color Scheme. 

4 In Context, select the area that contains items for which you want to specify col- 

ors. 

5 In Items, select the item for which you want to specify a color. 

6 In Colors, select a color or choose Select Color for more options. 

7 Click On/Off to show or hide the item (available only if the selected item can be 

turned off). 

8 When you have finished, click Apply & Close. 
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A Select an area of the drawing window. 

B Select an item for which to change color. 

C Displays an example of the current color 
selections. 

D Click to save the current color settings in a color 
scheme file. 

E Click to select a color scheme file and load it. 

F Click to restore color defaults for all contexts and 
items. 

G Click to restore color defaults for the currently 
selected context. 

H Click to restore the color default for the currently 
selected item. 

I Click to show or hide the selected item (available 
only if the item can be turned off). 

J Select a color for the currently selected item. 
Choose Select Color for more color options. 
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To save and open color schemes 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Display tab. 

3 Click Color Scheme. 

4 Make any adjustments before you save the settings. 

5 Click Save to save the current color selections as a color scheme file. 

6 Click Load to select a color scheme (.xml or .clr file) and load it. 

7 Click Apply & Close. 
 

 

Color schemes are an easy way to reuse favorite color settings. 

If you work on more than one computer, save a color scheme to a file and load the file 

on another computer. 
 

 

 
To restore colors to their defaults 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Display tab. 

3 Click Color Scheme. 

4 Do one of the following: 

• Reset a single item — Select the item you want to revert to the default color, 

then click Current Item. 

• Reset all items in a context — Select the context, then click Current Context. 

All items in the current context will be reverted to their default colors. 

• Reset all colors — Click All Colors. All items in all context will be reverted to 

their default colors. 

5 Click Apply & Close. 

 
Setting mouse options 
Mouse actions can be customized to best accommodate your work style. For exam- 

ple, you may prefer to repeat a recent command when right-clicking the mouse if you 

do not use shortcut menus. 
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To set the mouse options 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Display tab. 

3 Mark the Reverse Mouse Wheel Zoom Direction check box if you want to reverse 

the zoom direction of the mouse wheel, that is, spin the wheel forward to zoom out 

and spin it backward to zoom in, This can be especially helpful if you use the 

mouse with your left hand. When unmarked (the default), you spin the mouse 

wheel forward to zoom in and spin it backward to zoom out. 

4 To set the action to take when you right-click the mouse in a drawing, click Right- 

Click Action and choose from the following options: 

• No Selection — To repeat the previously used command if you right-click when 

entities are not selected, choose Repeat Last Command. To display a shortcut 

menu if you right-click when entities are not selected, select Show Shortcut 

Menu. 

• Entities Are Selected — To repeat the previously used command if you right- 

click when entities are selected, choose Repeat Last Command. To display a 

shortcut menu that displays options specific to the selected entities if you right- 

click, select Show Shortcut Menu. You can right-click anywhere in the drawing 

with entities selected and the shortcut menu for the selected entities will display. 

5 When you have finished, click OK. 

 
Setting how menus display 
The display of menus can be customized, including whether prompt menus and right- 

click shortcut menus display, whether menus load automatically, and the number of 

drawing files that display on the File menu. 
 

To set how menus display 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Display tab. 

3 Mark the Display Prompt Boxes check box if you want to show prompt boxes, 

which display the same options for commands that display on the status bar and 
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the command bar. Turning prompt boxes off may save screen space and may min- 

imize mouse clicks. 

4 Mark the Display Grip Menus check box if you want grip menus to display when 

the mouse pauses over a grip that has an associated menu. For example, polyline 

grips have a menu. 

5 In Recent Drawing List Size, enter how many recently opened drawings are listed 

on the File menu. 

6 When you have finished, click OK. 

 
Setting user interface options 
User interface options include how the title bar displays file names, themes that affect 

how 4MCAD windows look, and the language used to show options throughout 

4MCAD. 

The list of available languages depends on which languages were installed on your 

computer. If the desired language doesn't appear in the list, repair or re-install the 

application with customized settings for the desired language. 
 

To set the user interface options 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Display tab. 

3 Click Set Language and in Language Selection Method, choose one of the follow- 

ing options: 

• Manual selection — Uses the language selected in the Installed Languages list. 

• Automatically match regional settings — Matches the language set for the 

geographical region 

• Automatically match system locale — Matches the language set for the 

operating system. 

4 Click OK. 

5 Mark the Show Full Drawing Path in Title Bar check box if you want to display 

the drive and folder location of the drawing in the drawing title bar in addition to 
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the filename. When unmarked (the default), only the filename displays in the 

drawing title bar. 

6 In Theme, select the look you want for all 4MCAD windows. 

7 Click MDI Options and select options for displaying drawings on tabs in the main 

window: 

• Enable MDI Tabs — Select to display each drawing as its own tab in the 

4MCAD window. If turned off, drawings display as separate windows. 

• Tab Style — Select a style in which to display the tabs. 

• Tab Close Button — Select to display an [X] for a Close button on the active 

tab. If turned off, Close buttons do not display on drawing tabs. 

• Show Icons — Select to display an icon on each tab that indicates the type of 

drawing file. If turned off, icons do not display on the drawing tabs. 

• Auto Color — Select to display each tab with its own color. If turned off, tabs 

are not colored. 

• Document Menu — Select to display a menu that contains a list of open files. 

The menu displays when you click (  ) on the right side of the tabs area. If 

turned off, the menu is not available. 

• Top Location — Select to position the tabs at the top of drawings. If turned off, 

tabs are positioned at the bottom of drawings. 

8 Click OK. 

9 When you have finished, click OK. 
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A Displays the language set for the geographical 
region. 

B Displays the language set for the operating 
system. 

C Select to choose the desired language from the 
list of installed languages. 

D Select to automatically match the language set 
for the geographical region. 

E Select to automatically match the language set 
for the operating system. 

F Displays a list of languages installed for 
4MCAD. Click the desired language in the list; 
available only if the manual selection method is 
chosen. 

G Click to open the operating system's dialog box 
for setting language options. 
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Customizing display options for high resolution monitors or for switching 
between monitors 
4MCAD is designed to run at the proper size on a variety of monitors with differ- 

ent display resolutions. However, if you switch between monitors that have different 

resolutions, or if you’re using a monitor with 4K or higher resolution, you might need 

to set some options manually. 

These custom options are system variables available at the command prompt, not in 

the Options dialog box. 
 

To set display options for 4K monitors or for switching between monitors 

1   Type any of the following system variable names and change their settings: 

• 3DORBITCTRSPHERESIZE — Controls the size of the small orbit sphere that 

displays at the rotation point when using the Constrained Orbit (3DORBIT), 

Continuous Orbit (3DCORBIT), and Free Orbit (3DFORBIT) commands. Enter 

a number from 1 to 20. 

• APERTURE — Controls the entity snap selection area in pixels. Enter a number 

from 1 to 10. 

• BLIPSIZE — Controls the blip marker size in pixels. A blip is the plus sign (+) 

that appears temporarily when you specify a point on the screen. Enter a number 

from 1 to 255. 

• GRIPSIZE — Controls the size of the box (in pixels) used to display grips. Enter 

a number from 1 to 255. 

• PDSIZE — Controls the point display size. The default value (0) specifies a point 

size 5% of the screen size. A value greater than 0 specifies the absolute size, and 

a value less than 0 specifies a percentage size. 

• PICKBOX — Controls the target height for entity selection in pixels. Enter a 

number from 0 to 50. 

• SNAPSIZE — Controls the entity snap marker size in pixels. An entity snap 

marker is a temporary glyph that appears when using entity snapping and 

indicates the current snap location. Enter a number from 1 to 20. 
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Changing the options on the Profiles tab 
4MCAD allows you to customize the settings that control your drawing environ- 

ment, and then save and restore those settings in a profile. For example, if you prefer 

working with custom menus and toolbars, you can save these settings as your own 

profile. 

Profiles can be helpful if you have multiple users with different preferences, or if you 

are a single user who works on various projects that require unique settings. You can 

even export your profile and bring it with you when you work on a different com- 

puter. 

 
Understanding the settings saved in profiles 
Profiles save many settings that control the drawing environment. Once you start 

using a profile, it automatically tracks and stores changes that you make to your 

drawing environment. 

Some settings are saved immediately, but some require that you exit 4MCAD and 

then start 4MCAD again. This is because profiles save settings from your com- 

puter’s registry and some settings are only saved to the registry when you exit 

4MCAD. 

 
Settings saved in profiles 

 

 
Toolbar settings Tools > Customize, Toolbars tab Exit and restart of 4MCAD 

Menu settings Tools > Customize, Menus tab Immediately 

Keyboard settings Tools > Customize, Keyboard tab  Immediately 

Alias settings Tools > Customize, Aliases tab Immediately 

Window elements on/off 
status and their various 
settings 

View > Display > Command Bar 
View > Display > Model and 
Layout Tabs 
View > Display > Prompt History 
Window 
View > Display > Scroll Bars 
View > Status Bar 

Exit and restart of 4MCAD 

Tablet configurations Tools > Tablet Immediately 

User paths Tools > Options, Paths/Files tab Immediately 

System variables Typed in command bar Varies — some saved immediately 
and some upon exit and restart of 
4MCAD 

 
 

Setting Location When saved 
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Creating profiles 
Create profiles if you want to save your custom drawing environment settings. This 

can be helpful if you have two or more drawing environments that you use regularly. 

When you create a new profile, the current drawing environment settings are auto- 

matically saved with the new profile. 
 

To create a profile 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Profiles tab. 

3 Click Create. 

4 Enter a name, a description (optional), and then click OK. 

5 In the Options dialog box, click OK. 

6 Make changes to your drawing environment. 

4MCAD automatically saves the settings to the new profile. 
 

 

Some cases require you to exit and restart 4MCAD before settings are saved with the 

profile. 

This is because profiles save settings from your computer’s registry and some set- 

tings, such as toolbar settings, are only saved to the registry when you exit 4MCAD. 
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A Displays the name of the currently loaded profile. 

B Select a profile to load it or modify it. 

C Displays a description of the profile. 

D Click to restore the selected profile to the system 
default settings. 

E Click to open a profile stored in an .arg file. 

F Click to save the selected profile in an .arg file. 

G Click to delete the selected profile. 

H Click to rename the selected profile. 

I Click to make a copy of the selected profile. 

J Click to load the selected profile and make it the 
active profile. 

K Click to create a new profile. 

K 

A 

 
B 

J 

I 

H 

G 

F 

E 

D 

C 



C U S T O M I Z I N G   4M C A D 701  
 

 

Loading a profile 
While you work in 4MCAD, you can load the custom settings of any 

profile. The current profile when you exit 4MCAD is automatically 

loaded when you start 4MCAD again. 
 

To load a profile 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, 

or choose Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Profiles tab. 

3 Select the desired profile. 

4 Click Set Current. 
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Restoring the default settings 
At any time you can return to the default drawing environment settings that were 

installed with 4MCAD. 

If the Default profile is unchanged, simply load it to restore the default settings. If the 

Default profile is deleted or changed, reset an existing profile (one that you no longer 

need) to replace its contents with the default settings. 
 

To restore default settings using an unchanged Default profile 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Profiles tab. 

3 Select the Default profile. 

4 Click Set Current. 
 

To restore default settings without using the Default profile 
 

 

Resetting a profile erases all of the profile’s custom settings. 

Do this only if you are certain you no longer need the selected profile. 
 

 

 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Profiles tab. 

3 Select a profile that you no longer need; all of it’s custom settings will be erased. 

If necessary, create or copy a profile to use for restoring the default settings. 

4 Click Reset. 
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Managing profiles 
Once you start using profiles, you may need to rename, copy, or delete them. Copy- 

ing a profile is a quick way to create a new profile based on an existing profile. 
 

To rename a profile 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Profiles tab. 

3 Select the profile you want to rename. 

4 Click Rename. 

5 Make any necessary changes to the name or description, and then click OK. 
 

To copy a profile 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Profiles tab. 

3 Select the profile you want to copy. 

4 Click Copy. 

5 Enter a new name, a description (optional), and then click OK. 
 

To delete a profile 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Profiles tab. 

3 Select the profile you want to delete. 

4 Click Delete. 
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Working with profiles on multiple computers 
If you use multiple computers and you like to work with our own drawing environ- 

ment settings, save time by bringing your profile with you. 

On your computer, export your profile to an .arg file. Bring the file with you to the 

other computer using a disk, E-mail, network, or some other method. When you start 

working at another computer, simply open and load your profile instead of recreating 

your preferred drawing environment. 
 

To export a profile to a file 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Profiles tab. 

3 Select the profile to export. 

4 Click Export. 

5 Specify a location and name for the exported file, and then click Save. 
 

To open a profile from a file 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Profiles tab. 

3 Click Import. 

4 Locate and select the profile (.arg file), and then click Open. 

5 Make any necessary changes to the name or description, and then click OK. 

6 (Optional) To load the imported profile, select it, and then click Set Current. 

 

Changing the options on the Printing tab 
In the Options dialog box, on the Printing tab, you can determine several print set- 

tings, including the default printer, headers, footers, printer configuration files (PC3 

files), and print styles that change the appearance of your printed drawing without 

modifying the actual entities in your drawing. 
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A Select a default printer to assign to new 
drawings. 

B Click to specify print style table settings for new 
drawings created without a template or legacy 
drawings. 

C Click to specify a header or footer for printed 
drawings. 

D Click to specify settings for printer configuration 
files (PC3 files). 

 

 

Setting the default printer 
A default printer, or output device, is assigned to all new drawings. Select the device 

you use most often when printing drawings. Later, if needed, you can assign a differ- 

ent printer for any existing drawing. 
 

To set the default printer 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options then click the Printing tab or choose 

File > Print Options. 

• Type config, press Enter, then click the Printing tab. 

2 In Default Output Device, select a printer to assign to new drawings. 
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3 When you have finished, click OK. 
 
 

Setting default print styles 
Default print style settings affect only specific drawings: new drawings created with- 

out a template and older drawings when opened (older drawings that were created 

before print styles were available, for example, before AutoCAD 2000). Drawings 

that are currently opened are not affected. 

For more details about print styles and print style tables, see “Using print styles” on 

page 546. 
 

To set default print style settings for new drawings 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options then click the Printing tab or choose 

File > Print Options. 

• Type config, press Enter, then click the Printing tab. 

2 Click Print Style Settings. 

3 Select to use color-dependent or named print style tables for new drawings created 

without a template. 

4 Select a default print style table to use with new drawings. 

5 For named print style tables, select both the print style to assign to layer zero and 

to new entities. For color-dependent tables, the print style is BYCOLOR and is not 

selectable. 

6 Click OK. 

7 When you have finished, click OK. 
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Specifying a header and footer 
You can include information such as a date and time stamp, your name and company 

name, or other information that you want to appear at the top or bottom of drawings 

when you print them. 

Header and footer settings are set globally for all drawings, although they don’t have 

to be included with each drawing you print. When printing, in the Print dialog box 

mark or unmark Print Stamp On accordingly. 
 

To specify a header and footer for all drawings 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options then click the Printing tab or choose 

File > Print Options. 

• Type config, press Enter, then click the Printing tab. 

2 Click Print Stamp Settings. 

3 Type the content for the header and footer, or select an optional automatic field 

from the lists. 

To align text to the left, middle, or right in a header or footer, separate the text 

with commas. 

4 Click Advanced. 

5 Customize settings for any of the following: 

• Orientation Select Horizontal to place the header and footer on the top and 

bottom of the drawing. Select Vertical to rotate the header and footer 90 degrees 

on the left and right of the drawing. 

• X Offset Enter the distance to offset the header and footer from the edge of the 

printable area in the x-direction. 

• Y Offset Enter the distance to offset the header and footer from the edge of the 

printable area in the y-direction. 

• Offset Relative To Select whether to measure the offset from the edge of the 

paper or the printable area. 

• Font Select the font for the header and footer text. 

• Height Select the height for the header and footer text. 

• Units Select Inches or Millimeters as the unit of measure for the print stamp X 

Offset, Y Offset, and Height. 

• Add Print Event into Log File Select to include print stamp information in the 

print log file. 

6 Click OK. 

7 When you have finished, click OK. 
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Setting up printer configuration files 
Printer configuration files (PC3 files) store the printer information you use for spe- 

cific drawings or layouts. You can add, modify, and delete PC3 files. 

For more details about printer configuration files, see “Customizing and reusing print 

settings” on page 532. 
 

To set up printer configuration files 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options then click the Printing tab or choose 

File > Print Options. 

• Type config, press Enter, then click the Printing tab. 

2 Click Add or Configure Printers. 

3 To create a new PC3 file, do the following: 

• Click Add. 

• In the Add Printer Configuration File dialog box, select the desired printer for 

the new PC3 file. 

• Click Continue. 

• Select the options you want for the PC3 file. If you don't select any custom 

options, a PC3 file will not be created. 

• Click OK. 

4 To modify a PC3 file, do the following: 

• Select the desired file in the list. 

• Click Modify. 

• Select the options you want for the PC3 file. 

• Click OK. 

5 To delete a PC3 file, select the desired file in the list and click Delete. 

6 Click OK. 

7 When you have finished, click OK. 
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Changing the options on the Snapping tab 
In the Options dialog box, on the Snapping tab, you can control how entity snaps 

work, including fly-over snapping. Fly-over snapping is a visual aid to help you 

see and use entity snaps more efficiently. 
 

To change the options on the Snapping tab 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Snapping tab. 

3 Select the options you want. 

4 When you have finished, click OK. 
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A Select to display an extra image on the cursor to 

show which entity snap is active. (Available even 
if fly-over snapping is turned off.) 

B Select to turn on fly-over snapping. 

C Select to turn on fly-over snap tooltips, which 
indicate the type of snap that was used to select 
the marked location. 

D Select to turn on the fly-over snap aperture box. 
Entities found within the aperture box are 
available for selection, making it easier to find 
and select entity snap points. 

E Type or scroll to the tolerance size for the fly- 
over snap aperture box. Higher numbers 
increase the distance from the cursor in which 
entities are found. 

F Click to turn on entity snapping to hatches. 

G Click to turn on entity snapping to entities that 
have a negative z value when using a dynamic 
UCS. 

H Select whether there is no snapping to files 
attached to drawings as underlays, snapping is 
turned on for all underlays, or snapping is turned 
on but varies according to the file type. 

I Click to turn on entity snapping to .pdf files that 
are attached to drawings. (Available only if 
snapping to underlays is turned on to VARY.) 

 
J Click to turn on entity snapping to .dwf files that 

are attached to drawings. (Available only if 
snapping to underlays is turned on to VARY.) 

K Click to turn on entity snapping to .dgn files that 
are attached to drawings. (Available only if 
snapping to underlays is turned on to VARY.) 

L Click to turn on entity snapping to .ifc files that 
are attached to drawings. (Available only if 
snapping to underlays is turned on to VARY.) 

M Click to turn on entity snapping to .rvt and .rfa 
files that are attached to drawings. (Available 
only if snapping to underlays is turned on to 
VARY.) 

N Turns on entity snapping to dimension extension 
lines. 

O Type or scroll to the thickness of the fly-over 
snap marker. 

P Type or scroll to the size of the fly-over snap 
marker. 

Q Click to choose the color of the fly-over snap 
marker. 

R Select to turn on the display of fly-over snap 
markers in all views when you are using more 
than one viewport. 

S Select to turn on fly-over snap markers, which 
mark snap points on entities. 



C U S T O M I Z I N G   4M C A D 711  
 

 
Changing the options on the Clipboard tab 
You can control what formats are supported when copying content to the clipboard 

from 4MCAD. 

Copying all supported formats to the clipboard impacts performance—it is best to 

select only the necessary formats. 
 

To change the options on the Clipboard tab 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Clipboard tab. 

3 Select the options you want. 

4 When you have finished, click OK. 
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A Select which DWG format versions to copy to the 
clipboard. 

B Select to copy the formats for installed versions 
automatically. 

C Select to copy EMF, BMP, embedded object, 
and linked object formats to the clipboard. 



712 C H A P T E R   1 7  
 

 
Changing the options on the Selection Cycling tab 
Selection cycling allows you to cycle through overlapping entities under the cursor. 

Use the Selection Cycling tab to determine how selection cycle works. 
 

To change the options on the Selection Cycling tab 

1 Do one of the following to choose Options (  ): 

• On the ribbon, choose the Application button then choose Options, or choose 

Tools > Options (in Manage). 

• On the menu, choose Tools > Options. 

• Type config and then press Enter. 

2 Click the Selection Cycling tab. 

3 Select the options you want. 

4 When you have finished, click OK. 
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Customizing tool palettes 
 

Tool palettes contain commands and blocks that are organized for each access while 

working in drawings. Each tool palette is customizable according to your needs: add 

new palettes, delete existing palettes, and change the order in which they display on 

the pane. You can also control the transparency applied to the display of any palette, 

which is helpful if you want to view parts of a drawing that would otherwise be hid- 

den by opaque tool palettes. 

For details about displaying and positioning tool palettes, see “Displaying and hiding 

the Tool Palettes pane” on page 27. 

 

Creating tool palettes and adding commands and blocks 
Each tool palette that you create can contain any combination of tools that either run a 

command or insert a block. 
 

To create a new tool palette 

1 Right-click the name of an existing tool palette. 

2 Choose New Palette. 

3 Type the name of the new palette, then press Enter. 
 

To add a command to a tool palette 

1 On a tool palette, right-click an existing command tool and choose Copy. 

2 Right-click the tool area of the desired palette and choose Paste. 

3 Right-click the pasted command and choose Properties to change its settings: 

• Name Enter the name of the command. This name displays in the tool palette. 

• Description Type a one-sentence description of the tool. 

• Command Name Enter the command carried out when the tool is selected, 

which can contain a macro (one or more commands and their options), such as: 

^C^C^CZOOM;E;MSNAPSHOT 

• General Select the color, layer, linetype, linetype scale, lineweight, text style, 

and dimension style to apply when using the command. Choose Use Current to 

use the current property. 

4 Click OK. 
 

 

Commands can be added later too. 

Right-click a tool palette and choose Customize Commands. Then drag and drop 

commands from the list of commands to the tool palette. 
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To add a block to a tool palette 

1 Open a drawing that contains blocks, or if necessary create and insert a block. For 

details, see “Working with blocks” on page 470. 

2 Save the drawing. For details, see “Saving your drawing” on page 100. 

3 Select the block in the drawing and drag-and-drop it to the desired tool palette. 

 

Modifying tool palettes 
The Tool Palettes pane can contain multiple palettes. You can rename, reorder, and 

delete tool palettes, and you can also change the transparency in which they display. 
 

To change the name of a tool palette 

1 Right click the name of the tool palette you want to rename. 

2 Choose Rename Palette. 

3 Type a new name, then press Enter. 
 

To change the order in which tool palettes display 

1 Right click the name of the tool palette. 

2 Choose Move Up or Move Down. 
 

To delete a tool palette 

1 Right-click the name of the tool palette you want to delete. 

2 Choose Delete Palette. 

3 Click Yes to confirm the deletion or No to cancel. 
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To change the transparency of tool palettes 

1 Right-click the Tool Palette pane title bar. 

2 Choose Transparency. 

3 Select the desired options: 

• General Move the slider to specify the transparency in which panes display in 

the program. The lower the number, the more transparent the pane is. 

• Rollover Move the slider to specify the transparency in which panes display 

when the mouse moves over them. The lower the number, the more transparent 

the pane is. The transparency for mouse rollover cannot be less than the general 

transparency. 

• Preview Click to see a preview in the program of the mouse rollover trans- 

parency. You might need to move the Transparency dialog box to see a pane. 

• Apply settings to all palettes Mark this check box to apply selected transparency 

options to the display of all panes in the program, including any custom panes. 

• Disable transparency for all palettes Mark this check box to turn off trans- 

parency options for all panes in the program, including any custom panes. 

4 Click OK. 

 

Modifying the tools on a tool palette 
Individual tools on a tool palette can be modified in several ways: reorder the display 

of tools, change the image that displays for any tool, and settings such as name, com- 

mand or block that is assigned, and more. You can also delete tools from any palette. 
 

To change the name of a tool 

1 Right-click the tool you want to rename, then choose Rename. 

2 Type a new name, then press Enter. 
 

To reorder tools on a tool palette 

1   Click and drag a tool to move it up or down. 
 

To add a new tool to a tool palette 

1 Do one of the following: 

• Right-click a tool palette, then choose Customize Commands. 

• Type quickcui, then press Enter. 

2 From the list of commands, drag and drop a command to the tool palette. 

3 When finished, click OK. 
 

To delete a tool from a tool palette 

1   Right-click the tool you want to delete, then choose Delete. 
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To specify an image to display for a tool 

1 Right-click a tool, then choose Image. 

2 Select the image you want to display on the tool palette for the tool. 

3 Do one of the following: 

• Select the desired image. 

• Click Browse to load a .dll external resource file that contains bitmap resources, 

a .bmp file, or a .png file. The loaded images must be 32x32 pixels. 

4 When you have finished, click OK. 
 

To change the settings of a tool on a tool palette 

1 Right-click the tool and choose Properties. 

2 Customize the name and description of the tool: 

• Name Enter the name of the tool. This name displays in the tool palette. 

• Description Type a one-sentence description of the tool. 

3 If the tool is a command, you can customize these options: 

• Command Name Enter the command carried out when the tool is selected, 

which can contain a macro (one or more commands and their options), such as: 

^C^C^CZOOM;E;MSNAPSHOT 

• General Select the color, layer, linetype, linetype scale, lineweight, text style, 

and dimension style to apply when using the command. Choose Use Current to 

use the current property. 

If the tool is a block, you can customize these options: 

• Name Enter the name of the block to insert when using this tool. 

• Source File Enter the filename and path of the drawing that contains the source 

block. 

• Scale Enter the scale of the block. 

• Rotation Enter the rotation of the block. 

• Prompt Rotation Choose Yes to prompt for the block rotation value when 

inserting the block using this tool, or choose No. 

• Explode Choose Yes to allow blocks inserted with this tool to be exploded, or 

choose No. 

• General Select the color, layer, linetype, linetype scale, lineweight, text style, 

and dimension style to apply when inserting the block. Choose Use Current to 

use the current property. 

4 Click OK. 



C U S T O M I Z I N G   4M C A D 717  
 

 
Working with groups of tool palettes 
The Tool Palettes pane displays one group of palettes at a time. If you don’t create 

palette groups, all palettes display on the pane. If you organize palettes into groups, 

you can easily switch the palettes that display on the Tool Palettes pane, simply make 

a group current to view its palettes on the Tool Palettes pane. 

Palettes can be organized into groups. which can be used to quickly switch between 

groups of palettes. 

 

Working with tool palette files 
Tool palettes can be exchanged between computers Tool palettes can be imported and 

exported as .xtp files. Tool palette groups can be imported and exported as .xpg files. 
 

To export a tool palette to a file 

1 Do one of the following to choose Customize: 

• Type customize and then press Enter. 

• Right-click anywhere on a tool palette and choose Customize Palettes. 

2 Right-click the palette you want to save. 

3 Choose Export. 

4 Enter a name for the tool palette file (.xtp file), then click Save. 
 

To export all tool palettes to a file 

1 Do one of the following to choose Customize: 

• Type customize and then press Enter. 

• Right-click anywhere on a tool palette and choose Customize Palettes. 

2 Right-click a palette group. 

3 Choose Export All. 

4 Enter a name for the tool palette group file (.xpg file), then click Save. 
 

To import a tool palette file 

1 Do one of the following to choose Customize: 

• Type customize and then press Enter. 

• Right-click anywhere on a tool palette and choose Customize Palettes. 

2 Right-click a palette or a palette group. 

3 Choose Import. 

4 Select the tool palette file (.xtp file) or tool palette group file (.xpg file) to load, 

then click Open. 
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Customizing menus 
 

You can customize a current menu and save your changes as a file. Menus files can 

also be loaded. Loadable menu file formats can be any of the following: 4MCAD 

(*.icm files), Customizations (.cui files), and AutoCAD (*.mnu, *.mns files). 

 

Understanding menu compatibility 
CUI format menu files are created by newer versions of AutoCAD. MNU format files 

are menu files created by all AutoCAD releases, and MNS format files are included 

in AutoCAD Releases 13, 14, and 2000. 4MCAD reads all file formats, even when 

menu macros include AutoLISP code. This feature allows you to continue using your 

existing AutoCAD menus. 

4MCAD supports all sections of CUI format files required for customization. For 

MNU and MNS format file compatibility, see the following table. 

4MCAD support of specific sections in AutoCAD MNU and MNS format files 
 

Menu section Definition 4MCAD support 

***POP0 Cursor menu Supported 

***POPn Pull-down menus Supported 

***AUXn Auxiliary menus Not supported 

***BUTTONn Button menus Supported 

***ICON Icon menus Not supported 

***SCREEN Screen menus Not supported 

***TABLETn Tablet menus Supported 

 

To see how 4MCAD reads AutoCAD menu source files 

1 Type menu and then press Enter. 

2 Under Files Of Type, select AutoCAD Menu File (mnu). 

3 In the Open Menu dialog box, go to the AutoCAD Support folder and select the 

Acad.mnu file (or Acad.mns for Releases 13, 14, and 2000). 

4 To load the AutoCAD menu file into 4MCAD, click Open. 

The 4MCAD menu bar now looks identical to the AutoCAD menu bar. 

5 To see how it works, choose a few commands from the menu bar, such as File > 

Open or Draw > Line. 

6 To restore 4MCAD to its default user interface, choose Tools > Options, click 

the Profiles tab, and then click Reset. 
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Creating new menus and adding commands 
You can create a new menu by inserting a menu item at the top level of the Menus 

list. Then you can add commands to the new menu item. You can also add submenus 

and modify existing menu names and commands by adding, deleting, and rearranging 

them. 

 
 

Bullet colors indicate whether a command is available at the current experience level. 

A green bullet in front of a menu item or command indicates that the menu item or 

command is available; a red bullet in front of a menu item or command indicates that 

the menu item or command is not available for you to use at the experience level you 

have set. To change the experience level for an item, use the Visibility property in the 

Properties area. To change your experience level for the user interface, choose 

Tools > Options, then the General tab. 
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A Click to show or hide the Customization area. 

B Select a menu, submenu, or a menu’s command. 

C Click to show or hide the Command List area. 

D Click to search for the typed command name. 

E Type a command name for which to search. 

F Select a command from the list. Drag and drop it to the list in 
Customization or change its button images in Button Image and 
properties in Properties. 

G Displays properties assigned to the selected menu item in 
Customization or the selected command in Command List. Enter a 
new value or click [...] to select more options for each property. 

H Click to show or hide the Properties area. 

I Click to select an image file or .dll that contains the image to assign to 
the currently selected button. If you load an image file or .dll file, you 
can click Default to reset the images that display in Bitmap Images to 
the images that were installed with 4MCAD. 

J Select a button image for the selected small or large button in black 
and white or color. 

K Displays the full path and filename of the .dll, .bmp, or .png file that 
was loaded when you clicked Browse. 

L Click to show or hide the Button Image area. 

M Select the button you want to customize. 
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To create a new menu 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Menus in the list. The menus that display on the 

menu bar in the user interface are shown in the list with a plus sign (+) next to 

each name. 

4 Right-click the menu name located below the location of the new menu. 

5 Choose Insert Menu Item. 

6 Type a name for the new pull-down menu, and then press Enter. 

7 Add a command to the menu (see next). To see the new menu, you must add a 

command to it. 

8 Click OK. 
 

To add a command and customize a menu 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Menus in the list. 

4 Expand a menu name to show the menu sub-items and commands that display on 

each menu. 

5 From the Command List, drag a command to where you want it located in the 

Customization list. 

6 To further customize a menu, right-click an item located below where you want to 

add a new item, and choose one of the following: 

• Insert Menu Item Inserts a command above your selection. Enter the name as 

you want it to appear on the menu in the user interfaces, then press Enter. In 

Properties, enter the command name for the menu item in Command Name. 

• Insert Menu Sub-Item Inserts a sub-menu above your selection. Enter the name 

of the sub-menu as you want it to appear in the user interface, then press Enter. 
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• Insert Spacer Inserts a line above your selection that visually separates groups 

of commands on the menu. 

• Insert Context Menu Inserts a menu that appears when you right-click the mouse 

in the user interface. 

• Insert Context Menu Sub-Item Inserts a sub-menu to the selected context menu. 

Enter the name of the sub-menu as you want it to appear in the user interface, 

then press Enter. 

7 Click OK. 

 

Setting custom images for commands on a menu 
You can customize the image that appears for each command on a menu. 

Because you can configure the menu to display either large or small images and to 

display either in color or monochrome, create four different images for each com- 

mand. Create custom images using the following dimensions: 

• Small images: 16 x 16 pixels. 

• Large images: 32 x 32 pixels. 

For best results, images should be 32-bit ARGB format with an alpha transparent 

background. 

 
 

Images that do not match these dimensions are stretched or reduced by the program to fit 

the specified size. 

The resulting images may not appear as originally intended. 
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To customize the images for commands on a menu 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Menus in the list. 

4 Expand a menu name to show the menu sub-items and commands that display on 

each menu, then select a command. 

5 In the Button Image area, in Button Bitmaps, click the button image you want to 

change: Small color, Large color, Small black and white, Large black and white. 

6 Do one of the following: 

• In Bitmap Images, select the desired image from the display of available images. 

• Click Browse to load a .dll external resource file that contains bitmap resources, 

a .bmp file, or a .png file. The loaded images must be 16x16 pixels for small 

icons and 32x32 pixels for large icons. 

7 When you have finished, click OK. 

 

Setting properties of menu items 
You can specify properties for each item on a menu, including the name as it appears 

on the menu, its visibility, and more. 
 

To customize the properties of menu items 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Menus in the list. 

4 Expand a menu name to show the menu sub-items and commands that display on 

each menu, then select a menu item. 
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The properties available for customization vary according to the menu item you select. 

The Properties area of the Customize User Interface dialog box displays only 

those properties that are appropriate for the menu item you select. For example, 

visibility settings are available for commands, not menu names. 
 

 

 

5 In Name, enter the name that you want to display in the user interface. 

You can specify an access key by including an ampersand (&) immediately pre- 

ceding the letter you want to use as the access key. Be sure not to assign the same 

access key to more than one menu or command within a menu. For example, if 

you add a command named Quick Line to the Insert menu, including an amper- 

sand immediately preceding the letter Q causes that letter to appear underlined in 

the menu. You can then select that command by displaying the menu and pressing 

the Alt+Q keys. 

6 In Command Name, enter the name of the command to carry out when the menu 

item is selected in the user interface. 

Command Name may contain a macro (one or more commands and their options), 

such as: 

^C^C^CZOOM;E;MSNAPSHOT 

Adding three ^C (Ctrl+C) characters before a command cancels any active com- 

mands or dialog boxes. 

7 In Description, type a one-sentence description of the item. The string appears on 

the status line for menu items. 

8 In Visibility, click [...] to make your selections for the menu item: 

• Experience Level Select the user levels when the item will be visible: Beginner, 

Intermediate, or Advanced. Items appear only at the experience level you 

specify. For example, if you choose Advanced, the item does not appear if the 

user selects the Beginner or Intermediate level using the Tools > Options 
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command; but if you select Intermediate without also selecting Advanced, the 

item will appear only when you set the experience level to Intermediate. 

Selecting all three options sets the item to appear at all user levels. 

• MDI Window Select the number of drawing windows that must be open for this 

item to appear. If you want the item to appear only when at least one window is 

open, select At Least One Open. If you want the item to appear when no 

windows are open, select No Windows Open. Checking both options means that 

the item always appears. 

• ActiveX In-Place Activation Select the type of ActiveX editing with which the 

item is to appear. If you want the item to appear during embedded server editing, 

select Server, Embedded. If you want the item to appear during in-place server 

editing, select Server, In-place. If you want the ribbon item to appear during 

container editing, select Container. 

• Context Menu Exclusive Select to make the menu item appear only in the 

context menu. 

• Temporary Popup Select to make the item available on a temporary popup if the 

user presses SHIFT and simultaneously right-clicks when the command is 

active. (Available only for menu items.) 

• Hide Select to make the item hidden. 

9 In Entities Content, click [...] to define whether the menu item displays in an 

entity’s context menu. Choose from the following: 

• Customize the context menu on a per-entity basis by selecting or deselecting 

entities. Checking the box next to an entity causes the selected menu item to 

appear on the context menu for that particular entity. 

• If you do not want the menu item to appear in the context menu when only one 

entity is selected, select Exclude if Single Entity is Selected. 

• If you do not want the menu item to appear in the context menu when more than 

one entity is selected, select Exclude if Multiple Entities are Selected. 

10 If visibility of the menu item can be controlled by a system variable, specify any 

of the following: 

• Grayed-State Variable Enter the system variable name and value that controls 

whether this command displays in the user interface as grayed out. When the 

specified system variable is off, the button is grayed-out or appears off. For 

example, the Zoom In command’s grayed state variable is VIEWMODE = 1 

(perspective view = on). 

• Checked-State Variable Enter the system variable name and value that controls 

whether this command displays in the user interface as pressed in. When the 

specified system variable is on, the command’s button appears pressed in. For 

example, the Set Center Snap command’s pressed state variable is OSMODE = 

4 (center snap = on). 

• Hidden-State Variable Enter the system variable name that controls whether this 
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command is hidden in the user interface. When the specified system variable is 

on, the item is hidden. For example, some commands that require an additional 

license have a hidden-state variable. 

Enter the system variable name, an ampersand, then the value, with no spaces. For 

example: "OSMODE&4". 

11 When you have finished, click OK. 

 
 

You can reset the user interface to be the same as when the program was first installed. 

Use the Options command, click the Profiles tab, then click Reset. 
 

 

 

Renaming menu items 

To rename a menu item 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization list, right-click the menu item you want to rename. 

4 Choose Rename. 

5 Type a new name for the menu item by typing over the highlighted name, and then 

press Enter. 

6 Click OK. 

 

Copying and pasting menu items 

To copy and paste a menu item 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization list, right-click the menu item you want to copy. 

4 Choose Copy. 

5 Right-click the menu item located above where you want to locate the copy, then 

click Paste. 

6 Click OK. 
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Deleting menu items 

To delete a menu item 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization list, right-click the menu item you want to delete. 

4 Choose Delete. 

5 In the Confirmation dialog box, click Yes to delete the menu item. 

6 Click OK. 

 
 

Some menu items have sub-items below them. 

Deleting a menu item that has sub-items below it in the Menu Tree also deletes all of 

those sub-items. 
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Customizing the ribbon 
 

For versions of 4MCAD that include a ribbon, several areas contain commands: 

• Application button — Located in the upper left corner and contains file-related 

commands, such as New, Open, Import, Export, and more. 

• Quick Access toolbar — Located to the right of the Application button and con- 

tains common commands. 

• Ribbon — Located below the Application button and runs horizontally at the top 

of the drawing window. The main ribbon consist of tabs that contain related com- 

mands grouped together, for example, on the tabs named Home, Edit, Draw, etc. 

Each tab has panels that contain sub-categories of commands within a tab, for 

example Draw, Modify, and Layers on the Home tab. 

• Contextual ribbon states — Located temporarily when working with certain enti- 

ties: multiline text, raster images, and external references. 

All of these areas can be customized with the exception of contextual ribbon states, 

which are built-in to 4MCAD. 

Ribbon settings are saved automatically in a .cui file. The CUI format is the newest 

user interface format and also supports all legacy user interface elements such as 

menus, toolbars, tablet, etc. The CUI format is the only menu format the supports the 

ribbon interface, so if you are creating a menu file that will support the ribbon, use the 

CUI format. 

 

Creating and customizing ribbon tabs and child panels 
You can create a new ribbon tab by inserting a tab at the top level of the Ribbon list. 

Then you can add panels, or groups, to the new ribbon tab and add commands. You 

can also modify existing names and commands by adding, deleting, and rearranging 

them. 

 
 

Bullet colors indicate whether a command is available at the current experience level. 

A green bullet in front of a ribbon item or command indicates that the item is avail- 

able; a red bullet indicates that the item is not available for you to use at the experi- 

ence level you have set. To change the experience level for an item, use the Visibility 

property in the Properties area. To change your experience level for the user inter- 

face, use the Options command on the Tools menu. 
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A Click to show or hide the Customization area. 

B Select a ribbon tab, panel, or a ribbon’s command. 

C Click to show or hide the Command List area. 

D Click to search for the typed command name. 

E Type a command name for which to search. 

F Select a command from the list. Drag and drop it to the list in 
Customization or change its button images in Button Image and 
properties in Properties. 

G Displays properties assigned to the selected ribbon item in 
Customization or the selected command in Command List. Enter a 
new value or click [...] to select more options for each property. 

H Click to show or hide the Properties area. 

I Click to select an image file or .dll that contains the image to assign to 
the currently selected button. If you load an image file or .dll file, you 
can click Default to reset the images that display in Bitmap Images to 
the images that were installed with 4MCAD. 

J Select a button image for the selected small or large button in black 
and white or color. 

K Displays the full path and filename of the .dll, .bmp, or .png file that 
was loaded when you clicked Browse. 

L Click to show or hide the Button Image area. 

M Select the button you want to customize. 
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To create a new ribbon tab 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Ribbon in the list. The tabs that display on the rib- 

bon in the user interface are shown in the list with a plus sign (+) next to each 

name. 

3 Right-click the ribbon tab name located below the location of the new ribbon tab. 

4 Choose Insert Tab. 

5 Type a name for the new tab, and then press Enter. 

6 Add a panel and command to the ribbon tab (see next). To see the new ribbon tab, 

you must add a panel and command to it. 

7 Click OK. 
 

To customize a ribbon tab 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Ribbon in the list. 

4 Expand a ribbon tab then its panels to show the commands that display on each 

ribbon tab. 

5 From the Command List, drag a command to where you want it located in the 

Customization list. 
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6 To further customize a ribbon tab, right-click an item located below where you 

want to add a new item, and choose one of the following: 

• Insert Tab Inserts a new tab for the ribbon. Enter the name of the tab, then press 

Enter. The tab is inserted in the list above your selection. 

• Insert Panel and Insert Child Panel Inserts an area on the ribbon tab used to 

group related commands. Enter the name of the panel which displays below the 

group of commands on the tab, then press Enter. The panel is inserted in the list 

above your selection, or for child panels, nested in the list under your selection 

in the list. 

• Insert Row and Insert Child Row Inserts a row to a panel. Each panel can have 

one or more rows, which is a group of buttons aligned horizontally. The row is 

inserted in the list above your selection, or for child rows, nested in the list 

below your selection. Note that a set of panel rows can be broken into two parts 

(visible and collapsed) using the <PanelBreaker> element (right-click and 

choose Insert Panel Breaker). 

• Insert Command Button and Insert Child Command Button Inserts a command 

button that runs a command when clicked in the user interface. The command 

button is inserted in the list above your selection, or for child command buttons, 

nested in the list below your selection. 

• Insert Menu Button and Insert Child Menu Button Inserts a menu name that 

when clicked on the ribbon displays additional command buttons. The menu is 

inserted in the list above your selection, or for child menu buttons, nested in the 

list below your selection. 

• Insert Row Panel and Insert Child Row Panel Inserts a group of rows that display 

on a panel. The row panel is inserted in the list above your selection, or for child 

row panels, nested in the list below your selection. 

• Insert Control and Insert Child Control Inserts a standard control for selecting 

layers, colors, linetypes, lineweights, dimension styles, text styles, and print 

styles. The control is inserted in the list above your selection, or for child 

controls, nested in the list below your selection. 

• Insert Separator and Insert Child Separator Inserts a line that appears vertically 

on the ribbon to separate groups of commands. The separator is inserted in the 

list above your selection, or for child separators, nested in the list below your 

selection. 

• Insert Split Button and Insert Child Split Button Inserts a button that when 

clicked on the ribbon displays additional command buttons. For example, you 

might want the Array and 3D Array commands grouped together on a split 

button. The command button that displays by default on the ribbon is the last one 

used. The split button is inserted in the list above your selection, or for child split 

buttons, nested in the list below your selection. 

7 Click OK. 
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You can reset the user interface to be the same as when the program was first installed. 

Use the Options command, click the Profiles tab, then click Reset. 
 

 

 

Creating and customizing quick access toolbars 
You can create a new ribbon tab by inserting a tab at the top level of the Ribbon list. 

Then you can add panels, or groups, to the new ribbon tab and add commands. You 

can also modify existing names and commands by adding, deleting, and rearranging 

them. 
 

To create a new quick access toolbar 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Quick Access Toolbars in the list. The tabs that dis- 

play on the ribbon in the user interface are shown in the list with a plus sign (+) 

next to each name. 

3 Right-click a quick access toolbar name and then choose Insert Quick Access 

Toolbar. The new quick access toolbar will be inserted above your selection in the 

list. 

4 Type a name for the new quick access toolbar, and then press Enter. 

5 Add a command to the quick access toolbar (see next). To see the new quick 

access toolbar, you must add a command to it. 

6 Click OK. 
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To customize a quick access toolbar 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Quick Access Toolbars in the list. 

4 Expand a quick access toolbar to show the commands that it displays. 

5 Do one of the following to add a command to the quick access toolbar: 

• From the Command List, drag a command to where you want it located in the 

Customization list. 

• Right-click a command in the Quick Access Toolbar list and choose Insert 

Command Button. Type the name, and then press Enter. Then in Properties, 

enter the command name for the item in Command Name. 

6 Click OK. 

 
 

You can reset the user interface to be the same as when the program was first installed. 

Use the Options command, click the Profiles tab, then click Reset. 
 

 

 

Creating and customizing application buttons 
You can create a new application button and modify an existing one. You can also 

modify existing names and commands by adding, deleting, and rearranging them. 
 

To create a new application button 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Application Buttons in the list. 

3 Right-click an application button in the list, then choose Insert Application Button. 

The new application button will be inserted above your selection in the list. 

4 Type the application button name, and then press Enter 

5 Add a command to the application button (see next). To see the new application 

button, you must add a command to it. 

6 Click OK. 
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To customize an application button 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Application Buttons in the list. 

4 Expand an application button to show the commands that it displays. 

5 From the Command List, drag a command to where you want it located in the 

Customization list. 

6 To further customize an application button, right-click an item located below 

where you want to add a new item, and choose one of the following: 

• Insert Command Button Inserts an item that runs a command when clicked in 

the user interface. The command is inserted in the list above your selection. 

• Insert Menu Button Inserts a menu item that opens a sub-menu when clicked in 

the user interface. The menu is inserted in the list above your selection. 

• Insert Separator Inserts a line in the user interface that visually separates groups 

of commands. 

• Insert Child Command Button Inserts an item that runs a command when 

clicked in the user interface. The command is nested under your selection in the 

list. This option displays for menu buttons (not command buttons). 

• Insert Child Separator Inserts a line in the user interface that visually separates 

groups of commands. The separator is nested under your selection in the list. 

This option displays for menu buttons (not command buttons). 

7 Click OK. 

 

Setting custom images for commands on the ribbon 
You can customize the image that appears for each command on the ribbon. 

Because you can configure the ribbon to display either large or small images and to 

display either in color or monochrome, create four different images for each com- 

mand. Create custom images using the following dimensions: 

• Small images: 16 x 16 pixels. 

• Large images: 32 x 32 pixels. 

For best results, images should be 32-bit ARGB format with an alpha transparent 

background. 
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Images that do not match these dimensions are stretched or reduced by the program to fit 

the specified size. 

The resulting images may not appear as originally intended. 
 

 

 
To customize the images for commands on the ribbon 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Ribbon in the list. 

4 Expand a ribbon tab name and panel names to show the commands that display on 

each ribbon tab, then select a command. 

5 In the Button Image area, in Button Bitmaps, click the button image you want to 

change: Small color, Large color, Small black and white, Large black and white. 

6 Do one of the following: 

• In Bitmap Images, select the desired image from the display of available images. 

• Click Browse to load a .dll external resource file that contains bitmap resources, 

a .bmp file, or a .png file. The loaded images must be 16x16 pixels for small 

icons and 32x32 pixels for large icons. 

7 When you have finished, click OK. 

 

Setting properties of ribbon items 
You can specify properties for each item on the ribbon, including the name as it 

appears on the ribbon, its visibility, and more. 
 

To customize the properties of ribbon items 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Ribbon in the list. 

4 Expand a ribbon tab name and panel name to show the commands that display on 

each ribbon tab, then select a ribbon item. 
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The properties available for customization vary according to the ribbon item you 

select. 

The Properties area of the Customize User Interface dialog box displays only 

those properties that are appropriate for the ribbon item you select. For example, 

visibility settings are available for commands, not ribbon panel names. 
 

 

 

5 In Name, enter the name that you want to display in the ribbon. 

6 In Command Name, enter the name of the command to carry out when the ribbon 

item is selected in the user interface. 

Command Name may contain a macro (one or more commands and their options), 

such as: 

^C^C^CZOOM;E;MSNAPSHOT 

Adding three ^C (Ctrl+C) characters before a command cancels any active com- 

mands or dialog boxes. 

7 In Description, type a one-sentence description of the item. The string appears on 

the status line for ribbon items. 

8 In Visibility, click [...] to make your selections for the ribbon item: 

• Experience Level Select the user levels when the item will be visible: Beginner, 

Intermediate, or Advanced. Items appear only at the experience level you 

specify. For example, if you choose Advanced, the item does not appear if the 

user selects the Beginner or Intermediate level using the Tools > Options 
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command; but if you select Intermediate without also selecting Advanced, the 

item will appear only when you set the experience level to Intermediate. 

Selecting all three options sets the item to appear at all user levels. 

• MDI Window Select the number of drawing windows that must be open for this 

item to appear. If you want the item to appear only when at least one window is 

open, select At Least One Open. If you want the item to appear when no 

windows are open, select No Windows Open. Checking both options means that 

the item always appears. 

• ActiveX In-Place Activation Select the type of ActiveX editing with which the 

item is to appear. If you want the item to appear during embedded server editing, 

select Server, Embedded. If you want the item to appear during in-place server 

editing, select Server, In-place. If you want the item to appear during container 

editing, select Container. 

• Context Menu Exclusive Select to make the item appear only in the context 

menu. 

• Temporary Popup (Available only for menu items.) Select to make the item 

available on a temporary popup if the user presses SHIFT and simultaneously 

right-clicks when the command is active. 

• Hide Select to make the item hidden. 

9 In Entities Content, click [...] to define whether the ribbon item displays in an 

entity’s context menu. Choose from the following: 

• Customize the context menu on a per-entity basis by selecting or deselecting 

entities. Checking the box next to an entity causes the selected ribbon item to 

appear on the context menu for that particular entity. 

• If you do not want the ribbon item to appear in the context menu when only one 

entity is selected, select Exclude if Single Entity is Selected. 

• If you do not want the ribbon item to appear in the context menu when more than 

one entity is selected, select Exclude if Multiple Entities are Selected. 

10 If visibility of the ribbon item can be controlled by a system variable, specify any 

of the following: 

• Grayed-State Variable Enter the system variable name and value that controls 

whether this command displays in the user interface as grayed out. When the 

specified system variable is off, the button is grayed-out or appears off. For 

example, the Zoom In command’s grayed state variable is VIEWMODE = 1 

(perspective view = on). 

• Checked-State Variable Enter the system variable name and value that controls 

whether this command displays in the user interface as pressed in. When the 

specified system variable is on, the command’s button appears pressed in. For 

example, the Set Center Snap command’s pressed state variable is OSMODE = 

4 (center snap = on). 

• Hidden-State Variable Enter the system variable name that controls whether this 
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command is hidden in the user interface. When the specified system variable is 

on, the item is hidden. For example, some commands that require an additional 

license have a hidden-state variable. 

Enter the system variable name, an ampersand, then the value, with no spaces. For 

example: "OSMODE&4". 

11 When you have finished, click OK. 

 
 

You can reset the user interface to be the same as when the program was first installed. 

Use the Options command, click the Profiles tab, then click Reset. 
 

 

 

Renaming ribbon items 

To rename a ribbon item 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization list, right-click the ribbon item you want to rename. 

4 Choose Rename. 

5 Type a new name for the ribbon item by typing over the highlighted name, and 

then press Enter. 

6 Click OK. 

 

Copying and pasting ribbon items 

To copy and paste a ribbon item 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization list, right-click the ribbon item you want to copy. 

4 Choose Copy. 

5 Right-click the ribbon item located above where you want to locate the copy. 

6 Choose Paste. 

7 Click OK. 
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Deleting ribbon items 

To delete a ribbon item 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization list, right-click the ribbon item you want to delete. 

4 Choose Delete. 

5 In the Confirmation dialog box, click Yes to delete the ribbon item. 

6 Click OK. 

 
 

Some ribbon items have sub-items below them. 

Deleting a ribbon item that has sub-items below it also deletes all of those sub-items. 
 

 

 
 

 

Customizing toolbars 
 

4MCAD provides toolbars so that you can access frequently used commands. When 

a toolbar is turned on, it is always available, or on top, and in the same location so it is 

easy to find and use. However, toolbars occupy drawing display space and reduce 

the area available for working in drawings. 

You can customize these toolbars by adding or removing tools or by rearranging the 

organization of tools. You can also create custom toolbars. 

 

Creating and customizing toolbars 
You can create a new toolbar using the Customize UI command, then you can add 

tools to the new toolbar. You can also add, delete, or modify tools on any existing 

toolbar. 
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A Click to show or hide the Customization area. 

B Select a toolbar or a toolbar command. 

C Click to show or hide the Command List area. 

D Click to search for the typed command name. 

E Type a command name for which to search. 

F Select a command from the list. Drag and drop it to the list in 
Customization or change its button images in Button Image and 
properties in Properties. 

G Displays properties assigned to the selected toolbar item in 
Customization or the selected command in Command List. Enter a 
new value or click [...] to select more options for each property. 

H Click to show or hide the Properties area. 

I Click to select an image file or .dll that contains the image to assign to 
the currently selected button. If you load an image file or .dll file, you 
can click Default to reset the images that display in Bitmap Images to 
the images that were installed with 4MCAD. 

J Select a button image for the selected small or large button in black 
and white or color. 

K Displays the full path and filename of the .dll, .bmp, or .png file that 
was loaded when you clicked Browse. 

L Click to show or hide the Button Image area. 

M Select the button you want to customize. 
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To create a new toolbar 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Toolbars in the list. The toolbars are shown in the 

list with a plus sign (+) next to each name. 

4 Right-click a toolbar name located below the location of the new toolbar. 

5 Choose Insert Toolbar. 

6 Type a name for the new toolbar, and then press Enter. 

7 Add a command to the toolbar (see next). To see the new toolbar in the user inter- 

face, you must add a command to it. 

8 Click OK. 
 

To add a command to a toolbar 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Toolbars in the list. 

4 Expand a toolbar name to show the commands that display on each toolbar. 

5 From the Command List, drag a command to where you want it located in the 

Customization list. 

6 To further customize a toolbar, right-click an item located below where you want 

to add a new item, and choose one of the following: 

• Insert Button Inserts a toolbar button that runs a command when clicked in the 

user interface. The toolbar button is inserted in the list above your selection. 

• Insert Sub-Item Inserts a toolbar button if you right-clicked a toolbar name in 

the list. If you right-clicked an item in the list located on a toolbar, inserts a 

toolbar button nested in the list under your selection, and the selection becomes 

the parent command on a flyout. 

 
Toolbar flyouts are a way to organize related tools and conserve space on 
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toolbars. A flyout is indicated by a small triangle in the lower right corner of a 

tool. When you click a flyout tool, a set of additional tools displays. The flyout 

tool you select then becomes the default tool on the toolbar. 

• Insert Spacer Inserts a line that appears vertically on the toolbar to separate 

groups of commands. The separator is inserted in the list above your selection. 

7 Click OK. 

 
 

You can reset the user interface to be the same as when the program was first installed. 

Use the Options command, click the Profiles tab, then click Reset. 
 

 

 

Setting custom images for commands on a toolbar 
You can customize the image that appears for each command on a toolbar. 

Because you can configure toolbars to display either large or small tools and to dis- 

play tools either in color or monochrome, create four different images for each tool. 

Create custom images using the following dimensions: 

• Small images: 16 x 16 pixels. 

• Large images: 32 x 32 pixels. 

For best results, images should be 32-bit ARGB format with an alpha transparent 

background. 

 
 

Images that do not match these dimensions are stretched or reduced by the program to fit 

the specified size. 

The resulting tools may not appear as originally intended. 
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To customize the images for commands on a toolbar 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Toolbars in the list. 

4 Expand a toolbar name to show the commands that display on each toolbar, then 

select a command. 

5 In the Button Image area, in Button Bitmaps, click the button image you want to 

change: Small color, Large color, Small black and white, Large black and white. 

Note that black and white icons are used for high contrast which is used by color 

blind users or others with visual impairments. See Section 508 compliance. 

6 Do one of the following: 

• In Bitmap Images, select the desired image from the display of available images. 

• Click Browse to load a .dll external resource file that contains bitmap resources, 

a .bmp file, or a .png file. The loaded images must be 16x16 pixels for small 

icons and 32x32 pixels for large icons. 

7 When you have finished, click OK. 

 

Setting properties of toolbar items 
You can specify properties for each item on a toolbar, including the name as it 

appears on a tooltip, a tool’s visibility, and more. 
 

To customize the properties of toolbar items 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Toolbars in the list. 

4 Expand a toolbar name to show the commands that display on each toolbar, then 

select a toolbar item. 
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The properties available for customization vary according to the toolbar item you 

select. 

The Properties area of the Customize User Interface dialog box displays only 

those properties that are appropriate for the toolbar item you select. For example, 

visibility settings are available for commands, not toolbar names. 
 

 

 

5 In Name, enter the name that you want to display when you hover over a toolbar. 

6 In Command Name, enter the name of the command to carry out when the toolbar 

item is selected in the user interface. 

Command Name may contain a macro (one or more commands and their options), 

such as: 

^C^C^CZOOM;E;MSNAPSHOT 

Adding three ^C (Ctrl+C) characters before a command cancels any active com- 

mands or dialog boxes. 

7 In Description, type a one-sentence description of the item. The string appears on 

the status line for toolbar items. 

8 In Visibility, click [...] to make your selections for the toolbar item: 

• Experience Level Select the user levels when the item will be visible: Beginner, 

Intermediate, and/or Advanced. Items appear only at the experience level you 

specify. For example, if you choose Advanced, the item does not appear if the 

user selects the Beginner or Intermediate level using the Tools > Options 

command; but if you select Intermediate without also selecting Advanced, the 

item will appear only when you set the experience level to Intermediate. 

Selecting all three options sets the item to appear at all user levels. 

• MDI Window Select the number of drawing windows that must be open for this 

item to appear. If you want the item to appear only when at least one window is 

open, select At Least One Open. If you want the item to appear when no 

windows are open, select No Windows Open. Checking both options means that 

the item always appears. 

• ActiveX In-Place Activation Select the type of ActiveX editing with which the 

item is to appear. If you want the item to appear during embedded server editing, 

select Server, Embedded. If you want the item to appear during in-place server 

editing, select Server, In-place. If you want the item to appear during container 

editing, select Container. 

• Context Menu Exclusive Select to make the item appear only in the context 

menu. 
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• Temporary Popup (Available only for menu items.) Select to make the item 

available on a temporary popup if the user presses SHIFT and simultaneously 

right-clicks when the command is active. 

• Hide Select to make the item hidden. 

9 In Entities Content, click [...] to define whether the toolbar item displays in an 

entity’s context menu. Choose from the following: 

• Customize the context menu on a per-entity basis by selecting or deselecting 

entities. Checking the box next to an entity causes the selected toolbar item to 

appear on the context menu for that particular entity. 

• If you do not want the toolbar item to appear in the context menu when only one 

entity is selected, select Exclude if Single Entity is Selected. 

• If you do not want the toolbar item to appear in the context menu when more 

than one entity is selected, select Exclude if Multiple Entities are Selected. 

10 If visibility of the toolbar item can be controlled by a system variable, specify any 

of the following: 

• Grayed-State Variable Enter the system variable name and value that controls 

whether this command displays in the user interface as grayed out. When the 

specified system variable is off, the button is grayed-out or appears off. For 

example, the Zoom In command’s grayed state variable is VIEWMODE = 1 

(perspective view = on). 

• Checked-State Variable Enter the system variable name and value that controls 

whether this command displays in the user interface as pressed in. When the 

specified system variable is on, the command’s button appears pressed in. For 

example, the Set Center Snap command’s pressed state variable is OSMODE = 

4 (center snap = on). 

• Hidden-State Variable Enter the system variable name that controls whether this 

command is hidden in the user interface. When the specified system variable is 

on, the item is hidden. For example, some commands that require an additional 

license have a hidden-state variable. 

Enter the system variable name, an ampersand, then the value, with no spaces. For 

example: "OSMODE&4". 

11 When you have finished, click OK. 

 
 

You can reset the user interface to be the same as when the program was first installed. 

Use the Options command, click the Profiles tab, then click Reset. 
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Renaming toolbar items 

To rename a toolbar item 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization list, right-click the toolbar item you want to rename. 

4 Choose Rename. 

5 Type a new name for the toolbar item by typing over the highlighted name, and 

then press Enter. 

6 Click OK. 

 
 

You can also rename toolbars using the Toolbars command. 

Choose View > Toolbars to open the Select Toolbars dialog box. Select the toolbar 

you want to rename, then click Rename and type the new name. 
 

 

 

Copying and pasting toolbar items 

To copy and paste a toolbar item 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization list, right-click the toolbar item you want to copy. 

4 Choose Copy. 

5 Right-click the toolbar item located above where you want to locate the copy. 

6 Choose Paste. 

7 Click OK. 
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Deleting toolbar items 

To delete a toolbar item 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization list, right-click the toolbar item you want to delete. 

4 Choose Delete. 

5 In the Confirmation dialog box, click Yes to delete the toolbar item. 

6 Click OK. 
 
 

 

Customizing the keyboard 
 

4MCAD provides keyboard shortcuts so you can access frequently used com- 

mands. You can customize these shortcuts and add new shortcuts using the Custom- 

ize UI command. 

 

Creating and customizing keyboard shortcuts 
You can assign macros to special keys and certain combinations of keys to create a 

keyboard shortcut. A macro consists of one or more commands that are displayed on 

the status bar as follows: 

• A single command, such as QSAVE. 

• A command with options, such as ARC;\A;\\. 

• More than one command, such as ̂ C^C^CZOOM;E;QSAVE;QPRINT. 

Keyboard shortcuts are more powerful than aliases. An alias lets you abbreviate a sin- 

gle command name; a keyboard shortcut contains one or more macros. To activate a 

macro, you press the shortcut key; you do not need to press Enter as you do with an 

alias. A shortcut consists of the following keys: 

• The function and the cursor control keys, as well as alphanumeric keys pressed in 

combination with the Ctrl, Alt, and Shift keys. The Shift key must be used in con- 

junction with the Ctrl, Alt, and/or function keys. 

• Alphanumeric keys are those labeled A through Z and 1 though 0. 

• The cursor keys are the up, down, left, and right arrows and the Page Up, Page 

Down, Home, End, Insert, and Delete keys. 

• The function keys are those labeled F1 through F12. 
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A Click to show or hide the Customization area. 

B Select a keyboard shortcut. 

C Click to show or hide the Command List area. 

D Click to search for the typed command name. 

E Type a command name for which to search. 

F Displays a list of commands. You can change a command’s button 
images in Button Image and properties in Properties. 

G Displays properties assigned to the selected keyboard shortcut in 
Customization or the selected command in Command List. Enter a 
new value or click [...] if available to select more options for each 
property. 

H Click to show or hide the Properties area. 
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To create a keyboard shortcut 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Keyboard Shortcuts in the list. 

4 Right-click a shortcut name located above where you want to add the new key- 

board shortcut in the list. 

5 Choose Insert Accelerator. 

6 In the Keyboard Shortcut Keys dialog box, press the keyboard combination you 

want to add, for example, press Alt+A. 

7 Click OK. 

8 In Command Name, enter the name of the command to carry out when the key- 

board combination is pressed in the user interface. 

Command Name may contain a macro (one or more commands and their options), 

such as: 

^C^C^CZOOM;E;MSNAPSHOT 

Adding three ^C (Ctrl+C) characters before a command cancels any active com- 

mands or dialog boxes. 

9 In Description, type a one-sentence description of the item. 

10 To save your changes and close the dialog box, click OK. 
 

 

You can reset the user interface to be the same as when the program was first installed. 

Use the Options command, click the Profiles tab, then click Reset. 
 

 

 

Setting properties of keyboard shortcuts 
You can specify properties for each keyboard shortcut, including the associated com- 

mand, description, and key combination. 
 

To customize the properties of keyboard shortcuts 

1   Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 
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2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Keyboard Shortcuts in the list. 

4 Select a keyboard shortcut. 

5 In Command Name, enter the name of the command to carry out when the key- 

board shortcut is pressed in the user interface. 

Command Name may contain a macro (one or more commands and their options), 

such as: 

^C^C^CZOOM;E;MSNAPSHOT 

Adding three ^C (Ctrl+C) characters before a command cancels any active com- 

mands or dialog boxes. 

6 In Description, type a one-sentence description of the item. 

7 To specify a new key combination, do the following; 

• In Key(s), press [...]. 

• Press a new key combination. 

• Click OK. 

8 When you have finished, click OK. 

 
 

You can reset the user interface to be the same as when the program was first installed. 

Use the Options command, click the Profiles tab, then click Reset. 
 

 

 

Copying and pasting keyboard shortcuts 

To copy and paste a keyboard shortcut 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization list, right-click the keyboard shortcut you want to copy. 

4 Choose Copy. 

5 Right-click the keyboard shortcut located above where you want to locate the 

copy. 

6 Choose Paste. 

7 Click OK. 
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Deleting keyboard shortcuts 

To delete a keyboard shortcut item 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization list, right-click the keyboard shortcut you want to delete. 

4 Choose Delete. 

5 In the Confirmation dialog box, click Yes to delete the keyboard shortcut. 

6 Click OK. 

 

 

Creating aliases 
 

4MCAD provides aliases for many commands. You can use aliases to issue fre- 

quently used commands by entering one or two letters rather than the entire command 

name. 

The program also uses aliases to maintain command-name compatibility with 

AutoCAD. You can use the same aliases and keyboard shortcuts used by AutoCAD. 

In addition, 4MCAD has enhanced several AutoCAD commands. For example, 

4MCAD added two useful options to the rectangle command: you can draw a 

rectangle as a square, and you can rotate a rectangle at an angle. 

You can customize aliases, and you can add new aliases. You customize aliases using 

the Customize UI command. 

 

Creating aliases 
To create a new command alias, you first define the alias and then assign it one of the 

available 4MCAD commands. 
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A Click to show or hide the Customization area. 

B Select an alias. 

C Click to show or hide the Command List area. 

D Click to search for the typed command name. 

E Type a command name for which to search. 

F Displays a list of commands. You can change a command’s button 
images in Button Image and properties in Properties. 

G Displays properties assigned to the selected alias in Customization or 
the selected command in Command List. Enter a new value or click 
[...] if available to select more options for each property. 

H Click to show or hide the Properties area. 
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To create a new alias 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Aliases in the list. 

4 Right-click an alias name located below where you want to add the new alias in 

the list. 

5 Choose Insert Alias. 

6 Type the new alias, then press Enter. 

7 In Command Name, enter the name of the command to carry out when the alias is 

entered in the user interface. 

Command Name may contain a macro (one or more commands and their options), 

such as: 

^C^C^CZOOM;E;MSNAPSHOT 

Adding three ^C (Ctrl+C) characters before a command cancels any active com- 

mands or dialog boxes. 

8 In Description, type a one-sentence description of the item. 

9 To save your changes and close the dialog box, click OK. 

 
 

You can reset the user interface to be the same as when the program was first installed. 

Use the Options command, click the Profiles tab, then click Reset. 
 

 

 

Setting properties of aliases 
You can specify properties for each alias, including the associated command and 

description. 
 

To customize the properties of aliases 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization area, select either a workspace or a customization file (for 

example, ICAD), then expand Aliases in the list. 
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4 Select an alias. 

5 In Name, enter a new name for the alias. 

6 In Command Name, enter the name of the command to carry out when the alias 

name is entered in the user interface. 

Command Name may contain a macro (one or more commands and their options), 

such as: 

^C^C^CZOOM;E;MSNAPSHOT 

Adding three ^C (Ctrl+C) characters before a command cancels any active com- 

mands or dialog boxes. 

7 In Description, type a one-sentence description of the item. 

8 When you have finished, click OK. 

 
 

You can reset the user interface to be the same as when the program was first installed. 

Use the Options command, click the Profiles tab, then click Reset. 
 

 

 

Copying and pasting an alias item 

To copy and paste an alias item 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization list, right-click the alias you want to copy. 

4 Choose Copy. 

5 Right-click the alias located above where you want to locate the copy. 

6 Choose Paste. 

7 Click OK. 
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Deleting an alias item 

To delete an existing alias item 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 In the Customization list, right-click the alias you want to delete. 

4 Choose Delete. 

5 In the Confirmation dialog box, click Yes to delete the alias. 

6 Click OK. 
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Working with user interface customization files 
 

Many users customize areas of the 4MCAD main window such as the menus and 

toolbars using the Customize UI (CUI) command. These settings are saved in a .cui 

file, which is an XML format file that contains settings for the following: 

• Ribbon 

• Workspaces 

• Menus 

• Toolbars 

• Keyboard accelerators 

• Aliases 

• Double-click actions 

You can save and load .cui/.cuix files, restore them, copy settings between .cui files, 

and even manually edit a .cui/.cuix file. 

4MCAD works with other file types too that are used to customize the user inter- 

face. You can also load AutoCAD menus and toolbars (*.mnu, *.mns), 4MCAD 

menus and toolbars (*.icm), 4MCAD aliases (*.ica), AutoCAD aliases (*.pgp), and 

4MCAD keyboard shortcuts (*.ick). 

Tool palettes are part of the user interface and they can be customized too, but they 

are not saved in customization files. To customize tool palettes, see “Customizing 

tool palettes” on page 713 in this chapter. 

 

Saving customization files 

4MCAD automatically saves any customizations you make to the following: 

• Ribbon 

• Workspaces 

• Menus 

• Toolbars 

• Keyboard accelerators 

• Aliases 

• Double-click actions 

Your changes are saved automatically in a .cui/.cuix file. If desired, you can save the 

settings to a new .cui/.cuix file. 
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To save customization settings to a new customization file 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Transfer tab. 

3 On the right, click Save As. 

4 Enter a name for the .cui/.cuix file. 

5 Click Save. 

6 Click OK. 

 

Loading customization files 
You can replace the current customization file with a different one or you can extend 

the current customization file with additional items like custom menus. The program 

loads full customizations (*.cui, *.cuix), AutoCAD menus and toolbars (*.mnu, 

*.mns), 4MCAD menus and toolbars (*.icm), 4MCAD aliases (*.ica), AutoCAD 

aliases (*.pgp), and 4MCAD keyboard shortcuts (*.ick). 

Loading a menu, alias, or keyboard shortcut file replaces only those items in the user 

interface. 

You can also restore customization settings by loading the default customization file 

from when the program was installed or by loading a backup customization file. 
 

To load a customization file 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Transfer tab. 

3 On the left, click Open. 

4 From the Files Of Type list, choose the file type you want to load. 

5 Select the desired file. 

6 Click Open. 

7 Click OK. 
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To restore the default customization file 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 Click the double arrow for Current Customization. 

4 Choose Reset from Default. 

5 Click Yes to restore the default customization file or No to cancel. 

6 Click OK. 

 
 

You can also reset the CUI user interface customization from the command prompt. 

Type resetui to start the Reset User Interface command. 
 

 

 
To restore a backup customization file 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Customize tab. 

3 Click the double arrow for Current Customization. 

4 Choose Restore Backup, then choose Daily, Weekly, Monthly, or Annual. 

5 Click Yes to restore the backup customization file or No to cancel. 

6 Click OK. 
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Creating a new .cui file and copying settings 
Use the Customize UI command to quickly create a new .cui/.cuix file and copy set- 

tings from one customization file to another. You choose which settings to copy, 

from a single command to all settings in a file. 
 

To create a new .cui/.cuix file and copy settings 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Transfer tab. 

3 On the right, click New. 

4 On the left, click Open and select the customization file that contains the settings 

you want to copy. 

5 Drag and drop settings between the two files. 

6 Click OK when done. 

 

Customizing a .cui file using an editor 
A .cui file is an XML file format, which can be edited using any ASCII or Unicode 

text editor. However, it is best to edit .cui files using an XML editor such as Visual 

Studio or Notepad++. If you are developing with 4MCAD, you already have Visual 

Studio. 

Use caution when manually editing a .cui file and use the following tips about the for- 

mat of the file: 

• Content of .cui/.cuix files is case-sensitive. For example, the following is correct; 

no errors will be shown but ID attribute will be ignored: 

<ToolTip id="123">Help</ToolTip> 

The following is also correct; ID will be equal to 123: 

<ToolTip ID="123">Help</ToolTip> 

• Content of .cui files contains special symbols, similar to an .xml file: & (amper- 

sand), ' (quote), and more. Replace these special symbols with corresponding 

escape sequence or use XML CDATA structure instead. For example, the follow- 

ing is not correct: 

<ToolTip id="123">&Help</ToolTip> 

Correct: 

<ToolTip ID="123">&amp;Help</ToolTip> 

Not correct: 

<Command>'_HELP</Command> 
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Correct: 

<Command><![CDATA['_HELP]]></Command> 

• Properties of several entity types can be described in both node-style and attribute- 

style. For example, the following two toolbar buttons are the same: 

<ToolbarButton UID="unique-id" IsSeparator="true 

Visibility="CUI_LEV_ALL,CUI_MDI_OPN,CUI_OLE_SEM" 

EntityVisibility="RCM_ENT_ACS,RCM_ENT_MUL"/> 

 
 

<ToolbarButton UID="unique-id"> 
 

<IsSeparator>true</IsSeparator> 
 

<Visibility>CUI_LEV_ALL,CUI_MDI_OPN,CUI_OLE_SEM</Visibility> 
 

<EntityVisibility>RCM_ENT_ACS,RCM_ENT_MUL</EntityVisibility> 
 

</ToolbarButton> 

 
To customize a .cui/.cuix file using an editor 

1 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and then press Enter. 

2 Click the Menus tab, then click Export. 

3 Specify the directory and file name you want to use to save the menu file. 

4 In Save as Type, select CUI Customizations file (.cui). 

5 Click Save, then Close. 

6 In any ASCII or Unicode text editor, open the .cui file and make changes accord- 

ing to the following format. 

There are many editors, but if you are developing with 4MCAD, you already 

have Visual Studio, which is a good XML editor for .cui files. 
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Understanding versioning of a .cui file 
Each .cui file has a node that controls versioning: 

<FileVersion MajorVersion="1" MinorVersion="2" UserVersion="0" IncrementalVersion="91"/> 

• IncrementalVersion Must be incremented with any change in the Icad.cui file. 

• UserVersion Incremented automatically when a user customizes 4MCAD. In the 

default Icad.cui file, this must be always equal to 0 and never edited manually. 

• MinorVersion Must be incremented with a change or creation of a versioned entity 

(PopMenu, Toolbar, MenuMacro->Macro, ...). 

• MajorVersion Must be incremented with the following: 

• Change of Icad.cui file schema (for example, added/deleted sections or added 

new type of entities). 

• Deletion of a versioned entity. 

• Change of UID attribute of an existing versioned entity or change of Name 

attribute in case of a Workspace entity. 

If MajorVersion is incremented, the user's .cui file will be replaced with an 

updated .cui file. 

The .cui file also contains versioned entities: Workspace, MenuMacro->Macro, Pop- 

Menu, Toolbar, AppButton, QuickAccessToolbar, RibbonPanelSource, and 

RibbonTabSource. Each versioned entity also has a node: 

<ModifiedRev MinorVersion="2"/> 

After a versioned entity is modified or created, FileVersion->MinorVersion must be 

incremented, and then the result must be assigned to ModifiedRev->MinorVersion of 

the modified entity. 



762 C H A P T E R   1 7  
 

 
Understanding the format of a .cui file 
A .cui file can contain settings for the following areas of the 4MCAD main win- 

dow: 

• Ribbon 

• Workspaces 

• Menus 

• Toolbars 

• Keyboard accelerators 

• Command aliases 
 

CUI file format 
 

 
FileVersion 

MajorVersion 4 byte integer Yes Major version of the .cui file. For details, see “Understanding 
versioning of a .cui file” on page 761 in this chapter. 

MinorVersion 4 byte integer Yes Minor version of the .cui file. For details, see “Understanding 
versioning of a .cui file” on page 761 in this chapter. 

IncrementalVersion 4 byte integer Yes Incremental version of the .cui file. For details, see “Understanding 
versioning of a .cui file” on page 761 in this chapter. 

UserVersion 4 byte integer Yes User version of the .cui file. For details, see “Understanding 
versioning of a .cui file” on page 761 in this chapter. 

AppButton The application button. 

UID Text Yes ID of an AppButton. Unique among all UIDs. 

LargeImage Text("0") No Image resource ID of AppButton’s icon or path to local file. 

LargeImageHighContrast Text("0") No Image resource ID of AppButton’s high contrast icon or path to 
local file. 

Name Text("") No Name or tooltip of an AppButton. 

AppButtonItem Regular command button or separator line. 

UID Text Yes ID of an AppButtonItem. Unique among all UIDs. 

MenuMacroID Text Yes/No ID of referenced MenuMacro. Not required in case of separator 
button. Required in all other cases. 

IsSeparator true/false(false) No Determines whether an item is a separator line or regular 
command button. 

AppButtonPopItem Sub-menu that contains a set of AppButtonItem items. 

UID Text Yes ID of an AppButtonPopItem. Unique among all UIDs. 

LargeImage Text("0") No Image resource ID of AppButtonPopItem's icon or path to local 
file. 

LargeImageHighContrast Text("0") No Image resource ID of AppButtonPopItem 's high contrast icon or 
path to local file. 

 
 

Item 
Values 
(Default Value) Required?  Description 
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CUI file format 

Values 
(Default Value) Item Required?  Description 

 

 

Name 

QuickAccessToolbar 

UID 

QuickAccessToolbarStandardItem 

UID 

Text("") 

 

 
Text 

 

 
Text 

No 

 

 
Yes 

 

 
Yes 

Name or tooltip of an AppButtonPopItem. 

The Quick Access Toolbar. 

ID of a Quick Access toolbar. Unique among all UIDs. 

Regular command button. 

ID of a QuickAccessToolbarStandardItem. Unique among all 

   UIDs. 

MenuMacroID Text Yes ID of referenced MenuMacro. 

Workspace   Consists of the following sections: WSPopRoot, WSToolbarRoot, 
and WSRibbonRoot. 

DefaultWorkspace true/false (false) No Whether a workspace is selected by default. 

Name Text Yes Name of workspace. 

WSPop   In-workspace declaration of a pop-menu. 

Display 0/1 (0) No Whether to display (1) or not to display (0) pop-menu in the 
MenuBar. 

pUID Text Yes UID of a referenced pop-menu. Unique among all UIDs. 

WSToolbar   In-workspace declaration of a toolbar. 

Display 0/1 (0) No Whether to display (1) or not to display (0) a toolbar. 

pUID Text Yes UID of a referenced toolbar. Unique among all UIDs. 

ToolbarOrient top/left/bottom/right 
(float) 

No Toolbar orientation. 

rows 4 byte integer (1) No Number of button rows for a toolbar. 

xval 4 byte integer (0) No X-coordinate of a toolbar (relative in case of docked toolbar). 

yval 4 byte integer (0) No Y-coordinate of a toolbar (relative in case of docked toolbar). 

In-workspace declaration of a ribbon tab. Consists of a set of 
WSRibbonPanelSourceReference items. 

Whether to show or not to show a ribbon tab. 

UID of a referenced ribbon tab. 

In-workspace declaration of a ribbon panel. 

Whether to show or not to show a ribbon panel. 

UID of a referenced ribbon panel. 

Ribbon panel definition. Consists of a set of RibbonRow items. 

ID of a RibbonPanelSource. Unique among all UIDs. 

Name of a RibbonPanelSource. 
 

RibbonSplitButton Ribbon button with sub-items. Consists of RibbonCommandButton 
items. 

UID Text Yes ID of a RibbonSplitButton. Unique among all UIDs. 
 

 

WSRibbonTabSourceReference 

 
Show 

  
 

true/false (false) 

 
 

No 

TabId 

WSRibbonPanelSourceReference 

 Text Yes 

    

Show  true/false (false) No 

PanelId 

RibbonPanelSource 

 Text Yes 

UID  Text Yes 

Name  Text Yes 
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Values 
(Default Value) Item Required?  Description 

 

 

ButtonStyle LargeWithText/ 
SmallWithoutText/ 
SmallWithText 
(SmallWithoutText) 

No Style of a button. 

RibbonCommandButton   Regular command button. 

UID Text Yes ID of a RibbonCommandButton. Unique among all UIDs. 

MenuMacroID Text Yes ID of referenced MenuMacro. 

ButtonStyle LargeWithText/ 
SmallWithoutText/ 
SmallWithText 
(SmallWithoutText) 

No Style of a button. 

RibbonSeparator   Ribbon Separator element. 

UID Text Yes ID of a RibbonSeparator. Unique among all UIDs. 

SeparatorStyle Line/Spacer 
(Spacer) 

No Separator style can be either a line or a spacer. 

RibbonControl   Ribbon control. Can be of one of these predefined types: color, 
linetype, lineweight, layer, print style, text style, or dimension style. 

UID rbnctrl-layer/ 
rbnctrl-color/ 
rbnctrl-linetype/ 
rbnctrl-lineweight/ 
rbnctrl-printstyle/ 
rbnctrl-textstyle/ 
rbnctrl-dimstyle 

Yes Unique among all UIDs. Any other UID is not allowed. 

RibbonTabSource   Ribbon tab definition. Consists of a set of 
RibbonPanelSourceReference items. 

UID Text Yes ID of a RibbonTabSource. Unique among all UIDs. 

Name Text Yes Name of a RibbonTabSource. 

MenuAccelerator    

UID Text Yes ID of a MenuAccelerator. Unique among all UIDs. 

MenuAccelerator.Accelerator    

KeyCombo.AccelChar Text ("") Yes Virtual key code. Use letters, digits ("A", "B", "C", ... , "1", "2", "3", 
... , "0"), functional key codes ("F1", "F2", "F3", ..., "F16"), Num- 
pad key codes ("NUM1", "NUM2", "NUM3", ..., "NUM0", "NUM*", 
"NUM+", "NUM-", "NUMDEL", "NUM/"), some other key codes 
("BACKSPACE", "PAUSE", "PAGEUP", "PAGEDOWN", 
"LEFTARROW", "UPARROW", "RIGHTARROW", 
"DOWNARROW", "INS", "DEL", "END", "HOME") 

KeyCombo.accKeys Text ("") Yes if 
previous 
is letter or 
digit 

Accelerator modifier. Following combinations are allowed: "CTRL", 
"ALT", "SHIFT", "CTRL+ALT", "ALT+CTRL",          
"SHIFT+CTRL", "CTRL+SHIFT", "ALT+SHIFT", "SHIFT+ALT", 
"CTRL+ALT+SHIFT", "CTRL+SHIFT+ALT", "ALT+SHIFT+CTRL", 
"ALT+CTRL+SHIFT", "SHIFT+CTRL+ALT", "SHIFT+ALT+CTRL" 

MenuItem.MacroRef.MenuMacroID Text ("") No ID of a macro to be bound to this accelerator 
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CUI file format 

Values 
(Default Value) Item Required?  Description 

 

 

MenuAlias 

UID 

 

Text 

 

Yes 

 

ID of a MenuAlias. Unique among all UIDs. 

Name Text Yes Name of an alias. 

Command Text Yes Command that is to be called for the alias. 

MenuGroup    

Name Text ("ICAD") No Name of a menu group. 

MenuMacro    

UID Text Yes ID of a MenuMacro. Unique among all UIDs. 

Macro.Name.ID 4 byte integer (0) No Text resource id of macro name. Used to extract localized text. 

Macro.Name Text ("") No Default macro name. 

Macro.ToolTip.ID 4 byte integer No Text resource id of macro tooltip. Used to extract localized text. 

Macro.ToolTip Text Yes Default macro tooltip. 

Macro.HelpString.ID 4 byte integer (0) No Text resource id of macro help string. Used to extract localized 
text. 

Macro.HelpString Text Yes Default macro help string. 

Macro.Command Text Yes Command of a macro. 

Macro.SmallImage 4 byte integer (0) No Image resource id of small icon or path to local file. 

Macro.LargeImage 4 byte integer (0) No Image resource id of large icon or path to local file. 

Macro.SmallImageHighContrast 4 byte integer (0) No Image resource id of small high contrast icon or path to local file. 

Macro.LargeImageHighContrast 4 byte integer (0) No Image resource id of large high contrast icon or path to local file. 

Macro.AcadToolbarConversion Text ("") No Used to extract MenuMacro icon. 
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CUI file format 

Values 
(Default Value) Item Required?  Description 

 

Macro.Visibility Text 
(CUI_DEFAULT) 

No Determines the visibility of MenuMacro, constructed as a comma- 
separated concatenation of the following values, calculated with a 
logical OR applied to all values: 
Visibility Value Description 

CUI_DOC_DWG   .dwg document 

CUI_DOC_DGN .dgn document 

CUI_DOC_ALL All types of documents 

CUI_LEV_BEG User level: Beginner 

CUI_LEV_INT User level: Intermediate 

CUI_LEV_EXP User level: Expert 

CUI_LEV_ALL User level: Any 

CUI_MDI_OPN MDI Window: At least one open 

CUI_MDI_CLS MDI Window: No MDI windows 

CUI_MDI_ALL MDI Window: Either MDI state 

CUI_OLE_SEM OLE: Server, embedded 

CUI_OLE_SIP OLE: Server, in-place 

CUI_OLE_CLI OLE: Client 

CUI_OLE_ALL OLE: Any OLE state 

CUI_VIS_ALL CUI_LEV_ALL,CUI_MDI_ALL,CUI_OLE_ALL 

CUI_SPL_RCM Context (right-click) menu only 

CUI_SPL_HIDE Hide this menu or button 

CUI_SPL_OSNAP Temporary osnap mode (shift right click when 

command is active) 

CUI_SPL_CTRL Button is a control] 

CUI_SPL_NOENT Ignore all entity visibility flags] 

CUI_DEFAULT Default visibility: 

 

CUI_LEV_ALL,CUI_MDI_OPN,CUI_MDI_CLS, 

CUI_OLE_CLI 
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CUI file format 

Values 
(Default Value) Item Required?  Description 

 

Macro.EntityVisibility 

 

Note that this item controls visibility of 
right-click menus, which are 
designed to display only when certain 
entities are in the right-click selection 
set. This item is only used when 
Macro.Visibility includes 
CUI.SPL.RCM. 

Text 
(RCM_ENT_ALL) 

No Determines the entity visibility of Menu.Macro, constructed as a 
comma-separated concatenation of the following values, 
calculated with a logical OR applied to all values: 
Entity Visibility 
Value Description 

RCM_ENT_PNT Point 

RCM_ENT_LIN Line 

RCM_ENT_RAY Ray 

RCM_ENT_XLN XLine 

RCM_ENT_ARC Arc 

RCM_ENT_CIR Circle 

RCM_ENT_ELL Ellipse 

RCM_ENT_SHP Shape 

RCM_ENT_TRC Trace 

RCM_ENT_SLD Solid 

RCM_ENT_3DF 3D Face 

RCM_ENT_3DS 3D Solid 

RCM_ENT_2DP 2D Polyline 

RCM_ENT_3DP 3D Polyline 

RCM_ENT_PFM   Polyface Mesh 

RCM_ENT_3DM 3D Mesh 

RCM_ENT_PLN All types of polylines: 

RCM_ENT_2DP,RCM_ENT_3DP, 

RCM_ENT_PFM,RCM_ENT_3DM 

RCM_ENT_TXT Text 

RCM_ENT_INS Insert 

RCM_ENT_ATD AttDef 

RCM_ENT_DIM Dimension 

RCM_ENT_LDR Leader 

RCM_ENT_TOL Tolerance 

RCM_ENT_SPL Spline 

RCM_ENT_MTX Mtext 

RCM_ENT_MLN Mline 

RCM_ENT_GRP   Group 

RCM_ENT_IMG Image 

RCM_ENT_VPT Viewport 

RCM_ENT_HAT Hatch 

RCM_ENT_RGN  Region 

RCM_ENT_BDY Body 

RCM_ENT_XRF Xreferences 

RCM_ENT_IFC IFC Underlay 

RCM_ENT_GMI GeoMap Image 

RCM_ENT_ACS All ACIS entities: 

RCM_ENT_3DS,RCM_ENT_RGN, 

RCM_ENT_BDY 

RCM_ENT_ALL Any entity 

RCM_ENT_MUL   Hide this item if multiple entities are selected 
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Values 
(Default Value) Item Required?  Description 

 

 

Macro.CheckedExpression Text ("") No Controls whether the button or menu item is in checked state 
based on value of the system variable. 

Macro.GreyedOutExpression Text ("") No Controls whether the button or menu item is grayed-out (disabled) 
based on the value of the system variable. 

Macro.HideExpression Text ("") No Controls whether the button or menu item is visible based on 
value of the system variable. 

DoubleClickAction    

UID Text Yes ID of a DoubleClickAction. Unique among all UIDs. 

DxfName Text Yes DXF name of an entity type to be bound to this double-click action. 

MenuItem.MacroRef.MenuMacroID Text ("") No ID of a macro to be bound to this double-click action. 

PopMenu    

UID Text Yes ID of a PopMenu. Unique among all UIDs. 

Alias Text Yes Language independent tear-off-name, usually "POPNN" where 
NN is a number. 

Name.ID 4 byte integer (0) No Text resource id of popup menu name. Used to extract localized 
menu name. 

Name Text Yes Default popup menu name. 

PopMenuItem    

IsSeparator true/false (false) No Defines whether the menu item is a separator. 

NameRef.ID 4 byte integer (0) No Text resource id of menu item name. Used to extract localized 
menu item name. 

NameRef Text ("") No Default menu item name. 

MenuItem.MacroRef.MenuMacroID Text ("") No Id of a macro to be bound to this menu item. 

PopMenuRef    

pUID Text Yes ID of a popup menu to be bound to this menu item as a sub-menu. 
Unique among all UIDs. 

ToolTip.ID 4 byte integer (0) No Text resource id of menu item tooltip. Used to extract localized 
text. 

ToolTip Text Yes Default menu item tooltip. 

HelpString.ID 4 byte integer (0) No Text resource id of menu item help string. Used to extract 
localized text. 

HelpString Text Yes Default menu item help string. 

Visibility Text 
(CUI_DEFAULT) 

No Determines the visibility of PopMenuRef, constructed as a 
comma-separated concatenation of values, calculated with a 
logical OR applied to all values. For details about available values, 
see “Visibility Value Description” on page 766 in this chapter. 
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CUI file format 

Values 
(Default Value) Item Required?  Description 

 

 

EntityVisibility Text 
(RCM_ENT_ALL) 

No Determines the entity visibility of PopMenuRef, constructed as a 
comma-separated concatenation of the values and calculated with 
a logical OR applied to all values. For details about available 
values, see “Entity Visibility Value Description” on page 767 in this 
chapter. 

CheckedExpression Text ("") No Controls whether the button or menu item is in checked state 
based on value of the system variable. 

GreyedOutExpression Text ("") No Controls whether the button or menu item is grayed-out (disabled) 

   based on the value of the system variable. 

HideExpression Text ("") No Controls whether the button or menu item is visible based on 
value of the system variable. 

Toolbar    

UID Text Yes ID of a Toolbar. Unique among all UIDs. 

ToolbarOrient float/top/left/right/ 
bottom (float) 

No Specifies toolbar orientation. 

ToolbarVisible hide/show (hide) No Specifies whether to show or hide toolbar. 

rows 4 byte integer (1) No Number of button rows for a toolbar. 

xval 4 byte integer (0) No X coordinate of a floating toolbar and zero-based position index of 
a docked toolbar. 

yval 4 byte integer (0) No Y coordinate of a floating toolbar and zero-based position index of 
a docking row for a docked toolbar. 

Name Text Yes Name of a toolbar. 

UseOwnIcon true/false (false) No Specifies whether to use single icon when toolbar is used as 
flyout. 

ToolbarButton    

UID Text Yes ID of a ToolbarButton. Unique among all UIDs. 

IsSeparator true/false (false) No Defines whether the button is a separator. 

NameRef.ID 4 byte integer (0) No Text resource id of button name. Used to extract localized button 
tooltip. 

NameRef Text ("") No Default button name and tooltip. 

MenuItem.MacroRef.MenuMacroID Text ("") No ID of a macro to be bound to this button. 

ToolbarFlyout    

pTargetId 8 byte integer Yes ID of a popup menu to be bound to this item as a fly-out. 

ToolTip.ID 4 byte integer (0) No Text resource id of tooltip. Used to extract localized text. 

ToolTip  Yes Default fly-out tooltip. 

HelpString.ID 4 byte integer (0) No Text resource id of help string. Used to extract localized text. 

HelpString Text Yes Default fly-out help string. 

SmallImage 4 byte integer (0) No Image resource id of small icon. 
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CUI file format 

Values 
(Default Value) Item Required?  Description 

 

 

LargeImage 

SmallImageHighContrast 

LargeImageHighContrast 

AcadToolbarConversion 

Visibility 

4 byte integer (0) 

4 byte integer (0) 

4 byte integer (0) 

Text ("") 

Text 

No 

No 

No 

No 

No 

Image resource id of large icon. 

Image resource id of small high contrast icon. 

Image resource id of large high contrast icon. 

Used to extract fly-out icon. 

Determines the visibility of the fly-out, constructed as a comma- 

 (CUI_DEFAULT)  separated concatenation of values, calculated with a logical OR 
applied to all values. For details about available values, see 
“Visibility Value Description” on page 766 in this chapter. 

EntityVisibility Text 
(RCM_ENT_ALL) 

No Determines the entity visibility of the fly-out, constructed as a 
comma-separated concatenation of the values and calculated with 
a logical OR applied to all values. For details about available 
values, see “Entity Visibility Value Description” on page 767 in this 
chapter. 

CheckedExpression Text ("") No Controls whether the button or menu item is in the checked state 
based on the value of the system variable. 

GreyedOutExpression Text ("") No Controls whether the button or menu item is grayed-out (disabled) 
based on the value of the system variable. 

HideExpression Text ("") No Controls whether the button or menu item is visible based on 
value of the system variable. 

ToolbarControl    

UID tlbctrl-color/ 
tlbctrl-linetype/ 
tlbctrl-lineweight/ 
tlbctrl-printstyle/ 
tlbctrl-textstyle/ 
tlbctrl- 
dimensionstyle 

Yes ID of an AppButton. Unique among all UIDs. Any other UID is not 
allowed. 

HelpString.ID 4 byte integer (0) No Text resource id of help string. Used to extract localized text. 

HelpString Text Yes Default control help string. 

Visibility Text 
(CUI_DEFAULT) 

No Determines the visibility of the toolbar, constructed as a comma- 
separated concatenation of the values, calculated with a logical 
OR applied to all values. For details about available values, see 
“Visibility Value Description” on page 766 in this chapter. 

 

Creating customized toolbar files manually 

With 4MCAD, the easiest way to share toolbars is to create a new .cui file using the 

Customize UI command and share that file with other 4MCAD users. For more 

details, see “Creating a new .cui file and copying settings” on page 759 in this chap- 

ter. 

You can also manually create toolbars that you can share by creating or modifying an 

.mnu file manually. 
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To manually create a toolbar that you can share 

1 Open any ASCII or Unicode text editor. 

2 Use the following toolbar syntax to type the toolbar definitions: 

***MENUGROUP=group_name 
 

***TOOLBARS 

**toolbar_name 

ID_toolbar_name [_Toolbar ("toolbar_name", orient, visible, xval, yval, rows)] 

ID_button_name [_Button ("button_name", id_small, id_large)]command 
 

***HELPSTRINGS 

ID_button_name [help_string] 

Toolbar syntax and explanations 
 

 
group_name Menu group name. 

toolbar_name Toolbar name. 

orient Orientation. Select Floating, Top, Bottom, Left, and Right (not case 
sensitive). 

visible Visibility. Select Show or Hide (not case sensitive). 

xval x coordinate, designated in pixels from left edge of screen. Suggested 
value: 200. 

yval y coordinate, designated in pixels from top edge of screen. Suggested 
value: 200. 

rows Number of rows 

button_name Tool name. Appears as a ToolTip when user places cursor over button. 

id_small Name of small (16 x 16 pixels) icon bitmap (BMP) file. This file must be 
located in the 4MCAD folder specified in Tools > Options > Paths. 

id_large Name of large (32 x 32 pixels) icon bitmap (BMP) file. This file must be 
located in the 4MCAD folder specified in Tools > Options > Paths. 

command Command string (Example: ^C^C_LINE). 

help_string Help string. Appears in the status bar when cursor passes over the button. 
 

 

 

3 Save the file to the 4MCAD folder with a *.mnu extension. 
 

Example Toolbar File Contents 

***MENUGROUP=example 

 

***TOOLBARS 

**NewDraw 

ID_ NewDraw [_Toolbar("NewDraw ", _Bottom, _Show, 200, 200, 1)] ID_Line_0 

[_Button("Line", Iline.bmp, IL_line.bmp)]^C^C_line ID_Hatch [_Button("Hatch", 

Ihatch.bmp, IL_hatch.bmp)]^C^C_hatch ID_Dtext [_Button("Dtext", Idtext.bmp, 

IL_dtext.bmp)]^C^C_dtext 

ID 0 [_Button("Circle Rad", Icirad.bmp, IL_cirad.bmp)]^C^Ccircle; 

Item Explanation 
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ID_Erase [_Button("Erase", Ierase.bmp, IL_erase.bmp)]^C^Cerase; 

 

***HELPSTRINGS 

ID_Line_0 [Creates straight line segments] 

ID_Hatch [Fills an enclosed area with a nonassociative hatch pattern] ID_Dtext 

[Displays text on screen as it is entered] 

ID 0 [Allows user to draw a circle with a radius value] ID_Erase [Removes 

objects from a drawing] 

 

To open the file on another computer 

1 Copy the toolbar (.mnu) file and all related custom bitmap (*.bmp) files to the 

4MCAD folder on the other computer. 

2 Open 4MCAD. 

3 Do one of the following to choose Customize UI (  ): 

• On the ribbon, choose Tools > Customize UI (in Manage). 

• On the menu, choose Tools > Customize UI. 

• Type cui and press Enter. 

4 Click the Transfer tab. 

5 On the left, click Open. 

6 Select the new toolbar file, then click Open. 

7 Click OK. 
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Customizing entities 
 

4MCAD provides ways to customize entities beyond common formats, dimen- 

sions, and layers. Further customization includes using custom audio notes and using 

custom shape files. 

 

Working with audio notes 
In 4MCAD you can record and attach audio notes, which are sound clips attached to 

entities and available for playback at any time. For example, audio notes in a fac- 

tory floor plan can describe maintenance activities for specific areas of the factory 

and employees can play the audio notes to hear instructions. 

When you include audio notes in your drawing, they are saved in the drawing file — 

not in a separate audio file. Note that this can increase the file size of your drawing. 

Audio notes created from an existing *.wav file are also saved in the drawing file and 

the separate *.wav file remains unchanged. 

You can play audio notes in 4MCAD only. 

 
Attaching audio notes 
Audio notes can be created from existing *.wav files. You can also record an audio 

note using any microphone that works with your computer. Many computers have a 

built-in microphone. If you do not have a microphone and you record an audio note, 

the audio note will contain no sound. 

An audio note icon displays on entities that have attached audio notes. The icon is for 

display only and cannot be selected. 
 

To record and attach an audio note to entities 

1 Do one of the following to choose Audio Note ( ): 

• On the ribbon, choose Tools > Audio Note (in Manage). 

• On the menu, choose Tools > Audio Note. 

• On the Tools toolbar, click the Audio Note tool. 

• Type audionote and then press Enter. 

2 Select the desired entities, and then press Enter. 

3 Choose Record. 

4 Click Record to begin the audio note, and then speak into the microphone. 

5 Click Stop to end the audio note. 

6 To test the audio note, click Test, and then use Pause and Stop in the Test Audio 

Note area. 

7 If necessary, you can record the audio note again. This overwrites the previous 

audio note for the entities you selected in Step 2. 

8 Click Attach. 
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You can modify an audio note after you attach it to an entity. 

Select the entity and re-record the audio note using the previous steps. 
 

 

 
To attach an audio note to entities using a .wav file 

1 Do one of the following to choose Audio Note ( ): 

• On the ribbon, choose Tools > Audio Note (in Manage). 

• On the menu, choose Tools > Audio Note. 

• On the Tools toolbar, click the Audio Note tool. 

• Type audionote and then press Enter. 

2 Select the desired entities, and then press Enter. 

3 Choose Attach. 

4 Select the desired *.wav file, and then click Open. 

 
Selecting audio notes 
Audio notes themselves cannot be selected. Instead, you select the entity that corre- 

sponds to the desired audio note. 

An audio note icon displays on entities that have attached audio notes. The icon is for 

display only and cannot be selected. 

 

 

An audio note icon displays on an entity, signifying that an audio note 
is attached to the entity. 

To select audio notes 

1 Do one of the following to choose Audio Note ( ): 

• On the ribbon, choose Tools > Audio Note (in Manage). 

• On the menu, choose Tools > Audio Note. 

• On the Tools toolbar, click the Audio Note tool. 

• Type audionote and then press Enter. 

2 Select the entity that is attached to the desired audio note, and then press Enter. 

You cannot select the audio note icon that displays on the entity. 

3 Choose an option to continue working with audio notes. 
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Use the system variables. 

You can change the appearance of audio note icons using the AUDIOICON, AUDIO- 

ICONCOLOR, and AUDIOICONSCALE system variables. 
 

 

 
Playing audio notes 

To play audio notes 

1 Do one of the following to choose Audio Note ( ): 

• On the ribbon, choose Tools > Audio Note (in Manage). 

• On the menu, choose Tools > Audio Note. 

• On the Tools toolbar, click the Audio Note tool. 

• Type audionote and then press Enter. 

2 Select the entity that has the audio note you want to play, and then press Enter. 

3 Choose Playback. 

4 In the Playback dialog box, do the following: 

• Click Play to begin playback. 

• To pause the audio note temporarily, click Pause and then click Resume to 

continue. 

• Click Stop to end playback. 

5 Click OK. 

 
Deleting audio notes 
You can remove audio notes from selected entities. In some cases, you may want to 

remove extra audio notes to reduce the drawing file size. 

When you remove an audio note from an entity, the audio note is removed perma- 

nently and cannot be recovered. However, if the audio note was created using an 

existing *.wav file, that *.wav file is not removed. 
 

To delete audio notes 

1 Do one of the following to choose Audio Note ( ): 

• On the ribbon, choose Tools > Audio Note (in Manage). 

• On the menu, choose Tools > Audio Note. 

• On the Tools toolbar, click the Audio Note tool. 

• Type audionote and then press Enter. 

2 Select entities that have the audio notes you want to delete, and then press Enter. 

3 Choose Delete. 
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Using shape files 
Shapes are entities that you define for use as drawing symbols and text fonts. You can 

specify the scale and rotation to use for each shape as you add it. 

To use shape files, you first load the compiled shape file that defines the shape. Then 

you use insert shapes from the file into your drawing. 
 

To load a shape file 

1 Type load and then press Enter. 

2 In the Load Shape File dialog box, select a shape file. 

3 Click OK to close the Load Shape File dialog box. 
 

To use a shape file 

1 Type shape and then press Enter. 

2 Type a shape name and press Enter. 

3 Specify an insertion point. 

4 Specify a height. 

5 Specify a rotation angle. 
 
 

 

Creating and replaying scripts 
 

4MCAD can record anything you type on the keyboard and any points you select in 

a drawing. You can save all of these actions to a script file (with the *.scr exten- 

sion) and then repeat them by replaying the script. You can use scripts for succes- 

sively repeating commands, showing snapshots in a slide show, or batch printing. 

You can also load and run script files created for use with AutoCAD. 

 

Understanding scripts 
4MCAD supports most AutoCAD customization files, including menus, script files, 

and LISP routines. 4MCAD uses compatible linetypes, hatch patterns, units 

translation, and command aliases, but you can also substitute your own files for these. 

This feature allows you to continue to work with your favorite customized drafting 

environment. 

A script is a form of text file. A script file contains one line of text or other data for 

each action. For example, when you type a command and press Enter, it is recorded 

on a line in the script file. When you select a point in a drawing, the coordinate of that 

point is recorded on a line in the script file. You can also create script files outside 

4MCAD using a text editor (such as Microsoft® Notepad or Microsoft® WordPad) 

or a word-processing program (such as Microsoft® Word) that saves the file in ASCII 

format. The file type and extension must be .scr. 
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Script files can contain comments. Any line that begins with a semicolon is consid- 

ered a comment. The program ignores these lines when replaying the script. The 

Undo feature reverses the last command performed by the script. 

4MCAD improves on scripts, AutoLISP, and ADS by providing additional func- 

tions. For scripts, 4MCAD includes a Script Recorder that records both command 

line entries and screen picks you make with your mouse. 

 

Recording scripts 

After you activate the Script Recorder, every keyboard entry you make and any 

points you select in a drawing are recorded until you stop the Script Recorder. You 

can play back your script at any time. 

 
 

CAUTION 

The Script Recorder does not record your use of toolbars, menus, or dialog boxes. 

Using these elements while recording a script causes unpredictable results. 
 

 

 
To record a script 

1 Do one of the following to choose Record Script (  ): 

• On the ribbon, choose Tools > Record Script (in Applications). 

• On the menu, choose Tools > Record Actions > Record Script. 

• On the Tools toolbar, click the Record Script tool. 

• Type recscript and then press Enter. 

2 Specify the name of the script file you want to create. 

3 Click Save. 

4 Type commands on the keyboard. 

The Script Recorder records all keyboard entries and all points you select in the 

drawing, saving everything to the script file. 

 

To stop recording 

1   Do one of the following to choose Stop Recording (  ): 

• On the ribbon, choose Tools > Stop Recording (in Applications). 

• On the menu, choose Tools > Record Actions > Stop Recording. 

• On the Tools toolbar, click the Stop Recording tool. 

• Type stopscript and then press Enter. 
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Replaying scripts 

To replay a script 

1 Do one of the following to choose (  ): 

• On the ribbon, choose Tools > Run Script (in Applications). 

• On the menu, choose Tools > Record Actions > Run Script. 

• On the Tools toolbar, click the Run Script tool. 

• Type script and then press Enter. 

2 In the Run Script dialog box, specify the name of the script file you want to run. 

3 Click Open. 

The program immediately runs the script, performing all the actions originally 

recorded. 
 

 

Double-click a script file. 

To invoke a script automatically when you load 4MCAD, in Windows Explorer, 

double-click a script file. 
 

 

 

Modifying scripts 

To append to a script 

1 Do one of the following to choose Record Script (  ): 

• On the ribbon, choose Tools > Record Script (in Applications). 

• On the menu, choose Tools > Record Actions > Record Script. 

• On the Tools toolbar, click the Record Script tool. 

• Type rescript and then press Enter. 

2 In the Record Script dialog box, select the Append To Script check box. 

3 Select the existing script file to append. 

4 Click Save. 

5 Click Yes to the prompt asking whether you want to replace the existing script. 

6 Repeat the procedure to enter additional commands and steps. 
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Programming 4MCAD 
 

Another way you can customize 4MCAD is to add custom programs written in any of 

several programming languages that run within 4MCAD, including the follow- ing: 

TX, .NET, LISP, SDS, DCL, VBA, and DIESEL. 

In 4MCAD, you can run many programs originally created for use with AutoCAD. 

Specifically, you can use programs written entirely in AutoLISP with no modifica- 

tion. In addition, you can run many ADS programs originally written for use with 

AutoCAD after first recompiling them using the 4MCAD run-time libraries. Many 

AutoCAD third-party programs are compatible with 4MCAD. 

 
 

Use the online Help. 

For information about programming for 4MCAD, see the online Help for the 4MCAD 

Developer’s Reference. 
 

 

 

Using TX 
The TX interface is available for developers to create custom entities and applica- 

tions. 
 

To load a TX/IRX custom application 

Advanced experience level 

1 Do one of the following: 

• On the ribbon, choose Tools > Load Application (in Applications). 

• On the menu, choose Tools > Load Application. 

• Type appload and then press Enter. 

• Drag and drop the TX or IRX file into 4MCAD. 

2 In the Load Application Files dialog box, click Add File. 

3 Select the TX or IRX file that you want to load, and then click Open. 

4 Click OK. 
 

To run a TX/IRX custom application 

Advanced experience level 

1 Do one of the following: 

• On the ribbon, choose Tools > Load Application (in Applications). 

• On the menu, choose Tools > Load Application. 

• Type appload and then press Enter. 

2 In the Load Application Files dialog box, choose the routine you want to run 

(make sure that it is the only one selected), and then click Load. 
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For more information 

• See the sample TX and IRX applications. 

• Read the online documentation for TX and IRX, available in the Developer Refer- 

ence of 4MCAD Help. 

 

Using .NET applications 
4MCAD supports the .NET programming language in two ways: 

• .NET Classic — More closely matches the .NET interface used by AutoCAD. 

• .NET based on COM — Initial .NET interface supported by 4MCAD. 
 

To prepare a .NET custom application 

1   In the .NET application, inherit the IICadPlugin interface that is defined in 

4MCAD as: 

public interface IIcadPlugin 
 

{ 
 

void PluginLoaded(object sender, EventArgs e); void 

PluginUnLoading(object sender, EventArgs e); 

} 

Where PluginLoaded() is called on plug-in load, the sender argument is a COM 

Interop model class 4MCAD.Application for working with (storing it as a class 

member), and PluginUnLoading()is called right before the plug-in is unloaded. 
 

To load a .NET Classic custom application 

1 Do one of the following: 

• On the menu, choose Tools > Load Classic .NET Application. 

• Type netload and then press Enter. 

2 In the Open an Assembly dialog box, select the .NET .dll file that you want to 

load, and then click Open. 

 

To automatically load a .NET Classic custom application when 4MCAD starts 

1 Create an ASCII file named ICAD.NET that contains the path to a .NET plug-in 

file on each line of the file. 

2 Place ICAD.NET in the same folder as ICAD.EXE. 

3 Run 4MCAD. 

 

Using LISP routines 
4MCAD supports the LISP programming language and is compatible with 

AutoLISP, the implementation of the LISP language in AutoCAD. This means that 

you can load and run any AutoLISP program written for use with AutoCAD. 
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To load a LISP routine 

Advanced experience level 

1 Do one of the following: 

• On the ribbon, choose Tools > Load Application (in Applications). 

• On the menu, choose Tools > Load Application. 

• Type appload and then press Enter. 

• Drag and drop the LISP file into 4MCAD. 

2 In the Load Application Files dialog box, click Add File. 

3 Select the LISP file that you want to load, and then click Open. 

4 Click OK. 
 

 

Load LISP routines from the command bar. 

In the command bar, type (load “d:/path/routine.lsp”), making sure to include the 

parentheses and the quotation marks, where d:/path is the drive and path where the 

LISP routine is located on your computer, and routine.lsp is the LISP routine file 

name. 
 

 

 
To run a LISP routine 

Advanced experience level 

1 Do one of the following: 

• On the ribbon, choose Tools > Load Application (in Applications). 

• On the menu, choose Tools > Load Application. 

• Type appload and then press Enter. 

2 In the Load Application Files dialog box, choose the routine you want to run 

(make sure that it is the only one selected), and then click Load. 

Some LISP routines are created in such a way that you can run them by simply typing 

the name of the routine, or by typing a keyword, directly in the command bar. If noth- 

ing happens when you attempt to run the LISP routine from within the Load Applica- 

tion Files dialog box, turn on the display of the command bar or Prompt History 

window by choosing View > Display > Command Bar or View > Display > Prompt 

History Window, and look for an entry that is similar to the following: 

Loading D:\path\routine.lsp 

C:KEYWORD 

where D:\path\routine.lsp is the complete drive, path, and file name of the LISP rou- 

tine. You may need to scroll back several lines in the command bar or Prompt History 

window to find the lines indicating where the LISP routine was loaded. You can run 

the LISP routine by typing the name of the routine or keyword appearing after the C 

drive designation. 
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For example, if you loaded a LISP routine named drawbox.lsp and see the designa- 

tion C:DRAWBOX in the command bar or Prompt History window, you can run the 

LISP routine by typing drawbox in the command bar. 

 

Using SDS applications 
To write AutoCAD applications in C or C++, Autodesk® uses the ADS (AutoCAD 

Development System). This is an API (applications programming interface) that pro- 

vides a library to access AutoCAD-specific functions and drawing data. 

The equivalent in 4MCAD is called SDS™, the Solutions Development System™. 

SDS is a C/C++ language interface compatible with the ADS interface in AutoCAD. 

Like scripts and AutoLISP, you can run your existing ADS applications in 4MCAD. 

Simply recompile the source code using the SDS libraries provided on the 4MCAD 

CD-ROM, or, if you use an AutoCAD program written by a third- party vendor, 

contact that vendor for the 4MCAD version. 

4MCAD provides the Sds.H file, which redefines ADS function names to their SDS 

equivalents. SDS supports the AutoCAD dialog control language (DCL), which is 

used by ADS to define the look of a dialog box. You can use all DCL files unmod- 

ified within SDS. 

 
Understanding SDS compatibility 
The primary difference between ADS and SDS is that all SDS functions have an sds_ 

prefix, and ADS functions have a variety of prefixes, such as ads_, acad_, and acrx_. 

The exception is dialog-related SDS functions, which have a dlg_ prefix. 4MCAD 

accepts either prefix. Other differences include the additional SDS functions listed in 

the following table. 

 
SDS functions with no ADS equivalent 

 

 
sds_grclear Clears all graphics from the drawing window; similar to the LISP 

(grclear) function. 

sds_name_clear Clears the entity name or selection set. 

sds_name_equal Verifies whether two entity names or selection sets are equal. 

sds_name_nil Verifies whether the entity name or selection set has been 
cleared. 

sds_name_set Copies one entity name or selection set to another drawing. 

sds_pmtssget Similar to the ads_ssget function, but allows you to display a 
prompt appropriate for the specific command, rather than the 
generic “Select object” prompt. 

sds_point_set Copies a point from one variable to another. 

sds_progresspercent Displays the percentage done in a progress bar. 

sds_progressstart Starts the progress bar. 

sds_progressstop Ends the progress bar. 

SDS function name Description 
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SDS functions with no ADS equivalent 

 

 
sds_readaliasfile Loads the PGP file into 4MCAD. 

sds_sendmessage Sends a message to the 4MCAD command line. 

sds_swapscreen Flips the off-screen device context to the display. 

 

Some ADS functions are not supported in SDS, including: ads_arxload, 

ads_arxloaded, ads_arxunload, ads_ssgetx, ads_ssGetKwordCallbackPtr, 

ads_ssGetOtherCallbackPtr, adsw_acadMainWnd, and adsw_acadDocWnd. 
 

For more information 

• Read the online documentation for SDS functions. 

• See the \4MCAD\Api\Sds folder, which contains the SDS include, header, and 

library files. 

• See the \4MCAD\Api\Dcl folder, which contains the core DCL files. 

SDS function name Description 
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Using DDE applications 
4MCAD supports the DDE API, which allows you to execute 4MCAD commands at 

the command line from an external application. 4MCAD includes a sample 

command-line application that reads a script file and sends it to 4MCAD for step-by-

step execution. 
 

To see a sample of DDE script execution 

1 Compile the source code of the DDESample project. The sample application is 

located at: 

Source\4MCAD\api\DDE\Samples\DDESample 

2 Run 4MCAD. 

3 Run the DDESample application with the sample script file that is included in the 

VC project. 

4MCAD shows the results. 

 
Using DCL with 4MCAD 

4MCAD completely supports the AutoCAD DCL (dialog control language). DCL is 

used by AutoLISP functions to define the look of dialog boxes. You can use all DCL 

files unmodified within 4MCAD. 

 

Using VBA 
4MCAD can be customized using Visual Basic for Applications (VBA) through an 

integrated interface, available from the 4MCAD Tools menu. 4MCAD features a 

broad range of objects, giving you the power to write your own custom applications 

that can run within 4MCAD. 
 

To load a VBA project 

Advanced experience level 

1 Do one of the following: 

• On the ribbon, choose Tools > Load VBA Project (in Applications). 

• On the menu, choose Tools > Visual Basic > Load VBA Project. 

• Type vbiload and then press Enter. 

2 Locate and select the Visual Basic project file (.vbi file) to load, then click Open. 
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To run a VBA macro 

Advanced experience level 

1 Do one of the following: 

• On the ribbon, choose Tools > Macros (in Applications). 

• On the menu, choose Tools > Visual Basic > Macros. 

• Type vbarun and then press Enter. 

2 In the Run 4MCAD VBA Macro dialog box, enter the name of an existing VBA 

macro, and then click Run. 

You can also create, delete, and edit VBA macros from this dialog box. 
 

To edit a VBA macro 

Advanced experience level 

1 Do one of the following: 

• On the ribbon, choose Tools > Visual Basic Editor (in Applications). 

• On the menu, choose Tools > Visual Basic > Visual Basic Editor. 

• Type vba and then press Enter. 

2 Use the Visual Basic Editor to write or debug VBA macros. 
 

For more information 

• Read the online documentation for VBA, available from the editor Help menu and 

from the 4MCAD Help menu. 

• Many publications are available that explain how to program in VBA. 

 

Using DIESEL with 4MCAD 
4MCAD supports AutoCAD DIESEL (Direct Interactively Evaluated String 

Expression Language). DIESEL is a separate interpretive programming language that 

allows you to customize the following: 

• Status bar 

• Menus 

• LISP functions 

For more information 

• Read the online documentation for DIESEL, available from the 4MCAD Help. 

• Several publications and tutorials are available online that explain how to use 

DIESEL. 
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Using a digitizer tablet 
 

4MCAD supports tablets compatible with the TabletWorks driver and has its own 

tablet overlay. For instructions on installing the tablet driver and using the buttons on 

your pointing device, refer to your hardware documentation. 

Three options are available with the Tablet command: 

• Configure Maps the tablet overlay to the tablet itself. Configure the tablet if you 

plan to select 4MCAD tools from the tablet overlay. 

• Calibrate Maps points on the tablet, in absolute coordinates, to points on a draw- 

ing. Calibrate the tablet if you intend to digitize points. This process is convenient 

for tracing paper drawings. 

• Tablet ON/OFF Turns tablet calibration (digitizer mode) on and off. Use this to 

switch between tool selection and digitizer input. To use the tablet for tool selec- 

tion, tablet mode must be turned off. 

 

Configuring the tablet 
Before you begin to configure the tablet, slip the tablet overlay underneath the tab- 

let’s plastic cover, and align it in accordance with the directions for your tablet. If 

your tablet does not have a plastic cover, align the overlay holes with the pegs on 

your tablet. 

4MCAD provides a default configuration for tablets measuring 12" by 12". If you 

choose to accept the default, be sure to verify that the commands in the grid are acti- 

vated correctly. If the default alignment does not work for your tablet, you’ll need to 

begin the configuration process again and align the tablet yourself. 
 

To configure the tablet for menu input 

1 Do one of the following: 

• On the menu, choose Tools > Tablet > Configure. 

• Type tablet, choose Configure, and then press Enter. 

2 In response to the prompt to align the tablet, do one of the following: 

• If your tablet is 12" by 12", choose No to accept the default alignment and 

conclude the configuration process. 

• To align the tablet yourself, choose Yes, and then continue with step 3. 

3 Click the tablet pointer on the upper left alignment point of the overlay (). 

4 Click the tablet pointer on the lower left alignment point of the overlay (). 

5 Click the tablet pointer on the lower right alignment point of the overlay (). 

6 Click the tablet pointer on the lower left alignment point of the Workspace area of 

the overlay (). 
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5 

 
4 

3 

 

7 Click the tablet pointer on the upper right alignment of the Workspace area of the 

overlay (). 
 

 
Click points in the order shown to configure your tablet for menu input. 

 

To turn tablet mode on or off 

1   Do one of the following: 

• Choose Tools > Tablet > Tablet On (or Tablet Off). 

• Type tablet, choose On or Off, and then press Enter. 

• Press the F4 key to toggle tablet mode on or off. 

• On the status bar, double-click TABLET to turn tablet mode on or off. 

 
Calibrating the tablet 
You must specify at least two points for tablet calibration. However, the more points 

you specify, the more accurate the transformation between the tablet and the screen 

points. Specifying additional points is particularly useful if you plan to trace a paper 

drawing that is not orthogonal, such as an aerial photograph. 

 

Understanding transformation types 

Depending on the number of points specified, you have a choice of transformation 

types to use, along with the type recommended for 4MCAD. 

Transformation refers to the calculation of the points on the screen that correspond to 

points you digitize on the tablet. 

• Orthogonal Preserves all angles between lines, preserves all relative distances, 

and, in general, preserves shapes. If you specify only two points, an orthogonal 

transformation is automatically generated. The orthogonal transformation type 

yields the most precise mapping between the digitized points on the tablet and the 

corresponding points on the screen. 

1 

2 
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3 

4 

 

• Affine Preserves parallel lines, but not necessarily the angles between intersecting 

lines. If you specified three points, 4MCAD can no longer represent this map- 

ping as an exact orthogonal transformation. Therefore, you have a choice of an 

exact affine transformation or a “best fit” orthogonal transformation. 

• Projective Does not preserve parallel lines or angles. If you specify exactly four 

points, you have a choice of an exact projective transformation or a “best fit” 

orthogonal or affine transformation. 
 

Recommended and “best fit” transformation types 
 

 
2 Orthogonal None 

3 Affine Orthogonal 

4 Projective Orthogonal, Affine 

5-10 None Orthogonal, Affine 
 

 

 

Choose the recommended type unless you know it will not be appropriate for what 

you are digitizing. The most appropriate type is not always the one with the least 

error; for example, you might digitize three points and select the orthogonal transfor- 

mation, even though the affine transformation would yield a closer representation of 

your calibration entries. 

 

  
Digitizing by selecting points (1, 2, 3, and 4) on the tablet. Corresponding screen coordinates: 

1 Coordinate specification X0, Y0, Z0 

2 Coordinate specification X0, Y5, Z0 

3 Coordinate specification X5, Y5, Z0 

4 Coordinate specification X5, Y0, Z0 

2 3 

1 4 

2 

1 

Transformation type 
Number of points specified recommended “Best fit” (approximate) 
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Screen result of orthogonal transformation after 
tracing polyline on tablet. 

Screen result of affine transformation 
after tracing polyline on tablet. 

Screen result of projective transformation after 
tracing polyline on tablet. 

 

To calibrate your tablet for digitizing points 

1 Do one of the following: 

• Choose Tools > Tablet > Calibrate. 

• Type tablet, choose Calibrate, and then press Enter. 

2 Click a point on the tablet to define as the first calibration point. 

3 Specify a point within the 4MCAD drawing window to correspond to the point 

you digitized on the tablet, or enter coordinate values in the command bar. 

4 Click a point on the tablet to define as the second calibration point. 

Specify a point within the 4MCAD drawing window to correspond to the point 

you digitized on the tablet, or enter coordinate values in the command bar. To 

specify more than the two points required, click a point on the tablet to define as 

the third calibration point. You can enter up to 10 points. 

5 Choose the transformation type, and then press Enter. 

 

Customizing the tablet interface 
You can customize the digitizer tablet interface by using the LISP commands 

integrated with 4MCAD, even if you are not familiar with LISP. For instructions, 

see “Customizing the Tablet Interface” in the 4MCAD online Help. 
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Understanding AutoCAD compatibility 
 

4MCAD was designed to interface with AutoCAD as seamlessly as possible. There 

are, however, some differences for which those accustomed to working in AutoCAD 

may need to adjust. This appendix provides information specifically for that audi- 

ence. 

 
 
 
 
 
 

 
 
 
 
 
 
 
 
 

 
 
 
 
 

Appendix 



792 A P P E N D I X 
 

 
Using enhanced AutoCAD commands in 4MCAD 
 

4MCAD enhances several AutoCAD commands by providing more options. For 

example, if you hold down the Shift key, 4MCAD is placed temporarily in orthog- 

onal mode, which you will find to be a useful feature for drawing at right angles. The 

following table lists examples of other commands with enhanced options. 

 
Enhanced 4MCAD commands 

 

 
circle Arc Converts an arc to a circle. 

donut 2point Determines the outside diameter of a donut by 
two pick points. 

donut 3point Determines the outside diameter of a donut by 
three pick points. 

donut RadTanTan Determines the outside diameter of a donut by 
tangent points. 

line Angle Draws a line by angle, followed by a length. 

line Length Draws a line by a length, followed by an angle. 

msnapshot (mslide) and 
vsnapshot (vslide) 

msnapshot (mslide) and 
vsnapshot (vslide) 

EMF Saves and views screen images in enhanced 
metafile format. 

WMF Saves and views screen images in Windows 
metafile format. 

parallel (offset) Both sides Copies an entity parallel on both sides. 

plane (solid) Rectangle Draws a rectangular solid at any angle. 

plane (solid) Square Draws a square solid at any angle. 

plane (solid) Triangle Draws an equilateral solid at any angle. 

rectangle Square Draws a square rectangle. 

rectangle Rotated Draws a rotated rectangle. 
 

 

Command 
Enhanced 
option name Explanation 
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Using additional selection sets 
 

4MCAD has additional selection-set options not found in AutoCAD. In particular, in 

the circle selection set, the Crossing Circle (CC), Outside Circle (OC), and Win- 

dow Circle (WC) options select all entities relative to the same distance (radius) of a 

central pick point. 

The following table lists and describes the additional selection sets in 4MCAD. 

 
Additional selection set options 

 

 
CC Crossing Circle: Selects all entities within and crossing a circular area. 

D Selection method: Displays the Drawing Settings dialog box. 

O Outside Window: Selects all entities outside a rectangular area; this is the 
inverse of the Crossing Circle option. 

OC Outside Circle: Selects all entities outside a circular area. 

OP Outside Polygon: Selects all entities outside a polygonal area; this is the 
inverse of the CP (Crossing Polygon) and WP (Window Polygon) options. 

PRO Properties: Selects all entities with specific properties, such as area, color, 
and layer. 

WC Window Circle: Selects all entities within a circular area. 
 

 

Selection mode Description 
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Using additional 4MCAD commands 
 

Although you can use the AutoCAD command structure with 4MCAD, the pro- 

gram has its own set of commands. 4MCAD has numerous command names not 

found in AutoCAD, although many of these commands have an equivalent function 

in AutoCAD. When you type the AutoCAD equivalent, the 4MCAD alias system 

activates the correct command. 

For example, the AutoCAD offset command is mapped to the 4MCAD parallel 

command. You can type either offset or parallel in the command bar, or you can 

choose Modify > Parallel. 

The following table lists optional 4MCAD command names that you can use in 

place of AutoCAD command names to perform the equivalent AutoCAD function. 

 
Command differences in 4MCAD 

 

4MCAD command AutoCAD 2007 command AutoCAD 2000/R14 command Action in 4MCAD 

audionote No equivalent No equivalent Creates and plays audio notes 
attached to entities. 

cmdbar No equivalent No equivalent Positions the command 
window. 

coordinate Ctrl+D or F6 Ctrl+D or F6 Changes the display of 
coordinates on the status line. 

copyedata No equivalent No equivalent Copies extended entity data 
from one entity to another. 

customize toolbar toolbar Displays the Customize dialog 
box. 

deledata No equivalent No equivalent Deletes extended entity data 
from an entity. 

delete erase erase Removes entities from the 
drawing. 

dimension dim dim Switches to dimension mode. 

editedata No equivalent No equivalent Edits extended entity data 
found in an entity. 

editlen lengthen lengthen Changes the length of open 
entities. 

editpline pedit pedit Edits polylines and 
polymeshes. 

entprop ddmodify and ddchprop ddmodify and ddchprop Displays the Entity Properties 
dialog box. 

esnap -osnap -osnap Sets entity snaps from the 
command line. 

expblocks ddinsert ddinsert Displays the 4MCAD 
Explorer - Blocks. 
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Command differences in 4MCAD (continued) 

 

 

4MCAD command AutoCAD 2007 command AutoCAD 2000/R14 command Action in 4MCAD 

expdimstyles ddim ddim Displays the 4MCAD 
Explorer - Dimension Styles. 

expfonts style style Displays the 4MCAD 
Explorer - Styles. 

explayers layer layer Displays the 4MCAD 
Explorer - Layers. 

explorer ddrename ddrename Displays the 4MCAD 
Explorer. 

expltypes linetype linetype Displays the 4MCAD 
Explorer - Linetypes. 

expucs dducs dducs Displays the 4MCAD 
Explorer - UCS. 

expviews ddview ddview Displays the 4MCAD 
Explorer - Views. 

face 3dface 3dface Draws three-dimensional faces 
with three or four vertices. 

flatten No equivalent No equivalent Sets thickness to zero at user- 
specified elevation. 

font -style -style Displays the Text Style dialog 
box. 

freehand sketch sketch Allows freehand sketching. 

idpoint id id Returns the x-, y-, and z- 
coordinates of a picked point. 

infline xline xline Draws a line of infinite length. 

join pedit join pedit join Joins lines and arcs. 

mesh 3dmesh 3dmesh Draws a surface mesh. 

moveedata No equivalent No equivalent Moves extended entity data 
from one entity to another. 

msnapshot mslide mslide Makes an SLD, EMF, or WMF 
file of the current view. 

orthogonal ortho ortho Toggles orthogonal mode. 

parallel offset offset Copies an entity by a parallel 
offset distance. 

plane solid solid Draws a two-dimensional solid 
plane. 

pmthist F2 F2 Switches between the Prompt 
History window and the 
graphics screen. 

polyline pline pline Draws a polyline. 

ppreview preview preview Previews the print. 

print plot plot Prints the drawing. 
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Command differences in 4MCAD (continued) 

 

4MCAD command AutoCAD 2007 command AutoCAD 2000/R14 command Action in 4MCAD 

printstyle plotstyle printstyle (not applicable before 
AutoCAD 2000) 

Assigns a print style. 

psetup No equivalent No equivalent Displays the Print Setup dialog 
box. 

qprint No equivalent No equivalent Quickly prints the current 
viewport (window) with no 
options. 

reassocapp No equivalent No equivalent Reassociates extended entity 
data with an application. 

recscript No equivalent No equivalent Starts the Script Recorder. 

rtrot 3dorbit No equivalent Rotates the view of entities. 

rtrotx No equivalent No equivalent Rotates the view of entities 
while maintaining the x-axis. 

rtroty No equivalent No equivalent Rotates the view of entities 
while maintaining the y-axis. 

rtrotz 3dorbit No equivalent Rotates the view of entities 
while maintaining the z-axis. 

saveall No equivalent No equivalent Saves all currently open 
drawings. 

setcolor color ddcolor Displays the Color dialog box. 

setdim ddim ddim Displays the Dimension Styles 
dialog box. 

setesnap osnap osnap Displays the Drawing Settings 
dialog box with the Coordinate 
Input tab displayed. 

setlayer ai_molc ai_molc Sets the current layer based 
on the selected entity’s layer. 

settings No equivalent No equivalent Displays the Drawing Settings 
dialog box. 

setucs dducs dducs Displays the User Coordinate 
Systems dialog box. 

setvpoint No equivalent No equivalent Displays the Preset Viewpoints 
dialog box. 

stopscript No equivalent No equivalent Stops running the script. 

tipofday No equivalent No equivalent Displays the Tip of the Day. 

undelete oops oops Restores the last deleted 
entity. 

vba vbaide vbaide Opens the Visual Basic 
Applications editor. 
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Command differences in 4MCAD (continued) 

 

 

4MCAD command AutoCAD 2007 command AutoCAD 2000/R14 command Action in 4MCAD 

viewctl ddvpoint ddvpoint Sets the three-dimensional 
viewing direction via an 
interactive dialog box. 

viewpoint vpoint vpoint Sets the three-dimensional 
viewing direction via the 
command line. 

vsnapshot vslide vslide Displays an SLD, EMF, or 
WMF file in the current 
viewport. 

 

 

Recognizing subtle command differences 
 

The commands listed below function slightly differently in 4MCAD than in Auto- 

CAD. 
 

Command function differences 
 

 
cal cal Displays the Windows calculator. 

pan -pan Performs a vector pan instead of a real-time pan. 

zoom -zoom Performs a stepped zoom instead of a real-time zoom. 

4MCAD 
command 

AutoCAD 
command Function in 4MCAD 
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Identifying unsupported commands and features 
 

A few AutoCAD commands and features are not supported in this release of 

4MCAD, as shown in the following table. 

 
AutoCAD commands not supported by 4MCAD 

2008 Features: Info Center 

 

Commands: annoupdate, attipedit, dataextraction, datalink, 
datalinkupdate, dimbreak, diminspect, dimspace, dwflayers, freeweb, 
freespot, +layer, recoverall, renderexposure, targetpoint, tpnavigate 

2007 Features: Shadow property 
 

Commands: planar 

2005 Features: Zoom to Selection, Tables, Trimming Hatches, and Sheet 
Set Manager 

 
Commands: archive, assistclose, markup, newsheetset, 
opendwfmarkup, sheetset, table and -table, tableedit, tableexport, 
tablestyle, taskbar, tinsert, updatefield, viewplotdetails 

2004 Features: Ctrl + O Clean Screen, Error Reporting, Reference 
Manager, Background Printing, and Miscellaneous Print Style 
Features (Dithering, Grayscale, Screening, Adaptive, Line End Styles, 
Line Join Styles, Fill Styles) 

 

Commands: 3dorbitctl, jpgout, pngout, tifout 

2002 Features: Today window 
 

Commands: attext, and eattext 

2000 Features: Parallel Entity Snap, Viewports with UCS and Elevation 
Settings, AutoTrack, True Color Raster Output 

 

Commands: 3dclip, 3ddistance, 3dswivel, 3dzoom, blockicon, 
camera, dbclose, dbconnect, adcclose, adcenter, adcnavigate, 
layoutwizard, model, olescale, partialload, partialopen, pasteorig, 
pcinwizard, plottermanager, psetupin, qleader, shademode, ucsman, 
vbaman, vlisp, and whohas 

R14 Features: Tracking Points and Command Bar File Open 
 

Commands: xbind, rectang, and qdim 

R13 Commands: arx, dsviewer, dxbin, edge, mledit, treestat, and 
wmfopts 

Advanced 
AutoCAD 
modules 

ACIS commands (solids modeling): ameconvert, soldraw, solprof, 
solview, and stlout 

 

ASE commands (AutoCAD SQL extension): aseadmin, aseexport, 
aselinks, aserows, aseselect, and asesqled 

Internet commands: listurl, openurl, saveurl, and selecturl 
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AutoCAD commands not supported by 4MCAD 

 

 
 

 

Identifying what does not display 
 

When a drawing containing AutoCAD proxy entities is loaded into 4MCAD, the 

program displays the following message: “This drawing contains one or more entities 

that will not display. These entities WILL be stored and saved back into the draw- 

ing.” 

The following table identifies which AutoCAD objects are not displayed in 4MCAD. 
 

AutoCAD objects not displayed in 4MCAD 
 

 
Arc aligned text Text that is aligned along the curve of an arc. 

Camera Point at which a camera is inserted into a drawing. 

Light Point at which a light is inserted into a drawing. 

Read text Dynamically linked text that displays in a drawing but resides in an 
external file. 

Tables Tables display as anonymous blocks but cannot be edited. 
 

 

 
 

 

Select all proxies in a drawing. 

Type select, choose Filter, then choose Proxy. 
 

 

AutoCAD object Description 

Landscape commands: lsedit, lslib, and lsnew 

PostScript commands: psdrag, psfill, psin, and psout 

Render commands: fog, matlib, replay, saveimg, scene, setuv, 
showmat, stats, transparency, 3dsin, and 3dsout 
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Supporting AutoCAD customization 
 

The following table lists and describes the ways 4MCAD supports the AutoCAD 

customization files. 
 

4MCAD support of AutoCAD customization files 
 

 
LIN Supported: Linetypes and complex linetypes with text and shapes. 

MNU and MNS Supported: Toolbar and menu macros. 
Supported: ***POP0, ***POPn, and ***TOOLBAR sections. 
Not supported: ***TABLET, ***BUTTONS, ***SCREEN, ***AUX, and ***ICON 
sections. 

MIN Not supported: The multiline definition file is used by the AutoCAD mline 
command. 

PAT Supported: Hatch patterns. 

PGP Supported: Command aliases. 
Not supported: External commands. 

PSF Not supported: PostScript fill pattern file is used by the AutoCAD psfill 
command. 

SHP and SHX Supported: Text fonts and shapes. 

SLD Supported: Slide files. 

UNT Supported: Unit translation file used by the LISP (cvunit) and SDS sds_cvunit 
functions to translate values from one unit of measurement to another. 

 
 

 

 

Understanding menu compatibility 
 

MNU files are menu files created by all AutoCAD releases, and MNS files are 

included in AutoCAD Releases 13, 14, and 2000. 4MCAD reads both file formats, 

even when menu macros include AutoLISP code. This feature allows you to continue 

using your existing AutoCAD menus 
 

4MCAD support of specific sections in AutoCAD MNU and MNS files 
 

Menu section Definition 4MCAD support 

***POP0 Cursor menu Supported 

***POPn Pull-down menus Supported 

***AUXn Auxiliary menus Not supported 

***BUTTONn Button menus Not supported 

***ICON Icon menus Not supported 

***SCREEN Screen menus Not supported 

***TABLETn Tablet menus Not supported 

File extension Description 
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Importing and exporting customization files 
 

You can continue using aliases and menu files from AutoCAD by importing the 

appropriate file. You can import AutoCAD customization files and export 4MCAD 

formats using the Customize dialog box. All of the files listed in the following table 

are in ASCII format, which means you can view and edit them with a text editor, such 

as Notepad. 
 

Customizing files 
 

 
Aliases PGP: AutoCAD aliases 

ICA: 4MCAD aliases 
ICA: 4MCAD aliases 

PGP: AutoCAD aliases 

Keyboard ICK: 4MCAD keyboard ICK: 4MCAD keyboard 

Menus MNU: All AutoCAD menus 
MNS: AutoCAD R13, R14 and 2000 
menus 

ICM: 4MCAD menu 

ICM: 4MCAD menu 

Toolbars MNU: All AutoCAD menus None 
 

 

 
 

 

TIP You can manually add toolbar customizations to a MNU file. For more informa- 

tion, see “Customizing toolbars” on page 739. 
 

 

Customization Import file formats Export file formats 
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Programming 4MCAD 
 

4MCAD supports more AutoCAD application programming interfaces (APIs) than 

any other software, but not all of the AutoCAD APIs are available in 4MCAD. The 

following table summarizes the AutoCAD APIs 4MCAD supports. 
 

4MCAD support of the AutoCAD programming interface 
 

 
Scripts (SCR files) Supported 

AutoLISP (LSP files) Supported 

Dialog Control Language (DCL files) Supported 

AutoCAD Development System (ADS) Supported; source code must be 
recompiled 

Visual Basic Applications (VBA) Supported, depending on your version 
of 4MCAD 

Direct Interactively Evaluated String Expression 
Language (Diesel) 

Supported 

AutoCAD SQL Interface (ASI) Not supported 

Autodesk® Threaded Language Application System 
Toolkit (Atlast) 

Not needed 

AutoCAD Runtime Extension (ARx) Not supported 
 

 

 

Understanding AutoLISP compatibility 
4MCAD adds LISP functionality that you will find useful. The following table lists 

functions that are unique to 4MCAD LISP. 
 

Additional 4MCAD LISP functions 
 

 
(log10) Returns log base 10. 

(lpad) Pads a text string with spaces to the left. 

(rpad) Pads a text string with spaces to the right. 

(tan) Returns the tangent. 

(trim) Trims spaces from a string. 
 

 

Unique LISP function Definition 

AutoCAD programming interface 4MCAD support 
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Not all 4MCAD LISP functions are completely compatible with AutoLISP func- 

tions. The following table identifies 4MCAD LISP functions that are partially 

compatible with AutoLISP functions. 
 

Partially compatible LISP functions 
 

 
(menucmd) Supports P0 (cursor menu), P1 through P16 (the pull-down menus), 

and M (diesel expressions), but does not support A (aux menus), B 
(button menus), I (icon menus), S (screen menu), or T (tablet menus). 

(print1) Does not support Unicode characters, such as \U+00B0 (the degree 
symbol) and M+Nxxxx (multi-byte Unicode sequences). 

(ssget) and (ssadd) Supports additional selection modes: 
CC = Crossing Circle 
O = Outside 
OC = Outside Circle 
OP = Outside Polygon 
PO = POint 
PRO = Properties 

 
 

 

In addition, 4MCAD LISP does not support all AutoLISP functions. The following 

areas are not supported by 4MCAD LISP: 

• (acdimenableupdate), (acet-attsync), (acet-layerpmode), (acet-layerp-mark), 

(acet-laytrans), (acet-ms-to-ps), (acet-ps-to-ms), (defun-q), (defun-q-list-ref), 

(defun-q-list-set), (entmakex), (initdia), (namedobjdict), (ssnamex), and (tablet) 

• ARX-related functions that run ARX applications 

• (dict)-related functions 

• SQL-related functions that link AutoCAD entities with external database records. 

These functions start with ase_, for example, (ase_lsunite) and (ase_docmp) 

LISP function Description 



804 A P P E N D I X 
 

 

4MCAD and AutoCAD list of terms 
 
 

List of terms 
 

 
command bar command prompt area 

edit length lengthen 

entity object 

entity snap object snap 

entity snap precision aperture 

fixed attribute constant attribute 

follow continue 

freehand sketch 

hidden attribute invisible attribute 

infinite line XLine 

insert draw 

orthogonal ortho 

parallel offset 

plane solid (2D) 

predefined attribute preset attribute 

print plot 

print style plot style 

prompt box context menu 

Prompt History window text screen 

reference grid grid 

point snap node snap 

snapshot slide (SLD) 

validate attribute verify attribute 

4MCAD term Meaning for AutoCAD users 



 

 
 

 
 
 
 

Glossary 
 
 
 
 
 

 

2D Two-dimensional locations defined by x- and y-coordinates. 

3D Three-dimensional locations defined by x-, y-, and z-coordinates. 

3D solids Three-dimensional ACIS entity. 

 
absolute coordinates Coordinates defined in relation to the origin point of the cur- 

rent user coordinate system. See also coordinate system, coordinates, origin, rela- 

tive coordinates, user coordinate system, and World Coordinate System. 

ActiveX A mechanism for exchanging information between different programs 

whereby a copy of a source document is embedded or a pointer to a source document 

is linked to a target document. See also embed and link. 

acute angles Angles of fewer than 90 degrees. 

alias An abbreviation or alternative word for an 4MCAD command. 

aligned dimension A dimension aligned parallel to an entity or measuring the dis- 

tance between two points at any angle. 

angle The difference in direction between two nonparallel linear entities, measured 

in degrees or radians. 

angular dimension A dimension measuring the angle between two lines or sub- 

tended by an arc. 

angular unit The unit of measurement for angles. Angular units can be measured in 

decimal degrees, degrees/minutes/seconds, grads, and radians. 

annotation Any text, dimensions, tolerances, or notes added to a drawing. 

ANSI Acronym for American National Standards Institute. In the context of text, a 

standard character set defined by ANSI used in computer-aided drafting. 

arc A segment of a circle or ellipse. 

area Measurement of a planar region or the calculated space within an entity. 

array Multiple copies of selected entities in a circular or rectangular pattern. 

ASCII Acronym for American Standard Code for Information Interchange, a com- 

monly used system for assigning numbers to printable alphanumeric characters, 

punctuation, and symbols. 
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attribute A component of a block containing specific text or numeric information. 

You can copy the information contained in an attribute from the drawing to an exter- 

nal database. 

attribute definition An entity composed of a name, prompt for information, display 

characteristics, and default text that, when incorporated into a block, creates an attri- 

bute when the block is inserted into a drawing. 

attribute name Text that identifies an attribute within a block. 

attribute text The text containing an attribute’s information within a block. 

 
B-spline curve See spline. 

base point A point on an entity that serves as its reference or insertion point. A 

point of reference when specifying relative distances. 

baseline The line on which text characters appear to sit. The descenders of individ- 

ual characters drop below the baseline. 

baseline dimension Multiple parallel dimensions measured from the same baseline 

origin. 

bind To convert an externally referenced drawing into a standard block definition. 

blips Temporary screen markers displayed in a drawing when you select a point. 

Also called marker blips. 

block One or more entities grouped together to create a single entity. See also 

nested block. 

block definition The name, base point, and entities grouped together when creating 

a block. 

boundary polyline A selected area bounded by a single closed entity or by multiple 

entities that intersect. 

BYBLOCK A property whereby an entity inherits the color, linetype, lineweight, or 

print style of any block that contains it. 

BYLAYER A property whereby an entity inherits the color, linetype, lineweight, or 

print style of its associated layer. 

 
CAD Acronym for computer-aided design. 

Cartesian coordinates Coordinates defined using three perpendicular axes (x, y, 

and z) to define locations in three-dimensional space. See also cylindrical coordi- 

nates, polar coordinates, and spherical coordinates. 

center line A line used to indicate the center of a circle or an arc, usually consisting 

of a center mark and lines extending slightly beyond the diameter of the circle or the 

arc. 

center mark A cross marking the center of a circle or an arc. 
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chamfer A beveled edge between two lines. 

chord A line connecting two points on a circle or an arc. 

circumference The measurement of the distance around a circle. 

closed A condition whereby the start point and endpoint of an entity are the same. 

color-dependent print style table A collection of print styles that determine how 

entities print according to their assigned color. See print style table. 

comma-delimited Data that is separated by a comma to represent the end of a field. 

command bar A dockable window in which you type 4MCAD commands and 

view prompts and other program messages. 

cone A three-dimensional entity where a vertex exists above or below the circular 

shape and where a surface has been applied between the vertex and the circular shape. 

contiguous Connected, unbroken, or uninterrupted. Entities that share the same 

endpoint. 

continued dimension A dimension measured from the previous extension line of 

an existing dimension, resulting in two or more dimensions positioned end to end. 

control point A point used to define a spline. 

Coons patch A surface interpolated among three or four boundary curves. 

coordinate filter A function that extracts individual x-, y-, and z-coordinate values 

from different points to create a new composite point. 

coordinate system A system of points that represents the drawing space in relation 

to an origin (0,0,0) and a set of axes that intersect at the origin. In two dimensions, the 

x- and y-axes represent horizontal and vertical directions, respectively. In three 

dimensions, the z-axis represents locations above and below the two-dimensional xy 

plane. Locations in the drawing can be represented using two-dimensional and three- 

dimensional rectangular (Cartesian) coordinates, two-dimensional polar coordinates, 

three-dimensional polar (cylindrical) coordinates, and three-dimensional spherical 

coordinates. See also polar coordinates, relative coordinates, spherical coordi- 

nates, user coordinate system, and World Coordinate System. 

coordinates A set of values that determines a location in two-dimensional or three- 

dimensional space. See also absolute coordinates, Cartesian coordinates, polar 

coordinates, relative coordinates, and spherical coordinates. 

coplanar Lying within the same plane. 

crosshairs A cursor that consists of two or three lines that intersect at the cursor 

location. 

crosshatch To fill an area with a pattern of evenly spaced perpendicular lines. See 

also hatch. 
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crossing circle An entity-selection method that selects entities contained within or 

crossing the boundary of a circular selection window. 

crossing polygon An entity-selection method that selects entities contained within 

or crossing the boundary of a polygon selection window. 

crossing window An entity-selection method that selects entities contained within 

or crossing the boundary of a rectangular selection window. 

cube A boxed, three-dimensional, geometric shape where length, width, and height 

are equal. 

cursor The insertion-point symbol on the screen. The appearance of the cursor 

changes based on the current task. 

curve A smooth, continuous path made up of linear and arc segments. Curve types 

include arcs, splines, circles, and ellipses. 

cylindrical coordinates Coordinates describing a point in three-dimensional space 

based on its distance from the origin, its angle in the xy plane, and its z-coordinate 

value. See also polar coordinates and spherical coordinates. 

 
datum-line dimensioning See ordinate dimension. 

default An initial or predefined setting. 

detach To remove an external reference from a drawing. See also external refer- 

ence. 

diameter The distance across a circle or sphere. 

digitizer tablet A hardware input device that incorporates an electronic pad and a 

hand-held pointer similar to a mouse. A digitizer tablet serves two purposes: (1) You 

can select tools from paper representations attached to the pad (called an overlay), 

providing access to all tools at once while freeing your screen space; and (2) you can 

input digital points into the computer that correspond to points on a paper drawing, 

photograph, or blueprint attached to the pad. 

dimension A measurement, as in height or width. In the context of drafting, a set of 

lines, arrowheads, and text used to indicate a measurement. 

dimension style A named group of dimension variable settings that determines the 

appearance of the dimension. You can save multiple dimension styles for reuse. 

dimension text The measurement value. Dimension text can include prefixes, suf- 

fixes, tolerances, and other annotations. 

dimension text rotation The angle in degrees between the x-axis and the dimen- 

sion text baseline. 

dimension tolerance A value specifying the allowed variation of a dimension (+ or 

– n). 

dish The lower half of a sphere. See also dome. 
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displacement point The point to which a base, or reference, point will be relocated 

when moving or copying entities. 

distance The measure of space between two points. 

dock To position a toolbar or the command bar at the edge of the drawing window, 

where it locks into place. See also float. 

dome The upper half of a sphere. See also dish. 

donut A filled circle or flat ring created as a polyline. 

drawing extents See extents. 

drawing limits See limits. 

drawing unit The linear measurement system used in a drawing. The user deter- 

mines what a drawing unit represents, such as one inch, one centimeter, one foot, or 

one meter. 

DWF Acronym for Autodesk Design Web Format, a file format for viewing two- 

dimensional or three-dimensional drawings in a Web browser and distributing for 

review using free Autodesk® software and tools. 

.dwg A standard file extension used by CAD programs to store drawing files of the 

DWG format. 

.dwt A standard format used by CAD programs to store drawing templates, which 

are drawings that contain predefined settings that you can use when creating a new 

drawing. See also template. 

DXF Acronym for Drawing Exchange Format, a standard ASCII or binary file for- 

mat for importing and exporting files between most CAD programs. 

 
elevation The z value measured from the xy plane. Positive values are above the xy 

plane; negative values are below the xy plane. 

embed A technique for exchanging information between different programs 

whereby a copy of the source document is stored in the target document. See also 

ActiveX and link. 

EMF Acronym for Enhanced Metafile, a file format with the type and extension of 

.emf. It is a native internal file format of Windows 98. EMF supports both raster and 

vector information and 24-bit RGB color. Most Windows-based programs support 

this format. 

endpoint The point at which a line or curve ends. 

entity Any single basic item in a drawing. Entities include arcs, attributes, blocks,  

circles, dimensions, ellipses, elliptical arcs, infinite lines, lines, polylines, rays, and 

text. 

entity data Any of a variety of additional information, such as text, numbers, and 

distances, that can be attached to drawing entities. 
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entity snap A technique for accurately locating and specifying key geometric points 

on entities, such as endpoints and midpoints of lines, and center points and tangents 

of arcs and circles. 

entity snap override To disable or change an entity snap mode for a single input. 

See also entity snap and running entity snap. 

Esnap See entity snap. 

explode The conversion of a complex entity into its basic entities. 

extension lines Lines extending away from an entity being dimensioned so that 

you can place the dimension line away from the entity. Also called projection lines. 

extents The smallest rectangle that can contain all the entities in a drawing. Infinite 

lines and rays do not affect a drawing’s extents. See also limits. 

external reference A drawing that is linked to another drawing. 

extrude The process of converting a two-dimensional entity into a three-dimen- 

sional entity by stretching (extruding) the two-dimensional entity along a straight 

path. Changing the thickness of a two-dimensional entity effectively extrudes it along 

its z-axis. See also tabulated surface. 

 
face A planar surface defined by three or four points. 

fence An entity-selection method that selects entities crossing a multisegmented 

line. 

fillet An arc that smoothly connects the end of one line to another. 

float To position a toolbar or the command bar away from the edges of the drawing 

window where it can be moved independently. See also dock. 

freeze To suppress the display of, and ignore the entities on, a specified layer when 

regenerating a drawing, thus accelerating the display of the drawing. See also thaw. 

 
grid An adjustable, regularly spaced pattern of dots on the screen, used as an aid in 

drawing and aligning entities. The grid is not printed. 

grip A small square displayed at key positions on an entity when the entity is 

selected that can be used to modify the entity by clicking and dragging. 

 
halfwidth The distance from the center of a wide polyline to its edge. 

hatch To fill a selected area either with lines, crosshatching, or a hatch pattern. See 

also crosshatch. 

hatch pattern A pattern, often representing a material such as steel, wood, or sand, 

for filling selected areas. 
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hidden-line removal A visualization technique in which all lines that are hidden 

behind other entities or surfaces from your viewpoint are clipped or removed, giving 

the image the appearance of a solid entity. 

horizontal dimension A linear dimension measuring a horizontal distance. 

 
infinite line A line extending infinitely in both directions. 

insertion point The point where you place an entity into a particular space. A refer- 

ence point by which an entity is inserted in a drawing. 

intersection The point where two entities meet or cross. 

isometric drawing A drawing aligned with an isometric plane. 

isometric plane One of three planes representing the left, right, or top sides of an 

implied three-dimensional, orthogonal entity. Snap and grid points are aligned with 

the plane to constrain drawings. 

 
layer The computer equivalent of overlays used in manual drafting. A tool by which 

drawing components can be organized into related sets, such as plumbing, framing, 

and electrical systems of a house, each being drawn on its own layer. 

layout Similar to a sheet of paper, a representation of how a drawing will look when 

printed. 

layout viewport A window in a Layout tab (paper space) that displays all or a por- 

tion of a drawing’s model space entities. See also paper space and model space. 

leader A line leading from a feature of a drawing to an annotation. 

limits The user-defined boundary of a drawing, defined by its lower left and upper 

right corner coordinates. See also extents. 

limits tolerance Dimension text in which the measured dimension is replaced by 

the largest and smallest dimensions allowed, with the upper limit displayed above the 

lower limit. See also tolerance and variance tolerance. 

linetype The appearance of a line, defined as a solid (continuous) line or as a pattern 

of dashes, dots, and blank spaces. 

lineweight The width of a line, defined in millimeters or inches. 

link A technique for exchanging information between different programs whereby 

the target document maintains a pointer to the original source document. Any 

changes to the source document are reflected in all target documents containing links 

to the source. See also ActiveX and embed. 

LISP Acronym for List Processing Language, a computer language invented in the 

late 1950s by John McCarthy for use in artificial intelligence. Because it is inter- 

preted rather than compiled, and is relatively straightforward, it is a convenient lan- 

guage for users to write routines to extend the set of commands and functionality of 

4MCAD. 
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lock Prevents unauthorized access to drawing layers. 

 
M direction In a polygon mesh, the direction from the first to the second row. See 

also N direction. 

macro In menus and toolbars, several commands grouped together as one. Also 

Visual Basic for Applications code. 

major axis The longest distance across an ellipse, from one end to the other. See 

also minor axis. 

marker blips Temporary screen markers displayed in a drawing when you select a 

point. Also called blips. 

MDI Acronym for multiple-document interface. See multiple-document interface. 

mesh A set of connected polygon faces approximating a curved surface. 

minor axis The shortest distance across an ellipse, from one side to the other. See 

also major axis. 

mirror To create a reverse-image copy of selected entities by reflecting the entities 

symmetrically about a line or plane. 

model space The primary drawing area in which you create entities. See also paper 

space. 

multiple-document interface The ability to view and work with different drawings 

simultaneously. 

 
N direction In a polygon mesh, the direction from the first to the second column. 

See also M direction. 

named print style table A collection of print styles that determine how entities 

print according to the print styles you create and assign to entities and layers. See 

print style table. 

named view A saved view that can be recalled at a later time by specifying its name. 

nested block A block contained as part of the definition of another block. See also 

block. 

nonassociative hatch A hatch that is not associated with or linked to an entity. 

 
oblique Geometric lines or planes that are not parallel or perpendicular. 

offset See parallel. 

OLE Acronym for Object Linking and Embedding. See ActiveX. 

ordinate dimension A measurement of the horizontal (x-ordinate) or vertical (y- 

ordinate) distance from an established reference base point or datum. 
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origin The intersection point of the coordinate system axes. In a Cartesian coordi- 

nate system, the origin is the point at which the x-, y-, and z-axes intersect (the 0,0,0 

coordinate). 

orthogonal Having perpendicular slopes or tangents at the point of intersection. 

orthogonal mode (ortho) A drawing mode in which the entity creation is con- 

strained to parallel the horizontal and vertical axes relative to the current snap angle. 

orthographic projection A drafting technique by which a three-dimensional item 

is described in two dimensions by showing it from various directions, most com- 

monly front, top, and side views. 

outside circle An entity-selection method that selects entities falling completely 

outside a circular selection window. 

outside polygon An entity-selection method that selects entities falling completely 

outside a polygon selection window. 

outside window An entity-selection method that selects entities falling completely 

outside a rectangular selection window. 

 
pan To shift the displayed view of a drawing without changing the magnification. 

See also zoom. 

paper space A two-dimensional work area similar to a sheet of paper, in which you 

can arrange different views of your model as layout viewports. See also model space. 

parallel Two or more coplanar lines that never intersect one another. 

parallel dimension See baseline dimension. 

PDF Acronym for Portable Document Format. PDF files can be viewed using 

Adobe® Acrobat Reader, which is free software that users can download; they can 

also be viewed, reviewed, and edited using Adobe® Acrobat. 

perimeter The distance around the boundary of an entity. 

perpendicular Entities at right angles to one another. 

planar Entities whose extents are situated entirely within a plane. 

plane Two-dimensional surface. 

plan view A view of the drawing from above, looking down the z-axis perpendicular 

to the xy plane of the current UCS. 

point A location in space specified by its x-, y-, and z-coordinates. A drawing entity 

consisting of a single x,y,z-coordinate location and represented by one of several 

symbols. 

point filter See coordinate filter. 

polar array Multiple copies of selected entities in a circular pattern. 
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polar coordinates Coordinates describing a two-dimensional point on a two- 

dimensional plane based on the point’s distance from the origin and its angle in the 

plane. See also Cartesian coordinates, coordinates, cylindrical coordinates, rela- 

tive coordinates, and spherical coordinates. 

polygon A closed single entity with three or more sides. 

polyline A drawing entity composed of one or more connected line or arc segments 

treated as a single entity. 

print style A collection of settings, including color, pen width, linetype, and line- 

weight, that determine how a drawing looks when it is printed. See print style table. 

print style table A collection of print styles that you can assign to the Model tab or 

to a Layout tab. Print style tables change how a drawing looks when you print it with- 

out modifying the actual entities. See print style. 

profile File that contains your preferred drawing environment settings. 

projection lines See extension lines. 

prompt box A list of options displayed when a command or tool provides several 

choices. 

Prompt History window A window containing a history of the most recent com- 

mands and prompts issued since you started the current session of 4MCAD. 

 
quadrant One-fourth of a circle, arc, or ellipse entity. In the context of entity snaps, 

the option that snaps to points on a circle, arc, or ellipse at each quadrant. 

 
radial dimension A dimension that measures the radius of a circle or arc. 

radian A unit of angular measurement; 360 degrees equals 6.283185 or 2pi radians. 

radius The distance from the center of a circle or sphere to its periphery. 

ray A line that starts at a designated point and runs infinitely. 

ray tracing A visualization technique in which rays from imaginary light sources 

are traced as they refract off the surfaces of a model, determining where shadows fall 

and how reflections on shiny materials such as metal and glass appear. 

rectangle A four-sided, closed entity whereby opposite sides are equal in length. 

rectangular array Multiple copies of selected entities in a rectangular pattern con- 

sisting of a specified number of columns and rows. 

redo To reverse the effect of previous undo commands. See also undo. 

redraw To quickly update or refresh the drawing screen display. See also regener- 

ate. 

regenerate To update or refresh the drawing screen display by recalculating the 

drawing from its database. See also redraw. 
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region A two-dimensional closed, surfaced, planar boundary. 

relative coordinates Coordinates expressed in relation to a previous coordinate. 

See also absolute coordinates. 

render A visualization technique in which all surfaces of a model are shaded as 

though they were illuminated from an imaginary light source located behind you as 

you face the screen. Rendered images are photo-realistic, having depth, shadow, 

reflection, and texture. 

revolve Creating a three-dimensional surface entity by rotating a two-dimensional 

profile around an axis. 

right-hand rule A visual aid for remembering the relative directions of the positive 

x-, y-, and z-axes of a Cartesian coordinate system and the positive rotation direction 

about an axis. 

rotate To change the orientation of an entity, without modifying it, by repositioning 

it equidistant from, but at a new angle with respect to, a point or axis. 

rotation angle The angle by which an entity is displaced from its original location 

when rotating it about a point or axis. 

rubber-band line A ghosted image line that stretches dynamically on the screen 

with the movement of the cursor. The line extends between a fixed point and the cur- 

sor position to provide dynamic feedback. 

ruled surface A three-dimensional polygon mesh that approximates a smooth sur- 

face between two entities. 

running entity snap Setting an entity snap so that it continues for subsequent selec- 

tions. See also entity snap and entity snap override. 

 
scale To resize an entity. To draw according to the proportions of an entity. 

script A set of commands stored in an ASCII script file and replayed in sequence by 

running the script. 

SDS Acronym for Solutions Development System, a C programming interface for 

developing specialized programs to run inside 4MCAD. 

segment Any part of an entity bounded by two points. 

selection set One or more drawing entities selected on which one can operate as a 

single unit. 

shade To fill planar entities with solid colors for easier visualization. 

snap angle The angle around which the snap grid is rotated. 

snap grid An invisible grid that locks entity creation to a specified alignment and 

snap increment when Snap is enabled. 

snap resolution The spacing between points on the snap grid. 
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snapshot A raster representation of the current view of one’s drawing. 

spherical coordinates Coordinates describing a point in three-dimensional space 

based on its distance from the origin, its angle in the xy plane, and its angle up from 

the xy plane. See also Cartesian coordinates, coordinates, cylindrical coordinates, 

and polar coordinates. 

spline A curve generated along the path of three or more control points. The curve 

passes through the start point and endpoint, but does not necessarily pass through the 

intermediate control points. 

status bar The bar at the bottom of the 4MCAD window that displays informa- 

tion about the selected command or tool as well as the cursor coordinates, the name of 

the current layer, mode settings, and other information about drawing settings. 

surface model A three-dimensional model consisting of both edges and the sur- 

faces between those edges. See also wire-frame model. 

surface of revolution A three-dimensional polygon mesh that approximates the 

surface generated by rotating a two-dimensional profile around an axis. 

SVG An acronym for Scalable Vector Graphic, which is a file format for working 

with interactive graphics, including a Web development language. 

system variable A setting or value that stores operating environment and command 

information (such as the drawing limits or global linetype scale factor). 

 
tabulated surface A three-dimensional polygon mesh that approximates the sur- 

face generated by extruding a curve along a vector. See also extrude. 

tangent A line that passes through a single point on a curve. 

template A drawing with preset layers, linetypes, and other settings (and entities) 

that can be used as the basis for creating a new drawing. Templates are saved with a 

.dwt file extension. 

text style A named, saved collection of format settings that determines the appear- 

ance of text. 

thaw To redisplay a layer that was frozen. See also freeze. 

thickness An entity’s depth, as measured along its z-axis. The distance an entity is 

extruded above or below its elevation. See also elevation and extrude. 

through point In creating a parallel entity, a point through which the new entity 

passes. 

tolerance Dimension text indicating how much the actual dimension of a manufac- 

tured component can vary from the specified dimension. See also limits tolerance 

and variance tolerance. 

tolerance command A command that creates a feature-control frame used in 

mechanical geometric dimensioning and tolerancing. 



G L O S S A R Y 817  
 

 

toolbar A collection of tools arranged on a palette that can be moved and resized 

anywhere on the screen. 

torus A donut-shaped, three-dimensional entity. 

transparent command A command started while another command is already 

active. You can use a command transparently by preceding it with an apostrophe. 

true color Colors defined using 24-bit color. There are more than 16 million true 

colors from which you can choose. 

 
UCS Acronym for user coordinate system. See user coordinate system. 

UCS icon A user coordinate system icon that shows the orientation of the coordinate 

axes, the location of the coordinate system origin, and the viewing direction relative 

to the xy plane. 

undo To reverse the effect of previous commands. See also redo. 

unit See drawing unit. 

unlock Free access to layers in a drawing that would be otherwise locked, thus pro- 

hibiting them from being viewed or edited by another user. 

user coordinate system A Cartesian coordinate system with origins and orienta- 

tion defined by the user. See also World Coordinate System. 

 
variance tolerance Dimension text in which a plus/minus value is appended to the 

specified dimension to indicate how much the actual dimension of a manufactured 

component can vary from the specified dimension. See also limits tolerance and tol- 

erance. 

VBA Acronym for Visual Basic for Applications, a macro programming language 

embedded in programs that allows the user to customize the program. 

vector A means of describing a displacement using magnitude and orientation. For 

example, you can create a line entity, or move an entity, by specifying an initial point, 

a direction, and a distance. 

vertex The point of intersection of the sides of an angle. The start points or end- 

points of a line or arc segment in a polyline. 

vertical dimension A linear dimension measuring a vertical distance. 

view A representation of a drawing or portion of a drawing from a specific view- 

point in three-dimensional space. 

viewpoint A location in three-dimensional space for viewing one’s drafting. 

viewport A window that displays all or a portion of a drawing’s model space entities 

while in model space on the Model tab. See also model space and paper space. 

viewport configuration A named arrangement of windows that can be saved and 

restored. 
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WCS Acronym for World Coordinate System. See World Coordinate System. 

wedge A three-dimensional entity that resembles a box divided along one side from 

one corner to the opposite corner; for example, a doorstop or a ramp. 

window circle An entity-selection method that selects entities contained entirely 

within a circular selection window. 

window inside An entity-selection method that selects entities contained entirely 

within a rectangular selection window. 

window polygon An entity-selection method that selects entities contained entirely 

within a polygon selection window. 

wipeout An entity that displays with the current background color, so the details 

behind it do not display or print. 

wire-frame model A three-dimensional model consisting of lines and curves that 

define the edges of a three-dimensional entity. See also surface model. 

WMF Acronym for Windows metafile, a format containing vector and color informa- 

tion to render entities. 

World Coordinate System The fixed Cartesian coordinate system used as the basis 

for defining other coordinate systems. See also user coordinate system. 

 
xref See external reference. 

 
zoom To increase or decrease the magnification of the display of a drawing. See also 

pan. 
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Symbols 
- (hyphen characters) 223, 524, 525 

_ (underscore characters) 223, 524, 525 
, (commas) 240 

. (period characters) 241 

.dwg files 

creating 46 

defined 809 

exporting 4MCAD files as 655–668 

4MCAD compatibility with 3 opening 

47 
saving 100 

.NET applications 780 

@ (at symbols) 380 

& (ampersand character) 724 

% (percent signs) 412, 413 

° (degree symbols) 412, 413 

± (plus or minus signs) 412, 413 

< (angle brackets) 237, 239, 240 

$ (dollar signs) 223, 524, 525 

Numerics 
0 layer 256 

2D DWF files 657 

2-dimensional drawings 

2-dimensional coordinate systems 235 

coordinate systems 232 

defined 805 

isometric drawings 81 

point filters 241 

polar coordinates 237 

2-dimensional entities 

See also 2-dimensional entity types; entities 

arraying in columns or rows 365 

extruding to create 3-dimensional entities 580–583 
2- dimensional entity types 

arcs 109 

circles 105 

construction lines 120 

donuts 131 

ellipses 113 

elliptical arcs 114 

freehand sketches 127 

infinite lines 118 

lines 104 

planes 153 

point entities 115 

polygons 134 

polylines 128 

rays 117 

rectangles and squares 132 

splines 147 

3D Array command or tool (3darray) 616, 617 
3D DWF files 657 

3D Mirror command or tool (mirror3d) 618 

3D Rotate command or tool 615 

3D solids 580 

3- dimensional coordinate systems 239 

defined 805 

specifying locations with 238 

3-dimensional drawings 

compared to isometric 2-dimensional drawings 81 

coordinate system icons 233 

coordinate systems 232, 238 
defined 805 

point filters 242 

setting viewpoints 576–580 

snapping to entity intersections 92–93 

user coordinate systems 243 

wire-frame and surface models 580 

3-dimensional entities 

3D solids 580 

See also 3-dimensional entity types; entities 

aligning 618–621 

arraying copies of entities 615–617 

creating regions 604 

editing 614–621, 622–632 
hiding lines in drawings 633 

mirroring 618 

rotating entities 615 

shading surfaces 634 

thickness and elevation 580–585 

3-dimensional entity types 

boxes 592 

cones 595 

cylinders 599 

dishes 601 

domes 602 
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edge-defined Coons surface patch meshes 592 

extruded surface meshes 588 

faces 585 

polyface meshes 587 

pyramids 596 

rectangular meshes 586 
regions 604 

revolved surface meshes 590–592 

ruled surface meshes 587 
spheres 600 

tori 603, 605, 607, 608, 609 

wedges 594 

wire-frame 633 

3-Point Arc tool 109 

4K display issues 697 

A 
absolute coordinates 

See also coordinate systems; user coordinate sys- 

tems (UCS); World Coordinate System (WCS) 

defined 805 

specifying locations with 235, 238 

absolute size of point entities 115 

access keys for commands 724 

accuracy 

drawing unit display 59 

4MCAD compared to manual drafting 7–8 

precise point locations with entity snaps 327 

ACIS solids 

boxes 593 

combining 610, 611 

cones 595 

cylinders 599 

defined 805 

dishes 601 

domes 602 

extruding 605, 607, 608, 609 

intersecting 612 

pyramids 596 

regions 605 

revolving 606 

spheres 600 

subtracting 611 

tetrahedrons 596 

tori 603 

wedges 594 

acisin command 650, 651 

acisout command 659 

ActiveX 

defined 805 

dragging drawings into other applications 654–655 

editing linked or embedded objects 646, 653 

linking drawings to other applications 653 

linking objects to drawings 645–646 

sharing drawing information and data 11 

acute angles 805 

Add Leader Lines command or tool (aimmleaderadd) 

174 

Add To Set selection method 335 

adding 

aliases for commands 753 

areas of entities 324 

commands to menus 718, 721, 723, 735, 743, 749, 
753, 776 

commands to ribbon 730, 733, 734 

commands to the ribbon 728 

entities to selection sets 334 

hyperlinks 669 

keyboard shortcuts for commands 747 

layouts for printing 519 

tools to toolbars 741 

ADS programs 3, 4, 779 

ADT files 50 

advanced experience level 

changing level 3, 36, 677 

aliases for commands 

creating 753 

defined 805 

deleting 755 

align command 619, 620, 621 

Align command or tool (align) 619, 620, 621 

Align Multileader command or tool (mleaderalign) 174 

Aligned command or tool (dimaligned) 432 

aligned dimensions 

creating 432 

defined 805 

illustrated 428 aligning 

coordinate systems 

with current view 245 

with entities 243 

aligning entities 618 

aligning marker blocks on entities 321, 322 

aligning multileaders 174 

aligning text 
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on dimension lines 454 

options 456 

alternate dimension units, controlling 460 

alternate font 

setting the default file 681 

alternate text editor 424 

ambient light 635 

American National Standards Institute (ANSI) defined 

805 

American Standard Code for Information Interchange 

(ASCII) defined 805 

ampersand characters 724 

angle brackets 237, 239, 240 

angle drawing method 
construction lines 120 

infinite lines 118, 122 

rays 117 

angles 

angle direction and base settings 60 

calculating angle between points 326–328 
defined 805 

displaying instead of coordinates 234 

drawing unit settings 59, 809 

specifying for arcs 109, 111, 138 
specifying for chamfering 394 

specifying for dimension lines 435 

specifying for grid 80 

specifying for lines 104 

specifying for rotated entities 367–370 

specifying for text styles 288 

specifying locations by 237 

specifying text angle in text styles 291, 302, 303 

spherical and cylindrical coordinates 239 

zero angle settings 60 

Angular command or tool (dimangular) 435 

angular dimensions 435, 437 

creating 435 

defined 805 

formatting dimension unit display 458 

angular drawing units 805 

angularity tolerance symbol 462 

annotation scaling 216 

adding the current scale to entities 216 

assigning scales automatically 65, 216 

blocks 308 

dimension styles 456 

linetype scaling setup 54 

modifying scales assigned to entities 217 

purging the scales list 64 

setting up 62 

styles (dimension, text, multileader) 64 

text styles 288, 407 

turning on an off 215 

annotations 

adding in paper space 520 

creating as dimension text 440 

defined 805 

ANSI character sets 426 

aperture for entity snaps 86 

apostrophes 37 

app command modifier 37, 92, 93 
Apparent Intersection Snap command (apparent) 92 

appending scripts 778 

appload command 779, 780, 781 
Arc command (arc) 109 

Arc command or tool (dimarc) 437 

arc dimensions 437 

creating 437 

Arc Start-Center-Angle tool 109 

Arc Start-Center-End tool 110 

architectural 

drawing scale ratios 61 

drawing units 58 

arcs 

adding lines to 104 

angle dimensions for 435 

center marks 430 

converting donuts into arc entities 153 

converting polyline segments to arcs 136 

converting to circles 108 

defined 805 

diameter dimensions for 438 

direction of 114 

drawing methods 109 

elliptical arcs 114 

extending to boundaries 372 

joining 381, 389–390 
measured dimensions for 437 

measuring and marking off intervals 320–323 

moving with grips 365 

polyline drawing methods 138 

radius dimensions for 438 

Area command or tool (area) 323, 805 
calculating areas 323 
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ARG files (profiles) 704 

arranging windows 220 

See also views and viewports 

Array command or tool (array) 365 

arraying entities 360, 615, 805 

arrows and arrowheads 429, 452–456 

Artisan command or tool (artisan) 638 

Artisan Renderer 

creating a rendered image 638 

lights 639 

overview 638 

synchronize with 4MCAD 639 

Artisan Sync command or tool (artisan-sync) 639 

ASCII 

AutoCAD files. See DXF files 

defined 805 

text files 487 

assembling master drawings 490 

assigning aliases to commands 751 

associative dimensions 429 

at symbol 380 

Attach Drawing tool (Blocks toolbar) 305 

attaching 

attributes to blocks 486 

external references 491 

raster images 506 

attachment points 404 

See also insertion points 

attributes 

after exploding blocks 382 

attaching to blocks 486 

data in 470 

defined 303, 806 

definitions 484–486 
editing definitions 486 

extracting values 487–489 

fixed or variable values 484 

flags 484 

invisible data 484 

names 806 

overview 484–485 

snapping to insertion points 90 

text 806 

updating values for 486 

visible or hidden 484 

Audio Note command or tool (audionote) 773, 774, 775 
audio note icon 774 

audio notes 

attaching 773 

deleting 775 

overview 773 

playing 775 

selecting 774 

Audit command (audit) 49 

AutoCAD 

command name compatibility 751 

exporting 4MCAD files as AutoCAD files 655– 
668 

font compatibility 290 

4MCAD compatibility 3, 791 loading 

.cui files 728 

loading menu files 718, 757 
script files 776 

AutoCAD Development System programs (ADS) 3, 4, 
779 

AutoComplete command 31 

AutoLISP programs 3, 4, 780–782 

automatically 

assigning annotation scales 65 

changing code pages 426 

loading profiles 700 

reloading external references 495 

running scripts 778 

saving drawings 677 

automating 4MCAD functions 677 

AutoSave 677 

axes 

in coordinate systems 232, 235 

in ellipse drawing methods 113 

in elliptical arc drawing methods 114 

rotating entities around 615 

B 
background 635, 636 

background color 690 

Backgrounds command or tool (backgrounds) 637 

backward text 407 

base 635 

base points 

See also origin points 

defined 806 

for copying entities 354 

for entities to be moved 365 

for scaling entities 371 
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for stretching entities 370 

baseline 

of text 806 

offset in dimensions 449 

text alignment 410 

Baseline command or tool (dimbaseline) 433 

baseline dimensions 

adding to linear dimensions 430 

angular baseline dimensions 435 

creating 433 

defined 806 

illustrated 428 

basing drawings on templates 46–47 

basing layouts on templates 524 

beginner experience level 

changing level 3, 36, 677 
explained 3 

best fit for dimension text and arrows 456 
beveled edges on entities 394–398 

binding external references 497, 806 

bisect drawing method (infinite lines or rays) 117 

BL notation in extracted attribute file fields 488 

black-and-white 

printing 551 

tool icons 722, 734, 742 

blipmode command 227 

blips 

defined 806 

displaying current settings 330 

marker blips 227, 812 
turning on or off 227 

block command 472, 480, 481 

Block command (4MCAD Explorer) 307, 312 

Block command or tool (ddinsert) 477 

block name of layouts 301 

Block toolbar 305 

blocks 

See also Xref Manager command or tool (xrm) 

annotative 308 

as interval markers 320 

attributes 470–484 

Blocks list in 4MCAD Explorer 303 

BYBLOCK property 51–53 

clipping 498 

copying to other drawings 250 

creating 307, 470–477 

creating multileaders 172 

definitions 484–486 

deleting in 4MCAD Explorer 251 

displaying properties 329 

editing definitions 486 

entity storage in files 490 

exploding 382, 477, 483 

external references 490–500 

inserting 309, 472–??, 474–475, 477–478 
inserting drawings as 310 

insertion points 90, 305–310, 472–??, 474–475, 
477–478 

instances of 477, 480, 481 
listing 303 

multiple instances of 470, 474, 475 

names in extracted attribute file fields 487 

nesting 470 

number of occurrences 306 

overview 303, 470 

redefining and updating 470, 480, 481 

reusing blocks and drawings 10 

rotation angle and scale 475, 477, 478 

saving 470–477 

saving as drawing files 310, 474, 475 

search path for files 680 

selection filter 340 

snapping to insertion points 90 

BMP files 722, 734, 742 

bodies 

slicing and sectioning 623 

borders on drawings 520 

borders on images 511 

borders on viewports 

as available in each view 8 

setting as invisible 527 

bottom-aligned text 410 

boundaries 

extending entities to 372–376 
setting for paragraph text 404 

trimming or clipping entities to 376–377 

xref clipping 498 

Box command or tool (box) 593 

Break command or tool (break) 379 

breaking entities into pieces 

exploding blocks 483 

exploding into components 382 

splitting into two parts 379 

brightness of images 509 
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B-Spline curves. See splines 

buttons. See toolbars and tools 

BYBLOCK property 

after exploding 382 

colors 51–52 

creating blocks from entities on different layers 470 

defined 806 

linetypes 52–53, 279–281 
lineweights 56 

print styles 57 

BYLAYER property 

colors 268 

creating blocks from entities on different layers 470 

defined 806 

linetypes 52, 269–288 
lineweights 56 

C 
C character 

closing entities 237 

in extracted attribute file fields 488 

CAD defined 806 

calculating areas 323 

calculations 

area and perimeter 323 

distances and angles 326–328 

in 4MCAD and manual drafting 11 

scale factors and printed size 61–65 

callout lines. See leaders in dimensions 

Cartesian coordinates 

See also cylindrical coordinates; polar coordinates; 

spherical coordinates 

2-dimensional coordinate systems 235 

3-dimensional coordinate systems 238 

absolute and relative coordinates 235 

defined 806 
overview 7 

understanding coordinate systems 232, 234 

Cascade command 220, 253 

CDF files 487 

center command 88 

center lines 

defined 806 

for circles and arcs 430 

center marks 

defined 806 

for circles and arcs 430 

formatting 449–454 

center points of entities 

arcs 138 

circles 105 

dishes 601 

domes 602 

ellipses 113 

elliptical arcs 114 

polygons 134 

snapping to 85, 87, 88 

spheres 599 

center points of views 213 

Center Snap command (center) 88 

center-aligned text 410 

Center-Diameter circle method 105 

Center-Radius circle method 105 

chain dimensions. See continued dimensions 

Chamfer command or tool (chamfer) 398 

changing 

workspaces 33 

character sets for text display 426 

character string fields in extracted attribute file fields 488 

check spelling 419 

checking 

damaged files 49 

damaged files when opening 678 

solids 632 

chords in arcs 109, 138, 807 

Circle Center-Radius tool 105, 106, 107 

Circle command (circle) 105 

circle diameter symbol 412, 413 

Circle Radius-Tangent tool 107, 108 

circles 

See also donuts 809 

center marks 430 

creating from arcs 108 

diameter dimensions 438 

measuring and marking off intervals 320 

moving with grips 365 

radius dimensions 439 

circular 

arrays of entities. See polar arrays of entities 

runout tolerance symbol 462 

circularity tolerance symbol 462 

circumferences, defined 807 

cleaning solids 632 

Clear Entity Snaps command or tool (none) 85, 93 
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Clipboard 

copying entities into other drawings 356 

embedding objects into drawings 644 

embedding objects into other applications 654 

linking drawings into other applications 653 

clipping 

entities 376 

external references 498 

layout viewports 531 

raster images 512 

closed (entities), defined 807 

closing 

polylines 136, 388 
prompt boxes 32 

splines 149 

coaxiality tolerance symbol 462 

codepage command 426 

Collect Multileader command or tool (mleadercollect) 

175 

collecting multileaders 175 

color books 

creating 72, 75 
current entity color 52 

loading 76 

selecting a color 71 

Color dialog box 68, 70, 71 

color-dependent print style tables 

changing a drawing’s table type 555 

comparing with named tables 547 

converting to named 556 

copying, renaming, deleting 555 

creating 551 

default settings 706 

defined 546 

modifying 552 

colors 

applying shading 634–637 
changing in entity properties 350 

color books 71 

creating blocks from entities on different layers 470 

current settings 330 

default layer color 255 

dimension lines 450 

dimension text 455 

displaying information about entities 328 

displaying information about xrefs and blocks 329 

grip color 347 

index colors 68 

layer settings 253, 268–269 

mapping during printing 546 

multiline text 405 

overriding layer color 269 

print styles 552 

selecting entities by color 335 

solid faces 629 

working with 68 

columns of entities. See arraying entities; rectangular ar- 

rays of entities 

combining entities 

chamfering and filleting 394 

finding area of combined entities 324–326 

joining 381, 389 

lines and arcs in polylines 137 

solids 610 

combining zooming and panning actions 213 

Comma Delimited Format files 487, 807 
command bar 

Command Bar command 31 

defined 807 

displaying or hiding 31 

moving 24, 31 

navigating with arrow keys 684 

starting commands with 36 

using AutoComplete 31 

command strings for keyboard shortcuts 747 

commands 

active commands 35 

adding to menus 721, 723, 735, 743, 749, 753 

adding to ribbon 730, 733, 734 

aliases 751–776 

AutoCAD command name compatibility 751 
deleting from menus 726, 727 

deleting from ribbon 739 

displaying shortcut menus 24 

ending 35 

experience levels 677, 725, 737, 744 
information in status bar 31 

keyboard shortcuts for 39, 747–751 
loading custom programs 781 

modifying commands 37 

mouse shortcuts for 38 

nesting several commands 37 

prompt boxes 32 

renaming 726, 738, 746 
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repeating 36 

Script Recorder 41 

starting 36 

tracking history 37, 684 

commenting 

scripts 777 

company names on printouts 706 

complex entities 

See also types of entities (polylines; rectangles; do- 

nuts; and so on) 

defined 131 

exploding into components 382 

complex hatch patterns 190 

complex linetypes (4MCAD Explorer) 284 composite 

solids 610 

composite tolerances 461, 463 

compressing or expanding text 407, 410 

concentric entities. See donuts; tori 

concentricity tolerance symbol 462 

Cone command or tool (cone) 595 

cones 595, 807 
config command 677 

configuring 

code pages 426 

4MCAD 675 

layouts 519 

print settings 534 

connecting entities 

chamfering and filleting 394 

joining 381, 389 

constraining drawing 

to drawing limits 67 

to right angles 82, 83 

construction lines 

drawing 120 

construction lines. See infinite lines 

construction planes. See user coordinate systems (UCS) 

contiguous (entities), defined 807 

Continue command or tool (dimcontinue) 434 

continued dimensions 

adding to linear dimensions 430 

angular continued dimensions 435 

creating 435 

defined 807 
illustrated 428 

CONTINUOUS linetype 52, 56, 279 

contrast of images 509 

control codes for text 412, 413 

control points 148, 807 

convertctb command 557 

converting 

2-dimensional entities to three dimensions 580 

code pages 426 

color-dependent print style tables 556 

donut sides to arc entities 153 

drawing’s print style table type 555 

entities into components 382 

entities to other linetypes before deleting 251 

entities to other text styles before deleting 251 

entities to polylines 387 

line text to paragraph text 417 

plane sides to line entities 154 

polygon sides to line entities 136 

polyline segments to curves 389 

polyline segments to entities 136 

rectangle sides to line entities 132 

converting arcs to circles 108 

convertpstyles command 555, 556 

Coons Surface command or tool (edgesurf) 592 
Coons surface patch meshes 592, 807 

coordinate filters (point filters) 241, 807 

coordinate systems 

2- dimensional coordinate systems 235 

3-dimensional coordinate systems 238 

absolute and relative coordinates 235 

Cartesian coordinates 7, 232, 235, 806 
copying to use in other drawings 250 

cylindrical coordinates 240, 808 

defined 807 

deleting in 4MCAD Explorer 251 

icons for 233 

listing 293–294 

point filters 241, 243 

polar coordinates 234, 237, 814 

preset user coordinate systems 244 
right-hand rule 238 

spherical coordinates 239, 816 

user coordinate systems 233, 243, 531 

World Coordinate System 233, 245, 293, 579, 818 

Coordinate Systems list in 4MCAD Explorer 244, 293 
coordinates 

See also coordinate systems 

defined 807 

displaying for entities 328 
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finding point coordinates 235 

in ordinate dimensions 439 

of drawing limits 67 

viewpoints in three-dimensional drawings 576 

coplanar (entities), defined 807 

Copy command or tool (copy or copyclip) 354, 355–357, 
360 

Copy command or tool (4MCAD Explorer) 250 

copyclip command 356 

copying 

layers to other drawings 250 

layouts 525 

print style tables 555 

profiles 703 

ribbon items 738, 746, 750, 754 
settings to other drawings 250 

solid faces 628 

supported formats 711 

text in Prompt History window 38 

copying drawings 

dragging into other applications 654–655 

with external references for distribution 497 
copying entities 353–365 

arrays of entities 360, 615–617 

mirroring entities 359, 618 

parallel copies 357–359 

to other drawings 224, 356 

to other spaces 357, 366 

copying objects 

embedding 4MCAD data into other applications 

652–653 

embedding objects into drawings 643 

linking drawings to other applications 653 

linking objects to drawings 645 

corner points 

of planes 153 

of rectangles 132 
correcting mistakes 41 

Create Block command or tool (block) 472, 480, 481 

Create Snapshot dialog box 642 

creating 

audio notes 773 

blocks 310 

color books 72, 75 

files in different formats 563, 655 

hyperlinks 669 

layout viewports 527 

print style tables 551 

printed drawings 517 

profiles 699 

workspaces 33 

cropping 

entities (trimming) 376, 394–398 
external references 498 

raster images 512 

crosshairs 

defined 807 

entity snap target box 85 

crosshatching 190, 807 

See also hatch patterns and hatching 

Crossing Circle selection method 335, 808 
Crossing Polygon selection method 335, 370, 808 

Crossing Window selection method 335, 336, 370, 808 

CTB files 

assigning 550 

changing a drawing’s table type 555 

compared with STB files 547 

converting to STB files 556 creating 

551 

default settings 706 

defined 546 

modifying 552 

cubes 592–594, 808 

CUI files (ribbon files) 728 

current annotation scale 

customizing the scales list 62 

setting with automatic annotation scaling 65 

current editing session timer 331 

current settings 

layers 264 

linetypes 280 

lineweights 56 

loading profiles 700 

multileader style 176 

multiline style 143 

print styles 57 

text styles 291 

three-dimensional elevation and thickness 582 

tools 249 

user coordinate systems 295 

Current tool (4MCAD Explorer) 292, 295 

cursors 

coordinate information in status bar 31 

current position in coordinate systems 234 
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defined 808 

entity snap cursor decoration 709 

fly-over snap cursors 95, 709 
magnifying glass cursor 210 

curves. See also arcs; circles; ellipses; splines 

curving polyline segments 389 

Customize UI command (cui) 

customizing aliases 751–776 

customizing keyboard shortcuts 747 

customizing menus 718 

customizing ribbon 728–739 

customizing toolbars and tools 739, 747 

customizing 
4MCAD 41 

Quick Access toolbar 25, 27, 28, 713, 714, 716 

ribbon 25 

text editor 424 

user interface using workspaces 33 

customizing 4MCAD options 

aliases 751–776 
coordinate systems 243 

hatch patterns 190 

keyboard shortcuts 747 

menus 718 

print settings 534 

program settings 676–718 

ribbon 728–739 

running custom programs 779–782 

scripts for 776, 779 
templates 46 

toolbars and tools 24, 739 

Cut command or tool (cutclip) 356, 357, 366 

cutting entities 

moving to other drawings 224 

pasting in other drawings 356 

Cylinder command or tool (cylinder) 599 

cylinders 387, 599 

cylindrical coordinates 240, 808 

See also polar coordinates; spherical coordinates 

235 

D 
data 

attaching to blocks. See attributes 

attaching to drawings 11 

data fields for extracted attribute files 487–489 
databases 

for drawing data 204 

using information in drawings 11 

dates 

date stamps on printouts 706 

tracking time spent on drawings 331 

ddattdef command 484 

ddatte command 486 

ddattext command 489 

ddedit command 414, 419, 486 

ddgrips command 347 

ddinsert command 477 

decimal 

degrees in angular units 59 

drawing units 59 

decurving polyline segments 389 

default profile 702 

defaults 

arc direction 114 

code pages 426 

colors 255 

defined 808 

drawing environment (profiles) 702 

elevation 580 

entity colors 51 

icad.dwt template 23 
layers 251 

linetypes 53, 255, 269 

lineweights 56, 228, 270 
print style table settings 706 

print styles 57, 272 

text styles 407 

thickness 580 

values for attributes 484 

Define Attributes 

command or tool (ddattdef) 484 

dialog box 484 

defining 

complex linetypes 284–287 

dimension styles 447 

keyboard shortcuts 747 

linetypes 282–288 

lineweights 56, 228 

print settings 534 

text styles 290 

user coordinate systems 243, 294 
definition points 430 

degree symbols 412, 413 
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Delete command or tool (delete) 353 

Delete command or tool (4MCAD Explorer) 251 

deleting 

aliases 755 

audio notes 775 

clipping boundary 499, 512 

commands from menus 726, 727 

commands from ribbon 739 

dimension styles 449 

elements in 4MCAD Explorer 251–252 
entities 353 

external references 494 

freehand sketches 128 

hyperlinks 670 

images 515 
layouts 525 

lines in 3-dimensional entities 633–635 

multileader styles 177 

multiline styles 144 

page setups 537 

print style tables 555 

profiles 703 

segments of polylines 136 

settings 251 

solid faces 628 
xref clipping 500 

delta distances, calculating 326–327 

density of mesh surfaces 588, 589, 591, 592 

descenders on text characters 410 

deselecting entities 347 

Design Web Format 

exporting 502, 648, 657, 659 

importing 502, 648 

opening files 47 

detaching external references 808 

See also Xref Manager command or tool (xrm) 

Details tool (Block toolbar) 305 

dgnattach command 504 

Diameter command or tool (dimdiameter) 438 

diameter dimensions 

creating 438 

defined 808 

illustrated 428 

diameters 

circles 438 

donuts 151 

diametral dimensions 438 

DIESEL programs 785 

dimaligned command 432 

dimangular command 435 

dimarc command 437 

dimbaseline command 433 

dimcontinue command 434 

dimdiameter command 438 

dimedit command 

obliquing dimensions 443 

replacing dimension text with new text 445 

restoring dimension text to home position 445, 446 

rotating dimension text 444 

dimension lines 454 

See also dimension text; dimensions and dimension 

styles; extension line 

aligning text on 454 

defined 428, 808 

Dimension Style command 447 

dimension styles 

annotative 456 

Dimension Styles (4MCAD Explorer) 314 

Dimension Styles command or tool (setdim) 

arrows and arrowheads 452, 457 
baseline dimension offset 433 

creating, renaming, or deleting dimension styles 447 

dimension line colors 450 

formatting and positioning dimension text 454, 456 
rounding off numbers 458 

Dimension Styles dialog box 

Arrows tab 452–456 
Format tab 456 

Lines tab 449 

Text tab 454 

Units tab 458–462 

dimension text 

aligning on lines 454 

defined 443, 808 

formatting and positioning text 445, 446, 449, 454, 
456–458 

overview 429 

replacing dimension text with new text 445 

restoring dimension text to home position 445 

dimension tolerance 

controlling 465 

dimension units, alternate 460 

dimensions 

associative 429 
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exploded 429 

non-associative 429 

dimensions and dimension styles 

See also dimension text 

aligned dimensions 432 

angular dimensions 435–437 

arc dimensions 437–438 

arrows and arrowheads 452 

baseline dimensions 433 

creating dimensions 430–443 

creating or deleting styles 447 

diameter dimensions 438 

dimension styles defined 428, 447–462 

dimension variables 447, 808 

dimensions defined 808 

extension lines 429 

in paper space 441 

leaders and annotations 430, 440 
line colors 450 

line formats 449 

linear dimensions 430–435 

obliquing 443 

ordinate dimensions 439 

overview 428–430 

radius dimensions 439 

renaming styles 448 

types of dimensions 428 

units and rounding 458–462 

dimleader command 176, 441 
dimlinear command 431 

dimordinate command 440 

dimradius command 439 

dimtedit command 445 

directory paths for files 680 

Dish command or tool (dish) 601, 808 

disk space requirements for 4MCAD 22 

displacement points 

defined 809 

for copying entities 354 

for moving entities 365 

for stretching entities 370 

displaying 

annotative entities 215 

audio note icons 774 

command bar 31 

commands with AutoComplete 

turning on 

AutoComplete  at  the  command 

bar 31 

drawing information 328 

embedded files as icons 644 

entire drawings 214 

layers 265–267 
lineweights 228 

lists of text styles 408 

memory-intensive display elements 225 

menus 29 

Model and Layout tabs 523, 688 
multiple views of drawings. See also views and 

viewports 220 

online Help 42 

point entities 115 

Prompt History window 37 

properties information 329 

reference grid 76 

ribbon 25, 27 

rotated views 207 

scroll bars 689 

shortcut menus 24 

snapshots 643 

text 426 

text as boxes 225 

toolbars 29 

ToolTips 29 

warning messages 678 

xref clipping boundaries 500 

Distance command or tool (distance) 327 

Distance-Angle chamfer method 394–396 
Distance-Distance chamfer method 394 

distances 

calculating between points 326 

defined 809 

displaying instead of coordinates 234 

specifying in chamfering 394 

specifying locations by 237 

spherical and cylindrical coordinates 239, 240 
distant lighting 635 

Divide command (divide) 320, 322 

dividing display into multiple views. See views and view- 

ports 

dividing entities into equal segments 320 

docking 



831 
 

 
defined 809 

toolbars and command bar 24–31 

dollar signs 223, 524, 525 

Dome command or tool (dome) 602, 603, 809 

Donut command or tool (donut) 151 

donuts 

3-dimensional donuts (tori) 603, 605, 607, 608, 609 
converting sides to arc entities 153 

defined 809 

drawing 151 

editing 387 

filled or outlined 153 

dots 

in linetypes 283 

point entities 115 

doughnuts. See donuts 809 

draft quality images 511 

drafting manually compared to 4MCAD 5–13 
dragging 

drawings from the Internet 671 

drawings into other applications 654–655 

moving entities with grips 365 

new tools to toolbars 741 

Draw Freehand tool 127 

Draw Order command or tool (draworder) 369 

Draw Orthogonal tool 82, 83 

Draw Point command (point) 115 

Draw toolbar 29 

drawing code page 426 

drawing entities 

3-dimensional faces 585 

arcs 109 

boxes 592 

cylinders 599 
dishes 601 

domes 602, 603 

donuts 151 

edge-defined Coons surface patch meshes 592 

ellipses 113 

elliptical arcs 114 

extruded surface meshes 589 

freehand sketching 127 

hatching entities 190 

helices 150 

lines 104 

multilines 139 

planes 153 

point entities 115 

polyface meshes 587 

polygons 134 

polylines 136 

pyramids 596 

rays 117 

rectangles 132 

rectangular meshes 586 

rendering 635, 638 

revision clouds 168 

revolved surface meshes 590 

ruled surface meshes 588 

shading 634, 815 
spheres 600, 601 

splines 147, 149 
squares 132 

tori 603, 604 

traces 146 

wedges 594 

wipeouts 166 

drawing environment settings 698–704 

Drawing Exchange Format files 487, 655–668, 809 

Drawing Settings command or tool (settings) 

Blips display 227 

coordinate display in status bar 234 

drawing limits 66–76 

drawing units 58–61 
elevation and thickness settings 582 

entity snap target box 85 

freehand sketch settings 127 

grid rotation 80 

grid settings 76–82 
grip display options 347 

highlighting entities 350 

highlighting settings 227 

isometric snap and grid 81 

linetype scale settings 53–58 
linetype settings 52 

lineweight settings 56 

mesh surface settings 587, 589 

orthogonal setting 82 

point entity display 115 

polar tracking setting 83, 97, 98 
Quick Text feature 226 

shaded surface settings 634 

snap angle settings 80 

snap spacing settings 79 
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text height settings 65 

Drawing Settings dialog box - 3D Settings tab 

elevation and thickness settings 582 

mesh surface settings 589 

shaded surface settings 635 

Drawing Settings dialog box - Coordinate Input tab 

drawing limits 67 

entity snap settings 85 

entity snap target box 85 

grid rotation 80 

grid settings 76 

isometric snap and grid 81 

mesh surface settings 588 

orthogonal setting 82, 83 
snap angle settings 80 

snap spacing settings 79 

Drawing Settings dialog box - Display tab 

coordinate display in status bar 234 

grip display options 347 

highlighting entities 350 

highlighting settings 227 

Marker Blips display 227 

Quick Text feature 227 

Drawing Settings dialog box - Drawing Units tab 58 

Drawing Settings dialog box - Entity Creation tab 

entity color settings 52 

freehand sketch settings 128 

linetype scale settings 53 

linetype settings 53 

lineweight settings 56 

point entity display 115 

print style settings 57 

text height settings 65–66 

Drawing Settings dialog box - Entity Modification tab 

394–396 

Drawing Status command (status) 330 

drawing units 

angular units 59–61 
linear units 58 

real-world units and 58 

relationship to printed units 539 

rounding in dimension display 458 

scale factors and 61 

text height and 65 

drawings 

See also 2-dimensional drawings; 3-dimensional 

drawings 

3-dimensional and isometric drawings compared 81 

adding audio notes 773 

annotations, borders, and title blocks 520 

blocks 310, 477–484 

code pages 426 

copying entities to other drawings 224, 356 
copying settings to other drawings 250 

creating new drawings 23, 46 

damaged files 49 

default template 681 

displaying entire drawings 214 

displaying information about 328–332 

drawing limits 62, 66, 214, 330, 809 

drawing units 58 

embedding or linking into other applications 652– 
655 

exporting 655 

extents 117, 205, 214, 810 

external references 10, 303, 313, 318, 490 

grid settings 76–79 

isometric snap and grid 81 

layer settings 50 
layout viewports 526 

linetype settings 52, 56 

master and component drawings 490 

moving around in 205 

multiple drawings 3, 224 
opening 47 

orientation 538 

orthogonal setting 82, 83 

paper size 538 

passwords 101 

printing 560, 563 

recently used file list 694 

redrawing and regenerating 204 

reusability 5, 8, 10, 250 
saving 42 

scale factors 61–65 

search path for files 680 

sending through e-mail 668 

snap settings 85 

tracking time spent on drawings 331 

views 210 

writing sketches into drawings 127 

drivers for printers 539 

dtext command 

adding text to drawings 402 



833 
 

 
setting text style 408 

specifying alignment 403, 410, 411, 412, 413, 417 

dual monitors 697 

duplicating entities 353 

DWF files 

defined 809 

exporting 657, 659 

importing 502, 648 
opening 47 

dwfattach command 503 

DWG format 

supported copy formats 711 

DWGCODEPAGE 426 

DWT files 

defined 809 

importing 648 

opening 47 

saving 101 

DXF files 487, 502, 648, 649, 659, 809 

defined 809 

DXX files 487 

dynamic 

panning 207 

zooming 212 

Dynamic View Control 

command or tool (viewctl) 577 

dialog box 577 

dynamically rotating viewpoints in 3-dimensional draw- 

ings 577 

E 
edgesurf command 592 

Edit Block Attributes 

command or tool (ddatte) 486 

dialog box 486 

Edit Dimension Text command or tool (dimedit) 445 

Edit Length command or tool (editlen) 378 

Edit Polyline command or tool (editpline) 

curving and decurving 389 

joining 390 

moving polyline vertices 391 

opening and closing 388 

tapering polyline segments 393 

width and tapering 390 

Edit Text command or tool (ddedit) 

changing text properties 414 

editing attribute definitions 486 

editing text 414 

editing 

color book files 72, 75 
layout viewports 531 

linked or embedded objects 646 

polylines 387–393 
print style tables 552 

settings, single-click (4MCAD Explorer) 288 VBA 

programs 785 

editing drawings 

blocks 307 

embedded 4MCAD objects in other applications 

653 

in model space 526 

4MCAD compared to manual drafting 11 keyboard 

shortcuts 747 

layers 250, 251, 255, 264, 268 

linetypes 269, 277, 281, 282 

lineweights 270, 271 

linking objects to drawings 645 

print styles 272 

text styles 290–293, 407 

user coordinate systems 293–296 

views 298 
editing entities 

3-dimensional entities 614–621, 622–632 

aligning 618–621 

arraying 360, 615, 617 
attribute definitions 486 

breaking and joining 379–381, 389 

chamfering and filleting 394 

changing properties 350 

copying and pasting to other drawings 353 

curving and decurving 389 

cutting to Clipboard 356, 357, 366 
deleting 353 

dividing 322 

editing length 377 

elevation and thickness settings 583 

exploding into components 382, 483 

extending to boundaries 372 

grouping 384–387 

in model space 526 

measuring 321 

mirroring 359, 618 
moving 365 

moving polyline vertices 392 
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offset entities 358 

polylines 387 

rotating 367, 615 

scaling 371 

selecting before editing 334 

stretching 370 

tapering polyline segments 391, 393 
trimming 376 

vertices 391–393 

width of polylines 390 

with grips 347 

editing text 

alignment settings 410 

alternate text editor 424 

changing character sets 426 

changing text properties 414 

editing attribute definitions 486 

find and replace 415  

formatting 414 

moving dimension text 445 

replacing dimension text with new text 445 

restoring dimension text to home position 445 

rotating dimension text 444 

spelling 419 

text style settings 407 

unicode characters 425 

editlen command 378 

editpline command 

curving and decurving 389 

joining 390 

moving polyline vertices 392 

opening and closing 388 

tapering polyline segments 391, 393 
width 390 

elapsed-time timer 331 

electronically mailing files 668 

elements pane in 4MCAD Explorer 249 

Elevation command or tool (elev) 581 

elevation in 3-dimensional entities 580 

defined 809 

entering coordinates 242 

setting default elevation 581, 582 

Ellipse Axis-Axis tool 113 

Ellipse command (ellipse) 113 

ellipses 

drawing methods 113 

moving with grips 365 

Elliptical Arc Axis-Axis tool 114 

Elliptical Arc command (ellipse) 114 

e-mailing files 668 

embedding 

See also ActiveX; linking 

defined 809 

editing embedded objects 647, 653 
4MCAD objects into other applications 652 

objects into 4MCAD drawings 643–646 

EMF files 

defined 809 

exporting 4MCAD files as 655 

snapshot files 642 

end arrows 452 

ending 

commands 35 

points for moving entities. See displacement points 

script recording 777 

Endpoint Snap command (endpoint) 87 

endpoints of entities 

defined 809 

line entities 104 

methods of drawing arcs 109, 137 

snapping to 85, 87 

engineering drawing 

scale ratios 61 

units 59 

Enhanced Metafiles. See EMF files 

enlarging or reducing view of drawings 210 

entities 

See also types of entities (lines; rays; arcs; and so on) 

809 

3-dimensional entities 580–592 
area and perimeter 323 

arraying copies of entities 360, 615 

attaching audio notes 773 

attributes 484–489 

blocks 303, 307, 470–484 

breaking and joining 379, 389 

chamfering and filleting 394 

color settings 268 

complex entities 131 

copying or duplicating 353 

defined 809 

deleting 353 

displaying information about 328 

editing in viewports 526 
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elevation and thickness 580 

embedding into other applications 652 

grips 348–350 
linetypes 269 

lineweights 270 

measuring and marking off intervals 320 

moving and rotating 365–370, 614 

on deleted layers 251 

polylines 387 

print styles 272 

printing 517 

properties 350 

resizing 370–378 

selecting 265, 334, 430, 431 

simple entities 136 

text as 404 

viewing in 3D drawings 576–580 

zooming 212 

Entity Data defined 809 

Entity Properties dialog box 

changing entity properties 351 

editing attribute definitions 486 

elevation and thickness settings 582 

overriding layer color 269 

overriding layer linetype 270 

overriding layer lineweight 271 

overriding layer print style 272 

entity selection methods 335 

entity snap 

See also entity snap tools 

angle and base point 80 

aperture 86 

command modifiers 37 

controlling separately in multiple views 220 

current settings 85, 330 

defined 810 

definition point locations 430 

finding point coordinates with 235, 327 

fly-over snapping 95, 709, 711 

isometric snap and grid 81 

model space from paper space 522 

one-time entity snaps 37, 85 

origin 80 

override 810 

overview 7 

positioning ordinate points 439 

running entity snaps 85 

snap resolution defined 815 

spacing 79 

status bar information 31, 85 
target box 85 

turning off settings 93 

entity snap tools 

Apparent Intersection Snap 92 

Center Snap 85, 88 
Clear Entity Snaps 85, 93 

Endpoint Snap 85, 87 
illustrated 85 

Insertion Node Snap 85 

Insertion Point Snap 90 

Intersection Snap 85 

Midpoint Snap 85, 87 
Nearest Snap 85 

Node Snap 85, 91 
overview 85 

Parallel Snap 91, 97 

Perpendicular Snap 85, 89 

Quadrant Snap 85, 90 
Quick Snap 93 

Tangent Snap 85, 89 
entprop command 

changing entity properties 350 

layout viewports 531 

setting elevation and thickness 582 

erase command. See Delete command or tool (delete) 

erasing 

eraser tool 128 

freehand sketches 128 

segments of polylines 136 

error reporting 679 

ESNAP setting in status bar 85 

Esnap. See entity snap 

ETRACK setting in status bar 98 

exiting 4MCAD 43 

expanding or compressing text 407 

expblocks command 

creating and saving blocks 307 

inserting blocks 309 

inserting drawings as blocks 310 

inserting external references 313, 318 

listing blocks 304, 311, 317 
saving blocks as separate drawings 310 

experience levels 

changing level 3, 36, 677 
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explained 3 

setting for menus or commands 677, 725, 737, 744 

expfonts command 

See also Explore Text Styles command or tool 816 

creating new text styles 290, 407 

current text style 291 

editing text styles 291, 302 

explayers command 

copying and pasting layers to other drawings 250 

creating and naming layers 255 

current layer settings 50, 264 
deleting layers 251 

displaying list of layers 253 

hiding or freezing layers 265 

layer color settings 268 layer 

linetype settings 269 layer 

lineweight settings 270 layer 

print settings 267 

layer print style settings 272 

locking and unlocking layers 267 

Explode Attributes command or tool (burst) 383 

Explode command or tool (explode) 

converting donut sides to arc entities 153 

converting plane sides to line entities 154 

converting polygon sides to line entities 136 

converting polyline segments to entities 136 

converting rectangle sides to line entities 132 

exploding blocks 483 

exploding entities into components 382 

Explode Text command or tool (txtexp) 383 

exploded dimensions 429 

exploded hatching 190 

Explore Blocks command or tool (expblocks) 

creating and saving blocks 307, 312 

inserting blocks 309 

inserting drawings as blocks 310 

listing blocks 306 

saving blocks as separate drawings 311 

Explore Coordinate Systems command or tool (expucs) 

293 

Explore Layers command or tool (explayers) 248 

copying layers to other drawings 250 

creating and naming layers 256 

current layer settings 50, 264 
deleting layers 251 

displaying list of layers 254 

hiding or freezing layers 265 

layer color settings 268 layer 

linetype settings 269 layer 

lineweight settings 270 layer 

print settings 267 

layer print style settings 272 

locking and unlocking layers 267 

opening 4MCAD Explorer 248 

Explore Layouts command or tool (explayouts) 

listing views 301 

Explore Linetypes command or tool (expltypes) 

creating new linetypes 282, 284 

current linetype 277, 281 

listing linetypes 280 

renaming linetypes 288 

Explore Text Styles command or tool (expstyles) 

creating new styles 407 

creating new text styles 290, 301 
current text style 292 

editing text styles 291, 302 
listing text styles 289 

Explore Views command or tool (expviews) 

listing views 297 

saving and naming views 210, 297 
expltypes command 

creating new complex linetypes 284 

creating new linetypes 282 

current linetype 281 

listing linetypes 280 

loading additional linetypes 281 

renaming linetypes 288 

Export command or tool (export) 656, 658, 659 
exporting 

drawings 655 

layer states 278 

multiline styles 145 

profiles 704 

expstyles command 289 

See also Explore Text Styles command or tool 

expucs command 293 

See also Explore Coordinate Systems command or 

tool 

expviews command 296, 298, 300 
See also Explore Views command or tool 

Extend command or tool (extend) 

extending to boundaries 372, 414 
extending to implied boundaries 373 

extending 
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Apparent Intersection Snap 92 

dimensions 449 

entities to meet boundaries 372 

extension lines 

adding dimensions by selecting origins 430, 431 
adding dimensions by specifying lines 430 

arrows and arrowheads 452 

defined 429, 810 
formatting 449 

obliquing 443 

extension snaps 37, 92 

extents 

See also limits 

defined 810 

displaying entire drawings 214 

rays and 117 

scroll bar indicators 205 

external references 

displaying properties 329 

Extract Attributes command or tool (ddattext) 489 

extracting attribute data 484, 487–489 

Extruded Surface command or tool (tabsurf) 589 

extruding 

3-dimensional entities 584, 810 
solid faces 624 

surface meshes 588 

F 
Face command or tool (face) 585 

faces 585, 635, 810 

facet resolution 638 

fade of images 509 

feature control frames 462 

fence 

defined 810 

extending entities with 375 

illustrated 337 

trimming or clipping entities with 377 

Fence selection method 335 

fields in extracted attribute files 487 

file formats 

default Save As format 678 

exporting 655 

importing 502, 648 

4MCAD and AutoCAD files 3 

file paths 

for external references 496 

for raster images 515 

file size 

blocks and 470 

external references and 490 

linked and embedded objects and 645, 654 

files 

aliases 751 

audio 774 

basing on templates 46 

creating 46 

damaged 49, 678 
default Save As format 678 

embedding into drawings 644 

embedding into other applications 652, 653 
exiting 43 

exporting 563, 655 

external references 313, 318, 490 

extracted attribute data 484, 487 
fonts 290 

importing 502, 648 

inserting as blocks 477 

linking drawings into other applications 653 

opening 47 

passwords 101 

previewing before printing 558 

print style tables 546 

printing drawings 560 

profiles 698 

publishing drawings 563 

raster images 506 

recently used drawing list 694 

saving 42 

saving blocks as drawings 474, 475 
scripts 776 

search paths 680 

sending through e-mail 668 

shapes 776 

Fill command or tool (fill) 

filled or outlined lines on entities 132, 136, 153 

turning fill display on or off 225 

Fillet command or tool (fillet) 398 

filleting 

defined 394, 810 
methods 398 

filling entities 

displaying current settings 330 

donut lines 153 
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hatching 190 

planes 153 

polygon lines 136 

polyline lines 136 

rectangle lines 132 

turning off display to improve performance 225 

filtering entities during selection 338 

Find and Replace command or tool (find) 415, 417, 418 
find command 415 

finding point coordinates 235 

finding text 415 

Fit Tolerance values for splines 148 

fitting 

text and arrowheads on dimensions 456 

viewports to screen 527 

fixed 

attribute values 484 

coordinate systems 233 

flatness tolerance symbols 462 

flipping entities (creating mirror images) 359, 618 

flipping printed page 534, 538, 552 

floating toolbars and command bar 24, 35, 810 

floating viewports 

scale factor 530 

flyouts on tools 36 

font map 

setting the default file 681 

fonts 288 

AutoCAD fonts 290 

character sets 426 

defined 290 

font files 407 

in paragraphs 405 

in text styles 408 

search path for files 680 footers 

and headers on printouts 706 

forcing text to fit 410, 456 

form tolerance symbols 462–463 

formatting lines in dimensions 449 

formatting text 

dimension text 454–458 

text styles 407, 408 

fractional drawing units 58 

frames of images 511 

frames of wipeouts 167 

Free Orbit command (rtrot) 207 

Freehand command (freehand) 127 

freehand sketches 

drawing and inserting 127 

erasing 128 

setting as polylines or lines 128 

Freeze/Thaw tool (4MCAD Explorer) 266 

freezing layers 253, 266, 810 
Full Render command or tool (fullrender) 636 

full-size drawings 61 

G 
gaps in linetypes 283 

Geometric Tolerance dialog box 464 

geometric tolerances 462 

geometry, overlaying reference geometry 492 

global linetype scale 54 

greeking text (Quick Text feature) 226 

grid settings 

changing settings 76 

controlling separately in multiple views 220 

displaying current settings 330 

grid defined 810 

GRID setting in status bar 77 

isometric snap and grid 78, 81 

rotating grid 78, 80 

grips 

color and size 347 

editing entities with 347 

moving entities with 365 

resizing dimensions with 444 

resizing entities with 370 

scaling entities with 371–372 
selecting entities with 348 

stretching entities with 370 

turning on or off 347 

grouped entities. See blocks 

grouping entities 384–387 

H 
hand cursor (Pan tool) 205 

hand method to determine coordinates 238, 239 

handles (entity grips). See grips 

hardware acceleration 689 

hardware requirements for 4MCAD 22 hatch 

boundaries 190 

Hatch command or tool (hatch) 190 

hatch patterns and hatching 

adding to entities 190 
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4MCAD compatibility with AutoCAD files 3 

search path for files 680 

headers and footers on printouts 706 

height of named views 297 

height of text. See text height 

helices 

drawing 150 

Help 

assistance for 4MCAD 13 

displaying online Help 42 

search path for files 680 

hidden 

attributes 484 

edges on 3-dimensional polyface meshes 587 

lines 633 

hidden-line removal, defined 811 

Hide command or tool (hide) 633 

hiding 

command bar 31 

entities using wipeouts 166 

image frames 511 

layers 265, 267 
lines in 3-dimensional entities 633 

menus 29 

Model and Layout tabs 523, 688 
Prompt History window 37 

reference grid 77 

ribbon 25, 27 
scroll bars 689 

toolbars 29 

ToolTips 29 

warning messages 678 

wipeout frames 167 

xref clipping boundaries 500 

hierarchical viewing, external references 493 

high quality images 511 

high resolution displays 697 

highlight command 227 

highlighting entities 

edges of shaded entities 635 

turning highlighting on or off 350 

when selected 227 

horizontal 

grid spacing 76–79 

text orientation 407 

horizontal dimensions 

creating 430 

defined 811 

illustrated 428 

horizontal drawing method 

construction lines 120, 122 
infinite lines 118 

rays 117 
hyperlink command 669 

hyphens 223, 524, 525 

I 
icad print style tables 551 

icad.dwt template 23, 46 
icad.fnt font 407 

icad.lin file 281 

icad.pat library file 190 

ICM files (4MCAD menu files) 718, 757 

icons 

audio notes 774 

coordinate system 233 displaying 

embedded files as 644 large  

tools 30, 722, 734, 742 

ID Coordinates command or tool (idpoint) 235 

idpoint command 235 

i-drop feature 671 

IFC files 650 
ifcattach command 506 

image command 509, 514, 515 

imageattach command 506 

imageclip command 512 

imageframe command 511 

imagequality command 511 

images 

attaching 506 

changing paths 515 

clipping 512 

deleting 515 

modifying 509 

unloading and loading 514 

Images tool (Block toolbar) 305 

implied boundaries 

extending entities to 373 

trimming or clipping entities with 376 

importing 

files 502, 648 
layer states 278 

multiline styles 145 

profiles 704 
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imprinting solids 631 

improving performance 

hatch pattern memory requirements 190 

memory-intensive display elements 225 

included angles in arcs 109, 111, 138 
index colors 

current entity color 52 

selecting 68 

selecting for layers 268 

Infinite Line command or tool (infline) 118, 121, 122, 
123, 124, 125, 126 

infinite lines 

defined 811 

drawing 118 

filleting entities 400 

infline command 118, 121, 122, 123, 124, 125, 126 

Inquiry toolbar tools 

coordinates 235 

distances 326 

drawing status 329 

listing entity info 328 

time variables 332 

Insert Block dialog box 310, 478 

Insert External file Blocks tool (Block toolbar) 305, 310 

Insert Object dialog box 644, 646 

Insert tool (Block toolbar) 305, 310 
inserting 

blocks 477 

drawings from a Web site 671 

hatch patterns 190 

hyperlinks 669 
menu items 719 

menu sub-items 721, 723, 735, 743, 749, 753 

objects 644, 646 
raster images 506 

ribbon items 728 

ribbon sub-items 730, 733, 734 

text 402 

tolerances 464 

inserting dimensions 

aligned 432 

angular 435 

baseline 433 

continued 434 

diameter 438 

horizontal or vertical 431 

in paper space 441 

leaders on 440 

obliqued 443 

ordinate 439 

radius 439 

inserting drawings into other drawings. See Xref Manag- 

er command or tool (xrm) 

insertion command 90 

Insertion Point Snap command (insertion) 90 

insertion points 

attachment points 414 
base points for drawings 330 

for blocks 307, 309, 471, 472, 475, 478, 480 

for external references 492 

for text 402, 404, 408, 414 

in attribute definitions 484, 485 
in extracted attribute file fields 487 

snapping to 90 

insertobj command 644, 646 
installing 4MCAD 22 int 

command modifier 37 

4MCAD Explorer 

Blocks list 303–311 

Coordinate Systems element 244, 293–296 

copying elements to other drawings 250 

deleting elements 251 

Dimension Styles 314–316 
Layers element 253 

Layouts element 300–303 

overview 248–250 

purge tool 252 

single-click editing 288 

Text Styles element (text styles) 288–293 

tools 95, 249 

Views element 296–300 
4MCAD Explorer command or tool (explayers) 248 

intermediate experience level 

changing 3, 725, 737, 744 
explained 3 

Internet 

e-mailing drawings 668 

hyperlinks for 669 

opening drawings from 671 

publishing drawings to 670 

intersection of 3-dimensional entities 

defined 811 

intersecting solids 612 

snapping to 92 
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Intersection Snap command (intersection) 92 

intervals on entities, marking off 320 

invisible data. See attributes 

invisible edges 
of raster images 511 

on 3-dimensional faces 584, 585 

on 3-dimensional polyface meshes 587 

invisible layers 253, 255, 265 

isometric drawings 

defined 811 

enabling snap and grid settings 78 

isometric planes 

defined 811 

illustrated 81 

setting current plane 78 

J 
Join command or tool (join) 381 

joining 

combining solids 610, 611 

entities 381, 389, 394 
two views 222 

justification 

attribute text 485 

dimension line text 455 

K 
keyboard shortcuts 

adding or deleting 749 

customizing 747 

L 
Last Entity In Drawing selection method 335 

later states 

applying 277 

latitude lines 

dishes 601 

domes 602 

spheres 600 

layer states 

creating 274 

displaying 277 

importing and exporting 278 

layers 

blocks with entities from different layers 470 

BYLAYER property 51–58 

changing for text entities 414 

colors and linetypes 51–53, 268–272 

colors, linetypes, lineweights, and print styles 253 

copying to other drawings 250–251 
creating and naming 255, 264 

current layer settings 50, 264, 330 

defined 811 

deleting in 4MCAD Explorer 251 

displaying layer information 328 

displaying layer information for xrefs and blocks 

329 

freezing and thawing 255, 266 

hidden and visible 253, 254, 265, 267 

in entity properties 351 

Layer toolbar in 4MCAD Explorer 255 

Layers dialog box 268, 269, 270, 271 

Layers element in 4MCAD Explorer 250, 253 

locking and unlocking 253, 255, 267 

overview 6–7, 253–315 
print settings 267 

printing and nonprinting 253, 265, 267 

renaming 256 

selecting entities by layer 335 

setting properties to ByLayer 352 

status bar information 31 

transparent overlays 6 

layerstate command 

apply settings 277 

creating 275 

displaying 277 

displaying Layer State Manager 273 

importing and exporting 278 

layout command 524 

Layout tabs 

displaying 523, 688 
print options 534 

reordering 526 

layout viewports 

changing size 531 

clipping 531 

creating 527 

creating dimensions in 441 

defined 811 

invisible borders on 527 

locking 531 

maximizing 529 

minimizing 529 

modifying 531 
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scale factor 530 

selecting 531 

turning on and off 529 

UCS per viewport 531 

layouts 

command or tool (layout) 522 

copying 525 

creating from templates 524 

defined 811 

deleting 525 

displaying information for entities 328 

lineweights 542, 543, 544 

listing and saving layouts 300 

maximum number 523 

model space and paper space defined 521 

page setup 300 

print area and origin 539 

print options 534 

printing 560 

publishing 563 

renaming 525 

reordering 526 

saving as templates 525 

scale factor 539 

viewing list of 526 

Layouts list in 4MCAD Explorer 300  Leader 

command or tool (dimleader) 176, 441 

leader format of multileader styles 178, 180 

leaders in dimensions 
creating 441 

defined 430, 811 

leading zeros in dimensions 459 

least material condition (LMC) 463 

left-aligned text 410 

length of lines 

in freehand sketches 127 

specifying before drawing 104 

lengthening entities 370 

lengthening or shortening entities. See resizing entities 

levels of entities in arrays 615 

levels of precision. See accuracy 

libraries 

of hatch patterns 190 
of linetype 279, 281 

light sources 633, 634, 637, 639 

Lighting command or tool (lighting) 637 

limits 

See also extents 

defined 811 

displaying entire drawings 214 

displaying limits for drawings 330 

drawing limits for printing 541 

setting 62, 66 
limits tolerance. See tolerances 

lin files (linetype libraries) 281 

Line command or tool (line) 104 

Linear command or tool (dimlinear) 431 

linear dimensions 

aligned 432 

baseline 433 

continued 434 

creating 430 

formatting dimension unit display 459 

illustrated 428 

rounding in 458 

linear drawing units 58–59 

lines 

adding to arcs 104 colors 

in dimensions 450 

construction lines 120 

converting complex entity sides to 132, 136, 154 
dimensioning angles between lines 436 

drawing lines 104 

extending to boundaries 372 

filled or outlined on complex entities 132, 136 

formats in dimensions 449 

freehand sketches as 128 

hiding in 3D entities 633–635 

in hatching 190, 237 

in polylines 136 

infinite lines 118 

joining 381, 389 

measuring and marking off intervals 320 

moving with grips 365 

of text See text entities profile 

tolerance symbols 462 width 

133 

linetype scale 

changing global 54 

setting current 53 

linetype scales 

setting up 54 

linetypes 

changing in entity properties 350 
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compatibility with AutoCAD files 3 

copying to other drawings 249 

creating new linetypes 282 

current settings 52, 330 
default linetypes 255 

defined 811 

deleting in 4MCAD Explorer 251 

displaying information about entities 328 

displaying information about xrefs and blocks 329 

drawing scale factor and 61 

global scale settings 54 

layer settings 253, 269 

library files 281 

linetype scale settings 53 

loading additional linetypes 281 

overriding for entities 270, 280 

overview 279–280 
print styles 552 

setting up scaling 54 

status bar information 31 

Linetypes element (4MCAD Explorer) 281, 282 

lineweights 

current settings 56 

defined 811 

displaying 228 

layer settings 270 

overriding for entities 271 

print settings 542, 543, 544 

print styles 552 

scale factor 229 

set default 229 

linking 

See also ActiveX; embedding 

defined 811 

drawings into other applications 653 

editing linked objects 646 

external reference files 490–500 

objects into drawings 645–646 

raster images 506 

LISP programs 

calculating coordinates in rectangular meshes 586 

defined 811 

4MCAD compatibility 4 

running programs 780–782 

List Entity Info command or tool (list) 328 

List Processing Language. See LISP Programs 

listening to audio notes 775 

listing 

blocks and external references 304, 311, 317 
external references 493 

fonts and text styles 289, 314, 408 

hatch patterns 191, 192, 196, 200 

layers 254 
linetypes 280 

named views 296, 300 

print style tables 555 

user coordinate systems 293 

LMC (least material condition) 463 

Load Application Files dialog box 779, 780, 781 

load command 776, 781 

Load LISP or SDS Application command (appload) 779, 
781 

loading 

.NET programs 780 

additional linetypes 281 

code pages 426 

color books 76 

default drawing environment settings 702 

LISP programs 779, 781 

menu files 757 

profiles 700 

raster images 514 

location tolerance symbols 462 

locations in drawings 

absolute and relative coordinates 235, 239 
coordinate systems 232 

display order 369 

displaying entity coordinates 328 

finding point coordinates 235 

moving and rotating entities 367–370 
obtaining precise point locations 327 Lock/Unlock 

command tool (4MCAD Explorer) 267 

locking layers 253, 255, 267, 812 
locking layout viewports 531 

log file 

setting the default file 681 

M 
M or N direction 

defined 812 

in rectangular meshes 586 

in surface meshes 588, 589, 590, 592 

macros 784, 812 

See also scripts 
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magnification of drawings 

See also scale factors 

magnifying views 5 

methods 210 

zooming and panning in 3-dimensional drawings 

579 

magnifying glass cursor 210 

major axes 812 

Make Oblique command or tool (dimedit) 443 

Make Snapshot command or tool (msnapshot) 642 

manual drafting compared to 4MCAD 5 

MAPI protocol 668 

margins on drawings. See extents; limits 

marker blips. See blips 

marker blocks 320 

marking off interval on entities 320 

master drawings from component drawings 490 

material condition symbols 463 

materials 636 
Materials command or tool (materials) 637 

Maximize Viewport command or tool (vpmax) 222, 529 

maximum material condition (MMC) 463 

MDI (multiple-document interface) 3, 224, 812  

Measure command or tool (measure) 320, 321 

measurement lines. See dimensions and dimension styles 

measuring and marking entities 320 

memory requirements 

for 4MCAD 22 

hatch pattern requirements 190 

memory-intensive display elements 225 

menu files 

customizing menus 718 

4MCAD compatibility with AutoCAD files 3 

loading 757 

Menu Item command 721 

Menu Sub-Item command 721, 723, 735, 743, 749, 753 

menus 

adding commands 721, 723, 735, 743, 749, 753 
as part of workspaces 33 

changing experience levels 3, 36, 677, 725, 737, 
744 

creating new menus 721 

customizing 718 

deleting commands from 726, 727 
displaying and hiding 29 

displaying with ribbon 26 

menu bar illustrated 24 

renaming commands 726 

search path for files 680 

starting commands with 36 

Mesh command or tool (mesh) 586 

mesh surfaces. See surface meshes 

Messaging Application Program Interface (MAPI) 668 

middle-aligned text 410 

midpoint of two points 37 

Midpoint Snap command (midpoint) 87 

midpoints of entities 85, 87 

Minimize Viewport command or tool (vpmin) 223, 529 

minor axes 812 

Mirror command or tool (mirror) 359 

mirror3D command 618 

mirroring entities 359, 812 

mistakes, correcting 41 

MMC (maximum material condition) 463 

MNS files (AutoCAD menu files) 718, 757 

MNU files (AutoCAD menu files) 718, 757 

model space 

See also paper space 

copying entities to/from 357, 366 

defined 812 

displaying information for entities 328 

overview 8, 520 

print options 534 

snap from paper space 522 

switching to 522, 523 

switching to paper space 522 

viewport scale factor 530 

Model tab 
cannot delete 525 

displaying 523, 688 

displaying information for entities 328 

model space and paper space defined 520 

print options 534 

printing from 518, 560 
publishing 563 

viewports illustrated 520 

Modify toolbar 29 

modifying. See editing 

monochrome print style tables 551 

mouse shortcuts 38 

mouse wheel direction 693 

Move command or tool (move) 365 

moving 

around in drawings 205 
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external reference files 496 

profiles 704 

prompt boxes 32 

raster image files 514 

toolbars and command bar 24 

moving entities 

dimension text 445 

move command 365–367 

solid faces 625 

to other drawings 224 

to other layers before layer deletion 251 

vertices in polylines 392 

with grips 347 
msnapshot command 642 

mtext command 404, 424 

mtexted command 424 

mtp command modifier 37 

Multileader command or tool (mleader) 171 

multileader styles 

assigning 177 

creating 175 

deleting 177 

format of content 182 

format of leader structure 180 

format of leaders 178 

renaming 177 

setting current 176 

Multileader Styles Manager command or tool (mleader- 

style) 176 

multileaders 

add leader lines 174 

aligning 174 

collecting 175 

creating 171 

removing leader lines 174 

styles 175 

Multiline command or tool (mline) 139 

Multiline Styles command or tool (mlstyle) 

assigning to multiline 143 

creating 141 

deleting 144 

exporting 145 

importing 145 

modifying 142 

renaming 144 

setting current 143 

multiline text 

creating multileaders 171 

multilines 

drawing 139 

justification and scale 140 

styles 141 

multiple commands 

modifying commands 37 

nesting several commands 37 

repeating commands 36 

using while commands are active 35 

multiple copies 

of entities 354 

of external references 492 

of layouts 525 

multiple drawings 3, 224 
multiple monitors 697 

multiple views 
See views and viewports 

multiple-document interface (MDI) 3, 224, 812 

mview command 529 

N 
N direction. See M or N direction 

N symbol in extracted attribute file fields 488 

named print style tables 

changing a drawing’s table type 555 

comparing with color-dependent tables 547 

converting to 556 

copying, renaming, deleting 555 

creating 551 

default settings 706 

defined 546 

modifying 552 

setting current print style 57 

named text styles 407 

See also text styles 

named views 296, 812 

See also views and viewports 

Nearest Snap command (nearest) 87 

negative coordinate locations 232 

nested 

blocks 470, 812 
commands 37 

external reference files 492 

nested blocks 

See also blocks 

New command (newwiz) 46 
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new drawings 46 

new features 14 

New Item tool 95, 244, 249 

newwiz command 46 

node command 91 

Node Snap command (node) 91 

non-associative dimensions 429 

nonassociative hatches 812 

none command 93 

See also Clear Entity Snaps command or tool 

non-ISO linetypes 553 

nparallel command 91, 97 

numbers, rounding 458–462 

numeric fields in extracted attribute file fields 488 

O 
Object command (insertobj) 644, 646 

object linking and embedding. See Active X 

oblique angle 

in dimension lines 443 

in text styles 289, 291, 302, 407, 414 

Offset command or tool (offset) 358 

offset copies of entities. See parallel entities 

offset entities 357 

offsetting 

baseline dimensions 433 

solid faces 626 

text on dimension lines 455 

OLE. See Active X 

On/Off tool (4MCAD Explorer) 265 online 

Help 13, 42 

onweb command 671 

oops command 474 

Open command or tool (open) 47 

Open Drawing dialog box 48 

opening 

color books 72, 75 
damaged files 49 

drawings from a Web site 671 

drawings using Recover 678 

existing drawings 47 

external references 494 

files in other formats 502, 648 

files sent through e-mail 668 

4MCAD 23 

polylines 388 

profile files 704 

templates for printed layouts 524 

operating system code page 426 

Options command (config) 677, 680, 681, 684, 685, 
688, 690, 692, 693, 694, 705, 706, 707, 708, 709, 
711, 712 

Options dialog box 676 

options, setting or changing 676 

Ordinate command or tool (dimordinate) 440 

ordinate dimensions 

creating 440 

defined 812 

illustrated 428 

organizing information 

color books 72, 75 
for printing 517 

on layers 6, 253 

with blocks 470 

orientation 

of page 538 
of text 288 

of view 219, 220, 221 

printing upside down 534, 538, 552 
tolerance symbols 462 

origin points 

adding dimensions by selecting origins 430, 431 
compared to viewpoints in 3-dimensional drawings 

576–580 

defined 813 

displaying distances in ordinate dimensions 440 

of coordinate systems 243, 294 

of extension lines 430 

of print areas 542 

of snap and grid 80 

specifying locations by 237 

ORTHO setting in status bar 82 

orthogonal mode 

defined 813 

displaying current settings 330 

overview 7 

turning on 78, 82 
orthogonal projection 813 

osnap command. See entity snap 

outlined elements in 4MCAD Explorer 249 

outlining 

donut lines 153 

image frames 511 

planes 154 
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polygon lines 136 

polyline lines 136 

rectangle lines 132 

turning off fill display to improve performance 226 

wire-frame models 580 

output files of extracted attribute data 489 

Outside Circle selection method 335, 813 

Outside Polygon selection method 335, 813 

Outside Window selection method 335, 813 

overlaying external references 492 

overlays. See layers 

overscoring text 412, 413 

P 
page setups 

deleting 537 

Pan command or tool (pan) 205 

panels on ribbon 730, 733, 734 
panning 

See also zooming in or out 

defined 813 

in 3-dimensional drawings 579 

in viewports 522 

methods 205 

viewing drawings by 5 

paper sheet color 689, 690 

paper size 538 

paper space 

See also model space 

copying or resizing viewports. See model space 

copying entities to/from 357, 366 

defined 813 

dimensions 441 

displaying information for entities 328 

editing method 526 

layout viewports 527 

overview 8, 520 
print options 534 

printing from 300, 519 

scale factor 530 

snap from 522 

switching to 522 

paragraph text 

aligning 403, 410, 411, 412, 413, 417 
converting from line text 417 

creating 404 

parallel 

dimensions. See baseline dimensions 

drawing method, infinite lines and rays 117 

parallel entities 

defined 813 

filleting parallel lines 400 

parallel copies of entities 357 

Parallel Snap 91, 97 

Parallel Snap command (parallel) 91, 97 
parallelism tolerance symbols 462 

partial coordinates 241 

passwords for drawings 102 

Paste command or tool 

4MCAD Explorer 250 
pasteclip command 357 

Paste command or tool (4MCAD Explorer) 95, 249 

Paste Special command and dialog box 646 

pasting 

embedded objects into drawings 644 

entities into other drawings 224, 356 
layers into other drawings 250 

linked objects into drawings 646 

settings into other drawings 249 

text 406 

text in Prompt History window 38 

patch meshes 592 

paths for files 

color books 76 

external references 496 

raster images 515 

search paths 680 

patterned 

lines. See linetypes 
PDF 

publishing to 568, 570 

PDF files 656 

pdfattach command 503 

pen assignments 546–557 
pen numbers 552 

pencil tool 127 

percent signs 412, 413 

performance issues. See improving performance 

perimeters 813 

calculating areas 323 

perpendicular distances from origin points 439 

perpendicular entities 

defined 813 

infinite lines 118 
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rays 117 

snapping to 85, 88 

Perpendicular Snap command (perpendicular) 88 

perpendicularity tolerance symbols 462 

pface command 587 

photo-realistic 633, 635 

plan view 

coordinate system icons 233 

defined 813 

displaying 3-dimensional drawings 579 

Plan View command or tool (plan) 579 

planar entities 

converting to 3D 581 

defined 813 

planar tops for pyramids 597, 598 
Plane command or tool (plane) 153 

planes 

3-dimensional faces 585 

converting sides to lines 154 

defined 813 

drawing 153 

isometric planes 81 

playing 

audio notes 775 

scripts 776–779 

pline command. See Polyline command or tool (polyline) 

814 

plotters 

printing drawings 560 

publishing drawings 563 

selecting 539 

plotting. See printing drawings 

plus or minus signs 412, 413 

pmspace command 522 

point command 115 

point filters (coordinate filters) 241, 807 

Point Light command or tool (pointlight) 639 

Point Selection method 335 

Point Snap 91 

Point tool 115 

pointcloudattach command 504 

points 

See also base points; displacement points; endpoints 

of entities; insertion points; midpoints of entities; 

origin points; start points of entities 

changing point entity appearance 115 
defined 813, 814 

drawing point entities 115 

finding point coordinates 235 

interval marker point entities 320 

parallel copies passing through points 358 

point locations in coordinate systems 232 

snapping parallel 91, 97 
snapping to point entities 91 

polar 

arrays of entities 361, 615–617, 813 

coordinates 235, 237 

See also coordinate systems 

POLAR setting in status bar 83 

polar tracking, turning on 83 

Polyface Mesh command or tool (pface) 587 

polyface meshes 587 

Polygon command (polygon) 134 

polygon meshes 

edge-defined Coons surface patch meshes 592 

extruded surface meshes 588 

revolved surface meshes 590 

ruled surface meshes 587 

Polygon, Center-Side tool 135 

Polygon, Center-Vertex tool 134 

polygons 

See also polygon meshes 814 

calculating area and perimeter 323 

clipped images 513 

converting sides to lines 136 

defined 814 

drawing 134 

editing 387 

using as selection windows 337 

Polyline command or tool (polyline) 136 

polylines 

chamfering 396 

converting entities to polylines 387 

converting segments to entities 136 

curving and decurving 389 

defined 814 

donuts 151 

drawing 136 

editing 387 

editing vertices 391 

extending to boundaries 372 

filleting entities 398 

freehand sketches as 127 

joining 389 
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measuring and marking off intervals 320 

opening and closing 136, 388 

polygons 134 

rectangles 132 

tapering 136, 375 

width 136, 390 
position tolerance symbols 462 

positioning 

text on dimension lines 454 

positioning dimensions 

aligned dimensions 432 

angular dimensions 435 

arc dimensions 437 

baseline dimensions 433 

diameter dimensions 438 

dimension text 444 

horizontal or vertical dimensions 431 

leaders and annotations 441 

radius dimensions 439 

text and arrowhead positioning 456 

positioning entities 365 

See also insertion points 

blocks 477 

moving entities 347 positive 

coordinate locations 232 

ppreview command 558 

precision. See accuracy 

preferences command. See config command 

prefixes on dimension text 459 

presentations 642 

Preset Viewpoints 

command or tool (setvpoint) 576 

dialog box 577 

previewing 
block images 304 

files before opening 48, 101, 217 

print jobs 558 

Previous Selection selection method 335 

print area 541, 542 

print command 560 

Print command or tool (print) 560 

Print dialog box 542 

Print Preview command or tool (ppreview) 558 

Print Style Table Editor dialog box 554 

print style tables 

assigning 550 

changing drawing’s type 555 

comparing types 547 

copying, renaming, deleting 555 

creating 551 

default settings 706 

explained 546 

getting started with 548 

modifying 552 

search paths 680 

turning off 557 

print styles 

changing in entity properties 351 

default settings 706 

explained 546 

layer settings 272 

modifying 552 

setting current 57 

printers 

printing drawings 560 

publishing drawings 563 

selecting 539 

printing 

customizing the scales list 62 

printing drawings 

default print style settings 706 

drawing limits 541 

getting started 518 

headers and footers 706 

layer control 267 

layout viewports 526 

lineweights 542, 543, 544 

paper size and orientation 538 

paper space 8 

plotter drivers 539 

previewing before printing 558 

print styles 546–557 

printing and nonprinting layers 253, 265, 267 
printing drawings 560 

rendered drawings 637 

scale factors 61, 539 

selecting printer 539 

setting the scale 539 

upside down 534, 538, 552 
profile tolerance symbols 462 
profiles 698–704 

copying 703 

creating 699 

deleting 703 
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explained 698 

exporting 704 

importing 704 

loading 700 

renaming 703 

profiles for revolved surface meshes 590–592 

programming 4MCAD 779–785 

projected tolerances 461, 463 
projection lines. See extension lines 

prompt boxes 

choosing command options 32 

defined 814 

turning off 32, 694 
Prompt History window 

defined 814 

displaying drawing information 328 

navigating with arrow keys 684 

tracking history 37, 684 
prompts in status bar 484 

Properties command or tool (entprop) 

changing entity properties 218, 350, 352, 530 

changing viewport properties 531 

4MCAD Explorer 95, 249, 268, 269, 270, 271, 
291, 302 

setting elevation and thickness 583 

properties, selection by 338, 342, 345 
properties, setting to ByLayer 352 

proxies 

display of 799 

selecting 339 

publish command 563, 565, 566, 568, 570 

Publish command or tool (publish) 563 

publishing drawings 

publishing drawings 563 

publishing drawings to the Internet 670 

pull-down menus 719 

purge tool 252 

purging 64 

Pyramid command or tool (pyramid) 596, 597, 598 

pyramids 

drawing 596 

editing 387 

Q 
qtext command 226 

quadrant points of entities 90, 814 

Quadrant Snap command (quadrant) 90 

quadrilateral filled planes 153 

quality of images 511 

quick command 93 

Quick Select selection method 335 

Quick Snap command (quick) 93 

Quick Text feature 226 

quitting 4MCAD 43 

R 
radial dimensions 428, 430, 438 

radians 814 

radii of entities 

arc 109 
arcs 138 

circles 105, 106 

cylinders 599 

defined 814 

dishes 601 

domes 602 

filleting entities 398 

spheres 600 

tori 603, 605, 607, 608, 609 

Radius command or tool (dimradius) 439 

radius dimensions 439, 814 

Radius-Tangent-Tangent circle method 105 

RAM requirements. See memory requirements 

raster images 

attaching 506 

changing paths 515 

clipping 512 

deleting 515 

modifying 509 

unloading and loading 514 

Ray command or tool (ray) 117 

ray tracing 635 

defined 814 

rays 

defined 814 

drawing 117 

extending to boundaries 372 

filleting 400 

read-only files 48 

Real-Time Pan command (rtpan) 207 

Real-Time Zoom command (rtzoom) 212, 213, 214 

Record Script command or tool (recscript) 777, 778 

recording audio notes 773 

recording scripts 41, 776 
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Recover command (recover) 49 

Rectangle command or tool (rectangle) 132 

rectangles 

converting sides to lines 132 

defined 814 

drawing 132 

editing 387 

squares 132 

rectangular 

arrays of entities 363, 615, 814 
boxes 592 

clipped images 512 

filled planes 153 

Redo tool 41 

redoing actions 41, 814 

See also undoing actions 

redrawing screen 204, 814 

See also regenerating drawings 204 

reducing or enlarging view of drawings 210 

reference 

geometry 492 

grid. See grid settings 

Reference Grid tool 77 

reflections 635 

refreshing screen 204 

regardless of feature size (RFS) condition 463 

Regen command or tool (regen) 204, 226 

regenall command 204 
regenerating drawings 

See also redrawing screen 814, 815 

after editing text styles 291 

after enabling Quick Text 226 

compared to redrawing 204 

defined 814, 815 
Region command or tool (region) 605 

regions 604 

slicing and sectioning 623 

relative coordinates 

See also absolute coordinates; user coordinate sys- 

tems (UCS); World Coordinate System (WCS) 

815 

3-dimensional coordinate systems 238 

defined 815 

point filters 241 

polar coordinates 237 

spherical and cylindrical coordinates 239 

relinking external reference files 496 

reloading 

external reference drawings 313, 318, 491, 495 

raster images 514 

Remove Leader Lines command or tool (aimmleaderre- 

move) 174 

removing the current scale from entities 216 

removing. See deleting 

Rename Command (4MCAD Explorer) 256 

renaming 

attribute definitions 486 

blocks 307, 312 

commands in menus 726 

dimension styles 448 

layers 256 

layouts 525 

linetypes 288 

multileader styles 177 

multiline styles 144 

print style tables 555 

profiles 703 

ribbon items 738, 746 

Render command or tool (render) 634, 635, 638, 639, 
640 

rendering 

troubleshooting 689 

rendering 3-dimensional entities 633 

reordering 

entities 369 

Layout tabs 526 

repeating commands 36 

replacing dimension text with new text 445 

replacing text 415 

Reposition Dimension Text command or tool (dimedit) 

445 

resetting timer 331 

resizing 

layout viewports 531 

lineweights during printing 542 

toolbars 29 

viewports 531 

resizing entities 

arrowheads 453 

changing length 377 

extending to boundaries 372 

scaling 371 

stretching 370–371 
trimming or clipping 376 
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Restore Text Position command or tool (dimedit) 445, 
446 

restoring 

changed blocks to originals 481 

default drawing environment settings 702 

deleted entities 353 

dimension text to home position 445 

named views 299 

previous view of drawing 213, 223 
restricting. See constraining drawing 

reusing information 5 

copying settings into other drawings 250 

drawing environment settings 698 

4MCAD compared to manual drafting 8 

layouts 524 

reusing entire blocks and drawings 10 

Revision Cloud command or tool (revcloud) 168 

revision clouds 

custom settings 169 

drawing 168 

drawing using existing entities 169 

editing 169 

Revolved Surface command or tool (revsurf) 590, 591 

revolved surface meshes 590, 815 

revolving solids 606 

RFS (regardless of feature size condition) 463 

ribbon 

adding panels and commands 730, 733, 734 
as part of workspaces 33 

copying items 738, 746, 750, 754 

creating new ribbon tabs 730, 732, 733 

customizing 25, 728 

deleting commands from 739 

displaying and hiding 25, 27 

displaying with menus 29 

minimizing 26 

renaming items 738, 746 
starting commands with 35 

ribbon files 

customizing ribbon 728–739 

right-aligned text 403, 410, 411, 412, 413, 417 

right-click menus 24, 693 
right-click shortcuts 38 

right-hand rule to determine coordinates 238, 815 

Rotate command or tool (rotate) 367 

Rotate Dimension Text command or tool (dimedit) 444 

rotating 

3-dimensional entities 615 

angles in attribute text 485 

angles in elliptical arc drawing methods 114 

blocks 307, 309, 475, 477–478 

coordinate systems 243 

creating 3D arrays 617 

dimension text 444 

dimensions. See aligned dimensions 

entities 367, 614, 815 

grid 80 

images 509 

printed page 534, 538, 552 
solid faces 626 

text 402, 409, 414 

viewpoints in 3-dimensional drawings 577 

views 207 

visualizing rotation direction 238 

rotation points 

defined 815 

specifying 367 

rounding corners on entities. See filleting 

rounding numbers in dimension display 458 

roundness tolerance symbols 462 

rows and columns of entities. See rectangular arrays of 

entities 

rtrot command 208, 209, 210 
rubber-band lines 815 

Ruled Surface command or tool (rulesurf) 588 

ruled surface meshes 588, 815 
running 

entity snaps 85, 815 

4MCAD 23 

VBA programs 785 

runout tolerance symbols 462 

S 
SAT files 

importing 648 

Save As command or tool (saveas) 101 

Save Block dialog box 310 

Save Block to Disk 

command or tool (wblock) 474, 475 

tool (Block toolbar) 305 

Save command or tool (save) 42, 100 

Save/Restore View command or tool (view) 297 

saving 

attributes 484 
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blocks 307 

blocks as drawing files 474, 475 
blocks as separate drawing files 310 

color books 72, 75 

default Save As format 678 

drawings 42 

in other formats 655 

layouts as templates 525 

named views 297–299 

new complex linetypes 284–287 

new linetypes 282–288 

passwords with drawings 102 

profile settings 698 

sketches as part of drawings 127 

snapshots 642 

tracking last save time 331 

user coordinate system 233, 243, 244 

viewport configuration 223 

Scale command or tool (scale) 371 

scale factor 

lineweights 229 

scale factors 

blocks 307, 309, 477 

drawing to scale 5–6 

drawing units 58 

floating viewports 530 

in dimensions 459 

linetype scale 53 

magnifying view by precise scale factor 213 

printing lineweights 542 

printing to scale 539 

scaling entities 371 

understanding drawing scale factors 61 

viewports 530 

scale lists 

customizing 62 

scales list 64 

purging 64 

scaling. See resizing entities; scale factors 

scientific drawing units 59 

screen display 

customizing 682 

magnifying 5 

redrawing and regenerating 204 

turning off memory-intensive display elements 225 

screenshots (snapshots) 642 

Script Recorder 41 

scripts defined 815 

scroll bars 205 

displaying 689 

SDF files (Space Delineated Format) 487 

SDS programs 4, 41, 815 

search paths for files 496, 680 
searching text 415 

sectioning solids 623 

security for drawings 102 

segmented dimension lines. See continued dimensions 

segments 

converting polyline segments into curves 389 

defined 815 

editing in polylines 136 

measuring and marking off intervals on entities 320 

Select All Entities selection method 335 

Select Color command 268 

Select Font dialog box 408 

Select Layer by Entity command or tool (setlayer) 265 

Select Similar command or tool (selectsimilar) 344 

Select Toolbars dialog box 29–31 
selecting entities 

adding or removing entities from sets 347 

by block name 340 

by filter 338 

by properties 338, 342, 345 

by proxy 339 

by type 340 
by value 344 

highlighting 227, 350 

matching specific properties 335 
quick select 342, 345 

selection methods 334 

to copy or duplicate 354, 360 

to delete 353 

with audio notes 774 

selection 

sets 334, 815 
windows 335 

Selection modes 334 

semicolon 777 

separating solids 631 

setbylayer command 352 
setdim command 314 

arrows and arrowheads 452, 454, 456 

baseline dimension offset 433 

blocks and external references 248 
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creating dimension styles 447 

deleting dimension styles 449 

dimension line colors 450 

formatting dimension text 454 

renaming dimension styles 448 

rounding off numbers 458 

text positioning 454, 457 
settings 

arrows and arrowheads 452 

Artisan Renderer 638 

blips display 227 

blocks and external references 304, 305, 310, 311, 
317 

colors 268 

coordinate systems 248, 293 

default drawing environment 702 

default print style table options 706 

dimension styles 141, 142, 176, 447 

distances and angles display 234 

drawing environment 698 

elevation and thickness 580–585 
entity snap 85 

fills 225 

grip display options 347 

highlighting 350 

layers 50, 249–272 
linetypes 249 

lineweights 228, 270–271 

mesh surfaces 587 

Quick Text display 226 

setting layers by selecting entities 265 

shaded surfaces 634 

text styles 248, 288, 407 
user coordinate systems 243 
views 248, 296, 298, 300 

settings command 

dimension styles 458 

drawing limits 66 
drawing units 59 

elevation and thickness 581–583 

entity snap target box 86 
freehand sketches 128 

grid settings 77, 80 

highlighting 350 

isometric snap and grid 81 

linetype scale 53 

linetypes 53 

lineweights 56 

orthogonal mode 82, 83, 97, 98 

point entity display 115 
print styles 57 

shaded surfaces 635 

snap angles 80 

snap spacing 79 

text height 65 

Settings pane in 4MCAD Explorer 248 

setucs command 244, 245 

setvpoint command 576 

Shade command or tool (shade) 634 

shaded image 634 

shading surfaces of 3-dimensional entities 634, 815 

shadows 635, 637 

shape command 776 

shelling solids 631 

shortcut menus 693 

shortcuts 

adding access keys to commands 724 

customizing keyboard shortcuts 747 

displaying shortcut menus 24 

entity snaps menu 85 

keyboard 39 

using the mouse 38 

shortening entities 370 

shortening or lengthening entities. See resizing entities 

SHP files (fonts) 290 

SHX files (fonts) 290 

sides of entities 

editing polygons 136 

editing polylines 136 

editing rectangles 132 

maximum number for polygons 134 

specifying to draw polygons 136 

simple entities 103 

See also types of entities (lines; rays; arcs; and so on) 

simulating 

3-dimensional drawings 81 

paper output on screen. See paper space 

size 

of files. See file size 

of grips 347 

of printed drawings 62–65 
of text. See text height 

size of entities 

displaying size information 328 
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point entities 115 

resizing. See resizing entities 

sketch command. See freehand command 127 

sketching freehand entities 127 

slanted 

dimensions. See aligned dimensions 

text. See obliquing angle 

SLD files (snapshots) 642 

slicing solids 624 

slide 

files 642 

shows 642 

small tool icons 30 

smoothing angle 638 

snap 

angle 815 

grids 815 

model space from paper space 522 

resolution 815 

settings. See entity snap 

tool 79 

SNAP setting in status bar 79 

snapshots 

defined 816 

saving 642 

solid 

boxes 593 

composites 610 

cones 595 

cylinders 599 

dishes 601 
domes 602 

extruding solids 605, 607, 608, 609 

filled planes 153 

fills 225 

pyramids 596 

regions 605 

revolving solids 606 

spheres 600 

tetrahedrons 596 

tori 603 

wedges 594 

Solutions Development System (SDS) 4, 41, 815 

sound clips 773 

Space Delimited Format files 487 

spacing 

for entity snap 79 

in reference grid 77 

special characters 412, 413 

speed of processing. See improving performance 

Spelling command or tool (spell) 419 

spelling of text 419 

Sphere command or tool (sphere) 600, 601 

spheres, drawing 600 

spherical coordinates 239, 816 
See also coordinates 

Spline command or tool (spline) 147 

splines 

closing entities 149 

drawing 147, 149 
fit tolerance 148 

splitting entities 379 

Spot Light (spotlight) 640 

spotlights 635 

squares 133 

stacking entities in arrays 615 

standard 

text style 288, 407 
Standard toolbar 29 

start arrows 452 

start points of entities 

line entities 104 

methods of drawing arcs 109, 137 
starting 

direction of arcs 109 4MCAD 

23 

new drawings with templates 23, 46 
points for moving entities. See base points 

script recording 776 

starting commands 

from command bar 36 

from menus 36 

from the ribbon 35 

from tool palettes 35 

from toolbars 35 

status bar 

assistance with 4MCAD functions 13 

displaying cursor position 234 

illustrated 24, 31 
prompts for commands 718 

viewing model space and paper space 522 

status command 330 

status of drawings, displaying 49, 329 

STB files 
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assigning 550 

changing a drawing’s table type 555 

compared with CTB files 547 

converting to 556 

creating 551 

default settings 706 

defined 546 

modifying 552 

Stop Recording command or tool (stopscript) 777 

straightening curves in polylines 389 

straightness tolerance symbols 462 

Stretch command or tool (stretch) 370 

stretching 

entities 347, 370 
text 410 

style command (4MCAD Explorer) 290, 301 

styles 

annotative 64 

dimension styles 447 

multileader styles 175 

multiline styles 141 

print styles 546 

text styles 407 

stylesmanager command 

copying print style tables 555 

deleting print style tables 555 

modifying print style tables 553 

new print style tables 551 

renaming print style tables 555 

subtended angles 435 

Subtract From Set selection method 335 

subtracting areas of combined entities 325–326 
subtracting solids 611 

suffixes on dimension text 459 

surface 

material properties 635 

of revolution 816 

profile tolerance symbols 462 

shading 634 

surface meshes 

density 588, 589, 591, 592 

edge-defined Coons surface patch meshes 592 

extruded mesh surfaces 588 

polyface meshes 587 

rectangular meshes 586 

revolved surface meshes 590 

ruled surface meshes 587 

surface models 

See also wire-frame models 

defined 580 

removing lines and applying shading 633–635 
SVG files 

defined 816 

switching between model space and paper space 522 

switching between monitors 697 

symbols 

datum reference letters 464 

material condition symbols 463, 464 

special characters in text 412, 413 
symmetry tolerance 462 

tolerance 462, 464 

synchronizing drawing in Artisan Renderer 639 

SYSCODEPAGE 426 

system requirements for 4MCAD 22 

system variables 816 

T 
tables, mapping print settings 546 

tabsurf command 589 

tabulated surfaces 816 

Tangent Arc tool 111 

tangent command 89 

tangent entities 816 

drawing arcs tangent to an arc or line 111 

drawing circles tangent to entities 107, 108 

drawing donuts tangent to entities 152 

snapping to 85, 89 

tangent points on splines 147 

Tangent Snap command (tangent) 89 

tapered polylines 136, 393 
after joining 389 

changing width 390 

results of extending 375 

tapering solid faces 627 

target box for entity snaps 85 

templates 

basing new drawings on 46 

default icad.dwt template 23 

defined 816 

for extracted attribute files 487–489 
for printed layouts 524 

importing 648 

opening new drawings with 23 

saving from layouts 525 
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setting default template 681 

temporary files search path 680 

terrain models 586 

tetrahedrons 596 

text 

for multileaders 171 

text annotations 440 

Text command or tool (dtext) 

adding text entities 402 

setting text style 408 

specifying alignment 410 

text editor 424 

text entities 

See also text height; text in attributes; text on dimen- 

sion lines 

adding text to drawings 402 

alignment 410 

alternate text editor 424 

attachment points 408, 414 
backward or upside-down text 407 

changing properties 414 

character sets 426 

code page 426 

color 414 

compressing or expanding 410 

control codes and special characters 412, 413 

converting line text to paragraph text 417 

editing text 414 

find and replace 415 

fitting between two points 410 

insertion points 90, 402, 408 

layer settings 414 

obliquing 407 

paragraph text 404 

Quick Text feature 226 

rotation angle 402 

short lines of text 402 

spelling 419 

text styles 407 

turning off display to improve performance 227 

width 407 

text files 

script files 776 

templates for extracted attribute files 487 

text height 

calculating for different scale factors 61 

changing height 291, 302 

drawing scale factor and 61 

in dimension styles 455 

printed drawings and 61 

short lines of text 402 

specifying 65, 409, 414 
text styles 407 

text in attributes 485, 486 

text on dimension lines 
colors 455 

formatting and positioning 454, 456 
illustrated 428 

moving text 445 

prefixes or suffixes 459 

replacing with new text 445 

restoring to home position 445 

rotating 444 

specifying text styles in dimension styles 455 

text size. See text height 

text styles 

annotative 288, 407 

applying 408 

attribute text 485 

changing styles 414 

compatibility with AutoCAD files 3 

copying to other drawings 250 

creating new styles 290, 407 
current text style 291 

deleting in 4MCAD Explorer 251 

editing attribute definitions 486 

editing styles 290 

listing available styles 408 

overview 288 

vertical, upside-down, or backward text 289 

Text Styles dialog box 408 

Text Styles element in 4MCAD Explorer 288 

text-based data. See attributes 

thawing layers 255, 266, 816 
Thickness command or tool (thickness) 580 

thickness in 3-dimensional entities 816 

See also elevation in 3-dimensional entities 

changing in entity properties 350 

default thickness 580 

three-dimensional drawings. See 3-dimensional drawings 

three-dimensional entities. See 3-dimensional entities 

three-point 

arc method 109 

through points 358, 816 
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thumbnails of blocks 304 

thumbnails of drawings 47 

tick marks on dimension lines 452 

tiers of dimensions. See baseline dimensions 

Tile Horizontally command 220 

Tile Vertically command 220 

tiling windows 220 

tilting. See obliquing angle 

time stamps on printouts 706 

Time Variables command or tool (time) 332 

timers 

for AutoSave 677 

tracking drawing sessions 331 

title blocks 

adding in paper space 520 

as available in each view 8 

Tolerance command or tool (tolerance) 464 

tolerances 

adding geometric tolerances to drawings 462 

composite tolerances 463 

datum reference letters 464–465 
defined 816 

in Geometric Tolerances dialog box 464 

limits tolerance 816 

material condition symbols 461, 463 
projected tolerances 463 

symbols, defined 462 

tolerance commands 816 

variance tolerance 816 

tool palettes 

starting commands from 35 

toolbar 

customizing Quick Access toolbar 25, 27, 28, 713, 
714, 716 

toolbars and tools 

as part of workspaces 33 

compared to manual drafting 6 

creating new toolbars 741 

customizing tools and toolbars 24, 739 
defined 817 

displaying and hiding toolbars 29 

docking or floating toolbars 29 

entity snaps tools 85 

experience levels for toolbars 677 

flyouts 36, 742 
illustrated 24 

4MCAD Explorer tools 95, 249 

large tool icons 30, 722, 734, 742 

Layer toolbar 255 

size and color of tools 29 

starting commands from 35 

triangles on tools 742 

ToolTips 

adding to tools 739 

assistance with 4MCAD tools 13 turning 

on or off 29 

top-aligned text 410 

tori 603, 605, 607, 608, 609, 817 

total runout tolerance symbols 462 

Trace command (trace) 146 

tracking 

command history 37, 684 
last files used 48 

number of entities 303 

trailing zeros in dimensions 459 

transferring drawings to other people 497 

transparent 

commands 817 

images 509 

overlays. See layers 

triangles on tools 742 

triangular filled planes 153 

Trim command or tool (trim) 376 

trimming 

external references 498 

printed drawings 541 

trimming entities 

chamfering 394 

filleting 398 

troubleshooting 

drawing disappears from paper space 522 

lineweight display 228 

profile settings not saved 699 

setting layout viewport borders as invisible 527 

text display 426 

wipeout display 166 

true colors 

current entity color 52 

selecting for layers 268 

turning features on and off 

annotation scaling 215 

turning features on or off 

AutoSave 677 

blips 227 
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entity snaps 93 

grips 347 

highlighting 227, 350 

image frames 511 

orthogonal setting 82 

polar tracking setting 83, 97, 98 

print style tables 557 

prompt boxes 32, 694 
recent drawings list 694 

reference grid 77 

snap settings 79 

solid fill display 225 

text display 226 

wipeout frames 167 

xref clipping boundaries 500 

turning off 

AutoComplete at the command bar 31 

two-dimensional 

drawings. See 2-dimensional drawings 235 

entities. See 2-dimensional entities 235 

two-point circle method 105 

txt2mtxt command 417 

typing commands 

aliases 751 

entity snap commands 85, 87 

in command bar 36 

to load custom programs 781 

U 
UCS. See user coordinate systems (UCS) 243 

undelete command (undelete) 353, 472 

underscore characters 223, 524, 525 

underscoring text 412, 413 

undoing actions 41 

See also redoing actions 

Unicode characters 425 uniform 

width for polylines 390      

units. See drawing units 

unloading 

external references 494 

print style tables 557 

raster images 514 

unlocking layers 267, 817 
updating 

all instances of blocks 470, 480, 481 
attribute values 486 

block definitions 480, 481 

drawing in Artisan Renderer 639 

drawings inserted as blocks 310 

external references 490, 495 

file paths for external references 496 

file paths for raster images 515 

upside-down printing 534, 538, 552 

upside-down text 407, 414 

user coordinate systems (UCS) 

See also coordinates, World Coordinate System 

(WCS) 

command (4MCAD Explorer) 244, 294 
command or tool (setucs) 243 

current UCS 295 

defined 233, 817 
defining per layout viewport 531 
defining systems 243, 294 

dialog box 243 

listing 293 

plan views of drawings 579 

preset user coordinate systems 244 

user levels. See experience levels 

V 
validated attribute values 485 

values 

editing attribute values 486 

extracting attribute values 487 

variable attribute values 484 

variables 

dimension variables 447 

system variables 816 

variance tolerance 

See also tolerances 

variations in geometry. See tolerances 

vba command 785 

VBA macros command (vbarun) 785 

VBA programs 4, 817 

vbarun command 785 

vectors 817 

vertical 

drawing method (construction lines) 122 

drawing method (infinite lines) 118 

drawing method (rays) 117 

grid spacing 77 

orientation for text 407 

text orientation 291, 302 
vertical dimensions 
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creating 431–432 

defined 817 

illustrated 428 

vertical drawing method 

construction lines 120 

vertices 

chamfering 396 

defined 817 

drawing polygons 134 

editing polyline vertices 391 

filleting 399–400 
View command (4MCAD Explorer) 298 

View Snapshot 

command or tool (vsnapshot) 643 

dialog box 643 

snapshots 643 

viewing 

See also views and viewports; windows 817 

3-dimensional drawings 576 

command bar 31 

drawing thumbnails 47 

dynamic view controls 577 

external references 493 

hiding lines in 3-dimensional entities 633 

layout viewports 529 

list of layouts 526 

locked layers 267 

Model and Layout tabs 688 

panning drawings 205 

plan view 579 

preset viewpoints 576 

print jobs before printing 558 

print style tables 552 

Prompt History window 38 

redrawing screen 204 

regenerating drawings 204 

rotating the view 207 

scroll bars 689 

shading on entities 634 

text 426 

thawed layers 266 

ToolTips 29 

turning layers on 265 

viewpoints in 3-dimensional drawings 576 

workspaces 34 

zooming 210 

viewpoints in 3-dimensional drawings 817 

viewports 

maximizing 222 

minimizing 223 

views and viewports 

See also model space; paper space 817 

arranging windows 220 

changing properties 299, 531 

copying views to other drawings 95, 249 

creating layout viewports 527 

deleting views in 4MCAD Explorer 251 

displaying entire drawings 214 

height and width of views 296 

invisible borders on layout viewports 527 

joining two views 222 

layout viewports overview 526 

listing named views 296–297 
moving around in viewports 205 

multiple views 220 

orientation of viewports 219, 221 

restoring named views 299 

restoring previous view of drawing 213 

saving view configuration 223, 297 

scale factor 530 

switching between model and paper space 522 

turning on and off 529 

viewport configuration defined 817 

viewports defined 520, 817 

views defined 817 

zooming and panning 526 

Views list in 4MCAD Explorer 296 

visibility of layers 253, 255, 265 
visible 

attributes 484 

grid. See grid settings 

Visual Basic Editor command (vba) 785 

Visual Basic for Applications 4 

Visual Basic for Applications (VBA) 4, 784, 817 
visualizing coordinate systems 238 

W 
warnings when opening drawings 678 

WAV files 773 

wblock command 474, 475 
WCS. See Word Coordinate System (WCS) 

Web sites 

accessing 4MCAD 671 

hyperlinks for 669 
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opening files from 671 

publishing drawings for 670 

Wedge command or tool (wedge) 594 

wedges 594, 818 

what’s new 14 

width 

after creating regions 605 

after exploding 382 

after joining 390 

changing the polyline width 390 

lineweight settings 56 

of donuts 152 

of fields in extracted attribute files 488 

of lines 133 

of polylines 136, 393 

printing lineweights 542, 543, 544 

width of text 

in text styles 289, 291, 302, 407 
specifying 414 

Window Circle selection method 335 

Window Polygon selection method 335, 337 

Window-Inside selection method 335, 336 

Windows 

metafiles. See WMF files 

windows 

See also views and viewports 817 

arranging 220 

cascading 220 

displaying entire drawings 214 

joining two views 222 

listing and saving named views 296 

main 4MCAD window 24 

model space and paper space defined 520 

moving around in 205 

multiple views 220 

opening new windows 220 

saving arrangements 223 

selection windows 335 

tiling 220 

unique numbers 220 

Windows Clipboard 

See Clipboard 

embedding objects into drawings 643 

embedding objects into other applications 652, 669 

linking drawings into other applications 654 

Wipeout command or tool (wipeout) 166 

wipeouts 166–168 
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wire-frame models 

See also surface models 

defined 580, 818 

removing lines and applying shading 633 

witness lines. See extension lines 

WMF files 

defined 818 

snapshots 642 

workspaces 33 

World Coordinate System (WCS) 

defined 818 

overview 233 

plan views of drawings 579 

selecting 245 

working with coordinate systems 293 

World tool (4MCAD Explorer) 95, 249 

Write, Then Resume option (freehand command) 127 

writing sketches into drawings 127 

X 
x-axis 

in coordinate systems 232 

xclip command 

deleting 500 

polyline clipping boundaries 499 

rectangular clipping boundaries 499 

turning xref clipping on and off 500 

Xlines 118 

See also infinite lines 

x-ordinate dimensions 439 

Xplode command or tool (xplode) 383 

Xref Manager command or tool (xrm) 490, 491 

attaching or detaching external references 492 

binding external references 497 

changing file paths 496 

clipping 498 

defined 303, 810 

inserting drawings as 313, 318 
nesting 492 

overlaying 492 

overview 490 

reloading or updating 495 

reusing entire blocks and drawings 10 

xrm command 

See also Xref Manager command or tool (xrm) 

attaching external references 492 

binding external path names 497 
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clipping boundaries 498 

detaching external references 495 

moving or changing the path name 496 

opening external references 494 

reloading or uploading external references 495 

search path for files 680 

searching for external references 496 

unloading external references 494 

viewing external references 493 

Y 
y-axis 

in coordinate systems 232 

y-ordinate dimensions 439 

Z 
z-axis 

in coordinate systems 232 

z-coordinates in elevation 580, 583 

zero angle settings 60 

Zoom All tool 214 

Zoom Center tool 214 

Zoom command (zoom) 210, 530 

Zoom In command or tool (zoom) 210, 213 

Zoom Left tool 213 

Zoom Out tool 210 

Zoom Previous tool 213 

zooming in or out 

changing mouse wheel zoom direction 693 

changing viewport scale factor 530 defined 

818 

in 3-dimensional drawings 579 

in print preview window 559 

in viewports 526 

overview 210 

viewing drawings 5 

zooming methods 210 
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