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Preface 
 

This Quick Start Guide provides a fast and friendly introduction on 4MCAD main 

features and functionalities. All the features and functions of the program are 

presented and explained in detail within the complete User’s Guide, along with 

informative examples.  

4MCAD is a CAD alternative that provides open DWG file compatibility, similar 

environment, as well as full support for AutoCAD commands, menus, scripts, styles, 

patterns etc. 

The 4MCAD program is available in four versions: 

4MCAD Viewer: CAD Viewing & Printing plus adding texts & dimensions. 

4MCAD Classic: 2D/3D CAD Complete Design. 

4MCAD Standard: 4MCAD Classic + Raster-Image + Rendering. 

4MCAD Professional: 4MCAD Standard + 3D Solids + VBA support + Library 

Manager. 

This quick user’s guide covers in brief the basic aspects of all the four 4MCAD 

versions. More specifically, it shows the user how to proceed with the installation first 

and then how to start working on a new drawing, by taking advantage of the drawing 

settings (i.e. paper size, scale factors, text height etc) and the drawing aids (entity 

snaps, orthogonal mode etc). This guide also provides general guidelines about how to 

handle simple entities such as lines, circles and arcs, as well as complex entities such 

as polygons and spline curves. Other important aspects, such as moving around in the 

drawing, working with coordinate systems and printing existing drawings, are also 

described in short. All these capabilities constitute just a small part of the large number 

of features included within 4MCAD, which is designed for anyone who wants a fast and 

efficient CAD program with all the power and versatility of the most advanced CAD 

applications such as AutoCAD®. 

Despite its numerous capabilities, 4MCAD remains easy to be learned and operated 

even by novice users. As mentioned earlier, the aim of this Guide is to provide a short 

introduction on how the user can get familiar with the program. The full set of 

instructions and commands are described in detail within the five-hundred pages 

complete user’s guide. 
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1. Installation - Launching 
 

 

1.1 Installing 4MCAD 
 
1. Insert the CD in your computer CD-ROM drive (e.g. D:, E:) or, if you received your 

software via Internet, run the installation application you downloaded. 

2. When the Setup window appears, choose the language for the installation and click 
OK. 

3. When the Welcome page appears (as shown below), click Next. 

 

 

4. Follow the on-screen instructions until the installation is completed. 

5. After installation, the program is located within the programs list. 



 

 

2  4M 



 

 

4MCAD  3 

 

2. Environment & Commands 
 

 

2.1 4MCAD Environment 
As soon as the program starts running, the following main menu appears on the 
screen:  

 

4MCAD group of commands consist of the menu options “File”, “Edit”, “View”, “Insert”, 
“Format”, “Tools”, “Render”, “Plus”, “Draw”, “Dimension”, “Modify”, “Window” and 
“Help”.  

 

2.1.1 Working with 4MCAD 

You can work with the 4MCAD window and its elements in a variety of ways. For 
example, you can display and rearrange the toolbars, display the command bar, and 
enable the status bar. The toolbars and command bar can also be floated anywhere on 
the screen or docked to the edges of the main 4MCAD window.  
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A. You can customize the menu bar at the top of the window. 

B. You can customize the toolbars, changing the appearance and arrangement of tools and 
adding your own commands and macros. 

C. Your drawings are displayed in the drawing window. 

D. Click a tab to switch between the drawing of your model and a printed layout. 

E. You can type commands in the command bar. To reposition the command bar, drag it to 
another location on your screen. 

F. The status bar displays information such as the name or purpose of a tool, the current cursor 
coordinates, layer name, and mode settings. 

G. The user coordinate system (UCS) icon indicates the orientation of the drawing in three-
dimensional space. 

H. You can move and dock the toolbars to any location on your screen. 

I. You can manage the entities of the drawing on Properties Panel. 

2.1.2 Displaying commands on a shortcut menu 

Shortcut menus provide quick access to specific commands. A shortcut menu displays 
when you right-click an entity, toolbar, status bar, the Model tab name, or a Layout tab 
name. The selections presented in the shortcut menu depend on what you clicked.  

When you right-click a toolbar, the program displays a shortcut menu that lets you 
toggle the command bar, status bar, and various toolbars on and off. If you select one 
or more entities and then right-click, the program displays a shortcut menu from which 
you can choose a command to modify the selected entities. To display a shortcut 
menu from which you can choose an entity snap, press and hold down the <Shift> key, 
and then right-click anywhere within the drawing window.  

2.1.3 Displaying and hiding toolbars 

When you start 4MCAD the first time, multiple toolbars are displayed. The program 
provides more than a dozen toolbars, which you can customize by adding and deleting 
tools. You can also move and resize toolbars, and you can create new toolbars. You 
can use a shortcut menu to display or hide toolbars.  
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You can also choose whether toolbars are displayed large or small and in color. You 
can choose to display or hide ToolTips, which provide descriptions of tools that display 

when you pause the cursor over them. Go to View > Toolbars to make these 
selections.  

Toolbars are either docked or floating. A floating toolbar can be located anywhere on 
the screen and it can be resized. A docked toolbar does not display a title or Close 
box, cannot be resized, and is attached along one of the edges of the drawing window.  

 To dock a toolbar, drag it to the perimeter of your drawing; to undock it, drag it 
away from the perimeter.  

 To position a toolbar in a docking area without docking it, press Ctrl while you 
drag it.  

 To move a toolbar, drag it to a new location.  

 To resize a toolbar, move your cursor to the 
edge until it changes to a resize arrow, and 
then drag.  

To choose which toolbars to display  

1. Do one of the following:  

 Choose View > Toolbars.  

 Right-click anywhere on a docked toolbar to 
display the toolbar shortcut menu, and then 
choose Toolbars. You can also select the 
toolbars you want displayed directly on the 
shortcut menu.  

2. In the Select Toolbars dialog box, choose the 

toolbars you want displayed, and then click OK.  

2.1.4 Using the command bar  

The command bar is a dockable window in which you type 4MCAD commands and 
view prompts and other program messages. To display the command bar, choose 

View > Display > Command Bar. The command bar displays the three most recent 
lines of prompts. You can move the command bar by dragging it.  

When the command bar is floating, you can drag the top or bottom of the window to 
change the number of lines of text it displays. You can dock the command bar at the 
top or bottom of the drawing. 

2.1.5 Using the status bar 

If you select not to use the command bar, the status bar displays information about the 
selected command or tool. It also displays the current cursor coordinates, the name of 
the current layer, mode settings, and other information about current settings.  

In addition to displaying information, the status bar is a quick way to access many 
features. You can click status bar items to make changes, and right-click items to 
display short-cut menus that allow you more choices.  
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A. Information about the current command. 

B. Cursor coordinates (x,y,z). 

C. Layer name. Double-click to change layers. 

D. Drawing color. Double-click to change colors. 

E. Linetype. By default, the linetype is BYLAYER. Double-click to change linetypes. 

F. Lineweight. By default, the lineweight is BYLAYER. Double-click to change lineweights. 

G. Text style. Double-click to change text styles. 

H. Dimension style. Double-click to change dimension styles. 

I. Print style. Double-click to change print styles. (Available only for drawings that use named 
print style tables.) 

J. Scalse list. Click to selec the current scale. 

K. Toggle Annotation visibility. Click to set ON/OFF. 

L. Toggle Automatic annotation. Click to set ON/OFF 

M. Snap setting. Double-click to toggle on or off. 

N. Grid setting. Double-click to toggle on or off. 

O. Orthogonal setting. Double-click to toggle on or off. 

P. Polar tracking mode. Double-click to toggle on or off. 

Q. Entity snap setting. Double-click to select entity snaps. 

R. Polar tracking mode. Double-click to toggle on or off. 

S. Lineweight display. Double-click to toggle on or off. 

T. Model space or paper space. Double-click to toggle between model space and paper space. 

U. Digitizer mode. Double-click to toggle on or off. 

V. Click to switch between workspaces. 

W. Click to show window menu. 

X. Dynamic inpout mode. Double-click to toggle on or off. 

Y. Click to see the events list. 

To change the items that display on the status bar 

1. Right-click an empty area of the status bar. 

2. Select an item to add or remove it. 

To change the setting of an item on the status bar 

Do one of the following:  

 Double-click the status bar item.  

 Right-click the status bar item you want to change, and then select the desired 
setting. 
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2.1.6 Using prompt boxes 

4MCAD commands often provide several options. These options appear in the status 
bar or command bar and also in a prompt box (called a context menu in AutoCAD) 
initially displayed in the upper right corner of the screen. You can move the prompt box 
by dragging it; future prompt boxes will appear where you last placed it. The options 
appear as menu selections. Choose the appropriate option by selecting it in the prompt 
box. To close a prompt box, click the Close box.  

 

Command options appear in a prompt box.  

The prompt box is displayed by default. To turn off the display of prompt boxes, 

choose Tools > Preferences, click the Display tab, and then click the Display Prompt 
Boxes check box to clear it. 

2.1.7 Selecting commands  

Select commands using any of these methods:  

 Choose a command from a menu.  

 Click a tool in a toolbar.  

 Type the command in the command bar.  

Some commands remain active until you end them, so you can repeat an action 
without having to select a command repeatedly. You can end a command by clicking 

Done in the prompt box or by pressing Esc.  

2.1.8 Using commands  

You can use most commands while another command is active. For example, while 
drawing a line, you may want to use the Pan command to move the drawing across the 
screen to select the endpoint of the line. You can also change the settings of drawing 
aids such as snap or grid while other commands are active.  

2.1.9 Starting commands using toolbars  

To start a command from a toolbar, click a tool and respond to the prompts.  

Some tools, such as Line or Arc, contain flyouts, which are options either for using the 
basic tool with different methods or that contain other, related tools. Flyouts are 
indicated by a small triangle in the lower right corner of a tool. To display a flyout, click 
the tool and hold down the mouse button. To select a tool from a flyout, point to the 
tool you want and then release the mouse button. The tool you select on the flyout 
becomes the default tool on the toolbar.  
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2.1.10 Starting commands using menus  

To start a command from a menu, choose it from the list of menu options available.  

2.1.11 Starting commands using the command bar  

Type a command, and then press Enter. If the command bar is displayed, the 
command you typed appears there. If the command bar is not displayed, the command 
you typed appears in the status bar.  

2.1.12 Repeating a command  

You can repeat the command you just used without having to reselect it by doing one 
of the following:  

 Press the spacebar.  

 Press Enter.  

 Click the right mouse button.  

2.1.13 Nesting a command  

If you are working in the command bar, you can use another command from within a 
command, called nesting. To use a command inside an active command, type an 

apostrophe before you type the command, such as ‘circle, ‘line, or ‘pyramid. You can 
nest commands indefinitely in 4MCAD. Many menu and toolbar macros work this way 
by default; for example, select color, reference grid, zoom, and snap. When you have 
finished with the nested command, the original command resumes.  

2.1.14 Using the Prompt History window  

The Prompt History window displays a history of the commands and prompts issued 
since you started the current session of 4MCAD. By default, the program tracks up to 
256 command lines. There is no limit to the number of command lines you can track, 
but program performance may be degraded if you choose to track an excessively high 
number of lines.  

To display or close the Prompt History window 

 Press F2. 

To change the number of command lines to track 

1. Do one of the following: 

 Choose Tools > Preferences, and then click the Display tab.  

 Type options and then press Enter. Click the Display tab.  

2. In the Command Lines To Track field, type the number of command lines you 

want to display, and then click OK.  

2.1.15 Using scripts  

The 4MCAD Script Recorder captures and saves many of your actions so you can play 

them back. After you enable the Script Recorder, all commands and options that you 
type in the command bar are recorded until you type a command to stop recording. 
When you run the script, the program carries out the recorded commands in 
succession.  
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2.1.16 Correcting mistakes  

4MCAD tracks the commands you use and the changes you make. If you change your 
mind or make a mistake, you can undo, or reverse, the last action or several previous 
actions. You can also redo any actions that you reversed.   

  

A Click the Undo tool to reverse the last action. 

B Click the Redo tool to reverse the previous undos. 

You can undo multiple actions by typing undo and specifying the number of actions to 
undo.  

2.1.17 Customizing 4MCAD 

You can tailor many aspects of 4MCAD to better suit your needs. For example, you 
can easily create and modify toolbars by simply dragging and dropping icons. If you 
want to restore any area of the user interface back to its default state, click Reset. 
4MCAD stores your customized settings in the Windows registry rather than in a 
separate file.  

4MCAD supports the most important AutoCAD customization files, including linetypes, 
hatch patterns, text fonts, the unit conversion file, menus, toolbars, and aliases. In 
addition, 4MCAD unifies four AutoCAD customization functions with a single customize 
command: command aliases, keyboard shortcuts, menus, and toolbars.  

You can also add custom programs written in any of several programming languages, 
including the following:  

 LISP (the program’s Autodesk® AutoLISP-compatible language)  

 FDS (the program’s Autodesk® ADS-compatible language)  

 Microsoft® Visual Basic for Applications (VBA)  

Please note that each mouse button performs a specific function. The functions of the 
mouse buttons are the following: 

Left button:  Selection of a command, point or object. 

Right button:  Enter 

Middle button:  "Esnap" command. 

Note: In case your mouse has only two buttons (or it has three buttons, but the 
mouse driver has not been properly installed for the middle button to function), 
the first two functions are executed as described while the third one can be 
substituted by the combination of the "Shift" key and the right mouse button 
(right click while <Shift> is pressed down) 

 

2.2 Working with drawings 
CAD drawings help you organize information for greater efficiency. With 4MCAD, you 
can draw entities representing different types of information on various layers and use 
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those layers to control color, linetype, and visibility. 4MCAD also includes drawing aids 
that help you draw accurately.  

This section explains setting up drawings and using built-in drawing aids, including how 
to:  

- Create new drawings, open existing drawings, and save changes to drawings.  

- Use aids such as the grid, snap, and orthogonal settings to draw accurately.  

2.2.1 Creating a new drawing  

When you start 4MCAD, the program automatically creates a new drawing based on a 
template drawing, 4MCAD2k_en.dwg. This template includes predefined settings such 
as drawing units, text size, and drawing area. You can either use these settings or 
change them according to your needs. There is nothing unique about a template 
drawing. You can use any drawing as a template for future drawings.  

You can save many steps by basing a new drawing on an existing template (.dwt file). 
By doing this, a new drawing will contain all the settings and entities you need. When 
you open a new drawing from your custom template, you can modify existing settings 
and delete any entities that you don’t need. When you save a drawing that was created 
using a template, you do not change the template.  

To create a new drawing based on a template 

1. Do one of the following:  

 Choose File > New.  

 Type newwiz and then press Enter. 

2. Click Use A Template Drawing, and then click Next.  

3. To display the Open Template dialog box, click Browse.  

4. Select the template (.dwt) file that you want, and then click Open. You can also 
choose any drawing (.dwg) file to use as a template.  

5. Click Finish.  

2.2.2 Opening a drawing  

You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files, Design Web 
Format (.dwf) files, and drawing template (.dwt) files.  

You can also open and check drawings that you suspect are damaged.  

Opening an existing drawing  

You can open any of these drawing files:  

- Standard drawing files with a .dwg extension.  

- Drawing Exchange Format files with a .dxf file extension.  

- Design Web Format files with a .dwf file extension.  

- Drawing templates with a .dwt file extension.  

To open an existing drawing 

Use one of the following methods:  

 Choose File > Open.  
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 On the Standard toolbar, click the Open tool ( ).  

 Type open and then press Enter.  

In Files of Type, choose the type of file you want to open. 

Choose the folder containing the desired file. 

Choose the drawing you want to open. 

Click Open.  

If the drawing requires a password, enter the password, click OK to verify the 
password, and then click Open again.  

TIP: To quickly open a drawing file from the Open Drawing dialog box, double-click the 
drawing name. 

 

A. Displays a description of the file size, creation date, and other information about the drawing. 

B. Opens the drawing as read-only to prevent making changes to the file. 

C. Turns the drawing preview on or off. 

D. Unavailable when opening drawings; available only when saving drawings. 

E. Displays an image of the drawing before you open it. 

2.2.3 Opening damaged files  

Files can become damaged for many reasons. For example, if you are working on a 
drawing during a power outage, a system crash, or a hardware failure, your drawing 
file may become damaged. 4MCAD allows you to open and check damaged files to 
attempt file recovery. All the details are described within the main user’s guide. 

2.2.4 Setting up a drawing  

You can specify individual settings when you create a new drawing or when you modify 
settings in a drawing created from a template.  

Setting the current layer  
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Layers are like the overlays that you use in manual drafting. You use layers to organize 
different types of drawing information. Every drawing has at least one layer, the default 
layer, named “0.” Your drawing can also contain an unlimited number of additional 
layers. When you create an entity, it is created on the current layer.  

To set the current layer  

Do one of the following: 

 Choose Format > Explore Drawing. 

 On the Entity properties toolbar, click the Explore Layers tool (  ) 

 Type explayers and then press Enter. 

 Type la and then press Enter. 

Double-click the layer name that you want to make current. 

Close the 4MCAD Explorer window. 

 

Double-click the layer name that you want to make current.  

Setting the current entity color 

An entity’s color determines how it is displayed and, if you are using a color printer, 
how it prints. Entities are created in the current color. There are 255 standard colors 
and two additional color properties that are often referred to as colors. 

You can use seven of the 255 standard colors by name: red, yellow, green, cyan, blue, 
magenta, and white. (Numbers eight and nine are not named.) Each color has a 
unique number from 1 to 255. The two additional color properties are BYLAYER and 
BYBLOCK. These color properties cause an entity to adopt the color either of the layer 
or of the block in which it is a member. BYLAYER is color number 256, and BYBLOCK 
is color number 0. In all commands for which you would use a color, you can indicate 
BYLAYER and BYBLOCK as well as by numbers 256 and 0, respectively. 
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You can choose colors by selecting them from the Color dialog box. In the command 
bar or in some dialog boxes, you specify a color either by name or by number. 

When you open a new drawing, entities are created in the color BYLAYER, which 
adopts the color of the current layer. Initially, layer 0 is both the only layer and the 
current layer. Its default color is white, so your entities appear as white.  

To set the current entity color 

1. Do one of the following:  

 On the Standard toolbar, click the Drawing Settings tool (  ) 

 Type settings and then press Enter. 

2. Click the Entity Creation tab. 

3. Click Select Color. 

4. In the Color dialog box, click BYBLOCK, BYLAYER, or the color of your choice, or 
type the color number in the Index box.  

5. Click OK. 

6. Click OK again.  

 

A. Click to set the color to one of the standard colors. 

B. Click to set the color to one of the gray shades. 
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C. Click to set the color to any of the available colors. 

D. Indicates the current color. 

E. Displays the color number. 

F. Click to set the current color BYLAYER. 

G. Click to set the current color BYBLOCK. 

Setting the current linetype  

Linetypes help convey information. You use different linetypes to differentiate the 
purpose of one line from another. A linetype consists of a repeating pattern of dots, 
dashes, or blank spaces. Linetypes determine the appearance of entities both on the 
screen and when printed. By default, every drawing has at least three linetypes: 
CONTINUOUS, BYLAYER, and BYBLOCK. Your drawing may also contain an 
unlimited number of additional linetypes. 

When you create an entity, it is created using the current linetype. By default, the 
current linetype is BYLAYER. 4MCAD indicates that the entity linetype is determined 
by the current layer’s linetype by assigning the BYLAYER property as the default 
linetype setting. When you assign BYLAYER, changing a layer’s linetype changes the 
linetype of all the entities assigned that layer (if they were created using the linetype 
BYLAYER). 

You can also select a specific linetype as the current linetype, which overrides the 
layer’s linetype setting. Entities are then created using that linetype, and changing the 
layer linetype has no effect on them.  

As a third option, you can use the linetype BYBLOCK property, in which case new 
entities are drawn using the CONTINUOUS linetype until you group them into a block. 
The entities then inherit the block’s linetype setting when you insert the block into a 
drawing.  

To set the current linetype 

1. Do one of the following: 

 On the Standard toolbar, click the Drawing Settings tool (  ) 

 Type settings and then press Enter. 

2. Click the Entity Creation tab. 

3. In the Entity Linetype list, choose the linetype that you want to make current. 

4. Click OK.  

Setting the linetype scale  

You can specify the linetype scale. The smaller the scale, the more repetitions of the 
linetype pattern are generated per drawing unit. For example, a linetype pattern is 
defined as a sequence of dashed lines and open spaces, each 0.25 units long. The 
line-type scale uses the drawing scale factor to determine the length. A scale factor of 
0.5 would reduce the length of each line and space to 0.125 units; a scale factor of 2 
would increase the length of each to 0.5 units. You can control a new entity’s individual 
linetype scale factor as well as the overall or global scale factor applied to all the 
entities in the drawing.  

To set the current individual linetype scale 

1. Do one of the following: 
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 On the Standard toolbar, click the Drawing Settings tool (  ). 

 Type settings and then press Enter. 

2. Click the Entity Creation tab. 

3. In the Linetype Scale field, type or choose the linetype scale that you want to make 
current. 

4. Click OK.  

To change the global linetype scale  

Do one of the following:  

 On the Standard toolbar, click the Drawing Settings tool (  ). 

 Type settings and then press Enter. 

Click the Entity Creation tab. 

In the Global Linetype Scale field, type or choose the global linetype scale that you 
want to change. 

Click OK.  

Setting the current lineweight  

Lineweights help differentiate the purpose of one line from another. Lineweights 
determine how thick or thin entities appear both on the screen and when printed. Every 
drawing has these lineweights: DEFAULT, BYLAYER, BYBLOCK, and many additional 
lineweights in millimeters (or you can use inches). 

When you create an entity, it is created using the current lineweight. By default, the 
current lineweight for a new entity is BYLAYER. This means that the entity line-weight 
is determined by the current layer. When you assign BYLAYER, changing a layer’s 
lineweight changes the lineweight of all the entities assigned that layer (if they were 
created using the lineweight BYLAYER).  

You can also select a specific lineweight (or DEFAULT) as the current lineweight, 
which overrides the layer’s lineweight setting. Entities are then created using that 
lineweight (or the DEFAULT lineweight), and changing the layer lineweight has no 
effect on them.  

As a third option, you can use the lineweight BYBLOCK property, in which case new 
entities are drawn using the DEFAULT lineweight until you group them into a block. 
The entities then inherit the block’s lineweight setting when you insert the block into a 
drawing.  

If you choose a lineweight that is less than .025 millimeter, it displays as one pixel 
when you create your drawing. When you print your drawing, it prints at the thinnest 
lineweight that is available for your printer.  

You cannot assign lineweights to planes, points, TrueType fonts, and raster images (if 
supported in your version of 4MCAD).  

To set the current lineweight 

1. Do one of the following:  

 On the Standard toolbar, click the Drawing Settings tool (  ). 

 Type settings and then press Enter. 
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2. Click the Entity Creation tab.  

3. In the Lineweight list, choose the lineweight that you want to make current.  

4. Click OK.  

Setting drawing units 

With 4MCAD, you typically draw at full-size (1:1 scale), and then set a scale factor 
when you print or plot your drawing. Before you begin drawing, however, you need to 
determine the relationship between drawing units and real-world units.  

For example, you can decide whether one linear drawing unit represents an inch, a 
foot, a meter, or a mile. In addition, you can specify the way the program measures 
angles. For both linear and angular units, you can also set the degree of display 
precision, such as the number of decimal places or smallest denominator used when 
displaying fractions. The precision settings affect only the display of distances, angles, 
and coordinates. 4MCAD always stores distances, angles, and coordinates using 
floating-point accuracy.  

To set the linear drawing units 

1. Do one of the following:  

 On the Standard toolbar, click the Drawing Settings tool (  ). 

 Type settings and then press Enter.  

2. Click the Drawing Units tab.  

3. Under Change Settings For, choose Linear Units.  

4. Under Unit Types, select a unit type.  

5. Under Display Precision, type the display precision according to the number of 
decimal places you want, or click the arrows to select it. The field above this setting 
shows an example of the linear unit type at the current precision.  

6. Click OK.  
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A. Select the type of linear units. B. Choose the display precision for linear units.  

To set the angular drawing units  

1. Do one of the following:  

 On the Standard toolbar, click the Drawing Settings tool (  ). 

 Type settings and then press Enter.  

2.  Click the Drawing Units tab. 

3. Under Change Settings For, choose Angular Units. 

4. Under Unit Types, select a unit type. 

5. Under Display Precision, type the display precision according to the number of 
decimal places you want, or click the arrows to select it. The field above this setting 
shows an example of the angular unit type at the current precision.  

6. Under Angle Direction, select the direction in which angles increase when you 
specify a positive angle value.  

7. Under Angle Base, specify the compass location for the zero angle. For example, 
by default, angle 0 is at the “three o’clock” or “east” position. The adjacent icon 
shows the current location of the angle base.  

8. Click OK.  
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A. Determines the type of units you are controlling. 

B. Select the type of angular units. 

C. Choose the display precision for angular units.  

D. Select the direction in which angles increase. 

E. Select the angle base, the direction of the zero angle. 

Understanding scale factors  

Instead of drawing to a particular scale, you draw everything in the program full-size. 
Although it’s a good idea to keep your scale factor in mind when setting up a drawing, 
you don’t need to set the scale until you print it. For example, when you draw a 
mechanical part 40 inches in length with 4MCAD, you actually draw it as 40 inches, 
rather than applying a scale factor as you draw. When you print your drawing, you can 
assign the scale at which the drawing is to print. 

Scale, however, does affect the way a few elements such as text, arrows, or linetypes 
print or plot in your drawing. For these, you can make adjustments when you first set 
up your drawing so that they print or plot at the correct size. For example, when you 
draw text, you need to determine the text size so that when you plot it later at a 
particular scale, the text height is correct.  

After you determine the eventual scale of your finished drawing, you can calculate the 
scale factor for the drawing as a ratio of one drawing unit to the actual scale unit 
represented by each drawing unit. For example, if you plan to print your drawing at 1/8” 
= 1’-0”, your scale factor ratio is 1:96 (1/8” = 12” is the same as 1 = 96). If you want 
your printed scale to be 1 inch = 100 feet, your scale factor ratio is 1:1200.  
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The following table shows some standard architectural and engineering scale ratios 
and equivalent text heights required to create text that measures 1/8-inch high when 
you plot the drawing at the specified scale. 

Standard scale ratios and equivalent text heights 

Scale Scale factor Text height  

1/16” = 1’-0” 192 24” 

1/8” = 1’-0” 96 12” 

3/16” = 1’-0” 64 8” 

1/4” = 1’-0” 48 6” 

3/8” = 1’-0” 32 4” 

1/2” = 1’-0” 24 3” 

3/4” = 1’-0” 16 2” 

1” = 1’-0” 12 1.5” 

1 1/2” = 1’-0” 8 1” 

3” = 1’-0” 4 0.5” 

1” = 10’ 120 15” 

1” = 20’ 240 30” 

1” = 30’ 360 45” 

1” = 40’ 480 60” 

1” = 50’ 600 75” 

1” = 60’ 720 90” 

1” = 100’ 1200 150”  

You can use these scale factors to predetermine the size of your drawing to make sure 
that it fits on a specific size paper when you print it. You control the size of your 
drawing by the drawing limits. To calculate the drawing limits to match the size of your 
paper, multiply the dimensions of your paper size by your scale factor.  

For example, if the paper you use to print measures 36 inches x 24 inches and you plot 
your drawing at 1/8” = 1’-0” (in other words, using a scale factor of 96), the size of your 
drawing measured in drawing units is 36 x 96 (or 3,456 units) wide and 24 x 96 (or 
2,304 units) high.  

Keep in mind that you can print the finished drawing at any scale, regardless of the 
scale factor you calculate. You can also print on paper of a different size and use the 
Layout tabs to create different views of your drawing and to position and scale those 
views differently. The scaling factor is not related to the size of the entities you draw; it 
simply provides a preliminary guide to help you establish the text height and drawing 
limits when you begin your drawing. You can change the text height and drawing limits 
at any time.  

Setting the text height 

The text height setting controls the height of text, measured in drawing units. Set this 
value initially so that text used for your most common annotations, when scaled to the 
size at which you will print a drawing, measures 1/8-inch high on the printed drawing.  

For example, if you plan to print your drawing at 1/8” = 1’-0” and you want your text to 
be 1/8-inch high in the final drawing, create that text 1 foot high (in your real-world 
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drawing units) so that when you print it, it appears 1/8-inch high on the paper. You 
must create text 4 feet high that you want to print 1/2-inch high.  

To set the text height  

1. Do one of the following:  

 On the Standard toolbar, click the Drawing Settings tool (  ). 

 Type settings and then press Enter.  

2. Click the Entity Creation tab. 

3. Under Change Settings For, choose Text. 

4. In the Default Text Height field, select the text height or type the text height value 
that you want. 

5. Click OK. 

 

A. Choose Text. B. Specify the text height in drawing units.  

Setting the drawing limits  

You can specify the drawing limits that form an invisible boundary around your 
drawing. You can use the drawing limits to make sure that you do not create a drawing 
larger than can fit on a specific sheet of paper when printed at a specific scale.  

For example, if you plan to print your drawing at 1/8” = 1’-0” (in other words, using a 
scale factor of 96) on a sheet of paper measuring 36 inches x 24 inches, you can set 
drawing limits to 3,264 units wide (that is, 34 x 96) and 2,112 units high (22 x 96), 
which allows a 1-inch margin around the edges of the printed image.  
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To set the drawing limits 

1. Do one of the following:  

 On the Standard toolbar, click the Drawing Settings tool (  ). 

 Type settings and then press Enter. 

2. Click either the Coordinate Input tab or the Display tab. 

3. Under Change Settings For, choose Limits. 

4. Specify the x-coordinate and y-coordinate of the upper right drawing limit and the 
lower left drawing limit. You can also click Select to specify the drawing limits by 
selecting points in the drawing.  

5. To constrain your drawing to these drawing limits, click the Disallow Input Beyond 
Limits check box.  

6. Click OK. 

 

A Choose limits. 

B. Specify the x-coordinate and y-coordinate of the upper right drawing limit. 

C. Specify the x-coordinate and y-coordinate of the lower left drawing limit. 

D. When you click this check box, the program prevents you from drawing outside the drawing 
limits. 

E. Specify the drawing limits by selecting points in the drawing. 
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2.2.5 Setting and changing the grid and snap alignment 

Grid and snap settings are effective tools to use in your drawing to ensure accuracy. 
Although many users find it convenient to match grid points to snap settings, they are 
independent of each other and should not be confused. Grid points are for visual 
reference only; they do not affect your drawing and they do not print. Snap points are, 
by themselves, not visible; however, when set, they constrain the creation of new 
entities. 

Setting a reference grid 

A reference grid displays as a pattern of regularly spaced dots. You can turn the 
display on and off, and you can specify how far apart the dots are spaced.  

The reference grid extends only to the limits of the drawing, helping you to visualize 
the boundary of your drawing and to align entities and visualize distances between 
entities. You can turn the grid on and off as needed. You can also change the spacing 
of the grid at any time.  

To turn the grid on and set the grid spacing  

1. Do one of the following:  

 On the Standard toolbar, click the Drawing Settings tool (  ). 

 Type settings and then press Enter. 

2. Click the Coordinate Input tab. 

3. Under Change Settings For, choose Snap And Grid. 

4. Under Reference Grid, click the Show Grid check box. 

5. Under Reference Grid Spacing, in the X field, choose the horizontal grid spacing. 

6. Under Reference Grid Spacing, in the Y field, choose the vertical grid spacing. 

7. Click OK.  
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A. Click the check box to enable orthogonal mode. 

B. Click the check box to display the reference grid. 

C. Specify the x and y grid spacing. 

D. Click the check box to enable snap mode. 

E. Specify the x and y snap spacing. 

F. Click the check box to use an isometric snap and grid. 

G. Click the current isometric plane. 

H. Specify the grid rotation angle. 

I. Specify the x- and y-coordinates of the snap origin. 

Setting snap spacing  

Another way to ensure drawing accuracy is to turn on and set snap spacing. When 
snap is turned on, the program restricts the selection points to predetermined snap 
intervals. Although it is often helpful to match the snap spacing to some interval of the 
grid spacing or another related setting, the settings do not have to match.  

To turn snap settings on and set snap spacing 

1. Do one of the following:  

 On the Standard toolbar, click the Drawing Settings tool (  ). 

 Type settings and then press Enter. 

2. Click the Coordinate Input tab. 

3. Under Change Settings For, choose Snap And Grid. 
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4. Under Snap Settings, click the Snap check box to turn Snap on. 

5. Under Snap Settings Spacing, in the X field, choose the horizontal snap spacing. 

6. Under Snap Settings Spacing, in the Y field, choose the vertical snap spacing. 

7. Click OK.  

In addition to setting the snap spacing, you can change the snap and grid orientation. 
You can also rotate the alignment of the grid or set it to create isometric drawings.  

Changing the snap and grid angle and base point  

The snap and grid are both normally based on the drawing origin, the 0,0 coordinate in 
the World Coordinate System (WCS). You can relocate the snap and grid origin, 
however, to help you draw entities in relation to a different location. You can also rotate 
the grid to a different angle to realign the crosshairs to the new grid angle. If the grid is 
on, and the grid spacing is 0,0, then the grid defaults to the snap spacing.  

To change the snap angle and base point  

1. Do one of the following:  

 On the Standard toolbar, click the Drawing Settings tool (  ) 

 Type settings and then press Enter.  

2. Click the Coordinate Input tab.  

3. Under Change Settings For, select Snap And Grid.  

4. Under Snap Settings, click the Snap check box to turn Snap on.  

5. Under Reference Grid, click the Show Grid check box to turn Show Grid on.  

6. Under Snap And Grid Settings, in the X Origin field, type the x-coordinate of the 
new snap origin.  

7. Under Snap And Grid Settings, in the Y Origin field, type the y-coordinate of the 
new snap origin.  

8. Under Snap And Grid Settings, in the Rotation field, type the grid rotation angle.  

9. Click OK. 

 

Default grid and snap alignment. Rotated grid and snap alignment.  

 

Using isometric snap and grid  
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You can use the Isometric Snap And Grid option to create two-dimensional isometric 
drawings. With the isometric option, you are simply drawing a simulated three-
dimensional view on a two-dimensional plane, much the same as you might draw on a 
piece of paper. Do not confuse isometric drawings with three-dimensional drawings. 
You create three-dimensional drawings in three-dimensional space.  

The isometric option always uses three preset planes, which are denoted as left, right, 
and top. You cannot alter the arrangement of these planes. If the snap angle is 0, the 
three isometric axes are 30 degrees, 90 degrees, and 150 degrees.  

When you check the Isometric Snap And Grid option and select an isometric plane, the 
snap intervals, grid, and crosshairs align with the current plane. The grid is always 
shown as isometric and uses y-coordinates to calculate the grid spacing. If you click 
the Draw Orthogonal check box, the program restricts the drawing of entities to the 
current isometric plane.  

To turn the Isometric Snap And Grid option on 

1. Do one of the following:  

 On the Standard toolbar, click the Drawing Settings tool (  ). 

 Type settings and then press Enter. 

2. Click the Coordinate Input tab. 

3. Under Change Settings For, select Snap And Grid. 

4. Click the Isometric Snap And Grid check box. 

5. Under Isometric Crosshairs, click the option for the isometric plane you want (Top, 
Left, or Right). 

6. Click OK.  

 

Isometric planes left (A), right (B), top (C).  

 

2.2.6 Using the Draw Orthogonal option 

You can restrict cursor movement to the current horizontal and vertical axes so that 
you can draw at right angles, or orthogonally. For example, with the default 0-degree 
orientation (angle 0 at the “three o’clock” or “east” position), when the Draw Orthogonal 
option is enabled, lines are restricted to 0 degrees, 90 degrees, 180 degrees, or 270 
degrees. As you draw lines, the rubber-banding line follows either the horizontal or 
vertical axis, depending on which axis is farthest from the cursor. When you enable the 
isometric snap and grid, cursor movement is restricted to orthogonal equivalents within 
the current isometric plane. 

To enable orthogonal drawing 

1. Do one of the following:  
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 On the Standard toolbar, click the Drawing Settings tool (  ). 

 Type settings and then press Enter. 

2. Click the Coordinate Input tab. 

3. Click the Draw Orthogonal check box. 

4. Click OK.  

2.2.7 Using entity snaps  

Entity snaps enable you to quickly select exact geometric points on existing entities 
without having to know the exact coordinates of those points. With entity snaps, you 
can select the endpoint of a line or arc, the center point of a circle, the intersection of 
any two entities, or any other geometrically significant position. You can also use entity 
snaps to draw entities that are tangent or perpendicular to an existing entity. 

You can use entity snaps any time the program prompts you to specify a point -for 
example, if you are drawing a line or other entity. You can work with entity snaps in 
one of two ways:  

- Enable a running entity snap that remains in effect until you turn it off by choosing 
an entity snap when no other command is active. 

- Enable a one-time entity snap for a single selection by choosing an entity snap 
when another command is active. You can also use a one-time entity snap to 
override a running entity snap. 

When using entity snaps, the program recognizes only visible entities or visible 
portions of entities. You cannot snap to entities on layers that have been turned off or 
to the blank portions of dashed lines.  

When you specify one or more entity snaps, an entity snap target box is added to the 
crosshairs. In addition, an icon appears adjacent to the crosshairs indicating the active 
entity snap. When you select an entity, the program snaps to the snap point closest to 
the center of the target box.  

To change the size of the entity snap target box 

1. Do one of the following:  

 On the Standard toolbar, click the Drawing Settings tool (  ). 

 Type settings and then press Enter. 

2. Click the Coordinate Input tab. 

3. Under Change Settings For, choose Entity Selection. 

4. Under Entity Snap Aperture, change the value in the Aperture field. 

5. Click OK.  
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A. Choose Entity Selection. B. Type or select the entity snap aperture size. 

Setting entity snaps 

You can set entity snaps using any of the following methods: 

- On Standard toolbar, click one of the entity snap tools.  

- In the command bar, type an entity snap command.  

- In the status bar, double-click ESNAP.  

- Press and hold down the Shift key while right-clicking anywhere within the drawing 
window to display the entity snap shortcut menu, and then choose the entity snap 
you want to set.  

You can also set entity snaps using the Drawing Settings dialog box. To do this, 
choose Settings > Entity Snap > Entity Snap Settings. The Drawing Settings dialog box 
is displayed with the Coordinate Input tab active. In the Entity Snap Modes list, click 
the check box for each of the entity snaps that you want to set.  

The "Esnap" command can be activated either by holding down the "SHIFT" key and 
right clicking the mouse or by clicking the middle mouse button (if there is one 
available and active) or through the additional toolbar (version for Windows). The 
following menu will appear: 
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Nearest Snap tool  

Use the Nearest Snap tool to snap to the nearest point of another entity. You can snap 
to the nearest point on an arc, circle, ellipse, elliptical arc, line, point, polyline segment, 
ray, spline, or infinite line that is visually closest to the cursor.  

To set the Nearest Snap  

Do one of the following:  

 On the Standard toolbar, click the Set Nearest Snap tool (  ). 

 Type nearest and then press Enter.  

Endpoint Snap tool  

Use the Endpoint Snap tool to snap to the endpoint of another entity. You can snap to 
the closest endpoint of an arc, line, polyline segment, ray, plane, or three-dimensional 
face. If an entity has thickness, the Endpoint Snap also snaps to the endpoints of the 
edges of the entity.  

To set the Endpoint Snap  

Do one of the following:  

 On the Standard toolbar, click the Set Endpoint Snap tool (  ). 

 Type endpoint and then press Enter.  

 



 

 

4MCAD  29 

To snap to the endpoint, select anywhere on the entity near its endpoint (A). 

Midpoint Snap tool  

Use the Midpoint Snap tool to snap to the midpoint of another entity. You can snap to 
the midpoint of an arc, ellipse, line, polyline segment, plane, infinite line, or spline. In 
the case of infinite lines, the midpoint snaps to the first defined point. If an entity has 
thickness, the midpoint entity snap also snaps to the midpoint of the edges of the 
entity.   

To set the Midpoint Snap  

Do one of the following:  

 On the Standard toolbar, click the Set Midpoint Snap tool (  ). 

 Type midpoint and then press Enter.  

 
To snap to the midpoint, select anywhere on the entity near its midpoint (A). 

Center Snap tool  

Use the Center Snap tool to snap to the center point of another entity. You can snap to 
the center of an arc, circle, polygon, ellipse, or elliptical arc. To snap to the center, you 
must select a visible portion of the entity.  

To set the Center Snap  

Do one of the following:  

 On the Standard toolbar, click the Set Center Snap tool (  ). 

 Type center and then press Enter.  

 

To snap to the center, select anywhere on the visible portion of the entity (A).  

Perpendicular Snap tool  

Use the Perpendicular Snap tool to snap to the perpendicular point of another entity. 
You can snap to an arc, circle, ellipse, line, polyline, infinite line, ray, spline, or edge of 
a plane to form a perpendicular alignment with that entity or with an imaginary 
extension of that entity. 

To set the Perpendicular Snap  

Do one of the following:  

 On the Standard toolbar, click the Set Perpendicular Snap tool (  ). 
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 Type perpendicular and then press Enter.  

 

To form a perpendicular angle (A) to an entity (B), select anywhere on the entity.  

Tangent Snap tool  

Use the Tangent Snap tool to snap to the tangent point of another entity. You can snap 
to the point on an arc, ellipse, spline, or circle that, when connected to the previous 
point, forms a line tangent to that entity.  

Quadrant Snap tool  

Use the Quadrant Snap tool to snap to the quadrant point of another entity. You can 
snap to the closest quadrant of an arc, circle, ellipse, or elliptical arc. 

Insertion Point Snap tool  

Use the Insertion Point Snap tool to snap to the insertion point of an attribute, block, or 
text entity. 

To set the Insertion Point Snap  

Do one of the following:  

 On the Standard toolbar, click the Set Insertion Point Snap tool (  ). 

 Type insertion and then press Enter.  

 
To snap to an insertion point, select anywhere on the entity (A).  

Point Snap tool  

Use the Point Snap tool to snap to a point entity. 

To set the Point Snap  

Do one of the following:  

 On the Standard toolbar, click the Set Point Snap tool (  ). 

 Type node and then press Enter.  
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To snap to a point entity, select the entity (A).  

Intersection Snap tool  

Use the Intersection Snap tool to snap to the actual intersection in three-dimensional 
space of any combination of entities. You can snap to the combination of an arc, circle, 
line, polyline, ray, or infinite line. If the target covers only one entity, the program 
prompts you to select a second entity, and then snaps to the point at which the two 
entities would intersect if they were of infinite length. You can snap to the vertices of 
three-dimensional entities and the corners of entities that have thickness. 

To set the Intersection Snap  

Do one of the following:  

 On the Standard toolbar, click the Set Intersection Snap tool (  ). 

 Type intersection and then press Enter.  

 
To snap to an intersection, select the intersection (A).  

Quick Snap command  

Normally, an entity snap searches all the entities crossing the target and selects the 
one closest to the center of the target. Use the Quick Snap command to modify the 
current entity snap so that the program stops searching for the snap point as soon as it 
finds one entity with at least one point of the current entity type. 

To set the Quick Snap  

 Type quick and then press Enter. 

Clear Entity Snaps tool  

Use the Clear Entity Snaps tool to turn off all entity snap settings, regardless of how 
they were set: by menu, tool, command, or in the Drawing Settings dialog box.  

To set Clear Entity Snaps  

Do one of the following:  

 On the Standard toolbar, click the Clear Entity Snaps tool (  ). 

 Type none and then press Enter.  
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2.2.8 Using fly-over snapping  

Fly-over snapping is a visual aid to help you see and use entity snaps more efficiently. 
When fly-over snapping is turned on, 4MCAD will display a colored marker at matching 
entity snap points as you move the crosshairs around the drawing. 

Each entity has its own type of marker: 

 
1. Endpoint Snap 

2. Nearest Snap 

3. Midpoint Snap 

4. Center Snap 

5. Perpendicular Snap 

6. Tangent Snap 

7. Quadrant Snap 

8. Insertion Snap 

9. Node (point) Snap 

10. Intersection Snap  

When fly-over snapping is enabled 
and multiple entity snaps are on, you 
can press TAB to cycle through the 
available entity snap points of the 
entities covered by the target box. For 
example, when the Endpoint and 
Midpoint snaps are set and the 
aperture box is on a line, pressing TAB 
will cycle between the line's closest 
endpoint and midpoint.  

 

To set the Fly-over snapping option  

1. Right click on ESNAP in status bar 
and select “Settings”. The Drawing Settings dialog box opens to the Coordinate 
Input tab. 

2. Click Fly-over. The Options dialog box opens to the Snapping tab. 

3. Turn on the Enable Fly-over Snapping option. 

4. Set the fly-over options.  

5. Define the color, size, and thickness of the snap marker. 

6. Click OK. 

7. Click OK again 
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2.2.9 Saving your drawing   

When you save a drawing, your work is saved in a drawing (.dwg) file.  

After you have saved your drawing for the first time, you can save it with a new name. 
In addition to drawing (.dwg) files, you can also save a drawing in a Drawing Exchange 
Format (.dxf) file or a drawing template (.dwt) file.  

If you created your drawing using a template, saving the drawing does not alter the 
original template.  

If you need an added level of security for your drawing files, you can save the drawing 
with a password so only you and those who know the password can open the drawing.  

Saving a drawing 

To save a drawing, choose any of the following methods:  

 Choose File > Save.  

 On the Standard toolbar, click Save (  ). 

 Type save and then press Enter.  

 Type qsave and then press Enter.  

 

A. Displays a description of the file size, creation date, and other information about the drawing. 

B. Unavailable when saving drawings; available only when opening drawings.  

C. Turns the drawing preview on or off. 

D. Saves the drawing with a password.  

E. Displays an image of the drawing before you save it.   

Saving a drawing with a new name or file format  

You can save a drawing with a new name and in any of the following file formats:  

- Standard drawing files with a .dwg extension. You can choose a .dwg file format 
that is compatible with various versions of AutoCAD.  
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- Drawing exchange format files with a .dxf file extension. You can choose a .dxf file 
format that is compatible with various versions of AutoCAD.  

- Drawing templates with a .dwt file extension. Drawing templates allow you to easily 
create new drawings that reuse your drawing settings and entities.  

To save a drawing with a new name or file format 

1. Do one of the following:  

 Choose File > Save As.  

 Type saveas and then press Enter. 

2. In the Save Drawing As dialog box, under Save As Type, choose the file format. 

3. Specify the name of the file you want to create. 

4. Click Save.  

 

2.3 Creating simple entities 
With the program, simple entities include lines (both finite and infinite), circles, arcs, 
ellipses, elliptical arcs, points, and rays. In addition, 4MCAD includes a freehand 
sketch tool. Entities drawn freehand are also considered to be simple entities.  

This section explains several methods for creating simple entities, including how to:  

- Use menu commands on the Insert menu.  

- Use the tools on the Draw toolbar.  

- Type commands in the command bar.  

In some cases, there are a number of different ways to create an entity. For the most 
part, one or two are given here. Refer to the online Help to learn how to create entities 
using other methods.  

When you use a tool or a drawing command, the program prompts you to enter 
coordinate points, such as endpoints or insertion points. You can enter the points or 
distances either using a mouse or by typing coordinate values in the command bar. As 
you draw, the program also displays a context-sensitive prompt box with appropriate 
additional options for the type of entity you are drawing.  

After you create entities, you can modify them using the entity modification tools.  

2.3.1 Drawing lines  

A line consists of two points: a start point and an endpoint. You can connect a series of 
lines, but each line segment is considered a separate line entity.  

To draw a line 

1. Do one of the following: 

 Choose Draw > Line.  

 On the Draw toolbar, click the Line tool (  ). 

 Type line and then press Enter. 

2. Specify the start point. 
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3. Specify the endpoint. 

4. In the prompt box, choose Done to complete the command.  

 
Start point (A) and endpoint (B). 

The prompt box provides several options as you draw. For example, when you draw 
the first line segment, you can specify its length or orientation angle. After you draw at 
least one line segment, you can click Undo to remove the previous line segment. You 
can click Done to end the line command. After you draw two or more line segments, 
you can click Close to complete the line command by drawing a line segment that 
connects to the start point of the first line segment you drew.  

If the last entity you drew was an arc, you can also draw a line tangent to and starting 
from the endpoint of the arc.  

To draw a line as a continuation from the end of an arc 

1. Do one of the following: 

 Choose Draw > Line. 

 On the Draw toolbar, click the Line tool (  ). 

 Type line and then press Enter. 

2. In the prompt box, choose Follow. 

3. Specify the length of the line. 

 
Endpoint of previous arc (A) and length of the line (B).  

2.3.2 Drawing circles  

The default method for drawing a circle is to specify a center point and radius. You can 
draw circles using any of the following methods: 

 Center-Radius. 

 Center-Diameter. 

 Two points. 

 Three points. 

 Radius-Tangent-Tangent. 

 Convert Arc to Circle. 

To draw a circle by specifying its center and radius  

1. Do one of the following:  
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 Choose Draw > Circle.  

 On the Draw toolbar, click the Circle Center-Radius tool (  ). 

 Type circle and then press Enter. 

2. Specify the center point. 

3. Specify the radius of the circle.  

 
Center point (A) and radius (B). 

Note that within the user’s guide some other alternative options are also described, 
such as to draw a circle tangent to existing entities or to convert an arc to a circle. 

2.3.3 Drawing arcs and other entities 

An arc is a portion of a circle. The default method for drawing an arc is to specify three 
points - the start point, a second point, and the endpoint. You can draw arcs using 
alternative methods. Details are described within the main user’s guide, along with 

many other options for creating simple entities, such as ellipses, elliptical arcs, point 

entities, drawing rays, infinite lines, freehand sketches and others.  

2.4 Creating complex entities 
With 4MCAD, complex entities include polylines (including rectangles and polygons), 
spline curves, donuts, and planes. In addition, the program includes tools for adding 
hatching to your drawings. 

This section explains several methods for creating complex entities, including how to:  

- Use menu commands on the Draw menu.  

- Use the tools on the Draw toolbar.  

- Type commands in the command bar.  

When you type a drawing command or select a tool, the program prompts you to enter 
coordinate points, such as endpoints or insertion points. As you draw, the program 
displays a context-sensitive prompt box with appropriate additional options for the type 
of entity you are drawing.  

After you create complex entities, you can modify them using the entity-modification 
tools. Several of these entity types require special editing commands. 

2.4.1 Drawing rectangles  

Rectangles are closed polylines with four sides. You draw a rectangle by specifying its 
opposite corners. The rectangle is normally aligned parallel to the current snap and 
grid alignment, but you can use the Rotated option to align the rectangle to any angle. 

To draw a rectangle 

1. Do one of the following:  
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 Choose Draw > Rectangle.  

 On the Draw toolbar, click the Rectangle tool (  ). 

 Type rectangle and then press Enter. 

2. Specify one corner of the rectangle. 

3. Specify the opposite corner of the rectangle. 

 
Opposite corners (A and B). Resulting rectangle.  

You can convert the sides into individual line entities using the Explode tool (  ) on 

the Modify toolbar. You can also use the Rectangle tool (   ) to draw a square. Instead 
of specifying the opposite corners, you specify the length of one side and the 
alignment of the square.  

2.4.2 Drawing polygons  

Polygons are closed polylines composed of a minimum of three and a maximum of 
1,024 equal-length sides. The default method for drawing a polygon is to specify the 
center of the polygon and the distance from the center to each vertex. You can draw a 
polygon using alternative options. All the details are described within the main user’s 
guide. 

2.4.3 Drawing polylines and other complex entities 

With 4MCAD, a polyline is a connected sequence of arcs and lines that is treated as a 
single entity. You can draw a polyline with any linetype and using a width that either 
remains constant or tapers over the length of any segment. When editing a polyline, 
you can modify the entire polyline or change individual segments.  

After you specify the start point of a polyline, a prompt box provides several options as 
you draw, such as Distance, Halfwidth, and Width. You can specify different starting 
and ending widths to create a tapered polyline segment. 

After you draw at least one polyline segment, you can use the Undo tool (  ) to 
remove the previous segment. After you draw two or more polyline segments, you can 
use the Close option to complete the command by drawing a segment that ends at the 
start point of the first polyline segment you drew. Choose Done to complete the 
command without closing the polyline. 

 
Curved polyline with tapered width.Polyline with straight Closed polyline. segments.  

To draw a polyline with straight segments 

1. Do one of the following:  
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 Choose Draw > Polyline.  

 On the Draw toolbar, click the Polyline tool (  ). 

 Type polyline and then press Enter. 

2. Specify the start point. 

3. Specify the endpoint of each segment. 

4. To complete the command, choose Close or Done. 

 
Polyline start point (A) and segment endpoints (B). 

With the Draw Arcs option, you can continually draw arc segments until you select the 
Draw Lines option to go back to drawing line segments. When you draw arc segments, 
the first point of the arc is the endpoint of the previous segment. By default, you draw 
arc segments by specifying the endpoint of each segment. Each successive arc 
segment is drawn tangent to the previous arc or line segment. If you choose Close 
while in the Draw Arcs option, the closing segment is created as an arc.  

You can also specify the arc using any of the following methods:  

 Start point, included angle, center point  

 Start point, included angle, radius  

 Start point, center point, endpoint  

 Start point, included angle, endpoint  

 Start point, center point, included angle  

 Start point, center point, chord length  

 Start point, direction, endpoint  

 Start point, radius, included angle  

 Start point, second point, endpoint  

To draw a line segment followed by an arc polyline segment 

1. Do one of the following:  

 Choose Draw > Polyline.  

 On the Draw toolbar, click the Polyline tool (  ). 

 Type polyline and then press Enter.  

2. Specify the start point.  

3. Specify the endpoint.  

4. In the prompt box, choose Draw Arcs.  

5. Specify the endpoint of the arc segment.  
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6. To complete the command, choose Done.  

 
Polyline start point (A), line endpoint/arc start point (B), and arc endpoint (C).  

You can convert polylines into arc and line entities using the Explode tool (   ) on the 
Modify toolbar.  

Drawing splines  

A spline is a smooth curve defined by a set of points. You can use splines to create 
sculptured shapes such as the cross section of a turbine blade or an airplane wing. 

To draw a spline 

1. Do one of the following:  

 Choose Draw > Spline.  

 On the Draw toolbar, click the Spline tool (  ). 

 Type spline and then press Enter.  

2. Specify the first point of the spline. 

3. Specify the second point of the spline. 

4. Specify as many more points as you want.  

5. When you have finished, press Enter.  

You can add tangents to the spline, which are lines that give it shape.  

To add tangents to a spline 

1. Specify the starting tangent point. 

2. Specify the ending tangent point.  

 
Spline. Spline with starting tangent point (A) and ending tangent point (B).  

 

Other related issues, such as the way of specifying fit tolerance to a spline or how to 
draw a closed spline are described within the user’s guide. 
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2.4.4 Adding hatching  

When you add hatching to a drawing, 4MCAD fills entities or enclosed areas with a 
pattern. You can choose a predefined hatch pattern, or you can create your own hatch 
pattern. 

First you specify the hatch pattern and other options, and then you choose which 
entities or enclosed areas that you want to hatch. 

NOTE Hatch patterns are memory intensive and can take a considerable amount of 
time to draw and display. To improve performance, add hatching as one of the last 
steps when you create a drawing, or insert hatches on a separate layer that you can 
freeze as you continue to work on your drawing. 

To open the Boundary Hatch dialog box  

Do one of the following:  

 Choose Draw > Hatch 

 On the Draw toolbar, click the Hatch tool (  ) 

 Type bhatch and then press Enter. 

 

Specifying a hatch pattern  

A hatch pattern consists of a repeating pattern of lines, dashes, and dots. You can 
select a hatch pattern from a set of predefined patterns, or you can define a pattern of 
your own. The hatch pattern you used most recently is the default pattern the next time 
you add hatching. 

The program supplies predefined standard hatch patterns, which are stored in the 
4mcad.pat and 4mcadiso.pat hatch pattern library files. You can use other external 
hatch pattern libraries, such as an office standard library, customized patterns, and 
libraries available from vendors or standards organizations. 

To specify a predefined hatch pattern 

1. Do one of the following: 

 Choose Draw > Hatch  

 On the Draw toolbar, click the Hatch tool (   ) 

 Type bhatch and then press Enter. 

2. From the Hatch and Gradient dialog box, click the Hatch tab. 

3. In the Pattern Type list, select Predefined. 

With Predefined, you can apply a scale factor to make the pattern larger or smaller 
than the default size. 

4. For Scale, enter the scale factor as a percentage of the default. 

5. For Angle, enter the angle of the pattern in degrees (1-360). 

The default angle is clockwise; you can change the angle of any hatch pattern by 
entering a numerical value.  

6. For ISO Pen Width, enter the pen width. 
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If you choose a predefined, ISO standard pattern, you can scale the pattern based 
on the ISO pen width. 

7. To copy the pattern properties from an existing hatch, choose Inherit Properties 
and select the hatch. 

8. To associate the hatch pattern to its boundary entities, under Options, select the 
Associative check box. An associative hatch updates automatically if you move any 
of its boundaries.  

9. To continue, add a hatch by doing one of the following:  

 Select the entities you want to add a hatch. For details, see “Selecting entities 
for hatching”. Begin with step 2.  

 Select an area or boundary you want to add a hatch. For details, see “Selecting 
areas for hatching”. Begin with step 2. 

To specify a user-defined hatch pattern 

Do one of the following: 

 Choose Draw > Hatch 

 On the Draw toolbar, click the Hatch tool (   ) 

 Type bhatch and then press Enter. 

From the Hatch and Gradient dialog box, click the Hatch tab. 

In the Pattern Type list, click User Defined. 

For Spacing, enter the line spacing for the pattern. 

To crosshatch the pattern, select the Double check box. 

You can choose to crosshatch the pattern. Cross-hatching imposes a copy of the 
specified user-defined pattern at a 90-degree angle over the first pattern you 
defined. 

To copy the pattern properties from an existing hatch, choose Inherit Properties, and 
select a hatch pattern from a hatched entity in the drawing.  

To associate the hatch pattern to its boundary entities, under Options, select the 
Associative check box. An associative hatch updates automatically if you move any 
of its boundaries.  

To continue, add a hatch by doing one of the following:  

 Select the entities you want to add a hatch. For details, see “Selecting entities 
for hatching”. Begin with step 2.  

 Select an area or boundary you want to add a hatch. For details, see “Selecting 
areas for hatching”. Begin with step 2. 

To use a predefined library pattern 

1. Do one of the following: 

 Choose Draw > Hatch 

 On the Draw toolbar, click the Hatch tool (   ) 

 Type bhatch and then press Enter. 

2. From the Hatch and Gradient dialog box, click the Hatch tab. 
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3. For Hatch File, select the 4mcad.pat or 4mcadiso.pat hatch pattern library file. 

4. To select a predefined pattern, click the graphical representation of the hatch 
pattern.  

5. To continue, add a hatch by doing one of the following:  

 Select the entities you want to add hatching. For details, see “Selecting entities 
for hatching”. Begin with step 2.  

 Select an area or boundary you want to add hatching. For details, see 
“Selecting areas for hatching”. Begin with step 2. 

 

NOTE Hatch patterns are memory intensive and can take a considerable amount of 
time to draw and display. To improve performance, add hatching as one of the last 
steps when you create a drawing, or insert hatches on a separate layer that you can 
freeze as you continue to work on your drawing. 
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A. Select the Hatch file. 

B. Sets the pattern type. User-defined patterns are based on the current linetype in 
your drawing. A custom pattern is a pattern that is defined in any custom PAT files that 
you have added to the search path.  

C. Lists the available predefined patterns. The Pattern option is available only if you set 
Type to Predefined. 

D. Displays a preview of the selected pattern. 

E. Lists the available custom patterns. The Custom Pattern option is available only if 
you set Type to Custom. 

F. Expands or contracts a predefined or custom pattern. This option is available only if 
you set Type to Predefined or Custom. 

G. Specifies an angle for the hatch pattern relative to the X axis of the current UCS.  

H. For user-defined patterns, draws a second set of lines positioned at 90 degrees to 
the original lines, creating a crosshatch. This option is available only if you set Type to 
User Defined on the Hatch tab. 

I. Specifies the spacing of lines in a user-defined pattern. This option is available only if 
you set Type to User Defined 

J. Scales an ISO predefined pattern based on the selected pen width. This option is 
available only if you set Type to Predefined and set Pattern to one of the available ISO 
patterns. 

K. Scales the hatch pattern relative to paper space units. Using this option, you can 
easily display hatch patterns at a scale that is appropriate for your layout. This option is 
available only from a layout. 
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L. The origin is set to 0,0 by default. 

M. Specifies a new hatch origin. 

N. Specifies the new hatch origin point directly. 

O. Calculates a new origin based on the rectangular extents of the boundary for the 
hatch entity. Choices include each of the four corners of the extents and its center. 

P. Stores the value of the new hatch origin. 

Q. Shows the current location of the origin. 

R. Specifies that the hatch is annotative 

S. Controls whether the hatch or fill is associative or nonassociative. A hatch or fill that 
is associative is updated when you modify its boundaries. 

T. Controls whether a single hatch entity or multiple hatch entities are created when 
several separate closed boundaries are specified. 

U. Hatches or fills specified boundaries using the hatch or fill properties of a selected 
hatch entity. 

V. Assigns the draw order to a hatch or fill. You can place a hatch or fill behind all other 
entities front of all other entities, behind the hatch boundary, or in front of the hatch 
boundary. 

W. Controls several commonly used hatch or fill options.  

Selecting entities for hatching  

You can add hatching to any entity that forms a closed boundary, for example, a circle 
or rectangle. You can assign hatching to a single entity or several entities at the same 
time.  

To select entities for hatching 

Do one of the following: 

 Choose Draw > Hatch 

 On the Draw toolbar, click the Hatch tool (   ) 

 Type bhatch and then press Enter. 

From the Hatch and Gradient dialog box, click the Hatch tab. 

Under Island Detection Options, choose one of the following: 

 Normal The outer entity and all its islands are considered for hatching.  

 Outer Only the outer entity and its outer island are considered for hatching.  

 Ignore Only the outer entity is considered for hatching.  

 

Nested islands (A), with outer island (B), and with ignore islands (C).  

To keep any new entities that are created for drawing the boundary hatch, select the 
Retain Boundaries check box. Existing entities are always retained. 
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Click Select Entities. 

In the drawing, click the entities to be hatched individually or by choosing a selection 
method from the prompt box, and then press Enter when done. 

In the Hatch and Gradient dialog box, click OK. 

Selecting areas for hatching  

1. Do one of the following: 

 Choose Draw > Hatch 

 On the Draw toolbar, click the Hatch tool (   ) 

 Type bhatch and then press Enter. 

2. From the Hatch and Gradient dialog box, click the Hatch tab. 

3. Under Island Detection Options, choose one of the following: 

 Normal The outer entity and all its islands are considered for hatching.  

 Outer Only the outer entity and its outer island are considered for hatching.  

 Ignore Only the outer entity is considered for hatching. 

4. To keep any new entities that are created for drawing the boundary hatch, select 
the Retain Boundaries check box. Existing entities are always retained.  

5. Specify the entities that you want made available for boundary hatching. 

6. In the Hatch and Gradient dialog box, click Select Area. 

7. In the drawing, click inside the closed perimeter of a boundary, not on the boundary 
itself. If desired, continue clicking inside additional closed perimeters. 

8. To complete the selection, press Enter. 
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9. In the Hatch and Gradient dialog box, click OK. 

 

A. Determines a boundary from existing objects that form an enclosed area around the 
specified point. 

B. Determines a boundary from selected objects that form an enclosed area. 

C. Removes from the boundary definition any of the objects that were added 
previously.  

D. Creates a polyline or region around the selected hatch or fill, and optionally 
associates the hatch object with it. 

E. Temporarily closes the Hatch and Gradient dialog box and displays the currently 
defined boundaries with the current hatch or fill settings. This option is unavailable 
when no boundary has been defined. 

To add gradient hatch 

Do one of the following: 

 Choose Draw > Hatch 

 On the Draw toolbar, click the Hatch tool (   ) 

 Type bhatch and then press Enter. 
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From the Hatch and Gradient dialog box, click the Gradient tab. 

Under Color, choose one of the following: 

 One Color Specifies a fill that uses a smooth transition between darker shades 
and lighter tints of one color. When One Color is selected, hatch displays a 
color swatch with Browse button and a Shade and Tint slider 

 Two Color Specifies a fill that uses a smooth transition between two colors. 

In Color Swatch Specify the color for the gradient fill. 

Specify the orientation of the gradient and whether it is symmetrical. 

 

A. Select one or two color for Gradient hatch. 

B. Select the color for Gradient hatch. 

C. Specifies a gradient configuration that is symmetrical. If this option is not selected, 
the gradient fill is shifted up and to the left, creating the illusion of a light source to the 
left of the object. 

D. Specifies the angle of the gradient fill. The specified angle is relative to the current 
UCS. This option is independent of the angle specified for hatch patterns. 
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2.5 Modifying entities 
4MCAD provides many editing tools for modifying a drawing. You can easily move, 
rotate, or stretch drawing entities, or change their scale. When you want to remove an 
entity, you can delete it with a few clicks of the mouse. You can also make multiple 
copies of any entity and copy entities from one drawing to another.  

You can modify most entities using general-purpose editing commands, many of which 
are located on the Modify toolbar and the Modify menu. Some complex entities require 
special commands. This section explains how to:  

- Select entities using entity-selection methods and grips.  

- Change the properties of entities.  

- Rearrange entities by moving, rotating, or changing the display order.  

- Resize entities by stretching, scaling, extending, trimming, or editing their lengths.  

- Break and join entities.  

- Group entities.  

- Edit polylines.  

- Explode entities.  

- Create chamfers and fillets.  

2.5.1 Selecting entities 

You can create a selection set that consists of one or more entities before you modify 
them. Use any of the following methods to create a selection set:  

 Choose a command or tool first, and then select entities.  

 Select entities first, and then choose a command or tool (most entities).  

 Select entities by pointing, and then use grips to modify them.  

Displaying selected entities highlighted  

You can specify whether to display selected entities highlighted, which makes the 
selection set easier to see. By default, the highlighting feature is turned on.  

To turn the highlighting feature on or off 

1. Do one of the following:  

 On the Standard toolbar, click the Drawing Settings tool (  ). 

 Type settings and then press Enter. 

2. Click the Display tab. 

3. In the Change Settings For box, select Display. 

4. Select or clear the Highlight Item When Selected check box. 

5. Click OK.  

Entity-selection methods  
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When you choose a command that requires you to select entities (when you’re deleting 
or changing entity properties, for example), you can use any of the following selection 
methods, which are displayed in a prompt box:  

 Select all entities Selects all entities in the current drawing. 

 Add to set Adds one or more entities to the selection set. 

 Subtract from set Removes one or more entities from the selection set. 

 Previous selection Selects entities included in the previous selection set. 

 Last entity in drawing Selects the entity most recently added to the drawing. 

 Window-Inside Selects entities contained entirely within a rectangular 
selection window. 

 Crossing window Selects entities contained within or crossing the boundary of 
a rectangular selection window. 

 Outside window Selects entities falling completely outside a rectangular 
selection window. 

 Window polygon Selects entities contained entirely within a polygon selection 
window. 

 Crossing polygon Selects entities contained within or crossing the boundary of 
a polygon selection window. 

 Outside polygon Selects entities falling completely outside a polygon selection 
window. 

 Window circle Selects entities contained entirely within a circular selection 
window. 

 Crossing circle Selects entities contained within or crossing the boundary of a 
circular selection window. 

 Outside circle Selects entities falling completely outside a circular selection 
window. 

 Point Selects any closed entities that surround the selected point. 

 Fence Selects entities crossing a line or line segments. 

In addition to these methods, you can select entities that match a particular set of 
properties -for example, all entities on a particular layer or drawn in a certain color. 

You can also use a few selection methods automatically, without displaying the prompt 
box. For example, you can simply click to select entities, or you can use a Window-
Inside or Crossing Window by defining the opposite corners of a rectangular selection 
window. The direction in which you define the points of the rectangle (left-to-right or 
right-to-left) determines which type of window you create. Within the user’s guide, the 
user can find all the details about how to create a Window-Inside, or a crossing 
Window, as well as about how to select entities using a Window Polygon or a Fence 
etc.  

2.5.2 Modifying the properties of entities 

You can change the layer, thickness, linetype, color, and linetype scale of one or more 
entities. Depending on the type of entity or entities you select, you can also change 
other properties, such as the start point and endpoint of lines, the center point and 
radius of circles, and the vertices of polylines. 
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You can modify all the properties of all entities simultaneously. For example, using the 

ai_propchk command, select all entities on a particular layer, and then move the 
entities to another layer by simply selecting a name from the Layer text box.  

In the Entity Properties dialog box, changes that you make in the Layer, Color, 
Thickness, Lineweight, Linetype, and Linetype Scale fields affect all selected entities. If 
you select several entities that all have different properties, the default value initially is 
Varies. Changes that you make in the entity tabs, such as Circle, Line, and Arc, affect 
all selected entities of that type. You can select the entities to be changed using any 
entity-selection method.  

To modify properties of entities 

1. Do one of the following:  

 Choose Modify > Properties. 

 On the Modify toolbar, click the Properties tool (  ). 

 Type ai_propchk and then press Enter. 

2. Select the entities. 

3. Make changes to the desired properties, and then press Enter.  

You can also access many of the entity properties using the Entity Properties toolbar. 
Note that the Entity Properties toolbar settings that display when no entities are 
selected determine the properties of new entities when you draw them. 

The Properties Panel has two areas. The above area ‘’General’’ that appears common 
properties for all selected entities, such as layer, linetype, linetype scale, lineweight, 
color etc. 

 

By pressing the button with the arrow, the user can see the number an the type of the 
entities. The user can modify any common property. 

By selecting one entity, (eg line), the property panel change appearance and displays 
the properties of this selected entity. The user can modify any property of them. 
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2.5.3 Deleting entities 

You can remove entities from a drawing. You can delete entities using any of the 
entity-selection methods. 

To delete a selection set  

1. Do one of the following:  

 Choose Modify > Erase. 

 Choose Edit -> Clear. 

 On the Modify toolbar, click the Erase tool (  ).  

 Type delete or erase and then press Enter.  
2. Select the entities, and then press Enter.  

2.5.4 Copying entities 

You can copy one or more entities, making one copy or multiple copies within the 
current drawing. You can also copy entities between drawings. 

Use any of the following methods to copy entities within the current drawing:  

 Create a copy at a location referenced from the original.  

 Create a copy aligned parallel to the original.  
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 Create a copy as a mirror image of the original.  

 Create several copies in a rectangular or circular pattern.  

Copying entities within a drawing  

You can duplicate entities within the current drawing. The default method is to create a 
selection set and then specify a starting point, or base point, and an endpoint, or 
displacement point, for the copy. You can also make multiple copies or copy the 
selection set to a location you specify, using a direction vector. 

To copy a selection set once 

1. Do one of the following:  

 Choose Modify > Copy.  

 On the Modify toolbar, click the Copy tool (  ). 

 Type copy and then press Enter. 

2. Select the entities, and then press Enter. 

3. Specify the base point. 

4. Specify the displacement point. 

 

Entity to copy (A), base point (B), displacement point (C) and Result.  

 

Other related issues, such as to make multiple copies of a selection set, or how to 
copy between drawings by using the Clipboard, are described in detail within the user’s 
guide. 

2.5.5 Rearranging entities 

You can move one or more entities, and you can also rotate entities about a specified 
point. If you have entities that overlap, you can also change the display order.  

Moving entities 

You can move entities around within the current drawing or from one drawing to 
another. The default method is to create a selection set and then specify a starting 
point, or base point, and an endpoint, or displacement point, to define the relocation of 
the entities. You can also relocate the entities using a direction vector. 

To move a selection set 

1. Do one of the following:  

 Choose Modify > Move.  

 On the Modify toolbar, click the Move tool (  ). 

 Type move and then press Enter. 

2. Select the entities, and then press Enter. 
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3. Specify the base point. 

4. Specify the displacement point. 

 
To move an entity, select it (A), and then specify the base point (B) and the displacement point 

(C). 

You can also move entities using grips. To move an entity using grips, select the entity 
to display its grips, and then click a grip and drag it. The grip you select depends on 
the type of entity you’re modifying. For example, to move a line entity, select the 
midpoint grip. To move a curved entity, such as an arc, circle, or ellipse, select the 
center point grip. Not all entities can be moved using grips.  

To move an entity using grips  

1. Select the entity.  

2. Click a grip to select it.  

3. Drag the entity to where you want to relocate it.  

4. Click to release.  

Rotating entities  

You can rotate entities about a specified point at a specified rotation angle or by an 
angle referenced to a base angle. The default method rotates the entities using a 
relative rotation angle from their current orientation.  

To rotate a selection set 

1. Do one of the following:  

 Choose Modify > Rotate.  

 On the Modify toolbar, click the Rotate tool (  ).  

 Type rotate and then press Enter. 

2. Select the entities, and then press Enter. 

3. Specify the rotation point. 

4. Specify the rotation angle. 

 
To rotate an entity, select the entity to rotate (A), and then specify the rotation point (B) and the 

rotation angle (C).  



 

 

54  4M 

To rotate a selection set in reference to a base angle 

1. Do one of the following:  

 Choose Modify > Rotate.  

 On the Modify toolbar, click the Rotate tool (  ).  

 Type rotate and then press Enter. 

2. Select the entities, and then press Enter. 

3. Specify the rotation point. 

4. In the prompt box, choose Base Angle. 

5. Specify the base angle.  

6. Specify the new angle.  

 
To rotate an entity in reference to a base angle, select the entity (A), specify the rotation point 
(B), select the base angle and pick point (B) again (or type the @ symbol), specify the second 

point (C), and then specify the point representing the new angle (D).  

 

When multiple entities overlap, you can change the order in which they are displayed 

and printed, using the Tools > Display Order command. 

2.5.6 Resizing entities  

You can change the size of an entity or set of entities by stretching, scaling, extending, 
trimming, or editing their lengths.  

Stretching entities  

You can change the size of entities by stretching them. When you stretch entities, you 
must select the entities using either a crossing window or a crossing polygon. You then 
specify a displacement distance or select a base point and a displacement point. 
Entities that cross the window or polygon boundary are stretched; those completely 
within the crossing window or crossing polygon are simply moved.  

To stretch an entity 

1. Do one of the following:  

 Choose Modify > Stretch.  

 On the Modify toolbar, click the Stretch tool (  ). 

 Type stretch and then press Enter. 

2. In the prompt box, choose Crossing Window or Crossing Polygon. 

3. Select the entities, and then press Enter. 

4. Specify the base point. 
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5. Specify the second point of displacement.  

 
To stretch entities, select them using a crossing window (A) or crossing polygon, and then 

specify the base point (B) and displacement point (C).  

To stretch an entity using grips, you select it to display its grips and then select a grip 
to make it the active grip. This becomes the base point. Then you move the active grip 
to a new location. The grip you select depends on the type of entity you’re modifying. 
For example, to stretch one corner of a rectangle, select the corner point grip. To 
stretch a line, select an endpoint grip. Not all entities can be stretched using grips.  

To stretch an entity using 

grips 

1. Select the entity. 

2. Click a grip to activate it. 

3. Drag the grip. 

4. Click to release.   

 

Scaling entities  

You can change the size of a selected entity by scaling it in relation to a base point. 
You can change the size of an entity by specifying a base point and a length, which is 
used as a scale factor based on the current drawing units, or by specifying a scale 
factor. You can also use a scale factor referenced to a base scale factor, for example, 
by specifying the current length and a new length for the entity. 

To scale a selection set by a scale factor 

1. Do one of the following:  

 Choose Modify > Scale.  

 On the Modify toolbar, click the Scale tool (  ). 

 Type scale and then press Enter. 

2. Select the entities, and then press Enter. 

3. Specify the base point. 

4. Specify the scale factor. 

 
To scale an entity by a scale factor, select the entity (A), and then specify the base point (B) and 

the scale factor.  
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You can also scale some entities using grips. To scale an entity, you select the entity, 
and then click a grip. You then change the size of the entity by moving the grip. The 
grip you select depends on the type of entity you’re modifying. For example, to scale a 
circle, select a quadrant point grip.  

To scale an entity using grips  

1. Select the entity. 

2. Click a grip to select it. 

3. Drag the grip. 

4. Click to release. 

 
To scale using grips, select the entity (A), click a grip (B), and scale the entity by dragging the 

grip to its new location (C). 

Extending entities  

You can extend entities so that they end at a boundary defined by other entities. You 
can also extend entities to the point at which they would intersect an implied boundary 
edge. When extending entities, you first select the boundary edges, and then specify 
the entities to extend, selecting them either one at a time or using the fence selection 
method. 

You can extend arcs, lines, two-dimensional polylines, and rays. Arcs, circles, ellipses, 
lines, splines, polylines, rays, infinite lines, and viewports on a Layout tab can act as 
boundary edges.  

To extend an entity  

1. Do one of the following:  

 Choose Modify > Extend.  

 On the Modify toolbar, click the Extend tool (  ). 

 Type extend and then press Enter.  

2. Select one or more entities as boundary edges, and then press Enter.  

3. Select the entity to extend.  

4. Select another entity to extend, or press Enter to complete the command.  

 
To extend entities, select the boundary edge (A), and then select the entities to extend (B).  
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To extend an entity to an implied boundary 

1. Do one of the following:  

 Choose Modify > Extend.  

 On the Modify toolbar, click the Extend tool (  ). 

 Type extend and then press Enter. 

2. Select one or more boundary edges, and then press Enter. 

3. In the prompt box, choose Edge Mode. 

4. In the prompt box, choose Extend. 

5. Select the entity to extend. 

6. Select another entity to extend, or press Enter to complete the command.  

 
Select the boundary edge (A), and then select the entities to extend (B).  

To extend several entities using the fence selection method 

1. Do one of the following:  

 Choose Modify > Extend.  

 On the Modify toolbar, click the Extend tool (  ). 

 Type extend and then press Enter. 

2. Select one or more boundary edges, and then press Enter.  

3. In the prompt box, choose Fence.  

4. Specify the first point of the fence.  

5. Specify the second point of the fence.  

6. Specify the next fence point, or press Enter to complete the command.  

 
Select the boundary edge (A), and then specify the first point (B) and second point (C) of the 

fence. 

When you extend a wide polyline, its centerline intersects the boundary edge. Because 
the end of the polyline is always cut at a 90-degree angle, part of the polyline may 
extend past the boundary edge. A tapered polyline continues to taper until it intersects 
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the boundary edge. If this would result in a negative polyline width, the ending width 
changes to 0.  

 
A tapered polyline (A) continues to taper until it intersects the boundary edge (B).  

Trimming entities  

You can clip, or trim, entities so they end at one or more implied cutting edges defined 
by other entities. You can also trim entities to the point at which they would intersect an 
implied cutting edge. When trimming entities, you first select the cutting edges and 
then specify the entities to trim, selecting them either one at a time or using the fence 
selection method. 

You can trim arcs, circles, lines, open two-dimensional and three-dimensional 
polylines, and rays. Arcs, circles, lines, polylines, rays, infinite lines, and viewports on a 
Layout tab can act as cutting edges. An entity can be both a cutting edge and one of 
the entities being trimmed.  

To trim an entity 

1. Do one of the following:  

 Choose Modify > Trim. 

 On the Modify toolbar, click the Trim tool (  ).  

 Type trim and then press Enter. 

2. Select one or more cutting edges, and then press Enter. 

3. Select the entity to trim. 

4. Select another entity to trim, or press Enter to complete the command.  

 

To trim entities, select the cutting edge (A), and then select the entities to trim (B).  

To trim an entity to an implied boundary  

1. Do one of the following:  

 Choose Modify > Trim.  

 On the Modify toolbar, click the Trim tool (  ).  

 Type trim and then press Enter. 

2. Select one or more cutting edges, and then press Enter. 

3. In the prompt box, choose Edge Mode. 



 

 

4MCAD  59 

4. In the prompt box, choose Extend. 

5. Select the entity to trim.  

 
Select the implied boundary edge (A), and then select the entities to trim (B).  

To trim several entities using the fence selection method 

1. Do one of the following:  

 Choose Modify > Trim.  

 On the Modify toolbar, click the Trim tool (  ).  

 Type trim and then press Enter. 

2. Select one or more cutting edges, and then press Enter. 

3. In the prompt box, choose Fence. 

4. Specify the first point of the fence. 

5. Specify the second point of the fence. 

6. Specify the next fence point, or press Enter to complete the command.  

 
Select the boundary edge (A), and then specify the first point (B) and second point (C) of the 

fence.  

Editing the length of entities  

You can change the length of entities or the included angle of arcs. Use any of the 
following methods to change the length of an entity: 

 Dynamically drag the endpoint or angle.  

 Specify an incremental length or angle measured from an endpoint.  

 Specify the new length as a percentage of the total length or angle.  

 Specify a new length or included angle.  

You can change the length of arcs, lines, and open polylines.  

To change the length of an entity by dragging 

1.  Do one of the following:  

 Choose Modify > Edit Length.  
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 On the Modify toolbar, click the Edit Length tool (  ). 

 Type editlen and then press Enter. 

2. In the prompt box, choose Dynamic. 

3. Select the entity you want to change. 

4. Specify the new endpoint or included angle.  

 
Select the entity (A), and then select the new endpoint (B).  

2.5.7 Breaking and joining entities 

You can break an entity into two parts, removing a portion of the entity in the process. 
You can also join two entities into a single entity. 

Breaking entities 

You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When 
breaking entities, you must specify two points for the break. By default, the point you 
use to select the entity becomes the first break point; however, you can use the First 
option to select a break point different from the one that selects the entity. 

Joining entities  

You can join two entities into a single entity. You can join either two lines or two arcs. 
The two lines must be parallel; the two arcs must share the same center point and 
radius.  

Step-by-step instructions about how to break or join entities are given within the user’s 
guide. 

2.5.8 Grouping entities  

A group is a collection of entities saved together as one unit. After you select the 
entities that belong in the group, you can later add more entities, remove entities, and 
reorder the entities. If necessary, you can also ungroup the entities at any time to work 
with the entities separately. More details about the group dialog box controls are 
described within the user’s guide. 

2.5.9 Editing polylines  

You can modify any type of two-dimensional or three-dimensional polyline. Entities 
such as rectangles, polygons, and donuts, as well as three-dimensional entities such 
as pyramids, cylinders, and spheres, are all variations of polylines that you can edit. 

You can edit a polyline by opening or closing it, by changing its overall width or the 
widths of individual segments, and by converting a polyline with straight line segments 
into a flowing curve or an approximation of a spline. In addition, you can use the Edit 
Polyline tool to edit individual vertices, adding, removing, or moving vertices. You can 
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also add new segments to an existing polyline, change the linetypes of a polyline, and 
reverse the direction or order of the vertices.  

To modify a polyline, you first select the polyline, and then select a polyline editing 
option. The available options vary depending on whether the selected polyline is a two-
dimensional or three-dimensional entity. If the selected entity is not a polyline, the Edit 
Polyline tool provides the option of turning it into one. You can convert only arcs and 
lines into polylines. If several arcs or lines are joined endpoint to endpoint, they can all 
be selected and turned into one polyline. 

To convert an entity into a polyline 

1. Do one of the following:  

 Choose Modify > Object -> Polyline.  

 On the Modify toolbar, click the Edit Polyline tool (  ).  

 Type editpline or pedit and then press Enter. 

2. Select the entity. 

3. In the prompt box, choose Yes-Turn Into Polyline. 

4. In the prompt box, choose another option, or choose Done to complete the 
command.  

Opening and closing polylines 

When you close a polyline, the program draws a straight polyline segment from the 
last vertex of the polyline to the first vertex. Opening a polyline removes the closing 
segment. When you select a polyline for editing, the prompt box displays either the 
Open or Close option, depending on whether the polyline you select is closed or open. 

To close an open polyline 

1. Do one of the following:  

 Choose Modify > Object -> Polyline.  

 On the Modify toolbar, click the Edit Polyline tool (  ). 

 Type editpline or pedit and then press Enter.  

2. Select the polyline.  

3. In the prompt box, choose Close. 

4. In the prompt box, choose another option, or choose Done to complete the 
command. 

 
Closing an open polyline adds a straight polyline segment between the first (A) and last (B) 

vertices.  
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The way of curving and decurving polylines  (fit a curve to a polyline), Joining polylines 
(To join an arc, or polyline to an existing polyline), changing the polyline width (apply a 
uniform width to an entire polyline, or  taper a polyline uniformly along its length), as 
well as the way of editing polyline vertices, are all described within the user’s guide. 

 

2.5.10 Exploding entities 

You can convert a complex entity, such as a block or polyline, from a single entity into 
its component parts. Exploding a polyline, rectangle, donut, polygon, dimension, or 
leader reduces it to a collection of individual line and arc entities that you can then 
modify individually. Blocks are converted to the individual entities, possibly including 
other, nested blocks that composed the original entity. More details about how to 
explode entities are described within the user’s guide. 

2.5.11 Chamfering and filleting entities 

You can chamfer or fillet entities. A chamfer connects two nonparallel entities with a 
line to create a beveled edge. A fillet connects two entities with an arc of a specified 
radius to create a rounded edge. If both entities you are working with are on the same 
layer, the chamfer or fillet is drawn on that layer. If they are on different layers, the 
chamfer or fillet is drawn on the current layer. More details are described within the 
user’s guide. 

2.6 Working with coordinates 
For accuracy in a drawing, you can locate specific points by entering coordinates as 
you draw or modify entities. When you create two-dimensional entities, you enter two-
dimensional coordinates; for three-dimensional entities, you specify three-dimensional 
coordinates.  

You can also specify coordinates in relation to other known locations or entities in a 
drawing. In particular, when you work in three-dimensional drawings, it is often easier 
to specify coordinates in relation to a two-dimensional working plane, called a user 
coordinate system (UCS).  

This section explains how to work with coordinates, including how to:  

- Use two-dimensional and three-dimensional coordinate systems.  

- Specify absolute and relative coordinates.  

- Specify polar, spherical, and cylindrical coordinates.  

- Define and manipulate user coordinate systems.  

2.6.1 Using Cartesian coordinates 

Many commands in 4MCAD require that you specify points as you draw or modify 
entities. You can do so by selecting points with the mouse or by typing coordinate 
values in the command bar. The program locates points in a drawing using a Cartesian 
coordinate system.  

Understanding how coordinate systems work  

The Cartesian coordinate system uses three perpendicular axes -x, y, and z- to specify 
points in three-dimensional space. Every location in a drawing can be represented as a 
point relative to a 0,0,0 coordinate point, referred to as the origin. To draw a two-
dimensional entity, you specify horizontal coordinate positions along the x-axis and 
vertical coordinate positions along the y-axis. Thus, every point on a plane can be 
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represented as a coordinate pair composed of an x-coordinate and a y-coordinate. 
Positive coordinates are located above and to the right of the origin; negative 
coordinates are located to the left and below the origin.   

 
The three perpendicular axes of the Cartesian coordinate system.  

When you work in two dimensions, you need enter only the x- and y-coordinates; the 
program assumes that the z-axis value is always the current elevation. When you work 
in three dimensions, however, you must also specify the z-axis value. When you look 
at a plan view of your drawing (a view from above, looking down), the z-axis extends 
straight up out of the screen at a 90-degree angle to the xy plane. Positive coordinates 
are located above the xy plane, and negative coordinates are below the plane.  

All 4MCAD drawings use a fixed coordinate system, called the World Coordinate 
System (WCS), and every point in a drawing has a specific x,y,z-coordinate in the 
WCS. You can also define arbitrary coordinate systems located anywhere in three-
dimensional space. These are called user coordinate systems and can be located 
anywhere in the WCS and oriented in any direction.  

You can create as many user coordinate systems as you want, saving or redefining 
them to help you construct three-dimensional entities. By defining a UCS within the 
WCS, you can simplify the creation of most three-dimensional entities into 
combinations of two-dimensional entities. 

To help you keep your bearings in the current coordinate system, the program displays 
a coordinate system icon. When you begin a new drawing, you are automatically in the 
WCS, indicated by the letter W in the icon. When you display a drawing in plan view, 
you see the coordinate system icon from the top, with the z-axis directed straight 
toward you. When you display a three-dimensional drawing in a view other than plan 
view, the coordinate system icon changes to reflect your new viewpoint.  

TIP: The visible portions of the axes are the positive directions. 
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WCS icon. - Plan UCS icon. - 3D View WCS icon.  

The 4MCAD UCS icon looks different from the UCS icon in AutoCAD, because it 
presents more information. Three colors represent the three axes, making it easier for 
you to recognize the orientation in three-dimensional space:  

 x-axis: red  

 y-axis: green  

 z-axis: blue  

If you prefer a single color for the cursor and UCS icon, you can make that change 
with the config or options command.  

Understanding how coordinates are displayed  

The current position of the cursor is displayed as x,y,z-coordinates in the status bar 
and, by default, updates dynamically as you move the cursor. You can toggle the 

coordinate display to static mode by pressing F6, so that it updates only when you 
select a point in the drawing. 

 

You can also change the coordinate display to a different dynamic mode that shows 
the distance and angle (rather than x,y,z-coordinates) when the program displays a 
rubber-band line. To do this, choose Settings > Drawing Settings and select the 
Display tab. Under Coordinate Display, select the option for Coordinates In Polar Form 
For Distance And Angle Selection.  

 
You can control the coordinate display from the Drawing Settings dialog box.  

Finding the coordinates of a point  
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To find the x,y,z-coordinates for a point on an entity, such as the endpoint of a line, 
select an appropriate entity snap (such as Endpoint) before selecting the entity. If you 
have no entity snaps set, the x,y-coordinates of the point you specified is displayed, 
with the z-coordinate equal to the current elevation.  

To find the coordinate of a point in the drawing 

1. Do one of the following:  

 Choose Tools > Inquiry > ID Coordinates.  

 On the Inquiry toolbar, click the ID Coordinates tool (  ). 

 Type idpoint or id and then press Enter. 

2. Select the point for which you want to find the coordinates. 

If the command bar is activated, the x,y,z-coordinates for the point you selected 
display in the command bar. If the command bar is not activated, the Prompt History 
window displays, showing the x,y,z-coordinates for the point you selected.  

2.6.2 Using two-dimensional coordinates  

When working in two dimensions, you specify points on the xy plane. You can specify 
any point as an absolute coordinate (or Cartesian coordinate), using the exact x-
coordinate and y-coordinate locations in relation to the origin (the 0,0 coordinate point 
at which the two axes intersect), or as a relative coordinate in relation to the previous 
point. You can also specify points using relative or absolute polar coordinates, which 
locate a point using a distance and an angle.  

Entering absolute Cartesian coordinates  

To enter absolute Cartesian coordinates, type the coordinate location of the point in 
the command bar. For example, to use absolute Cartesian coordinates to draw a line 
from the origin (0,0) to a point 3 units to the right and 1 unit above the origin, start the 
Line command and respond to the prompts as follows:  

Start of line: 0,0 

Angle • Length • <Endpoint>: 3,1 

 
Drawing a line using the absolute Cartesian coordinate method.  

When using absolute Cartesian coordinates, you need to know the exact point 
locations for anything you draw. For instance, to use absolute Cartesian coordinates to 
draw an 8.5-unit square with its lower left corner at 4,5, you must determine that the 
upper left corner is at coordinate 4,13.5, the upper right corner at 12.5,13.5, and the 
lower right corner at 12.5,5.  



 

 

66  4M 

Entering relative Cartesian coordinates  

Another, simpler method is to use relative Cartesian coordinates: you specify a location 
in the drawing by determining its position relative to the last coordinate you specified. 
To use relative Cartesian coordinates, type the coordinate values in the command bar, 
preceded by the at symbol (@). The coordinate pair following the @ symbol represents 
the distance along the x-axis and the y-axis to the next point. For example, to draw an 
8.5-unit square with its lower left corner at 4,5 using relative Cartesian coordinates, 
start the Line command, and then respond to the prompts as follows:  

Start of line: 4,5 

Angle • Length • <Endpoint>: @8.5,0 

Angle • Length • Follow • Undo • <Endpoint>: @0,8.5 

Angle • Length • Follow • Close • Undo • <Endpoint>: @-8.5,0 

Angle • Length • Follow • Close • Undo • <Endpoint>: C 

 
Drawing a square using the relative Cartesian coordinates method; enter C to close.  

The first relative coordinate (@8.5,0) locates the new point 8.5 units to the right (along 
the x-axis) from the previous point of 4,5; the second relative coordinate (@0,8.5) 
locates the next point 8.5 units above (along the y-axis) the previous point, and so on. 
Entering C (for Close) draws the final line segment back to the first point specified 
when you started the Line command.  

Entering polar coordinates  

Using relative polar coordinates makes drawing a square tilted at a 45-degree angle a 
simple task. Polar coordinates base the location of a point on a distance and angle 
from either the origin (absolute coordinate) or from the previous point (relative 
coordinate).  

To specify polar coordinates, type a distance and an angle, separated by the open 
angle bracket (<). For example, to use relative polar coordinates to specify a point 1 
unit away from the previous point and at an angle of 45 degrees, type @1<45.  

To draw the square from the example in the previous section, “Entering relative 
Cartesian coordinates,” this time tilted at a 45-degree angle, start the Line command, 
and then respond to the prompts as follows:  

Start of line: 4,5 

Angle • Length • <Endpoint>: @8.5<45 

Angle • Length • Follow • Undo • <Endpoint>: @8.5<315 
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Angle • Length • Follow • Close • Undo • <Endpoint>: @8.5<225 

Angle • Length • Follow • Close • Undo • <Endpoint>: C 

 
Drawing a tilted square using the relative polar coordinates method; enter C to close.  

2.6.3 Using three-dimensional coordinates 

Specifying coordinates in three-dimensional space is similar to working in two 
dimensions, except that you also use the z-axis to locate coordinates. Three-
dimensional coordinates are represented in the format x,y,z (for example, 2,3,6).  

More details about how to use 3D coordinates are described within the user’s guide. 

 

2.7 Viewing your drawing  
4MCAD provides many ways to display and view your drawing. You can also change 
various display settings to speed up the display or printing of a drawing. This section 
explains how to:  

- Navigate within a drawing by scrolling, panning, and rotating the view.  

- Change the magnification of a drawing by zooming in and out.  

- Work with multiple windows or views of a drawing.  

- Control the display of elements to optimize performance when working with large or 
complex drawings.  

2.7.1 Redrawing and regenerating a drawing 

As you work on a drawing, visual elements may remain after the completion of a 
command. You can remove these elements by refreshing, or redrawing, the display.  

To redraw (refresh) the current window display  

Do one of the following:  

 Choose View > Redraw.  

 Type redraw and then press Enter.  

Information about drawing entities is stored in a database as floating point values, 
ensuring a high level of precision. Sometimes a drawing must be recalculated, or 
regenerated, from the floating-point database to convert those values to the 
appropriate screen coordinates. This occurs automatically. You can also manually 
initiate a regeneration. When the drawing is regenerated, it is also redrawn. To 
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regenerate the current window, type regen in the command bar. If more than one 

window is displayed, type regenall to regenerate all the windows.  

2.7.2 Moving around within a drawing  

You can move the view of a drawing displayed in the current viewport by scrolling, 
panning, or rotating the view. Doing this changes the portion of the drawing you are 
viewing without changing the current magnification. Scrolling lets you move around in 
the drawing horizontally and vertically. Panning lets you move the drawing in any 
direction. Rotating lets you view your drawing from any angle.  

Using scroll bars  

To assist you in navigating within a drawing, horizontal and vertical scroll bars are 
available in each drawing window. The size of the scroll box in relation to the scroll bar 
indicates the current level of drawing magnification. The position of the scroll box in 
relation to the scroll bar indicates the location of the center of the drawing in relation to 
the extents of the drawing (the smallest rectangle containing all the entities in the 
drawing). 

To turn scroll bars on or off  

Do one of the following:  

 Choose View > Display -> Scroll Bars.  

 Type scrollbar, press Enter, and then select On, Off, or Toggle.  

Using the Pan command  

You can move the drawing in any direction using the Pan tool (  ) on the View toolbar. 
Panning shifts or slides the view of the drawing horizontally, vertically, or diagonally. 
The magnification of the drawing remains the same, as does its orientation in space. 
The only change is the portion of the drawing displayed.  

To pan, you can use any of the following methods:  

 For precise panning, specify two points defining the magnitude and direction of 
the pan. The first point, or base point, indicates the starting point of the pan. 
The second point indicates the amount of pan displacement relative to the first 
point.  

 To pan in real time, use the right mouse button.  

 If you have a mouse with a wheel, use the wheel to pan up or down.  

 To pan in small increments, use the arrow keys.  

To pan by specifying two points 

1. Do one of the following:  

 Choose View > Pan -> Real time.  

 On the Standard toolbar, click the Pan tool (  ). 

 Type pan and then press Enter. 

2. Specify the pan base point either by typing the coordinates or by specifying a point 
in the drawing window.  

3. Specify the pan displacement point either by typing the coordinates or by 
specifying a point in the drawing window.  
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Select the pan base point (A),and then select a second point (B) to specify the pan 

displacement. 

To pan in real time 

1. Simultaneously press Ctrl+Shift and click and hold the right mouse button. 

2. Move the cursor in the direction you want to pan. 

3. To stop panning, release the mouse button. 

To pan using a mouse with a wheel  

 Rotate the wheel backward to pan up or forward to pan down.  

To pan using the arrow keys  

 Press the up, down, right, or left arrow keys.  

Rotating the view  

4MCAD allows you to rotate your view of a drawing in real time. This allows you to view 
your model from any angle.  

If desired, you can continue the view rotation after you release your mouse. Choose 

Tools > Preferences to enable continuous motion.  

To rotate the view in real time 

1. Type rtrot, and then press Enter.  

2. Click and drag the mouse in the drawing. The view rotates according to the 
movement of your mouse.  

3. To stop rotating, release the mouse button.  

4. If desired, continue rotating the view.  

5. When finished, press Enter or right-click the drawing.  

2.7.3 Changing the magnification of your drawing   

You can change the magnification of your drawing at any time by zooming. The cursor 

changes to a magnifying glass (  ) when a zoom tool is active. Zoom out to reduce the 
magnification so you can see more of the drawing, or zoom in to increase the 
magnification so you can see a portion of the drawing in greater detail. Changing the 
magnification of the drawing affects only the way the drawing is displayed; it has no 
effect on the dimensions of the entities in your drawing.  

Zooming in and out  

One of the easiest ways to change the magnification of the drawing is to zoom in or 

out by a preset increment. On the View toolbar, the Zoom In (  ) tool doubles the 

current magnification of the drawing. The Zoom Out (  ) tool reduces the 
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magnification of the drawing by half. The portion of the drawing located at the center of 
the current viewport remains centered on the screen as you zoom in and out.  

 

Zoom in. - Zoom out.  

Zooming methods  

To zoom, you can use any of the following methods:  

 To define the portion of the drawing to zoom, create a window.  

 To zoom in real time, use the mouse.  

 If you have a mouse with a wheel, use the wheel button to zoom in and out.  

To zoom in to an area using a window 

1. Do one of the following:  

 Choose View > Zoom > Window.  

 On the View toolbar, click the Zoom Window tool (  ). 

 Type zoom and then press Enter. 

2. Select one corner of the window around the area you want to magnify. 

3. Specify the opposite corner of the window around the area you want to magnify.  

 

To specify a rectangular window around the area you want to magnify, select first one corner(A), 
and then select the opposite corner (B). 

To zoom in real time 

1. Simultaneously press Ctrl+Shift and click and hold the left mouse button. 

2. To zoom in, move the cursor up the screen; to zoom out, move the cursor down the 
screen. 

3. To stop zooming, release the mouse button.  

To zoom using a mouse with a wheel 

 Rotate the wheel away from you to zoom in or toward you to zoom out.  

Each rotation of the wheel away from you zooms out .8 times; each rotation toward you 
zooms in 1.25 times.  

Displaying the previous view of a drawing  
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After you zoom in or pan to view a portion of your drawing in greater detail, you may 
want to zoom back out to see the entire drawing. On the View menu, the Zoom 

Previous tool (  ) lets you restore the previous view. Selecting this tool repeatedly 
steps back through up to 25 successive zoomed or panned views. 

Zooming to a specific scale 

You can increase or decrease the magnification of your view by a precise scale factor 
measured relative to the overall size of the drawing or in relation to the current display. 
When you change the magnification factor, the portion of the drawing located at the 
center of the current viewport remains centered on the screen. 

To change the magnification of the view relative to the overall size of the drawing, type 
a number representing the magnification scale factor. For example, if you type a scale 
factor of 2, the drawing appears at twice its original size. If you type a magnification 
factor of .5, the drawing appears at half its original size.  

You can also change the magnification of the drawing relative to its current 
magnification by adding an x after the magnification scale factor. For example, if you 
type a scale factor of 2x, the drawing changes to twice its current size. If you type a 
magnification factor of .5x, the drawing changes to half its current size.  

To zoom to a specific scale relative to the current display 

1. Do one of the following:  

 Choose View > Zoom > In.  

 On the View toolbar, click the Zoom In tool (  ).  

 Type zoom and then press Enter. 

2. Type the scale factor, followed by an x (such as 2x). 

3. Press Enter.  

Combining zooming and panning 

You can specify the point you want at the center of the view when you change the 
drawing magnification. You can specify the point you want at the lower left of the view 

when you change the magnification of the drawing with the Zoom Left tool (  ) on the 
View toolbar. With the exception of the Zoom Window tool, the other zoom tools zoom 
in or out from the center of the current view. 

To change the center of the current view 

1. Do one of the following:  

 Choose View > Zoom > Center.  

 On the Zoom toolbar, click the Zoom Center tool (  ). 

 Type zoom, press Enter, and then in the prompt box, choose Center. 

2. Select the point you want located at the center of the new view.  

3. Specify the zoom scale factor or the height of the drawing in drawing units. 
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Current view showing the point to be centered in the new view (A), and the new view zoomed 
using a scale factor of 2x.  

Displaying the entire drawing  

You can use the Zoom All tool (  ) on the View toolbar to display an entire drawing. If 
you have drawn any entities outside the defined limits of the drawing, the extents of the 
drawing are displayed. If you drew all entities within the limits of the drawing, the 
drawing is displayed all the way to the drawing limits. 

The Zoom Extents tool (  ) on the View toolbar displays the drawing to its extents, 
making the image fill the display to the greatest possible magnification.  

 

Zoom extents (displays all entities). - Zoom all (displays to drawing limits).  

2.7.4 Displaying multiple views  

When you begin a new drawing, it is displayed in a single window. You can view the 
drawing in a second window, or you can divide one window into multiple windows. You 
can also open and display multiple drawings.  

 

2.8 Working with blocks, attributes, and 
external references  
Blocks, attributes, and external references provide mechanisms for managing entities 
in your drawings and for including additional information with the standard drawing 
entities. With blocks, you can combine numerous entities into a single entity, and then 
reuse it, inserting multiple copies. With attributes, you can associate text, such as part 
numbers or prices, with blocks, and then extract the text-attribute information to a 
separate file, such as a database, for further analysis. With external references, you 
can link separate reference drawing files to a drawing to combine information without 
adding the contents of the reference drawings to the current drawing. If you make 
changes to the referenced file, all references are updated automatically.  

Within the user’s guide there are detailed explanations about how to:  

- Create, insert, and redefine blocks.  
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- Create, edit, and insert attributes.  

- Extract attribute data to a separate file.  

- Attach and work with external references.  

 

2.9 Drawing in three dimensions 
Paper drawings typically represent two-dimensional views of three-dimensional 
objects. With the program you can create three-dimensional models of three-
dimensional objects.  

This section explains how to:  

 View entities in three dimensions.  

 Create three-dimensional entities.  

 Edit entities in three-dimensional space.  

 Edit three-dimensional solids.  

 Display hidden-line and shaded views of three-dimensional entities.  

 

2.10 Printing 
The printing of a drawing to a printer or a plotter, or even to a file is accomplished 
through the PRINT (or PLOT) command, either clicking on the command located at the 
“FILE” group of commands, or through the command line, given that a drawing has 
been already loaded. More details about the printing procedure and the related options 
are given in the next paragraph. 

Formatting and printing drawings 

You can print a copy of your drawing exactly as you created it, or you can add 
formatting and specify print controls to change how your drawing looks when it is 
printed.  

Sometimes you may require multiple printed drawings, each with a different look or 
layout. For example, you may need one printed drawing for a client presentation, along 
with several other variations for production contractors. For each type of printed 
drawing that you require, you can create a layout that defines its characteristics, 
including scale, area to print, pen widths, and more.  

This section explains how to:  

 Set up a drawing to print from model space on the Model tab.  

 Set up a drawing to print multiple layouts from paper space on a Layout tab.  

 Define how you want your drawing to look when it is printed.  

 Print or plot your drawing.  

Understanding paper space and model space  

When you start a drawing session, your initial working area is called model space.  
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Model space is an area in which you create two-dimensional and three-dimensional 
entities based on either the World Coordinate System (WCS) or a user coordinate 
system (UCS). You view and work in model space while using the Model tab.  

Your view of this area is a single viewport that fills the screen. You can create 
additional views on the Model tab, called viewports, which can show the same or 
different two-dimensional or three-dimensional views, all of which are displayed in a 
tiled manner. You can work in only one of these viewports at a time on the Model tab, 
and you can print only the current viewport.  

 

Model space with two viewports.  

4MCAD provides an additional work area, called paper space. The contents of paper 
space represent the paper layout of your drawing. In this work area, you can create 
and arrange different views of your model similar to the way you arrange detail 
drawings or orthogonal views of a model on a sheet of paper. You can also add 
keynotes, annotations, borders, title blocks, and other print-related entities in paper 
space, which reduces clutter when you work with your model in model space.   

You view and work in paper space while using a Layout tab. Each view, or layout 
viewport, that you create in paper space provides a window of your drawing in model 
space. You can create one layout viewport or several. You can place layout viewports 
anywhere on the screen; their edges can be touching or not; and you can print them all 
at the same time. You do not need to use paper space to print your drawing, but it 
offers several advantages:  

 Print the same drawing with different print settings that you save with each 
layout, for example, pen widths, printer configuration files, lineweight settings, 
drawing scale, and more.  

 Add print-related entities that are not essential to the model itself, such as 
keynotes or annotations, to reduce clutter when you work with your model in 
model space on the Model tab.  

 For a single layout, create multiple layout viewports that print the model at 
different views and scales. 
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Paper space with layout viewports.  

Viewing drawings in paper space and model space  

When you work in paper space on a Layout tab, you can still view your drawing in 
model space. First you need to create a layout viewport in paper space; this allows you 
to view your model space entities from paper space.  

Within a layout viewport you can modify the model space entities, but it is often more 
convenient to modify these entities on the Model tab.  

Zooming or panning the drawing in model space or paper space affects the entire 
drawing, unless you use multiple windows or viewports.  

To view a drawing in model space using the Model tab  

 Click the Model tab.  

To view a drawing in paper space using a Layout tab 

Do one of the following: 

 Click one of the Layout tabs.  

 Type layout and then press Enter. In the prompt box, choose Set. Type a name 
for the layout you want to make current, and then press Enter.  

The first time you switch to a Layout tab, your drawing seems to disappear. This is 
normal. You must create at least one layout viewport to see your work. 

To view your drawing in model space using a Layout tab 

1. Click the desired Layout tab. 

2. Create and view a layout viewport. 

Creating a new layout  

In 4MCAD, you can create multiple layouts for a single drawing. Each layout 
represents a sheet of paper. For each layout you can specify the print area, print scale, 
lineweight scale, pen mappings, and add viewports, dimensions, a title block, and other 
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geometry specific to the layout. The entities you add to a layout in paper space do not 
appear in model space.  

Each layout requires at least one layout viewport. This viewport displays the drawing’s 
model space entities.  

When you create a new drawing, the drawing automatically contains two default 
layouts: Layout1 and Layout2. You can start by using one of the default layouts, you 
can create your own, or your can create a new layout from another template (.dwt) file, 
drawing (.dwg) file, or drawing interchange (.dxf) file.  

Each drawing can contain up to 255 layouts.  

To create a new layout using the Layout1 or Layout2 tab 

1. Click the Layout1 or Layout2 tab.  

2. Set up at least one layout viewport. For details, see “Working with layout 
viewports”. 

3. If desired, rename the layout. For details, see “To rename a layout”. 

To create a new layout using a new Layout tab 

1. Do one of the following:  

Choose Insert > Layout > New Layout.  

Type layout, press Enter, and choose New.  

2. Type a unique name for your layout and then press Enter.  

The name can be up to 255 characters in length and can contain letters, numbers, 
the dollar sign ($), hyphen (-), and underscore (_), or any combination.  

3. Set up at least one layout viewport. For details, see “Working with layout view
 ports”.  

To create a new layout from an existing file 

1. Do one of the following:  

Choose Insert > Layout > Layout from Template.  

Type layout, press Enter, and choose Template.  

2. Select the desired template, drawing, or drawing interchange file that contains the 
layout you want, and then click Open. 

3. Select the layout(s), and then click OK. You can choose multiple layouts by holding 
down Ctrl while selecting layout names. 

Reusing layouts from other files  

Save time by re-using layouts that you have already created. Within the same drawing, 
you may want to make a copy of a layout that contains most of the settings you want, 
and then make changes to the new copy. If you created layouts that you want to use 
again when you create new drawings, you can save the layouts as a drawing template. 
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To make a copy of a layout 

1. Type layout and then press Enter. 

2. In the prompt box, choose Copy. 

3. Type the name of the layout you want to copy, and then press Enter. 

4. Type a name for the new layout, and then press Enter. 

To save a layout as a drawing template 

1. Type layout and then press Enter. 

2. In the prompt box, choose Save. 

3. Type the name of the layout that you want to save, and then press Enter. 

4. Specify the file name and location for the template, and then click Save. 

After you save a layout as a template, you can use the template when you create new 
drawings. You can also import the template’s layouts into another drawing. 

Managing layouts in a drawing  

You can rename layouts, delete layouts, and view a list of all layouts available in a 
drawing. 

To rename a layout 

1. Right-click the Layout tab to rename. 

2. Type a new name for the layout. 

3. Click OK. 

The name can be up to 255 characters in length and can contain letters, numbers, the 
dollar sign ($), hyphen (-), and underscore (_), or any combination. 

To delete a layout 

1. Right-click the Layout tab to delete. 

2. Click OK to confirm the deletion. 

NOTE You cannot delete the Model tab or the last remaining Layout tab. To delete all 
geometry from the Model tab or a Layout tab, first select all geometry and then use the 
Erase command.  

To view a list of all layouts 

1. Type layout and then press Enter. 

2. In the prompt box, choose ? to list all layouts. 

3. Type s or press Enter to scroll through the layouts. 
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Working with layout viewports  

When you begin working in a drawing on the Model tab, it consists of a single view of 
your model. You may have created additional views by dividing the drawing space into 
multiple windows; each window is a separate viewport on the Model tab.  

On a Layout tab, you must create at least one layout viewport to see your model. 
However, you can create multiple layout viewports that display unique views of your 
model located in model space. Each layout viewport functions as a window into your 
model space drawing. You can separately control the view, scale, and contents of each 
layout viewport. Each layout viewport is created as a separate entity that you can 
move, copy, or delete.  

Click any layout viewport to make it the current viewport, and then add or modify model 
space entities in that viewport. Any changes you make in one layout viewport are 
immediately visible in the other viewports (if the other layout viewports are displaying 
that portion of the drawing). Zooming or panning in the current viewport affects only 
that viewport.  

This section focusses on working with layout viewports in paper space on a Layout tab. 
For additional information about viewports in model space, see “Dividing the current 
window into multiple views”.  

Creating layout viewports  

The first time you switch to a Layout tab, all of your model space entities disappear. 
You must create at least one layout viewport on the Layout tab to see your work.  

You can create layout viewports anywhere inside the drawing area. You can control the 
number of viewports created and the arrangement of the viewports.  

To create layout viewports 

1. Do one of the following:  

Choose View > Floating Viewports > 1,2,3, or 4 Viewports 

Type mview and then press Enter. 

2. In the prompt box, choose the viewport orientation. 

3. Do one of the following:  

 To arrange the viewports to fill the current graphic area, in the prompt box, 
choose Fit To Screen.  

 To fit the viewports within a bounding rectangle, specify the corners of a 
rectangle.  

TIP When you create a layout viewport, the layout viewport border is created on the 
current layer. You can make layout viewport borders invisible by creating a new layer 
before you create layout viewports and then turning off that layer after you create the 
layout viewports. To select a layout viewport’s borders, you must turn that layer back 
on before you can rearrange or modify the layout viewport.  
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You can create a single layout viewport, or you can divide the graphic area into two viewports 
arrangedvertically (A) or horizontally (B); three viewports arranged left (C), right (D), above 

(E),below (F), vertically (G), or horizontally (H); or four viewports (I). 

Viewing and scaling layout viewports  

If you have created numerous layout viewports, your system performance may be 
affected. If necessary, you can turn a layout viewport on or off. Turning off a layout 
viewport does not delete the viewport or its contents; it simply turns off its display.  

You can also change how you view items within a layout viewport by specifying a scale 
factor, which changes how large or small model space entities appear within the layout 
viewport.  

To turn layout viewports on or off 

1. Click the desired Layout tab.  

2. Do one of the following:  

Choose View > Floating Viewports > Viewports On or Viewports Off. 

Type mview and then press Enter. 

3. Select the edge of the layout viewport to turn on or off, and then press Enter.  

To change the scale of model space entities relative to paper space 

 
1. Click the Model tab. 

2. Click a viewport to make it current. 

3. Choose View > Zoom > Scale. 

4. Type the zoom scale factor relative to paper space by appending the suffix xp to 
the scale factor, and then press Enter. 

For example, to increase the scale of the entities in the viewport on the Model tab 
to twice the size of paper space units, type 2xp. To decrease the scale to half the 
size of paper space units, type .5xp. 

Modifying layout viewports  

After you create layout viewports, you can modify them as needed. On the Layout tab, 
you can snap to the viewport borders using entity snap. You can also copy, delete, 
move, scale, and stretch layout viewports as you would any other drawing entity.  
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Modifying a layout viewport on a Layout tab does not affect the model space entities 
within the layout viewport.  

To modify layout viewport properties 

1. Click the desired Layout tab. 

2. Do one of the following: 

Choose Modify > Properties. 

On the Properties toolbar, click the Properties tool (  ). 

Type _ai_propchk and then press Enter. 

3. Select the edge of the layout viewport you want to modify. 

4. Adjust the center point, width, or height of the viewport. 

5. In Scale, enter the scale at which you want to view model space entities from within 
the layout viewport. 

6. Mark Lock Viewport to lock the viewport scale and view in model space while 
panning or zooming in the layout viewport. 

7. Mark UCS per Viewport if you want to use a unique UCS for each layout viewport. 

8. Click OK. 

NOTE: You can only select layout viewports for modification. If you click a viewport on 
the Model tab, it makes that viewport active, not available for modification.  
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A. Enter the center point of the layout viewport. 

B. Enter the height of the layout viewport. 

C. Enter the width of the layout viewport. 

D. Enter the scale used for viewing model space entities from within the layout viewport. 

E. Select ‘’Yes’’ or ‘’No’’ to use a unique UCS for each layout viewport. 

F. Select ‘’Yes’’ or ‘’No’’ to lock the viewport scale and view in model space while panning or 
zooming in the layout viewport. 

Customizing print Options 

Before you print, you can set up many aspects of printing. The following print settings 
are set globally for all drawings:  

 Specify paper size and orientation.  

 Select and configure a printer or plotting device.  

 Specify the view and scale of a printed drawing, including which portion of a 
drawing to print, the print scale, and the origin of the print area.  

 Choose whether to print and scale lineweights.  



 

 

82  4M 

 Choose whether to implement print style tables to control colors, pen widths, 
line-types, and lineweights. 

 Open printer configuration (PCP) files; create and save PCP files.  

Setting the paper size and orientation 

You can specify a paper size and paper orientation for all drawings.  

To select the paper size and orientation 

1. Do one of the following:  

Choose File > Plot Setup  

On the Standard toolbar, click the Print tool ( ). 

Type psetup, print or plot and then press Enter.  

2. Select the paper size and paper orientation, and then click OK. 

You can also adjust the orientation by printing a drawing upside down on the paper. 

Each layout in your drawing can specify whether to print upside down. 

Selecting a printer or plotter 

You can specify a printer or plotter to be used when printing any drawing. You can 
print your drawing on any printer or plotter that is compatible with Windows, including 
raster printers.  

To select a printer or plotter 

1. Do one of the following:  

Choose File > Plot Setup  

On the Standard toolbar, click the Print tool ( ).  

Type psetup, print or plot and press Enter  

2. From the Printer/Plotter Name list, select a printer or plotter, and then click OK.  

Setting the scale and view  

You can print or plot the entire drawing or a selected portion, depending on which 
options you select in the Print dialog box. You can choose to print what is visible on the 
screen, or you can specify to print an area of the drawing.  

You can control the position of the drawing on the paper by specifying the origin of the 
print area, the location of the lower left corner of the print area, in relation to the lower 
left corner of the paper. The origin is normally set to 0,0, which places the lower left 
corner of the print area as close to the lower left corner of the paper as the printer or 
plotter will allow. You can specify a different origin, however, by specifying different 
coordinates.  

When you create a drawing, you generally draw entities full-size. When you print the 
drawing, you can specify the scale of the resulting print or let the program adjust the 
size of the drawing to fit the paper. To print the drawing at a specific scale, specify the 
scale as a ratio of drawing units to printed units.  

If you are printing from a Layout tab, the scale and view options you specify can be 
different for each layout that you create.  

To automatically scale the drawing for printing 
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If necessary, click the desired Layout tab or the Model tab. 

Do one of the following: 

Choose File > Plot Setup  

On the Standard toolbar, click the Print tool ( ).  

Type psetup, print or plot and press Enter  

To scale the drawing to fit on one printed page, in Plot Scale, select Fit to paper. 

Select Save Changes to layout, and then click Apply to Layout to save your changes. 

To specify the scale factor yourself 

1. If necessary, click the desired Layout tab or the Model tab. 

2. Do one of the following: 

Choose File > Plot Setup  

On the Standard toolbar, click the Print tool ( ).  

Type psetup, print or plot and press Enter  
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3. In Plot Scale, do one of the following: 

Select a pre-defined scale. For example, choose 1:2 if you want 1 printed unit (inch 
or millimeter) to equal 2 drawing units.  

Select Custom, and then type the ratio of printed units of measure (inches or 
millimeters) to drawing units.  

4. To specify the printed units of measure, click Inches (inch) or Millimeters (mm). 

5. Select Save Changes to layout, and then click Apply to Layout to save your 
changes. 

NOTE 4MCAD saves your print settings each time you print.  

To specify a portion of the drawing to print  

1. If necessary, click the desired Layout tab or the Model tab. 

2. Do one of the following: 

 Choose File > Plot Setup  

 On the Standard toolbar, click the Print tool ( ).  

 Type psetup, print or plot and press Enter  

3. Under Plot Area, select one of the following: 

Display - prints the view on the screen.  

Limits - prints to the limits defined for the layout or drawing.  

Window - prints the portion of the drawing contained in the specified window, 
maintaining the aspect ratio of the windowed area to the drawing.  

If you selected Window, you must specify the window. Select the area on the 
screen.  

4. Click Apply to Layout to save your changes.  
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A. Displays either “Model” or the layout name to which the print settings apply. 

B. Click to select the area of the drawing that you want to print. 

C. Select to specify coordinates in the drawing window. 
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D. Specify the custom scale for the print area by typing the ratio of drawing units to printed 
inches or printed millimeters. (Available only if Custom is selected for Print Scale.) or check Fit to 
paper.  

E. Select to save the print settings for the model or layout.  

F. Select to define the shaded viewport options. 

To specify the print area origin 

If necessary, click the desired Layout tab or the Model tab. 

Do one of the following: 

 Choose File > Plot Setup  

 On the Standard toolbar, click the Print tool ( ).  

 Type psetup, print or plot and press Enter  

Under Plot Offset, do one of the following: 

To center the specified print area on the printed page, select the Center to Plot 
check box.  

To specify an origin for the print area, type the x- and y-coordinates.  

Select Save Changes to Layout, and then click Apply to Layout to save your changes. 

Choosing how lineweights print 

If entities are assigned lineweights, you can control whether they print with the 
assigned lineweights. If you turn off lineweight printing, entities print with a default 
outline. You can also control whether lineweights print in proportion to the scale you 
set.  

Each layout in your drawing can specify whether to print and scale lineweights.  

To set lineweight options 

If necessary, click the desired Layout tab or the Model tab. 

Do one of the following: 

Choose File > Plot Setup  

On the Standard toolbar, click the Print tool ( ).  

Type psetup, print or plot and press Enter  

Choose how you want to print lineweights: 

Print entity lineweights - prints entities with their assigned lineweights, 

Scale Lineweights - Prints entities with their assigned print styles and lineweights 
defined in the currently selected print style table. 

Click Apply to Layout to save your changes.  
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A. Select to center the print area on the page.  

B. Type x- and y-coordinates to specify the origin of the print area. 

C. Select to print entities using plot styles. 

D. Select to print entities with their assigned lineweights. 

E. Select a print style table. 

F. Click to make changes to the selected print style table. 

G. Select to print lineweights in proportion to the scale you set. (A Layout tab must be active.) 

Using print styles 

4MCAD uses print styles to change the appearance of your printed drawing without 
modifying the actual entities in your drawing. Assigning print styles allows you to 
customize the color, pen width, linetype, and lineweight that are used to print your 
drawing.  

Print styles help you control what your drawing looks like when it is printed. Rather 
than describe what an entity looks like on your screen, print styles describe what an 
entity will look like when you print it. For example, you can map all yellow entities in 
your drawing to print in blue without modifying the actual entities. You could also map 
all yellow entities to print with whatever lineweight, linetype, or pen width that you 
specify.  

Because print styles are saved in print style tables, which are files located on your 
computer, disk, or server, you can reuse them to help eliminate the need to 
reconfigure your print settings each time you print a drawing. For example, you may 
have multiple clients who have their own printing preferences. You can save print 
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styles in a named file for each of your clients. You can even share the file with co-
workers, or store the files on a network to ensure that everyone in your office uses the 
same standards.  

Assigning print style tables 

Select a print style table before printing if you want to change how your drawing 
appears when you print it. Print style tables can modify how colors, pen widths, line-
types, and lineweights look when they are printed. 

You can assign print style tables globally for all layouts (including the Model tab), or 
individually for the Model tab or a Layout tab. Assigning a print style table to an 
individual layout allows you to further customize the layouts you use to print a drawing. 

However, assigning different named print style tables to various layouts may result in 
mismatched print style names; a named print style assigned to an entity or layer may 
not be located in the assigned print style table at print time. In this case, entities are 
printed using their default properties, which is similar to assigning the Normal print 
style to an entity or layer. 

To assign print style tables 

If necessary, click the desired Layout tab, or click the Model tab. 

Do one of the following: 

 Choose File > Plot Setup  

 On the Standard toolbar, click the Print tool ( ).  

 Type psetup, print or plot and press Enter  

Under Plot Style Table (pen assignments), select a print style table that you created or 
one of the following: 

None - Applies no print style table. Entities print according to their own properties.  

4mcad - Uses the default print style table and its color assignments.  

Monochrome - Prints all colors as black.  

At the prompt, choose Yes to assign the print style table to all layouts in the drawing, 
including the Model tab, or choose No to assign the print style table only to the 
individual layout listed in Layout Name on the Print dialog box.  

Select Save Changes to layout, and then click Apply to Layout to save your changes.  

NOTE When your drawing was first created it was set up to use either color-dependent 
or named print style tables. For details on converting a drawing to use a different type 
of print style table, see “Understanding print style tables”. 

Creating new print style tables 

4MCAD offers several print style tables to help you get started. If you want to 
customize your print output further, you can create your own print style table. You can 

create a new print style table entirely from scratch, based on 4MCAD registry settings, 
or by importing a printer configuration file (PCP file).  

To create new print style tables 

Do one of the following: 

Choose File > Print Styles Manager… 

Type stylesmanager and then press Enter. 
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Double-click Create a Print Style Table. 

Complete the setup wizard. 

On the last wizard page, you can click Print Style Table Editor to set up the print styles 
for the table. For more details about the Print Style Table Editor options, see the next 
section. 

Modifying print style tables 

When your drawing was created, it was set up to use color-dependent or named print 
style tables. 

Color-dependent print style tables (.ctb files) You can modify individual print styles 
within the table, but you cannot add, rename, or delete print styles. Color-dependent 
print style tables always have 255 print styles, each named for a specific color. Your 
changes affect all entities and layers assigned that color.  

Named print style tables (.stb files) You can add, modify, rename, and delete 
individual print styles within the table. However, you cannot modify, rename, or delete 
the Normal print style. Your changes affect all entities and layers that are assigned that 
print style name.  

TIP If you can’t remember what type of print style table is assigned to your drawing, 
use the PSTYLEMODE system variable to determine the print style table type.  

Each print style within a print style table specifies a color, pen numbers, linetype, and 

lineweight. 4MCAD recognizes additional characteristics for compatibility with 
AutoCAD only, including: dither, grayscale, screening, adaptive, line end style, line join 
style, and fill style.  

When specifying print style characteristics, be sure to consider the limitations of your 
output device.  

NOTE It is recommended that you only modify print style tables that you have created. 

If you modify a default print style table that came with 4MCAD, you overwrite the 
original information which is then lost.  

To modify print style tables 

1. Do one of the following: 

Choose File > Print Styles Manager.. 

Type stylesmanager and then press Enter. 

2. Double-click the print style table you want to modify. 

3. Click the General tab, and then do any of the following: 

Enter a new table description.  

Select Apply Global Scale Factor to Non-ISO Linetypes to apply the scale factor to 
non-ISO linetypes used for any print style in the current print style table. This 

also applies to fill patterns, which are not used in 4MCAD, but are recognized 
for compatibility with AutoCAD.  

Enter a scale factor to apply to non-ISO linetypes used for any print style in the 
current print style table. 

4. Click the Properties tab, and then do any of the following: 
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Make format changes to a print style by selecting it in the Print Styles list, then 
make color, pen map, linetype, or lineweight changes for the print style. Your 
changes are saved automatically for the selected print style.  

Add a new print style by clicking Add Style. Enter a new name, and then click OK. 
Select the options for the print style. (Available for named print styles only.)  

Rename a print style by selecting it in the Print Styles list. Single-click the print style 
again, and then enter a new name. (Available for named print styles only.)  

Delete a print style by selecting it in the Print Styles list. Click Delete Style. 
(Available for named print styles only.)  

5. Click OK. 
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A. Select a print style to modify it. 

B. Enter a description for the selected print style. 

C. Click to create a new print style. (Named print style tables only.) 

D. Click to delete the selected print style. (Named print style tables only.) 

E. Click to modify the list of available lineweights for the current print style table. 

F. Click to save the print style table with a new name or in a new location.  

G. Choose a lineweight for the selected print style. 

H. Choose a linetype for the selected print style. 

I. Type or scroll to the width of the virtual pen for the selected print style (for printers that don’t 
have physical pens, such as laser or inkjet printers). 

J. Type or scroll to the width of the physical pen for the selected print style. 

K. Choose a color for the selected print style. 

Printing or plotting your drawing  

After you have configured your drawing and any layouts for printing, you are ready to 
print. If desired, you can preview your page before printing.  
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Previewing a drawing before printing  

Viewing a drawing before printing gives you a preview of what your drawing will look 
like when it is printed. This helps you see if there are any changes you want to make 
before actually printing the drawing. 

To preview a drawing before printing 

If necessary, click the desired Layout tab or the Model tab. 

Do one of the following: 

Choose File > Plot Preview  

On the Standard toolbar, click the Print Preview tool ( ).  

Type ppreview and then press Enter.  

After checking the preview image, do one of the following:  

To print the drawing, click Print Settings to display the Print dialog box.  

To return to the drawing, click Close. 

 

A. Click to zoom in. 

B. Click to zoom out. If you have zoomed in several times, click multiple times to restore  

C. Click to print the drawing. 

D. Click to close the preview. 

Printing a drawing  

The Print dialog box is organized by tabs into two functional areas: scaling and 
viewing, and advanced printing options. The print setting options available under each 
tab were described in the previous sections.  

NOTE You cannot print a rendered image directly to a printer. To print a rendered 
image, you must first save the drawing to a different format and then print it from 
another graphics program.  
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To print a drawing 

1. If necessary, click the desired Layout tab or the Model tab. 

2. Do one of the following: 

Choose File > Plot.  

On the Standard toolbar, click the Print tool ( ). 

If you click the Print tool, the Print dialog box does not display. Your drawing 

Type print and press Enter. 

3. From the Print dialog box, make any adjustments to the settings. 

4. Click Print. 

NOTE Instead of using the print settings you saved with your layout, you can select 
Previous Print in the Use Settings list to print according to the settings used the last 

time you printed. If necessary, you can click Reset to restore the 4MCAD default print 
settings. 


